openPASS - Developer Documentation: openPASS Developer Documentation

openPASS - Developer Documentation
  • Main Page
  • Modules
  • Classes
openPASS Developer Documentation

Table of Contents

  • Introduction
  • Glossary and Abbreviations
  • Legal Notes

Introduction

The openPASS tool is intended for the simulation of interaction between traffic participants to evaluate active safety systems. A simulation is based on a specific situation configuration and can contain several simulation runs (=situations) which differ due to random parameters.
This documentation is focused on modules and components for scenario based simulations as well as simulating PCM cases.

Configuration of a PCM Simulation

Glossary and Abbreviations

Abbreviation | Description
openPASS | Framework for the Simulative Evaluation of Active Safety Systems in Vehicles.
ADAS | Advanced Driver Assistance System
Agent | An arbitrary static or dynamic object in the simulation of a traffic situation. Therefore, it might (but does not have to) be a traffic participant.
Component | A module that is part of an agent´s equipment.
Equipment | A set of models determining an agent´s behavior.
Model | An abstract representation of a real object which might omit details e.g. ADAS, driving dynamics, pedestrian, environmental conditions. In the openPASS framework, a model consists of one or more modules as well as channels connecting them.
Module | A dynamic library that is loaded and whose interface functions are called by the framework. Modules contain models or other individual functionality necessary for the simulation. Modules are exchangeable and can be fitted to various purposes ensuring ahigh flexibility of the framework.
PCM | Post Crash Matrix
Scenario | A set of similar traffic situations.
Situation | A unique variation of a traffic scenario that is described unambiguously by its spatial (e.g. road network), temporal (time, date, duration) as well as participant (e.g. starting points and intended trajectories, behaviour of people and ADAS) set up.

Legal Notes

Please note that the descriptions used in this document, as well as brand and product name are the property of their respective owners and are protected by patent, trademark rights and copyrights.

All information herein has been carefully controlled. ITK Engineering GmbH cannot be held liable for damages resulting from the use of this document and does not guarantee accuracy, correctness, completeness and currentness of the information.

Copyright
© This Example Content is intended to demonstrate usage of Eclipse technology. It is provided to you under the terms and conditions of the Eclipse Distribution License v1.0 which is available at http://www.eclipse.org/org/documents/edl-v10.php
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Modules

  • Classes
Modules
Here is a list of all modules:
[detail level 12]
Event |
▼ openPASS components basic |
Action_BrakeLight_Basic | Sets the brake light
Algorithm_CruiseControlByDistance | Models the lateral controller of the driver
Dynamics_Longitudinal_Basic | Calculate the next velocity and position of the agent in the next timestep based on the acceleration in longitudinal direction
Sensor_Distance | Basic module to sense the current state of an agent
Action_LongitudinalDriver | Sets the longitudinal values
Action_SecondaryDriverTasks | Controls secondary driver tasks
Agent_Updater | This module gets the final values for the dynamic parameters of the agent and updates the agent accordingly
Algorithm_AEB | This module represents a simple autonomous emergency braking system (AEB)
Algorithm_Lateral | Models the lateral controller of the driver
Algorithm_Longitudinal | Models the longitudinal controller of the driver
ComponentController | This module
Dynamics_Collision | This modules calculates all dynaimcs of the agent in case of a collision
Dynamics_CollisionPostCrash | Collision component that calculates post-crash dynamics
Dynamics_RegularDriving | Models the longitudinal and lateral dynamics of the vehicle coresponding to the pedal and steering inputs
Dynamics_RegularTwoTrack | Dynamic component to model the dynamic of a two track vehicle
Dynamics_TrajectoryFollower | Makes an agent strictly follow a predefined path
LimiterAccelerationVehicleComponents | Limits the acceleration output from all vehicle components
Parameters_Vehicle | Defines and distributes parameters (constants and stochasitc variables) for all components of an agent
Sensor_Driver | Collect and distribute Data from the WorldInterface and AgentInterface concerning the own vehicle, traffic rule information, lane geometry and surrounding objects
SensorObjectDetector | This file models the SensorObjectDetectors
SensorFusion | This file models the SensorFusion
SignalPrioritizer | Collects signals of same kind and relays the one with highest priority
OpenPassMaster |
EventNetwork |
EventDetector | This file contains the basic EventDetector functionality
Manipulator | This file contains the basic Manipulator functionality
▼ openPASS CoreModules basic |
Observation_State | Logs the current X position of every agent at each time step
Observation_Ttc | Logs the time to collision (ttc) of all agents
SpawnPoint_Start | Spawn agents at the beginning of road
World_Basic | Implementation of a world interface
SpawnPoint | This SpawnPointPreRunCommon populates the current World with Common Agents
Stochastics | Implementation of StochasticsInterface
World | Implementation of a world interface
OpenPassSlave |
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Event

Files | Classes
Event

Files

file basicEvent.h
This file contains all basic functionality of events.

Classes

class | BasicEvent< EventCategory >
class | ComponentStateChangeEvent
class | LaneChangeEvent
class | SpeedActionEvent
class | TrajectoryEvent

Detailed Description

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: BasicEvent< EventCategory > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • openpass
  • events
  • BasicEvent
List of all members
BasicEvent< EventCategory > Class Template Reference
Event
Inheritance diagram for BasicEvent< EventCategory >:
[legend]
Collaboration diagram for BasicEvent< EventCategory >:
[legend]

Detailed Description

template<EventDefinitions::EventCategory EventCategory>
class openpass::events::BasicEvent< EventCategory >

Signal This class contains all functionality of the BasicEvent.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ComponentStateChangeEvent Class Reference

  • Class Hierarchy
  • Class Members
  • openpass
  • events
  • ComponentStateChangeEvent
List of all members
ComponentStateChangeEvent Class Reference
Event
Inheritance diagram for ComponentStateChangeEvent:
[legend]
Collaboration diagram for ComponentStateChangeEvent:
[legend]

Detailed Description

This class hold information about a Component State Change Event

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneChangeEvent Class Reference

  • openpass
  • events
  • LaneChangeEvent
List of all members
LaneChangeEvent Class Reference
Event
Inheritance diagram for LaneChangeEvent:
[legend]
Collaboration diagram for LaneChangeEvent:
[legend]

Detailed Description

This class implements all functionality of the LaneChangeEvent.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpeedActionEvent Class Reference

  • openpass
  • events
  • SpeedActionEvent
List of all members
SpeedActionEvent Class Reference
Event
Inheritance diagram for SpeedActionEvent:
[legend]
Collaboration diagram for SpeedActionEvent:
[legend]

Detailed Description

This class implements all functionality of the SpeedActionEvent.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TrajectoryEvent Class Reference

  • openpass
  • events
  • TrajectoryEvent
List of all members
TrajectoryEvent Class Reference
Event
Inheritance diagram for TrajectoryEvent:
[legend]
Collaboration diagram for TrajectoryEvent:
[legend]

Detailed Description

This class implements all functionality of the Trajectory Event.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: openPASS components basic

Modules
openPASS components basic
Collaboration diagram for openPASS components basic:

Modules

Action_BrakeLight_Basic
sets the brake light
Algorithm_CruiseControlByDistance
models the lateral controller of the driver
Dynamics_Longitudinal_Basic
Calculate the next velocity and position of the agent in the next timestep based on the acceleration in longitudinal direction.
Sensor_Distance
basic module to sense the current state of an agent

Detailed Description

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Action_BrakeLight_Basic

Classes
Action_BrakeLight_Basic
openPASS components basic

sets the brake light More...

Collaboration diagram for Action_BrakeLight_Basic:

Classes

class Action_BrakeLight_Basic_Implementation
sets the brake light More...

Detailed Description

sets the brake light

This component sets the brake light to on if the acceleration of the vehicle is negative and lower the coasting deceleration.

Inputs

Input variables:

name | meaning
in_aVehicle | The acceleration of the agent in m/s^2.
in_aCoasting | The deceleration caused by the air.

Input channel IDs:

Input ID | signal class | contained variables
0 | double | in_aVehicle
1 | double | in_aCoasting

Init Inputs

none

Outputs

none

External parameters

none

Internal paramters

none

Parameters to be specified in agentConfiguration.xml

none

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Action_BrakeLight_Basic_Implementation Class Reference

Public Member Functions | Private Attributes | List of all members
Action_BrakeLight_Basic_Implementation Class Reference
openPASS components basic » Action_BrakeLight_Basic

sets the brake light More...

Inheritance diagram for Action_BrakeLight_Basic_Implementation:
[legend]
Collaboration diagram for Action_BrakeLight_Basic_Implementation:
[legend]

Public Member Functions

virtual void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
virtual void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
virtual void | Trigger (int time)
Process data within component. More...

Private Attributes

double | in_aVehicle = 0
The acceleration of the agent in m/s^2.
double | in_aCoasting = 0
The brake acceleration that is assumed to happen if no pedal is pressed due to air drag in m/s^2.

Detailed Description

sets the brake light

This class sets the brake light to on if the acceleration of the vehicle is negative and lower the coasting deceleration.

Member Function Documentation

virtual void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
virtual void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update outputs.

Function is called by framework when this component has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
virtual void Trigger ( int time )
virtual

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component.

Refer to module description for information about the module's task.

Parameters
[in] time Current scheduling time
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Algorithm_CruiseControlByDistance

Classes
Algorithm_CruiseControlByDistance
openPASS components basic

models the lateral controller of the driver More...

Collaboration diagram for Algorithm_CruiseControlByDistance:

Classes

class Algorithm_CruiseControlByDistance_Implementation
models the lateral controller of the driver More...

External Parameters

double | Par_desiredVelocity = 0
Desired velocity in m/s.
double | Par_reactionTime = 0
The reaction time of the driver.

Internal Parameters

double | _standardCycleTimeSecond = 0.1
standard cycle time for spawning, update, trigger tasks (in s)
double | _cw = 0.5
air drag coefficient
double | _airDensity = 1.2
air density at 20°C
double | _carHeight = 1.5
height
double | _carWidth = 1.8
width
double | _carWeight = 1300
weight
double | _airDragCoefficent = 0
Coefficent of car and enviromental constants to calculate the acceleration depending on current the velocity of the car.
double | _accelerationMax = 3
maximal plausilbe acceleration [m/s^2]
double | accelerationMin = -15
maximal plausible deceleration [m/s^2]

Detailed Description

models the lateral controller of the driver

This component models the lateral controller of the driver. It calculates a desired acceleration based on the desired velocity and a safety distance which is numerically half of the velocity (km/h) in m.

Inputs

Input variables:

name | meaning
in_distance2NextAgent | Distance to next agent in front.
in_velocity | Current velocity of agent.

Input channel IDs:

Input ID | signal class | contained variables
0 | DoubleSignal | in_distance2NextAgent
1 | DoubleSignal | in_velocity

Init Inputs

none

Outputs

Output variables:

name | meaning
out_desiredAcceleration | The desired acceleration based on the desired velocity and distance to next agent in front.
out_aCoasting | The deceleration caused by the air.

Output channel IDs:

Output Id | signal class | contained variables
0 | DoubleSignal | out_desiredAcceleration
1 | DoubleSignal | out_aCoasting

External parameters

name | value | meaning
Par_desiredVelocity | 20 | Desired velocity in m/s.
Par_reactionTime | 0.3 | The reaction time of the driver.

Internal paramters

name | value | meaning
_standardCycleTimeSecond | 0.1 | standard cycle time for spawning, update, trigger tasks (in s)
_cw | 0.5 | air drag coefficient
_airDensity | 1.2 | air density at 20°C
_carHeight | 1.5 | height
_carWidth | 1.8 | width
_carWeight | 1300 | weight
_airDragCoefficent | 0 | Coefficent of car and enviromental constants to calculate the acceleration depending on current the velocity of the car.
_accelerationMax | 3 | maximal plausilbe acceleration [m/s^2]
_decelerationMax | 15 | maximal plausible deceleration [m/s^2]

Parameters to be specified in agentConfiguration.xml

type | id | meaning | corresponding external paramter
double | 0 | a | Par_desiredVelocity
double | 1 | a | Par_reactionTime
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Algorithm_CruiseControlByDistance_Implementation Class Reference

Public Member Functions | Private Member Functions | Private Attributes | List of all members
Algorithm_CruiseControlByDistance_Implementation Class Reference
openPASS components basic » Algorithm_CruiseControlByDistance

models the lateral controller of the driver More...

Inheritance diagram for Algorithm_CruiseControlByDistance_Implementation:
[legend]
Collaboration diagram for Algorithm_CruiseControlByDistance_Implementation:
[legend]

Public Member Functions

void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
void | Trigger (int time)
Process data within component. More...

Private Member Functions

double PlausibleTestAcceleration (double desiredAcceleration)
Check an accelation for plausibility. More...

Private Attributes

double | in_distance2NextAgent = 0
Distance to next agent in front.
double | in_velocity = 0
Current velocity of agent.
double | out_desiredAcceleration = 0
The desired acceleration based on the desired velocity and distance to next agent in front.
double | out_aCoasting = 0
The brake acceleration that is assumed to happen if no pedal is pressed due to air drag in m/s^2.
double | previousDistance = 0
stores the distance of the previous time step
External Parameters
double | Par_desiredVelocity = 0
Desired velocity in m/s.
double | Par_reactionTime = 0
The reaction time of the driver.
Internal Parameters
double | _standardCycleTimeSecond = 0.1
standard cycle time for spawning, update, trigger tasks (in s)
double | _cw = 0.5
air drag coefficient
double | _airDensity = 1.2
air density at 20°C
double | _carHeight = 1.5
height
double | _carWidth = 1.8
width
double | _carWeight = 1300
weight
double | _airDragCoefficent = 0
Coefficent of car and enviromental constants to calculate the acceleration depending on current the velocity of the car.
double | _accelerationMax = 3
maximal plausilbe acceleration [m/s^2]
double | accelerationMin = -15
maximal plausible deceleration [m/s^2]

Detailed Description

models the lateral controller of the driver

This component models the lateral controller of the driver. It calculates a acceleration based on the desired velocity and a safety distance which is numerically half of the velocity (km/h) in m.

Member Function Documentation

void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |

Update outputs.

Function is called by framework when this component has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
void Trigger ( int time )

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component.

Refer to module description for information about the module's task.

Parameters
[in] time Current scheduling time
double PlausibleTestAcceleration ( double desiredAcceleration )
private

Check an accelation for plausibility.

Test a desired acceleration for plausibility and return _accelerationMax or _decelerationMax or the same acceleration if it is in range of them.

Parameters
[in] desiredAcceleration The desired acceleration

return A plausible acceleration

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Dynamics_Longitudinal_Basic

Classes
Dynamics_Longitudinal_Basic
openPASS components basic

Calculate the next velocity and position of the agent in the next timestep based on the acceleration in longitudinal direction. More...

Collaboration diagram for Dynamics_Longitudinal_Basic:

Classes

class Dynamics_Longitudinal_Basic_Implementation
Calculate the next velocity and position of the agent in the next timestep based on the acceleration in longitudinal direction. More...

Internal Parameters

const double _VLowerLimit = 0
The minimal velocity of the agent in m/s.

Detailed Description

Calculate the next velocity and position of the agent in the next timestep based on the acceleration in longitudinal direction.

This component gets a desired acceleration and calculates the position and velocity of the next timestep of the agent.

Inputs

Input variables:

name | meaning
in_aVehicle | The acceleration of the agent in m/s^2.

Input channel IDs:

Input ID | signal class | contained variables
0 | DoubleSignal | in_aVehicle

Init Inputs

none

Outputs

none

External parameters

none

Parameters to be specified in agentConfiguration.xml

none

Internal paramters

name | value | meaning
_VLowerLimit | 0 | The minimal velocity of the agent in m/s.
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Dynamics_Longitudinal_Basic_Implementation Class Reference

Public Member Functions | Private Attributes | List of all members
Dynamics_Longitudinal_Basic_Implementation Class Reference
openPASS components basic » Dynamics_Longitudinal_Basic

Calculate the next velocity and position of the agent in the next timestep based on the acceleration in longitudinal direction. More...

Inheritance diagram for Dynamics_Longitudinal_Basic_Implementation:
[legend]
Collaboration diagram for Dynamics_Longitudinal_Basic_Implementation:
[legend]

Public Member Functions

virtual void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
virtual void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
virtual void | Trigger (int time)
Process data within component. More...

Private Attributes

double | in_aVehicle = 0
The acceleration of the agent in m/s^2.
Internal Parameters
const double | _VLowerLimit = 0
The minimal velocity of the agent in m/s.

Detailed Description

Calculate the next velocity and position of the agent in the next timestep based on the acceleration in longitudinal direction.

This component gets a desired acceleration and calculates the position and velocity of the next timestep of the agent.

Member Function Documentation

virtual void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
virtual void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update outputs.

Function is called by framework when this component has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
virtual void Trigger ( int time )
virtual

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component.

Refer to module description for information about the module's task.

Parameters
[in] time Current scheduling time
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Sensor_Distance

Classes
Sensor_Distance
openPASS components basic

basic module to sense the current state of an agent More...

Collaboration diagram for Sensor_Distance:

Classes

class Sensor_Distance_Implementation
This module is a basic module to sense the current state of an agent. More...

Detailed Description

basic module to sense the current state of an agent

This module provides information about the distance of the agent to the agent in front and the current velocity of the agent.

Inputs

none

Init Inputs

none

Outputs

Output variables:

name | meaning
distance2NextAgent | The distance between this agent and agent in front
out_agentVelocity | The velocity of the agent

Output channel IDs:

Output Id | signal class | contained variables
0 | DoubleSignal | distance2NextAgent
1 | DoubleSignal | out_agentVelocity

External parameters

none

Parameters to be specified in agentConfiguration.xml

none

Internal paramters

none

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Sensor_Distance_Implementation Class Reference

Public Member Functions | Private Attributes | List of all members
Sensor_Distance_Implementation Class Reference
openPASS components basic » Sensor_Distance

This module is a basic module to sense the current state of an agent. More...

Inheritance diagram for Sensor_Distance_Implementation:
[legend]
Collaboration diagram for Sensor_Distance_Implementation:
[legend]

Public Member Functions

virtual void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
virtual void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
virtual void | Trigger (int time)
Process data within component. More...

Private Attributes

double | out_distanceToNextAgent = 0
The distance to the next agent in front.
double | out_agentVelocity = 0
The velocity of the agent.

Detailed Description

This module is a basic module to sense the current state of an agent.

This module provides information about the distance of the agent to the agent in front and the current velocity of the agent.

Member Function Documentation

virtual void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
virtual void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update outputs.

Function is called by framework when this component has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
virtual void Trigger ( int time )
virtual

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component.

Refer to module description for information about the module's task.

Parameters
[in] time Current scheduling time
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Action_LongitudinalDriver

Classes
Action_LongitudinalDriver

Sets the longitudinal values. More...

Classes

class ActionLongitudinalDriverImplementation

Detailed Description

Sets the longitudinal values.

This component sets pedal positions and gear

Inputs

Input variables:

name | meaning
in_accPedalPos | Acceleration pedal position
in_brakePedalPos | Brake pedal position
in_gear | Gear

Input channel IDs:

Input ID | signal class | contained variables
0 | LongitudinalSignal | in_accPedalPos, in_brakePedalPos, in_gear
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ActionLongitudinalDriverImplementation Class Reference

Public Member Functions | Private Attributes | List of all members
ActionLongitudinalDriverImplementation Class Reference
Action_LongitudinalDriver
Inheritance diagram for ActionLongitudinalDriverImplementation:
[legend]
Collaboration diagram for ActionLongitudinalDriverImplementation:
[legend]

Public Member Functions

virtual void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
virtual void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
virtual void | Trigger (int time)
Process data within component. More...

Private Attributes

double | in_accPedalPos = 0
Position of the accecaleration pedal position in percent.
double | in_brakePedalPos = 0
Position of the brake pedal position in percent.
int | in_gear = 0
Number of gears and position of gear.

Member Function Documentation

virtual void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
virtual void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update outputs.

Function is called by framework when this Component.has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
virtual void Trigger ( int time )
virtual

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component.

Refer to module description for information about the module's task.

Parameters
[in] time Current scheduling time
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Action_SecondaryDriverTasks

Action_SecondaryDriverTasks

controls secondary driver tasks More...

controls secondary driver tasks

This component sets the brake light to on if the acceleration of the vehicle is smaller than the coasting acceleration, sets the indicator and other switches the driver uses during driving.

Inputs

Input variables:

name | meaning
in_IndicatorState | State of the turning indicator (left, center/off, right).
in_hornSwitch | Horn activation (true/false)
in_headLightSwitch | Light activation (true/false)
in_highBeamLightSwitch | HighBeamLight activation (true/false)
in_flasherSwitch | Flasher activation (true/false)

Input channel IDs:

Input ID | signal class | contained variables
0 | SecondaryDriverTasksSignal | in_IndicatorState, in_hornSwitch, in_headLightSwitch, in_highBeamLightSwitch, in_flasherSwitch

Outputs

none

InternalParameters

none

ExternalParameters

none

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Agent_Updater

Agent_Updater

This module gets the final values for the dynamic parameters of the agent and updates the agent accordingly. More...

This module gets the final values for the dynamic parameters of the agent and updates the agent accordingly.

Inputs

Input variables:

name | meaning
acceleration | Acceleration of the agent in m/s.
velocity | Velocity of the agent in m/s.
positionX | X position of the agent.
positionY | Y position of the agent.

Input channel IDs:

Input ID | signal class | contained variables
0 | DynamicsSignal | acceleration, velocity, positionX, positionY
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Algorithm_AEB

Algorithm_AEB

This module represents a simple autonomous emergency braking system (AEB). More...

This module represents a simple autonomous emergency braking system (AEB).

Utility class for AEB to predict the bounding box of objects in future timesteps.

This module represents a simple autonomous emergency braking system (AEB). If the predicted time to collision (TTC) with an other object detected by a sensor is below a certain treshold it brake with a constant deceleration. The module deactivates again if the TTC is above 1.5 times the treshold

Inputs

name | meaning
detectedMovingObjects | moving objects detected by a sensor
detectedStationaryObjects | stationary objects detected by a sensor

Outputs

name | meaning
activeAcceleration | current acceleration of this module
componentState | current state of this module
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Algorithm_Lateral

Algorithm_Lateral

models the lateral controller of the driver More...

models the lateral controller of the driver

This component models the lateral controller of the driver. It calculates a steering wheel angle wish of the driver that tries to diminish the lateral offset to the current or target lane in a lane change. This wish depends also on the intensity of a lane change.

Inputs

Input variables:

name | meaning
in_LatDisplacement | The current control deviation of lateral displacment in m.
in_lateralDeviation | The lateral deviation from the lane change or swerving trajectory [m].
in_headingError | The heading error regarding the lane change or swerving trajectory [rad].
in_gainLateralDeviation | Gain for lateral deviation control in AlgorithmLateralDriver [rad/s^2].
in_gainHeadingError | Gain for heading error control in AlgorithmLateralDriver [1/s].
in_kappaSet | Set value for trajectory curvature [1/m].
velocity | Current velocity
steeringWheelAngle | Current steering wheel angle

Input channel IDs:

Input ID | signal class | contained variables
0 | LateralSignal | laneWidth, lateralDeviation, gainLateralDeviation, headingError, gainHeadingError, kappaSet
101 | SensorDriverSignal | used from signal: velocity, steeringWheelAngle

Init Inputs

Init input variables:

name | meaning
in_steeringRatio | The steering ratio of the vehicle.
in_steeringMax | The maximum possible steering wheel angle in both directions in degree.
in_wheelBase | The wheel base of the vehicle in m.

Note that these variables are only used implicetly by the component without assigning the values to variable names.

Init input channel IDs:

Input Id | signal class | contained variables
100 | ParametersVehicleSignal | used from signal: steeringRatio, steeringMax, wheelbase

Outputs

Output variables:

name | meaning
out_desiredSteeringWheelAngle | The steering wheel angle wish of the driver in degree.

Output channel IDs:

Output Id | signal class | contained variables
0 | SteeringSignal | out_desiredSteeringWheelAngle

External parameters

none

Internal paramters

name | value | meaning --—|----—|---—.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Algorithm_Longitudinal

Classes | Functions | Variables
Algorithm_Longitudinal

models the longitudinal controller of the driver. More...

Classes

class | AlgorithmLongitudinalImplementation
class | AlgorithmLongitudinalCalculations
This class does all the calculations in the Algorithm_Longitudinal module. More...

Functions

void CalculatePedalPositionAndGear ()
Calculate the pedal positions and gear.

Variables

const std::string | COMPONENTNAME = "AlgorithmLongitudinal"
Name of the current component.
bool | initializedAccelerationInput {false}
initialize module with sended prioritzer data
bool | initializedVehicleModelParameters {false}
initialize module with sended vehicle parameters sended from ParametersAgent
bool | initializedSensorDriverData {false}
initialize module with sended parameters sended from SensoDriver
double | accelerationWish {0.0}
The wish acceleration of the agent in m/s^2.
double | currentVelocity {0.0}
current agent velocity
double | out_accPedalPos {0.0}
Position of the accelerator pedal position in percent.
double | out_brakePedalPos {0.0}
Position of the brake pedal position in percent.
int | out_gear {0}
Currently choosen gear.
VehicleModelParameters vehicleModelParameters
contains: double carMass; double rDyn and more;

Detailed Description

models the longitudinal controller of the driver.

This component models the longitudinal controller of the driver / some ADAS. It calculates the positions of the acceleration pedal and the brake pedal, as well as the chosen gear and models the actuation of the pedals.

Inputs

Input variables:

name | meaning
accelerationWish | wish acceleration
velocity | current velocity

Input channel IDs:

Input ID | signal class | contained variables
0 | AccelerationSignal | accelerationWish
101 | SensorDriverSignal | used from signal: velocity

Init Inputs

Init input variables:

name | meaning
vehicleModelParameters | VehicleModelParameters

Init input channel IDs:

Input Id | signal class | contained variables
100 | ParametersVehicleSignal | vehicleModelParameters

Outputs

Output variables:

name | meaning
out_desiredSteeringWheelAngle | The steering wheel angle wish of the driver in degree.

Output channel IDs:

Output Id | signal class | contained variables
0 | SteeringSignal | out_desiredSteeringWheelAngle

External parameters

none

Internal paramters

name | value | meaning --—|----—|---—.

This component models the longitudinal controller of the driver / some ADAS. It calculates the positions of the acceleration pedal and the brake pedal, as well as the chosen gear and models the actuation of the pedals.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AlgorithmLongitudinalImplementation Class Reference

Public Attributes | Private Member Functions | Private Attributes | List of all members
AlgorithmLongitudinalImplementation Class Reference
Algorithm_Longitudinal
Inheritance diagram for AlgorithmLongitudinalImplementation:
[legend]
Collaboration diagram for AlgorithmLongitudinalImplementation:
[legend]

Public Attributes

const std::string COMPONENTNAME = "AlgorithmLongitudinal"
Name of the current component.

Private Member Functions

void CalculatePedalPositionAndGear ()
Calculate the pedal positions and gear.

Private Attributes

bool | initializedAccelerationInput {false}
initialize module with sended prioritzer data
bool | initializedVehicleModelParameters {false}
initialize module with sended vehicle parameters sended from ParametersAgent
bool | initializedSensorDriverData {false}
initialize module with sended parameters sended from SensoDriver
double | accelerationWish {0.0}
The wish acceleration of the agent in m/s^2.
double | currentVelocity {0.0}
current agent velocity
double | out_accPedalPos {0.0}
Position of the accelerator pedal position in percent.
double | out_brakePedalPos {0.0}
Position of the brake pedal position in percent.
int | out_gear {0}
Currently choosen gear.
VehicleModelParameters vehicleModelParameters
contains: double carMass; double rDyn and more;
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AlgorithmLongitudinalCalculations Class Reference

Public Member Functions | List of all members
AlgorithmLongitudinalCalculations Class Reference
Algorithm_Longitudinal

This class does all the calculations in the Algorithm_Longitudinal module. More...

Collaboration diagram for AlgorithmLongitudinalCalculations:
[legend]

Public Member Functions

AlgorithmLongitudinalCalculations (double velocity, double accelerationWish, const VehicleModelParameters &vehicleModelParameters)
void | CalculateGearAndEngineSpeed ()
Calculates the necessary gear and engine to achieve the desired acceleration at the current velocity.
void | CalculatePedalPositions ()
Calculates the necessary accelerator pedal and brake pedal position to achieve desired acceleration depending on the gear. Therefor CalculateGearAndEngineSpeed needs to be called first.
double | GetBrakePedalPosition () const
double | GetAcceleratorPedalPosition () const
double | GetEngineSpeed () const
int | GetGear () const
double | GetAccFromEngineTorque (double engineTorque, int chosenGear)
Calculates the acceleration that will result from the engineTorque at the given gear.
double | GetEngineSpeedByVelocity (double velocity, int gear)
Calculates the engine speed required to drive with the given velocity at the specified gear.
bool | isWithinEngineLimits (int gear, double engineSpeed, double acceleration)
Checks wether the engineSpeed and acceleration/torque can be achieved by the engine.
double | GetEngineTorqueMin (double engineSpeed)
Returns the maximum possible engineTorque for the given engineSpeed.
double | GetEngineTorqueMax (double engineSpeed)
Returns the minimum engineTorque (i.e. maximum drag) for the given engineSpeed.
double | GetEngineTorqueAtGear (int gear, double acceleration)
Calculates the engine torque required to achieve the given acceleration at the specified gear.

Detailed Description

This class does all the calculations in the Algorithm_Longitudinal module.

Based on the current velocity of the agent and a desired acceleration, this class calculates the gear and the pedal positions required to achieve this acceleration. The AlgorithmLongitudinal constructs an instance of this class with the parameters, then calls the calculate functions and then acquires the results be calling the respective getter.

Constructor & Destructor Documentation

AlgorithmLongitudinalCalculations | ( | double | velocity,
 |  | double | accelerationWish,
 |  | const VehicleModelParameters & | vehicleModelParameters
 | ) |  |
Parameters
velocity | current velocity of the agent
accelerationWish | desired acceleration (can be negative)
vehicleModelParameters | parameters of the vehicle model

Member Function Documentation

double GetBrakePedalPosition ( ) const
Returns
Calculated position of brake pedal in percent
double GetAcceleratorPedalPosition ( ) const
Returns
Calculated position of accelerator pedal in percent
double GetEngineSpeed ( ) const
Returns
Calculated engine speed
int GetGear ( ) const
Returns
Calculated gear
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ComponentController

Classes
ComponentController

This module. More...

Classes

class ComponentControllerImplementation

Detailed Description

This module.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ComponentControllerImplementation Class Reference

Public Member Functions | Private Member Functions | List of all members
ComponentControllerImplementation Class Reference
ComponentController
Inheritance diagram for ComponentControllerImplementation:
[legend]
Collaboration diagram for ComponentControllerImplementation:
[legend]

Public Member Functions

virtual void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
virtual void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
virtual void | Trigger (int time)
Process data within component. More...

Private Member Functions

bool IsAgentAffectedByEvent (EventInterface const *event)
Check if the associated agent is within the affected agents of the given id. More...

Member Function Documentation

virtual void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
virtual void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update outputs.

Function is called by framework when this component has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
virtual void Trigger ( int time )
virtual

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component

Parameters
[in] time Current scheduling time
bool IsAgentAffectedByEvent ( EventInterface const * event )
private

Check if the associated agent is within the affected agents of the given id.

Parameters
event
Returns
True if affected
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Dynamics_Collision

Dynamics_Collision

This modules calculates all dynaimcs of the agent in case of a collision. More...

This modules calculates all dynaimcs of the agent in case of a collision.

This module becomes active after the agent was involved in a collision. Once it is active the agent decelerates with a constant deceleration of -10.0 m/s^2 in a linear trajectory until it comes to a stop. At the moment of the collision the velocities and the yaw angle of the ego and the collision partner are adjusted based on a inelastic collision algorithm. If the agent collides with a static object, it immediately comes to a fullstop.

Outputs

Output variables:

name | meaning
dynamicsSignal | Signal containing all dynamics information

Output channel IDs:

Output ID | signal class | contained variables
0 | DynamicsSignal | dynamicsSignal
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Dynamics_CollisionPostCrash

Classes
Dynamics_CollisionPostCrash

Collision component that calculates post-crash dynamics. More...

Classes

class DynamicsPostCrashImplementation

Internal states

enum | CollisionState
Specifies the current state of collision the agent is in.
double | velocity {}
host velocity
double | movingDirection {}
host velocity direction
unsigned int | numberOfCollisionPartners = 0
number of collision partners of host agent
bool | isActive = false
flag that shows if collision has occurred
enum DynamicsPostCrashImplementation::CollisionState | collisionState = CollisionState::NOCOLLISION

Detailed Description

Collision component that calculates post-crash dynamics.

The algorithms for collision detection and calculation of the post-crash dynamics are based on algorithms provided by Harald Kolk (TU Graz).

The algorithm for collision dection is based on the Sutherland–Hodgman algorithm for polygon clipping.

The algorithm for calculating the post-crash-dynamics is based on conservation of momentum and angular momentum. It works in 2D and is only valid for non-sliding collisions.

Note that this module is provisional regarding several aspect. openPASS needs to be changed in order to improve the following:

  • The post-crash dynamics is currently only calculated and written to the log-file since openPASS does not allow to forward the results to dynamic-components and observation modules, currently.
  • This module needs several parameters (coeffRest, interFriction and timeOfPenetration). openPASS currently does not allow to set parameters for this module in the config files. Therefore, these parameters are hard-coded.
  • The calculation of the post-crash dynamics is based on the assumptions that the time where the collision starts is known since the post-crash dynamics shall be calculated a certain time ( given by the parameter timeOfPenetration ) after the first contact of the vehicles. Currently, this module does not know anything about sample rates etc. which makes it difficult to find the correct time to calculate the post-crash dynamics.
  • The algorithm for the post-crash dynamics uses the pre-crash yaw velocities of both agents. Since the yaw velocity is not available for the agents currently, the yaw velocities are set to zero here.

Note:

  • The method GetVertexTypes in collisionDetection assumes that the intersection of the two vehicles is rather small. It has not been checked if the method covers all possible cases for bigger intersections which are possible in openPASS depending on the cycle times.

Outputs

Output variables:

name | meaning
dynamicsSignal | Signal containing all dynamics information

Output channel IDs:

Output ID | signal class | contained variables
0 | DynamicsSignal | dynamicsSignal
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: DynamicsPostCrashImplementation Class Reference

Public Member Functions | Private Member Functions | List of all members
DynamicsPostCrashImplementation Class Reference
Dynamics_CollisionPostCrash
Inheritance diagram for DynamicsPostCrashImplementation:
[legend]
Collaboration diagram for DynamicsPostCrashImplementation:
[legend]

Public Member Functions

virtual void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
virtual void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
virtual void | Trigger (int time)
Process data within component. More...

Private Member Functions

bool | TriggerPostCrashCheck (int time)
Process data for collisionPartners as given by simulation core. More...
void | SetFadingDynamics ()
Calculate and set vehicle dynamics for fading out after collision. More...

Private Attributes

Internal objects
DynamicsSignal dynamicsSignal
Output Signal.

Internal states

enum | CollisionState
Specifies the current state of collision the agent is in.
double | velocity {}
host velocity
double | movingDirection {}
host velocity direction
unsigned int | numberOfCollisionPartners = 0
number of collision partners of host agent
bool | isActive = false
flag that shows if collision has occurred
enum DynamicsPostCrashImplementation::CollisionState | collisionState = CollisionState::NOCOLLISION

Member Function Documentation

virtual void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
virtual void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update outputs.

Function is called by framework when this component has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
virtual void Trigger ( int time )
virtual

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component

Parameters
[in] time Current scheduling time
bool TriggerPostCrashCheck ( int time )
private

Process data for collisionPartners as given by simulation core.

Function is called by Trigger

Parameters
[in] time Current scheduling time
void SetFadingDynamics ( )
private

Calculate and set vehicle dynamics for fading out after collision.

Function is called by Trigger

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Dynamics_RegularDriving

Classes
Dynamics_RegularDriving

models the longitudinal and lateral dynamics of the vehicle coresponding to the pedal and steering inputs More...

Classes

class DynamicsRegularDrivingImplementation

Detailed Description

models the longitudinal and lateral dynamics of the vehicle coresponding to the pedal and steering inputs

This component models the reaction of the vehicle based on the pedal and steering wheel operation of the driver. It calculates velocity and position of the agent according to his acceleration and his collision state. If no collision took place in the previous time step where the agent was the rear opponent, the velocity and position of the agent is calculated according to his acceleration wish. If the agent was the rear opponent in a collision, its velocity is set to the one of the front agent. The position is calculated according to this velocity. Additionaly the maximum change of steering wheel angle according to the desired steering wheel angle is calculated.

Inputs

Input variables:

name | meaning
in_accPedalPos | Position of the gas pedal in percent
in_brakePedalPos | Position of the brake pedal in percent
in_gear | Current gear
in_steeringWheelAngle | Steering wheel angle of the agent

Input channel IDs:

Input ID | signal class | contained variables
1 | LongitudinalSignal | in_accPedalPos, in_brakePedalPos, in_gear
2 | SteeringSignal | in_steeringWheelAngle

Init Inputs

Init input variables:

name | meaning
vehicleModelParameters | VehicleModelParameters
  • Init input channel IDs:
    Input Id | signal class | contained variables
    100 | ParametersVehicleSignal | vehicleModelParameters

Outputs

Output variables:

name | meaning
acceleration | Acceleration of the current agent coresponding to the pedalpositions [m/s²]
velocity | The driven curvature of the car coresponding to the steering wheel angle based on Ackermann [radiant]
positionX | new inertial x-position [m]
positionY | new inertial y-position [m]
yaw | new yaw angle in current time step [radiant]
yawRate | change of yaw angle due to ds and curvature [radiant]
steeringWheelAngle | new angle of the steering wheel angle [degree]
travelDistance | distance traveled by the agent during this timestep [m]

Output channel IDs:

Output Id | signal class | contained variables
0 | DynamicsSignal | acceleration, velocity, positionX, positionY, yaw, yawRate, steeringWheelAngle, travelDistance

External parameters

none

Internal paramters

name | value | meaning
VLowerLimit | 0 | The minimal velocity of the agent in m/s.
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: DynamicsRegularDrivingImplementation Class Reference

Public Member Functions | Public Attributes | Private Member Functions | List of all members
DynamicsRegularDrivingImplementation Class Reference
Dynamics_RegularDriving
Inheritance diagram for DynamicsRegularDrivingImplementation:
[legend]
Collaboration diagram for DynamicsRegularDrivingImplementation:
[legend]

Public Member Functions

virtual void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
virtual void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
virtual void | Trigger (int time)
Process data within component. More...

Public Attributes

const std::string COMPONENTNAME = "DynamicRegularDriving"
Name of the current component.

Private Member Functions

void | ApplyGearLimit ()
Applies limit to incoming geer.
void | ApplyPedalPositionLimits ()
Applies limits to the incoming steering wheel angle and incoming pedal position.
double | GetAccVehicle (double accPedalPos, double brakePedalPos, int gear, int time)
double | GetAccelerationFromAirResistance (double velocity)
double | GetAccelerationFromRollingResistance ()
double | GetEngineMoment (double gasPedalPos, int lastGear)
double | GetEngineMomentMin (double engineSpeed)
double | GetEngineMomentMax (double engineSpeed)
double | GetEngineSpeedByVelocity (double xVel, int gear)
double | GetAccFromEngineMoment (double xVel, double engineMoment, int chosenGear, int cycleTime)
double | GetFrictionCoefficient ()

Private Attributes

Internal Parameters
const double | VLowerLimit = 0
The minimal velocity of the agent [m/s].
External Parameters
double | in_accPedalPos = 0
Position of the accecaleration pedal position [%].
double | in_brakePedalPos = 0
Position of the brake pedal position [%].
int | in_gear = 0
Number of gears and position of gear.
double | in_steeringWheelAngle = 0
The steering wheel angle [°].
DynamicsSignal dynamicsSignal
Output Signal containing (aLong,v,x,y,dpsi,psi)
VehicleModelParameters vehicleModelParameters
Containing the vehicle parameters e.g. double carMass; double rDyn and more.
const double | DegreeToRadiant = 0.01745329251994329576923690768489
Conversion factor degree to radiant.
double | _twoPi = 2 * M_PI
PI.
double | _oneG = 9.81
value of earth gravity [m/s²].
double | _rho = 1.23
air density.

Member Function Documentation

virtual void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
virtual void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update outputs.

Function is called by framework when this component has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
virtual void Trigger ( int time )
virtual

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component

Parameters
[in] time Current scheduling time
double GetAccVehicle | ( | double | accPedalPos,
 |  | double | brakePedalPos,
 |  | int | gear,
 |  | int | time
 | ) |  |
private

Get the acceleration of the vehicle from pedal position and gear.

Parameters
[in] | accPedalPos | current Gas pedal position [%]
[in] | brakePedalPos | current Brake pedal position [%]
[in] | gear | current Gear
[in] | carParameters | parameters of the car
Returns
current acceleration
double GetAccelerationFromAirResistance ( double velocity )
private

Get the acceleration (negative) caused by the air resistance of the vehicle.

Parameters
[in] velocity absolute vehicle speed [m/s]
Returns
acceleration due to rolling resistance [m/s^2]
double GetAccelerationFromRollingResistance ( )
private

Get the acceleration (negative) caused by the rolling resistance of the wheels.

Returns
acceleration due to rolling resistance [m/s^2]
double GetEngineMoment | ( | double | gasPedalPos,
 |  | int | lastGear
 | ) |  |
private

Get the moment of the engine from pedal position and gear.

Parameters
[in] | gasPedalPos | current Gas pedal position. [%]
[in] | lastGear | the last chosen gear.
[in] | carParameters | parameters of the car
Returns
engine moment [Nm]
double GetEngineMomentMin ( double engineSpeed )
private

Get the drag moment of the engine corresponding to its speed

Parameters
[in] | engineSpeed | the speed of the engine
[in] | carParameters | parameters of the car
Returns
drag moment [Nm]
double GetEngineMomentMax ( double engineSpeed )
private

Get the maximum possible torque of the engine in the current state

Parameters
[in] | engineSpeed | the speed of the engine
[in] | carParameters | parameters of the car
Returns
maximum moment in the current state [Nm]
double GetEngineSpeedByVelocity | ( | double | xVel,
 |  | int | gear
 | ) |  |
private

Calculate the engine speed coresponding to the current speed and gear of the car

Parameters
[in] | xVel | longitudinal speed of the car
[in] | gear | current gear
[in] | carParameters | parameters of the car
Returns
engine speed [1/min]
double GetAccFromEngineMoment | ( | double | xVel,
 |  | double | engineMoment,
 |  | int | chosenGear,
 |  | int | cycleTime
 | ) |  |
private

Calculate the resulting acceleration of the car with the delivered moment of the engine

Parameters
[in] | xVel | longitudinal speed of the car (unused)
[in] | engineMoment | delivered moment of the engine
[in] | chosenGear | the curent gear
[in] | carParameters | parameters of the car
[in] | cycleTime | Cycle time of this components trigger task [ms] (unused)
Returns
resulting acceleration [m/s²]
double GetFrictionCoefficient ( )
private

Returns the friction coefficient according to enviroment and car conditions

Returns
friction coefficient (currently ALWAYS 1)
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Dynamics_RegularTwoTrack

Classes
Dynamics_RegularTwoTrack

Dynamic component to model the dynamic of a two track vehicle. More...

Classes

class DynamicsRegularTwoTrackImplementation

Detailed Description

Dynamic component to model the dynamic of a two track vehicle.

Simple open-loop two-track model.

Inputs

Input variables:

name | meaning
in_accPedalPos | Position of the gas pedal in percent
in_brakePedalPos | Position of the brake pedal in percent
in_gear | Current gear
in_steeringWheelAngle | Steering wheel angle of the agent

Input channel IDs:

Input ID | signal class | contained variables
1 | LongitudinalSignal | in_accPedalPos, in_brakePedalPos, in_gear
2 | SteeringSignal | in_steeringWheelAngle

Outputs

Output variables:

name | meaning
acceleration | Acceleration of the current agent coresponding to the pedalpositions [m/s²]
velocity | The driven curvature of the car coresponding to the steering wheel angle based on Ackermann [radiant]
positionX | new inertial x-position [m]
positionY | new inertial y-position [m]
yaw | new yaw angle in current time step [radiant]
yawRate | change of yaw angle due to ds and curvature [radiant]
steeringWheelAngle | new angle of the steering wheel angle [degree]
travelDistance | distance traveled by the agent during this timestep [m]

Output channel IDs:

Output Id | signal class | contained variables
0 | DynamicsSignal | acceleration, velocity, positionX, positionY, yaw, yawRate, steeringWheelAngle, travelDistance
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: DynamicsRegularTwoTrackImplementation Class Reference

Public Member Functions | Public Attributes | Private Member Functions | Private Attributes | List of all members
DynamicsRegularTwoTrackImplementation Class Reference
Dynamics_RegularTwoTrack
Inheritance diagram for DynamicsRegularTwoTrackImplementation:
[legend]
Collaboration diagram for DynamicsRegularTwoTrackImplementation:
[legend]

Public Member Functions

virtual void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
virtual void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
virtual void | Trigger (int time)
Process data within component. More...

Public Attributes

const std::string COMPONENTNAME = "DynamicRegularTwoTrack"
Name of the current component.

Private Member Functions

void | ReadPreviousState ()
Update data on agent's actual position, velocity and acceleration.
void | NextStateTranslation ()
Calculate next position, translation velocity and translation acceleration of the agent.
void | NextStateRotation ()
Calculate next yaw angle, rotation velocity and rotation acceleration of the agent.
void | NextStateSet ()
Write next position, velocity and acceleration of the agent.
void | Init ()
Initialize parameters and vehicle, as in original constructor.

Private Attributes

DynamicsSignal dynamicsSignal
Output Signal.
std::map< int, ComponentPort * > | inputPorts
map for all InputPort
External Parameters

Parameter which are set externally in configuration file.

externalParameter< double > | radiusTire {0, &parameterMapDouble }
externalParameter< double > | muTireMax {1, &parameterMapDouble }
externalParameter< double > | muTireSlide {2, &parameterMapDouble }
externalParameter< double > | slipTireMax {3, &parameterMapDouble }
externalParameter< double > | powerEngineMax {4, &parameterMapDouble }
externalParameter< double > | torqueBrakeMin {5, &parameterMapDouble }
InputPorts

All input ports with PortId

InputPort< DoubleSignal, double > | throttlePedal {0, &inputPorts}
throttle pedal position in the range [0...1]
InputPort< DoubleSignal, double > | brakePedal {1, &inputPorts}
brake pedal position in the range [0...1]
InputPort< DoubleSignal, double > | angleTireFront {2, &inputPorts}
steering angle [radian]
Internal states
double | timeStep = 0.0
Time step as double in s.
double | yawAngle = 0.0
Yaw angle.
Common::Vector2d | positionCar = {0.0, 0.0}
Car's position.
double | yawVelocity = 0.0
Yaw rate.
Common::Vector2d | velocityCar = {0.0, 0.0}
Car's velocity.
double | yawAcceleration = 0.0
Yaw acceleration.
Common::Vector2d | accelerationCar = {0.0, 0.0}
Car's acceleration.
std::vector< double > | brakeSuperpose = {0.0, 0.0, 0.0, 0.0}
Brake position for each tire.
std::vector< double > | forceWheelVertical = {0.0, 0.0, 0.0, 0.0}
Vertical force on wheels.
Internal objects
std::unique_ptr< VehicleSimpleTT > | vehicle
Vehicle in trajectory CS.

Member Function Documentation

virtual void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
virtual void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update outputs.

Function is called by framework when this component has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
virtual void Trigger ( int time )
virtual

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component

Parameters
[in] time Current scheduling time
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Dynamics_TrajectoryFollower

Classes
Dynamics_TrajectoryFollower

makes an agent strictly follow a predefined path More...

Classes

class TrajectoryFollowerImplementation
Makes an agent strictly follow a predefined path. More...

Detailed Description

makes an agent strictly follow a predefined path

The path is defined in a file that is loaded in the importer into a map. The module simply reads the coordinates defined in the map every step and forces the agent to move to that position. The vehicle is in this mode very simplified (there is no driver, no logic or any intelligence). It's basically a "playback" of the trajectory.

Inputs

Input variables:

name | meaning
inputAcceleration | acceleration from some vehicle component, if any
velocity | current velocity
maxReachableState | max ComponentState for this module is given by ComponentController

Input channel IDs:

Input ID | signal class | contained variables
0 | SteeringSignal | componentState
1 | AccelerationSignal | inputAcceleration, componentState
2 | TrajectorySignal | trajectory

Outputs

Output variables:

name | meaning
acceleration | Acceleration of the current agent coresponding to the pedalpositions [m/s²]
velocity | The driven curvature of the car coresponding to the steering wheel angle based on Ackermann [radiant]
positionX | new inertial x-position [m]
positionY | new inertial y-position [m]
yaw | new yaw angle in current time step [radiant]
yawRate | change of yaw angle due to ds and curvature [radiant]
steeringWheelAngle | new angle of the steering wheel angle [degree]
travelDistance | distance traveled by the agent during this timestep [m]

Output channel IDs:

Output Id | signal class | contained variables
0 | DynamicsSignal | acceleration, velocity, positionX, positionY, yaw, yawRate, steeringWheelAngle, travelDistance
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TrajectoryFollowerImplementation Class Reference

Public Member Functions | List of all members
TrajectoryFollowerImplementation Class Reference
Dynamics_TrajectoryFollower

Makes an agent strictly follow a predefined path. More...

Inheritance diagram for TrajectoryFollowerImplementation:
[legend]
Collaboration diagram for TrajectoryFollowerImplementation:
[legend]

Public Member Functions

void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) override
Update Inputs. More...
void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) override
Update outputs. More...
void | Trigger (int time) override
Process data within component. More...
void | CalculateNextTimestep ()
Calculates dynamics for next timestep. More...

Detailed Description

Makes an agent strictly follow a predefined path.

Member Function Documentation

void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
override

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
override

Update outputs.

Function is called by framework when this component has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
void Trigger ( int time )
override

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component

Parameters
[in] time Current scheduling time
void CalculateNextTimestep ( )

Calculates dynamics for next timestep.

Parameters
[in] time Current scheduling time
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LimiterAccelerationVehicleComponents

LimiterAccelerationVehicleComponents

Limits the acceleration output from all vehicle components. More...

Limits the acceleration output from all vehicle components.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Parameters_Vehicle

Classes
Parameters_Vehicle

defines and distributes parameters (constants and stochasitc variables) for all components of an agent More...

Classes

class ParametersVehicleImplementation
defines constants or creates stochastic values that are used in more than one module More...

Detailed Description

defines and distributes parameters (constants and stochasitc variables) for all components of an agent

This component defines parameters for all other components of an agent. It includes constants and stochastic variables, which are divided into driver and vehicle parameters in the components output data structs.

Inputs

none

Init Inputs

none

Outputs

Output variables:

Information in output data struct out_vehicleParameters

name | meaning
airDragCoefficient | The air drag coefficient of the vehicle
axleRatio | The ratio of the axle gear
decelerationFromPowertrainDrag | The deceleration caused by the overall powertrain drag torque in m/s2
distanceReferencePointToFrontAxle | The distance between the vehicle coordinate system's reference point (rear axle) and the front axle in m
distanceReferencePointToLeadingEdge | The distance between the vehicle coordinate system's reference point (rear axle) and the front bumper in m
frictionCoeff | The friction coefficient between road and the vehicles tires
frontSurface | The projected front surface of the vehicle in m2
gearRatios | The ratios of all gears in the gearbox (no reverse gear)
height | The maximum height of the vehicle in m
heightCOG | The height of the center of gravity above ground in m
length | The maximum length of the vehicle in m
maxCurvature | The maximum curavture the vehicle is able to drive in 1/m
maximumEngineSpeed | The maximum engine speed in 1/min
maximumEngineTorque | The maximum torque of the engine in Nm
maximumSteeringWheelAngleAmplitude | The maximum amplitude of the steering wheel angle in degree
maxVelocity | The maximum velocity of the vehicle in m/s
minimumEngineSpeed | The idle speed of the engine in 1/min
minimumEngineTorque | The drag torque of the engine in Nm
momentInertiaPitch | The moment of inertia along the vehicle's lateral axes in kgm2
momentInertiaRoll | The moment of inertia along the vehicle's longtudinal axes in kgm2
momentInertiaYaw | The moment of inertia along the vehicle's vertical axes in kgm2
numberOfGears | The number of gears in the gearbox (no reverse gear)
staticWheelRadius | The static wheel radius in m
steeringRatio | The ratio of the steering gear
trackwidth | The trackwidth of the vehicle in m (for all axles)
vehicleType | The type of the driver's vehicle
weight | The overall mass of the vehicle in kg
wheelbase | The wheelbase of the vehicle in m
width | The maximum width of the vehicle in m

Output channel IDs:

Output Id | signal class | contained variables
1 | VehicleParameterSignal | out_vehicleParameters
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ParametersVehicleImplementation Class Reference

List of all members
ParametersVehicleImplementation Class Reference
Parameters_Vehicle

defines constants or creates stochastic values that are used in more than one module More...

Inheritance diagram for ParametersVehicleImplementation:
[legend]
Collaboration diagram for ParametersVehicleImplementation:
[legend]

Detailed Description

defines constants or creates stochastic values that are used in more than one module

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Sensor_Driver

Sensor_Driver

Collect and distribute Data from the WorldInterface and AgentInterface concerning the own vehicle, traffic rule information, lane geometry and surrounding objects. More...

Collect and distribute Data from the WorldInterface and AgentInterface concerning the own vehicle, traffic rule information, lane geometry and surrounding objects.

This component creates a data struct to store the world and agent data of the own vehicle, traffic rule information, lane geometry and surrounding vehicles. Own vehicle data examples are ID, velocity, heading angle, yaw angle, ... for the ego vehicle. Traffic rule information are traffic signs for each lane. Lane geometry is visibility distance and lane specifics like lane curvature, lane width, ... Surrounding object data (vehicles or statics) is for example distance, velocity ... for different positions around the agent.

Inputs

name | meaning
agent | This interface provides access to agent parameters, properties, attributes and dynamic states
callbacks | Interface for callbacks to framework
componentId | Id of the component
cycleTime | Cycle time of this components trigger task [ms]
data | Referenced signal (copied by sending component)
isInit | Query whether the component was just initialized
localLinkId | Corresponds to "id" of "ComponentInput"
publisher | Publishing instance provided by the framework
offsetTime | Offset time of the component
parameters | Interface provides access to the configuration parameters
priority | Priority of the component
responseTime | Response time of the component
stochastics | Provides access to the stochastics functionality of the framework
time | Current scheduling time
world | Provides access to world representation

Outputs

name | meaning -|- none

Output channel IDs:

Output Id | signal class | contained variables
0 | SensorDriverSignal | ownVehicleInformation, trafficRuleInformation, geometryInformation, surroundingObjects
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SensorObjectDetector

Classes
SensorObjectDetector

This file models the SensorObjectDetectors. More...

Classes

class | ObjectDetectorBase
This class is the common base for all SensorObjectDetectors. More...
class | SensorGeometric2D
This file models a sensor which only detects agents in a 2D area (x/y) in front of the agent. More...

Detailed Description

This file models the SensorObjectDetectors.

This file models the SensorObjectDetectors which can be part of an agent. The SensorObjectDetectors represent sensor which can detect other WorldObjects around the agent. Those sensor have different approaches in detecting other WorldObjects. The detected Objects can then be sent to the corresponding ADAS which uses them.

Outputs

Output variables:

name | meaning
out_detectedObjects | Vector of all detected objects.

Output channel IDs:

Output Id | signal class | contained variables
0 | SensorObjectDetectorToAdasSignal | out_detectedObjects

External parameters

name | meaning
sensorParameters | All parameters which describe the sensor.
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ObjectDetectorBase Class Reference

Public Member Functions | Protected Member Functions | Static Protected Member Functions | Private Member Functions | List of all members
ObjectDetectorBase Class Referenceabstract
SensorObjectDetector

This class is the common base for all SensorObjectDetectors. More...

Inheritance diagram for ObjectDetectorBase:
[legend]
Collaboration diagram for ObjectDetectorBase:
[legend]

Public Member Functions

virtual void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)=0
Update Inputs. More...
void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
virtual void | Trigger (int time)=0
Process data within component. More...
const osi3::SensorData & | getSensorData ()

Protected Member Functions

Position GetAbsolutePosition ()
Returns the absolute position of the sensor. More...
osi3::SensorData | ApplyLatency (int time, osi3::SensorData currentSensorData)
Apply the predefined latency to the detected results. More...
bool | HasDetectionError ()
Rolls for the failure chance of the sensor. More...
double | ApplyMeasurementError (double value)
Applies a measurement error to a given value. More...
virtual osi3::SensorViewConfiguration | GenerateSensorViewConfiguration ()
Generates the basic SensorViewConfiguration. More...
polygon_t | TransformPolygonToGlobalCoordinates (polygon_t polygon, point_t sensorPositionGlobal, double yaw) const
Translates the polygon from local coordinates to global coordinates. More...
virtual point_t | TransformPointToLocalCoordinates (point_t point, point_t sensorPositionGlobal, double yaw)
Translates a point from global coordinates to local coordinates. More...
point_t | CalculateGlobalSensorPosition (point_t vehiclePosition, double yaw) const
Calculates the position of the sensor in global coordinates. More...
virtual point_t | CalculateRelativeVector (const point_t absolute, const point_t own, double yaw)
Calculates the relative velocity or acceleration between this vehicle and another in local vehicle coordinates. More...

Static Protected Member Functions

static polygon_t CalculateBoundingBox (const osi3::Dimension3d dimension, const osi3::Vector3d position, const osi3::Orientation3d orientation)
Calculates the bounding box of an object from the osi information. More...

Private Member Functions

void ParseBasicParameter ()
This method parses the initial parameters required by the module.

Detailed Description

This class is the common base for all SensorObjectDetectors.

This class is the common base for all SensorObjectDetectors. It provides the basic functionality for all object detectors.

Member Function Documentation

virtual void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
pure virtual

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |

Update outputs.

Function is called by framework when this Component.has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
virtual void Trigger ( int time )
pure virtual

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component.

Refer to module description for information about the module's task.

Parameters
[in] time Current scheduling time
const osi3::SensorData& getSensorData ( )
inline

For testing

Position GetAbsolutePosition ( )
protected

Returns the absolute position of the sensor.

This method calculates and returns the absolute position of the sensor by adding the agent's position to the sensor's mounting position (and taking the yaw angle into account).

Returns
The absolute position and yaw of the sensor with respect to world coordinates
osi3::SensorData ApplyLatency | ( | int | time,
 |  | osi3::SensorData | currentSensorData
 | ) |  |
protected

Apply the predefined latency to the detected results.

The base implementation can be overriden in derived classes

Parameters
[in] | time
[in] | list | of detected objects
bool HasDetectionError ( )
protected

Rolls for the failure chance of the sensor.

Returns
true if the sensor failed. false otherwise.
double ApplyMeasurementError ( double value )
protected

Applies a measurement error to a given value.

Parameters
[in] value Value to which the error gets applied.
Returns
New value including the measurement error.
virtual osi3::SensorViewConfiguration GenerateSensorViewConfiguration ( )
protectedvirtual

Generates the basic SensorViewConfiguration.

Returns
SensorViewConfiguration for parametrization of Sensorview

Reimplemented in SensorGeometric2D.

static polygon_t CalculateBoundingBox | ( | const osi3::Dimension3d | dimension,
 |  | const osi3::Vector3d | position,
 |  | const osi3::Orientation3d | orientation
 | ) |  |
staticprotected

Calculates the bounding box of an object from the osi information.

Parameters
[in] | dimension | osi dimension
[in] | position | osi position
[in] | orientation | osi orientation
[in] | distanceReferencePointToFront | distance from the reference point to the front
Returns
bounding box of object
polygon_t TransformPolygonToGlobalCoordinates | ( | polygon_t | polygon,
 |  | point_t | sensorPositionGlobal,
 |  | double | yaw
 | ) |  | const
 protected

Translates the polygon from local coordinates to global coordinates.

Parameters
[in] | polygon | polygon in local coordinates
[in] | sensorPositionGlobal | position of the sensor in global coordinates
[in] | yaw | yaw of the sensor in global coordinates
Returns
polygon in global coordinates
virtual point_t TransformPointToLocalCoordinates | ( | point_t | point,
 |  | point_t | sensorPositionGlobal,
 |  | double | yaw
 | ) |  |
protectedvirtual

Translates a point from global coordinates to local coordinates.

Parameters
[in] | point | point in global coordinates
[in] | sensorPositionGlobal | position of the sensor in global coordinates
[in] | yaw | yaw of the sensor in global coordinates
Returns
point in local coordinates
point_t CalculateGlobalSensorPosition | ( | point_t | vehiclePosition,
 |  | double | yaw
 | ) |  | const
 protected

Calculates the position of the sensor in global coordinates.

Parameters
[in] | vehiclePosition | position of the vehicle in global coordinates
[in] | yaw | yaw of the vehicle in global coordinates
Returns
position of the sensor in global coordinates
virtual point_t CalculateRelativeVector | ( | const point_t | absolute,
 |  | const point_t | own,
 |  | double | yaw
 | ) |  |
protectedvirtual

Calculates the relative velocity or acceleration between this vehicle and another in local vehicle coordinates.

Parameters
[in] | absolute | absolute velocity/acceleration of other vehicle in global coordinates
[in] | own | absolute velocity/acceleration of own vehicle in global coordinates
[in] | yaw | yaw of own vehicle in global coordinates
Returns
relative velocity/acceleration of other vehicle in vehicle coordinates
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SensorGeometric2D Class Reference

Public Member Functions | Protected Member Functions | Private Member Functions | Static Private Member Functions | List of all members
SensorGeometric2D Class Reference
SensorObjectDetector

This file models a sensor which only detects agents in a 2D area (x/y) in front of the agent. More...

Inheritance diagram for SensorGeometric2D:
[legend]
Collaboration diagram for SensorGeometric2D:
[legend]

Public Member Functions

SensorDetectionResults DetectObjects ()
Calculate which objects are inside the detection field. More...
- Public Member Functions inherited from ObjectDetectorBase
void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
const osi3::SensorData & | getSensorData ()

Protected Member Functions

osi3::SensorViewConfiguration | GenerateSensorViewConfiguration () override
Generates the SensorViewConfiguration to send the world data for filtering of the SensorView. More...
- Protected Member Functions inherited from ObjectDetectorBase
Position GetAbsolutePosition ()
Returns the absolute position of the sensor. More...
osi3::SensorData | ApplyLatency (int time, osi3::SensorData currentSensorData)
Apply the predefined latency to the detected results. More...
bool | HasDetectionError ()
Rolls for the failure chance of the sensor. More...
double | ApplyMeasurementError (double value)
Applies a measurement error to a given value. More...
polygon_t | TransformPolygonToGlobalCoordinates (polygon_t polygon, point_t sensorPositionGlobal, double yaw) const
Translates the polygon from local coordinates to global coordinates. More...
virtual point_t | TransformPointToLocalCoordinates (point_t point, point_t sensorPositionGlobal, double yaw)
Translates a point from global coordinates to local coordinates. More...
point_t | CalculateGlobalSensorPosition (point_t vehiclePosition, double yaw) const
Calculates the position of the sensor in global coordinates. More...
virtual point_t | CalculateRelativeVector (const point_t absolute, const point_t own, double yaw)
Calculates the relative velocity or acceleration between this vehicle and another in local vehicle coordinates. More...

Private Member Functions

template<typename T >
std::pair< std::vector< T >, std::vector< T > > | CalcVisualObstruction (const std::vector< const T * > &objects, const multi_polygon_t &brightArea)
Calculate if objects in the detection field visually obstruct other objects and remove those whose visibility percentage is below the threshold. More...
polygon_t | CalcInitialBrightArea (point_t sensorPosition)
void | AddMovingObjectToSensorData (osi3::MovingObject object, point_t ownVelocity, point_t ownAcceleration, point_t ownPosition, double yaw, double yawRate)
Adds the information of a detected moving object as DetectedMovingObject to the sensor data. More...
void | AddStationaryObjectToSensorData (osi3::StationaryObject object, point_t ownPosition, double yaw)
Adds the information of a detected stationary object as DetectedStationaryObject to the sensor data. More...
bool | OpeningAngleWithinHalfCircle () const
Returns true if opening angle is smaller than pi.
bool | OpeningAngleWithinFullCircle () const
Returns true if opening angle is smaller than two pi.
polygon_t | CreateFourPointDetectionField () const
Creates the detection field for angles smaller than pi.
polygon_t | CreateFivePointDetectionField () const
Creates the detection field for angles between pi and two pi.

Static Private Member Functions

static multi_polygon_t | CalcObjectShadow (const polygon_t &boundingBox, point_t sensorPosition)
static double | CalcObjectVisibilityPercentage (const polygon_t &boundingBox, const multi_polygon_t &brightArea)

Additional Inherited Members

- Static Protected Member Functions inherited from ObjectDetectorBase
static polygon_t CalculateBoundingBox (const osi3::Dimension3d dimension, const osi3::Vector3d position, const osi3::Orientation3d orientation)
Calculates the bounding box of an object from the osi information. More...

Detailed Description

This file models a sensor which only detects agents in a 2D area (x/y) in front of the agent.

This sensor does not consider height.

Member Function Documentation

SensorDetectionResults DetectObjects ( )

Calculate which objects are inside the detection field.

For further explanation of the calculation see the documentation

osi3::SensorViewConfiguration GenerateSensorViewConfiguration ( )
overrideprotectedvirtual

Generates the SensorViewConfiguration to send the world data for filtering of the SensorView.

Returns
SensorViewConfiguration for parametrization of Sensorview

Reimplemented from ObjectDetectorBase.

std::pair<std::vector<T>, std::vector<T> > CalcVisualObstruction | ( | const std::vector< const T * > & | objects,
 |  | const multi_polygon_t & | brightArea
 | ) |  |
private

Calculate if objects in the detection field visually obstruct other objects and remove those whose visibility percentage is below the threshold.

For further explanation of the calculation see the documentation

Parameters
movingObjects | list of moving objects in the detection field for which visual obstruction should be applied
stationaryObjects | list of stationary objects in the detection field for which visual obstruction should be applied
sensorPositionGlobal | sensor postion in global coordinates
polygon_t CalcInitialBrightArea ( point_t sensorPosition )
private

Calculate the polygon to approximate the detection area

Returns
bright area polygon
static multi_polygon_t CalcObjectShadow | ( | const polygon_t & | boundingBox,
 |  | point_t | sensorPosition
 | ) |  |
staticprivate

Calculate the shadow drawn by an object with the sensorPosition as light source

Parameters
boundingBox | boundingBox of the objects which draws the shadow
sensorPosition | Position of the sensor (light source)
Returns
shadow polygon
static double CalcObjectVisibilityPercentage | ( | const polygon_t & | boundingBox,
 |  | const multi_polygon_t & | brightArea
 | ) |  |
staticprivate

Calculate how many percent of an object are inside the bright area

Parameters
boundingBox boundingBox of the object
brightArea
Returns
percentage of the visible area of the object
void AddMovingObjectToSensorData | ( | osi3::MovingObject | object,
 |  | point_t | ownVelocity,
 |  | point_t | ownAcceleration,
 |  | point_t | ownPosition,
 |  | double | yaw,
 |  | double | yawRate
 | ) |  |
private

Adds the information of a detected moving object as DetectedMovingObject to the sensor data.

Parameters
object | detected moving object
ownVelocity | velocity of own vehicle in global coordinates
ownAcceleration | acceleration of own vehicle in global coordinates
ownPosition | position of own vehicle in global coordinates
yaw | yaw of own vehicle in global coordinates
yawRate | yawRate of own vehicle in global coordinates
void AddStationaryObjectToSensorData | ( | osi3::StationaryObject | object,
 |  | point_t | ownPosition,
 |  | double | yaw
 | ) |  |
private

Adds the information of a detected stationary object as DetectedStationaryObject to the sensor data.

Parameters
object | stationary moving object
ownPosition | position of own vehicle in global coordinates
yaw | yaw of own vehicle in global coordinates
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SensorFusion

Classes
SensorFusion

This file models the SensorFusion. More...

Classes

class SensorFusionImplementation
This class is the SensorFusion module. More...

Detailed Description

This file models the SensorFusion.

This file models the SensorFusion which can be part of an agent. This module gets OSI SensorData of all sensors of the vehicle and forwards a combined SensorData to the driver assistance systems.

Inputs

Input variables:

name | meaning
sensorData | SensorData of a single sensor.

Input channel IDs:

Input Id | signal class | contained variables
0 | SensorDataSignal | sensorData

Outputs

Output variables:

name | meaning
out_sensorData | Combined SensorData from all sensors.

Output channel IDs:

Output Id | signal class | contained variables
0 | SensorDataSignal | out_sensorData
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SensorFusionImplementation Class Reference

Public Member Functions | List of all members
SensorFusionImplementation Class Reference
SensorFusion

This class is the SensorFusion module. More...

Inheritance diagram for SensorFusionImplementation:
[legend]
Collaboration diagram for SensorFusionImplementation:
[legend]

Public Member Functions

virtual void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
virtual void | Trigger (int time)
Process data within component. More...

Detailed Description

This class is the SensorFusion module.

This class contains all logic regarding the sensor fusion.

Member Function Documentation

virtual void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |

Update outputs.

Function is called by framework when this Component.has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
virtual void Trigger ( int time )
virtual

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component.

Refer to module description for information about the module's task.

Parameters
[in] time Current scheduling time
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SignalPrioritizer

Classes | Functions
SignalPrioritizer

Collects signals of same kind and relays the one with highest priority. More...

Classes

class SignalPrioritizerImplementation
This class manages the routing of signals to the sepcific components. More...

Functions

void | UpdateInput (int localLinkId, const Signal &signal, int time) override
Holds the signal if there are other with higher priority. More...
void | UpdateOutput (int localLinkId, Signal &signal, int time) override
Changes the signal to a signal on hold if there is still on on hold in the current time step. More...
void | ParseSenderPriorities (const std::map< std::string, int > &priorities)
Translates the string/int parameter representation to the internally used representation of priorities. More...
bool | IsActive (const std::shared_ptr< const ComponentStateSignalInterface > &signal) const
Checks if the provided signal is valid and in the active state. More...
bool | IsPrior (int firstSignal, int secondSignal) const
std::shared_ptr< SignalInterface const > | GetSignalWithHighestPriority () const
Returns the signal with the highest priority. More...
void | Error (std::string message) const
Helper method for reporting errors. More...

Detailed Description

Collects signals of same kind and relays the one with highest priority.

This components acts as intersection between multiple modules, potentially setting the same signals. In such a case, the signal with the highest priority will be hold until UpdateOutput is invoked.

Example: UpdateInput (t=0): BrakeSignal SenderId=2, Priority=2 UpdateInput (t=0): BrakeSignal SenderId=3, Priority=5 UpdateInput (t=0): BrakeSignal SenderId=1, Priority=1 UpdateOutput (t=0): Transmit BrakeSignal SenderId=3

The priorities are set by means of the parameter interface providing a map of "ModuleIds" (sender) and "Priority" (largest priority wins).

Function Documentation

void UpdateInput | ( | int | localLinkId,
 |  | const Signal & | signal,
 |  | int | time
 | ) |  |
override

Holds the signal if there are other with higher priority.

Parameters
[in] | signal | Signal.
[in] | time | Timestamp in milliseconds.
void UpdateOutput | ( | int | localLinkId,
 |  | Signal & | signal,
 |  | int | time
 | ) |  |
override

Changes the signal to a signal on hold if there is still on on hold in the current time step.

Parameters
[out] | signal | Signal.
[in] | time | Timestamp in milliseconds.
void ParseSenderPriorities ( const std::map< std::string, int > & priorities )
private

Translates the string/int parameter representation to the internally used representation of priorities.

Parameters
[in] priorities map linking moduleIds to priorities (larger = higher priority)
bool IsActive ( const std::shared_ptr< const ComponentStateSignalInterface > & signal ) const
private

Checks if the provided signal is valid and in the active state.

Parameters
[in] signal signal with component state
Returns
true if active
bool IsPrior | ( | int | firstSignal,
 |  | int | secondSignal
 | ) |  | const
 private

Compares the priority of two signals

Parameters
[in] | firstSignal | firstSignal
[in] | secondSignal | secondSignal
Returns
true if firstSignal has highest priority
std::shared_ptr<SignalInterface const> GetSignalWithHighestPriority ( ) const
private

Returns the signal with the highest priority.

Returns
signal with highest priority
void Error ( std::string message ) const
private

Helper method for reporting errors.

Parameters
[in] message message for to the log and thrown exception
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SignalPrioritizerImplementation Class Reference

Public Member Functions | Private Member Functions | List of all members
SignalPrioritizerImplementation Class Reference
SignalPrioritizer

This class manages the routing of signals to the sepcific components. More...

Inheritance diagram for SignalPrioritizerImplementation:
[legend]
Collaboration diagram for SignalPrioritizerImplementation:
[legend]

Public Member Functions

void | UpdateInput (int localLinkId, const Signal &signal, int time) override
Holds the signal if there are other with higher priority. More...
void | UpdateOutput (int localLinkId, Signal &signal, int time) override
Changes the signal to a signal on hold if there is still on on hold in the current time step. More...

Private Member Functions

void | ParseSenderPriorities (const std::map< std::string, int > &priorities)
Translates the string/int parameter representation to the internally used representation of priorities. More...
bool | IsActive (const std::shared_ptr< const ComponentStateSignalInterface > &signal) const
Checks if the provided signal is valid and in the active state. More...
bool | IsPrior (int firstSignal, int secondSignal) const
std::shared_ptr< SignalInterface const > | GetSignalWithHighestPriority () const
Returns the signal with the highest priority. More...
void | Error (std::string message) const
Helper method for reporting errors. More...

Detailed Description

This class manages the routing of signals to the sepcific components.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: OpenPassMaster

OpenPassMaster

Detailed Description

This is the master module of the framework and it contains the main entry point of the framework.

These executeable is started by the GUI with or without an argument to set the masterConfig.xml file. It reads the masterConfig.xml and saves all options and information. Following this a slave executable is started with the options and information as agrument.

arguments

arguments | meaning
–config | Path to master configuration file. Working directory and "masterConfig.xml" by default.

files

file | description
OpenPassMaster.log | Default name for file containing all log messages (depending on the logLevel). Path and name are specified in masterConfig.xml.
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: EventNetwork

Files | Classes
EventNetwork

Files

file eventNetwork.h
The EventNetwork manages events and can trigger functions in different framework modules.

Classes

class EventNetwork
Implements the functionality of the interface. More...

Detailed Description

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: EventNetwork Class Reference

  • SimulationSlave
  • EventNetwork
Public Member Functions | List of all members
EventNetwork Class Referencefinal
EventNetwork

Implements the functionality of the interface. More...

Inheritance diagram for EventNetwork:
[legend]
Collaboration diagram for EventNetwork:
[legend]

Public Member Functions

virtual EventContainer | GetEvents (const EventDefinitions::EventCategory eventCategory) override
Returns the active events of a specific category. More...
virtual void | InsertEvent (SharedEvent event) override
Inserts an event for the manipulators. More...
virtual void | Clear () override
Clears the event maps and resets pointers.
virtual void | AddCollision (const int agentId) override
Adds a collision id to the RunResult. More...
virtual void | Initialize (RunResultInterface *runResult) override
Initalizes the EventNetwork. More...
void | InsertTrigger (const std::string &topic, std::unique_ptr< EventInterface > event) override
Add a trigger, which is being relayed to the components. More...
std::vector< EventInterface const * > | GetTrigger (const std::string &topic) const override
Returns a collection of active trigger. More...

Detailed Description

Implements the functionality of the interface.

Member Function Documentation

virtual EventContainer GetEvents ( const EventDefinitions::EventCategory eventCategory )
overridevirtual

Returns the active events of a specific category.

Returns
List of active events.
virtual void InsertEvent ( SharedEvent event )
overridevirtual

Inserts an event for the manipulators.

Parameters
[in] event Shared pointer of the event.
virtual void AddCollision ( const int agentId )
overridevirtual

Adds a collision id to the RunResult.

Adds a collision id to the RunResult

Parameters
[in] agentId Id of the collision agent
virtual void Initialize ( RunResultInterface * runResult )
overridevirtual

Initalizes the EventNetwork.

Initalizes the EventNetwork.

Parameters
[in] runResult Pointer to the runResult.
void InsertTrigger | ( | const std::string & | topic,
 |  | std::unique_ptr< EventInterface > | event
 | ) |  |
override

Add a trigger, which is being relayed to the components.

Parameters
topic | for identification of the specific trigger
event | The according event, which is being sent
std::vector<EventInterface const *> GetTrigger ( const std::string & topic ) const
override

Returns a collection of active trigger.

Parameters
topic for identification of the specific triggers
Returns
Collection of active trigger
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: EventDetector

Classes
EventDetector

This file contains the basic EventDetector functionality. More...

Classes

class | CollisionDetector
This class detectes wether a collision happen in the simulation. More...
class | EventDetectorCommonBase
This is the parent class for all EventDetectors providing the basic functionality. More...

Detailed Description

This file contains the basic EventDetector functionality.

This file contains the basic EventDetector functionality. An EventDetector acts as Trigger for specific events. Those events are then forwarded to the EventNetwork. The EventDetector uses its access to the world and the framework to find events. Each EventDetector can have its own cycle time.

External parameters

name | meaning
triggeringAgents | Determines what agents can trigger the EventDetector.
sequenceName | Name of the sequence the EventDetector belongs to.
agentGroupName | In case there are no triggeringAgents an EventDetector can trigger to a ceratin agent group.
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CollisionDetector Class Reference

Public Member Functions | Private Member Functions | List of all members
CollisionDetector Class Reference
EventDetector

This class detectes wether a collision happen in the simulation. More...

Inheritance diagram for CollisionDetector:
[legend]
Collaboration diagram for CollisionDetector:
[legend]

Public Member Functions

virtual void | Trigger (int time)
Triggers the functionality of this class. More...
void | CalculateWorldObjectGeometry (const WorldObjectInterface *worldObject, const Common::Vector2d &position, std::array< Common::Vector2d, 4 > &resultCorners, std::array< Common::Vector2d, 2 > &resultNormals)
CalculateAgentGeometry Calculate the geometry of an agent and provide geometrical vectors. More...
void | GetWorldObjectGeometry (const WorldObjectInterface *worldObject, std::array< Common::Vector2d, 4 > &resultCorners, std::array< Common::Vector2d, 2 > &resultNormals)
GetAgentGeometry Retrieve geometrical vectors of the agent. More...
void | GetMinMax4 (std::array< double, 4 > &input, double &maxValue, double &minValue)
GetMinMax4 Retrieve the max and min value of an array of four. More...
void | GetMinMax2 (std::array< double, 2 > &input, double &maxValue, double &minValue)
GetMinMax2 Retrieve the max and min value of an array of two. More...
bool | CalculateDistOnBorder (const WorldObjectInterface *worldObject, int corner, double cornerDistance, double &result)
bool | CalculateIntersectionPoints (const WorldObjectInterface *agent, const WorldObjectInterface *other, bool &intersected, Common::Vector2d &intersectionPoint, double &otherDistanceFromCorner, int &otherFromCorner, double &agentDistanceFromInitial, Common::Vector2d &agentReferencePoint, Common::Vector2d &otherReferencePoint, size_t &agentPenetratingCorner)
bool | CalculatePointOfContact (AgentInterface *agent, const WorldObjectInterface *other, double &resultAgentDistOnBorder, double &resultOtherDistOnBorder, Common::Vector2d &resultAgentReferencePoint, Common::Vector2d &resultOtherReferencePoint)
bool | DetectCollision (const WorldObjectInterface *other, AgentInterface *agent, std::array< Common::Vector2d, NumberCorners > agentCorners, std::array< Common::Vector2d, NumberNormals > agentNormals)
- Public Member Functions inherited from EventDetectorCommonBase
virtual int | GetCycleTime () override
Returns the cycle time. More...
virtual void | Reset () override
Resets the initial state of the EventDetector.

Private Member Functions

bool | DetectIntersectionOfTwoWorldObjects (const WorldObjectInterface *agent, std::array< Common::Vector2d, NumberNormals > agentNormals, std::array< Common::Vector2d, NumberCorners > agentCorners, const WorldObjectInterface *other, std::array< Common::Vector2d, NumberNormals > otherNormals, std::array< Common::Vector2d, NumberCorners > otherCorners)
void | DetectedCollisionWithObject (int time, AgentInterface *agent, const WorldObjectInterface *other)
void | DetectedCollisionWithAgent (int time, AgentInterface *agent, AgentInterface *other)

Additional Inherited Members

- Protected Member Functions inherited from EventDetectorCommonBase
void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)
Log Provides callback to LOG() macro. More...

Detailed Description

This class detectes wether a collision happen in the simulation.

This class detects wether an agent collided with either another agent or a traffic object. In case a collision happend an event is created.

Member Function Documentation

virtual void Trigger ( int time )
virtual

Triggers the functionality of this class.

Trigger gets called each cycle timestep. This function is repsonsible for creating events

Parameters
[in] time Current time.

Implements EventDetectorCommonBase.

void CalculateWorldObjectGeometry | ( | const WorldObjectInterface * | worldObject,
 |  | const Common::Vector2d & | position,
 |  | std::array< Common::Vector2d, 4 > & | resultCorners,
 |  | std::array< Common::Vector2d, 2 > & | resultNormals
 | ) |  |

CalculateAgentGeometry Calculate the geometry of an agent and provide geometrical vectors.

Parameters
[in] | agent | agent reference
[out] | position | position vector
[out] | resultCorners | vector of corners
[out] | resultNormals | vector of normals
void GetWorldObjectGeometry | ( | const WorldObjectInterface * | worldObject,
 |  | std::array< Common::Vector2d, 4 > & | resultCorners,
 |  | std::array< Common::Vector2d, 2 > & | resultNormals
 | ) |  |

GetAgentGeometry Retrieve geometrical vectors of the agent.

Parameters
[in] | agent | agent reference
[out] | resultCorners | vector of corners
[out] | resultNormals | vector of normals
void GetMinMax4 | ( | std::array< double, 4 > & | input,
 |  | double & | maxValue,
 |  | double & | minValue
 | ) |  |

GetMinMax4 Retrieve the max and min value of an array of four.

Parameters
[in] | input | input array with four double values
[out] | maxValue | maximal value
[out] | minValue | minimal value
void GetMinMax2 | ( | std::array< double, 2 > & | input,
 |  | double & | maxValue,
 |  | double & | minValue
 | ) |  |

GetMinMax2 Retrieve the max and min value of an array of two.

Parameters
[in] | input | input array with two double values
[out] | maxValue | maximal value
[out] | minValue | minimal value
bool CalculateDistOnBorder | ( | const WorldObjectInterface * | worldObject,
 |  | int | corner,
 |  | double | cornerDistance,
 |  | double & | result
 | ) |  |

Calculates distance of point of impact based on agent geometry.

Parameters
[in] | agent | pointer to agent
[in] | corner | corner from which cornerDistance is measured (clockwise)
[in] | cornerDistance | distance from previous corner to point of impact
[out] | result | distance from upper left corner on agent border to point of impact
Returns
true for success
bool CalculateIntersectionPoints | ( | const WorldObjectInterface * | agent,
 |  | const WorldObjectInterface * | other,
 |  | bool & | intersected,
 |  | Common::Vector2d & | intersectionPoint,
 |  | double & | otherDistanceFromCorner,
 |  | int & | otherFromCorner,
 |  | double & | agentDistanceFromInitial,
 |  | Common::Vector2d & | agentReferencePoint,
 |  | Common::Vector2d & | otherReferencePoint,
 |  | size_t & | agentPenetratingCorner
 | ) |  |

Calculates parameters of intersection point

The velocity of the first agent is transformed relatively to the second agent whose position is kept constant. After this transformation each corner of the fist agent is tested for collision separately. The corner which penetrates first into the body of the second agent determines the result.

Parameters
[in] | agent | pointer to first agent
[in] | other | pointer to second agent
[out] | intersectionPoint | point of intersection
[out] | intersected | indicates if intersection occurred
[out] | otherDistanceFromCorner | indicates distance on border of second agent where first agent penetrated (measured clockwise from previous corner)
[out] | otherFromCorner | number of start corner of edge where first agent penetrated (counted clockwise)
[out] | agentDistanceFromInitial | scaling value of direction vector until first agent penetrates into second agent (measured from initial position of first agent after relative transformation)
[out] | agentReferencePoint | position of reference point of first agent at point of collision
[out] | otherReferencePoint | position of reference point of second agent at point of collision
[out] | agentPenetratingCorner | corner of first agent which penetrated into second agent
Returns
indicates if intersection point could be calculated correctly
bool CalculatePointOfContact | ( | AgentInterface * | agent,
 |  | const WorldObjectInterface * | other,
 |  | double & | resultAgentDistOnBorder,
 |  | double & | resultOtherDistOnBorder,
 |  | Common::Vector2d & | resultAgentReferencePoint,
 |  | Common::Vector2d & | resultOtherReferencePoint
 | ) |  |

Calculates parameters of point of contact

Parameters
[in] | agent | pointer to agent
[in] | other | pointer to other agent
[out] | resultAgentDistOnBorder | distance of point of contact on agent border (counted clockwise from upper left corner)
[out] | resultOtherDistOnBorder | distance of point of contact on other agents border (counted clockwise from upper left corner)
[out] | resultAgentReferencePoint | position of center of gravity of agent at point of contact
[out] | resultOtherReferencePoint | position of center of gravity of agent at point of contact
Returns
indicates if impact parameters could be calculated correctly
bool DetectCollision | ( | const WorldObjectInterface * | other,
 |  | AgentInterface * | agent,
 |  | std::array< Common::Vector2d, NumberCorners > | agentCorners,
 |  | std::array< Common::Vector2d, NumberNormals > | agentNormals
 | ) |  |

Check For Collision between worldObjects

Parameters
[in] | other | pointer to worldObject
[in] | agent | pointer to agent
[in] | agentCorners | agent corners
[in] | agentNormals | agent normals
Returns
true when collision detected
bool DetectIntersectionOfTwoWorldObjects | ( | const WorldObjectInterface * | agent,
 |  | std::array< Common::Vector2d, NumberNormals > | agentNormals,
 |  | std::array< Common::Vector2d, NumberCorners > | agentCorners,
 |  | const WorldObjectInterface * | other,
 |  | std::array< Common::Vector2d, NumberNormals > | otherNormals,
 |  | std::array< Common::Vector2d, NumberCorners > | otherCorners
 | ) |  |
private

Check For Collision between worldObjects

Parameters
[in] | agent | pointer to agent
[in] | agentNormals | world object normals
[in] | agentCorners | world object corners
[in] | other | pointer to other agent/object
[in] | otherNormals | world object normals
[in] | otherCorners | world object corners
Returns
true when collision detected
void DetectedCollisionWithObject | ( | int | time,
 |  | AgentInterface * | agent,
 |  | const WorldObjectInterface * | other
 | ) |  |
private

Creates a CollisionEvent and inserts it into the event network

Parameters
[in] | time
[in] | agent | pointer to agent
[in] | other | pointer to other world object
void DetectedCollisionWithAgent | ( | int | time,
 |  | AgentInterface * | agent,
 |  | AgentInterface * | other
 | ) |  |
private

Creates a CollisionEvent and inserts it into the event network

Parameters
[in] | time
[in] | agent | pointer to agent
[in] | other | pointer to other agent
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: EventDetectorCommonBase Class Reference

Public Member Functions | Protected Member Functions | List of all members
EventDetectorCommonBase Class Referenceabstract
EventDetector

This is the parent class for all EventDetectors providing the basic functionality. More...

Inheritance diagram for EventDetectorCommonBase:
[legend]
Collaboration diagram for EventDetectorCommonBase:
[legend]

Public Member Functions

void | Trigger (int time) override=0
Triggers the functionality of this class. More...
virtual int | GetCycleTime () override
Returns the cycle time. More...
virtual void | Reset () override
Resets the initial state of the EventDetector.

Protected Member Functions

void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)
Log Provides callback to LOG() macro. More...

Detailed Description

This is the parent class for all EventDetectors providing the basic functionality.

Member Function Documentation

void Trigger ( int time )
overridepure virtual

Triggers the functionality of this class.

Trigger gets called each cycle timestep. This function is repsonsible for creating events

Parameters
[in] time Current time.

Implemented in CollisionDetector.

virtual int GetCycleTime ( )
overridevirtual

Returns the cycle time.

Returns
cycle time.
void Log | ( | CbkLogLevel | logLevel,
 |  | const char * | file,
 |  | int | line,
 |  | const std::string & | message
 | ) |  |
protected

Log Provides callback to LOG() macro.

Parameters
[in] | logLevel | Importance of log
[in] | file | Name of file where log is called
[in] | line | Line within file where log is called
[in] | message | Message to log
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Manipulator

Classes
Manipulator

This file contains the basic Manipulator functionality. More...

Classes

class | CollisionManipulator
This class notifies all relevant modules about the collision. More...
struct | CollisionManipulator::CrashInfo
class | ComponentStateChangeManipulator
This class toggles an assistance system. More...
class | LaneChangeManipulator
This class removes an agent. More...
class | ManipulatorCommonBase
This is the parent class for all Manipulators providing the basic functionality. More...
class | NoOperationManipulator
This class is a manipulator, that doesn't trigger any action and solely returns the event. It existes to met the OpenSCENARIO conventions. More...
class | RemoveAgentsManipulator
This class removes an agent. More...
class | SpeedActionManipulator
This class emits the SpeedActionEvent. More...
class | CollisionDetectionPostCrash
Collision component that calculates post-crash dynamics. More...
class | TrajectoryManipulator
This manipulator sets a trajectory for an agent. More...

Detailed Description

This file contains the basic Manipulator functionality.

This file contains the basic Manipulator functionality. A Manipulator acts upon a specific event. The Manipulator usually influences agents or framework modules. Each Manipulator can have its own cycle time.

External parameters

name | meaning
eventTypes | Event types which trigger the manipulator.
actorNames | Names of acting agents.
sequenceName | Name of the sequence the Manipulator belongs to.
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CollisionManipulator Class Reference

Classes | Public Member Functions | Private Member Functions | Private Attributes | List of all members
CollisionManipulator Class Reference
Manipulator

This class notifies all relevant modules about the collision. More...

Inheritance diagram for CollisionManipulator:
[legend]
Collaboration diagram for CollisionManipulator:
[legend]

Classes

struct CrashInfo

Public Member Functions

virtual void | Trigger (int time) override
Triggers the functionality of this class. More...
- Public Member Functions inherited from ManipulatorCommonBase
virtual int | GetCycleTime ()
Returns the cycle time. More...

Private Member Functions

void UpdateCollision (AgentInterface *agent, AgentInterface *opponent)

Private Attributes

CollisionDetectionPostCrash collisionPostCrash
Handles the calculation of post crash dynamics.

Additional Inherited Members

- Protected Member Functions inherited from ManipulatorCommonBase
void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)
Log Provides callback to LOG() macro. More...

Detailed Description

This class notifies all relevant modules about the collision.

This class notifies the event network and the colliding agents about the collision.

Member Function Documentation

virtual void Trigger ( int time )
overridevirtual

Triggers the functionality of this class.

Trigger gets called each cycle timestep. This function is repsonsible for creating events

Parameters
[in] time Current time.

Implements ManipulatorCommonBase.

void UpdateCollision | ( | AgentInterface * | agent,
 |  | AgentInterface * | opponent
 | ) |  |
private

This function updates the collisionPartners of the agent, the opponent and recursively of all existing collisionPartners of both.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CollisionManipulator::CrashInfo Struct Reference

  • CollisionManipulator
  • CrashInfo
List of all members
CollisionManipulator::CrashInfo Struct Reference
Manipulator
Collaboration diagram for CollisionManipulator::CrashInfo:
[legend]
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ComponentStateChangeManipulator Class Reference

Public Member Functions | List of all members
ComponentStateChangeManipulator Class Reference
Manipulator

This class toggles an assistance system. More...

Inheritance diagram for ComponentStateChangeManipulator:
[legend]
Collaboration diagram for ComponentStateChangeManipulator:
[legend]

Public Member Functions

virtual void | Trigger (int time) override
Triggers the functionality of this class. More...
- Public Member Functions inherited from ManipulatorCommonBase
virtual int | GetCycleTime ()
Returns the cycle time. More...

Additional Inherited Members

- Protected Member Functions inherited from ManipulatorCommonBase
void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)
Log Provides callback to LOG() macro. More...

Detailed Description

This class toggles an assistance system.

This manipulator toggles the max state of a component Therefore it needs the name of the component and the state in which it should be put.

Member Function Documentation

virtual void Trigger ( int time )
overridevirtual

Triggers the functionality of this class.

Trigger gets called each cycle timestep. This function is repsonsible for creating events

Parameters
[in] time Current time.

Implements ManipulatorCommonBase.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneChangeManipulator Class Reference

Public Member Functions | List of all members
LaneChangeManipulator Class Reference
Manipulator

This class removes an agent. More...

Inheritance diagram for LaneChangeManipulator:
[legend]
Collaboration diagram for LaneChangeManipulator:
[legend]

Public Member Functions

virtual void | Trigger (int time) override
Triggers the functionality of this class. More...
- Public Member Functions inherited from ManipulatorCommonBase
virtual int | GetCycleTime ()
Returns the cycle time. More...

Additional Inherited Members

- Protected Member Functions inherited from ManipulatorCommonBase
void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)
Log Provides callback to LOG() macro. More...

Detailed Description

This class removes an agent.

This class removes the agent.

Member Function Documentation

virtual void Trigger ( int time )
overridevirtual

Triggers the functionality of this class.

Trigger gets called each cycle timestep. This function is repsonsible for creating events

Parameters
[in] time Current time.

Implements ManipulatorCommonBase.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ManipulatorCommonBase Class Reference

Public Member Functions | Protected Member Functions | List of all members
ManipulatorCommonBase Class Referenceabstract
Manipulator

This is the parent class for all Manipulators providing the basic functionality. More...

Inheritance diagram for ManipulatorCommonBase:
[legend]
Collaboration diagram for ManipulatorCommonBase:
[legend]

Public Member Functions

virtual void | Trigger (int time)=0
Triggers the functionality of this class. More...
virtual int | GetCycleTime ()
Returns the cycle time. More...

Protected Member Functions

void | Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)
Log Provides callback to LOG() macro. More...
virtual EventContainer | GetEvents ()=0
Returns all current triggering events. More...

Detailed Description

This is the parent class for all Manipulators providing the basic functionality.

Member Function Documentation

virtual void Trigger ( int time )
pure virtual

Triggers the functionality of this class.

Trigger gets called each cycle timestep. This function is repsonsible for creating events

Parameters
[in] time Current time.

Implemented in ComponentStateChangeManipulator, CollisionManipulator, SpeedActionManipulator, LaneChangeManipulator, RemoveAgentsManipulator, and TrajectoryManipulator.

virtual int GetCycleTime ( )
virtual

Returns the cycle time.

Returns
cycle time.
void Log | ( | CbkLogLevel | logLevel,
 |  | const char * | file,
 |  | int | line,
 |  | const std::string & | message
 | ) |  |
protected

Log Provides callback to LOG() macro.

Parameters
[in] | logLevel | Importance of log
[in] | file | Name of file where log is called
[in] | line | Line within file where log is called
[in] | message | Message to log
virtual EventContainer GetEvents ( )
protectedpure virtual

Returns all current triggering events.

Returns all triggering events which are currently in the event network. Filters according to the defined event types.

param[in] manipulated event

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: NoOperationManipulator Class Reference

List of all members
NoOperationManipulator Class Reference
Manipulator

This class is a manipulator, that doesn't trigger any action and solely returns the event. It existes to met the OpenSCENARIO conventions. More...

Inheritance diagram for NoOperationManipulator:
[legend]
Collaboration diagram for NoOperationManipulator:
[legend]

Additional Inherited Members

- Public Member Functions inherited from ManipulatorCommonBase
virtual int | GetCycleTime ()
Returns the cycle time. More...
- Protected Member Functions inherited from ManipulatorCommonBase
void | Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)
Log Provides callback to LOG() macro. More...

Detailed Description

This class is a manipulator, that doesn't trigger any action and solely returns the event. It existes to met the OpenSCENARIO conventions.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RemoveAgentsManipulator Class Reference

Public Member Functions | List of all members
RemoveAgentsManipulator Class Reference
Manipulator

This class removes an agent. More...

Inheritance diagram for RemoveAgentsManipulator:
[legend]
Collaboration diagram for RemoveAgentsManipulator:
[legend]

Public Member Functions

virtual void | Trigger (int time) override
Triggers the functionality of this class. More...
- Public Member Functions inherited from ManipulatorCommonBase
virtual int | GetCycleTime ()
Returns the cycle time. More...

Additional Inherited Members

- Protected Member Functions inherited from ManipulatorCommonBase
void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)
Log Provides callback to LOG() macro. More...

Detailed Description

This class removes an agent.

This class removes the agent.

Member Function Documentation

virtual void Trigger ( int time )
overridevirtual

Triggers the functionality of this class.

Trigger gets called each cycle timestep. This function is repsonsible for creating events

Parameters
[in] time Current time.

Implements ManipulatorCommonBase.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpeedActionManipulator Class Reference

Public Member Functions | List of all members
SpeedActionManipulator Class Reference
Manipulator

This class emits the SpeedActionEvent. More...

Inheritance diagram for SpeedActionManipulator:
[legend]
Collaboration diagram for SpeedActionManipulator:
[legend]

Public Member Functions

virtual void | Trigger (int time)
Triggers the functionality of this class. More...
- Public Member Functions inherited from ManipulatorCommonBase
virtual int | GetCycleTime ()
Returns the cycle time. More...

Additional Inherited Members

- Protected Member Functions inherited from ManipulatorCommonBase
void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)
Log Provides callback to LOG() macro. More...

Detailed Description

This class emits the SpeedActionEvent.

This class emits the SpeedActionEvent which allows for an acceleration manipulation of actors.

Member Function Documentation

virtual void Trigger ( int time )
virtual

Triggers the functionality of this class.

Trigger gets called each cycle timestep. This function is repsonsible for creating events

Parameters
[in] time Current time.

Implements ManipulatorCommonBase.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CollisionDetectionPostCrash Class Reference

Public Member Functions | Protected Member Functions | Private Member Functions | List of all members
CollisionDetectionPostCrash Class Reference
Manipulator

Collision component that calculates post-crash dynamics. More...

Collaboration diagram for CollisionDetectionPostCrash:
[legend]

Public Member Functions

bool | CreatePostCrashDynamics (const AgentInterface *agent1, const AgentInterface *agent2, PostCrashDynamic *postCrashDynamic1, PostCrashDynamic *postCrashDynamic2, int &timeOfFirstContact)
Calculate and store collision data Calculates collision time and post-crash dynamics. More...
CollisionAngles GetCollisionAngles ()
Retrieve collision angles. More...
void | SetCollisionAngles (double OYA, double HCPAo, double OCPAo, double HCPA, double OCPA)
Sets collision angles as defined in http://indexsmart.mirasmart.com/26esv/PDFfiles/26ESV-000177.pdf. More...

Protected Member Functions

void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)
logs messages Provides callback to LOG() macro More...

Private Member Functions

std::vector< Common::Vector2d > | GetAgentCorners (const AgentInterface *agent)
Gets corners of one agent Agents are treated as rectangles. Agent corners are calculated from agent geometry parameters, current position and current yaw angle. More...
std::vector< Common::Vector2d > | CalculateAllIntersectionPoints (std::vector< Common::Vector2d > corners1, std::vector< Common::Vector2d > corners2)
Calculates points of intersection of two rectangles The intersection area of two rectangles is a polygon. This method calculates the corners of the intersection polygon. More...
bool | GetIntersectionPoint (Common::Vector2d n1, Common::Vector2d n2, double d1, double d2, Common::Vector2d &intersectionPoint)
Calculates intersection point of two vectors The calculation is based on describing the vectors using the Hesse normal form. More...
bool | GetFirstContact (const AgentInterface *agent1, const AgentInterface *agent2, int &timeFirstContact)
calculates time of first constact The time of the first contact of two colliding agents is estimated. It is assumed that the velocity vectors between the time of first contact and the current time (where a collision has been detected) are constant. Yaw velocities are not taken into account since they are not provided by openPASS currently. More...
void | CalculateCollisionAngles (const AgentInterface *agent1, const AgentInterface *agent2, int timeFirstContact)
calculates collision angles The time of the first contact of two colliding agents is used to calculate the first point of contact. Based on this first point of contact, the collision angles are calculated. More...
bool | CalculatePlaneOfContact (Polygon intersection, std::vector< int > vertexTypes, Common::Vector2d &pointOfImpact, double &phi)
Calculates contact plane of two colliding agents. More...
bool | CalculatePostCrashDynamic (Common::Vector2d cog1, const AgentInterface *agent1, Common::Vector2d cog2, const AgentInterface *agent2, Common::Vector2d poi, double phi, PostCrashDynamic *postCrashDynamic1, PostCrashDynamic *postCrashDynamic2)
Calculate post-crash dynamics The post-crash dynamics is calculated based on conservation of momentum and angular momentum. It works in 2D and is only valid for non-sliding collisions. More...
std::vector< int > | GetVertexTypes (std::vector< Common::Vector2d > vertices1, std::vector< Common::Vector2d > vertices2, std::vector< Common::Vector2d > verticesIntersection)
Calculates vertex types of intersection polygon. More...
Common::Vector2d | GetAgentVelocityVector (const AgentInterface *agent)
Get vector of the agent velocity Retrieve the vector of the velocity of an agent in the global coordinate system. More...
bool | ShiftPolygonsAndCheckIntersection (Polygon polygon1, Polygon polygon2, Common::Vector2d shiftVector1, Common::Vector2d shiftVector2)
shifts 2 polygons and checks if the shifted polygons are intersecting Shift two polygons along their shift vectors and check if they are intersecting each other. More...
bool | GetCollisionPosition (const AgentInterface *agent1, const AgentInterface *agent2, Common::Vector2d &cog1, Common::Vector2d &cog2, Common::Vector2d &pointOfImpact, double &phi, int timeFirstContact)
Get geometry data at collision time Calculate the geometry parameters of the collision of two agents at a time (time of first contact + penetration time). Geometry data comprise. More...

Private Attributes

Internal Parameter

Parameters for model of post-crash dynamics

double | coeffRest = 0.3
coefficient of restitution [1]
double | interFriction = 0.3
Inter-vehicle friction [1].
CollisionAngles collAngles
collision angles [degrees] as defined in http://indexsmart.mirasmart.com/26esv/PDFfiles/26ESV-000177.pdf
int | penetrationTime = 30
time for overlapping vehicles [ms]

Detailed Description

Collision component that calculates post-crash dynamics.

  • The algorithms for collision detection and calculation of the post-crash dynamics are based on algorithms provided by Harald Kolk (TU Graz).

The algorithm for collision dection is based on the Sutherland–Hodgman algorithm for polygon clipping.

The algorithm for calculating the post-crash-dynamics is based on conservation of momentum and angular momentum. It works in 2D and is only valid for non-sliding collisions.

Note that this module is provisional regarding several aspect. openPASS needs to be changed in order to improve the following:

  • The post-crash dynamics is currently only calculated and written to the log-file since openPASS does not allow to forward the results to dynamic-components and observation modules, currently.
  • This module needs several parameters (coeffRest, interFriction and timeOfPenetration). openPASS currently does not allow to set parameters for this module in the config files. Therefore, these parameters are hard-coded.
  • The calculation of the post-crash dynamics is based on the assumptions that the time where the collision starts is known since the post-crash dynamics shall be calculated a certain time ( given by the parameter timeOfPenetration ) after the first contact of the vehicles. Currently, this module does not know anything about sample rates etc. which makes it difficult to find the correct time to calculate the post-crash dynamics.
  • The algorithm for the post-crash dynamics uses the pre-crash yaw velocities of both agents. Since the yaw velocity is not available for the agents currently, the yaw velocities are set to zero here.

Note:

  • The method GetVertexTypes in collisionDetection assumes that the intersection of the two vehicles is rather small. It has not been checked if the method covers all possible cases for bigger intersections which are possible in openPASS depending on the cycle times.

Member Function Documentation

bool CreatePostCrashDynamics | ( | const AgentInterface * | agent1,
 |  | const AgentInterface * | agent2,
 |  | PostCrashDynamic * | postCrashDynamic1,
 |  | PostCrashDynamic * | postCrashDynamic2,
 |  | int & | timeOfFirstContact
 | ) |  |

Calculate and store collision data Calculates collision time and post-crash dynamics.

Parameters
[in] | agent1 | 1st agent
[in] | agent2 | 2nd agent
[out] | postCrashDynamic1 | postCrashDynamic for first agent
[out] | postCrashDynamic2 | postCrashDynamic for second agent
Returns
true if postCrashDynamics are created successfully
CollisionAngles GetCollisionAngles ( )

Retrieve collision angles.

Returns
collision angles
void SetCollisionAngles | ( | double | OYA,
 |  | double | HCPAo,
 |  | double | OCPAo,
 |  | double | HCPA,
 |  | double | OCPA
 | ) |  |

Sets collision angles as defined in http://indexsmart.mirasmart.com/26esv/PDFfiles/26ESV-000177.pdf.

Parameters
[in] | OYA | opponent yaw angle relative to host yaw angle
[in] | HCPAo | original host collision point angle
[in] | OCPAo | original opponent collision point angle
[in] | HCPA | transformed host collision point angle
[in] | OCPA | transformed opponent collision point angle
void Log | ( | CbkLogLevel | logLevel,
 |  | const char * | file,
 |  | int | line,
 |  | const std::string & | message
 | ) |  |
inlineprotected

logs messages Provides callback to LOG() macro

Parameters
[in] | logLevel | Importance of log
[in] | file | Name of file where log is called
[in] | line | Line within file where log is called
[in] | message | Message to log
std::vector<Common::Vector2d> GetAgentCorners ( const AgentInterface * agent )
private

Gets corners of one agent Agents are treated as rectangles. Agent corners are calculated from agent geometry parameters, current position and current yaw angle.

Parameters
[in] agent agent reference
Returns
agent corners
std::vector<Common::Vector2d> CalculateAllIntersectionPoints | ( | std::vector< Common::Vector2d > | corners1,
 |  | std::vector< Common::Vector2d > | corners2
 | ) |  |
private

Calculates points of intersection of two rectangles The intersection area of two rectangles is a polygon. This method calculates the corners of the intersection polygon.

The algorithm is based on the Sutherland-Hodgman-Algorith for polygon clipping and MATLAB-code provided by Harald Kolk (TU Graz). It assumes the corners to be ordered conter-clockwise.

See also: http://stackoverflow.com/questions/13101288/intersection-of-two-convex-polygons

Parameters
agentCorner1[in] | corners of first agent
agentCorner2[in] | corners second agent
Returns
vector of of intersection points
bool GetIntersectionPoint | ( | Common::Vector2d | n1,
 |  | Common::Vector2d | n2,
 |  | double | d1,
 |  | double | d2,
 |  | Common::Vector2d & | intersectionPoint
 | ) |  |
private

Calculates intersection point of two vectors The calculation is based on describing the vectors using the Hesse normal form.

Parameters
n1[in] | normal vector of 1st vector
n2[in] | normal vector of 2nd vestor
d1[in] | distance from point of origin of first vector
d2[in] | distance from point of origin of second vector
intersectionPoint[out] | vector intersection point
Returns
flag indicating if calculation could be done correctly
bool GetFirstContact | ( | const AgentInterface * | agent1,
 |  | const AgentInterface * | agent2,
 |  | int & | timeFirstContact
 | ) |  |
private

calculates time of first constact The time of the first contact of two colliding agents is estimated. It is assumed that the velocity vectors between the time of first contact and the current time (where a collision has been detected) are constant. Yaw velocities are not taken into account since they are not provided by openPASS currently.

The time is given relative to the current time. The time at this timestep is 0, so the time in the past will be negative.

Parameters
[in] | agent1 | first agent to consider
[in] | agent2 | other agent to consider
[out] | firstTimeContact | time of first contact –> negative since in the past [ms]
Returns
flag indicating if calculation could be done correctly
void CalculateCollisionAngles | ( | const AgentInterface * | agent1,
 |  | const AgentInterface * | agent2,
 |  | int | timeFirstContact
 | ) |  |
private

calculates collision angles The time of the first contact of two colliding agents is used to calculate the first point of contact. Based on this first point of contact, the collision angles are calculated.

Parameters
[in] | agent1 | first agent to consider
[in] | agent2 | other agent to consider
[in] | firstTimeContact | time of first contact –> negative since in the past [ms]
bool CalculatePlaneOfContact | ( | Polygon | intersection,
 |  | std::vector< int > | vertexTypes,
 |  | Common::Vector2d & | pointOfImpact,
 |  | double & | phi
 | ) |  |
private

Calculates contact plane of two colliding agents.

PC-Crash method for setting the contact plane. Simply sets the plane as line through two nodes of vertex type = 2, moved parallel to the centroid of the intersection poygon.

The contact plane is described by the point of impact (beeing the centroid of the intersection polygon) and the angle of the contact plane (line in 2D).

The algorithm is based on MATLAB-code provided by Harald Kolk (TU Graz).

Parameters
[in] | intersection | intersection polygon of the two colliding agent
[in] | vertexTypes | vector of vertex types (see GetVertexTypes)
[out] | pointOfImpact | Centroid of the intersecting polygon
[out] | phi | Angle of the contact plane
Returns
flag indicating if contact plane could be calculated correctly
bool CalculatePostCrashDynamic | ( | Common::Vector2d | cog1,
 |  | const AgentInterface * | agent1,
 |  | Common::Vector2d | cog2,
 |  | const AgentInterface * | agent2,
 |  | Common::Vector2d | poi,
 |  | double | phi,
 |  | PostCrashDynamic * | postCrashDynamic1,
 |  | PostCrashDynamic * | postCrashDynamic2
 | ) |  |
private

Calculate post-crash dynamics The post-crash dynamics is calculated based on conservation of momentum and angular momentum. It works in 2D and is only valid for non-sliding collisions.

The algorithm is based on MATLAB-code provided by Harald Kolk (TU Graz).

Parameters
[in] | cog1 | center of gravity of first agent
[in] | agent1 | first agent
[in] | cog2 | center of gravity of second agent
[in] | agent2 | second agent
[in] | poi | point of impact (2d-vector)
[in] | phi | angle of contact plane [rad]
[out] | postCrashDynamic1 | PostCrashDynamic of first agent
[out] | postCrashDynamic2 | PostCrashDynamic of second agent
Returns
true if calculation was successful
std::vector<int> GetVertexTypes | ( | std::vector< Common::Vector2d > | vertices1,
 |  | std::vector< Common::Vector2d > | vertices2,
 |  | std::vector< Common::Vector2d > | verticesIntersection
 | ) |  |
private

Calculates vertex types of intersection polygon.

Vertex types: 1: vertex can be found among the vertices of the intersecting polyons. 2: vertex is the intersection of two edges of the two original polygons. 3: Special case for perfectly straight impacts with parallel intersecting edges.

Note: This algorithm assumes that the intersection of the two vehicles is rather small. It has not been checked if it covers all possible cases for bigger intersections which are possible in openPASS depending on the cycle times.

The algorithm is based on MATLAB-code provided by Harald Kolk (TU Graz).

Parameters
[in] | vertices1 | vertices of rectangle of agent1
[in] | vertices2 | vertices of rectangle of agent2
[in] | verticesIntersection | vertices of intersection polygon
Returns
vertex types of vertices of intersection polygon
Common::Vector2d GetAgentVelocityVector ( const AgentInterface * agent )
private

Get vector of the agent velocity Retrieve the vector of the velocity of an agent in the global coordinate system.

Parameters
[in] agent agent
Returns
vector (x,y) of the velocity of the agent
bool ShiftPolygonsAndCheckIntersection | ( | Polygon | polygon1,
 |  | Polygon | polygon2,
 |  | Common::Vector2d | shiftVector1,
 |  | Common::Vector2d | shiftVector2
 | ) |  |
private

shifts 2 polygons and checks if the shifted polygons are intersecting Shift two polygons along their shift vectors and check if they are intersecting each other.

Parameters
[in] | polygon1 | first polygon
[in] | polygon2 | second polygon
[in] | shiftVector1 | shift vector of first polygon
[in] | shiftVector2 | shift vector of seond polygon
Returns
true if they are intersecting each other after shifting, false otherwise
bool GetCollisionPosition | ( | const AgentInterface * | agent1,
 |  | const AgentInterface * | agent2,
 |  | Common::Vector2d & | cog1,
 |  | Common::Vector2d & | cog2,
 |  | Common::Vector2d & | pointOfImpact,
 |  | double & | phi,
 |  | int | timeFirstContact
 | ) |  |
private

Get geometry data at collision time Calculate the geometry parameters of the collision of two agents at a time (time of first contact + penetration time). Geometry data comprise.

  • center of gravity of both agents
  • paramters describing the contact plane (point of impact and angle)
Parameters
[in] | agent1 | first agent
[in] | agent2 | second agent
[out] | cog1 | center of gravity of first agent
[out] | cog2 | center of gravity of second agent
[out] | pointOfImpact | vector of the point of impact
[out] | phi | angle of the contact plane
Returns
true if calculation was successful
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TrajectoryManipulator Class Reference

Public Member Functions | List of all members
TrajectoryManipulator Class Reference
Manipulator

This manipulator sets a trajectory for an agent. More...

Inheritance diagram for TrajectoryManipulator:
[legend]
Collaboration diagram for TrajectoryManipulator:
[legend]

Public Member Functions

virtual void | Trigger (int time) override
Triggers the functionality of this class. More...
- Public Member Functions inherited from ManipulatorCommonBase
virtual int | GetCycleTime ()
Returns the cycle time. More...

Additional Inherited Members

- Protected Member Functions inherited from ManipulatorCommonBase
void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)
Log Provides callback to LOG() macro. More...

Detailed Description

This manipulator sets a trajectory for an agent.

This manipulator sets a trajectory for an agent.

Member Function Documentation

virtual void Trigger ( int time )
overridevirtual

Triggers the functionality of this class.

Trigger gets called each cycle timestep. This function is repsonsible for creating events

Parameters
[in] time Current time.

Implements ManipulatorCommonBase.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: openPASS CoreModules basic

Modules
openPASS CoreModules basic
Collaboration diagram for openPASS CoreModules basic:

Modules

Observation_State
logs the current X position of every agent at each time step.
Observation_Ttc
logs the time to collision (ttc) of all agents
SpawnPoint_Start
Spawn agents at the beginning of road.
World_Basic
implementation of a world interface

Detailed Description

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Observation_State

Classes | Variables
Observation_State
openPASS CoreModules basic

logs the current X position of every agent at each time step. More...

Collaboration diagram for Observation_State:

Classes

class Observation_State_Implementation
logs the current X position of every agent at each time step. More...

Variables

std::vector< int > | timeChannel
time values
std::map< std::string, std::vector< std::string > > | channels
samples
int | runNumber = 0
run number

External Parameters

bool Par_WriteOutputForVisualisation = true
This flag states whether an output for visualisation should be written out or not.

Detailed Description

logs the current X position of every agent at each time step.

This component logs the states of the agents that are necessary for the visualisation or the evaluation into a file.

The file format is xml to easily access time series or statistics data in an arbitrary editor.

This component in this version is just for debug purpose.

Inputs

none

Outputs

none

Parameters to be specified in runConfiguration.xml

type | id | meaning | corresponding external paramter
string | 0 | folder where simulation output shall be stored | Par_folder
string | 1 | filename for temporary simulation output | Par_tmpFilename
string | 2 | filename for final simulation output (*.xml) | Par_finalFilename
bool | 0 | flag if visualization data shall be written to file | Par_WriteOutputForVisualisation
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Observation_State_Implementation Class Reference

Public Member Functions | Private Attributes | List of all members
Observation_State_Implementation Class Reference
openPASS CoreModules basic » Observation_State

logs the current X position of every agent at each time step. More...

Inheritance diagram for Observation_State_Implementation:
[legend]
Collaboration diagram for Observation_State_Implementation:
[legend]

Public Member Functions

virtual void | MasterPreHook ()
Called by framework in master before each simulation run starts.
virtual void | MasterPostHook (const std::string &filename)
virtual void | SlavePreRunHook ()
Called by framework in slave before each simulation run starts.
virtual void | SlaveUpdateHook (int time, RunResultInterface &runResult)
virtual void | SlavePostRunHook (const RunResultInterface &runResult)
virtual void | SlavePostHook ()
Called by framework in slave after all simulation runs end.
virtual const std::string | SlaveResultFile ()

Private Attributes

std::vector< int > | timeChannel
time values
std::map< std::string, std::vector< std::string > > | channels
samples
int | runNumber = 0
run number
External Parameters
bool | Par_WriteOutputForVisualisation = true
This flag states whether an output for visualisation should be written out or not.

Detailed Description

logs the current X position of every agent at each time step.

This component logs the states of the agents that are necessary for the visualisation or the evaluation into a file.

The file format is xml to easily access time series or statistics data in an arbitrary editor.

This component in this version is just for debug purpose.

Member Function Documentation

virtual void MasterPostHook ( const std::string & filename )
inlinevirtual

Called by framework in master after each simulation run ends

Parameters
[in] filename Name of file containing the simulation run results from the slave
virtual void SlaveUpdateHook | ( | int | time,
 |  | RunResultInterface & | runResult
 | ) |  |
virtual

Called by framework in slave at each time step. Observation module can indicate end of simulation run here.

Parameters
[in] | time | Current scheduling time
[in,out] | runResult | Reference to run result
virtual void SlavePostRunHook ( const RunResultInterface & runResult )
virtual

Called by framework in slave after each simulation run ends. Observation module can observe the current simulation run here.

Parameters
[in] runResult Reference to run result
virtual const std::string SlaveResultFile ( )
inlinevirtual

Called by framework in slave after all simulation runs end to transfer the observation module results to the master.

Returns
File to be transferred
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Observation_Ttc

Classes | Variables
Observation_Ttc
openPASS CoreModules basic

logs the time to collision (ttc) of all agents More...

Collaboration diagram for Observation_Ttc:

Classes

class Observation_Ttc_Implementation
logs the time to collision (ttc) of all agents More...

Variables

std::map< int, std::map< int, double > > | agentsTtc
A map of all agents and their ttc at every time.
std::map< int, double > | agentsMinTtc
A map to save the minimal Ttc of an agent.
std::vector< int > | timeVector
time vector
std::string | fullResultFilePath
full path name of result file
int | runID = 0
ID of each run.

External Parameters

std::string | Par_resultFolderName
foldername for the result file
std::string | Par_tempFileName
file name for the temporary file
std::string | Par_finalFileName
file name for final result file

Detailed Description

logs the time to collision (ttc) of all agents

This component logs the time to collision (ttc) of all agents.

The file format is csv to easily access ttc data. Output data is the minimal ttc and the ttc at each time step of each agent.

Inputs

none

Outputs

none

Parameters to be specified in runConfiguration.xml

type | id | meaning | corresponding external paramter
string | 0 | folder where simulation output shall be stored | foldername for the result file
string | 1 | filename for temporary simulation output | file name for the temporary file
string | 2 | filename for final simulation output (*.xml) | file name for final result file
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Observation_Ttc_Implementation Class Reference

Public Member Functions | Private Attributes | List of all members
Observation_Ttc_Implementation Class Reference
openPASS CoreModules basic » Observation_Ttc

logs the time to collision (ttc) of all agents More...

Inheritance diagram for Observation_Ttc_Implementation:
[legend]
Collaboration diagram for Observation_Ttc_Implementation:
[legend]

Public Member Functions

virtual void | MasterPreHook ()
Called by framework in master before each simulation run starts.
virtual void | MasterPostHook (const std::string &filename)
virtual void | SlavePreHook (const std::string &path)
virtual void | SlavePreRunHook ()
Called by framework in slave before each simulation run starts.
virtual void | SlaveUpdateHook (int time, RunResultInterface &runResult)
virtual void | SlavePostRunHook (const RunResultInterface &runResult)
virtual void | SlavePostHook ()
Called by framework in slave after all simulation runs end.
virtual const std::string | SlaveResultFile ()
int | findFrontAgentID (int ownID)

Private Attributes

std::map< int, std::map< int, double > > | agentsTtc
A map of all agents and their ttc at every time.
std::map< int, double > | agentsMinTtc
A map to save the minimal Ttc of an agent.
std::vector< int > | timeVector
time vector
std::string | fullResultFilePath
full path name of result file
int | runID = 0
ID of each run.
External Parameters
std::string | Par_resultFolderName
foldername for the result file
std::string | Par_tempFileName
file name for the temporary file
std::string | Par_finalFileName
file name for final result file

Detailed Description

logs the time to collision (ttc) of all agents

This component logs the time to collision (ttc) of all agents.

The file format is csv to easily access ttc data. Output data is the minimal ttc and the ttc at each time step of each agent.

Member Function Documentation

virtual void MasterPostHook ( const std::string & filename )
inlinevirtual

Called by framework in master after each simulation run ends

Parameters
[in] filename Name of file containing the simulation run results from the slave
virtual void SlavePreHook ( const std::string & path )
virtual

Called by framework in slave before all simulation runs start

Parameters
[in] path Directory where simulation results will be stored
virtual void SlaveUpdateHook | ( | int | time,
 |  | RunResultInterface & | runResult
 | ) |  |
virtual

Called by framework in slave at each time step. Observation module can indicate end of simulation run here.

Parameters
[in] | time | Current scheduling time
[in,out] | runResult | Reference to run result
virtual void SlavePostRunHook ( const RunResultInterface & runResult )
virtual

Called by framework in slave after each simulation run ends. Observation module can observe the current simulation run here.

Parameters
[in] runResult Reference to run result
virtual const std::string SlaveResultFile ( )
inlinevirtual

Called by framework in slave after all simulation runs end to transfer the observation module results to the master.

Returns
File to be transferred
int findFrontAgentID ( int ownID )

Finds the ID of the agent that is exactly in front of the agent.

Returns
ID of agent in front
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnPoint_Start

Classes
SpawnPoint_Start
openPASS CoreModules basic

Spawn agents at the beginning of road. More...

Collaboration diagram for SpawnPoint_Start:

Classes

class SpawnPoint_Start_Implementation
Spawn agents at the beginning of road. More...

External Parameters

int | Par_NSpawnCars = 100
Number of spawned cars.
double | Par_demandHighway = 900
demand of highway in cars/hour
double | Par_vMean = 25
mean velocity in m/s
double | Par_vMin
minimal velocity in m/s
double | Par_vSd = 3
velocity standard deviation

Internal Parameters

int _standardCycleTime = 100
standard cycle time for spawning, update, trigger tasks

Detailed Description

Spawn agents at the beginning of road.

This SpawnPoint module implements a basic SpawnPointInterface which is used by the framework. It used to spawn several agents at the beginning of the road with random position and velocity.

External parameters

name | value | meaning
Par_NSpawnCars | 10 | The maximum number of vehicles that will be spawned on the road. However, the simulation of each situation might stop before this amount is reached. The amount of spawned vehicles might therefore vary between different situations of the same simulation.
Par_demandHighway | 900 | The traffic demand of the simulated road. The number states how many vehicles pass a point on the road per hour.
Par_vMean | 25 | mean velocity in m/s
Par_vSd | 3 | velocity standard deviation

Parameters to be specified in runConfiguration.xml

type | id | meaning | corresponding external paramter
int | 0 | Number of spawned cars | Par_NSpawnCars
double | 0 | demand of highway in cars/hour | Par_demandHighway
double | 1 | mean velocity in m/s | Par_vMean
double | 2 | minimal velocity in m/s | Par_vMin
double | 3 | velocity standard deviation | Par_vSd

Internal paramters

name | value | meaning
standardCycleTime | 100 | standard time for one cycle in ms
See also
SpawnPointInterface
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnPoint_Start_Implementation Class Reference

Private Attributes | List of all members
SpawnPoint_Start_Implementation Class Reference
openPASS CoreModules basic » SpawnPoint_Start

Spawn agents at the beginning of road. More...

Inheritance diagram for SpawnPoint_Start_Implementation:
[legend]
Collaboration diagram for SpawnPoint_Start_Implementation:
[legend]

Private Attributes

double | _carRate
spawning car rate in cars/second
int | _iSpawnCar = 0
number of cars already spawned
External Parameters
int | Par_NSpawnCars = 100
Number of spawned cars.
double | Par_demandHighway = 900
demand of highway in cars/hour
double | Par_vMean = 25
mean velocity in m/s
double | Par_vMin
minimal velocity in m/s
double | Par_vSd = 3
velocity standard deviation
Internal Parameters
int | _standardCycleTime = 100
standard cycle time for spawning, update, trigger tasks

Detailed Description

Spawn agents at the beginning of road.

This SpawnPoint module implements a basic SpawnPointInterface which is used by the framework. It used to spawn several agents at the beginning of the road with random position and velocity.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: World_Basic

Classes
World_Basic
openPASS CoreModules basic

implementation of a world interface More...

Collaboration diagram for World_Basic:

Classes

class World_Basic_Implementation
Implementation of a WorldInterface. More...

Detailed Description

implementation of a world interface

The World module implements a WorldInterface which is used by the framework and the agents. It is used to set up a basic simulated world with static objects like roads, intersection and curves and dynamic objects like cars, bicycles and pedastrians.

The World handles all simulated objects.

Inputs

name | meaning
callbacks | CallbackInterface to send log information to the framework

Outputs

name | meaning
*WoldInterface | Provides a reference to an implementation of a WorldInterface to the framework.

Parameters to be specified in runConfiguration.xml

tag | meaning
World | Name of World library. "World" by default.
See also
WorldInterface
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: World_Basic_Implementation Class Reference

Protected Member Functions | List of all members
World_Basic_Implementation Class Reference
openPASS CoreModules basic » World_Basic

Implementation of a WorldInterface. More...

Inheritance diagram for World_Basic_Implementation:
[legend]
Collaboration diagram for World_Basic_Implementation:
[legend]

Protected Member Functions

void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)

Detailed Description

Implementation of a WorldInterface.

This class implements all function of the WorldInterface. It is responsible for all dynamic and static objects in a given scenery.

Member Function Documentation

void Log | ( | CbkLogLevel | logLevel,
 |  | const char * | file,
 |  | int | line,
 |  | const std::string & | message
 | ) |  |
inlineprotected

Provides callback to LOG() macro

Parameters
[in] | logLevel | Importance of log
[in] | file | Name of file where log is called
[in] | line | Line within file where log is called
[in] | message | Message to log
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnPoint

SpawnPoint

This SpawnPointPreRunCommon populates the current World with Common Agents. More...

This SpawnPointPreRunCommon populates the current World with Common Agents.

The SpawnPointRuntimeCommon keeps the World populated with Common Agents by spawning new Agents according to the provided Traffic Parameters.

This SpawnPointPreRunCommon generates random Common Agents and places them in the World based on the specified spawning area of the configuration. This SpawnPointPreRunCommon also checks that no cars are spawned in between Ego/Scenario agents.

The SpawnPointRuntimeCommon continuously checks a specified road location for a valid spawn opportunity and spawns Common Agents when such an opportunity is found. This keeps traffic ever-flowing within the world.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Stochastics

Classes
Stochastics

implementation of StochasticsInterface More...

Classes

class StochasticsImplementation
implementation of StochasticsInterface More...

Detailed Description

implementation of StochasticsInterface

The Stochastics module implements a StochasticsInterface which is used by all agents to create a random behavior.

Inputs

name | meaning
callbacks | CallbackInterface to send log information to the framework

Outputs

name | meaning
*StochasticsInterface | Provides a reference to an implementation of a StochasticsInterface to the framework.
See also
StochasticsInterface
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: StochasticsImplementation Class Reference

Protected Member Functions | List of all members
StochasticsImplementation Class Reference
Stochastics

implementation of StochasticsInterface More...

Inheritance diagram for StochasticsImplementation:
[legend]
Collaboration diagram for StochasticsImplementation:
[legend]

Protected Member Functions

void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)

Detailed Description

implementation of StochasticsInterface

The Stochastics module implements a StochasticsInterface which is used by all agents to create a random behavior.

Member Function Documentation

void Log | ( | CbkLogLevel | logLevel,
 |  | const char * | file,
 |  | int | line,
 |  | const std::string & | message
 | ) |  |
inlineprotected

Provides callback to LOG() macro

Parameters
[in] | logLevel | Importance of log
[in] | file | Name of file where log is called
[in] | line | Line within file where log is called
[in] | message | Message to log
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: World

Classes
World

implementation of a world interface More...

Classes

class WorldImplementation
Implementation of a WorldInterface. More...

Detailed Description

implementation of a world interface

The World module implements a WorldInterface which is used by the framework and the agents. It is used to set up a basic simulated world with static objects like roads, intersection and curves and dynamic objects like cars, bicycles and pedastrians.

The World handles all simulated objects.

Inputs

name | meaning
callbacks | CallbackInterface to send log information to the framework

Outputs

name | meaning
*WoldInterface | Provides a reference to an implementation of a WorldInterface to the framework.

Parameters to be specified in runConfiguration.xml

tag | meaning
World | Name of World library. "World" by default.
See also
WorldInterface
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: WorldImplementation Class Reference

Protected Member Functions | List of all members
WorldImplementation Class Reference
World

Implementation of a WorldInterface. More...

Inheritance diagram for WorldImplementation:
[legend]
Collaboration diagram for WorldImplementation:
[legend]

Protected Member Functions

void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)

Detailed Description

Implementation of a WorldInterface.

This class implements all function of the WorldInterface. It is responsible for all dynamic and static objects in a given scenery.

Member Function Documentation

void Log | ( | CbkLogLevel | logLevel,
 |  | const char * | file,
 |  | int | line,
 |  | const std::string & | message
 | ) |  |
inlineprotected

Provides callback to LOG() macro

Parameters
[in] | logLevel | Importance of log
[in] | file | Name of file where log is called
[in] | line | Line within file where log is called
[in] | message | Message to log
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: OpenPassSlave

Classes
OpenPassSlave

Classes

class | AgentParser
convert agent to taskItems for Scheduling More...
class | RunResult
stores run results for output data More...
class | Scheduler
execute all tasks for an simulation run More...
class | SchedulerTasks
managing timing of all given tasks More...
class | TaskBuilderInterface
interface of taskBuilder More...
class | TaskBuilder
handles fix tasks of scheduler More...
class | TaskItem
handles data to store scheduler tasks More...
class | Tasks
stores taskItems in multiset More...

Detailed Description

Detailed Description

This is the slave module of the framework and it contains the main entry point of the simulation process.

It is started by a master module with or without arguments. Following this the slave reads all configuration files and sets up the program parameters and the framework infrastructure. After that the simulation starts and stores its results in a prespecified file.

arguments

arguments | meaning
-libraryPath | Path to all libraries. Working directory by default.
-observationResultPath | Path where the simulation results are stored. Working directory by default.
-agentConfiguration | Path and name of agent configuration file. "agentConfiguration.xml" by default.
-sceneryConfiguration | Path and name of scenery configuration file. "sceneryConfiguration.xml" by default.
-runConfiguration | Path and name of run configuration file. "runConfiguration.xml" by default.
-logFile | Path and name were the log is stored. Working directory and "logSlave.txt" by default.
-logLevel | Level at which the log messages are stored. "0" by default.

files

file | description
logSlave.txt | Default name for file containing all log messages (depending on the logLevel). Path and name are specified in slaveConfig.xml.
simulationOutput.xml | This file contains the simulation results. Path is specified in frameworkConfig.xml and name in runConfig.xml.
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AgentParser Class Reference

  • openpass
  • scheduling
  • AgentParser
Public Member Functions | List of all members
AgentParser Class Reference
OpenPassSlave

convert agent to taskItems for Scheduling More...

Public Member Functions

void Parse (const SimulationSlave::Agent &agent)
Parse. More...

Detailed Description

convert agent to taskItems for Scheduling

Member Function Documentation

void Parse ( const SimulationSlave::Agent & agent )

Parse.

function is called when spawning agent and provides tasks for each component of the agent

Parameters
[in] Agent new agent
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RunResult Class Reference

  • SimulationSlave
  • RunResult
Public Member Functions | List of all members
RunResult Class Reference
OpenPassSlave

stores run results for output data More...

Inheritance diagram for RunResult:
[legend]
Collaboration diagram for RunResult:
[legend]

Public Member Functions

void AddCollisionId (const int agentId)
AddCollisionId. More...

Detailed Description

stores run results for output data

Member Function Documentation

void AddCollisionId ( const int agentId )

AddCollisionId.

add agent id to list of collided agents

Parameters
[in] int id of collided agent
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Scheduler Class Reference

  • openpass
  • scheduling
  • Scheduler
Public Member Functions | Private Member Functions | List of all members
Scheduler Class Reference
OpenPassSlave

execute all tasks for an simulation run More...

Public Member Functions

bool | Run (int startTime, int endTime, SimulationSlave::RunResult &runResult, SimulationSlave::EventNetworkInterface &eventNetwork)
Run. More...
void | ScheduleAgentTasks (SchedulerTasks &taskList, const SimulationSlave::Agent &agent)
ScheduleAgentTasks. More...

Private Member Functions

void | UpdateAgents (SchedulerTasks &taskList, WorldInterface &world)
UpdateAgents. More...
template<typename T >
bool | ExecuteTasks (T tasks)
ExecuteTasks. More...

Detailed Description

execute all tasks for an simulation run

The scheduler triggers TaskBuilder to build up common tasks and SchedulerTasks to manage sorting of all tasks. Each timestep all given tasks are executed.

Member Function Documentation

bool Run | ( | int | startTime,
 |  | int | endTime,
 |  | SimulationSlave::RunResult & | runResult,
 |  | SimulationSlave::EventNetworkInterface & | eventNetwork
 | ) |  |

Run.

execute all tasks for one simulation run

Parameters
[in] | startTime | simulation start
[in] | endTime | simulation end
[out] | runResult | RunResult
[in,out] | EventNetwork | EventNetwork
Returns
true if simulation ends withuot error
void ScheduleAgentTasks | ( | SchedulerTasks & | taskList,
 |  | const SimulationSlave::Agent & | agent
 | ) |  |

ScheduleAgentTasks.

schedule all tasks of an new agent e.g. for respawning

Parameters
[in] | taskList | current task list
[in] | Agent | new agent
void UpdateAgents | ( | SchedulerTasks & | taskList,
 |  | WorldInterface & | world
 | ) |  |
private

UpdateAgents.

schedule new agents and remove deleted ones

Parameters
[in] | taskList | current task list
[out] | WorldInterface | world
bool ExecuteTasks ( T tasks )
private

ExecuteTasks.

execute function of given task

Parameters
[in] tasks execute function of given tasks
Returns
false, if a task reports error
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SchedulerTasks Class Reference

  • openpass
  • scheduling
  • SchedulerTasks
Public Member Functions | Private Member Functions | List of all members
SchedulerTasks Class Reference
OpenPassSlave

managing timing of all given tasks More...

Collaboration diagram for SchedulerTasks:
[legend]

Public Member Functions

void | ScheduleNewRecurringTasks (std::list< TaskItem > newTasks)
ScheduleNewRecurringTasks. More...
void | ScheduleNewNonRecurringTasks (std::list< TaskItem > newTasks)
ScheduleNewNonRecurringTasks. More...
void | DeleteAgentTasks (std::list< int > &agents)
DeleteAgentTasks. More...
void | DeleteAgentTasks (int agentId)
DeleteAgentTasks. More...
int | GetNextTimestamp (int timestamp)
GetNextTimestamp. More...
std::list< TaskItem > | GetTasks (int timestamp)
GetTasks. More...
std::list< TaskItem > | GetSpawningTasks (int timestamp)
GetCommonTasks. More...
std::list< TaskItem > | ConsumeNonRecurringAgentTasks (int timestamp)
ConsumeNonRecurringTasks. More...
void | PullNonRecurringTasks (int timestamp, std::list< TaskItem > &currentTasks)
PullNonRecurringTasks. More...
std::list< TaskItem > | GetRecurringAgentTasks (int timestamp)
GetRecurringTasks. More...
std::multiset< TaskItem > | GetBootstrapTasks ()
GetBootstrapTasks. More...
std::multiset< TaskItem > | GetFinalizeTasks ()
GetFinalizeTasks. More...

Private Member Functions

void | CreateNewScheduledTimestamps ()
CreateNewScheduledTimestamps. More...
void | GetTasks (int timestamp, std::multiset< TaskItem > &tasks, std::list< TaskItem > &currentTasks)
GetTasks. More...
void | UpdateScheduledTimestamps (int cycleTime, int delay)
UpdateScheduledTimestamps. More...
void | UpdateScheduledTimestamps (std::multiset< TaskItem > &tasks)
UpdateScheduledTimestamps. More...
void | ScheduleNewTasks (Tasks &tasks, std::list< TaskItem > newTasks)
ScheduleNewTasks. More...
void | ClearNonrecurringTasks ()
ClearNonrecurringTasks. More...
void | ExpandUpperBoundary (int timestamp)
ExpandUpperBoundary. More...

Detailed Description

managing timing of all given tasks

The SchedulerTasks class sorts tasks for each phase (bbootstrap, common, nonrecurring, recurring, finalize recurring, finalize) Returns all tasks for given timestamp.

Member Function Documentation

void ScheduleNewRecurringTasks ( std::list< TaskItem > newTasks )

ScheduleNewRecurringTasks.

insert given tasks to intern recurring tasks

Parameters
[in] list of TaskItems new tasks
void ScheduleNewNonRecurringTasks ( std::list< TaskItem > newTasks )

ScheduleNewNonRecurringTasks.

insert given tasks to intern nonrecurring tasks

Parameters
[in] list of TaskItems new tasks
void DeleteAgentTasks ( std::list< int > & agents )

DeleteAgentTasks.

filter all tasks to remove tasks of given agent id

Parameters
[in] list of int agent ids to remove from tasks
void DeleteAgentTasks ( int agentId )

DeleteAgentTasks.

filter all tasks to remove tasks of given agent id

Parameters
[in] int agentId
int GetNextTimestamp ( int timestamp )

GetNextTimestamp.

calculates with scheduledTimestamps next timestamp

Parameters
[in] int timestamp
Returns
int next timestamp
std::list<TaskItem> GetTasks ( int timestamp )

GetTasks.

Parameters
[in] int timestamp
Returns
list of TaskItems all tasks for given timestamp
std::list<TaskItem> GetSpawningTasks ( int timestamp )

GetCommonTasks.

Parameters
[in] int timestamp
Returns
list of TaskItems all common tasks for given timestamp
std::list<TaskItem> ConsumeNonRecurringAgentTasks ( int timestamp )

ConsumeNonRecurringTasks.

calls PullNonRecurringTasks

Parameters
[in] int timestamp
Returns
list of TaskItems all init tasks for given timestamp
void PullNonRecurringTasks | ( | int | timestamp,
 |  | std::list< TaskItem > & | currentTasks
 | ) |  |

PullNonRecurringTasks.

clear all init tasks after returning them

Parameters
[in] | int | timestamp
[out] | list | of TaskItems all init tasks for given timestamp
std::list<TaskItem> GetRecurringAgentTasks ( int timestamp )

GetRecurringTasks.

Parameters
[in] int timestamp
Returns
list of TaskItems all recurring tasks for given timestamp
std::multiset<TaskItem> GetBootstrapTasks ( )

GetBootstrapTasks.

Parameters
[in] int timestamp
Returns
list of TaskItems all bootstrap tasks for given timestamp
std::multiset<TaskItem> GetFinalizeTasks ( )

GetFinalizeTasks.

Parameters
[in] int timestamp
Returns
list of TaskItems all finalize tasks for given timestamp
void CreateNewScheduledTimestamps ( )
private

CreateNewScheduledTimestamps.

renew scheduled timestamps

void GetTasks | ( | int | timestamp,
 |  | std::multiset< TaskItem > & | tasks,
 |  | std::list< TaskItem > & | currentTasks
 | ) |  |
private

GetTasks.

Parameters
[in] | int | timestamp
[in] | tasks | tasks to filter by current timestamp
[out] | list | of TaskItems filtered tasks
void UpdateScheduledTimestamps | ( | int | cycleTime,
 |  | int | delay
 | ) |  |
private

UpdateScheduledTimestamps.

update scheduled timestamps with new schedule times

Parameters
[in] | int | cycletime of task
[in] | int | delay/offset of task
void UpdateScheduledTimestamps ( std::multiset< TaskItem > & tasks )
private

UpdateScheduledTimestamps.

call UpdateScheduledTimestamps for each task

Parameters
[out] tasks new scheduled tasks
void ScheduleNewTasks | ( | Tasks & | tasks,
 |  | std::list< TaskItem > | newTasks
 | ) |  |
private

ScheduleNewTasks.

call UpdateScheduledTimestamps for each task

Parameters
[out] tasks new scheduled tasks
void ClearNonrecurringTasks ( )
private

ClearNonrecurringTasks.

clears non recurring tasks

void ExpandUpperBoundary ( int timestamp )
private

ExpandUpperBoundary.

if reaching upper limit of currently scheduled timestamps next timestamps have to be calculated

Parameters
[in] int ctimestamp
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TaskBuilderInterface Class Reference

  • openpass
  • scheduling
  • TaskBuilderInterface
List of all members
TaskBuilderInterface Class Referenceabstract
OpenPassSlave

interface of taskBuilder More...

Inheritance diagram for TaskBuilderInterface:
[legend]

Detailed Description

interface of taskBuilder

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TaskBuilder Class Reference

  • openpass
  • scheduling
  • TaskBuilder
Public Member Functions | Private Member Functions | List of all members
TaskBuilder Class Reference
OpenPassSlave

handles fix tasks of scheduler More...

Inheritance diagram for TaskBuilder:
[legend]
Collaboration diagram for TaskBuilder:
[legend]

Public Member Functions

std::list< TaskItem > | CreateBootstrapTasks () override
CreateBootstrapTasks. More...
std::list< TaskItem > | CreateSpawningTasks () override
CreateCommonTasks. More...
std::list< TaskItem > | CreateSynchronizeTasks () override
CreateFinalizeRecurringTasks. More...
std::list< TaskItem > | CreateFinalizeTasks () override
CreateFinalizeTasks. More...

Private Member Functions

void | BuildEventDetectorTasks ()
BuildEventDetectorTasks. More...
void | BuildManipulatorTasks ()
BuildManipulatorTasks. More...

Detailed Description

handles fix tasks of scheduler

Member Function Documentation

void BuildEventDetectorTasks ( )
private

BuildEventDetectorTasks.

In constructor all eventDetectors are read out and stored in eventDetector Tasks to fill them later in tasks.

void BuildManipulatorTasks ( )
private

BuildManipulatorTasks.

In constructor all manipulators are read out and stored in eventDetector Tasks to fill them later in tasks.

std::list<TaskItem> CreateBootstrapTasks ( )
overridevirtual

CreateBootstrapTasks.

Creates tasks with all tasks of bootstrap phase. Bootstrap tasks can not be changed.

Returns
tasks final tasks of bootstrap phase

Implements TaskBuilderInterface.

std::list<TaskItem> CreateSpawningTasks ( )
overridevirtual

CreateCommonTasks.

Creates tasks with all tasks of common phase. Common tasks can not be changed.

Returns
tasks final tasks of common phase

Implements TaskBuilderInterface.

std::list<TaskItem> CreateSynchronizeTasks ( )
overridevirtual

CreateFinalizeRecurringTasks.

Creates tasks with all tasks of finalizeRecurring phase. FinalizeRecurring tasks can not be changed.

Returns
tasks final tasks of finalizeRecurring phase

Implements TaskBuilderInterface.

std::list<TaskItem> CreateFinalizeTasks ( )
overridevirtual

CreateFinalizeTasks.

Creates tasks with all tasks of finalize phase. Finalize tasks can not be changed.

Returns
tasks final tasks of finalize phase

Implements TaskBuilderInterface.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TaskItem Class Reference

  • openpass
  • scheduling
  • TaskItem
List of all members
TaskItem Class Reference
OpenPassSlave

handles data to store scheduler tasks More...

Inheritance diagram for TaskItem:
[legend]

Detailed Description

handles data to store scheduler tasks

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Tasks Class Reference

  • openpass
  • scheduling
  • Tasks
Public Member Functions | List of all members
Tasks Class Reference
OpenPassSlave

stores taskItems in multiset More...

Public Member Functions

void | AddTask (const TaskItem &newTask)
AddTask. More...
void | DeleteTasks (int agentId)
DeleteTasks. More...

Detailed Description

stores taskItems in multiset

Member Function Documentation

void AddTask ( const TaskItem & newTask )

AddTask.

add given taskItem to intern multiset tasks

Parameters
[in] TaskItem subclass of taskItem
void DeleteTasks ( int agentId )

DeleteTasks.

add given taskItem to intern multiset tasks

Parameters
[in] int id of removed agent to filter it out of tasks
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Namespace Members

  • Namespace Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • g
  • i
  • r
  • s
  • t
Here is a list of all documented namespace members with links to the namespaces they belong to:

- a -

  • AddPointsToWorld() : GeometryConverter

- b -

  • BuildRoadPolygons() : GeometryConverter

- c -

  • CalcAngleBetweenPoints() : CommonHelper
  • CalculateBorderPoints() : GeometryConverter
  • CalculateCoordZ() : GeometryConverter
  • CalculateGeometry() : GeometryConverter
  • CalculateGeometryOffsetEnd() : GeometryConverter
  • CalculateGeometryOffsetStart() : GeometryConverter
  • CalculateIntersectionInfoForRoadPolygons() : GeometryConverter
  • CalculateIntersections() : GeometryConverter
  • CalculateJoints() : GeometryConverter
  • CalculateJunctionIntersectionsFromRoadPolygons() : GeometryConverter
  • CalculateLaneBorder() : GeometryConverter
  • CalculateLaneWidth() : GeometryConverter
  • CalculateMomentInertiaYaw() : CommonHelper
  • CalculateRoads() : GeometryConverter
  • CalculateSection() : GeometryConverter
  • CalculateSectionBetweenRoadMarkChanges() : GeometryConverter
  • CalculateSlope() : GeometryConverter
  • CalculateSlopeAtRoadPosition() : GeometryConverter
  • CalculateWidthAtSectionPosition() : GeometryConverter
  • Convert() : GeometryConverter
  • CreateBuildPolygonFromLaneGeometryFunction : GeometryConverter

- d -

  • DoubleEquality() : CommonHelper

- g -

  • GetRelativeRank() : GeometryConverter
  • GetRelevantRoadElevation() : GeometryConverter
  • GetRelevantRoadLaneWidth() : GeometryConverter

- i -

  • InterpolateLinear() : CommonHelper
  • IsEqual() : GeometryConverter

- r -

  • roundDoubleWithDecimals() : CommonHelper

- s -

  • SetAngleToValidRange() : CommonHelper

- t -

  • TokenizeString() : CommonHelper
  • TransformPointToSourcePointCoord() : CommonHelper
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Namespace Members

  • Namespace Members
  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • g
  • i
  • r
  • s
  • t

- a -

  • AddPointsToWorld() : GeometryConverter

- b -

  • BuildRoadPolygons() : GeometryConverter

- c -

  • CalcAngleBetweenPoints() : CommonHelper
  • CalculateBorderPoints() : GeometryConverter
  • CalculateCoordZ() : GeometryConverter
  • CalculateGeometry() : GeometryConverter
  • CalculateGeometryOffsetEnd() : GeometryConverter
  • CalculateGeometryOffsetStart() : GeometryConverter
  • CalculateIntersectionInfoForRoadPolygons() : GeometryConverter
  • CalculateIntersections() : GeometryConverter
  • CalculateJoints() : GeometryConverter
  • CalculateJunctionIntersectionsFromRoadPolygons() : GeometryConverter
  • CalculateLaneBorder() : GeometryConverter
  • CalculateLaneWidth() : GeometryConverter
  • CalculateMomentInertiaYaw() : CommonHelper
  • CalculateRoads() : GeometryConverter
  • CalculateSection() : GeometryConverter
  • CalculateSectionBetweenRoadMarkChanges() : GeometryConverter
  • CalculateSlope() : GeometryConverter
  • CalculateSlopeAtRoadPosition() : GeometryConverter
  • CalculateWidthAtSectionPosition() : GeometryConverter
  • Convert() : GeometryConverter

- d -

  • DoubleEquality() : CommonHelper

- g -

  • GetRelativeRank() : GeometryConverter
  • GetRelevantRoadElevation() : GeometryConverter
  • GetRelevantRoadLaneWidth() : GeometryConverter

- i -

  • InterpolateLinear() : CommonHelper
  • IsEqual() : GeometryConverter

- r -

  • roundDoubleWithDecimals() : CommonHelper

- s -

  • SetAngleToValidRange() : CommonHelper

- t -

  • TokenizeString() : CommonHelper
  • TransformPointToSourcePointCoord() : CommonHelper
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Namespace Members

  • Namespace Members
  • All
  • Functions
  • Variables
  • CreateBuildPolygonFromLaneGeometryFunction : GeometryConverter
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 1234]
►N Common | This file implements a generic 2D vector
C Line
C Vector2d
C Vector3d
►N CommonTrafficSign
C Entity
►N ComponentControl
C AdasComponentStateInformation
C ComponentStateEquality | This Condition is fullfilled if two ComponentStateExpressions are evaluated to the same value
C ComponentStateExpression | This class represents an expression that can be evaluated as ComponentState
C ComponentStateInformation | The ComponentStateConfiguration class handles the dependencies of a single component
C Condition | This class represents a Condition based on all the information the ComponentController has gathered
C FixedComponentStateExpression | The FixedComponentStateExpression is a ComponentStateExpression that always evaluates to the same ComponentState
C StateManager | Handles the dependencies of all components
C VehicleComponentStateExpression | The VehicleComponentStateExpression is a ComponentStateExpression that evaluates to the current state of some fixed component
►N Configuration
C ConfigurationContainer | This class imports and stores all configurations
C Scenario
C Scenery | Class representing a scenery as a list of roads
C SlaveConfig | Container class for the slave configuration
C SystemConfig
C VehicleModels
►N Importer
C EventDetectorImporter
C ProfilesImporter
C ScenarioImporter
C SceneryImporter
C SlaveConfigImporter | This class povides the import functionality
C SystemConfigImporter | Class handles importing an agent system configuration
►C VehicleModelsImporter | Provides methods for importing vehicle models from OpenSCENARIO catalog files
C TypeHelper | Helper for template type deduction with std::optional parameters
►N Internal
C ConversionStatus
►N LaneMarking
C Entity
►N openpass
►N common
►C RuntimeInformation
C Directories
C Versions
C Version
►N core
C Directories
►N events
C BasicEvent
C CollisionEvent
C ComponentStateChangeEvent
C LaneChangeEvent
C SpeedActionEvent
C TrajectoryEvent
►N parameter
►N internal
C VisitParameterElement | Switches between flat parameters and parameter lists
C ExponentialDistribution
C GammaDistribution
C LogNormalDistribution
C NormalDistribution
C UniformDistribution
►N publisher
C AgentDataPublisher | ! Interface which has to be provided by observation modules
C CoreDataPublisher | ! Interface which has to be provided by observation modules
C LogEntry
C LogEntryBase | Base class for logging of acyclic events in the datastore
►N scheduling
C AgentParser | Convert agent to taskItems for Scheduling
C EventDetectorTaskItem | TaskItem for eventDetector task
C ManipulatorTaskItem | TaskItem for manipulator task
C ObservationTaskItem | TaskItem for observation task
C Scheduler | Execute all tasks for an simulation run
C SchedulerTasks | Managing timing of all given tasks
C SpawningTaskItem | TaskItem for spawning task
C SyncWorldTaskItem | TaskItem for synchronize world task
C TaskBuilder | Handles fix tasks of scheduler
C TaskBuilderInterface | Interface of taskBuilder
C TaskItem | Handles data to store scheduler tasks
C Tasks | Stores taskItems in multiset
C TimeKeeper | Allows core components to access the current schedule time without need for a direct reference
C TriggerTaskItem | TaskItem for triggering task
C UpdateGlobalDrivingViewTaskItem | TaskItem for update global driving view task
C UpdateTaskItem | TaskItem for update task
►N sensors
C Parameter
C Position
C Profile
►N type
C AffectedEntities | Contains the affected entities of an acyclic
C NamedType
C TriggeringEntities | Contains the triggering entities of an acyclic
►N openScenario
►N transformation
C LaneChange
C SpeedAction
C Trajectory
C TransformerBase | CRTP Base class for Transformer
C AbsoluteTargetSpeed
C ActorInformation
C ByEntityCondition
C ByValueCondition
C ConditionalEventDetectorInformation | Event specific information collected from an openSCENARIO story
C CustomCommandAction
C EntityAction
C FollowTrajectoryAction
C LaneChangeAction
C LaneChangeParameter
C LanePosition
C ManipulatorInformation
C Orientation
C ParameterizedAttribute | Attribute in a catalog that is not yet resolved
C ReachPositionCondition
C RelativeLanePosition
C RelativeSpeedCondition
C RelativeTargetSpeed
C RoadPosition
C ScenarioImporterHelper
C SimulationTimeCondition
C SpeedAction
C StochasticAttribute
C TimeHeadwayCondition
C TimeToCollisionCondition
C Trajectory
C TrajectoryPoint
C TransitionDynamics
C VisibilityAction
C WorldPosition
►N OWL
►N Fakes
C Junction
C Lane
C LaneBoundary
C MovingObject
C Road
C RoadMarking
C Section
C StationaryObject
C TrafficSign
C WorldData
►N Implementation
C InvalidLane
C InvalidRoad
C InvalidSection
C Junction
C Lane
C LaneBoundary
C MovingObject
C Road
C RoadMarking
C Section
C StationaryObject
C TrafficSign
C Vehicle
►N Interfaces
C Junction | This class represents a junction in the world
C Lane | This class represents a single lane inside a section
C LaneBoundary | This class represents the boundary between two lanes
C MovingObject
C Road | This class represents a road in the world
C RoadMarking | This class represents a traffic sign that is painted on the road surface
C Section | This class represents one section of a road
C StationaryObject
C TrafficSign | This class represents a static traffic sign
C WorldData | This class contains the entire road network and all objects in the world
C WorldObject
►N Primitive
C AbsAcceleration
C AbsCoordinate
C AbsOrientation
C AbsOrientationRate
C AbsPosition
C AbsVelocity
C Dimension
C LaneAcceleration
►C LaneGeometryElement
C Joints
►C LaneGeometryJoint
C Points | Tripple describing the sampled points of the lane
C LaneOrientation
C LaneOrientationRate
C LanePosition
C LaneVelocity
C RoadAcceleration
C RoadCoordinate
C RoadOrientationRate
C RoadVelocity
C IntersectionInfo
C Lazy
C NonExistentOsiRef
C WorldData
►N RelativeWorldView
C Junction
C Lane
C LanesInterval
►N SimulationCommon
C Callbacks | Callback implementation within framework
C ModelParameters
C ObservationParameters
C Parameters
C SpawnPointParameters
C WorldParameters
►N SimulationMaster
►N Configuration
C MasterConfig | Used as value storage of parsed configuration parameters
C MasterConfigImporter
C SlaveConfig
►N SimulationSlave
C Agent
C AgentFactory
C AgentType
C Channel
C ChannelBuffer
C Component
C ComponentType
C DataStore
C DataStoreBinding
C DataStoreLibrary
C EventDetector
C EventDetectorBinding
C EventDetectorLibrary
C EventDetectorNetwork
C EventNetwork | Implements the functionality of the interface
C FrameworkModuleContainer
C Manipulator
C ManipulatorBinding
C ManipulatorLibrary
C ManipulatorNetwork
C ModelBinding
C ModelLibrary
C ObservationBinding
C ObservationLibrary
C ObservationModule
C ObservationNetwork
C RunInstantiator
C RunResult | Stores run results for output data
C SpawnItemParameter
C SpawnPoint
C SpawnPointBinding
C SpawnPointLibrary
C SpawnPointNetwork
C Stochastics
C StochasticsBinding
C StochasticsLibrary
C World
C WorldBinding
C WorldLibrary
►N SpawnPointDefinitions
C AgentProfileLaneMaps
C SpawningAgentProfile
►N SpawnPointPreRunCommonDefinitions
C PreRunSpawnerParameters
C SpawnArea
►N SpawnPointRuntimeCommonDefinitions
C SpawnDetails
C SpawnPointRuntimeCommonParameters
C SpawnPosition
►N World
►N Localization
C LaneIntersection | This struct describes the intersection of an object with a lane
C LocalizationElement | This struct contains all the information about a LaneGeometryElement that is needed by the Localizer
C Localizer
C LocatedObject
C PointQuery
C Result
C WorldToRoadCoordinateConverter
C AccelerationSignal | Signal class
C Action_BrakeLight_Basic_Implementation | Sets the brake light
C ActionLongitudinalDriverImplementation
C ActionSecondaryDriverTasksImplementation | Controls secondary driver tasks
C ActionTransformRepository | Use this class as mixed set for fixed and auto registering transformations
C AcyclicResult
►C AgentAdapter | The AgentAdapter class This class is a adapter for the communication between the framework and world
C LaneObjParameters
C AgentBlueprint | This class stores all information which is required to instantiate an agent
C AgentBlueprintProvider
C AgentBuildInformation | The AgentBuildInformation struct contains all information that the AgentBlueprintProvider needs to fill out the AgentBlueprint for a dynamic AgentProfile
C AgentCompToCompCtrlSignal
C AgentNetwork | Network of agents
C AgentSpawnItem | Representation of an agent as defined in the run configuration
C AgentUpdaterImplementation | The class which is responsible for updating the agent in each time step
C Algorithm_CruiseControlByDistance_Implementation | Models the lateral controller of the driver
C Algorithm_FmuWrapper
C AlgorithmAgentFollowingDriverModelImplementation
C AlgorithmAutonomousEmergencyBrakingImplementation
C AlgorithmFmuWrapperImplementation
C AlgorithmLateralImplementation | Models the lateral controller of the driver
C AlgorithmLongitudinalCalculations | This class does all the calculations in the Algorithm_Longitudinal module
C AlgorithmLongitudinalImplementation
C BasicDataStoreImplementation | This class implements a basic version of a data store
C BoolSignal | Primitive signal class for boolean values
C BorderPoint | This lane represents the outer boundary points of a lane at one s coordinate
C BorderPoints | This struct represents the boundary points of all lanes (including lane 0) at one s coordinate (i.e. one joint)
C BoundingBoxCalculation
C cmplx
C cmplxl
C CollisionAngles
C CollisionDetectionPostCrash | Collision component that calculates post-crash dynamics
C CollisionDetector | This class detectes wether a collision happen in the simulation
►C CollisionManipulator | This class notifies all relevant modules about the collision
C CrashInfo
C CommandLineArguments
C CommandLineOption
C CommandLineParser
C CompCtrlToAgentCompSignal Facilitates communication with the agent component, defining the max reachable state of the component as well as the states of other components connected to the

ComponentController

C CompCtrlToDriverCompSignal Facilitates communication with the driver component, allowing for warnings to be forwarded to the driver

alongside standard agent component information.

C ComponentControllerImplementation
C ComponentPort | A Class to manage ports of a component
C ComponentStateChangeManipulator | This class toggles an assistance system
C ComponentStateSignal | Primitive signal class for componentState values
C ConditionalEventDetector
C ConditionCommonBase
C ConditionMetaInformation
C ConfigurationFiles
C Connection
C CSVParser
C CustomCommandFactory | Use this class as static auto registering factory for custom commands
C CyclicResult
C DefaultComponents | Defines the default components that all agents need
C DoubleSignal | Primitive signal class for double values
C DynamicAgentTypeGenerator | Used to build the AgentBuildInformation struct in particular the AgentType
C DynamicParameters
C DynamicParameterSampler
C DynamicProfileSampler | Responsible for sampling all profile names (except AgentProfile which is sampled by the AgentProfilesSampler)
C Dynamics_Longitudinal_Basic_Implementation | Calculate the next velocity and position of the agent in the next timestep based on the acceleration in longitudinal direction
C DynamicsCollisionImplementation
C DynamicsPostCrashImplementation
C DynamicsRegularDrivingImplementation
C DynamicsRegularTwoTrackImplementation
C DynamicsSignal | Signal class
C EgoAgent
C EventDetectorCommonBase | This is the parent class for all EventDetectors providing the basic functionality
C externalParameter
C FakeLaneManager
C fmi1_csv_input_t
C fmi2_csv_input_t
C fmu_check_data_t
C FrameworkModules
C GeometryInformation | This struct contains infrastructure information of surrounding lanes that describe its geometric features
C GlobalRoadPosition | Position of a point in the road network
C InputPort
C IntersectingConnection | Information regarding a connecting road intersecting another
C IntSignal | Primitive signal class for integer values
C Joint | This struct contains all information calculated by the JointBuilder for one joint
C JointsBuilder
C Junction
C JunctionConnection
C JunctionConnectorPriority
C LaneChangeManipulator | This class removes an agent
C LaneGeometryPolygon
C LaneInformationGeometry | This struct is used to transport data of a lane concerning its geometric features as seen by the driver
C LaneInformationTrafficRules | This struct is used to trasport data of a lane concerning traffic rules as seen by the driver
C LaneJoint | This struct contains all information calculated by the JointBuilder for one joint and one lane
C LateralDynamicConstants | Calulaction parameters for the lateral acceleration wish [m/s]
C LateralSignal
C LimiterAccelerationVehicleComponentsImplementation | This class implements the set limit
C Log | Coordinates logging
C LogOutputPolicy | Handles access of file
C LongitudinalDistance | Longitudinal distance (i.e. along s) between two objects on the same road
C LongitudinalSignal
C ManipulatorCommonBase | This is the parent class for all Manipulators providing the basic functionality
►C MultiStream
C Node
C NoOperationManipulator | This class is a manipulator, that doesn't trigger any action and solely returns the event. It existes to met the OpenSCENARIO conventions
C ObjectDetectorBase | This class is the common base for all SensorObjectDetectors
C ObjectInformation | This struct is used to transport data of an object as seen be the driver
C ObjectPosition | Position of an object in the road network
C ObjectView
C Observation_State_Implementation | Logs the current X position of every agent at each time step
C Observation_Ttc_Implementation | Logs the time to collision (ttc) of all agents
C ObservationCyclics | The ObservationCyclics stores the samples which are logged by various modules and written into the cyclics tag of the simulationOutput.xml
C ObservationFileHandler | Provides the basic logging and observer functionality
C ObservationInstance | Wrapper for building an ObservationInstance
C ObservationLogImplementation | This class adds the RunStatistic information to the simulation output
C Obstruction | Describes the obstruction of an opposing object within the driving lanes
C OpenScenarioActionsImplementation | Relays triggered OpenScenario actions as signals to other components
C OscActionsCalculation | This class makes calculations for the OpenScenarioActions module
C OsmpFmuHandler
C OutputAttributes
C OutputPort
C OutputTags
C overload
C OwnVehicleInformation | Data about the lane to left (in driving direction) of the mainLane
C ParametersVehicleImplementation | Defines constants or creates stochastic values that are used in more than one module
C ParametersVehicleSignal | Provides all vehicle parameters for the driver
C Polygon | Polygon in 2d
C Position
C PostCrashDynamic | Class to store post-crash dynamics data Used to store information about the dynamic after a collision
C PostCrashVelocity
C ProcessManager
C Profiles
C ReachPositionCondition
C Remainder | This struct describes how much space an agent has to next lane boundary on both sides
C RemoveAgentsManipulator | This class removes an agent
C Road | Class representing a road
C RoadGeometry
C RoadGeometryArc | Class representing a road arc as a RoadGeometry
C RoadGeometryLine | Class representing a road line as a RoadGeometry
C RoadGeometryParamPoly3 | Class representing a road form defined via a parametric cubic polynomial as a RoadGeometry
C RoadGeometryPoly3 | Class representing a road form defined via a cubic polynomial as a RoadGeometry
C RoadGeometrySpiral | Class representing a spiral road (clothoid) as a RoadGeometry
C RoadInterval | Interval on a specific road
C RoadLane | Class representing a road lane
C RoadLaneSection | Class representing a road lane section that can contain several road lanes
C RoadLink | Class representing a link to a road
C RoadNetworkBuilder
C RoadNetworkElement
C RoadObject
C RoadPosition | Position of a point on a specific lane
C RoadSignal | Class representing a road signal
C RouteElement | This represents one node on the road network graph of the world or in the routing graph of an agent
C RunStatistic
C RunStatisticCalculation | Helper functions for run statistic analysis
C SampledGeometry | This struct is the result of the geometry sampling of one road section
C SampledProfiles | The SampledProfiles struct constains the name of all profiles sampled by the DynamicProfileSampler. With this the DynamicAgentTypeGenerator can generate an AgentType
C SceneryConverter
C SecondaryDriverTasksSignal
C Sensor_Distance_Implementation | This module is a basic module to sense the current state of an agent
C SensorDataSignal
C SensorDetectionResults
C SensorDriverCalculations | Utility class for the sensor driver
C SensorDriverImplementation
C SensorDriverSignal
C SensorFusionHelperFunctions
C SensorFusionImplementation | This class is the SensorFusion module
C SensorGeometric2D | This file models a sensor which only detects agents in a 2D area (x/y) in front of the agent
C SensorRecordStateImplementation | Records the state of the agent
C SignalPrioritizerImplementation | This class manages the routing of signals to the sepcific components
C SignalVector | Primitive signal class for vectors
C SimulationTimeCondition
C SpawnPoint_Start_Implementation | Spawn agents at the beginning of road
C SpawnPointDependencies
C SpawnPointLibraryInfo
C SpawnPointPreRunCommon | Spawns agents for all scenarios
C SpawnPointRuntimeCommon
C SpawnPointScenario | Spawns agents for all scenarios
C SpeedActionManipulator | This class emits the SpeedActionEvent
C SpeedActionSignal | Signal class
C STCoordinates
C SteeringController
C SteeringSignal | Signal class
C StochasticsImplementation | Implementation of StochasticsInterface
C Stream
C StreamInfo
C SurroundingObjects
C Tire | Static tire model based on TMEASY by Rill et al
C TrafficHelperFunctions | Containing general static functions to evaluate traffic situations
C TrafficObjectAdapter
C TrafficRuleInformation | This struct contains infrastructure information of surrounding lanes that are used to establish traffic rules
C TrajectoryFollowerImplementation | Makes an agent strictly follow a predefined path
C TrajectoryManipulator | This manipulator sets a trajectory for an agent
C TrajectorySignal | Signal class
►C TtcCalculations | Containing functions to calculate time to collision of two objects
C TtcParameters | Structure to hold all necessary world object parameters for TTC calculation
C VehicleCompToCompCtrlSignal
C VehicleModelParameters
C VehicleSimpleTT | Simple STATIC two-track vehicle model
C World_Basic_Implementation | Implementation of a WorldInterface
C WorldAnalyzer | This class provides utility functions for spawners to query information about the world
C WorldDataQuery | Helper class for complex queries on the world data
C WorldImplementation | Implementation of a WorldInterface
C WorldObjectAdapter
C WorldParameter
C WorldParameterOSI
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Common Namespace Reference

  • Namespace Members
Classes
Common Namespace Reference

This file implements a generic 2D vector. More...

Classes

struct | Line
class | Vector2d
class | Vector3d

Detailed Description

This file implements a generic 2D vector.

This file implements a generic 3D vector.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Line Struct Reference

  • Common
  • Line
List of all members
Line Struct Reference
Collaboration diagram for Line:
[legend]
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Vector2d Class Reference

  • Common
  • Vector2d
Public Member Functions | Friends | List of all members
Vector2d Class Referencefinal

Public Member Functions

constexpr | Vector2d (double x=0, double y=0) noexcept
constexpr void | Translate (double x, double y) noexcept
constexpr void | Translate (Vector2d translationVector) noexcept
Translate translation of vector via another vector. More...
void | Rotate (double angle) noexcept
constexpr void | Scale (double scale) noexcept
constexpr void | Add (const Vector2d &in) noexcept
constexpr void | Sub (const Vector2d &in) noexcept
constexpr double | Dot (const Vector2d &in) const noexcept
constexpr double | Cross (const Vector2d &in) const noexcept
bool | Norm ()
double | Length () const noexcept
double | Angle () const noexcept
Angle returns the angle of the vector [-pi,+pi]. More...
constexpr bool | operator== (const Vector2d &in) const noexcept
Comparison operator taking EPSILON of 1e-9 into account. More...
constexpr bool | operator!= (const Vector2d &in) const noexcept
Inequality operator taking EPSILON of 1e-9 into account. More...

Friends

std::ostream & operator<< (std::ostream &os, const Vector2d &vector)
Overload << operator for Vector2d.

Detailed Description

class for 2d vectors in cartesian coordinate system

Constructor & Destructor Documentation

constexpr Vector2d | ( | double | x = 0,
 |  | double | y = 0
 | ) |  |
inlinenoexcept

create 2d vector from pair (x,y)

Parameters
[in] | x | x-value
[in] | y | y-value

Member Function Documentation

constexpr void Translate | ( | double | x,
 |  | double | y
 | ) |  |
inlinenoexcept

translation of vector

Parameters
[in] | x | x-value of displacement vector
[in] | y | y-value of displacement vector

Here is the caller graph for this function:

constexpr void Translate ( Vector2d translationVector )
inlinenoexcept

Translate translation of vector via another vector.

Parameters
[in] translationVector vector of translation
void Rotate ( double angle )
inlinenoexcept

rotates vector by angle

Parameters
[in] angle angle, in radians

Here is the caller graph for this function:

constexpr void Scale ( double scale )
inlinenoexcept

scales vector by a factor

Parameters
[in] scale scaling factor
constexpr void Add ( const Vector2d & in )
inlinenoexcept

adds a vector

Parameters
[in] in added 2d vector
constexpr void Sub ( const Vector2d & in )
inlinenoexcept

subtracts a vector

Parameters
[in] in subtracted 2d vector
constexpr double Dot ( const Vector2d & in ) const
inlinenoexcept

scalar product / dot product

Parameters
[in] in 2d vector
Returns
returns dot product of the 2 vectors
constexpr double Cross ( const Vector2d & in ) const
inlinenoexcept

cross product with Z=0

Parameters
[in] in 2d vector
Returns
returns z-component of the cross product
bool Norm ( )
inline

Normalizes the 2d vector

Each component of the vector is devided by the length of the vector.

In case of a vector with length 0, the vector cannot be normalized and false is returned.

Returns
returns true if vector could be normalized, false otherwise
double Length ( ) const
inlinenoexcept

returns length of the vector

Returns
length of the vector
double Angle ( ) const
inlinenoexcept

Angle returns the angle of the vector [-pi,+pi].

Returns
angle of vector
constexpr bool operator== ( const Vector2d & in ) const
inlinenoexcept

Comparison operator taking EPSILON of 1e-9 into account.

Parameters
in[in] Vector to compare to
Returns
true if vectors are considered equal, false otherwise
constexpr bool operator!= ( const Vector2d & in ) const
inlinenoexcept

Inequality operator taking EPSILON of 1e-9 into account.

Parameters
in[in] Vector to compare to
Returns
false if vectors are considered equal, true otherwise
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Vector3d Class Reference

  • Common
  • Vector3d
Public Member Functions | List of all members
Vector3d Class Reference

Public Member Functions

Vector3d (double x=0, double y=0, double z=0)
void | Translate (double x, double y, double z)
void | Scale (double scale)
void | Add (const Vector3d &in)
void | Sub (const Vector3d &in)
bool | Norm ()
double | Length () const

Detailed Description

class for 3d vectors in cartesian coordinate system

Constructor & Destructor Documentation

Vector3d | ( | double | x = 0,
 |  | double | y = 0,
 |  | double | z = 0
 | ) |  |

create 2d vector from pair (x, y, z)

Parameters
[in] | x | x-value
[in] | y | y-value
[in] | z | z-value

Member Function Documentation

void Translate | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) |  |

translation of vector

Parameters
[in] | x | x-value of displacement vector
[in] | y | y-value of displacement vector
[in] | z | z-value of displacement vector
void Scale ( double scale )

scales vector by a factor

Parameters
[in] scale scaling factor
void Add ( const Vector3d & in )

adds a vector

Parameters
[in] in added 3d vector
void Sub ( const Vector3d & in )

subtracts a vector

Parameters
[in] in subtracted 3d vector
bool Norm ( )

Normalizes the 3d vector

Each component of the vector is devided by the length of the vector.

In case of a vector with length 0, the vector cannot be normalized and false is returned.

Returns
returns true if vector could be normalized, false otherwise
double Length ( ) const

returns length of the vector

Returns
length of the vector
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Entity Struct Reference

  • CommonTrafficSign
  • Entity
List of all members
Entity Struct Reference
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AdasComponentStateInformation Class Reference

  • ComponentControl
  • AdasComponentStateInformation
Public Member Functions | List of all members
AdasComponentStateInformation Class Reference
Inheritance diagram for AdasComponentStateInformation:
[legend]
Collaboration diagram for AdasComponentStateInformation:
[legend]

Public Member Functions

AdasType | GetAdasType () const
GetAdasType gets the adas type of the contained component information. More...
ComponentState | DetermineDefaultMaximumComponentStateByType () const
DetermineDefaultMaximumComponentStateByType determines the default max reachable state by adas type of this component. More...
- Public Member Functions inherited from ComponentStateInformation
ComponentType | GetComponentType () const
GetComponentType Gets the component type of the contained component information. More...
std::string | GetComponentName () const
GetComponentName gets the component name of the contained component information. More...
ComponentState | GetCurrentState () const
GetCurrentState gets the current state of the contained component information. More...
void | SetCurrentState (const ComponentState currentState)
SetCurrentState sets the current state of the contained component information. More...
void | SetDesiredState (const ComponentState desiredState)
SetDesiredState sets the desired state of the contained component information. More...
ComponentState | GetMaxReachableState () const
GetMaxReachableState gets the max reachable state of the contained component information. More...
void | SetMaxReachableState (const ComponentState maxReachableState)
SetMaxReachableState sets the max reachable state of the contained component information. More...
bool | GetMaxReachableStateSetByEvent () const
GetMaxReachableStateSetByEvent gets the flag indicating whether the max reachable state was set by an event. More...
void | SetMaxReachableStateSetByEvent (const bool maxReachableStateSetByEvent)
SetMaxReachableStateSetByEvent sets the flag indicating whether the max reachable state was set by an event. More...
void | AddStateCondition (std::shared_ptr< Condition > condition, const ComponentState state)
Adds a conditional state to the bottom of the list of conditional states. More...
const std::vector< std::pair< std::shared_ptr< Condition >, ComponentState > > & | GetStateConditions () const
GetStateConditions gets a const ref to the std::vector containing pairs of Conditions to ComponentStates which define max reachable states given fulfillment of conditions. More...

Member Function Documentation

AdasType GetAdasType ( ) const

GetAdasType gets the adas type of the contained component information.

Returns
Gets the ADAS type of the contained component information as an AdasType
ComponentState DetermineDefaultMaximumComponentStateByType ( ) const

DetermineDefaultMaximumComponentStateByType determines the default max reachable state by adas type of this component.

Returns
the default max reachable component state for the adas type of this component
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ComponentStateEquality Class Reference

  • ComponentControl
  • ComponentStateEquality
List of all members
ComponentStateEquality Class Reference

This Condition is fullfilled if two ComponentStateExpressions are evaluated to the same value. More...

Inheritance diagram for ComponentStateEquality:
[legend]
Collaboration diagram for ComponentStateEquality:
[legend]

Additional Inherited Members

Detailed Description

This Condition is fullfilled if two ComponentStateExpressions are evaluated to the same value.

The ComponentStateEquality is used either to check, wether the state of two components is the same, or to check of the state of some component is equal to some fixed value (e.g. Acting).

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ComponentStateExpression Class Reference

  • ComponentControl
  • ComponentStateExpression
Public Member Functions | List of all members
ComponentStateExpression Class Referenceabstract

This class represents an expression that can be evaluated as ComponentState. More...

Inheritance diagram for ComponentStateExpression:
[legend]

Public Member Functions

virtual ComponentState Get (const StateMapping &componentNameToComponentTypeAndStateMap) const =0
Evaluates this expression. More...

Detailed Description

This class represents an expression that can be evaluated as ComponentState.

A ComponentStateExpression is either a fixed value or the ComponentState of some named component.

Member Function Documentation

virtual ComponentState Get ( const StateMapping & componentNameToComponentTypeAndStateMap ) const
pure virtual

Evaluates this expression.

Parameters
componentNameToComponentTypeAndStatesMap Information the ComponentController has gathered
Returns
ComponentState this expression evaluates to
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ComponentStateInformation Class Reference

  • ComponentControl
  • ComponentStateInformation
Public Member Functions | List of all members
ComponentStateInformation Class Reference

The ComponentStateConfiguration class handles the dependencies of a single component. More...

Inheritance diagram for ComponentStateInformation:
[legend]

Public Member Functions

ComponentType | GetComponentType () const
GetComponentType Gets the component type of the contained component information. More...
std::string | GetComponentName () const
GetComponentName gets the component name of the contained component information. More...
ComponentState | GetCurrentState () const
GetCurrentState gets the current state of the contained component information. More...
void | SetCurrentState (const ComponentState currentState)
SetCurrentState sets the current state of the contained component information. More...
void | SetDesiredState (const ComponentState desiredState)
SetDesiredState sets the desired state of the contained component information. More...
ComponentState | GetMaxReachableState () const
GetMaxReachableState gets the max reachable state of the contained component information. More...
void | SetMaxReachableState (const ComponentState maxReachableState)
SetMaxReachableState sets the max reachable state of the contained component information. More...
bool | GetMaxReachableStateSetByEvent () const
GetMaxReachableStateSetByEvent gets the flag indicating whether the max reachable state was set by an event. More...
void | SetMaxReachableStateSetByEvent (const bool maxReachableStateSetByEvent)
SetMaxReachableStateSetByEvent sets the flag indicating whether the max reachable state was set by an event. More...
void | AddStateCondition (std::shared_ptr< Condition > condition, const ComponentState state)
Adds a conditional state to the bottom of the list of conditional states. More...
const std::vector< std::pair< std::shared_ptr< Condition >, ComponentState > > & | GetStateConditions () const
GetStateConditions gets a const ref to the std::vector containing pairs of Conditions to ComponentStates which define max reachable states given fulfillment of conditions. More...

Detailed Description

The ComponentStateConfiguration class handles the dependencies of a single component.

The ComponentStateConfiguration consist of an ordered list of conditional states and a default state. The conditions of the list are evaluated from top to bottom and the first fullfilled condition defines the maxReachableState of the component. If no condition is fullfilled then the defaultState is the maxReachableState.

Member Function Documentation

ComponentType GetComponentType ( ) const

GetComponentType Gets the component type of the contained component information.

Returns
Gets the component type of the contained component information as a ComponentType
std::string GetComponentName ( ) const

GetComponentName gets the component name of the contained component information.

Returns
Gets the component name of the contained component information as a std::string
ComponentState GetCurrentState ( ) const

GetCurrentState gets the current state of the contained component information.

Returns
Gets the current state of the contained component information as a ComponentState
void SetCurrentState ( const ComponentState currentState )

SetCurrentState sets the current state of the contained component information.

Parameters
currentState The new current state of the contained component information as a ComponentState
void SetDesiredState ( const ComponentState desiredState )

SetDesiredState sets the desired state of the contained component information.

Parameters
desiredState The new desired state of the contained component information as a ComponentState
ComponentState GetMaxReachableState ( ) const

GetMaxReachableState gets the max reachable state of the contained component information.

Returns
the max reachable state of the contained component information
void SetMaxReachableState ( const ComponentState maxReachableState )

SetMaxReachableState sets the max reachable state of the contained component information.

Parameters
the new max reachable state of the contained component information
bool GetMaxReachableStateSetByEvent ( ) const

GetMaxReachableStateSetByEvent gets the flag indicating whether the max reachable state was set by an event.

Returns
the flag indicating whether the max reachable state was set by an event
void SetMaxReachableStateSetByEvent ( const bool maxReachableStateSetByEvent )

SetMaxReachableStateSetByEvent sets the flag indicating whether the max reachable state was set by an event.

Parameters
the new value for the flag indicating whether the max reachable state was set by an event
void AddStateCondition | ( | std::shared_ptr< Condition > | condition,
 |  | const ComponentState | state
 | ) |  |

Adds a conditional state to the bottom of the list of conditional states.

Parameters
condition | - the condition for which the state should be selected
state | - the state which should be selected, given the condition
const std::vector<std::pair<std::shared_ptr<Condition>, ComponentState> >& GetStateConditions ( ) const

GetStateConditions gets a const ref to the std::vector containing pairs of Conditions to ComponentStates which define max reachable states given fulfillment of conditions.

Returns
a const ref to a std::vector containing pairs of conditions and their related states
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Condition Class Reference

  • ComponentControl
  • Condition
Public Member Functions | List of all members
Condition Class Referenceabstract

This class represents a Condition based on all the information the ComponentController has gathered. More...

Inheritance diagram for Condition:
[legend]

Public Member Functions

virtual bool IsFullfilled (const StateMapping &componentNameToComponentTypeAndStatesMap) const =0
Returns wether this Condition is fullfilled. More...

Detailed Description

This class represents a Condition based on all the information the ComponentController has gathered.

The Statemanager uses this to decide which maxReachableState a component has. The different kinds of conditions are subclasses of this class

Member Function Documentation

virtual bool IsFullfilled ( const StateMapping & componentNameToComponentTypeAndStatesMap ) const
pure virtual

Returns wether this Condition is fullfilled.

Parameters
componentNameToComponentTypeAndStatesMap Information the ComponentController has gathered
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: FixedComponentStateExpression Class Reference

  • ComponentControl
  • FixedComponentStateExpression
Public Member Functions | List of all members
FixedComponentStateExpression Class Reference

The FixedComponentStateExpression is a ComponentStateExpression that always evaluates to the same ComponentState. More...

Inheritance diagram for FixedComponentStateExpression:
[legend]
Collaboration diagram for FixedComponentStateExpression:
[legend]

Public Member Functions

FixedComponentStateExpression (ComponentState value)

Detailed Description

The FixedComponentStateExpression is a ComponentStateExpression that always evaluates to the same ComponentState.

Constructor & Destructor Documentation

FixedComponentStateExpression ( ComponentState value )
inline
Parameters
value The fixed ComponentState
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: StateManager Class Reference

  • ComponentControl
  • StateManager
Public Member Functions | Private Member Functions | List of all members
StateManager Class Reference

The StateManager class handles the dependencies of all components. More...

Public Member Functions

void | AddComponent (const int localLinkId, std::shared_ptr< ComponentStateInformation > componentStateInformation)
Adds a new component which has dependencies to other components. More...
std::shared_ptr< ComponentStateInformation > | GetComponent (const int localLinkId) const
GetComponent gets a registered component by its local link id. More...
ComponentState | GetMaxReachableStateOfComponentAtLocalLinkId (const int localLinkId) const
GetMaxReachableStateOfComponentAtLocalLinkId gets the current max reachable state for a component registered at localLinkId. More...
int | GetComponentLocalLinkIdByName (const std::string &componentName) const
GetComponentLocalLinkIdByName gets the localLinkId registered for a specified component name. More...
void | UpdateComponentCurrentState (const int localLinkId, const ComponentState currentState)
UpdateComponentCurrentState updates the current state of the component as represented in the ComponentController. More...
void | UpdateComponentDesiredState (const int localLinkId, ComponentState desiredState)
UpdateComponentDesiredState updates the desired state of the component as represented in the ComponentController. More...
void | UpdateComponentMaxReachableState (const int localLinkId, ComponentState maxReachableState)
UpdateComponentMaxReachableState updates the max reachable state of the component as represented in the ComponentController. More...
std::map< std::string, std::pair< ComponentType, ComponentState > > | GetVehicleComponentNamesToTypeAndStateMap ()
GetVehicleComponentNameToTypesAndStatesMap. More...
bool | LocalLinkIdIsRegistered (const int localLinkId) const
LocalLinkIdIsRegistered. More...
void | FlagComponentMaxReachableStateSetByEvent (const int localLinkId)
FlagComponentMaxReachableStateSetByEvent sets the flag noting that the component's max reachable state was set by an event. More...
void | UpdateMaxReachableStatesForRegisteredComponents (std::vector< openpass::events::ComponentStateChangeEvent const * > &componentStateChanges)
UpdateMaxReachableStatesForRegisteredComponents Calculates and updates the max reachable states for the registered components using the provided event list (filtered to include only ComponentStateChangeEvents and only for the agentId of the ComponentController owning the statemanager) and registered Condition-state pairs. More...

Private Member Functions

void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message) const

Detailed Description

The StateManager class handles the dependencies of all components.

Member Function Documentation

void AddComponent | ( | const int | localLinkId,
 |  | std::shared_ptr< ComponentStateInformation > | componentStateInformation
 | ) |  |

Adds a new component which has dependencies to other components.

Parameters
name | name of the component
config | dependencies of the component
Returns
true if there is not already a component of this name, false otherwise
std::shared_ptr<ComponentStateInformation> GetComponent ( const int localLinkId ) const

GetComponent gets a registered component by its local link id.

Parameters
localLinkId the localLinkId representing the local channel to which the desired component was registered
Returns
The information regarding the component as a ComponentStateInformation
ComponentState GetMaxReachableStateOfComponentAtLocalLinkId ( const int localLinkId ) const

GetMaxReachableStateOfComponentAtLocalLinkId gets the current max reachable state for a component registered at localLinkId.

Parameters
localLinkId the id for the interesting component
Returns
the current max reachable state of the component as a ComponentState type
int GetComponentLocalLinkIdByName ( const std::string & componentName ) const

GetComponentLocalLinkIdByName gets the localLinkId registered for a specified component name.

Parameters
componentName the name of the registered component
Returns
The localLinkId for the component
void UpdateComponentCurrentState | ( | const int | localLinkId,
 |  | const ComponentState | currentState
 | ) |  |

UpdateComponentCurrentState updates the current state of the component as represented in the ComponentController.

Parameters
localLinkId | the localLinkId of the component
currentState | the new state of the component
void UpdateComponentDesiredState | ( | const int | localLinkId,
 |  | ComponentState | desiredState
 | ) |  |

UpdateComponentDesiredState updates the desired state of the component as represented in the ComponentController.

Parameters
localLinkId | the localLinkId of the component
desiredState | the new desired state of the component
void UpdateComponentMaxReachableState | ( | const int | localLinkId,
 |  | ComponentState | maxReachableState
 | ) |  |

UpdateComponentMaxReachableState updates the max reachable state of the component as represented in the ComponentController.

Parameters
localLinkId | the localLinkId of the component
maxReachableState | the new maxReachableState of the component
std::map<std::string, std::pair<ComponentType, ComponentState> > GetVehicleComponentNamesToTypeAndStateMap ( )

GetVehicleComponentNameToTypesAndStatesMap.

Returns
a std::map of component names to a pair containing their respective ADAS type and ComponentState as represented in the ComponentController
bool LocalLinkIdIsRegistered ( const int localLinkId ) const

LocalLinkIdIsRegistered.

Parameters
localLinkId the localLinkId to test for registration
Returns
whether or not the localLinkId is registered
void FlagComponentMaxReachableStateSetByEvent ( const int localLinkId )

FlagComponentMaxReachableStateSetByEvent sets the flag noting that the component's max reachable state was set by an event.

Parameters
localLinkId the localLinkId of the component for which the flag shoule be set
void UpdateMaxReachableStatesForRegisteredComponents ( std::vector< openpass::events::ComponentStateChangeEvent const * > & componentStateChanges )

UpdateMaxReachableStatesForRegisteredComponents Calculates and updates the max reachable states for the registered components using the provided event list (filtered to include only ComponentStateChangeEvents and only for the agentId of the ComponentController owning the statemanager) and registered Condition-state pairs.

Parameters
componentStateChanges the event list from the event network, filtered to include only those events related to the agentId of the controlling ComponentController and only including ComponentStateChangeEvents
void Log | ( | CbkLogLevel | logLevel,
 |  | const char * | file,
 |  | int | line,
 |  | const std::string & | message
 | ) |  | const
 inlineprivate

Provides callback to LOG() macro

Parameters
[in] | logLevel | Importance of log
[in] | file | Name of file where log is called
[in] | line | Line within file where log is called
[in] | message | Message to log
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: VehicleComponentStateExpression Class Reference

  • ComponentControl
  • VehicleComponentStateExpression
Public Member Functions | List of all members
VehicleComponentStateExpression Class Reference

The VehicleComponentStateExpression is a ComponentStateExpression that evaluates to the current state of some fixed component. More...

Inheritance diagram for VehicleComponentStateExpression:
[legend]
Collaboration diagram for VehicleComponentStateExpression:
[legend]

Public Member Functions

VehicleComponentStateExpression (const std::string &component)

Detailed Description

The VehicleComponentStateExpression is a ComponentStateExpression that evaluates to the current state of some fixed component.

Constructor & Destructor Documentation

VehicleComponentStateExpression ( const std::string & component )
inline
Parameters
component Name of the component of which the state is evaluated
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ConfigurationContainer Class Reference

  • Configuration
  • ConfigurationContainer
Public Member Functions | List of all members
ConfigurationContainer Class Reference

This class imports and stores all configurations. More...

Inheritance diagram for ConfigurationContainer:
[legend]
Collaboration diagram for ConfigurationContainer:
[legend]

Public Member Functions

bool | ImportAllConfigurations () override
This functions imports all confiugrations. More...
std::shared_ptr< SystemConfigInterface > | GetSystemConfigBlueprint () override
Returns a pointer to the SystemConfigBlueprint. More...
SlaveConfigInterface * | GetSlaveConfig () override
Returns a pointer to the SlaveConfig. More...
ProfilesInterface * | GetProfiles () override
Returns a pointer to the Profiles. More...
SceneryInterface * | GetScenery () override
Returns a pointer to the Scenery. More...
ScenarioInterface * | GetScenario () override
Returns a pointer to the Scenario. More...
std::map< std::string, std::shared_ptr< SystemConfigInterface > > & | GetSystemConfigs () override
Returns imported systemConfigs. More...
VehicleModelsInterface * | GetVehicleModels () override
Returns a pointer to the VehicleModels. More...
const openpass::common::RuntimeInformation & | GetRuntimeInformation () const override
Returns the RunTimeInformation. More...

Detailed Description

This class imports and stores all configurations.

Member Function Documentation

bool ImportAllConfigurations ( )
override

This functions imports all confiugrations.

This function imports all configurations and stores them.

Returns
true, if successful
std::shared_ptr<SystemConfigInterface> GetSystemConfigBlueprint ( )
override

Returns a pointer to the SystemConfigBlueprint.

Returns
SystemConfigBlueprint pointer
SlaveConfigInterface* GetSlaveConfig ( )
override

Returns a pointer to the SlaveConfig.

Returns
SlaveConfig pointer
ProfilesInterface* GetProfiles ( )
override

Returns a pointer to the Profiles.

Returns
Profiles pointer
SceneryInterface* GetScenery ( )
override

Returns a pointer to the Scenery.

Returns
Scenery pointer
ScenarioInterface* GetScenario ( )
override

Returns a pointer to the Scenario.

Returns
Scenario pointer
std::map<std::string, std::shared_ptr<SystemConfigInterface> >& GetSystemConfigs ( )
override

Returns imported systemConfigs.

Returns
systemConfigs map
VehicleModelsInterface* GetVehicleModels ( )
override

Returns a pointer to the VehicleModels.

Returns
VehicleModels pointer
const openpass::common::RuntimeInformation& GetRuntimeInformation ( ) const
override

Returns the RunTimeInformation.

Returns
RunTimeInformation
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Scenario Class Reference

  • Configuration
  • Scenario
Public Member Functions | Private Attributes | List of all members
Scenario Class Reference
Inheritance diagram for Scenario:
[legend]
Collaboration diagram for Scenario:
[legend]

Public Member Functions

const std::string & | GetVehicleCatalogPath () override
Getter for vehicle catalog path. More...
void | SetVehicleCatalogPath (const std::string &catalogPath) override
Setter for vehicle catalog path. More...
const std::string & | GetPedestrianCatalogPath () override
Getter for pedestrian catalog path. More...
void | SetPedestrianCatalogPath (const std::string &catalogPath) override
Setter for pedestrian catalog path. More...
const std::string & | GetTrajectoryCatalogPath () override
Retreives the path to the trajectory catalog file. More...
void | SetTrajectoryCatalogPath (const std::string &catalogPath) override
const std::string & | GetSceneryPath () override
Getter for scenery path. More...
void | SetSceneryPath (const std::string &sceneryPath) override
Setter for scenery path. More...

Private Attributes

std::string | vehicleCatalogPath
The path of the vehicle catalog (relative to Scenario.xosc)
std::string | pedestrianCatalogPath
The path of the pedestrian catalog (relative to Scenario.xosc)
std::string | trajectoryCatalogPath
The path of the trajectory catalog (relative to Scenario.xosc)
std::string | sceneryPath
The path of the scenery file (relative to Scenario.xosc)
double | endTimeInSeconds
The simulationTime at which the simulation should end.

Member Function Documentation

const std::string& GetVehicleCatalogPath ( )
override

Getter for vehicle catalog path.

Returns
The relative file path to the OpenSCENARIO vehicle catalog in use
void SetVehicleCatalogPath ( const std::string & catalogPath )
override

Setter for vehicle catalog path.

Parameters
[in] catalogPath Relative file path to the OpenSCENARIO vehicle catalog to use
const std::string& GetPedestrianCatalogPath ( )
override

Getter for pedestrian catalog path.

Returns
The relative file path to the OpenSCENARIO pedestrian catalog in use
void SetPedestrianCatalogPath ( const std::string & catalogPath )
override

Setter for pedestrian catalog path.

Parameters
[in] catalogPath Relative file path to the OpenSCENARIO pedestrian catalog to use
const std::string& GetTrajectoryCatalogPath ( )
override

Retreives the path to the trajectory catalog file.

Returns
Relative path to the trajectory catalog
void SetTrajectoryCatalogPath ( const std::string & catalogPath )
override

Sets the path to the trajectory catalog file

Parameters
[in] catalogPath Relative path to the trajectory catalog file
const std::string& GetSceneryPath ( )
override

Getter for scenery path.

Returns
The relative file path to the OpenDRIVE scenery in use
void SetSceneryPath ( const std::string & sceneryPath )
override

Setter for scenery path.

Parameters
[in] sceneryPath Relative file path to the OpenDRIVE scenery to use
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Scenery Class Reference

  • Configuration
  • Scenery
Public Member Functions | List of all members
Scenery Class Reference

Class representing a scenery as a list of roads. More...

Inheritance diagram for Scenery:
[legend]
Collaboration diagram for Scenery:
[legend]

Public Member Functions

void | Clear ()
Clears the scenery by deleting all stored roads.
RoadInterface * | AddRoad (const std::string &id)
JunctionInterface * | AddJunction (const std::string &id)
const std::map< std::string, RoadInterface * > & | GetRoads () const
const std::map< std::string, JunctionInterface * > & | GetJunctions () const
const JunctionInterface * | GetJunction (const std::string &id) const
const RoadInterface * | GetRoad (const std::string &id) const

Detailed Description

Class representing a scenery as a list of roads.

Member Function Documentation

RoadInterface* AddRoad ( const std::string & id )

Adds a new road to a scenery by creating a new Road object and adding it via its ID to a stored mapping of roads.

Parameters
[in] id ID of the road to add
Returns
created road
JunctionInterface* AddJunction ( const std::string & id )

Adds a new junction to a scenery by creating a new Junction object and adding it via its ID to a stored mapping of junctions.

Parameters
[in] id ID of the junction to add
Returns
created junction
const std::map<std::string, RoadInterface*>& GetRoads ( ) const
inline

Returns the stored list of roads.

Returns
list of roads
const std::map<std::string, JunctionInterface*>& GetJunctions ( ) const
inline

Returns the stored list of junctions.

Returns
list of junctions
const JunctionInterface* GetJunction ( const std::string & id ) const
inline

Returns the junction with the provided ID from the scenery.

Parameters
[in] id ID of the junction
Returns
junction with the provided ID
const RoadInterface* GetRoad ( const std::string & id ) const
inline

Returns the road with the provided ID from the scenery.

Parameters
[in] id ID of the road
Returns
road with the provided ID
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SlaveConfig Class Reference

  • Configuration
  • SlaveConfig
List of all members
SlaveConfig Class Reference

Container class for the slave configuration. More...

Inheritance diagram for SlaveConfig:
[legend]
Collaboration diagram for SlaveConfig:
[legend]

Detailed Description

Container class for the slave configuration.

This class stores all information provided by the slaveConfig.xml and provides access to this information

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SystemConfig Class Reference

  • Configuration
  • SystemConfig
List of all members
SystemConfig Class Reference
Inheritance diagram for SystemConfig:
[legend]
Collaboration diagram for SystemConfig:
[legend]
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: VehicleModels Class Reference

  • Configuration
  • VehicleModels
List of all members
VehicleModels Class Reference
Inheritance diagram for VehicleModels:
[legend]
Collaboration diagram for VehicleModels:
[legend]
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: EventDetectorImporter Class Reference

  • Importer
  • EventDetectorImporter
Static Public Member Functions | Static Private Member Functions | List of all members
EventDetectorImporter Class Reference

Static Public Member Functions

static openScenario::ConditionalEventDetectorInformation ImportEventDetector (QDomElement &eventElement, const std::string &eventName, const int numberOfExecutions, const openScenario::ActorInformation &actorInformation, const std::vector< ScenarioEntity > &entities, openScenario::Parameters &parameters)
ImportEventDetector parses information from an EventElement for instantiation of a ConditionalEventDetector. More...

Static Private Member Functions

static openScenario::Condition | ImportConditionElement (QDomElement &conditionElement, const std::vector< ScenarioEntity > &entities, openScenario::Parameters &parameters)
Imports a condition element of a OpenSCENARIO storyboard DOM. More...
static openScenario::Condition | ImportByEntityElement (QDomElement byEntityElement, const std::vector< ScenarioEntity > &entities, openScenario::Parameters &parameters)
Imports a ByEntity condition element of a OpenSCENARIO storyboard DOM. More...
static openScenario::Condition | ImportEntityCondition (QDomElement byEntityCondition, std::vector< std::string > triggeringEntities)
Imports a EntityCondition element of a OpenSCENARIO storyboard DOM. More...
static openScenario::Condition | ImportConditionByValueElement (QDomElement &byValueElement, openScenario::Parameters &parameters)
ImportConditionByValueElement Imports a Condition ByValue element into a condition parameter interface. More...
static bool | ContainsEntity (const std::vector< ScenarioEntity > &entities, const std::string &entityName)
Tests, if a entity with a given name is included in the provided vector of scenario entities. More...

Member Function Documentation

static openScenario::ConditionalEventDetectorInformation ImportEventDetector | ( | QDomElement & | eventElement,
 |  | const std::string & | eventName,
 |  | const int | numberOfExecutions,
 |  | const openScenario::ActorInformation & | actorInformation,
 |  | const std::vector< ScenarioEntity > & | entities,
 |  | openScenario::Parameters & | parameters
 | ) |  |
static

ImportEventDetector parses information from an EventElement for instantiation of a ConditionalEventDetector.

Parameters
[in] | eventElement | the element from which to parse ConditionalEventDetector instantiation information
[in] | eventName | Name of the event used for identification e.g. "MyStory/MyAct/MySequence/MyManeuver/MyEvent"
[in] | numberOfExecutions | the maximum number of times the ConditionalEventDetector is to emit an event
[in] | actorInformation | information detailing what entities are the actors to be targeted by the ConditionalEventDetector's emitted events
[in] | entities | entities defined in openScenario Entities
Returns
a struct containing all information relevant for the

instantiation of a ConditionalEventDetector

static openScenario::Condition ImportConditionElement | ( | QDomElement & | conditionElement,
 |  | const std::vector< ScenarioEntity > & | entities,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports a condition element of a OpenSCENARIO storyboard DOM.

Parameters
[in] | conditionElement | The DOM root of the condition element
[in] | entities | Objects from 'Entities' tag
[in] | parameters | Declared parameters
static openScenario::Condition ImportByEntityElement | ( | QDomElement | byEntityElement,
 |  | const std::vector< ScenarioEntity > & | entities,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports a ByEntity condition element of a OpenSCENARIO storyboard DOM.

Parameters
[in] | byEntityElement | The DOM root of the by-entity element
[in] | entities | Objects from 'Entities' tag
[in] | parameters | Declared parameters
static openScenario::Condition ImportEntityCondition | ( | QDomElement | byEntityCondition,
 |  | std::vector< std::string > | triggeringEntities
 | ) |  |
staticprivate

Imports a EntityCondition element of a OpenSCENARIO storyboard DOM.

Parameters
[in] | byEntityCondition | The DOM root of the byEntityCondition element
[in] | triggeringEntities | Objects from 'Entities' tag

return Condition

static openScenario::Condition ImportConditionByValueElement | ( | QDomElement & | byValueElement,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

ImportConditionByValueElement Imports a Condition ByValue element into a condition parameter interface.

Parameters
[in] byValueElement the ByValue element to parse for condition details.
[in] parameters Declared parameters

openScenario Condition

static bool ContainsEntity | ( | const std::vector< ScenarioEntity > & | entities,
 |  | const std::string & | entityName
 | ) |  |
staticprivate

Tests, if a entity with a given name is included in the provided vector of scenario entities.

Parameters
[in] | entities | Vector of entities to test against
[in] | entityName | Name of the entity to check for existence
Returns
true, if entityName is included in entities, false otherwise.
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ProfilesImporter Class Reference

  • Importer
  • ProfilesImporter
Static Public Member Functions | List of all members
ProfilesImporter Class Reference

Static Public Member Functions

static void | ImportAgentProfiles (QDomElement agentProfilesElement, std::unordered_map< std::string, AgentProfile > &agentProfiles)
Imports the AgentProfiles section of the profiles catalog. More...
static void | ImportProfileGroups (ProfileGroups &profileGroups, QDomElement &profilesElement)
Imports all ProfileGroups defined in the profiles catalog. More...
static void | ImportVehicleProfiles (QDomElement vehicleProfilesElement, std::unordered_map< std::string, VehicleProfile > &vehicleProfiles)
Imports the AgentProfiles section of the profiles catalog. More...
static VehicleProfile | ImportVehicleProfile (QDomElement vehicleProfileElement)
Imports a single VehicleProfile. More...
static void | ImportAllVehicleComponentsOfVehicleProfile (QDomElement vehicleProfileElement, VehicleProfile &vehicleProfile)
Imports all VehicleComponentes contained in one VehicleProfile. More...
static void | ImportVehicleComponent (QDomElement vehicleComponentElement, VehicleComponent &vehicleComponent)
Imports a single VehicleComponentes contained in one VehicleProfile. More...
static void | ImportSensorLinksOfComponent (QDomElement sensorLinksElement, std::list< SensorLink > &sensorLinks)
Imports all SensorLinks of a VehicleComponents contained in one VehicleProfile. More...
static void | ImportAllSensorsOfVehicleProfile (QDomElement vehicleProfileElement, VehicleProfile &vehicleProfile)
Imports all Sensor contained in one VehicleProfiles. More...
static void | ImportSensorParameters (QDomElement sensorElement, openpass::sensors::Parameter &sensorParameter)
Imports a single Sensor contained in one VehicleProfile. More...
static bool | Import (const std::string &filename, Profiles &profiles)
Imports the entire profiles catalog. More...

Member Function Documentation

static void ImportAgentProfiles | ( | QDomElement | agentProfilesElement,
 |  | std::unordered_map< std::string, AgentProfile > & | agentProfiles
 | ) |  |
static

Imports the AgentProfiles section of the profiles catalog.

Parameters
[in] | agentProfilesElement | Element containing the information
[out] | agentProfiles | Map into which the values get saved
Returns
true, if successful
static void ImportProfileGroups | ( | ProfileGroups & | profileGroups,
 |  | QDomElement & | profilesElement
 | ) |  |
static

Imports all ProfileGroups defined in the profiles catalog.

Parameters
profileGroups | Element containing the information
profilesElement | Map into which the values get saved
static void ImportVehicleProfiles | ( | QDomElement | vehicleProfilesElement,
 |  | std::unordered_map< std::string, VehicleProfile > & | vehicleProfiles
 | ) |  |
static

Imports the AgentProfiles section of the profiles catalog.

Parameters
[in] | agentProfilesElement | Element containing the information
[out] | agentProfiles | Map into which the values get saved
Returns
true, if successful
static VehicleProfile ImportVehicleProfile ( QDomElement vehicleProfileElement )
static

Imports a single VehicleProfile.

Parameters
vehicleProfileElement | Element containing the information
vehicleProfile | VehicleProfile to fill
Returns
static void ImportAllVehicleComponentsOfVehicleProfile | ( | QDomElement | vehicleProfileElement,
 |  | VehicleProfile & | vehicleProfile
 | ) |  |
static

Imports all VehicleComponentes contained in one VehicleProfile.

Parameters
vehicleProfileElement | Element containing the information
vehicleProfile | VehicleProfile to fill
Returns
static void ImportVehicleComponent | ( | QDomElement | vehicleComponentElement,
 |  | VehicleComponent & | vehicleComponent
 | ) |  |
static

Imports a single VehicleComponentes contained in one VehicleProfile.

Parameters
vehicleComponentElement | Element containing the information
vehicleComponent | VehicleComponent to fill
Returns
static void ImportSensorLinksOfComponent | ( | QDomElement | sensorLinksElement,
 |  | std::list< SensorLink > & | sensorLinks
 | ) |  |
static

Imports all SensorLinks of a VehicleComponents contained in one VehicleProfile.

Parameters
sensorLinksElement | Element containing the information
sensorLinksElement | Map into which SensorLinks are saved
Returns
static void ImportAllSensorsOfVehicleProfile | ( | QDomElement | vehicleProfileElement,
 |  | VehicleProfile & | vehicleProfile
 | ) |  |
static

Imports all Sensor contained in one VehicleProfiles.

Parameters
vehicleProfileElement | Element containing the information
vehicleProfile | VehicleProfile to fill
Returns
static void ImportSensorParameters | ( | QDomElement | sensorElement,
 |  | openpass::sensors::Parameter & | sensorParameter
 | ) |  |
static

Imports a single Sensor contained in one VehicleProfile.

Parameters
sensorElement | Element containing the information
sensorParameter | SensorParameter to fill
Returns
static bool Import | ( | const std::string & | filename,
 |  | Profiles & | profiles
 | ) |  |
static

Imports the entire profiles catalog.

Calls all sections specific methods and saves the result in the CombiantionConfig

Parameters
[in] | filename | Name of the SlaveConfig file
[out] | slaveConfig | Calss into which the values get saved
Returns
true, if successful
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ScenarioImporter Class Reference

  • Importer
  • ScenarioImporter
Static Public Member Functions | Static Private Member Functions | Static Private Attributes | List of all members
ScenarioImporter Class Reference

Static Public Member Functions

static void | ImportEntity (QDomElement &entityElement, ScenarioEntity &entity, openScenario::Parameters &parameters)
Imports an entity of a OpenSCENARIO Entities DOM. More...
static void | ImportStoryboard (QDomElement &documentRoot, std::vector< ScenarioEntity > &entities, ScenarioInterface *scenario, openScenario::Parameters &parameters)
Imports the storyboard from OpenSCENARIO DOM. More...
static std::string | ImportCatalog (const std::string &catalogName, QDomElement &catalogsElement, openScenario::Parameters &parameters)
Imports a catalog tag. More...

Static Private Member Functions

static void | ImportAndValidateVersion (openScenario::Parameters &parameters)
Imports and validates the internally used OpenSCENARIO schema version. More...
static void | ImportCatalogs (QDomElement &documentRoot, ScenarioInterface *scenario, const std::string &filePath, openScenario::Parameters &parameters)
Imports catalogs from OpenSCENARIO DOM. More...
static void | ImportRoadNetwork (QDomElement &roadNetworkElement, std::string &sceneryPath, openScenario::Parameters &parameters)
Imports the roadnetwork information from OpenSCENARIO DOM. More...
static void | ImportInitElement (QDomElement &initElement, std::vector< ScenarioEntity > &entities, openScenario::Parameters &parameters)
Imports the init element of a OpenSCENARIO storyboard DOM. More...
static void | ImportEndConditionsFromStoryboard (const QDomElement &storyboardElement, ScenarioInterface *scenario, openScenario::Parameters &parameters)
Imports the simulation end conditions. More...
static void | ParseConditionAttributes (const QDomElement &conditionElement, std::string &name, double &delay, std::string &edge, openScenario::Parameters &parameters)
ParseConditionAttributes parses the attributes for a condition element. More...
static void | ParseSimulationTime (const QDomElement &byValueElement, double &value, std::string &rule, openScenario::Parameters &parameters)
ParseSimulationTime parses the simulation time tag according to the OpenSCENARIO standard. More...
static void | ImportEntities (QDomElement &documentRoot, std::vector< ScenarioEntity > &entities, std::map< std::string, std::list< std::string > > &groups, openScenario::Parameters &parameters)
Imports the entities element of a OpenSCENARIO DOM. More...
static void | ImportSelectionElements (QDomElement &entitiesElement, std::map< std::string, std::list< std::string >> &groups, openScenario::Parameters &parameters)
Imports a group definition of a OpenSCENARIO Selection DOM. More...
static void | ImportMembers (const QDomElement &membersElement, std::list< std::string > &members, openScenario::Parameters &parameters)
Imports a list of members of a OpenSCENARIO Members DOM. More...
static void | ImportEntityCatalogReference (QDomElement &catalogReferenceElement, ScenarioEntity &entity, openScenario::Parameters &parameters)
Imports a catalog reference of an entity of a OpenSCENARIO Entities DOM. More...
static void | ImportStoryElement (QDomElement &storyElement, const std::vector< ScenarioEntity > &entities, ScenarioInterface *scenario, openScenario::Parameters &parameters)
Imports a story element of a OpenSCENARIO storyboard DOM. More...
static openScenario::ActorInformation | ImportActors (QDomElement &actorsElement, const std::vector< ScenarioEntity > &entities, openScenario::Parameters &parameters)
Imports actors from of a OpenSCENARIO story DOM. More...
static void | ImportManeuverElement (QDomElement &maneuverElement, const std::vector< ScenarioEntity > &entities, ScenarioInterface *scenario, const openScenario::ActorInformation &actorInformation, const std::vector< std::string > &nameStack, const int numberOfExecutions, openScenario::Parameters &parameters)
Imports a maneuvre element of a OpenSCENARIO storyboard DOM. More...
static openScenario::Orientation | ImportOrientation (QDomElement &orientationElement, openScenario::Parameters &parameters)
Imports a orientation element of a OpenSCENARIO entity. More...
static void | ImportPrivateElement (QDomElement &privateElement, std::vector< ScenarioEntity > &entities, openScenario::Parameters &parameters)
Imports a private element of a OpenSCENARIO Storyboard/Init/Actions DOM. More...
static void | ImportPrivateElements (QDomElement &actionsElement, std::vector< ScenarioEntity > &entities, openScenario::Parameters &parameters)
Imports all private elements of a OpenSCENARIO actions DOM. More...
static bool | ContainsEntity (const std::vector< ScenarioEntity > &entities, const std::string &entityName)
Tests, if a entity with a given name is included in the provided vector of scenario entities. More...
static ScenarioEntity * | GetEntityByName (std::vector< ScenarioEntity > &entities, const std::string &entityName)
Returns the entity object contained in a vector of entities, selected by its name. More...
static void | CategorizeEntities (const std::vector< ScenarioEntity > &entities, const std::map< std::string, std::list< std::string > > &groups, ScenarioInterface *scenario)
Categorizes the provided entities and adds them to the scenario either as scanario entity or ego entity. More...
static openScenario::LanePosition | ImportLanePosition (QDomElement positionElement, openScenario::Parameters &parameters)
Imports an openScenario Lane-Position element. More...
static openScenario::WorldPosition | ImportWorldPosition (QDomElement positionElement, openScenario::Parameters &parameters)
Imports an openScenario World-Position element. More...
static openScenario::Action | ImportAction (QDomElement eventElement, openScenario::Parameters &parameters, const std::string catalogPath)
Imports an openScenario Action element. More...

Static Private Attributes

static constexpr auto supportedScenarioVersion = "0.4.0"
Currently supported "internal" OpenSCENARIO version.

Member Function Documentation

static void ImportEntity | ( | QDomElement & | entityElement,
 |  | ScenarioEntity & | entity,
 |  | openScenario::Parameters & | parameters
 | ) |  |
static

Imports an entity of a OpenSCENARIO Entities DOM.

Parameters
[in] | entityElement | The DOM root of the entity element
[out] | entity | Entity element data is imported into this container
[in] | parameters | declared parameters
static void ImportStoryboard | ( | QDomElement & | documentRoot,
 |  | std::vector< ScenarioEntity > & | entities,
 |  | ScenarioInterface * | scenario,
 |  | openScenario::Parameters & | parameters
 | ) |  |
static

Imports the storyboard from OpenSCENARIO DOM.

Parameters
[in] | documentRoot | The DOM root of the scenario file
[in] | entities | Objects from 'Entities' tag
[out] | scenario | The storyboard is imported into this scenario
[in] | parameters | declared parameters
static std::string ImportCatalog | ( | const std::string & | catalogName,
 |  | QDomElement & | catalogsElement,
 |  | openScenario::Parameters & | parameters
 | ) |  |
static

Imports a catalog tag.

Parameters
[in] | catalogName | Name of the catalog to import
[in] | catatalogsElement | DOM element holding all available catalogs
[in] | parameters | declared parameters
Returns
True on successful parsing, false otherwise.
static void ImportAndValidateVersion ( openScenario::Parameters & parameters )
staticprivate

Imports and validates the internally used OpenSCENARIO schema version.

Parameters
[in] parameters declared parameters
Returns
true if import succeeds and version matches, falso otherwise
static void ImportCatalogs | ( | QDomElement & | documentRoot,
 |  | ScenarioInterface * | scenario,
 |  | const std::string & | filePath,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports catalogs from OpenSCENARIO DOM.

Currently, vehicle and pedestrian catalogs are imported.

Parameters
[in] | documentRoot | The DOM root of the scenario file
[out] | scenario | Catalogs are imported into this scenario
[in] | parameters | declared parameters
static void ImportRoadNetwork | ( | QDomElement & | roadNetworkElement,
 |  | std::string & | sceneryPath,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports the roadnetwork information from OpenSCENARIO DOM.

Currently, the path to the OpenDRIVE scenery file is extracted.

Parameters
[in] | roadNetworkElement | DOM element of the roadnetwork tag
[out] | sceneryPath | File path to the scenery
[in] | parameters | declared parameters
static void ImportInitElement | ( | QDomElement & | initElement,
 |  | std::vector< ScenarioEntity > & | entities,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports the init element of a OpenSCENARIO storyboard DOM.

Parameters
[in] | initElement | The DOM of the storyboard init element
[in] | entities | Objects from 'Entities' tag
[in] | parameters | declared parameters
static void ImportEndConditionsFromStoryboard | ( | const QDomElement & | storyboardElement,
 |  | ScenarioInterface * | scenario,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports the simulation end conditions.

Parameters
[in] | storyboardElement | The storyboard DOM element
[out] | scenario | End conditions data is imported into this scenario
[in] | parameters | declared parameters
static void ParseConditionAttributes | ( | const QDomElement & | conditionElement,
 |  | std::string & | name,
 |  | double & | delay,
 |  | std::string & | edge,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

ParseConditionAttributes parses the attributes for a condition element.

Parameters
[in] | conditionElement
[out] | name | the value of the name attribute is parsed into this std::string
[out] | delay | the value of the delay attribute is parsed into this double
[out] | edge | the value of the edge attribute is parsed into this std::string
[in] | parameters | declared parameters
Exceptions
std::runtime_exception If name, delay, or edge is not specified, or if a negative delay is provided
static void ParseSimulationTime | ( | const QDomElement & | byValueElement,
 |  | double & | value,
 |  | std::string & | rule,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

ParseSimulationTime parses the simulation time tag according to the OpenSCENARIO standard.

Parameters
[in] | byValueElement | the byValueElement containing the SimulationTime element
[out] | value | the value of the value attribute of the SimulationTime element
[out] | rule | the value of the rule attribute of the SimulationTime element
[in] | parameters | declared parameters
Exceptions
std::runtime_exception If value or rule is not specified, or an invalid rule is provided
static void ImportEntities | ( | QDomElement & | documentRoot,
 |  | std::vector< ScenarioEntity > & | entities,
 |  | std::map< std::string, std::list< std::string > > & | groups,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports the entities element of a OpenSCENARIO DOM.

Parameters
[in] | documentRoot | The DOM root of the scenario file
[out] | entities | Entity element data is imported into this container
[in] | parameters | declared parameters
static void ImportSelectionElements | ( | QDomElement & | entitiesElement,
 |  | std::map< std::string, std::list< std::string >> & | groups,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports a group definition of a OpenSCENARIO Selection DOM.

Parameters
[in] | selectionElement | The DOM node of the selection element
[out] | groups | Groups element data is imported into this container
[in] | parameters | declared parameters
static void ImportMembers | ( | const QDomElement & | membersElement,
 |  | std::list< std::string > & | members,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports a list of members of a OpenSCENARIO Members DOM.

Parameters
[in] | membersElement | The DOM root of the members element
[out] | members | Members element data is imported into this container
static void ImportEntityCatalogReference | ( | QDomElement & | catalogReferenceElement,
 |  | ScenarioEntity & | entity,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports a catalog reference of an entity of a OpenSCENARIO Entities DOM.

Parameters
[in] | catalogReferenceElement | The DOM root of the catalog reference element
[out] | entity | Catalog refrence data is imported into this container
[in] | parameters | declared parameters
static void ImportStoryElement | ( | QDomElement & | storyElement,
 |  | const std::vector< ScenarioEntity > & | entities,
 |  | ScenarioInterface * | scenario,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports a story element of a OpenSCENARIO storyboard DOM.

Parameters
[in] | storyElement | The DOM root of the catalog reference element
[in] | entities | Objects from 'Entities' tag
[out] | scenario | The story data is imported into this scenario
[in] | parameters | declared parameters
static openScenario::ActorInformation ImportActors | ( | QDomElement & | actorsElement,
 |  | const std::vector< ScenarioEntity > & | entities,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports actors from of a OpenSCENARIO story DOM.

Parameters
[in] | actorsElement | The DOM root of the actors element
[in] | entities | Objects from 'Entities' tag
[in] | parameters | declared parameters
Returns
Actor names referenced in the DOM
static void ImportManeuverElement | ( | QDomElement & | maneuverElement,
 |  | const std::vector< ScenarioEntity > & | entities,
 |  | ScenarioInterface * | scenario,
 |  | const openScenario::ActorInformation & | actorInformation,
 |  | const std::vector< std::string > & | nameStack,
 |  | const int | numberOfExecutions,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports a maneuvre element of a OpenSCENARIO storyboard DOM.

Parameters
[in] | maneuverElement | The DOM root of the maneuver element
[in] | entities | Objects from 'Entities' tag
[out] | scenario | The maneuver data is imported into this scenario
[out] | actors | Actors from the maneuver are imported into this container
[in] | parameters | declared parameters

ImportManeuverElement

Parameters
maneuverElement | The DOM root of the maneuver element
entities | Objects from 'Entities' tag
scenario | The maneuver data is imported into this scenario
actorInformation | Information of actors from the maneuver
nameStack | List of names from tree structure e.g. {"myStory", "myAct", "myManeuver"}
numberOfExecutions | Number of executions
static openScenario::Orientation ImportOrientation | ( | QDomElement & | orientationElement,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports a orientation element of a OpenSCENARIO entity.

Parameters
[in] | orientationElement | The DOM root of the orientation element
[in] | parameters | declared parameters
Returns
orientation
static void ImportPrivateElement | ( | QDomElement & | privateElement,
 |  | std::vector< ScenarioEntity > & | entities,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports a private element of a OpenSCENARIO Storyboard/Init/Actions DOM.

Parameters
[in] | privateElement | The DOM root of the storyboard/init/action element
[in,out] | entities | Objects from 'Entities' tag. Containing spawn information will be set by this method call.
[in] | parameters | declared parameters
static void ImportPrivateElements | ( | QDomElement & | actionsElement,
 |  | std::vector< ScenarioEntity > & | entities,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports all private elements of a OpenSCENARIO actions DOM.

Parameters
[in] | privateElement | The DOM root of the actions element
[in,out] | entities | Objects from 'Entities' tag. Containing spawn information will be set by this method call.
[in] | parameters | declared parameters
static bool ContainsEntity | ( | const std::vector< ScenarioEntity > & | entities,
 |  | const std::string & | entityName
 | ) |  |
staticprivate

Tests, if a entity with a given name is included in the provided vector of scenario entities.

Parameters
[in] | entities | Vector of entities to test against
entityName | Name of the entity to check for existence
Returns
true, if entityName is included in entities, false otherwise
static ScenarioEntity* GetEntityByName | ( | std::vector< ScenarioEntity > & | entities,
 |  | const std::string & | entityName
 | ) |  |
staticprivate

Returns the entity object contained in a vector of entities, selected by its name.

Parameters
[in] | entities | Vector of entities to search
[in] | entityName | Name of entity to look up
Returns
Pointer to found entity if name exists, nullptr otherwise
static void CategorizeEntities | ( | const std::vector< ScenarioEntity > & | entities,
 |  | const std::map< std::string, std::list< std::string > > & | groups,
 |  | ScenarioInterface * | scenario
 | ) |  |
staticprivate

Categorizes the provided entities and adds them to the scenario either as scanario entity or ego entity.

Parameters
[in] | entities | Entities to check for being Ego or of other type
[out] | scenario | Ego and Scenario entities are added to this scenario
static openScenario::LanePosition ImportLanePosition | ( | QDomElement | positionElement,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports an openScenario Lane-Position element.

Parameters
[in] | positionElement | XML-Element containing position
[in] | parameters | declared parameters
Returns
lanePosition
static openScenario::WorldPosition ImportWorldPosition | ( | QDomElement | positionElement,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports an openScenario World-Position element.

Parameters
[in] | positionElement | XML-Element containing position
[in] | parameters | declared parameters
Returns
worldPosition
static openScenario::Action ImportAction | ( | QDomElement | eventElement,
 |  | openScenario::Parameters & | parameters,
 |  | const std::string | catalogPath
 | ) |  |
staticprivate

Imports an openScenario Action element.

Parameters
[in] | eventElement | XML-Element containing Event
[in] | parameters | declared parameters
[in] | catalogPath | catalog path
Returns
action
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SceneryImporter Class Reference

  • Importer
  • SceneryImporter
Static Public Member Functions | Static Private Member Functions | List of all members
SceneryImporter Class Reference

Static Public Member Functions

static bool | Import (const std::string &filename, Scenery *scenery)
static void | ParseRoads (QDomElement &documentRoot, Scenery *scenery)
Parses roads into a scenery object. More...
static void | ParseJunctions (QDomElement &documentRoot, Scenery *scenery)
Parses junctions into a scenery object. More...
static void | ParseJunctionConnections (QDomElement &junctionElement, JunctionInterface *junction)
Parses connections into a junction object. More...
static void | ParseJunctionConnectionLinks (QDomElement &connectionElement, ConnectionInterface *connection)
Parses connection links into a connection object. More...
static void | ParseJunctionPriorities (QDomElement &junctionElement, JunctionInterface *junction)
Parses priorities into a junction object. More...
static void | ParseSignals (QDomElement &roadElement, RoadInterface *road)
Parses the signals specification into a road object. More...
static void | ParseObjects (QDomElement &roadElement, RoadInterface *road)
Parses multiple OpenDRIVE road objects into a road object. More...
static void | ParseObject (QDomElement &objectElement, RoadInterface *road)
Parses a single OpenDRIVE object into a road object. More...
static void | ParseElementValidity (const QDomElement &rootElement, RoadElementValidity &validity)
Converts a validitiy tag into a vector with increasing lane numbers. More...
static void | ParseRoadTypes (QDomElement &roadElement, RoadInterface *road)
Parses the road typen into a road object. More...
static std::list< RoadObjectSpecification > | ParseObjectRepeat (QDomElement &objectElement, const RoadObjectSpecification &object)
Parses repeat tag of objects. More...
static void | ParseRepeat (QDomElement &repeatElement, RoadObjectSpecification object, std::list< RoadObjectSpecification > &objectRepitions)
Parses repeat objects into a list of road objects. More...
static void | ApplyRepeat (ObjectRepeat objectRepeat, RoadObjectSpecification object, std::list< RoadObjectSpecification > &objectRepitions)
Calculates and applies attributes to repeated objects. More...
static void | AddParsedObjectsToRoad (std::list< RoadObjectSpecification > parsedObjects, RoadInterface *road)
Add all objects from List to Road. More...
static void | ParseOptionalInterval (QDomElement &repeatElement, std::string startAttribute, std::string endAttribute, OptionalInterval &interval)
Parse optional parameters of an interval. More...

Static Private Member Functions

static void | ParseLanes (QDomElement &rootElement, RoadLaneSectionInterface *laneSection)
Parses lane elements in a lane section and stores their information in a lane section object. More...
static void | ParseLaneRoadMark (std::string leftCenterRight, QDomElement &roadLaneElement, RoadLaneInterface *roadLane)
Parses lane road mark elements into a road lane object. More...
static void | ParseGeometries (QDomElement &roadElement, RoadInterface *road)
Parses the road geometry into a road object. More...
static void | ParseElevationProfile (QDomElement &roadElement, RoadInterface *road)
Parses the elevation profile into a road object. More...
static void | ParseRoadLinks (QDomElement &roadElement, RoadInterface *road)
Parses the road links into a road object. More...
static void | ParseRoadLanes (QDomElement &roadElement, RoadInterface *road)
Parses the lanes specification into a road object. More...
static void | ParseSignalUnit (std::string element, RoadSignalUnit &signalUnit)
Converts a potential signal unit into a known RoadSignalUnit. More...
static void | checkRoadSignalBoundaries (RoadSignalSpecification signal)
Checks the values which are not enumerations of validity (if possible) More...

Member Function Documentation

static bool Import | ( | const std::string & | filename,
 |  | Scenery * | scenery
 | ) |  |
static

Imports data structures from the scenery configuration file e.g. OpenDrive file

Parameters
[in] filename path to OpenDrive file
Returns
true on success
static void ParseRoads | ( | QDomElement & | documentRoot,
 |  | Scenery * | scenery
 | ) |  |
static

Parses roads into a scenery object.

Note
Use this entry point only for testing or within the class context

OpenDRIVE attributes whose information is stored in the road:

  • road tag: id Then parses geometries, elevationProfile, road links, and road lanes.
Parameters
[in] | documentRoot | DOM element containing the OpenDRIVE road
[out] | scenery | Scenery with the contents of the DOM element
static void ParseJunctions | ( | QDomElement & | documentRoot,
 |  | Scenery * | scenery
 | ) |  |
static

Parses junctions into a scenery object.

Note
Use this entry point only for testing or within the class context
Parameters
[in] | documentRoot | DOM element containing the OpenDRIVE road
[out] | scenery | Scenery with the contents of the DOM element
static void ParseJunctionConnections | ( | QDomElement & | junctionElement,
 |  | JunctionInterface * | junction
 | ) |  |
static

Parses connections into a junction object.

Note
Use this entry point only for testing or within the class context
Parameters
[in] | junctionElement | DOM element containing the OpenDRIVE junction
[out] | junction | Junction with the contents of the DOM element
static void ParseJunctionConnectionLinks | ( | QDomElement & | connectionElement,
 |  | ConnectionInterface * | connection
 | ) |  |
static

Parses connection links into a connection object.

Note
Use this entry point only for testing or within the class context
Parameters
[in] | junctionElement | DOM element containing the OpenDRIVE junction
[out] | junction | Connection with the contents of the DOM element
Returns
False if an error occurred, true otherwise
static void ParseJunctionPriorities | ( | QDomElement & | junctionElement,
 |  | JunctionInterface * | junction
 | ) |  |
static

Parses priorities into a junction object.

Note
Use this entry point only for testing or within the class context
Parameters
[in] | junctionElement | DOM element containing the OpenDRIVE junction
[out] | junction | Junction with the contents of the DOM element
static void ParseLanes | ( | QDomElement & | rootElement,
 |  | RoadLaneSectionInterface * | laneSection
 | ) |  |
staticprivate

Parses lane elements in a lane section and stores their information in a lane section object.

OpenDRIVE attributes whose information is stored in the lane section:

  • lane tag: id and type
  • width subtag: sOffset, a, b, c, and d
  • link subtag: predecessor (and its id) and successor (and its id)
Parameters
[in] | rootElement | DOM element containing the OpenDRIVE lanes
[out] | laneSection | Lane section with the contents of the DOM elements
static void ParseLaneRoadMark | ( | std::string | leftCenterRight,
 |  | QDomElement & | roadLaneElement,
 |  | RoadLaneInterface * | roadLane
 | ) |  |
staticprivate

Parses lane road mark elements into a road lane object.

OpenDRIVE attributes whose information is stored in the road lane object.:

  • roadMark tag: sOffset, type
Parameters
[in] | leftCenterRight | left/center/right lane road mark
[in] | roadLaneElement | DOM element containing the OpenDRIVE road lane
[out] | roadLane | Road lane with the contents of the DOM element
static void ParseGeometries | ( | QDomElement & | roadElement,
 |  | RoadInterface * | road
 | ) |  |
staticprivate

Parses the road geometry into a road object.

OpenDRIVE attributes whose information is stored in the road:

  • geometry tag: s, x, y, hdg and length
  • line subtag
  • arc subtag: curvature
  • spiral subtag: curvStart and curvEnd
  • poly3 subtag: a, b, c, and d
Parameters
[in] | roadElement | DOM element containing the OpenDRIVE road
[out] | road | Road with the contents of the DOM element
static void ParseElevationProfile | ( | QDomElement & | roadElement,
 |  | RoadInterface * | road
 | ) |  |
staticprivate

Parses the elevation profile into a road object.

OpenDRIVE attributes whose information is stored in the road:

  • elevationProfile tag
  • elevation subtag: s, a, b, c, and d
Parameters
[in] | roadElement | DOM element containing the OpenDRIVE road
[out] | road | Road with the contents of the DOM element
static void ParseRoadLinks | ( | QDomElement & | roadElement,
 |  | RoadInterface * | road
 | ) |  |
staticprivate

Parses the road links into a road object.

OpenDRIVE attributes whose information is stored in the road:

  • link tag
  • predecessor subtag: elementType (only "road" allowed), elementId, contactPoint ("start" or "end")
  • successor subtag: elementType (only "road" allowed), elementId, contactPoint ("start" or "end")
  • neighbor subtag: side ("left" or "right"), elementId, and direction ("same" or "opposite")
Parameters
[in] | roadElement | DOM element containing the OpenDRIVE road
[out] | road | Road with the contents of the DOM element
static void ParseRoadLanes | ( | QDomElement & | roadElement,
 |  | RoadInterface * | road
 | ) |  |
staticprivate

Parses the lanes specification into a road object.

OpenDRIVE attributes whose information is stored in the road:

  • lanes tag
  • laneOffset subtag: s, a, b, c, and d
  • laneSection subtag: s
  • left subtag: ParseLanes called
  • right subtag: ParseLanes called
Parameters
[in] | roadElement | DOM element containing the OpenDRIVE road
[out] | road | Road with the contents of the DOM element
static void ParseSignals | ( | QDomElement & | roadElement,
 |  | RoadInterface * | road
 | ) |  |
static

Parses the signals specification into a road object.

OpenDRIVE attributes whose information is stored in the road:

  • signals tag
  • signal subtag: s, t, dynamic, type, subtype, value, unit, and orientation
  • optional: validity subtag fromLane and toLane
Parameters
[in] | roadElement | DOM element containing the OpenDRIVE road
[out] | road | Road with the contents of the DOM element
static void ParseObjects | ( | QDomElement & | roadElement,
 |  | RoadInterface * | road
 | ) |  |
static

Parses multiple OpenDRIVE road objects into a road object.

OpenDRIVE attributes whose information is stored in the road:

  • objects tag
  • object subtag
Parameters
[in] | roadElement | DOM element containing the OpenDRIVE road
[out] | road | Road with the contents of the DOM element
static void ParseObject | ( | QDomElement & | objectElement,
 |  | RoadInterface * | road
 | ) |  |
static

Parses a single OpenDRIVE object into a road object.

OpenDRIVE attributes whose information is stored in the road:

  • objects tag
  • object subtag
Parameters
[in] | objectElement | DOM element containing the OpenDRIVE object
[out] | road | Road with the contents of the DOM element
static void ParseElementValidity | ( | const QDomElement & | rootElement,
 |  | RoadElementValidity & | validity
 | ) |  |
static

Converts a validitiy tag into a vector with increasing lane numbers.

Parameters
[in] | rootElement | root element containing a validity sub-tag
[out] | validities | parsed result
static void ParseRoadTypes | ( | QDomElement & | roadElement,
 |  | RoadInterface * | road
 | ) |  |
static

Parses the road typen into a road object.

Parameters
[in] | roadElement | DOM element containing the OpenDRIVE road
[out] | road | Road with the contents of the DOM element
static std::list<RoadObjectSpecification> ParseObjectRepeat | ( | QDomElement & | objectElement,
 |  | const RoadObjectSpecification & | object
 | ) |  |
static

Parses repeat tag of objects.

Parameters
[in] | objectElement | DOM element containing the traffic object
[out] | object | Object with the contents of the DOM element
Returns
List of all repeated objects
static void ParseRepeat | ( | QDomElement & | repeatElement,
 |  | RoadObjectSpecification | object,
 |  | std::list< RoadObjectSpecification > & | objectRepitions
 | ) |  |
static

Parses repeat objects into a list of road objects.

OpenDRIVE attributes whose information is stored in the road:

  • repeat tag s, length, distance optional: tStart, tEnd, widthStart, widthEnd, heightStart, heightEnd, zOffsetStart, zOffsetEnd
Parameters
[in] | repeatElement | DOM element containing the OpenDRIVE repeat element
[in] | object | DOM element of the parent object
[out] | objectRepetitions | Reference to a list of repeated road objects
static void ApplyRepeat | ( | ObjectRepeat | objectRepeat,
 |  | RoadObjectSpecification | object,
 |  | std::list< RoadObjectSpecification > & | objectRepitions
 | ) |  |
static

Calculates and applies attributes to repeated objects.

OpenDRIVE attributes whose information is stored in the road:

  • repeat tag s, length, distance optional: tStart, tEnd, widthStart, widthEnd, heightStart, heightEnd, zOffsetStart, zOffsetEnd
Parameters
[in] | objectRepeat | Repeat data
[in] | object | Base road object
[out] | objectRepetitions | Reference to a list of repeated road objects to apply the data to
static void AddParsedObjectsToRoad | ( | std::list< RoadObjectSpecification > | parsedObjects,
 |  | RoadInterface * | road
 | ) |  |
static

Add all objects from List to Road.

Parameters
[in] | parsedObjects | List of all parsed Objects within one object tag
[in] | road | road with should contain objects
static void ParseOptionalInterval | ( | QDomElement & | repeatElement,
 |  | std::string | startAttribute,
 |  | std::string | endAttribute,
 |  | OptionalInterval & | interval
 | ) |  |
static

Parse optional parameters of an interval.

Parameters
[in] | Attribute | start and end double of intervall
[in] | repeatElement | road with should contain objects
[out] | OptionalInterval | DOM element containing the retetition of an object
static void ParseSignalUnit | ( | std::string | element,
 |  | RoadSignalUnit & | signalUnit
 | ) |  |
staticprivate

Converts a potential signal unit into a known RoadSignalUnit.

Parameters
[in] | element | element to be parsed
[out] | signalType | parsed result
static void checkRoadSignalBoundaries ( RoadSignalSpecification signal )
staticprivate

Checks the values which are not enumerations of validity (if possible)

Parameters
[in] signal signal to be checked
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SlaveConfigImporter Class Reference

  • Importer
  • SlaveConfigImporter
Static Public Member Functions | Static Private Attributes | List of all members
SlaveConfigImporter Class Reference

This class povides the import functionality. More...

Static Public Member Functions

static ExperimentConfig::Libraries | ImportLibraries (QDomElement rootElement)
Imports the libraries used by the simulator. More...
static void | ImportExperiment (QDomElement experimentElement, ExperimentConfig &experimentConfig)
Imports the ExperimentConfig section of the slave configuration. More...
static void | ImportScenario (QDomElement scenarioElement, const std::string configurationDir, ScenarioConfig &scenarioConfig)
Imports the ScenarioConfig section of the slave configuration. More...
static void | ImportEnvironment (QDomElement environmentElement, EnvironmentConfig &environmentConfig)
Imports the EnvironmentConfig section of the slave configuration. More...
static void | ImportSpawners (const QDomElement &spawnersElement, SpawnPointLibraryInfoCollection &spawnPointsInfo)
ImportSpawnPointsConfig Imports the SpawnPointConfig section of the slave configuration. More...
static bool | Import (const std::string &configurationDir, const std::string &slaveConfigFile, Configuration::SlaveConfig &slaveConfig)
Imports the entire slave configuration. More...

Static Private Attributes

static const ExperimentConfig::Libraries defaultLibraryMapping
Identifier with correspondiong default values for mandatory libraries. More...

Detailed Description

This class povides the import functionality.

All methods in this class are static

Member Function Documentation

static ExperimentConfig::Libraries ImportLibraries ( QDomElement rootElement )
static

Imports the libraries used by the simulator.

Parameters
[in] librariesElement Element containing the libraries information
Returns
Libraries (defaulted if element or single elements are missing)
See also
defaultLibraryMapping
static void ImportExperiment | ( | QDomElement | experimentElement,
 |  | ExperimentConfig & | experimentConfig
 | ) |  |
static

Imports the ExperimentConfig section of the slave configuration.

Parameters
[in] | experimentConfigElement | Element containing the information
[out] | experimentConfig | Struct into which the values get saved
static void ImportScenario | ( | QDomElement | scenarioElement,
 |  | const std::string | configurationDir,
 |  | ScenarioConfig & | scenarioConfig
 | ) |  |
static

Imports the ScenarioConfig section of the slave configuration.

Parameters
[in] | scenarioConfigElement | Element containing the information
[out] | scenarioConfig | Struct into which the values get saved
static void ImportEnvironment | ( | QDomElement | environmentElement,
 |  | EnvironmentConfig & | environmentConfig
 | ) |  |
static

Imports the EnvironmentConfig section of the slave configuration.

Parameters
[in] | environmentConfigElement | Element containing the information
[out] | environmentConfig | Struct into which the values get saved
static void ImportSpawners | ( | const QDomElement & | spawnersElement,
 |  | SpawnPointLibraryInfoCollection & | spawnPointsInfo
 | ) |  |
static

ImportSpawnPointsConfig Imports the SpawnPointConfig section of the slave configuration.

Parameters
spawnPointsConfigElement | Element containing the information
spawnPointsInfo | struct into which the values get saved
Returns
static bool Import | ( | const std::string & | configurationDir,
 |  | const std::string & | slaveConfigFile,
 |  | Configuration::SlaveConfig & | slaveConfig
 | ) |  |
static

Imports the entire slave configuration.

Calls all sections specific methods and saves the result in the CombiantionConfig

Parameters
[in] | configurationDir | Path of the configuration files
[in] | slaveConfigFile | Name of the SlaveConfig file
[out] | slaveConfig | Class into which the values get saved
Returns
true, if successful

Member Data Documentation

const ExperimentConfig::Libraries defaultLibraryMapping
inlinestaticprivate
Initial value:
=
{
{"DataStoreLibrary", "BasicDataStore"},
{"EventDetectorLibrary", "EventDetector"},
{"ManipulatorLibrary", "Manipulator"},
{"WorldLibrary", "World"},
{"StochasticsLibrary", "Stochastics"}
}

Identifier with correspondiong default values for mandatory libraries.

Note
: The identifier is identical to the XML tag
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SystemConfigImporter Class Reference

  • Importer
  • SystemConfigImporter
Static Public Member Functions | List of all members
SystemConfigImporter Class Reference

Class handles importing an agent system configuration. More...

Static Public Member Functions

static bool | Import (const std::string &filename, std::shared_ptr< SystemConfig > systemConfig)
static openpass::parameter::ParameterSetLevel1 | ImportSystemParameters (QDomElement &parametersElement)
Public for testing.

Detailed Description

Class handles importing an agent system configuration.

Member Function Documentation

static bool Import | ( | const std::string & | filename,
 |  | std::shared_ptr< SystemConfig > | systemConfig
 | ) |  |
static

Imports the XML agent system configuration from the provided file path and stores the results in the provided mapping.

Parameters
[in] | filename | Path to the file with the XML agent system config
[out] | agentTypes | Mapping from IDs to agents to store the results of the import
Returns
False if an error occurred, true otherwise
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: VehicleModelsImporter Class Reference

  • Importer
  • VehicleModelsImporter
Classes | Static Public Member Functions | Static Private Member Functions | List of all members
VehicleModelsImporter Class Reference

Provides methods for importing vehicle models from OpenSCENARIO catalog files. More...

Classes

struct TypeHelper
Helper for template type deduction with std::optional parameters. More...

Static Public Member Functions

static bool | Import (const std::string &vehicleModelsPath, const std::string &pedestrianModelsPath, Configuration::VehicleModels &vehicleModels)
Imports vehicle and pedestrian models from the given paths. More...
static void | ImportVehicleModel (QDomElement &modelElement, VehicleModelMap &vehicleModelsMap)
Imports a vehicle model from OpenSCENARIO DOM. More...
static void | ImportPedestrianModel (QDomElement &pedestrianElement, VehicleModelMap &vehicleModelsMap)
Imports a pedestrian model from OpenSCENARIO DOM. More...

Static Private Member Functions

static void | CheckModelParameters (const ParametrizedVehicleModelParameters &model)
Asserts that the provided model parameters are valid. More...
static void | ImportCatalog (const std::string &catalogPath, QDomElement &catalogElement)
Imports a catalog from OpenSCENARIO DOM. More...
static void | ImportVehicleCatalog (QDomElement &catalogElement, Configuration::VehicleModels &vehicleModels)
Imports all vehicles from a catalog (OpenSCENARIO DOM) More...
static void | ImportPedestrianCatalog (QDomElement &catalogElement, Configuration::VehicleModels &vehicleModels)
Imports all pedestrians from a catalog (OpenSCENARIO DOM) More...
static void | ImportModelBoundingBox (QDomElement &modelElement, ParametrizedVehicleModelParameters &modelParameters, openScenario::Parameters &parameters)
Imports the model's bounding box from OpenSCENARIO DOM. More...
static void | ImportVehicleModelAxles (QDomElement &vehicleElement, ParametrizedVehicleModelParameters &modelParameters, openScenario::Parameters &parameters)
Imports the models' axles parameters. More...
static void | ImportVehicleModelAxle (QDomElement &axleElement, VehicleAxle &axleParameters, openScenario::Parameters &parameters)
Imports the parameters of a single axle. More...
static void | ValidateAxles (const VehicleAxle &frontAxle, const VehicleAxle &rearAxle)
Validates the axle parameters. More...
static void | ImportVehicleModelPerformance (QDomElement &vehicleElement, ParametrizedVehicleModelParameters &modelParameters, openScenario::Parameters &parameters)
Imports the models' performance tag from OpenSCENARIO DOM. More...
static void | ImportVehicleModelGears (ParametrizedVehicleModelParameters &modelParameters, const Properties &properties)
Imports the models' gears from its ParameterDeclaration in OpenSCENARIO DOM. More...
template<typename T >
static void | AssignProperty (const std::string &propertyName, openScenario::ParameterizedAttribute< T > &attribute, const Properties &properties, std::optional< typename TypeHelper< T >::type > defaultValue=std::nullopt)
Assigns the value of a property to a attribute. More...
static Properties | ImportProperties (QDomElement &root)
Imports the properties of an element. More...

Detailed Description

Provides methods for importing vehicle models from OpenSCENARIO catalog files.

Member Function Documentation

static bool Import | ( | const std::string & | vehicleModelsPath,
 |  | const std::string & | pedestrianModelsPath,
 |  | Configuration::VehicleModels & | vehicleModels
 | ) |  |
static

Imports vehicle and pedestrian models from the given paths.

The vehicleModelsPath and the pedestrianModelsPath are appended to the configurationDir string, respectively. If one of the paths is an empty string, the import of this type of models is ommited and doesn't result in an error.

Parameters
[in] | vehicleModelsPath | File path to the vehicle model catalog
[in] | pedestrianModelsPath | File path to the pedestrian model catalog
[out] | vehicleModels | Storage for the imported models
Returns
true on success, false otherwise
static void ImportVehicleModel | ( | QDomElement & | modelElement,
 |  | VehicleModelMap & | vehicleModelsMap
 | ) |  |
static

Imports a vehicle model from OpenSCENARIO DOM.

The model is stored in vehicleModelsMap with the model attribute name as its key. Duplicated model names are not allowed.

Supported vehicle model categories are car, van, truck, bus, motorbike and bicycle.

Parameters
[in] | modelElement | Vehicle model DOM element
[out] | vehicleModelsMap | Storage for the imported vehicle model
Exceptions
std::runtime_error On invalid XML, duplicated model names or unsupported vehicle category
static void ImportPedestrianModel | ( | QDomElement & | pedestrianElement,
 |  | VehicleModelMap & | vehicleModelsMap
 | ) |  |
static

Imports a pedestrian model from OpenSCENARIO DOM.

The model is stored in vehicleModelsMap with the model attribute name as its key. Duplicated model names are not allowed.

The only supported pedestrian model category is pedestrian.

Parameters
[in] | modelElement | Pedestrian model DOM element
[out] | vehicleModelsMap | Storage for the imported pedestrian model (NOTE: internaly shared with vehicles)
Exceptions
std::runtime_error On invalid XML, duplicated model names or unsupported pedestrian category
static void CheckModelParameters ( const ParametrizedVehicleModelParameters & model )
staticprivate

Asserts that the provided model parameters are valid.

Model parameters are considered valid, if all the following parameters have a value greater than 0.0 and the vehicle type is not AgentVehicleType::Undefined:

  • length
  • width
  • height
  • trackwidth
  • wheelbase
  • maxVelocity
  • maxCurvature
Parameters
[in] model The model parameters to check
static void ImportCatalog | ( | const std::string & | catalogPath,
 |  | QDomElement & | catalogElement
 | ) |  |
staticprivate

Imports a catalog from OpenSCENARIO DOM.

Parameters
[in] | catalogPath | Full path to the catalog XML file
[out] | catalogElement | The imported catalog element
Exceptions
std::runtime_error On invalid XML or missing catalog tag
static void ImportVehicleCatalog | ( | QDomElement & | catalogElement,
 |  | Configuration::VehicleModels & | vehicleModels
 | ) |  |
staticprivate

Imports all vehicles from a catalog (OpenSCENARIO DOM)

Parameters
[in] | catalogElement | The catalog element to import vehicles from
[out] | vehicleModels | Storage for the imported vehicle models
static void ImportPedestrianCatalog | ( | QDomElement & | catalogElement,
 |  | Configuration::VehicleModels & | vehicleModels
 | ) |  |
staticprivate

Imports all pedestrians from a catalog (OpenSCENARIO DOM)

Parameters
[in] | catalogElement | The catalog element to import predestrians from
[out] | vehicleModels | Storage for the imported pedestrian models (NOTE: internaly shared with vehicles)
static void ImportModelBoundingBox | ( | QDomElement & | modelElement,
 |  | ParametrizedVehicleModelParameters & | modelParameters,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports the model's bounding box from OpenSCENARIO DOM.

Parameters
[in] | modelElement | The DOM element of the model
[out] | modelParameters | Storage for the imported values
[in] | parameters | declared parameters

A warning is issued, if the bounding box center is not 0.0 in y-direction and half the model's height in z-direction, as offsets in these directions are not supported by the simulator.

Exceptions
std::runtime_error On missing BoundingBox, Center or Dimension tag
static void ImportVehicleModelAxles | ( | QDomElement & | vehicleElement,
 |  | ParametrizedVehicleModelParameters & | modelParameters,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports the models' axles parameters.

The following parameters are derived from axle configuration:

  • maxCurvature
  • maximumSteeringWheelAngleAmplitude
  • trackWidth
  • wheelBase
  • distanceReferencePointToFrontAxle
  • staticWheelRadius

Warnings are issued for unsupported configurations (different track width for axles, different radius for front and rear wheels or front axle located behind rear axle).

Parameters
[in] | vehicleElement | The DOM element of the vehicle model
[out] | modelParameters | Storage for the imported values
[in] | parameters | declared parameters
Exceptions
std::runtime_error On missing Axles, Front or Rear tag, reference point not being on rear axle or steering defined for rear axle
static void ImportVehicleModelAxle | ( | QDomElement & | axleElement,
 |  | VehicleAxle & | axleParameters,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports the parameters of a single axle.

Parameters
[in] | axleElement | The DOM element ot the axle
[out] | axleParameters | Storage for the imported values
[in] | parameters | declared parameters
Exceptions
std::runtime_error On missing Axles, Front or Rear tag, reference point not being on rear axle or steering defined for rear axle
static void ValidateAxles | ( | const VehicleAxle & | frontAxle,
 |  | const VehicleAxle & | rearAxle
 | ) |  |
staticprivate

Validates the axle parameters.

Parameters
[in] | frontAxle | The parameters of the front axle
[in] | rearAxle | The parameters of the rear axle
Exceptions
std::runtime_error When reference point not on rear axle or rear axle steering != 0.0
static void ImportVehicleModelPerformance | ( | QDomElement & | vehicleElement,
 |  | ParametrizedVehicleModelParameters & | modelParameters,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Imports the models' performance tag from OpenSCENARIO DOM.

The values for maxSpeed and mass are imported to their corresponding model parameters.

Note
Currently, maxDeceleration is ignored.
Parameters
[in] | vehicleElement | The DOM element of the vehicle model
[out] | modelParameters | Storage for the imported values
[in] | parameters | declared parameters
Exceptions
std::runtime_error On missing Performance tag or missing or invalid maxSpeed or mass attribute
static void ImportVehicleModelGears | ( | ParametrizedVehicleModelParameters & | modelParameters,
 |  | const Properties & | properties
 | ) |  |
staticprivate

Imports the models' gears from its ParameterDeclaration in OpenSCENARIO DOM.

The paramters NumberOfGears has to specifiy the number of gears in a model. The first entry in ParametrizedVehicleModelParameters gearRatios will always be 0.0. For every gear, a Parameter tag GearRatioN has to exist, where N represents the number of a gear. Ratios are imported in ascending order of the gear number.

Parameters
[out] | modelParameters | Storage for the imported values
[in] | properties | openScenario properties
static void AssignProperty | ( | const std::string & | propertyName,
 |  | openScenario::ParameterizedAttribute< T > & | attribute,
 |  | const Properties & | properties,
 |  | std::optional< typename TypeHelper< T >::type > | defaultValue = std::nullopt
 | ) |  |
inlinestaticprivate

Assigns the value of a property to a attribute.

Parameters
[in] | propertyName | Name of the parameter to import
[out] | attribtue | Reference to the attribute
[in] | properties | Properties
[in] | defaultValue | An optional default value to use if it cannot be imported
Exceptions
std::runtime_error On missing model Parameter tag or invalid name or value attribute.

Here is the call graph for this function:

static Properties ImportProperties ( QDomElement & root )
staticprivate

Imports the properties of an element.

Parameters
[in] root XML document root
Returns
Properties

Here is the caller graph for this function:

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: VehicleModelsImporter::TypeHelper< T > Struct Template Reference

  • Importer
  • VehicleModelsImporter
  • TypeHelper
List of all members
VehicleModelsImporter::TypeHelper< T > Struct Template Reference

Helper for template type deduction with std::optional parameters. More...

Detailed Description

template<typename T>
struct Importer::VehicleModelsImporter::TypeHelper< T >

Helper for template type deduction with std::optional parameters.

As template type deduction is only able to directly match types, the type passed std::optional arguments has to be stated explicitly. This wrapper allows to circumvent this restriction.

See also
ImportModelParameter
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ConversionStatus Struct Reference

  • Internal
  • ConversionStatus
List of all members
ConversionStatus Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Entity Struct Reference

  • LaneMarking
  • Entity
List of all members
Entity Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RuntimeInformation Struct Reference

  • openpass
  • common
  • RuntimeInformation
Classes | List of all members
RuntimeInformation Struct Reference
Collaboration diagram for RuntimeInformation:
[legend]

Classes

struct | Directories
struct | Versions
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RuntimeInformation::Directories Struct Reference

  • openpass
  • common
  • RuntimeInformation
  • Directories
List of all members
RuntimeInformation::Directories Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RuntimeInformation::Versions Struct Reference

  • openpass
  • common
  • RuntimeInformation
  • Versions
List of all members
RuntimeInformation::Versions Struct Reference
Collaboration diagram for RuntimeInformation::Versions:
[legend]
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Version Struct Reference

  • openpass
  • common
  • Version
List of all members
Version Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Directories Class Reference

  • openpass
  • core
  • Directories
Static Public Member Functions | Public Attributes | Static Private Member Functions | List of all members
Directories Class Reference

Static Public Member Functions

static const std::string | Concat (const std::string &path, const std::string &file)
!< directory for outputs More...
static const std::vector< std::string > | Concat (const std::string &path, const std::vector< std::string > &filenames)
Concats a path and multiple filenames with the seperator used by the current system. More...
static const std::string | StripFile (const std::string &path)
Removes the file from a path. More...
static bool | IsRelative (const std::string &path)
Checkes whether a given path is absolute or relative. More...

Public Attributes

const std::string | configurationDir
!< path of the executed application
const std::string | libraryDir
!< directory of the configuration files
const std::string | outputDir
!< directory of the libraries

Static Private Member Functions

static const std::string Resolve (const std::string &applicationPath, const std::string &path)
Internally used to get a cononical path w.r.t to the application path. More...

Detailed Description

Directories takes care of a consistent handling of paths and directories without making the underlying implementation public or a dependency

Once initialized, the paths are resolved w.r.t the applications base directory if the paths are relative, or kept absolute

Note that all directories are returned without a trailing path seperator Use Concat if you need to concat a path and a file with the current systems seperator

Member Function Documentation

static const std::string Concat | ( | const std::string & | path,
 |  | const std::string & | file
 | ) |  |
static

!< directory for outputs

Concats a path and a file with the seperator used by the current system

Parameters
path | e.g. /the_path
file | e.g. the_file
Returns
Concatenated string, e.g. /the_path/the_file
static const std::vector<std::string> Concat | ( | const std::string & | path,
 |  | const std::vector< std::string > & | filenames
 | ) |  |
static

Concats a path and multiple filenames with the seperator used by the current system.

Parameters
path | e.g. /the_path
filenames | e.g. the_filenames
Returns
Vector of concatenated strings, e.g. /the_path/the_filename
static const std::string StripFile ( const std::string & path )
static

Removes the file from a path.

Parameters
path with file
Returns
Resolved string e.g. /baseDir/path or /path, respectively
static bool IsRelative ( const std::string & path )
static

Checkes whether a given path is absolute or relative.

Parameters
path
Returns
true if relative path
static const std::string Resolve | ( | const std::string & | applicationPath,
 |  | const std::string & | path
 | ) |  |
staticprivate

Internally used to get a cononical path w.r.t to the application path.

Parameters
applicationPath | absolute path of the executed file, e.g. /baseDir
path | relative or absolute path, e.g. path or /path
Returns
Resolved string e.g. /baseDir/path or /path, respectively
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: openpass::events Namespace Reference

  • Namespace Members
  • openpass
  • events
Classes
openpass::events Namespace Reference

Classes

class | BasicEvent
class | CollisionEvent
class | ComponentStateChangeEvent
class | LaneChangeEvent
class | SpeedActionEvent
class | TrajectoryEvent

Detailed Description

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CollisionEvent Class Reference

  • openpass
  • events
  • CollisionEvent
List of all members
CollisionEvent Class Reference
Inheritance diagram for CollisionEvent:
[legend]
Collaboration diagram for CollisionEvent:
[legend]

Detailed Description

This class implements all functionality of the CollisionEvent.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: VisitParameterElement Struct Reference

  • openpass
  • parameter
  • internal
  • VisitParameterElement
Public Member Functions | List of all members
VisitParameterElement Struct Reference

switches between flat parameters and parameter lists More...

Public Member Functions

void | operator() (const ParameterValue &value)
execute if visited variant holds a ParameterValue
void | operator() (const ParameterListLevel2 &list)
execute if visited variant holds a ParameterList

Detailed Description

switches between flat parameters and parameter lists

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ExponentialDistribution Class Reference

  • openpass
  • parameter
  • ExponentialDistribution
List of all members
ExponentialDistribution Class Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: GammaDistribution Class Reference

  • openpass
  • parameter
  • GammaDistribution
List of all members
GammaDistribution Class Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LogNormalDistribution Class Reference

  • openpass
  • parameter
  • LogNormalDistribution
List of all members
LogNormalDistribution Class Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: NormalDistribution Class Reference

  • openpass
  • parameter
  • NormalDistribution
List of all members
NormalDistribution Class Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: UniformDistribution Class Reference

  • openpass
  • parameter
  • UniformDistribution
List of all members
UniformDistribution Class Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AgentDataPublisher Class Reference

  • openpass
  • publisher
  • AgentDataPublisher
List of all members
AgentDataPublisher Class Reference

! Interface which has to be provided by observation modules More...

Inheritance diagram for AgentDataPublisher:
[legend]
Collaboration diagram for AgentDataPublisher:
[legend]

Detailed Description

! Interface which has to be provided by observation modules

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CoreDataPublisher Class Reference

  • openpass
  • publisher
  • CoreDataPublisher
List of all members
CoreDataPublisher Class Reference

! Interface which has to be provided by observation modules More...

Inheritance diagram for CoreDataPublisher:
[legend]
Collaboration diagram for CoreDataPublisher:
[legend]

Detailed Description

! Interface which has to be provided by observation modules

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LogEntry Class Reference

  • openpass
  • publisher
  • LogEntry
List of all members
LogEntry Class Reference
Inheritance diagram for LogEntry:
[legend]
Collaboration diagram for LogEntry:
[legend]
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LogEntryBase Class Reference

  • openpass
  • publisher
  • LogEntryBase
List of all members
LogEntryBase Class Referenceabstract

Base class for logging of acyclic events in the datastore. More...

Inheritance diagram for LogEntryBase:
[legend]
Collaboration diagram for LogEntryBase:
[legend]

Detailed Description

Base class for logging of acyclic events in the datastore.

See also
openpass::publisher::coreDataPublisher
openpass::publisher::LogEntry
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: EventDetectorTaskItem Class Reference

  • openpass
  • scheduling
  • EventDetectorTaskItem
List of all members
EventDetectorTaskItem Class Reference

taskItem for eventDetector task More...

Inheritance diagram for EventDetectorTaskItem:
[legend]
Collaboration diagram for EventDetectorTaskItem:
[legend]

Detailed Description

taskItem for eventDetector task

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ManipulatorTaskItem Class Reference

  • openpass
  • scheduling
  • ManipulatorTaskItem
List of all members
ManipulatorTaskItem Class Reference

taskItem for manipulator task More...

Inheritance diagram for ManipulatorTaskItem:
[legend]
Collaboration diagram for ManipulatorTaskItem:
[legend]

Detailed Description

taskItem for manipulator task

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ObservationTaskItem Class Reference

  • openpass
  • scheduling
  • ObservationTaskItem
List of all members
ObservationTaskItem Class Reference

taskItem for observation task More...

Inheritance diagram for ObservationTaskItem:
[legend]
Collaboration diagram for ObservationTaskItem:
[legend]

Detailed Description

taskItem for observation task

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawningTaskItem Class Reference

  • openpass
  • scheduling
  • SpawningTaskItem
List of all members
SpawningTaskItem Class Reference

taskItem for spawning task More...

Inheritance diagram for SpawningTaskItem:
[legend]
Collaboration diagram for SpawningTaskItem:
[legend]

Detailed Description

taskItem for spawning task

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SyncWorldTaskItem Class Reference

  • openpass
  • scheduling
  • SyncWorldTaskItem
List of all members
SyncWorldTaskItem Class Reference

taskItem for synchronize world task More...

Inheritance diagram for SyncWorldTaskItem:
[legend]
Collaboration diagram for SyncWorldTaskItem:
[legend]

Detailed Description

taskItem for synchronize world task

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TimeKeeper Class Reference

  • openpass
  • scheduling
  • TimeKeeper
Static Public Member Functions | Static Protected Attributes | List of all members
TimeKeeper Class Reference

Allows core components to access the current schedule time without need for a direct reference. More...

Static Public Member Functions

static int | Now () noexcept
Get the current simulation time. More...
static int | Now () noexcept
Get the current simulation time. More...

Static Protected Attributes

static int time {-1}
Global time for the simulator.

Detailed Description

Allows core components to access the current schedule time without need for a direct reference.

Note
The scheduler holds a manipulate reference to the current time provided by this instance
auto currentTime = openpass::scheduling::TimeKeeper::Now();

Member Function Documentation

static int Now ( )
inlinestaticnoexcept

Get the current simulation time.

Returns
Current simulation time
static int Now ( )
inlinestaticnoexcept

Get the current simulation time.

Returns
Current simulation time
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TriggerTaskItem Class Reference

  • openpass
  • scheduling
  • TriggerTaskItem
List of all members
TriggerTaskItem Class Reference

taskItem for triggering task More...

Inheritance diagram for TriggerTaskItem:
[legend]
Collaboration diagram for TriggerTaskItem:
[legend]

Detailed Description

taskItem for triggering task

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: UpdateGlobalDrivingViewTaskItem Class Reference

  • openpass
  • scheduling
  • UpdateGlobalDrivingViewTaskItem
List of all members
UpdateGlobalDrivingViewTaskItem Class Reference

taskItem for update global driving view task More...

Inheritance diagram for UpdateGlobalDrivingViewTaskItem:
[legend]
Collaboration diagram for UpdateGlobalDrivingViewTaskItem:
[legend]

Detailed Description

taskItem for update global driving view task

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: UpdateTaskItem Class Reference

  • openpass
  • scheduling
  • UpdateTaskItem
List of all members
UpdateTaskItem Class Reference

taskItem for update task More...

Inheritance diagram for UpdateTaskItem:
[legend]
Collaboration diagram for UpdateTaskItem:
[legend]

Detailed Description

taskItem for update task

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Parameter Struct Reference

  • openpass
  • sensors
  • Parameter
List of all members
Parameter Struct Reference
Collaboration diagram for Parameter:
[legend]
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Position Struct Reference

  • openpass
  • sensors
  • Position
List of all members
Position Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Profile Struct Reference

  • openpass
  • sensors
  • Profile
List of all members
Profile Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AffectedEntities Struct Reference

  • openpass
  • type
  • AffectedEntities
List of all members
AffectedEntities Struct Reference

Contains the affected entities of an acyclic. More...

Detailed Description

Contains the affected entities of an acyclic.

Might be enhanced in the future to hold additional information about the affected entities

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: NamedType< T, Tag > Struct Template Reference

  • openpass
  • type
  • NamedType
List of all members
NamedType< T, Tag > Struct Template Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TriggeringEntities Struct Reference

  • openpass
  • type
  • TriggeringEntities
List of all members
TriggeringEntities Struct Reference

Contains the triggering entities of an acyclic. More...

Detailed Description

Contains the triggering entities of an acyclic.

Might be enhanced in the future to hold additional information about the affected entities

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneChange Struct Reference

  • openScenario
  • transformation
  • LaneChange
List of all members
LaneChange Struct Reference
Inheritance diagram for LaneChange:
[legend]
Collaboration diagram for LaneChange:
[legend]

Additional Inherited Members

- Static Public Member Functions inherited from TransformerBase< LaneChange, TrajectorySignal, openpass::events::LaneChangeEvent >
static TransformResult Transform (const SimulationSlave::EventNetworkInterface *eventNetwork, WorldInterface *world, AgentInterface *agent, int cycleTime)
Entry point for the transformation. More...
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpeedAction Struct Reference

  • openScenario
  • transformation
  • SpeedAction
List of all members
SpeedAction Struct Reference
Inheritance diagram for SpeedAction:
[legend]
Collaboration diagram for SpeedAction:
[legend]

Additional Inherited Members

- Static Public Member Functions inherited from TransformerBase< SpeedAction, SpeedActionSignal, openpass::events::SpeedActionEvent >
static TransformResult Transform (const SimulationSlave::EventNetworkInterface *eventNetwork, WorldInterface *world, AgentInterface *agent, int cycleTime)
Entry point for the transformation. More...
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Trajectory Struct Reference

  • openScenario
  • transformation
  • Trajectory
List of all members
Trajectory Struct Reference
Inheritance diagram for Trajectory:
[legend]
Collaboration diagram for Trajectory:
[legend]

Additional Inherited Members

- Static Public Member Functions inherited from TransformerBase< Trajectory, TrajectorySignal, openpass::events::TrajectoryEvent >
static TransformResult Transform (const SimulationSlave::EventNetworkInterface *eventNetwork, WorldInterface *world, AgentInterface *agent, int cycleTime)
Entry point for the transformation. More...
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TransformerBase< T, Signal, TriggeringEvent > Class Template Reference

  • openScenario
  • transformation
  • TransformerBase
Static Public Member Functions | Static Private Member Functions | List of all members
TransformerBase< T, Signal, TriggeringEvent > Class Template Reference

CRTP Base class for Transformer. More...

Static Public Member Functions

static TransformResult Transform (const SimulationSlave::EventNetworkInterface *eventNetwork, WorldInterface *world, AgentInterface *agent, int cycleTime)
Entry point for the transformation. More...

Static Private Member Functions

static bool AgentIsAffected (const int agentId, EventInterface const *event)
Checks if the agentId is affected of the triggering event. More...

Detailed Description

template<typename T, typename Signal, typename TriggeringEvent>
class openScenario::transformation::TransformerBase< T, Signal, TriggeringEvent >

CRTP Base class for Transformer.

This class encapsulates the extraction of a specific TriggeringEvent from the eventNetwork, so that the derived classes only need to take care of the tranformation to the Signal itself

Member Function Documentation

static TransformResult Transform | ( | const SimulationSlave::EventNetworkInterface * | eventNetwork,
 |  | WorldInterface * | world,
 |  | AgentInterface * | agent,
 |  | int | cycleTime
 | ) |  |
inlinestatic

Entry point for the transformation.

Parameters
eventNetwork | Necessary for extracting the TriggeringEvent
world | Releayed to the actual transformer
agent | Releayed to the actual transformer
cycleTime | Releayed to the actual transformer
Returns
Transform result for the given triggering event
static bool AgentIsAffected | ( | const int | agentId,
 |  | EventInterface const * | event
 | ) |  |
inlinestaticprivate

Checks if the agentId is affected of the triggering event.

Parameters
agentId | the current agent id
event | the triggering event
Returns
true if the agentId is contained in the acting agents

Here is the caller graph for this function:

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AbsoluteTargetSpeed Struct Reference

  • openScenario
  • AbsoluteTargetSpeed
List of all members
AbsoluteTargetSpeed Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ActorInformation Struct Reference

  • openScenario
  • ActorInformation
List of all members
ActorInformation Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ByEntityCondition Class Reference

  • openScenario
  • ByEntityCondition
List of all members
ByEntityCondition Class Reference
Inheritance diagram for ByEntityCondition:
[legend]
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ByValueCondition Class Reference

  • openScenario
  • ByValueCondition
List of all members
ByValueCondition Class Reference
Inheritance diagram for ByValueCondition:
[legend]
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ConditionalEventDetectorInformation Struct Reference

  • openScenario
  • ConditionalEventDetectorInformation
Public Attributes | List of all members
ConditionalEventDetectorInformation Struct Reference

Event specific information collected from an openSCENARIO story. More...

Collaboration diagram for ConditionalEventDetectorInformation:
[legend]

Public Attributes

int numberOfExecutions {}
Specifies number of executions. Use -1 for "unrestricted".

Detailed Description

Event specific information collected from an openSCENARIO story.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CustomCommandAction Struct Reference

  • openScenario
  • CustomCommandAction
List of all members
CustomCommandAction Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: EntityAction Struct Reference

  • openScenario
  • EntityAction
List of all members
EntityAction Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: FollowTrajectoryAction Struct Reference

  • openScenario
  • FollowTrajectoryAction
List of all members
FollowTrajectoryAction Struct Reference
Collaboration diagram for FollowTrajectoryAction:
[legend]
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneChangeAction Struct Reference

  • openScenario
  • LaneChangeAction
List of all members
LaneChangeAction Struct Reference
Collaboration diagram for LaneChangeAction:
[legend]
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneChangeParameter Struct Reference

  • openScenario
  • LaneChangeParameter
Public Attributes | List of all members
LaneChangeParameter Struct Reference

Public Attributes

int | value {}
Whether the target is absolute or relative.
std::string | object {}
Value of the target element.
double | dynamicsTarget {}
Name of the reference object if relative.
DynamicsType | dynamicsType {}
Time or distance defined by Dynamics element.
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LanePosition Struct Reference

  • openScenario
  • LanePosition
List of all members
LanePosition Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ManipulatorInformation Struct Reference

  • openScenario
  • ManipulatorInformation
List of all members
ManipulatorInformation Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Orientation Struct Reference

  • openScenario
  • Orientation
List of all members
Orientation Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ParameterizedAttribute< T > Struct Template Reference

  • openScenario
  • ParameterizedAttribute
Public Member Functions | Public Attributes | List of all members
ParameterizedAttribute< T > Struct Template Reference

Attribute in a catalog that is not yet resolved. More...

Public Member Functions

ParameterizedAttribute ()=default
Value defined in the catalog (may later be overwriten in the CatalogReference)

Public Attributes

T defaultValue
Name of the parameter in OpenSCENARIO.

Detailed Description

template<typename T>
struct openScenario::ParameterizedAttribute< T >

Attribute in a catalog that is not yet resolved.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ReachPositionCondition Class Reference

  • openScenario
  • ReachPositionCondition
List of all members
ReachPositionCondition Class Reference
Inheritance diagram for ReachPositionCondition:
[legend]
Collaboration diagram for ReachPositionCondition:
[legend]
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RelativeLanePosition Struct Reference

  • openScenario
  • RelativeLanePosition
List of all members
RelativeLanePosition Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RelativeSpeedCondition Class Reference

  • openScenario
  • RelativeSpeedCondition
List of all members
RelativeSpeedCondition Class Reference
Inheritance diagram for RelativeSpeedCondition:
[legend]
Collaboration diagram for RelativeSpeedCondition:
[legend]
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RelativeTargetSpeed Struct Reference

  • openScenario
  • RelativeTargetSpeed
List of all members
RelativeTargetSpeed Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadPosition Struct Reference

  • openScenario
  • RoadPosition
List of all members
RoadPosition Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ScenarioImporterHelper Class Reference

  • openScenario
  • ScenarioImporterHelper
Static Public Member Functions | Static Private Member Functions | List of all members
ScenarioImporterHelper Class Reference

Static Public Member Functions

static Position | ImportPosition (QDomElement root, Parameters &parameters)
Import an openscenario Position Element. More...
static GlobalAction | ImportGlobalAction (QDomElement globalActionElement, Parameters &parameters)
Import an openscenario GlobalAction Element. More...
static PrivateAction | ImportPrivateAction (QDomElement privateActionElement, Parameters &parameters, const std::string catalogPath="")
Import an openscenario PrivateAction Element. More...
static UserDefinedAction | ImportUserDefinedAction (QDomElement userDefinedActionElement)
Import an openscenario UserDefinedAction Element. More...

Static Private Member Functions

static Orientation | ImportOrientation (QDomElement &orientationElement, Parameters &parameters)
Import an openscenario Orientation Element. More...
static LanePosition | ImportLanePosition (QDomElement positionElement, Parameters &parameters)
Import an openscenario LanePosition Element. More...
static RelativeLanePosition | ImportRelativeLanePosition (QDomElement positionElement, Parameters &parameters)
Import an openscenario RelativeLanePosition Element. More...
static RoadPosition | ImportRoadPosition (QDomElement positionElement, Parameters &parameters)
Import an openscenario RoadPosition Element. More...
static WorldPosition | ImportWorldPosition (QDomElement positionElement, Parameters &parameters)
Import an openscenario WorldPosition Element. More...
static std::pair< std::string, StochasticAttribute > | ImportStochastics (QDomElement &stochasticsElement, Parameters &parameters)
Import an openPASS custom Stochastic Element. More...
static EntityAction | ImportEntityAction (QDomElement entityActionElement, Parameters &parameters)
Import an openscenario EntityAction Element. More...
static LateralAction | ImportLateralAction (QDomElement lateralActionElement, Parameters &parameters)
Import an openscenario LateralAction Element. More...
static LongitudinalAction | ImportLongitudinalAction (QDomElement longitudinalActionElement, Parameters &parameters)
Import an openscenario LongitudinalAction Element. More...
static TeleportAction | ImportTeleportAction (QDomElement teleportActionElement, Parameters &parameters)
Import an openscenario TeleportAction Element. More...
static RoutingAction | ImportRoutingAction (QDomElement routingActionElement, Parameters &parameters, const std::string catalogPath)
Import an openscenario RoutingAction Element. More...
static VisibilityAction | ImportVisibilityAction (QDomElement visibilityActionElement, Parameters &parameters)
Import an openscenario VisibilityAction Element. More...
static QDomElement | GetTrajectoryElementFromCatalog (const std::string &catalogName, const std::string &catalogPath, const std::string &entryName, openScenario::Parameters &parameters)
Gets the Trajectory xml Element from a specified catalog. More...

Member Function Documentation

static Position ImportPosition | ( | QDomElement | root,
 |  | Parameters & | parameters
 | ) |  |
static

Import an openscenario Position Element.

Parameters
[in] | root | Root of the xml Element
[in] | parameters | Parametersset for openScenario parameter references

return Position

static GlobalAction ImportGlobalAction | ( | QDomElement | globalActionElement,
 |  | Parameters & | parameters
 | ) |  |
static

Import an openscenario GlobalAction Element.

Parameters
[in] | globalActionElement | GlobalAction xml Element
[in] | parameters | Parametersset for openScenario parameter references

return GlobalAction

static PrivateAction ImportPrivateAction | ( | QDomElement | privateActionElement,
 |  | Parameters & | parameters,
 |  | const std::string | catalogPath = ""
 | ) |  |
static

Import an openscenario PrivateAction Element.

Parameters
[in] | privateActionElement | PrivatAction xml Element
[in] | parameters | Parametersset for openScenario parameter references
[in] | catalogPath | Catalogpath used by some sub functions

return PrivateAction

static UserDefinedAction ImportUserDefinedAction ( QDomElement userDefinedActionElement )
static

Import an openscenario UserDefinedAction Element.

Parameters
[in] | userDefinedActionElement | Root of the xml Element
[in] | parameters | Parametersset for openScenario parameter references

return UserDefinedAction

static Orientation ImportOrientation | ( | QDomElement & | orientationElement,
 |  | Parameters & | parameters
 | ) |  |
staticprivate

Import an openscenario Orientation Element.

Parameters
[in] | orientationElement | Orientation xml Element
[in] | parameters | Parametersset for openScenario parameter references

return Orientation

static LanePosition ImportLanePosition | ( | QDomElement | positionElement,
 |  | Parameters & | parameters
 | ) |  |
staticprivate

Import an openscenario LanePosition Element.

Parameters
[in] | positionElement | Position xml Element
[in] | parameters | Parametersset for openScenario parameter references

return LanePosition

static RelativeLanePosition ImportRelativeLanePosition | ( | QDomElement | positionElement,
 |  | Parameters & | parameters
 | ) |  |
staticprivate

Import an openscenario RelativeLanePosition Element.

Parameters
[in] | positionElement | Position xml Element
[in] | parameters | Parametersset for openScenario parameter references

return RelativeLanePosition

static RoadPosition ImportRoadPosition | ( | QDomElement | positionElement,
 |  | Parameters & | parameters
 | ) |  |
staticprivate

Import an openscenario RoadPosition Element.

Parameters
[in] | positionElement | Position xml Element
[in] | parameters | Parametersset for openScenario parameter references

return RoadPosition

static WorldPosition ImportWorldPosition | ( | QDomElement | positionElement,
 |  | Parameters & | parameters
 | ) |  |
staticprivate

Import an openscenario WorldPosition Element.

Parameters
[in] | positionElement | Position xml Element
[in] | parameters | Parametersset for openScenario parameter references

return WorldPosition

static std::pair<std::string, StochasticAttribute> ImportStochastics | ( | QDomElement & | stochasticsElement,
 |  | Parameters & | parameters
 | ) |  |
staticprivate

Import an openPASS custom Stochastic Element.

Parameters
[in] | stochasticsElement | Stochastics xml Element
[in] | parameters | Parametersset for openScenario parameter references

return attributeName, Stochastic

static EntityAction ImportEntityAction | ( | QDomElement | entityActionElement,
 |  | Parameters & | parameters
 | ) |  |
staticprivate

Import an openscenario EntityAction Element.

Parameters
[in] | entityActionElement | EntityAction xml Element
[in] | parameters | Parametersset for openScenario parameter references

return EntityAction

static LateralAction ImportLateralAction | ( | QDomElement | lateralActionElement,
 |  | Parameters & | parameters
 | ) |  |
staticprivate

Import an openscenario LateralAction Element.

Parameters
[in] | lateralActionElement | LateralAction xml Element
[in] | parameters | Parametersset for openScenario parameter references

return LateralAction

static LongitudinalAction ImportLongitudinalAction | ( | QDomElement | longitudinalActionElement,
 |  | Parameters & | parameters
 | ) |  |
staticprivate

Import an openscenario LongitudinalAction Element.

Parameters
[in] | longitudinalActionElement | LongitudinalAction xml Element
[in] | parameters | Parametersset for openScenario parameter references

return LongitudinalAction

static TeleportAction ImportTeleportAction | ( | QDomElement | teleportActionElement,
 |  | Parameters & | parameters
 | ) |  |
staticprivate

Import an openscenario TeleportAction Element.

Parameters
[in] | teleportActionElement | TeleportAction xml Element
[in] | parameters | Parametersset for openScenario parameter references

return TeleportAction

static RoutingAction ImportRoutingAction | ( | QDomElement | routingActionElement,
 |  | Parameters & | parameters,
 |  | const std::string | catalogPath
 | ) |  |
staticprivate

Import an openscenario RoutingAction Element.

Parameters
[in] | routingActionElement | RoutingAction xml Element
[in] | parameters | Parametersset for openScenario parameter references
[in] | catalogPath | CatalogPath

return RoutingAction

static VisibilityAction ImportVisibilityAction | ( | QDomElement | visibilityActionElement,
 |  | Parameters & | parameters
 | ) |  |
staticprivate

Import an openscenario VisibilityAction Element.

Parameters
[in] | visbilityActionElement | VisibilityAction xml Element
[in] | parameters | Parametersset for openScenario parameter references

return VisibilityAction

static QDomElement GetTrajectoryElementFromCatalog | ( | const std::string & | catalogName,
 |  | const std::string & | catalogPath,
 |  | const std::string & | entryName,
 |  | openScenario::Parameters & | parameters
 | ) |  |
staticprivate

Gets the Trajectory xml Element from a specified catalog.

Parameters
[in] | catalogName | Name of the catalog
[in] | catalogPath | Path of the catalog
[in] | entryName | Name of the catalog entry
[in] | parameters | Parametersset for openScenario parameter references

return TrajectoryElement

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SimulationTimeCondition Class Reference

  • openScenario
  • SimulationTimeCondition
List of all members
SimulationTimeCondition Class Reference
Inheritance diagram for SimulationTimeCondition:
[legend]
Collaboration diagram for SimulationTimeCondition:
[legend]
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpeedAction Struct Reference

  • openScenario
  • SpeedAction
List of all members
SpeedAction Struct Reference
Collaboration diagram for SpeedAction:
[legend]
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: StochasticAttribute Struct Reference

  • openScenario
  • StochasticAttribute
List of all members
StochasticAttribute Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TimeHeadwayCondition Class Reference

  • openScenario
  • TimeHeadwayCondition
List of all members
TimeHeadwayCondition Class Reference
Inheritance diagram for TimeHeadwayCondition:
[legend]
Collaboration diagram for TimeHeadwayCondition:
[legend]
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TimeToCollisionCondition Class Reference

  • openScenario
  • TimeToCollisionCondition
List of all members
TimeToCollisionCondition Class Reference
Inheritance diagram for TimeToCollisionCondition:
[legend]
Collaboration diagram for TimeToCollisionCondition:
[legend]
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Trajectory Struct Reference

  • openScenario
  • Trajectory
List of all members
Trajectory Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TrajectoryPoint Struct Reference

  • openScenario
  • TrajectoryPoint
List of all members
TrajectoryPoint Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TransitionDynamics Struct Reference

  • openScenario
  • TransitionDynamics
List of all members
TransitionDynamics Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: VisibilityAction Struct Reference

  • openScenario
  • VisibilityAction
List of all members
VisibilityAction Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: WorldPosition Struct Reference

  • openScenario
  • WorldPosition
List of all members
WorldPosition Struct Reference
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Junction Class Reference

  • OWL
  • Fakes
  • Junction
List of all members
Junction Class Reference
Inheritance diagram for Junction:
[legend]
Collaboration diagram for Junction:
[legend]

Additional Inherited Members

- Public Member Functions inherited from Junction
virtual const std::string & | GetId () const =0
Returns the Id of the Junction.
virtual void | AddConnectingRoad (const Interfaces::Road *connectingRoad)=0
Adds a connecting road to this road.
virtual const Roads & | GetConnectingRoads () const =0
Returns a vector of all connecting roads that this road consists of.
virtual void | AddPriority (const std::string &high, const std::string &low)=0
Adds a priority entry for this junction.
virtual const Priorities & | GetPriorities () const =0
Returns all priorities of connectors in this junction.
virtual void | AddIntersectionInfo (const std::string &roadId, const IntersectionInfo &intersectionInfo)=0
Adds intersection info for the road with roadId to the junction.
virtual const std::map< std::string, std::vector< IntersectionInfo > > & | GetIntersections () const =0
Gets all of this junction's roads' intersection info.
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Lane Class Reference

  • OWL
  • Fakes
  • Lane
List of all members
Lane Class Reference
Inheritance diagram for Lane:
[legend]
Collaboration diagram for Lane:
[legend]

Additional Inherited Members

- Public Member Functions inherited from Lane
virtual void | CopyToGroundTruth (osi3::GroundTruth &target) const =0
Copies the underlying OSI object to the given GroundTruth. More...
virtual Id | GetId () const =0
Returns the OSI Id.
virtual bool | Exists () const =0
Returns false of this lane is invalid, otherwise returns true.
virtual const Section & | GetSection () const =0
Returns the section that this lane is part of.
virtual const Road & | GetRoad () const =0
Returns the road that this lane is part of.
virtual const LaneGeometryElements & | GetLaneGeometryElements () const =0
Returns all lane geometry elements of the lane.
virtual double | GetLength () const =0
Returns the length of the lane.
virtual int | GetRightLaneCount () const =0
Returns the number of lanes to the right of this lane.
virtual LaneType | GetLaneType () const =0
Returns the type of the lane.
virtual double | GetCurvature (double distance) const =0
virtual double | GetWidth (double distance) const =0
virtual double | GetDirection (double distance) const =0
virtual const Primitive::LaneGeometryJoint::Points | GetInterpolatedPointsAtDistance (double distance) const =0
virtual const std::vector< Id > & | GetNext () const =0
Returns the ids of all successors of this lane.
virtual const std::vector< Id > & | GetPrevious () const =0
Returns the ids of all predecessors of this lane.
virtual const Lane & | GetLeftLane () const =0
Returns the (possibly invalid) lane to the right of this lane.
virtual const Lane & | GetRightLane () const =0
Returns the (possibly invalid) lane to the right of this lane.
virtual const std::vector< Id > | GetLeftLaneBoundaries () const =0
Returns the ids of all left lane boundaries.
virtual const std::vector< Id > | GetRightLaneBoundaries () const =0
Returns the ids of all right lane boundaries.
virtual double | GetDistance (MeasurementPoint measurementPoint) const =0
virtual bool | Covers (double distance) const =0
Returns true if the specified distance is valid on this lane, otherwise returns false.
virtual void | AddNext (const Lane *lane)=0
Sets the sucessor of the lane. Throws an error if the lane already has a sucessor.
virtual void | AddPrevious (const Lane *lane)=0
Sets the predecessor of the lane. Throws an error if the lane already has a predecessor.
virtual void | AddLaneGeometryJoint (const Common::Vector2d &pointLeft, const Common::Vector2d &pointCenter, const Common::Vector2d &pointRight, double sOffset, double curvature, double heading)=0
virtual void | SetLaneType (LaneType specifiedType)=0
Sets type of the lane.
virtual void | SetLeftLane (const Interfaces::Lane &lane)=0
Sets lane to the left of this lane.
virtual void | SetRightLane (const Interfaces::Lane &lane)=0
Sets lane to the right of this lane.
virtual void | SetLeftLaneBoundaries (const std::vector< OWL::Id > laneBoundaries)=0
virtual const Interfaces::WorldObjects & | GetWorldObjects () const =0
Returns a vector of all WorldObjects that are currently in this lane.
virtual const Interfaces::TrafficSigns & | GetTrafficSigns () const =0
Returns a vector of all traffic signs that are assigned to this lane.
virtual const Interfaces::RoadMarkings & | GetRoadMarkings () const =0
Returns a vector of all road markings that are assigned to this lane.
virtual void | AddMovingObject (OWL::Interfaces::MovingObject &movingObject)=0
Adds a MovingObject to the list of objects currently in this lane.
virtual void | AddStationaryObject (OWL::Interfaces::StationaryObject &stationaryObject)=0
Adds a StationaryObject to the list of objects currently in this lane.
virtual void | AddWorldObject (Interfaces::WorldObject &worldObject)=0
Adds a WorldObject to the list of objects currently in this lane.
virtual void | AddTrafficSign (Interfaces::TrafficSign &trafficSign)=0
Assigns a traffic sign to this lane.
virtual void | AddRoadMarking (Interfaces::RoadMarking &roadMarking)=0
Assigns a road marking to this lane.
virtual void | ClearMovingObjects ()=0
Removes all MovingObjects from the list of objects currently in this lane while keeping StationaryObjects.
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneBoundary Class Reference

  • OWL
  • Fakes
  • LaneBoundary
List of all members
LaneBoundary Class Reference
Inheritance diagram for LaneBoundary:
[legend]
Collaboration diagram for LaneBoundary:
[legend]

Additional Inherited Members

- Public Member Functions inherited from LaneBoundary
virtual Id | GetId () const =0
Returns the OSI Id.
virtual double | GetWidth () const =0
Returns the width of the boundary.
virtual double | GetSStart () const =0
Returns the s coordinate, where this boundary starts.
virtual double | GetSEnd () const =0
Returns the s coordinate, where this boundary ends.
virtual LaneMarking::Type | GetType () const =0
Returns the type of the boundary.
virtual LaneMarking::Color | GetColor () const =0
Return the color of the boundary.
virtual LaneMarkingSide | GetSide () const =0
Returns the side (Left/Right) of this boundary if it is part of a double line, or Single otherwise.
virtual void | AddBoundaryPoint (const Common::Vector2d &point, double heading)=0
virtual void | CopyToGroundTruth (osi3::GroundTruth &target) const =0
Copies the underlying OSI object to the given GroundTruth. More...
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: MovingObject Class Reference

  • OWL
  • Fakes
  • MovingObject
List of all members
MovingObject Class Reference
Inheritance diagram for MovingObject:
[legend]
Collaboration diagram for MovingObject:
[legend]

Additional Inherited Members

- Public Member Functions inherited from WorldObject
virtual void | CopyToGroundTruth (osi3::GroundTruth &target) const =0
Copies the underlying OSI object to the given GroundTruth. More...
virtual Id | GetId () const =0
Returns the OSI Id of the object.
virtual Primitive::Dimension | GetDimension () const =0
Returns the dimension of the object.
virtual Primitive::AbsPosition | GetReferencePointPosition () const =0
Returns the position of the reference point of the object in absolute coordinates (i. e. world coordinates)
virtual Primitive::AbsOrientation | GetAbsOrientation () const =0
Returns the orientation of the object in absolute coordinates (i. e. world coordinates)
virtual double | GetAbsVelocityDouble () const =0
virtual double | GetAbsAccelerationDouble () const =0
template<typename T >
T * | GetLink ()
template<typename T >
T * | GetLink () const
template<typename T >
bool | Is () const
Returns true is this object is of type T otherwise false.
template<typename T >
T * | As () const
Returns this object casted to T*.
template<typename T >
T * | As ()
Returns this object casted to T*.
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Road Class Reference

  • OWL
  • Fakes
  • Road
List of all members
Road Class Reference
Inheritance diagram for Road:
[legend]
Collaboration diagram for Road:
[legend]

Additional Inherited Members

- Public Member Functions inherited from Road
virtual const std::string & | GetId () const =0
Returns the Id of the road.
virtual void | AddSection (Interfaces::Section &section)=0
Adds a section to this road.
virtual const Sections & | GetSections () const =0
Returns a vector of all sections that this road consists of.
virtual double | GetLength () const =0
Returns the length of the road.
virtual const std::string & | GetSuccessor () const =0
Returns the id of the successor of the road (i.e. next road or junction)
virtual const std::string & | GetPredecessor () const =0
Returns the id of the predecessor of the road (i.e. previous road or junction)
virtual void | SetSuccessor (const std::string &successor)=0
virtual void | SetPredecessor (const std::string &predecessor)=0
virtual bool | IsInStreamDirection () const =0
virtual double | GetDistance (MeasurementPoint mp) const =0
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadMarking Class Reference

  • OWL
  • Fakes
  • RoadMarking
List of all members
RoadMarking Class Reference
Inheritance diagram for RoadMarking:
[legend]
Collaboration diagram for RoadMarking:
[legend]

Additional Inherited Members

- Public Member Functions inherited from RoadMarking
virtual std::string | GetId () const =0
Returns the OpenDrive ID.
virtual double | GetS () const =0
Returns the s coordinate.
virtual CommonTrafficSign::Entity | GetSpecification (const double relativeDistance) const =0
Returns the specification of the sign with the set relative distance.
virtual bool | IsValidForLane (OWL::Id laneId) const =0
Returns wether the sign is valid for the specified lane.
virtual Primitive::AbsPosition | GetReferencePointPosition () const =0
Returns the position of the reference point of the object in absolute coordinates (i. e. world coordinates)
virtual void | SetS (double sPos)=0
Sets the s coordinate.
virtual void | SetValidForLane (OWL::Id laneId)=0
Adds the specified lane to the list of valid lanes.
virtual bool | SetSpecification (RoadSignalInterface *signal, Position position)=0
virtual void | CopyToGroundTruth (osi3::GroundTruth &target) const =0
Copies the underlying OSI object to the given GroundTruth. More...
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Section Class Reference

  • OWL
  • Fakes
  • Section
List of all members
Section Class Reference
Inheritance diagram for Section:
[legend]
Collaboration diagram for Section:
[legend]

Additional Inherited Members

- Public Member Functions inherited from Section
virtual void | AddNext (const Interfaces::Section &section)=0
Sets the sucessor of the section. Throws an error if the section already has a sucessor.
virtual void | AddPrevious (const Interfaces::Section &section)=0
Sets the predecessor of the section. Throws an error if the section already has a predecessor.
virtual void | AddLane (const Interfaces::Lane &lane)=0
Adds a lane to this section.
virtual void | SetRoad (Interfaces::Road *road)=0
Sets the road that this section is part of.
virtual const Lanes & | GetLanes () const =0
Returns a vector of all lanes of the section.
virtual const Interfaces::Road & | GetRoad () const =0
Returns the road that this section is part of.
virtual double | GetDistance (MeasurementPoint measurementPoint) const =0
virtual bool | Covers (double distance) const =0
Returns true if the specified distance is valid on this sections, otherwise returns false.
virtual bool | CoversInterval (double startDistance, double endDistance) const =0
Returns true at least one s coordinate between startDistance and endDistance is valid on this section.
virtual double | GetSOffset () const =0
Returns the s coordinate of the section start.
virtual double | GetLength () const =0
Returns the length of the section.
virtual void | SetCenterLaneBoundary (std::vector< Id > laneBoundaryId)=0
virtual std::vector< Id > | GetCenterLaneBoundary () const =0
Returns the ids of the lane boundaries of the center lane.
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: StationaryObject Class Reference

  • OWL
  • Fakes
  • StationaryObject
List of all members
StationaryObject Class Reference
Inheritance diagram for StationaryObject:
[legend]
Collaboration diagram for StationaryObject:
[legend]

Additional Inherited Members

- Public Member Functions inherited from WorldObject
virtual void | CopyToGroundTruth (osi3::GroundTruth &target) const =0
Copies the underlying OSI object to the given GroundTruth. More...
virtual Id | GetId () const =0
Returns the OSI Id of the object.
virtual Primitive::Dimension | GetDimension () const =0
Returns the dimension of the object.
virtual Primitive::AbsPosition | GetReferencePointPosition () const =0
Returns the position of the reference point of the object in absolute coordinates (i. e. world coordinates)
virtual Primitive::AbsOrientation | GetAbsOrientation () const =0
Returns the orientation of the object in absolute coordinates (i. e. world coordinates)
virtual double | GetAbsVelocityDouble () const =0
virtual double | GetAbsAccelerationDouble () const =0
virtual void | AddLaneAssignment (const Interfaces::Lane &lane)=0
Assigns a lane to this object.
virtual const Interfaces::Lanes & | GetLaneAssignments () const =0
Returns a vector of all lanes that this object is assigned to.
virtual void | ClearLaneAssignments ()=0
Clears the list of lanes that this object is assigned to.
template<typename T >
T * | GetLink ()
template<typename T >
T * | GetLink () const
template<typename T >
bool | Is () const
Returns true is this object is of type T otherwise false.
template<typename T >
T * | As () const
Returns this object casted to T*.
template<typename T >
T * | As ()
Returns this object casted to T*.
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TrafficSign Class Reference

  • OWL
  • Fakes
  • TrafficSign
List of all members
TrafficSign Class Reference
Inheritance diagram for TrafficSign:
[legend]
Collaboration diagram for TrafficSign:
[legend]

Additional Inherited Members

- Public Member Functions inherited from TrafficSign
virtual std::string | GetId () const =0
Returns the OpenDrive ID.
virtual double | GetS () const =0
Returns the s coordinate.
virtual std::pair< double, CommonTrafficSign::Unit > | GetValueAndUnitInSI (const double osiValue, const osi3::TrafficSignValue_Unit osiUnit) const =0
Returns the value of the sign converted in SI Units.
virtual CommonTrafficSign::Entity | GetSpecification (const double relativeDistance) const =0
Returns the specification of the sign with the set relative distance.
virtual bool | IsValidForLane (OWL::Id laneId) const =0
Returns wether the sign is valid for the specified lane.
virtual Primitive::AbsPosition | GetReferencePointPosition () const =0
Returns the position of the reference point of the object in absolute coordinates (i. e. world coordinates)
virtual void | SetS (double sPos)=0
Sets the s coordinate.
virtual void | SetValidForLane (OWL::Id laneId)=0
Adds the specified lane to the list of valid lanes.
virtual bool | SetSpecification (RoadSignalInterface *signal, Position position)=0
virtual void | AddSupplementarySign (RoadSignalInterface *odSignal, Position position)=0
virtual void | CopyToGroundTruth (osi3::GroundTruth &target) const =0
Copies the underlying OSI object to the given GroundTruth. More...
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: WorldData Class Reference

  • OWL
  • Fakes
  • WorldData
List of all members
WorldData Class Reference
Inheritance diagram for WorldData:
[legend]
Collaboration diagram for WorldData:
[legend]

Additional Inherited Members

- Public Member Functions inherited from WorldData
virtual void | Clear ()=0
Deletes all objects, roads, sections and lanes.
virtual SensorView_ptr | GetSensorView (osi3::SensorViewConfiguration &conf, int agentId)=0
Creates a OSI SensorView. More...
virtual const std::unordered_map< std::string, Road * > & | GetRoads () const =0
Returns a map of all Roads with their OSI Id.
virtual Interfaces::MovingObject & | AddMovingObject (void *linkedObject)=0
virtual Interfaces::StationaryObject & | AddStationaryObject (void *linkedObject)=0
virtual Interfaces::TrafficSign & | AddTrafficSign (const std::string odId)=0
Creates a new TrafficSign and returns it.
virtual Interfaces::RoadMarking & | AddRoadMarking ()=0
Creates a new RoadMarking and returns it.
virtual void | AssignTrafficSignToLane (OWL::Id laneId, Interfaces::TrafficSign &trafficSign)=0
virtual void | AssignRoadMarkingToLane (OWL::Id laneId, Interfaces::RoadMarking &roadMarking)=0
virtual void | RemoveMovingObjectById (Id id)=0
Deletes the moving object with the specified Id.
virtual const std::unordered_map< Id, OdId > & | GetLaneIdMapping () const =0
Returns the mapping of OSI Ids to OpenDrive Ids for lanes.
virtual const std::unordered_map< std::string, Id > & | GetTrafficSignIdMapping () const =0
Returns the mapping of OpenDrive Ids to OSI Ids for trafficSigns.
virtual const std::unordered_map< Id, Lane * > & | GetLanes () const =0
Returns a map of all lanes with their OSI Id.
virtual const std::unordered_map< Id, LaneBoundary * > & | GetLaneBoundaries () const =0
Returns a map of all lane boundaries with their OSI Id.
virtual const std::map< std::string, Junction * > & | GetJunctions () const =0
Returns a map of all junctions with their OSI Id.
virtual const std::unordered_map< Id, TrafficSign * > & | GetTrafficSigns () const =0
Returns a map of all traffic signs with their OSI Id.
virtual const std::unordered_map< Id, RoadMarking * > & | GetRoadMarkings () const =0
Returns a map of all road markings with their OSI Id.
virtual void | SetRoadGraph (const RoadGraph &&roadGraph, const RoadGraphVertexMapping &&vertexMapping)=0
virtual const RoadGraph & | GetRoadGraph () const =0
Returns the graph representation of the road network.
virtual const RoadGraphVertexMapping & | GetRoadGraphVertexMapping () const =0
Returns the mapping from roads (with direction) to the vertices of the roadGraph.
virtual void | AddLane (RoadLaneSectionInterface &odSection, const RoadLaneInterface &odLane, const std::vector< Id > laneBoundaries)=0
virtual Id | AddLaneBoundary (const RoadLaneRoadMark &odLaneRoadMark, double sectionStart, LaneMarkingSide side)=0
virtual void | SetCenterLaneBoundary (const RoadLaneSectionInterface &odSection, std::vector< Id > laneBoundaryIds)=0
virtual void | AddSection (const RoadInterface &odRoad, const RoadLaneSectionInterface &odSection)=0
virtual void | AddRoad (const RoadInterface &odRoad)=0
virtual void | AddJunction (const JunctionInterface *odJunction)=0
virtual void | AddJunctionConnection (const JunctionInterface *odJunction, const RoadInterface &odRoad)=0
Adds a connection road (path) to a junction.
virtual void | AddJunctionPriority (const JunctionInterface *odJunction, const std::string &high, const std::string &low)=0
Adds a priority entry of to connecting roads to a junction.
virtual void | AddLaneGeometryPoint (const RoadLaneInterface &odLane, const Common::Vector2d &pointLeft, const Common::Vector2d &pointCenter, const Common::Vector2d &pointRight, const double sOffset, const double curvature, const double heading)=0
virtual void | AddCenterLinePoint (const RoadLaneSectionInterface &odSection, const Common::Vector2d &pointCenter, const double sOffset, double heading)=0
virtual void | AddLaneSuccessor (RoadLaneInterface &odLane, RoadLaneInterface &successorOdLane)=0
Sets successorOdLane as successor of odLane.
virtual void | AddLanePredecessor (RoadLaneInterface &odLane, RoadLaneInterface &predecessorOdLane)=0
Sets predecessorOdLane as predecessor of odLane.
virtual void | SetRoadSuccessor (const RoadInterface &road, const RoadInterface &successorRoad)=0
Sets successorRoad as successor of road in OSI.
virtual void | SetRoadPredecessor (const RoadInterface &road, const RoadInterface &predecessorRoad)=0
Sets predecessorRoad as predecessor of road in OSI.
virtual void | SetSectionSuccessor (const RoadLaneSectionInterface &section, const RoadLaneSectionInterface &successorSection)=0
Sets successorSection as successor of section in OSI.
virtual void | SetSectionPredecessor (const RoadLaneSectionInterface &section, const RoadLaneSectionInterface &predecessorSection)=0
Sets predecessorSection as predecessor of section in OSI.
virtual void | SetRoadSuccessorJunction (const RoadInterface &road, const JunctionInterface *successorJunction)=0
Sets a junction as the successor of a road.
virtual void | SetRoadPredecessorJunction (const RoadInterface &road, const JunctionInterface *predecessorJunction)=0
Sets a junction as the predecessor of a road.
virtual void | ConnectLanes (RoadLaneSectionInterface &firstOdSection, RoadLaneSectionInterface &secondOdSection, const std::map< int, int > &lanePairs, bool isPrev)=0
Currently not implemented.
virtual void | Reset ()=0
Resets the world for new run; deletes all moving objects.
virtual OWL::Id | GetOwlId (int agentId)=0
Retrieves the OWL Id of an agent. More...
virtual int | GetAgentId (const OWL::Id owlId) const =0
Retrieves the simualtion framework Id of an agent associated to the given OWL Id. More...
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: InvalidLane Class Reference

  • OWL
  • Implementation
  • InvalidLane
List of all members
InvalidLane Class Reference
Inheritance diagram for InvalidLane:
[legend]
Collaboration diagram for InvalidLane:
[legend]

Additional Inherited Members

- Public Member Functions inherited from Lane
Lane (osi3::Lane *osiLane, const Interfaces::Section *section)
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: InvalidRoad Class Reference

  • OWL
  • Implementation
  • InvalidRoad
List of all members
InvalidRoad Class Reference
Inheritance diagram for InvalidRoad:
[legend]
Collaboration diagram for InvalidRoad:
[legend]

Additional Inherited Members

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: InvalidSection Class Reference

  • OWL
  • Implementation
  • InvalidSection
List of all members
InvalidSection Class Reference
Inheritance diagram for InvalidSection:
[legend]
Collaboration diagram for InvalidSection:
[legend]

Additional Inherited Members

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Junction Class Reference

  • OWL
  • Implementation
  • Junction
List of all members
Junction Class Reference
Inheritance diagram for Junction:
[legend]
Collaboration diagram for Junction:
[legend]

Additional Inherited Members

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Lane Class Reference

  • OWL
  • Implementation
  • Lane
Public Member Functions | List of all members
Lane Class Reference
Inheritance diagram for Lane:
[legend]
Collaboration diagram for Lane:
[legend]

Public Member Functions

Lane (osi3::Lane *osiLane, const Interfaces::Section *section)

Constructor & Destructor Documentation

Lane | ( | osi3::Lane * | osiLane,
 |  | const Interfaces::Section * | section
 | ) |  |
Parameters
[in] | osiLane | representation of the road in OpenDrive
[in] | section | section that this lane is part of
[in] | isInStreamDirection | flag whether this lane is in the same direction as the LaneStream it belongs to
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneBoundary Class Reference

  • OWL
  • Implementation
  • LaneBoundary
Private Attributes | List of all members
LaneBoundary Class Reference
Inheritance diagram for LaneBoundary:
[legend]
Collaboration diagram for LaneBoundary:
[legend]

Private Attributes

double | sStart
underlying OSI object
double | sEnd
s coordinate where this boundary starts
double | width
s coordinate where this boundary ends
LaneMarkingSide | side
width of the line

Additional Inherited Members

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: MovingObject Class Reference

  • OWL
  • Implementation
  • MovingObject
List of all members
MovingObject Class Reference
Inheritance diagram for MovingObject:
[legend]
Collaboration diagram for MovingObject:
[legend]

Additional Inherited Members

- Public Member Functions inherited from WorldObject
template<typename T >
T * | GetLink ()
template<typename T >
T * | GetLink () const
template<typename T >
bool | Is () const
Returns true is this object is of type T otherwise false.
template<typename T >
T * | As () const
Returns this object casted to T*.
template<typename T >
T * | As ()
Returns this object casted to T*.
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Road Class Reference

  • OWL
  • Implementation
  • Road
List of all members
Road Class Reference
Inheritance diagram for Road:
[legend]
Collaboration diagram for Road:
[legend]

Additional Inherited Members

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadMarking Class Reference

  • OWL
  • Implementation
  • RoadMarking
List of all members
RoadMarking Class Reference
Inheritance diagram for RoadMarking:
[legend]
Collaboration diagram for RoadMarking:
[legend]

Additional Inherited Members

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Section Class Reference

  • OWL
  • Implementation
  • Section
List of all members
Section Class Reference
Inheritance diagram for Section:
[legend]
Collaboration diagram for Section:
[legend]

Additional Inherited Members

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: StationaryObject Class Reference

  • OWL
  • Implementation
  • StationaryObject
List of all members
StationaryObject Class Reference
Inheritance diagram for StationaryObject:
[legend]
Collaboration diagram for StationaryObject:
[legend]

Additional Inherited Members

- Public Member Functions inherited from WorldObject
template<typename T >
T * | GetLink ()
template<typename T >
T * | GetLink () const
template<typename T >
bool | Is () const
Returns true is this object is of type T otherwise false.
template<typename T >
T * | As () const
Returns this object casted to T*.
template<typename T >
T * | As ()
Returns this object casted to T*.
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TrafficSign Class Reference

  • OWL
  • Implementation
  • TrafficSign
List of all members
TrafficSign Class Reference
Inheritance diagram for TrafficSign:
[legend]
Collaboration diagram for TrafficSign:
[legend]

Additional Inherited Members

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Vehicle Class Reference

  • OWL
  • Implementation
  • Vehicle
List of all members
Vehicle Class Reference
Inheritance diagram for Vehicle:
[legend]
Collaboration diagram for Vehicle:
[legend]

Additional Inherited Members

- Public Member Functions inherited from WorldObject
template<typename T >
T * | GetLink ()
template<typename T >
T * | GetLink () const
template<typename T >
bool | Is () const
Returns true is this object is of type T otherwise false.
template<typename T >
T * | As () const
Returns this object casted to T*.
template<typename T >
T * | As ()
Returns this object casted to T*.
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Junction Class Reference

  • OWL
  • Interfaces
  • Junction
Public Member Functions | List of all members
Junction Class Referenceabstract

This class represents a junction in the world. More...

Inheritance diagram for Junction:
[legend]

Public Member Functions

virtual const std::string & | GetId () const =0
Returns the Id of the Junction.
virtual void | AddConnectingRoad (const Interfaces::Road *connectingRoad)=0
Adds a connecting road to this road.
virtual const Roads & | GetConnectingRoads () const =0
Returns a vector of all connecting roads that this road consists of.
virtual void | AddPriority (const std::string &high, const std::string &low)=0
Adds a priority entry for this junction.
virtual const Priorities & | GetPriorities () const =0
Returns all priorities of connectors in this junction.
virtual void | AddIntersectionInfo (const std::string &roadId, const IntersectionInfo &intersectionInfo)=0
Adds intersection info for the road with roadId to the junction.
virtual const std::map< std::string, std::vector< IntersectionInfo > > & | GetIntersections () const =0
Gets all of this junction's roads' intersection info.

Detailed Description

This class represents a junction in the world.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Lane Class Reference

  • OWL
  • Interfaces
  • Lane
Public Member Functions | List of all members
Lane Class Referenceabstract

This class represents a single lane inside a section. More...

Inheritance diagram for Lane:
[legend]

Public Member Functions

virtual void | CopyToGroundTruth (osi3::GroundTruth &target) const =0
Copies the underlying OSI object to the given GroundTruth. More...
virtual Id | GetId () const =0
Returns the OSI Id.
virtual bool | Exists () const =0
Returns false of this lane is invalid, otherwise returns true.
virtual const Section & | GetSection () const =0
Returns the section that this lane is part of.
virtual const Road & | GetRoad () const =0
Returns the road that this lane is part of.
virtual const LaneGeometryElements & | GetLaneGeometryElements () const =0
Returns all lane geometry elements of the lane.
virtual double | GetLength () const =0
Returns the length of the lane.
virtual int | GetRightLaneCount () const =0
Returns the number of lanes to the right of this lane.
virtual LaneType | GetLaneType () const =0
Returns the type of the lane.
virtual double | GetCurvature (double distance) const =0
virtual double | GetWidth (double distance) const =0
virtual double | GetDirection (double distance) const =0
virtual const Primitive::LaneGeometryJoint::Points | GetInterpolatedPointsAtDistance (double distance) const =0
virtual const std::vector< Id > & | GetNext () const =0
Returns the ids of all successors of this lane.
virtual const std::vector< Id > & | GetPrevious () const =0
Returns the ids of all predecessors of this lane.
virtual const Lane & | GetLeftLane () const =0
Returns the (possibly invalid) lane to the right of this lane.
virtual const Lane & | GetRightLane () const =0
Returns the (possibly invalid) lane to the right of this lane.
virtual const std::vector< Id > | GetLeftLaneBoundaries () const =0
Returns the ids of all left lane boundaries.
virtual const std::vector< Id > | GetRightLaneBoundaries () const =0
Returns the ids of all right lane boundaries.
virtual double | GetDistance (MeasurementPoint measurementPoint) const =0
virtual bool | Covers (double distance) const =0
Returns true if the specified distance is valid on this lane, otherwise returns false.
virtual void | AddNext (const Lane *lane)=0
Sets the sucessor of the lane. Throws an error if the lane already has a sucessor.
virtual void | AddPrevious (const Lane *lane)=0
Sets the predecessor of the lane. Throws an error if the lane already has a predecessor.
virtual void | AddLaneGeometryJoint (const Common::Vector2d &pointLeft, const Common::Vector2d &pointCenter, const Common::Vector2d &pointRight, double sOffset, double curvature, double heading)=0
virtual void | SetLaneType (LaneType specifiedType)=0
Sets type of the lane.
virtual void | SetLeftLane (const Interfaces::Lane &lane)=0
Sets lane to the left of this lane.
virtual void | SetRightLane (const Interfaces::Lane &lane)=0
Sets lane to the right of this lane.
virtual void | SetLeftLaneBoundaries (const std::vector< OWL::Id > laneBoundaries)=0
virtual const Interfaces::WorldObjects & | GetWorldObjects () const =0
Returns a vector of all WorldObjects that are currently in this lane.
virtual const Interfaces::TrafficSigns & | GetTrafficSigns () const =0
Returns a vector of all traffic signs that are assigned to this lane.
virtual const Interfaces::RoadMarkings & | GetRoadMarkings () const =0
Returns a vector of all road markings that are assigned to this lane.
virtual void | AddMovingObject (OWL::Interfaces::MovingObject &movingObject)=0
Adds a MovingObject to the list of objects currently in this lane.
virtual void | AddStationaryObject (OWL::Interfaces::StationaryObject &stationaryObject)=0
Adds a StationaryObject to the list of objects currently in this lane.
virtual void | AddWorldObject (Interfaces::WorldObject &worldObject)=0
Adds a WorldObject to the list of objects currently in this lane.
virtual void | AddTrafficSign (Interfaces::TrafficSign &trafficSign)=0
Assigns a traffic sign to this lane.
virtual void | AddRoadMarking (Interfaces::RoadMarking &roadMarking)=0
Assigns a road marking to this lane.
virtual void | ClearMovingObjects ()=0
Removes all MovingObjects from the list of objects currently in this lane while keeping StationaryObjects.

Detailed Description

This class represents a single lane inside a section.

Member Function Documentation

virtual void CopyToGroundTruth ( osi3::GroundTruth & target ) const
pure virtual

Copies the underlying OSI object to the given GroundTruth.

Parameters
[in] target The target OSI GroundTruth
virtual double GetCurvature ( double distance ) const
pure virtual

Returns the curvature of the lane at the specified distance

Parameters
distance s coordinate
virtual double GetWidth ( double distance ) const
pure virtual

Returns the width of the lane at the specified distance

Parameters
distance s coordinate
virtual double GetDirection ( double distance ) const
pure virtual

Returns the direction of the lane at the specified distance

Parameters
distance s coordinate
virtual const Primitive::LaneGeometryJoint::Points GetInterpolatedPointsAtDistance ( double distance ) const
pure virtual

Returns the left, right and reference point at the specified s coordinate interpolated between the geometry joints

Parameters
distance s coordinate
virtual double GetDistance ( MeasurementPoint measurementPoint ) const
pure virtual

Returns the s coordinate of the lane start if measure point is road start or the s coordinate of the lane end if measure point is road end

virtual void AddLaneGeometryJoint | ( | const Common::Vector2d & | pointLeft,
 |  | const Common::Vector2d & | pointCenter,
 |  | const Common::Vector2d & | pointRight,
 |  | double | sOffset,
 |  | double | curvature,
 |  | double | heading
 | ) |  |
pure virtual

Adds a new lane geometry joint to the end of the current list of joints

Parameters
pointLeft | left point of the new joint
pointCenter | reference point of the new joint
pointRight | right point of the new joint
sOffset | s offset of the new joint
curvature | curvature of the lane at sOffset
heading | heading of the lane at sOffset
virtual void SetLeftLaneBoundaries ( const std::vector< OWL::Id > laneBoundaries )
pure virtual

Adds the ids to the list of left lane boundaries

Parameters
laneBoundaries ids to add
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneBoundary Class Reference

  • OWL
  • Interfaces
  • LaneBoundary
Public Member Functions | List of all members
LaneBoundary Class Referenceabstract

This class represents the boundary between two lanes. More...

Inheritance diagram for LaneBoundary:
[legend]

Public Member Functions

virtual Id | GetId () const =0
Returns the OSI Id.
virtual double | GetWidth () const =0
Returns the width of the boundary.
virtual double | GetSStart () const =0
Returns the s coordinate, where this boundary starts.
virtual double | GetSEnd () const =0
Returns the s coordinate, where this boundary ends.
virtual LaneMarking::Type | GetType () const =0
Returns the type of the boundary.
virtual LaneMarking::Color | GetColor () const =0
Return the color of the boundary.
virtual LaneMarkingSide | GetSide () const =0
Returns the side (Left/Right) of this boundary if it is part of a double line, or Single otherwise.
virtual void | AddBoundaryPoint (const Common::Vector2d &point, double heading)=0
virtual void | CopyToGroundTruth (osi3::GroundTruth &target) const =0
Copies the underlying OSI object to the given GroundTruth. More...

Detailed Description

This class represents the boundary between two lanes.

Member Function Documentation

virtual void AddBoundaryPoint | ( | const Common::Vector2d & | point,
 |  | double | heading
 | ) |  |
pure virtual

Adds a new point the end of the list of boundary points

Parameters
point | point to add
heading | heading of the lane
virtual void CopyToGroundTruth ( osi3::GroundTruth & target ) const
pure virtual

Copies the underlying OSI object to the given GroundTruth.

Parameters
[in] target The target OSI GroundTruth
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: MovingObject Class Reference

  • OWL
  • Interfaces
  • MovingObject
List of all members
MovingObject Class Referenceabstract
Inheritance diagram for MovingObject:
[legend]
Collaboration diagram for MovingObject:
[legend]

Additional Inherited Members

- Public Member Functions inherited from WorldObject
virtual void | CopyToGroundTruth (osi3::GroundTruth &target) const =0
Copies the underlying OSI object to the given GroundTruth. More...
virtual Id | GetId () const =0
Returns the OSI Id of the object.
virtual Primitive::Dimension | GetDimension () const =0
Returns the dimension of the object.
virtual Primitive::AbsPosition | GetReferencePointPosition () const =0
Returns the position of the reference point of the object in absolute coordinates (i. e. world coordinates)
virtual Primitive::AbsOrientation | GetAbsOrientation () const =0
Returns the orientation of the object in absolute coordinates (i. e. world coordinates)
virtual double | GetAbsVelocityDouble () const =0
virtual double | GetAbsAccelerationDouble () const =0
template<typename T >
T * | GetLink ()
template<typename T >
T * | GetLink () const
template<typename T >
bool | Is () const
Returns true is this object is of type T otherwise false.
template<typename T >
T * | As () const
Returns this object casted to T*.
template<typename T >
T * | As ()
Returns this object casted to T*.
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Road Class Reference

  • OWL
  • Interfaces
  • Road
Public Member Functions | List of all members
Road Class Referenceabstract

This class represents a road in the world. More...

Inheritance diagram for Road:
[legend]

Public Member Functions

virtual const std::string & | GetId () const =0
Returns the Id of the road.
virtual void | AddSection (Interfaces::Section &section)=0
Adds a section to this road.
virtual const Sections & | GetSections () const =0
Returns a vector of all sections that this road consists of.
virtual double | GetLength () const =0
Returns the length of the road.
virtual const std::string & | GetSuccessor () const =0
Returns the id of the successor of the road (i.e. next road or junction)
virtual const std::string & | GetPredecessor () const =0
Returns the id of the predecessor of the road (i.e. previous road or junction)
virtual void | SetSuccessor (const std::string &successor)=0
virtual void | SetPredecessor (const std::string &predecessor)=0
virtual bool | IsInStreamDirection () const =0
virtual double | GetDistance (MeasurementPoint mp) const =0

Detailed Description

This class represents a road in the world.

Member Function Documentation

virtual void SetSuccessor ( const std::string & successor )
pure virtual

Sets the successor of the road

Parameters
successor id of successor (road or junction)
virtual void SetPredecessor ( const std::string & predecessor )
pure virtual

Sets the predecessor of the road

Parameters
predecessor id of predecessor (road or junction)
virtual bool IsInStreamDirection ( ) const
pure virtual

Returns true if the direction of the road is the same as the direction of the road stream, false otherwise

virtual double GetDistance ( MeasurementPoint mp ) const
pure virtual

Returns the distance to a point on the road, relative to the road itself

Parameters
mp the point on the road to measure
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadMarking Class Reference

  • OWL
  • Interfaces
  • RoadMarking
Public Member Functions | List of all members
RoadMarking Class Referenceabstract

This class represents a traffic sign that is painted on the road surface. More...

Inheritance diagram for RoadMarking:
[legend]

Public Member Functions

virtual std::string | GetId () const =0
Returns the OpenDrive ID.
virtual double | GetS () const =0
Returns the s coordinate.
virtual CommonTrafficSign::Entity | GetSpecification (const double relativeDistance) const =0
Returns the specification of the sign with the set relative distance.
virtual bool | IsValidForLane (OWL::Id laneId) const =0
Returns wether the sign is valid for the specified lane.
virtual Primitive::AbsPosition | GetReferencePointPosition () const =0
Returns the position of the reference point of the object in absolute coordinates (i. e. world coordinates)
virtual void | SetS (double sPos)=0
Sets the s coordinate.
virtual void | SetValidForLane (OWL::Id laneId)=0
Adds the specified lane to the list of valid lanes.
virtual bool | SetSpecification (RoadSignalInterface *signal, Position position)=0
virtual void | CopyToGroundTruth (osi3::GroundTruth &target) const =0
Copies the underlying OSI object to the given GroundTruth. More...

Detailed Description

This class represents a traffic sign that is painted on the road surface.

Member Function Documentation

virtual bool SetSpecification | ( | RoadSignalInterface * | signal,
 |  | Position | position
 | ) |  |
pure virtual

Converts the specification imported from OpenDrive to OSI.

Parameters
signal | OpenDrive specification
position | position in the world
Returns
true if succesfull, false if the road marking can not be converted
virtual void CopyToGroundTruth ( osi3::GroundTruth & target ) const
pure virtual

Copies the underlying OSI object to the given GroundTruth.

Parameters
[in] target The target OSI GroundTruth
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Section Class Reference

  • OWL
  • Interfaces
  • Section
Public Member Functions | List of all members
Section Class Referenceabstract

This class represents one section of a road. More...

Inheritance diagram for Section:
[legend]

Public Member Functions

virtual void | AddNext (const Interfaces::Section &section)=0
Sets the sucessor of the section. Throws an error if the section already has a sucessor.
virtual void | AddPrevious (const Interfaces::Section &section)=0
Sets the predecessor of the section. Throws an error if the section already has a predecessor.
virtual void | AddLane (const Interfaces::Lane &lane)=0
Adds a lane to this section.
virtual void | SetRoad (Interfaces::Road *road)=0
Sets the road that this section is part of.
virtual const Lanes & | GetLanes () const =0
Returns a vector of all lanes of the section.
virtual const Interfaces::Road & | GetRoad () const =0
Returns the road that this section is part of.
virtual double | GetDistance (MeasurementPoint measurementPoint) const =0
virtual bool | Covers (double distance) const =0
Returns true if the specified distance is valid on this sections, otherwise returns false.
virtual bool | CoversInterval (double startDistance, double endDistance) const =0
Returns true at least one s coordinate between startDistance and endDistance is valid on this section.
virtual double | GetSOffset () const =0
Returns the s coordinate of the section start.
virtual double | GetLength () const =0
Returns the length of the section.
virtual void | SetCenterLaneBoundary (std::vector< Id > laneBoundaryId)=0
virtual std::vector< Id > | GetCenterLaneBoundary () const =0
Returns the ids of the lane boundaries of the center lane.

Detailed Description

This class represents one section of a road.

Member Function Documentation

virtual double GetDistance ( MeasurementPoint measurementPoint ) const
pure virtual

Returns the s coordinate of the section start if measure point is road start or the s coordinate of the section end if measure point is road end

virtual void SetCenterLaneBoundary ( std::vector< Id > laneBoundaryId )
pure virtual

Sets the ids of the lane boundaries of the center lane

Parameters
laneBoundaryId ids of center lane boundaries
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: StationaryObject Class Reference

  • OWL
  • Interfaces
  • StationaryObject
List of all members
StationaryObject Class Referenceabstract
Inheritance diagram for StationaryObject:
[legend]
Collaboration diagram for StationaryObject:
[legend]

Additional Inherited Members

- Public Member Functions inherited from WorldObject
virtual void | CopyToGroundTruth (osi3::GroundTruth &target) const =0
Copies the underlying OSI object to the given GroundTruth. More...
virtual Id | GetId () const =0
Returns the OSI Id of the object.
virtual Primitive::Dimension | GetDimension () const =0
Returns the dimension of the object.
virtual Primitive::AbsPosition | GetReferencePointPosition () const =0
Returns the position of the reference point of the object in absolute coordinates (i. e. world coordinates)
virtual Primitive::AbsOrientation | GetAbsOrientation () const =0
Returns the orientation of the object in absolute coordinates (i. e. world coordinates)
virtual double | GetAbsVelocityDouble () const =0
virtual double | GetAbsAccelerationDouble () const =0
virtual void | AddLaneAssignment (const Interfaces::Lane &lane)=0
Assigns a lane to this object.
virtual const Interfaces::Lanes & | GetLaneAssignments () const =0
Returns a vector of all lanes that this object is assigned to.
virtual void | ClearLaneAssignments ()=0
Clears the list of lanes that this object is assigned to.
template<typename T >
T * | GetLink ()
template<typename T >
T * | GetLink () const
template<typename T >
bool | Is () const
Returns true is this object is of type T otherwise false.
template<typename T >
T * | As () const
Returns this object casted to T*.
template<typename T >
T * | As ()
Returns this object casted to T*.
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TrafficSign Class Reference

  • OWL
  • Interfaces
  • TrafficSign
Public Member Functions | List of all members
TrafficSign Class Referenceabstract

This class represents a static traffic sign. More...

Inheritance diagram for TrafficSign:
[legend]

Public Member Functions

virtual std::string | GetId () const =0
Returns the OpenDrive ID.
virtual double | GetS () const =0
Returns the s coordinate.
virtual std::pair< double, CommonTrafficSign::Unit > | GetValueAndUnitInSI (const double osiValue, const osi3::TrafficSignValue_Unit osiUnit) const =0
Returns the value of the sign converted in SI Units.
virtual CommonTrafficSign::Entity | GetSpecification (const double relativeDistance) const =0
Returns the specification of the sign with the set relative distance.
virtual bool | IsValidForLane (OWL::Id laneId) const =0
Returns wether the sign is valid for the specified lane.
virtual Primitive::AbsPosition | GetReferencePointPosition () const =0
Returns the position of the reference point of the object in absolute coordinates (i. e. world coordinates)
virtual void | SetS (double sPos)=0
Sets the s coordinate.
virtual void | SetValidForLane (OWL::Id laneId)=0
Adds the specified lane to the list of valid lanes.
virtual bool | SetSpecification (RoadSignalInterface *signal, Position position)=0
virtual void | AddSupplementarySign (RoadSignalInterface *odSignal, Position position)=0
virtual void | CopyToGroundTruth (osi3::GroundTruth &target) const =0
Copies the underlying OSI object to the given GroundTruth. More...

Detailed Description

This class represents a static traffic sign.

Member Function Documentation

virtual bool SetSpecification | ( | RoadSignalInterface * | signal,
 |  | Position | position
 | ) |  |
pure virtual

Converts the specification imported from OpenDrive to OSI.

Parameters
signal | OpenDrive specification
position | position in the world
Returns
true if succesfull, false if the sign can not be converted
virtual void AddSupplementarySign | ( | RoadSignalInterface * | odSignal,
 |  | Position | position
 | ) |  |
pure virtual

Adds a supplementary sign to this sign and converts its specifation from OpenDrive to OSI

Parameters
odSignal | OpenDrive specification of supplementary sign
position | position of the supplementary sign
virtual void CopyToGroundTruth ( osi3::GroundTruth & target ) const
pure virtual

Copies the underlying OSI object to the given GroundTruth.

Parameters
[in] target The target OSI GroundTruth
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: WorldData Class Reference

  • OWL
  • Interfaces
  • WorldData
Public Member Functions | List of all members
WorldData Class Referenceabstract

This class contains the entire road network and all objects in the world. More...

Inheritance diagram for WorldData:
[legend]

Public Member Functions

virtual void | Clear ()=0
Deletes all objects, roads, sections and lanes.
virtual SensorView_ptr | GetSensorView (osi3::SensorViewConfiguration &conf, int agentId)=0
Creates a OSI SensorView. More...
virtual const std::unordered_map< std::string, Road * > & | GetRoads () const =0
Returns a map of all Roads with their OSI Id.
virtual Interfaces::MovingObject & | AddMovingObject (void *linkedObject)=0
virtual Interfaces::StationaryObject & | AddStationaryObject (void *linkedObject)=0
virtual Interfaces::TrafficSign & | AddTrafficSign (const std::string odId)=0
Creates a new TrafficSign and returns it.
virtual Interfaces::RoadMarking & | AddRoadMarking ()=0
Creates a new RoadMarking and returns it.
virtual void | AssignTrafficSignToLane (OWL::Id laneId, Interfaces::TrafficSign &trafficSign)=0
virtual void | AssignRoadMarkingToLane (OWL::Id laneId, Interfaces::RoadMarking &roadMarking)=0
virtual void | RemoveMovingObjectById (Id id)=0
Deletes the moving object with the specified Id.
virtual const std::unordered_map< Id, OdId > & | GetLaneIdMapping () const =0
Returns the mapping of OSI Ids to OpenDrive Ids for lanes.
virtual const std::unordered_map< std::string, Id > & | GetTrafficSignIdMapping () const =0
Returns the mapping of OpenDrive Ids to OSI Ids for trafficSigns.
virtual const Implementation::InvalidLane & | GetInvalidLane () const =0
Returns an invalid lane.
virtual const std::unordered_map< Id, Lane * > & | GetLanes () const =0
Returns a map of all lanes with their OSI Id.
virtual const std::unordered_map< Id, LaneBoundary * > & | GetLaneBoundaries () const =0
Returns a map of all lane boundaries with their OSI Id.
virtual const std::map< std::string, Junction * > & | GetJunctions () const =0
Returns a map of all junctions with their OSI Id.
virtual const std::unordered_map< Id, TrafficSign * > & | GetTrafficSigns () const =0
Returns a map of all traffic signs with their OSI Id.
virtual const std::unordered_map< Id, RoadMarking * > & | GetRoadMarkings () const =0
Returns a map of all road markings with their OSI Id.
virtual void | SetRoadGraph (const RoadGraph &&roadGraph, const RoadGraphVertexMapping &&vertexMapping)=0
virtual const RoadGraph & | GetRoadGraph () const =0
Returns the graph representation of the road network.
virtual const RoadGraphVertexMapping & | GetRoadGraphVertexMapping () const =0
Returns the mapping from roads (with direction) to the vertices of the roadGraph.
virtual void | AddLane (RoadLaneSectionInterface &odSection, const RoadLaneInterface &odLane, const std::vector< Id > laneBoundaries)=0
virtual Id | AddLaneBoundary (const RoadLaneRoadMark &odLaneRoadMark, double sectionStart, LaneMarkingSide side)=0
virtual void | SetCenterLaneBoundary (const RoadLaneSectionInterface &odSection, std::vector< Id > laneBoundaryIds)=0
virtual void | AddSection (const RoadInterface &odRoad, const RoadLaneSectionInterface &odSection)=0
virtual void | AddRoad (const RoadInterface &odRoad)=0
virtual void | AddJunction (const JunctionInterface *odJunction)=0
virtual void | AddJunctionConnection (const JunctionInterface *odJunction, const RoadInterface &odRoad)=0
Adds a connection road (path) to a junction.
virtual void | AddJunctionPriority (const JunctionInterface *odJunction, const std::string &high, const std::string &low)=0
Adds a priority entry of to connecting roads to a junction.
virtual void | AddLaneGeometryPoint (const RoadLaneInterface &odLane, const Common::Vector2d &pointLeft, const Common::Vector2d &pointCenter, const Common::Vector2d &pointRight, const double sOffset, const double curvature, const double heading)=0
virtual void | AddCenterLinePoint (const RoadLaneSectionInterface &odSection, const Common::Vector2d &pointCenter, const double sOffset, double heading)=0
virtual void | AddLaneSuccessor (RoadLaneInterface &odLane, RoadLaneInterface &successorOdLane)=0
Sets successorOdLane as successor of odLane.
virtual void | AddLanePredecessor (RoadLaneInterface &odLane, RoadLaneInterface &predecessorOdLane)=0
Sets predecessorOdLane as predecessor of odLane.
virtual void | SetRoadSuccessor (const RoadInterface &road, const RoadInterface &successorRoad)=0
Sets successorRoad as successor of road in OSI.
virtual void | SetRoadPredecessor (const RoadInterface &road, const RoadInterface &predecessorRoad)=0
Sets predecessorRoad as predecessor of road in OSI.
virtual void | SetSectionSuccessor (const RoadLaneSectionInterface &section, const RoadLaneSectionInterface &successorSection)=0
Sets successorSection as successor of section in OSI.
virtual void | SetSectionPredecessor (const RoadLaneSectionInterface &section, const RoadLaneSectionInterface &predecessorSection)=0
Sets predecessorSection as predecessor of section in OSI.
virtual void | SetRoadSuccessorJunction (const RoadInterface &road, const JunctionInterface *successorJunction)=0
Sets a junction as the successor of a road.
virtual void | SetRoadPredecessorJunction (const RoadInterface &road, const JunctionInterface *predecessorJunction)=0
Sets a junction as the predecessor of a road.
virtual void | ConnectLanes (RoadLaneSectionInterface &firstOdSection, RoadLaneSectionInterface &secondOdSection, const std::map< int, int > &lanePairs, bool isPrev)=0
Currently not implemented.
virtual void | Reset ()=0
Resets the world for new run; deletes all moving objects.
virtual OWL::Id | GetOwlId (int agentId)=0
Retrieves the OWL Id of an agent. More...
virtual int | GetAgentId (const OWL::Id owlId) const =0
Retrieves the simualtion framework Id of an agent associated to the given OWL Id. More...

Detailed Description

This class contains the entire road network and all objects in the world.

Member Function Documentation

virtual SensorView_ptr GetSensorView | ( | osi3::SensorViewConfiguration & | conf,
 |  | int | agentId
 | ) |  |
pure virtual

Creates a OSI SensorView.

Parameters
[in] | conf | SensorViewConfiguration to create SensorView from
[in] | host_id | The Id of the associated Agent
Returns
A OSI SensorView with filtered GroundTruth
virtual Interfaces::MovingObject& AddMovingObject ( void * linkedObject )
pure virtual

Creates a new MovingObject linked to an AgentAdapter and returns it

Parameters
linkedObject Object of type AgentAdapter which will be linked to new MovingObject
virtual Interfaces::StationaryObject& AddStationaryObject ( void * linkedObject )
pure virtual

Creates a new StationaryObject linked to a TrafficObjectAdapter and returns it

Parameters
linkedObject Object of type TrafficObjectAdapter which will be linked to new StationaryObject
virtual void AssignTrafficSignToLane | ( | OWL::Id | laneId,
 |  | Interfaces::TrafficSign & | trafficSign
 | ) |  |
pure virtual

Adds a traffic sign to the assigned signs of lane

Parameters
laneId | OSI Id of the lane
trafficSign | traffic sign to assign
virtual void AssignRoadMarkingToLane | ( | OWL::Id | laneId,
 |  | Interfaces::RoadMarking & | roadMarking
 | ) |  |
pure virtual

Adds a road marking to the assigned road markings of lane

Parameters
laneId | OSI Id of the lane
roadMarking | roadMarking to assign
virtual void SetRoadGraph | ( | const RoadGraph && | roadGraph,
 |  | const RoadGraphVertexMapping && | vertexMapping
 | ) |  |
pure virtual

Sets the road graph as imported from OpenDrive

Parameters
roadGraph | graph representation of road network
vertexMapping | mapping from roads (with direction) to the vertices of the roadGraph
virtual void AddLane | ( | RoadLaneSectionInterface & | odSection,
 |  | const RoadLaneInterface & | odLane,
 |  | const std::vector< Id > | laneBoundaries
 | ) |  |
pure virtual

Creates a new lane with parameters specified by the OpenDrive lane

Parameters
odSection | OpenDrive section to add lane to
odLane | OpenDrive lane to add
laneBoundaries | Osi Ids of the left lane boundaries of the new lane
virtual Id AddLaneBoundary | ( | const RoadLaneRoadMark & | odLaneRoadMark,
 |  | double | sectionStart,
 |  | LaneMarkingSide | side
 | ) |  |
pure virtual

Creates a new lane boundary specified by the OpenDrive RoadMark

Parameters
odLaneRoadMark | OpenDrive roadMark (= laneBoundary) to add
sectionStart | Start s coordinate of the section
side | Specifies which side of a double line to add (or Single if not a double line)
Returns
Osi id of the newly created laneBoundary
virtual void SetCenterLaneBoundary | ( | const RoadLaneSectionInterface & | odSection,
 |  | std::vector< Id > | laneBoundaryIds
 | ) |  |
pure virtual

Sets the ids of the center lane boundaries for a section

Parameters
odSection | OpenDrive section for which to set the center line
laneBoundaryIds | Osi ids of the center lane boundaries
virtual void AddSection | ( | const RoadInterface & | odRoad,
 |  | const RoadLaneSectionInterface & | odSection
 | ) |  |
pure virtual

Creates a new section with parameters specified by the OpenDrive section

Parameters
odRoad | OpenDrive road to add section to
odSection | OpenDrive section to add
virtual void AddRoad ( const RoadInterface & odRoad )
pure virtual

Creates a new road with parameters specified by the OpenDrive road

Parameters
odRoad OpenDrive road to add
virtual void AddJunction ( const JunctionInterface * odJunction )
pure virtual

Creates a new junction with parameters specified by the OpenDrive junction

Parameters
odJunction OpenDrive junction to add
virtual void AddLaneGeometryPoint | ( | const RoadLaneInterface & | odLane,
 |  | const Common::Vector2d & | pointLeft,
 |  | const Common::Vector2d & | pointCenter,
 |  | const Common::Vector2d & | pointRight,
 |  | const double | sOffset,
 |  | const double | curvature,
 |  | const double | heading
 | ) |  |
pure virtual

Adds a new lane geometry joint to the end of the current list of joints of the specified lane and a new geometry element and the boundary points of all affected right lane boundaries

Parameters
pointLeft | left point of the new joint
pointCenter | reference point of the new joint
pointRight | right point of the new joint
sOffset | s offset of the new joint
curvature | curvature of the lane at sOffset
heading | heading of the lane at sOffset
virtual void AddCenterLinePoint | ( | const RoadLaneSectionInterface & | odSection,
 |  | const Common::Vector2d & | pointCenter,
 |  | const double | sOffset,
 |  | double | heading
 | ) |  |
pure virtual

Adds a new boundary point to the center line of the specified section

Parameters
odSection | section to add boundary point to
pointCenter | point to add
sOffset | s offset of the new point
heading | heading of the road at sOffset
virtual OWL::Id GetOwlId ( int agentId )
pure virtual

Retrieves the OWL Id of an agent.

Parameters
agentId[in] Agent id (as used in AgentInterface)
Returns
OWL Id of the underlying OSI object
virtual int GetAgentId ( const OWL::Id owlId ) const
pure virtual

Retrieves the simualtion framework Id of an agent associated to the given OWL Id.

Parameters
owlId[in] OWL Id
Returns
Agent Id of the associated agent
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: WorldObject Class Reference

  • OWL
  • Interfaces
  • WorldObject
Public Member Functions | List of all members
WorldObject Class Referenceabstract
Inheritance diagram for WorldObject:
[legend]

Public Member Functions

virtual void | CopyToGroundTruth (osi3::GroundTruth &target) const =0
Copies the underlying OSI object to the given GroundTruth. More...
virtual Id | GetId () const =0
Returns the OSI Id of the object.
virtual Primitive::Dimension | GetDimension () const =0
Returns the dimension of the object.
virtual Primitive::AbsPosition | GetReferencePointPosition () const =0
Returns the position of the reference point of the object in absolute coordinates (i. e. world coordinates)
virtual Primitive::AbsOrientation | GetAbsOrientation () const =0
Returns the orientation of the object in absolute coordinates (i. e. world coordinates)
virtual double | GetAbsVelocityDouble () const =0
virtual double | GetAbsAccelerationDouble () const =0
virtual const ObjectPosition & | GetLocatedPosition () const =0
Returns the road coordinates of the object.
virtual void | AddLaneAssignment (const Interfaces::Lane &lane)=0
Assigns a lane to this object.
virtual const Interfaces::Lanes & | GetLaneAssignments () const =0
Returns a vector of all lanes that this object is assigned to.
virtual void | ClearLaneAssignments ()=0
Clears the list of lanes that this object is assigned to.
virtual void | SetReferencePointPosition (const Primitive::AbsPosition &newPosition)=0
Sets the position of the reference point of the object in absolute coordinates (i. e. world coordinates)
virtual void | SetDimension (const Primitive::Dimension &newDimension)=0
Sets the dimension of the object.
virtual void | SetAbsOrientation (const Primitive::AbsOrientation &newOrientation)=0
Sets the orientation of the object in absolute coordinates (i. e. world coordinates)
virtual void | SetLocatedPosition (const ObjectPosition &position)=0
Sets the road coordinates of the object.
template<typename T >
T * | GetLink ()
template<typename T >
T * | GetLink () const
template<typename T >
bool | Is () const
Returns true is this object is of type T otherwise false.
template<typename T >
T * | As () const
Returns this object casted to T*.
template<typename T >
T * | As ()
Returns this object casted to T*.

Detailed Description

Common base for all objects in the world that can be on the road and have a position and a dimension WorldObjects are either MovingObjects or StationaryObjects

Member Function Documentation

virtual void CopyToGroundTruth ( osi3::GroundTruth & target ) const
pure virtual

Copies the underlying OSI object to the given GroundTruth.

Parameters
[in] target The target OSI GroundTruth
virtual double GetAbsVelocityDouble ( ) const
pure virtual

Returns the absolute value of the velocity if the object is moving in road direction or the inverse if the object is moving against the road direction

virtual double GetAbsAccelerationDouble ( ) const
pure virtual

Returns the absolute value of the acceleration if the object is moving in road direction or the inverse if the object is moving against the road direction

T* GetLink ( )
inline

Returns the WorldObjectInterface that this WorldObject is linked to and casts it to T* T can be -WorldObjectsAdapter or -AgentAdapter, if this is a MovingObject or -TrafficAdapter, if this is a StationaryObject

T* GetLink ( ) const
inline

Returns the WorldObjectInterface that this WorldObject is linked to and casts it to T* T can be -WorldObjectsAdapter or -AgentAdapter, if this is a MovingObject or -TrafficAdapter, if this is a StationaryObject

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AbsAcceleration Struct Reference

  • OWL
  • Primitive
  • AbsAcceleration
List of all members
AbsAcceleration Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AbsCoordinate Struct Reference

  • OWL
  • Primitive
  • AbsCoordinate
List of all members
AbsCoordinate Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AbsOrientation Struct Reference

  • OWL
  • Primitive
  • AbsOrientation
List of all members
AbsOrientation Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AbsOrientationRate Struct Reference

  • OWL
  • Primitive
  • AbsOrientationRate
List of all members
AbsOrientationRate Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AbsPosition Struct Reference

  • OWL
  • Primitive
  • AbsPosition
List of all members
AbsPosition Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AbsVelocity Struct Reference

  • OWL
  • Primitive
  • AbsVelocity
List of all members
AbsVelocity Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Dimension Struct Reference

  • OWL
  • Primitive
  • Dimension
List of all members
Dimension Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneAcceleration Struct Reference

  • OWL
  • Primitive
  • LaneAcceleration
List of all members
LaneAcceleration Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneGeometryElement Struct Reference

  • OWL
  • Primitive
  • LaneGeometryElement
Classes | List of all members
LaneGeometryElement Struct Reference
Collaboration diagram for LaneGeometryElement:
[legend]

Classes

struct Joints
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneGeometryElement::Joints Struct Reference

  • OWL
  • Primitive
  • LaneGeometryElement
  • Joints
List of all members
LaneGeometryElement::Joints Struct Reference
Collaboration diagram for LaneGeometryElement::Joints:
[legend]
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneGeometryJoint Struct Reference

  • OWL
  • Primitive
  • LaneGeometryJoint
Classes | Public Attributes | List of all members
LaneGeometryJoint Struct Reference
Collaboration diagram for LaneGeometryJoint:
[legend]

Classes

struct Points
Tripple describing the sampled points of the lane. More...

Public Attributes

double | curvature
Curvature of the reference line at this joint.
double | sOffset
Offset with respect to the start of the road.
double | sHdg
Heading of the s projection axis.
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneGeometryJoint::Points Struct Reference

  • OWL
  • Primitive
  • LaneGeometryJoint
  • Points
List of all members
LaneGeometryJoint::Points Struct Reference

Tripple describing the sampled points of the lane. More...

Collaboration diagram for LaneGeometryJoint::Points:
[legend]

Detailed Description

Tripple describing the sampled points of the lane.

Note
Left/Right refers to the direction of the road
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneOrientation Struct Reference

  • OWL
  • Primitive
  • LaneOrientation
List of all members
LaneOrientation Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneOrientationRate Struct Reference

  • OWL
  • Primitive
  • LaneOrientationRate
List of all members
LaneOrientationRate Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LanePosition Struct Reference

  • OWL
  • Primitive
  • LanePosition
List of all members
LanePosition Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneVelocity Struct Reference

  • OWL
  • Primitive
  • LaneVelocity
List of all members
LaneVelocity Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadAcceleration Struct Reference

  • OWL
  • Primitive
  • RoadAcceleration
List of all members
RoadAcceleration Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadCoordinate Struct Reference

  • OWL
  • Primitive
  • RoadCoordinate
List of all members
RoadCoordinate Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadOrientationRate Struct Reference

  • OWL
  • Primitive
  • RoadOrientationRate
List of all members
RoadOrientationRate Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadVelocity Struct Reference

  • OWL
  • Primitive
  • RoadVelocity
List of all members
RoadVelocity Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: IntersectionInfo Struct Reference

  • OWL
  • IntersectionInfo
Public Attributes | List of all members
IntersectionInfo Struct Reference

Public Attributes

std::map< std::pair< Id, Id >, std::pair< double, double > > sOffsets

Member Data Documentation

std::map<std::pair<Id, Id>, std::pair<double, double> > sOffsets

For each pair of lanes on the own road (first id) and the intersecting road (second id) this contains the start s and end s of the intersection on the own lane

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Lazy< T > Struct Template Reference

  • OWL
  • Lazy
List of all members
Lazy< T > Struct Template Reference
Collaboration diagram for Lazy< T >:
[legend]
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: NonExistentOsiRef Class Reference

  • OWL
  • NonExistentOsiRef
List of all members
NonExistentOsiRef Class Reference
Inheritance diagram for NonExistentOsiRef:
[legend]
Collaboration diagram for NonExistentOsiRef:
[legend]
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: WorldData Class Reference

  • OWL
  • WorldData
Public Member Functions | Protected Member Functions | List of all members
WorldData Class Reference
Inheritance diagram for WorldData:
[legend]
Collaboration diagram for WorldData:
[legend]

Public Member Functions

GroundTruth_ptr | GetFilteredGroundTruth (const osi3::SensorViewConfiguration &conf, const Interfaces::MovingObject &reference)
Retrieves a filtered OSI GroundTruth. More...
std::vector< const Interfaces::TrafficSign * > | GetTrafficSignsInSector (const Primitive::AbsPosition &origin, double radius, double absYawMin, double absYawMax)
Retrieves the TrafficSigns located in the given sector (geometric shape) More...
std::vector< const Interfaces::RoadMarking * > | GetRoadMarkingsInSector (const Primitive::AbsPosition &origin, double radius, double absYawMin, double absYawMax)
Retrieves the RoadMarkings located in the given sector (geometric shape) More...
std::vector< const Interfaces::StationaryObject * > | GetStationaryObjectsInSector (const Primitive::AbsPosition &origin, double radius, double absYawMin, double absYawMax)
Retrieves the StationaryObjects located in the given sector (geometric shape) More...
std::vector< const Interfaces::MovingObject * > | GetMovingObjectsInSector (const Primitive::AbsPosition &origin, double radius, double absYawMin, double absYawMax)
Retrieves the MovingObjects located in the given sector (geometric shape) More...
double | NormalizeAngle (double angle)
Normalizes angles to +/- PI. More...
template<typename T >
std::vector< const T * > | ApplySectorFilter (const std::vector< T * > &objects, const Primitive::AbsPosition &origin, double radius, double leftBoundaryAngle, double rightBoundaryAngle)
Applies a sector-shaped filter on a list of objects. More...

Protected Member Functions

void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)

Member Function Documentation

GroundTruth_ptr GetFilteredGroundTruth | ( | const osi3::SensorViewConfiguration & | conf,
 |  | const Interfaces::MovingObject & | reference
 | ) |  |

Retrieves a filtered OSI GroundTruth.

Parameters
[in] | conf | The OSI SensorViewConfiguration to be used for filtering
[in] | reference | Host of the sensor
Returns
A OSI GroundTruth filtered by the given SensorViewConfiguration
std::vector<const Interfaces::TrafficSign*> GetTrafficSignsInSector | ( | const Primitive::AbsPosition & | origin,
 |  | double | radius,
 |  | double | absYawMin,
 |  | double | absYawMax
 | ) |  |

Retrieves the TrafficSigns located in the given sector (geometric shape)

Parameters
[in] | origin | Origin of the sector shape
[in] | radius | Radius of the sector shape
[in] | absYawMin | Right boundary angle of the sector shape
[in] | absYawMax | Left boundary angle of the sector shape
Returns
Vector of TrafficSing pointers located in the given sector
std::vector<const Interfaces::RoadMarking*> GetRoadMarkingsInSector | ( | const Primitive::AbsPosition & | origin,
 |  | double | radius,
 |  | double | absYawMin,
 |  | double | absYawMax
 | ) |  |

Retrieves the RoadMarkings located in the given sector (geometric shape)

Parameters
[in] | origin | Origin of the sector shape
[in] | radius | Radius of the sector shape
[in] | absYawMin | Right boundary angle of the sector shape
[in] | absYawMax | Left boundary angle of the sector shape
Returns
Vector of RoadMarking pointers located in the given sector
std::vector<const Interfaces::StationaryObject*> GetStationaryObjectsInSector | ( | const Primitive::AbsPosition & | origin,
 |  | double | radius,
 |  | double | absYawMin,
 |  | double | absYawMax
 | ) |  |

Retrieves the StationaryObjects located in the given sector (geometric shape)

Parameters
[in] | origin | Origin of the sector shape
[in] | radius | Radius of the sector shape
[in] | absYawMin | Right boundary angle of the sector shape
[in] | absYawMax | Left boundary angle of the sector shape
Returns
Vector of StationaryObject pointers located in the given sector
std::vector<const Interfaces::MovingObject*> GetMovingObjectsInSector | ( | const Primitive::AbsPosition & | origin,
 |  | double | radius,
 |  | double | absYawMin,
 |  | double | absYawMax
 | ) |  |

Retrieves the MovingObjects located in the given sector (geometric shape)

Parameters
[in] | origin | Origin of the sector shape
[in] | radius | Radius of the sector shape
[in] | absYawMin | Right boundary angle of the sector shape
[in] | absYawMax | Left boundary angle of the sector shape
Returns
Vector of MovingObject pointers located in the given sector
double NormalizeAngle ( double angle )

Normalizes angles to +/- PI.

Parameters
[in] angle Angle to normalize [rad]
Returns
Normalized angle in range [-PI, PI] [rad]

Here is the caller graph for this function:

std::vector<const T*> ApplySectorFilter | ( | const std::vector< T * > & | objects,
 |  | const Primitive::AbsPosition & | origin,
 |  | double | radius,
 |  | double | leftBoundaryAngle,
 |  | double | rightBoundaryAngle
 | ) |  |
inline

Applies a sector-shaped filter on a list of objects.

Parameters
[in] | objects | List of objects to apply filter to
[in] | origin | Origin of sector-shape
[in] | radius | Radius of the sector-shape. Negative value results in empty result
[in] | leftBoundaryAngle | Angle of left boundary of sector-shape (view from origin) [-PI, PI] [rad]
[in] | rightBoundaryAngle | Angle of right boundary of sector-shape (view from origin) [-PI, PI] [rad]
Returns
Vector of objects inside the sector-shape

Here is the call graph for this function:

void Log | ( | CbkLogLevel | logLevel,
 |  | const char * | file,
 |  | int | line,
 |  | const std::string & | message
 | ) |  |
inlineprotected

Provides callback to LOG() macro

Parameters
[in] | logLevel | Importance of log
[in] | file | Name of file where log is called
[in] | line | Line within file where log is called
[in] | message | Message to log
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Junction Struct Reference

  • RelativeWorldView
  • Junction
List of all members
Junction Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Lane Struct Reference

  • RelativeWorldView
  • Lane
List of all members
Lane Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LanesInterval Struct Reference

  • RelativeWorldView
  • LanesInterval
List of all members
LanesInterval Struct Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Callbacks Class Reference

  • SimulationCommon
  • Callbacks
Public Member Functions | List of all members
Callbacks Class Reference

callback implementation within framework More...

Inheritance diagram for Callbacks:
[legend]
Collaboration diagram for Callbacks:
[legend]

Public Member Functions

virtual void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message) const

Detailed Description

callback implementation within framework

Member Function Documentation

virtual void Log | ( | CbkLogLevel | logLevel,
 |  | const char * | file,
 |  | int | line,
 |  | const std::string & | message
 | ) |  | const
 virtual

Logs a provided message yielded from the provided line in the provided file

Parameters
[in] | logLevel | Importance of log
[in] | file | Name of file which triggered the logging
[in] | line | Line within the file that triggered the logging
[in] | message | Message to log
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ModelParameters Class Reference

  • SimulationCommon
  • ModelParameters
List of all members
ModelParameters Class Reference
Inheritance diagram for ModelParameters:
[legend]
Collaboration diagram for ModelParameters:
[legend]
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ObservationParameters Class Reference

  • SimulationCommon
  • ObservationParameters
List of all members
ObservationParameters Class Reference
Inheritance diagram for ObservationParameters:
[legend]
Collaboration diagram for ObservationParameters:
[legend]
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Parameters Class Reference

  • SimulationCommon
  • Parameters
List of all members
Parameters Class Reference
Inheritance diagram for Parameters:
[legend]
Collaboration diagram for Parameters:
[legend]
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnPointParameters Class Reference

  • SimulationCommon
  • SpawnPointParameters
List of all members
SpawnPointParameters Class Reference
Inheritance diagram for SpawnPointParameters:
[legend]
Collaboration diagram for SpawnPointParameters:
[legend]
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: WorldParameters Class Reference

  • SimulationCommon
  • WorldParameters
List of all members
WorldParameters Class Reference
Inheritance diagram for WorldParameters:
[legend]
Collaboration diagram for WorldParameters:
[legend]
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: MasterConfig Struct Reference

  • SimulationMaster
  • Configuration
  • MasterConfig
Static Private Member Functions | List of all members
MasterConfig Struct Reference

Used as value storage of parsed configuration parameters. More...

Static Private Member Functions

static int CheckOrDefault (int logLevel)
Checks if the passed value is in between the minimum and maximum log level boundaries. More...

Detailed Description

Used as value storage of parsed configuration parameters.

Member Function Documentation

static int CheckOrDefault ( int logLevel )
inlinestaticprivate

Checks if the passed value is in between the minimum and maximum log level boundaries.

Parameters
[in] logLevel Value to be checked.
Returns
logLevel if passed, defaultLogLevel if not
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: MasterConfigImporter Class Reference

  • SimulationMaster
  • Configuration
  • MasterConfigImporter
Static Public Member Functions | Static Private Member Functions | List of all members
MasterConfigImporter Class Reference

Static Public Member Functions

static MasterConfig Import (const QString &filename)
Imports the master configuration details from the master configuration xml. More...

Static Private Member Functions

static SlaveConfig | ParseSlaveConfig (const QDomElement &element)
Parses slave configuration details from the master configuration xml. More...
static QString | GetAbsoluteFilePath (const QString &filename)
Converts a filename to an absolute file path, if necessary. Throws if no file exists at the location specified by the absolute file path. More...
static QDomElement | ReadDocument (QFile &xmlFile, const std::string &file)
Prepares an XML file for parsing using QDomElements. More...
static SlaveConfigs | ParseSlaveConfigs (const QDomElement &element)
Parses multiple slaves' configuration details from the master configuration xml. More...

Member Function Documentation

static MasterConfig Import ( const QString & filename )
static

Imports the master configuration details from the master configuration xml.

Parameters
[in] filename The name of the master configuration xml file to parse
Returns
A MasterConfig object containing the details of the master configuration as detailed in the master configuration xml
static SlaveConfig ParseSlaveConfig ( const QDomElement & element )
staticprivate

Parses slave configuration details from the master configuration xml.

Parameters
[in] element The Xml Element containing the slave configuration data
Returns
A SlaveConfig object containing the details of the slave configuration as detailed in the xml element
static QString GetAbsoluteFilePath ( const QString & filename )
staticprivate

Converts a filename to an absolute file path, if necessary. Throws if no file exists at the location specified by the absolute file path.

Parameters
[in] filename The filename to convert to an absolute file path.
Returns
A QString representing the absolute filepath to filename.
static QDomElement ReadDocument | ( | QFile & | xmlFile,
 |  | const std::string & | file
 | ) |  |
staticprivate

Prepares an XML file for parsing using QDomElements.

Parameters
[in] | xmlFile | The QFile object to be parsed with QDomElements
[in] | file | The path of the file xmlFile refers to
Returns
A QDomElement referring to the root element of the XML file
static SlaveConfigs ParseSlaveConfigs ( const QDomElement & element )
staticprivate

Parses multiple slaves' configuration details from the master configuration xml.

Parameters
[in] element The parent of the xml elements containing the slaves' configuration data
Returns
A std:vector<SlaveConfig> containing the details of the slaves' configurations as detailed in the xml element
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SlaveConfig Class Reference

  • SimulationMaster
  • Configuration
  • SlaveConfig
List of all members
SlaveConfig Class Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SimulationSlave Namespace Reference

  • Namespace Members
Classes
SimulationSlave Namespace Reference

Classes

class | Agent
class | AgentFactory
class | AgentType
class | Channel
class | ChannelBuffer
class | Component
class | ComponentType
class | DataStore
class | DataStoreBinding
class | DataStoreLibrary
class | EventDetector
class | EventDetectorBinding
class | EventDetectorLibrary
class | EventDetectorNetwork
class | EventNetwork
Implements the functionality of the interface. More...
class | FrameworkModuleContainer
class | Manipulator
class | ManipulatorBinding
class | ManipulatorLibrary
class | ManipulatorNetwork
class | ModelBinding
class | ModelLibrary
class | ObservationBinding
class | ObservationLibrary
class | ObservationModule
class | ObservationNetwork
class | RunInstantiator
class | RunResult
stores run results for output data More...
class | SpawnItemParameter
class | SpawnPoint
class | SpawnPointBinding
class | SpawnPointLibrary
class | SpawnPointNetwork
class | Stochastics
class | StochasticsBinding
class | StochasticsLibrary
class | World
class | WorldBinding
class | WorldLibrary

Detailed Description

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Agent Class Reference

  • SimulationSlave
  • Agent
List of all members
Agent Class Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AgentFactory Class Reference

  • SimulationSlave
  • AgentFactory
Private Member Functions | List of all members
AgentFactory Class Reference
Inheritance diagram for AgentFactory:
[legend]
Collaboration diagram for AgentFactory:
[legend]

Private Member Functions

bool | ConnectAgentLinks (Agent *agent)
Links all channels of the agent components. More...
std::unique_ptr< Agent > | CreateAgent (int id, AgentBlueprintInterface *agentBlueprint)
Creates a new agent based on the provided parameters, initializes it and links its agent channels. More...

Member Function Documentation

bool ConnectAgentLinks ( Agent * agent )
private

Links all channels of the agent components.

Gets the channels of the agent from all its components' output links, creates for each a channel buffer using its source and attaches it to the channel.

Parameters
[in] agent The agent whose channels are connected
Returns
Flag if the connect was successful
std::unique_ptr<Agent> CreateAgent | ( | int | id,
 |  | AgentBlueprintInterface * | agentBlueprint
 | ) |  |
private

Creates a new agent based on the provided parameters, initializes it and links its agent channels.

Gets the agent type via the reference stored in the agent run configuration definition, initializes a new agend using the parameters, resets its local driving view and initializes it, before finally linking the agent channels accordingly.

Parameters
[in] | id | Agent ID
[in] | agentBlueprint | agentBlueprint contains all necessary informations to create an agent
[in] | spawnTime | Spawn time in ms
Returns
The created agent
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AgentType Class Reference

  • SimulationSlave
  • AgentType
List of all members
AgentType Class Reference
Inheritance diagram for AgentType:
[legend]
Collaboration diagram for AgentType:
[legend]
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Channel Class Reference

  • SimulationSlave
  • Channel
List of all members
Channel Class Reference
Collaboration diagram for Channel:
[legend]
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ChannelBuffer Class Reference

  • SimulationSlave
  • ChannelBuffer
List of all members
ChannelBuffer Class Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Component Class Reference

  • SimulationSlave
  • Component
Public Member Functions | List of all members
Component Class Reference
Inheritance diagram for Component:
[legend]
Collaboration diagram for Component:
[legend]

Public Member Functions

virtual | ~Component () override
Destructor, deletes all saved output channel buffers.
void | SetImplementation (ModelInterface *implementation) override
Agent * | GetAgent () const override
bool | AddInputLink (Channel *input, int linkId) override
bool | AddOutputLink (Channel *output, int linkId) override
virtual void | SetObservations (const std::map< int, ObservationModule * > &observations) override
std::map< int, Channel * > & | GetInputLinks () override
std::map< int, Channel * > & | GetOutputLinks () override
const std::map< int, ObservationInterface * > & | GetObservations () const override
bool | TriggerCycle (int time) override
bool | AcquireOutputData (int linkId, int time) override
bool | ReleaseOutputData (int linkId) override
bool | UpdateInputData (int linkId, int time) override
ChannelBuffer * | CreateOutputBuffer (int linkId) override
bool | SetInputBuffer (int linkId, ChannelBuffer *buffer) override
bool | GetInit () const override
int | GetPriority () const override
int | GetOffsetTime () const override
int | GetResponseTime () const override
int | GetCycleTime () const override
bool | SetModelLibrary (ModelLibrary *modelLibrary) override
bool | ReleaseFromLibrary () override
ModelInterface * | GetImplementation () const override
std::string | GetName () const override

Member Function Documentation

void SetImplementation ( ModelInterface * implementation )
override

Sets the model interface implementation.

Parameters
[in] implementation Model interface implementation to set
Agent* GetAgent ( ) const
override

Returns the stored agent.

Returns
Stored agent
bool AddInputLink | ( | Channel * | input,
 |  | int | linkId
 | ) |  |
override

Adds the provided channel with the provided ID to the stored list of input channels.

Parameters
[in] | input | Input channel to add
[in] | linkId | ID of the channel to add
Returns
Flag if adding the channel was successful
bool AddOutputLink | ( | Channel * | output,
 |  | int | linkId
 | ) |  |
override

Adds the provided channel with the provided ID to the stored list of output channels.

Parameters
[in] | output | Output channel to add
[in] | linkId | ID of the channel to add
Returns
Flag if adding the channel was successful
virtual void SetObservations ( const std::map< int, ObservationModule * > & observations )
overridevirtual

Sets the observation modules map of the component

Parameters
[in] observations Observation modules (as interface)to add
std::map<int, Channel*>& GetInputLinks ( )
override

Returns the map of IDs to stored input channels.

Returns
Map of IDs to stored input channels
std::map<int, Channel*>& GetOutputLinks ( )
override

Returns the map of IDs to stored output channels.

Returns
Map of IDs to stored output channels
const std::map<int, ObservationInterface*>& GetObservations ( ) const
override

Returns the map of IDs to stored observation modules.

Returns
Map of IDs to stored observation modules
bool TriggerCycle ( int time )
override

Calls the Trigger method on the stored model library with the stored model interface implementation and the time parameter provided.

Parameters
[in] time Observation module (as interface)to add
Returns
False if an error occurred, true otherwise
bool AcquireOutputData | ( | int | linkId,
 |  | int | time
 | ) |  |
override

Gets the data on the channel with the provided ID by updating the output via the model library using the stored model instance implementation and the provided time stamp, then setting this data on the channel with the provided ID.

Parameters
[in] | linkId | ID of the output channel
[in] | time | Time stamp for the output
Returns
False if an error occurred, true otherwise
bool ReleaseOutputData ( int linkId )
override

Releases the data on the channel with the provided ID.

Parameters
[in] linkId ID of the output channel
Returns
False if an error occurred, true otherwise
bool UpdateInputData | ( | int | linkId,
 |  | int | time
 | ) |  |
override

Updates the input data on the input channelwith the provided ID by updating the input via the model library using the stored model instance implementation and the provided time stamp.

Parameters
[in] | linkId | ID of the input channel
[in] | time | Time stamp for the output
Returns
False if an error occurred, true otherwise
ChannelBuffer* CreateOutputBuffer ( int linkId )
override

Creates a new channel buffer with the provided ID, store it in the stored list of output channel buffers and return it.

Parameters
[in] linkId ID of the channel output buffer to create
Returns
Created output channel buffer
bool SetInputBuffer | ( | int | linkId,
 |  | ChannelBuffer * | buffer
 | ) |  |
override

Insert the provided channel buffer with the provided ID in the list of stored input channel buffers.

Parameters
[in] | linkId | ID of the channel input buffer
[in] | buffer | Channel input bufer to set
Returns
False if an error occurred, true otherwise
bool GetInit ( ) const
override

Returns if the stored model interface implementation is defined as init module.

Returns
Returns false if error occured, otherwise the flag if stored model interface implementation is defined as init module
int GetPriority ( ) const
override

Returns the priority of the stored model interface implementation.

Returns
Returns std::numeric_limits<int>::min() if error occured, otherwise the priority of the stored model interface implementation
int GetOffsetTime ( ) const
override

Returns the offset time of the stored model interface implementation, i.e. the time at which this item is inserted for scheduling.

Returns
Returns 0 if error occured, otherwise the offset time of the stored model interface implementation
int GetResponseTime ( ) const
override

Returns the response time of the stored model interface implementation.

Returns
Returns 0 if error occured, otherwise the respone time of the stored model interface implementation
int GetCycleTime ( ) const
override

Returns the cycle time of the stored model interface implementation, i.e. the time after which it is rescheduled.

Returns
Returns 0 if error occured, otherwise the cycle time of the stored model interface implementation
bool SetModelLibrary ( ModelLibrary * modelLibrary )
override

Set the provided model library as library to store.

Parameters
[in] modelLibrary Model library to set
Returns
False if library is already set, true otherwise
bool ReleaseFromLibrary ( )
override

Releases this component from the stored library.

Returns
Result of releasing this component
ModelInterface* GetImplementation ( ) const
override

Returns the stored model interface instance.

Returns
Stored model interface instance
std::string GetName ( ) const
override

Returns the stored ID.

Returns
Stored ID
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ComponentType Class Reference

  • SimulationSlave
  • ComponentType
List of all members
ComponentType Class Reference
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: DataStore Class Reference

  • SimulationSlave
  • DataStore
List of all members
DataStore Class Reference
Inheritance diagram for DataStore:
[legend]
Collaboration diagram for DataStore:
[legend]
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: DataStoreBinding Class Reference

  • SimulationSlave
  • DataStoreBinding
Public Member Functions | List of all members
DataStoreBinding Class Reference
Collaboration diagram for DataStoreBinding:
[legend]

Public Member Functions

DataStoreInterface * | Instantiate ()
void | Unload ()
Unloads the stochasticsInterface binding by deleting the library.

Member Function Documentation

DataStoreInterface* Instantiate ( )

Gets the dataStore instance library and stores it, then creates a new dataStoreInterface of the library.

Returns
dataStoreInterface created from the library
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: DataStoreLibrary Class Reference

  • SimulationSlave
  • DataStoreLibrary
Public Member Functions | List of all members
DataStoreLibrary Class Reference
Collaboration diagram for DataStoreLibrary:
[legend]

Public Member Functions

virtual | ~DataStoreLibrary ()
Destructor, deletes the stored library (unloads it if necessary)
bool | Init ()
bool | ReleaseDataStore ()
DataStoreInterface * | CreateDataStore (const openpass::common::RuntimeInformation &runtimeInformation)

Member Function Documentation

bool Init ( )

Creates a QLibrary based on the path from the constructor and stores function pointer for getting the library version, creating and destroying instances and setting the stochasticsInterface item (see typedefs for corresponding signatures).

Returns
true on successful operation, false otherwise
bool ReleaseDataStore ( )

Delete the DataStoreInterface and the library

Returns
Flag if the release was successful
DataStoreInterface* CreateDataStore ( const openpass::common::RuntimeInformation & runtimeInformation )

Make sure that the library exists and is loaded, then call the "create instance" function pointer, which instantiates a DataStoreInterface. The created Interface is stored.

Parameters
[in] runtimeInformation Reference to the simulation slave runtime information
Returns
DataStoreInterface created
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: EventDetector Class Reference

  • SimulationSlave
  • EventDetector
Public Member Functions | List of all members
EventDetector Class Reference
Collaboration diagram for EventDetector:
[legend]

Public Member Functions

virtual | ~EventDetector ()
Destructor, releases the event detector from the stored library.
EventDetectorInterface * | GetImplementation () const
EventDetectorLibrary * GetLibrary ()

Member Function Documentation

EventDetectorInterface* GetImplementation ( ) const
inline

Returns the event detector interface.

Returns
event detector interface
EventDetectorLibrary* GetLibrary ( )
inline

Returns the event detector library.

Returns
event detector library
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: EventDetectorBinding Class Reference

  • SimulationSlave
  • EventDetectorBinding
Public Member Functions | List of all members
EventDetectorBinding Class Reference
Collaboration diagram for EventDetectorBinding:
[legend]

Public Member Functions

std::vector< const EventDetector * > | Instantiate (const std::string libraryPath, ScenarioInterface *scenario, EventNetworkInterface *eventNetwork, WorldInterface *world, StochasticsInterface *stochastics)
void | Unload ()
Unloads the event detector binding by deleting all stored event detector libraries.

Member Function Documentation

std::vector<const EventDetector *> Instantiate | ( | const std::string | libraryPath,
 |  | ScenarioInterface * | scenario,
 |  | EventNetworkInterface * | eventNetwork,
 |  | WorldInterface * | world,
 |  | StochasticsInterface * | stochastics
 | ) |  |

Gets the event detector instance library either from the already stored libraries or create a new instance (which is then also stored), then create a new event detector using the provided parameters.

Parameters
[in] | libraryPath | Path to the library
[in] | scenario | Scenario
[in] | eventNetwork | Interface of the eventNetwork
[in] | world | World instance
[in] | stochastics | The stochastics object
Returns
Vector of created EventDetectors from the library
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: EventDetectorLibrary Class Reference

  • SimulationSlave
  • EventDetectorLibrary
Public Member Functions | List of all members
EventDetectorLibrary Class Reference
Collaboration diagram for EventDetectorLibrary:
[legend]

Public Member Functions

virtual | ~EventDetectorLibrary ()
bool | Init ()
bool | ReleaseEventDetector (EventDetector *eventDetector)
EventDetector * | CreateCollisionDetector (EventNetworkInterface *eventNetwork, WorldInterface *world, StochasticsInterface *stochastics)

Constructor & Destructor Documentation

virtual ~EventDetectorLibrary ( )
virtual

Destructor, deletes the stored library (unloads it if necessary), if the list of stored event detectors is empty.

Member Function Documentation

bool Init ( )

Creates a QLibrary based on the path from the constructor and stores function pointer for getting the library version, creating and destroying instances and setting the spawn item (see typedefs for corresponding signatures).

Returns
Null pointer
bool ReleaseEventDetector ( EventDetector * eventDetector )

Find event detector in the sored list of event detectors, then call the "destroy instance" function pointer with its implementation and remove it from the list of stored event detectors.

Parameters
[in] eventDetector event detector to release
Returns
Flag if the release was successful

Here is the caller graph for this function:

EventDetector* CreateCollisionDetector | ( | EventNetworkInterface * | eventNetwork,
 |  | WorldInterface * | world,
 |  | StochasticsInterface * | stochastics
 | ) |  |

Make sure that the library exists and is loaded, then call the "create instance" function pointer using the parameters from the event detector instance to get a event detector interface, which is then used to instantiate a event detector which is also stored in the list of event detectors.

Parameters
eventDetectorType
parameters
eventNetwork
world
stochastics
Returns
instance of event detector
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: EventDetectorNetwork Class Reference

  • SimulationSlave
  • EventDetectorNetwork
Public Member Functions | List of all members
EventDetectorNetwork Class Reference
Inheritance diagram for EventDetectorNetwork:
[legend]
Collaboration diagram for EventDetectorNetwork:
[legend]

Public Member Functions

bool | Instantiate (const std::string libraryPath, ScenarioInterface *scenario, EventNetworkInterface *eventNetwork, StochasticsInterface *stochastics)
void | Clear ()
Clears all eventdetectors.
std::vector< const EventDetector * > | GetEventDetectors ()
void | ResetAll ()
Resets all eventdetectors to their initial state.

Member Function Documentation

bool Instantiate | ( | const std::string | libraryPath,
 |  | ScenarioInterface * | scenario,
 |  | EventNetworkInterface * | eventNetwork,
 |  | StochasticsInterface * | stochastics
 | ) |  |

Instantiates the eventdetector network.

Parameters
[in] | libraryPath | Path to the library
[in] | scenario | Scenario
[in] | eventNetwork | Interface of the eventNetwork
[in] | stochastics | The stochastics object
Returns
true, if successful
std::vector<const EventDetector*> GetEventDetectors ( )

Returns all eventdetectors

Returns
Vector of created EventDetectors from the library
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: FrameworkModuleContainer Class Reference

  • SimulationSlave
  • FrameworkModuleContainer
List of all members
FrameworkModuleContainer Class Referencefinal
Inheritance diagram for FrameworkModuleContainer:
[legend]
Collaboration diagram for FrameworkModuleContainer:
[legend]
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Manipulator Class Reference

  • SimulationSlave
  • Manipulator
Public Member Functions | List of all members
Manipulator Class Reference
Collaboration diagram for Manipulator:
[legend]

Public Member Functions

virtual | ~Manipulator ()
Destructor, releases the manipulator from the stored library.
ManipulatorInterface * | GetImplementation () const
ManipulatorLibrary * GetLibrary ()

Member Function Documentation

ManipulatorInterface* GetImplementation ( ) const
inline

Returns the manipulator interface.

Returns
Manipulator interface
ManipulatorLibrary* GetLibrary ( )
inline

Returns the manipulator library.

Returns
Manipultar library
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ManipulatorBinding Class Reference

  • SimulationSlave
  • ManipulatorBinding
Public Member Functions | List of all members
ManipulatorBinding Class Reference
Collaboration diagram for ManipulatorBinding:
[legend]

Public Member Functions

std::vector< const Manipulator * > | Instantiate (const std::string libraryPath, ScenarioInterface *scenario, EventNetworkInterface *eventNetwork, WorldInterface *world, PublisherInterface *publisher)
void | Unload ()
Unloads the spawn point binding by deleting all stored spawn point libraries.

Member Function Documentation

std::vector<const Manipulator *> Instantiate | ( | const std::string | libraryPath,
 |  | ScenarioInterface * | scenario,
 |  | EventNetworkInterface * | eventNetwork,
 |  | WorldInterface * | world,
 |  | PublisherInterface * | publisher
 | ) |  |

Creates all manipulators and returns them as a vector

Parameters
[in] | libraryPath | Path to the library
[in] | scenario | Scenario
[in] | eventNetwork | Interface of the eventNetwork
[in] | world | World instance
Returns
Vector of created manipulators
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ManipulatorLibrary Class Reference

  • SimulationSlave
  • ManipulatorLibrary
Public Member Functions | List of all members
ManipulatorLibrary Class Reference
Collaboration diagram for ManipulatorLibrary:
[legend]

Public Member Functions

virtual | ~ManipulatorLibrary ()
bool | Init ()
bool | ReleaseManipulator (Manipulator *manipulator)
Manipulator * | CreateManipulator (const openScenario::ManipulatorInformation manipulatorInformation, EventNetworkInterface *eventNetwork, WorldInterface *world)

Constructor & Destructor Documentation

virtual ~ManipulatorLibrary ( )
virtual

Destructor, deletes the stored library (unloads it if necessary), if the list of stored spawn points is empty.

Member Function Documentation

bool Init ( )

Creates a QLibrary based on the path from the constructor and stores function pointer for getting the library version, creating and destroying instances and setting the spawn item (see typedefs for corresponding signatures).

Returns
Null pointer
bool ReleaseManipulator ( Manipulator * manipulator )

Find spawn point in the sored list of spawn points, then call the "destroy instance" function pointer with its implementation and remove it from the list of stored spawn points.

Parameters
[in] spawnPoint Spawn point to release
Returns
Flag if the release was successful

Here is the caller graph for this function:

Manipulator* CreateManipulator | ( | const openScenario::ManipulatorInformation | manipulatorInformation,
 |  | EventNetworkInterface * | eventNetwork,
 |  | WorldInterface * | world
 | ) |  |

Make sure that the library exists and is loaded, then call the "create instance" function pointer using the parameters from either the action interface or the ManipulatorParameters to get a manipulator

Parameters
[in] | action | Action interface containing manipulator parameters
[in] | manipulatorType | The type of the manipulator to be instantiated; this is only necessary if no action is passed
[in] | parameters | The parameters for the manipulator; this is only necessary if no action is passed
[in] | eventNetwork | The event network within which the manipulator inserts events
[in] | world | World instance
Returns
Manipulator created
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ManipulatorNetwork Class Reference

  • SimulationSlave
  • ManipulatorNetwork
Public Member Functions | List of all members
ManipulatorNetwork Class Reference
Inheritance diagram for ManipulatorNetwork:
[legend]
Collaboration diagram for ManipulatorNetwork:
[legend]

Public Member Functions

bool | Instantiate (const std::string libraryPath, ScenarioInterface *scenario, EventNetworkInterface *eventNetwork)
void | Clear ()
Clears all manipulators.
std::vector< const Manipulator * > | GetManipulators ()

Member Function Documentation

bool Instantiate | ( | const std::string | libraryPath,
 |  | ScenarioInterface * | scenario,
 |  | EventNetworkInterface * | eventNetwork
 | ) |  |

Instantiates the manipulator network.

Parameters
[in] | libraryPath | Path to the library
[in] | scenario | Scenario
[in] | eventNetwork | Interface of the eventNetwork
Returns
true, if successful
std::vector<const Manipulator*> GetManipulators ( )

Returns all manipulators

Returns
Vector of created manipulators from the library
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ModelBinding Class Reference

  • SimulationSlave
  • ModelBinding
Public Member Functions | List of all members
ModelBinding Class Reference
Collaboration diagram for ModelBinding:
[legend]

Public Member Functions

ComponentInterface * | Instantiate (std::shared_ptr< ComponentType > componentType, std::string componentName, StochasticsInterface *stochastics, WorldInterface *world, ObservationNetworkInterface *observationNetwork, Agent *agent, EventNetworkInterface *eventNetwork, PublisherInterface *publisher)
Creates a new component from the given parameters using the respective model library. More...
void | Unload ()
Unloads the model library by deleting the stored libraries.

Member Function Documentation

ComponentInterface* Instantiate | ( | std::shared_ptr< ComponentType > | componentType,
 |  | std::string | componentName,
 |  | StochasticsInterface * | stochastics,
 |  | WorldInterface * | world,
 |  | ObservationNetworkInterface * | observationNetwork,
 |  | Agent * | agent,
 |  | EventNetworkInterface * | eventNetwork,
 |  | PublisherInterface * | publisher
 | ) |  |

Creates a new component from the given parameters using the respective model library.

Gets the model library from the component type (instantiating and initializing it, if not already done), then creates the new component from the given parameters using this library.

Parameters
[in] | componentType | Type of the component to instantiate
[in] | componentName | Name of the component to instantiate
[in] | stochastics | Stochastics interface
[in] | world | World representation
[in] | observationNetwork | Network of the observation modules
[in] | agent | Agent that the component type is a part of
[in] | eventNetwork | Instance of the internal event logic
[in] | publisher | Publisher instance
Returns
The instantiated component
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ModelLibrary Class Reference

  • SimulationSlave
  • ModelLibrary
Public Member Functions | List of all members
ModelLibrary Class Reference

Public Member Functions

bool | Init ()
bool | ReleaseComponent (ComponentInterface *component)
ComponentInterface * | CreateComponent (std::shared_ptr< ComponentType > componentType, std::string componentName, const openpass::common::RuntimeInformation &runtimeInformation, StochasticsInterface *stochastics, WorldInterface *world, ObservationNetworkInterface *observationNetwork, Agent *agent, EventNetworkInterface *eventNetwork, PublisherInterface *publisher)
Creates a new agent component and its implementation and link all observation modules in the observation network to it. More...
bool | UpdateInput (ModelInterface *implementation, int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
bool | UpdateOutput (ModelInterface *implementation, int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
bool | Trigger (ModelInterface *implementation, int time)

Member Function Documentation

bool Init ( )

Inits the model library by obtaining the function pointers to all "Interface.h" functions defined via typedef.

Returns
Flag if init was successful
bool ReleaseComponent ( ComponentInterface * component )

Releases a component instance by calling the destroyInstance method on the instance and removing the instance from the list of components.

Returns
Flag if release was successful
ComponentInterface* CreateComponent | ( | std::shared_ptr< ComponentType > | componentType,
 |  | std::string | componentName,
 |  | const openpass::common::RuntimeInformation & | runtimeInformation,
 |  | StochasticsInterface * | stochastics,
 |  | WorldInterface * | world,
 |  | ObservationNetworkInterface * | observationNetwork,
 |  | Agent * | agent,
 |  | EventNetworkInterface * | eventNetwork,
 |  | PublisherInterface * | publisher
 | ) |  |

Creates a new agent component and its implementation and link all observation modules in the observation network to it.

Checks that the library exists and is loaded, then creates a new component using the agent and world parameter, set its model library to this object and link all observation modules in the observation networks to it. Finally, create a model interface using the "create instance" function pointer, set the component's implementation to this model interface and store the created component in the list of stored components and return it.

Parameters
[in] | componentType | Agent as defined in the agent config file
[in] | componentName | Name of the component
[in] | runtimeInformation | Static information from the slave for the components
[in] | stochastics | The stochastics interface
[in] | world | The world interface
[in] | observationNetwork | Network of the observation modules
[in] | agent | Agent instance
[in] | eventNetwork | Instance of the internal event logic
[in] | publisher | Publisher instance
Returns
bool UpdateInput | ( | ModelInterface * | implementation,
 |  | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
inline

Calls the "update input" function pointer with the provided parameters and returns the result of this call.

Parameters
[in] | implementation | Model interface
[in] | localLinkId | ID of the local link from the agent configuration
[in] | data | Pointer to the signal interface
[in] | time | Current virtual simulation time
Returns
Flag if update was successful?
bool UpdateOutput | ( | ModelInterface * | implementation,
 |  | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
inline

Calls the "update output" function pointer with the provided parameters and returns the result of this call.

Parameters
[in] | implementation | Model interface
[in] | localLinkId | ID of the local link from the agent configuration
[out] | data | Pointer to the data as signal interface
[in] | time | Current virtual simulation time
Returns
Flag if update was successful?
bool Trigger | ( | ModelInterface * | implementation,
 |  | int | time
 | ) |  |
inline

Calls the "trigger" function pointer with the provided parameters and returns the result of this call.

Parameters
[in] | implementation | Model interface
[in] | time | Timepoint at which the trigger happens?
Returns
Flag if triggering was successful?
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ObservationBinding Class Reference

  • SimulationSlave
  • ObservationBinding
Public Member Functions | List of all members
ObservationBinding Class Reference
Collaboration diagram for ObservationBinding:
[legend]

Public Member Functions

ObservationModule * | Instantiate (const std::string &libraryPath, const openpass::parameter::ParameterSetLevel1 &parameter, StochasticsInterface *stochastics, WorldInterface *world, SimulationSlave::EventNetworkInterface *eventNetwork, DataStoreReadInterface *dataStore)
void | Unload ()
Deletes the library mapping and all referenced observation library objects.

Member Function Documentation

ObservationModule* Instantiate | ( | const std::string & | libraryPath,
 |  | const openpass::parameter::ParameterSetLevel1 & | parameter,
 |  | StochasticsInterface * | stochastics,
 |  | WorldInterface * | world,
 |  | SimulationSlave::EventNetworkInterface * | eventNetwork,
 |  | DataStoreReadInterface * | dataStore
 | ) |  |

Creates an observation module based on the observation instance in the run config and the observation library stored in the mapping for the library name of the observation instance

Parameters
[in] | libraryPath | Path of the library
[in] | parameters | Observation parameters
[in] | stochastics | The stochastics interface
[in] | world | The world interface
[in] | eventNetwork | EventNetwork
Returns
Observation module created from the observation instance
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ObservationLibrary Class Reference

  • SimulationSlave
  • ObservationLibrary
Public Member Functions | List of all members
ObservationLibrary Class Reference

Public Member Functions

bool | Init ()
bool | ReleaseObservationModule (ObservationModule *observationModule)
ObservationModule * | CreateObservationModule (const openpass::common::RuntimeInformation &runtimeInformation, const openpass::parameter::ParameterSetLevel1 &parameters, StochasticsInterface *stochastics, WorldInterface *world, EventNetworkInterface *eventNetwork, DataStoreReadInterface *const dataStore)

Member Function Documentation

bool Init ( )

Inits the observation library by obtaining the function pointers to all "Interface.h" functions defined via typedef.

Returns
Flag if init was successful
bool ReleaseObservationModule ( ObservationModule * observationModule )

Releases an observation module instance by calling the destroyInstance method on the instance and removing the instance from the list of observation modules.

Returns
Flag if release was successful
ObservationModule* CreateObservationModule | ( | const openpass::common::RuntimeInformation & | runtimeInformation,
 |  | const openpass::parameter::ParameterSetLevel1 & | parameters,
 |  | StochasticsInterface * | stochastics,
 |  | WorldInterface * | world,
 |  | EventNetworkInterface * | eventNetwork,
 |  | DataStoreReadInterface *const | dataStore
 | ) |  |

Creates an observation module based on the observation instance in the run config and the observation library stored in the mapping for the library name of the observation instance.

Parameters
[in] | observationInstance | Observation instance from the run config
[in] | stochastics | The stochastics interface
[in] | world | The world interface
Returns
Observation module created from the observation instance
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ObservationModule Class Reference

  • SimulationSlave
  • ObservationModule
List of all members
ObservationModule Class Reference
Collaboration diagram for ObservationModule:
[legend]
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ObservationNetwork Class Reference

  • SimulationSlave
  • ObservationNetwork
List of all members
ObservationNetwork Class Reference
Inheritance diagram for ObservationNetwork:
[legend]
Collaboration diagram for ObservationNetwork:
[legend]
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RunInstantiator Class Reference

  • SimulationSlave
  • RunInstantiator
Public Member Functions | Private Member Functions | List of all members
RunInstantiator Class Reference
Collaboration diagram for RunInstantiator:
[legend]

Public Member Functions

bool ExecuteRun ()
Executes the run by preparing the stochastics, world and observation network instances, then scheduling for each run invocation an update on the observation network, finalizing the run invocation and, after all invocations have terminated, the observation network itself. More...

Private Member Functions

bool InitPreRun (ScenarioInterface &scenario, SceneryInterface &scenery)
Stops the current run.

Member Function Documentation

bool ExecuteRun ( )

Executes the run by preparing the stochastics, world and observation network instances, then scheduling for each run invocation an update on the observation network, finalizing the run invocation and, after all invocations have terminated, the observation network itself.

Executes the run by initializing the stochastics generator with the random seed from the run configuration, instantiating and initializing the observation network with the observation instances from the run configuration and the observation result path from the framework configuration. For each run invocation:

  • configure the world paremeters from the run configuration
  • import the scenery file and the world global objects
  • init the observation network run
  • instantiate the world's spawn point network
  • start the scheduling with the observation networks's UpdateTimeStep as update callback
  • finalize the run invocation using the result on the observation network

Finally, finalize the observation network and clear teh world.

Returns
Flag if the update was successful
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnItemParameter Class Reference

  • SimulationSlave
  • SpawnItemParameter
List of all members
SpawnItemParameter Class Reference
Inheritance diagram for SpawnItemParameter:
[legend]
Collaboration diagram for SpawnItemParameter:
[legend]
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnPoint Class Reference

  • SimulationSlave
  • SpawnPoint
Public Member Functions | List of all members
SpawnPoint Class Reference
Collaboration diagram for SpawnPoint:
[legend]

Public Member Functions

virtual | ~SpawnPoint ()=default
Destructor, releases the spawn point from the stored library.
int | GetId () const
AgentFactoryInterface * | GetAgentFactory ()
SpawnPointInterface * | GetImplementation ()
SpawnPointLibrary * GetLibrary ()

Member Function Documentation

int GetId ( ) const
inline

Return the ID of the respective spawn point instance.

Returns
ID of the respective spawn point instance
AgentFactoryInterface* GetAgentFactory ( )
inline

Returns the agent factory.

Returns
Agent factory
SpawnPointInterface* GetImplementation ( )
inline

Returns the spawn point interface.

Returns
Spawn point interface
SpawnPointLibrary* GetLibrary ( )
inline

Returns the spawn point library.

Returns
Spawn point library
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnPointBinding Class Reference

  • SimulationSlave
  • SpawnPointBinding
Public Member Functions | List of all members
SpawnPointBinding Class Reference
Collaboration diagram for SpawnPointBinding:
[legend]

Public Member Functions

std::unique_ptr< SpawnPoint > | Instantiate (const std::string &libraryPath, const SpawnPointDependencies &dependencies)
void | SetParameter (std::unique_ptr< ParameterInterface > parameter)
void | Unload ()
Unloads the spawn point binding by deleting all stored spawn point libraries.

Member Function Documentation

std::unique_ptr<SpawnPoint> Instantiate | ( | const std::string & | libraryPath,
 |  | const SpawnPointDependencies & | dependencies
 | ) |  |

Gets the spawn point instance library either from the already stored libraries or create a new instance (which is then also stored), then create a new spawn point using the provided parameters.

Parameters
[in] | libraryPath | Path of the spawnpoint library
[in] | deps | Spawn point dependencies
Returns
Spawn point created from the library
void SetParameter ( std::unique_ptr< ParameterInterface > parameter )
inline

Transfers ownership of parameters to this specific binding

Parameters
parameter Parameters
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnPointLibrary Class Reference

  • SimulationSlave
  • SpawnPointLibrary
Public Member Functions | List of all members
SpawnPointLibrary Class Reference
Collaboration diagram for SpawnPointLibrary:
[legend]

Public Member Functions

virtual | ~SpawnPointLibrary ()
bool | Init ()
std::unique_ptr< SpawnPoint > | CreateSpawnPoint (const SpawnPointDependencies &dependencies)

Constructor & Destructor Documentation

virtual ~SpawnPointLibrary ( )
virtual

Destructor, deletes the stored library (unloads it if necessary), if the list of stored spawn points is empty.

Member Function Documentation

bool Init ( )

Creates a QLibrary based on the path from the constructor and stores function pointer for getting the library version, creating and destroying instances and setting the spawn item (see typedefs for corresponding signatures).

Returns
Null pointer
std::unique_ptr<SpawnPoint> CreateSpawnPoint ( const SpawnPointDependencies & dependencies )

Make sure that the library exists and is loaded, then call the "create instance" function pointer using the parameters from the spawn point instance to get a spawn point interface, which is then used to instantiate a spawn point which is also stored in the list of spawn points.

Parameters
[in] | world | World instance
[in] | parameters | Spawn point parameters
[in] | agentFactory | Factory for the agents
[in] | agentBlueprintProvider | AgentBluePrintProvider
[in] | sampler | Sampler instance
[in] | scenario | Scenario from configs
Returns
Spawn point created
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnPointNetwork Class Reference

  • SimulationSlave
  • SpawnPointNetwork
List of all members
SpawnPointNetwork Class Reference
Inheritance diagram for SpawnPointNetwork:
[legend]
Collaboration diagram for SpawnPointNetwork:
[legend]
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Stochastics Class Reference

  • SimulationSlave
  • Stochastics
List of all members
Stochastics Class Reference
Inheritance diagram for Stochastics:
[legend]
Collaboration diagram for Stochastics:
[legend]
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: StochasticsBinding Class Reference

  • SimulationSlave
  • StochasticsBinding
Public Member Functions | List of all members
StochasticsBinding Class Reference

Public Member Functions

StochasticsInterface * | Instantiate (std::string libraryPath)
void | Unload ()
Unloads the stochasticsInterface binding by deleting the library.

Member Function Documentation

StochasticsInterface* Instantiate ( std::string libraryPath )

Gets the stochastics library and stores it, then creates a new stochasticsInterface of the library.

Parameters
[in] libraryPath Path of the library
Returns
StochasticsInterface created from the library
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: StochasticsLibrary Class Reference

  • SimulationSlave
  • StochasticsLibrary
Public Member Functions | List of all members
StochasticsLibrary Class Reference

Public Member Functions

virtual | ~StochasticsLibrary ()
Destructor, deletes the stored library (unloads it if necessary)
bool | Init ()
bool | ReleaseStochastics ()
StochasticsInterface * | CreateStochastics ()

Member Function Documentation

bool Init ( )

Creates a QLibrary based on the path from the constructor and stores function pointer for getting the library version, creating and destroying instances and setting the stochasticsInterface item (see typedefs for corresponding signatures).

Returns
Null pointer
bool ReleaseStochastics ( )

Delete the stochasticsInterface and the library

Returns
Flag if the release was successful
StochasticsInterface* CreateStochastics ( )

Make sure that the library exists and is loaded, then call the "create instance" function pointer using the parameters from the stochastics instance to get a stochastics interface, which is then used to instantiate a stochasticsInterface which is stored.

Returns
stochasticsInterface created
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: World Class Reference

  • SimulationSlave
  • World
Public Member Functions | List of all members
World Class Reference
Inheritance diagram for World:
[legend]
Collaboration diagram for World:
[legend]

Public Member Functions

bool | Instantiate ()
bool | isInstantiated () override

Member Function Documentation

bool Instantiate ( )
inline

Instantiate the world by creating a WorldInterface out of a world library with given world parameters

Parameters
[in] worldParameter parameters of world inclusive library path
Returns
true if successful

Here is the call graph for this function:

bool isInstantiated ( )
inlineoverride

Returns true if world was already instantiated

Returns
true if world was already instantiated
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: WorldBinding Class Reference

  • SimulationSlave
  • WorldBinding
Public Member Functions | List of all members
WorldBinding Class Reference
Collaboration diagram for WorldBinding:
[legend]

Public Member Functions

WorldInterface * | Instantiate ()
void | Unload ()
Unloads the stochasticsInterface binding by deleting the library.

Member Function Documentation

WorldInterface* Instantiate ( )

Gets the world instance library and stores it, then creates a new worldInterface of the library.

Returns
worldInterface created from the library

Here is the caller graph for this function:

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: WorldLibrary Class Reference

  • SimulationSlave
  • WorldLibrary
Public Member Functions | List of all members
WorldLibrary Class Reference

Public Member Functions

virtual | ~WorldLibrary ()
Destructor, deletes the stored library (unloads it if necessary)
bool | Init ()
bool | ReleaseWorld ()
WorldInterface * | CreateWorld ()

Member Function Documentation

bool Init ( )

Creates a QLibrary based on the path from the constructor and stores function pointer for getting the library version, creating and destroying instances and setting the stochasticsInterface item (see typedefs for corresponding signatures).

Returns
Null pointer
bool ReleaseWorld ( )

Delete the worldInterface and the library

Returns
Flag if the release was successful
WorldInterface* CreateWorld ( )

Make sure that the library exists and is loaded, then call the "create instance" function pointer using the parameters from the stochastics instance to get a stochastics interface, which is then used to instantiate a stochasticsInterface which is stored.

Returns
stochasticsInterface created
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AgentProfileLaneMaps Struct Reference

  • SpawnPointDefinitions
  • AgentProfileLaneMaps
List of all members
AgentProfileLaneMaps Struct Reference
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawningAgentProfile Struct Reference

  • SpawnPointDefinitions
  • SpawningAgentProfile
List of all members
SpawningAgentProfile Struct Reference
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: PreRunSpawnerParameters Struct Reference

  • SpawnPointPreRunCommonDefinitions
  • PreRunSpawnerParameters
List of all members
PreRunSpawnerParameters Struct Reference
Collaboration diagram for PreRunSpawnerParameters:
[legend]
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnArea Struct Reference

  • SpawnPointPreRunCommonDefinitions
  • SpawnArea
List of all members
SpawnArea Struct Reference
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnDetails Struct Reference

  • SpawnPointRuntimeCommonDefinitions
  • SpawnDetails
List of all members
SpawnDetails Struct Reference
Collaboration diagram for SpawnDetails:
[legend]
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnPointRuntimeCommonParameters Struct Reference

  • SpawnPointRuntimeCommonDefinitions
  • SpawnPointRuntimeCommonParameters
List of all members
SpawnPointRuntimeCommonParameters Struct Reference
Collaboration diagram for SpawnPointRuntimeCommonParameters:
[legend]
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnPosition Struct Reference

  • SpawnPointRuntimeCommonDefinitions
  • SpawnPosition
List of all members
SpawnPosition Struct Reference
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneIntersection< T > Struct Template Reference

  • World
  • Localization
  • LaneIntersection
List of all members
LaneIntersection< T > Struct Template Reference

This struct describes the intersection of an object with a lane. More...

Detailed Description

template<typename T = double>
struct World::Localization::LaneIntersection< T >

This struct describes the intersection of an object with a lane.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LocalizationElement Struct Reference

  • World
  • Localization
  • LocalizationElement
Public Attributes | List of all members
LocalizationElement Struct Reference

This struct contains all the information about a LaneGeometryElement that is needed by the Localizer. More...

Collaboration diagram for LocalizationElement:
[legend]

Public Attributes

const CoarseBoundingBox | search_box
Box for r-tree in millimeters.
Common::Vector2d referenceVector
Vector from reference point of current joint to reference point of next joint.
double | referenceScale
Factor between the actual length of the referenceVector and the s coordinate distance.
std::optional< Common::Vector2d > | tAxisCenter
Intersection point of all t-axis or nullopt if t-axis are paralel.

Detailed Description

This struct contains all the information about a LaneGeometryElement that is needed by the Localizer.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Localizer Class Reference

  • World
  • Localization
  • Localizer
Private Member Functions | List of all members
Localizer Class Reference
Collaboration diagram for Localizer:
[legend]

Private Member Functions

Result BuildResult (const LocatedObject &locatedObject) const
BuildResult. More...

Member Function Documentation

Result BuildResult ( const LocatedObject & locatedObject ) const
private

BuildResult.

Parameters
locatedObject
route
Returns
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LocatedObject Struct Reference

  • World
  • Localization
  • LocatedObject
List of all members
LocatedObject Struct Reference

Detailed Description

This struct is the result of the localization on all geometry element using an r-tree It is than used to build the localization result

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: PointQuery Class Reference

  • World
  • Localization
  • PointQuery
Static Public Member Functions | List of all members
PointQuery Class Reference

Static Public Member Functions

static bool IsWithin (const OWL::Primitive::LaneGeometryElement &element, const Common::Vector2d &point)

Member Function Documentation

static bool IsWithin | ( | const OWL::Primitive::LaneGeometryElement & | element,
 |  | const Common::Vector2d & | point
 | ) |  |
static

Check if point lies within (or at the boundaries) of a given geometry element

Parameters
[in] | element | element object
[in] | point | 2D point
Returns
true, if point is within (or at the boundaries) of the element
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Result Class Reference

  • World
  • Localization
  • Result
List of all members
Result Class Reference
Collaboration diagram for Result:
[legend]

Detailed Description

This struct contains all the information about an objects position in the world, that result from the Localization

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: WorldToRoadCoordinateConverter Class Reference

  • World
  • Localization
  • WorldToRoadCoordinateConverter
List of all members
WorldToRoadCoordinateConverter Class Reference
Collaboration diagram for WorldToRoadCoordinateConverter:
[legend]
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AccelerationSignal Class Reference

Public Member Functions | List of all members
AccelerationSignal Class Reference

Signal class. More...

Inheritance diagram for AccelerationSignal:
[legend]
Collaboration diagram for AccelerationSignal:
[legend]

Public Member Functions

AccelerationSignal ()
Constructor.
AccelerationSignal (AccelerationSignal &other)
Constructor.
AccelerationSignal (ComponentState componentState, double acceleration)
Constructor.
virtual operator std::string () const

Detailed Description

Signal class.

Member Function Documentation

virtual operator std::string ( ) const
inlinevirtual

Returns the content/payload of the signal as an std::string

Returns
Content/payload of the signal as an std::string
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ActionSecondaryDriverTasksImplementation Class Reference

Public Member Functions | Private Attributes | List of all members
ActionSecondaryDriverTasksImplementation Class Reference

controls secondary driver tasks More...

Inheritance diagram for ActionSecondaryDriverTasksImplementation:
[legend]
Collaboration diagram for ActionSecondaryDriverTasksImplementation:
[legend]

Public Member Functions

virtual void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
virtual void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
virtual void | Trigger (int time)
Process data within component. More...

Private Attributes

IndicatorState | in_IndicatorState = IndicatorState::IndicatorState_Off
State of the turning indicator (left, center/off, right).
bool | in_hornSwitch = false
Switch for activation of horn.
bool | in_headLightSwitch = false
Switch for activation of headlight.
bool | in_highBeamLightSwitch = false
Switch for activation of Highbeamlight.
bool | in_flasherSwitch = false
Switch for activation of Flasher.

Detailed Description

controls secondary driver tasks

This class controls the brakelight, indicators and switches the driver uses during driving.

Member Function Documentation

virtual void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
virtual void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update outputs.

Function is called by framework when this Component.has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
virtual void Trigger ( int time )
virtual

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component.

Refer to module description for information about the module's task.

Parameters
[in] time Current scheduling time
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ActionTransformRepository Class Reference

Static Public Member Functions | List of all members
ActionTransformRepository Class Referencefinal

Use this class as mixed set for fixed and auto registering transformations. More...

Static Public Member Functions

template<typename... Args>
static TransformResults | Transform (Args...args)
Applies an event to signal transformation on each event for the internally defined identifier. More...
static bool | Register (TransformSignature transform)
Register a new transformation. More...

Detailed Description

Use this class as mixed set for fixed and auto registering transformations.

When used as fixed resource simply call: ActionTransformRepository::Register(customTransformer);

This class can be used in conjunction with automatic compile time registration. Note that registration happens automatically without additional construction code, when the register method is used in a static assignment. This means that registering will be done if the translation unit holds an accodring statement (!)

Example: SomeClass.h -> static inline bool registered = ActionTransformRepository::Register(Transform); SomeClass.cpp is part of the translation unit

Effect: SomeOtherFile.cpp -> ActionTransformRepository::Register(customTransformer);

Member Function Documentation

static TransformResults Transform ( Args... args )
inlinestatic

Applies an event to signal transformation on each event for the internally defined identifier.

Parameters
args Relayed to the registered transformer
Returns
TransformResult holding a list of identifiers (for link id assignment), update state (does the current agent need an update), and signal (must not be nullptr)
static bool Register ( TransformSignature transform )
inlinestatic

Register a new transformation.

Parameters
transform
Returns
true
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AcyclicResult Class Reference

Private Attributes | List of all members
AcyclicResult Class Reference
Inheritance diagram for AcyclicResult:
[legend]
Collaboration diagram for AcyclicResult:
[legend]

Private Attributes

const AcyclicStore & | store
Reference to the acyclic datastore associated with the result set.
const AcyclicRowRefs | elements
The result set (referencing elements in a datastore)
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AgentAdapter Class Reference

Classes | Protected Member Functions | Private Member Functions | List of all members
AgentAdapter Class Reference

The AgentAdapter class This class is a adapter for the communication between the framework and world. More...

Inheritance diagram for AgentAdapter:
[legend]
Collaboration diagram for AgentAdapter:
[legend]

Classes

struct LaneObjParameters

Protected Member Functions

void | Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)
void | Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message) const

Private Member Functions

void | InitEgoVehicle ()
Initialize the ego vehicle object inside the drivingView.
void | UpdateEgoVehicle ()
Update the ego vehicle object inside the drivingView.

Detailed Description

The AgentAdapter class This class is a adapter for the communication between the framework and world.

Member Function Documentation

void Log | ( | CbkLogLevel | logLevel,
 |  | const char * | file,
 |  | int | line,
 |  | const std::string & | message
 | ) |  |
inlineprotected

Provides callback to LOG() macro

Parameters
[in] | logLevel | Importance of log
[in] | file | Name of file where log is called
[in] | line | Line within file where log is called
[in] | message | Message to log
void Log | ( | CbkLogLevel | logLevel,
 |  | const char * | file,
 |  | int | line,
 |  | const std::string & | message
 | ) |  | const
 inlineprotected

Provides callback to LOG() macro

Parameters
[in] | logLevel | Importance of log
[in] | file | Name of file where log is called
[in] | line | Line within file where log is called
[in] | message | Message to log
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AgentAdapter::LaneObjParameters Struct Reference

  • AgentAdapter
  • LaneObjParameters
List of all members
AgentAdapter::LaneObjParameters Struct Reference
Collaboration diagram for AgentAdapter::LaneObjParameters:
[legend]
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AgentBlueprint Class Reference

Public Member Functions | List of all members
AgentBlueprint Class Reference

This class stores all information which is required to instantiate an agent. More...

Inheritance diagram for AgentBlueprint:
[legend]
Collaboration diagram for AgentBlueprint:
[legend]

Public Member Functions

virtual void | SetVehicleComponentProfileNames (VehicleComponentProfileNames vehicleComponentProfileNames) override
Sets the vehicle component profile names. More...
virtual void | SetAgentCategory (AgentCategory agentCategory) override
Sets the agent category. More...
virtual void | SetAgentProfileName (std::string agentProfileName) override
Sets the agent profile name. More...
virtual void | SetVehicleProfileName (std::string vehicleProfileName) override
Sets the vehicle profile name. More...
virtual void | SetVehicleModelName (std::string vehicleModelName) override
Sets the vehicle model name. More...
virtual void | SetVehicleModelParameters (VehicleModelParameters vehicleModelParameters) override
Sets the vehicle model parameter. More...
virtual void | SetDriverProfileName (std::string driverProfileName) override
Sets the driver profile name. More...
virtual void | SetSpawnParameter (SpawnParameter spawnParameter) override
Sets the spawn parameter. More...
virtual void | SetSpeedGoalMin (double speedGoalMin) override
Sets the minimum speed goal. More...
virtual void | SetObjectName (std::string objectName) override
Sets the object name. More...
virtual void | AddSensor (openpass::sensors::Parameter parameters) override
Adds a sensor to the vehicle model parameters. More...
virtual AgentCategory | GetAgentCategory () const override
Returns the agent category. More...
virtual std::string | GetAgentProfileName () const override
Returns the agent profile name. More...
virtual std::string | GetVehicleProfileName () const override
Returns the vehicle profile name. More...
virtual std::string | GetVehicleModelName () const override
Returns the vehicle model name. More...
virtual std::string | GetDriverProfileName () const override
Returns the driver profile name. More...
virtual std::string | GetObjectName () const override
Returns the object name. More...
virtual VehicleModelParameters | GetVehicleModelParameters () const override
Returns the vehicle model parameter. More...
virtual openpass::sensors::Parameters | GetSensorParameters () const override
Returns the sensor parameter. More...
virtual VehicleComponentProfileNames | GetVehicleComponentProfileNames () const override
Returns the vehicle components profile names. More...
virtual SimulationSlave::AgentTypeInterface & | GetAgentType () const override
Returns the agent type as pointer. More...
virtual SpawnParameter & | GetSpawnParameter () override
Returns the spawn parameter as reference. More...
virtual const SpawnParameter & | GetSpawnParameter () const override
Returns the spawn parameter as reference. More...
virtual double | GetSpeedGoalMin () const override
Returns the minimum speed goal. More...

Detailed Description

This class stores all information which is required to instantiate an agent.

The information stored include physical spawn variable as well as components the agent consists out of.

Member Function Documentation

virtual void SetVehicleComponentProfileNames ( VehicleComponentProfileNames vehicleComponentProfileNames )
overridevirtual

Sets the vehicle component profile names.

Parameters
[in] vehicleComponentProfileNames
virtual void SetAgentCategory ( AgentCategory agentCategory )
overridevirtual

Sets the agent category.

Parameters
[in] agentCategory
virtual void SetAgentProfileName ( std::string agentProfileName )
overridevirtual

Sets the agent profile name.

Parameters
[in] agentProfileName
virtual void SetVehicleProfileName ( std::string vehicleProfileName )
overridevirtual

Sets the vehicle profile name.

Parameters
[in] vehicleProfileName
virtual void SetVehicleModelName ( std::string vehicleModelName )
overridevirtual

Sets the vehicle model name.

Parameters
[in] vehicleModelName
virtual void SetVehicleModelParameters ( VehicleModelParameters vehicleModelParameters )
overridevirtual

Sets the vehicle model parameter.

Parameters
[in] vehicleModelParameters
virtual void SetDriverProfileName ( std::string driverProfileName )
overridevirtual

Sets the driver profile name.

Parameters
[in] driverProfileName
virtual void SetSpawnParameter ( SpawnParameter spawnParameter )
overridevirtual

Sets the spawn parameter.

Parameters
[in] spawnParameter
virtual void SetSpeedGoalMin ( double speedGoalMin )
overridevirtual

Sets the minimum speed goal.

Parameters
[in] speedGoalMin
virtual void SetObjectName ( std::string objectName )
overridevirtual

Sets the object name.

Parameters
[in] objectName
virtual void AddSensor ( openpass::sensors::Parameter parameters )
overridevirtual

Adds a sensor to the vehicle model parameters.

Parameters
[in] | name | Name of the sensor
[in] | parameters | Parameters of the sensor
virtual AgentCategory GetAgentCategory ( ) const
overridevirtual

Returns the agent category.

Returns
agentCategory
virtual std::string GetAgentProfileName ( ) const
overridevirtual

Returns the agent profile name.

Returns
agentProfileName
virtual std::string GetVehicleProfileName ( ) const
overridevirtual

Returns the vehicle profile name.

Returns
vehicleProfileName
virtual std::string GetVehicleModelName ( ) const
overridevirtual

Returns the vehicle model name.

Returns
vehicleModelName
virtual std::string GetDriverProfileName ( ) const
overridevirtual

Returns the driver profile name.

Returns
driverProfileName
virtual std::string GetObjectName ( ) const
overridevirtual

Returns the object name.

Returns
objectName
virtual VehicleModelParameters GetVehicleModelParameters ( ) const
overridevirtual

Returns the vehicle model parameter.

Returns
vehicleModelParameters
virtual openpass::sensors::Parameters GetSensorParameters ( ) const
overridevirtual

Returns the sensor parameter.

Returns
sensorParameter
virtual VehicleComponentProfileNames GetVehicleComponentProfileNames ( ) const
overridevirtual

Returns the vehicle components profile names.

Returns
vehicleComponentProfileNames
virtual SimulationSlave::AgentTypeInterface& GetAgentType ( ) const
overridevirtual

Returns the agent type as pointer.

Returns
agentType
virtual SpawnParameter& GetSpawnParameter ( )
overridevirtual

Returns the spawn parameter as reference.

Returns
spawnParameter
virtual const SpawnParameter& GetSpawnParameter ( ) const
overridevirtual

Returns the spawn parameter as reference.

Returns
spawnParameter
virtual double GetSpeedGoalMin ( ) const
overridevirtual

Returns the minimum speed goal.

Returns
speedGoalMin
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AgentBlueprintProvider Class Reference

Public Member Functions | List of all members
AgentBlueprintProvider Class Reference
Inheritance diagram for AgentBlueprintProvider:
[legend]
Collaboration diagram for AgentBlueprintProvider:
[legend]

Public Member Functions

virtual AgentBlueprint | SampleAgent (const std::string &agentProfileName, const openScenario::Parameters &assignedParameters) const override
Samples an entire agent. More...
void | GenerateDynamicAgentBlueprint (AgentBlueprintInterface &agentBlueprint, AgentBuildInformation agentBuildInformation, std::string &driverProfileName) const
Store sampled information in AgentBlueprint for dynamic AgentProfile. More...
void | GenerateStaticAgentBlueprint (AgentBlueprintInterface &agentBlueprint, std::string systemConfigName, int systemId, std::string vehicleModelName) const
Store sampled information in AgentBlueprint for static AgentProfile. More...

Member Function Documentation

virtual AgentBlueprint SampleAgent | ( | const std::string & | agentProfileName,
 |  | const openScenario::Parameters & | assignedParameters
 | ) |  | const
 overridevirtual

Samples an entire agent.

First samples the agent profile and then depending on wether it is a static or dynamic profile samples the dynamic profiles and builds an AgentType from this or loads the AgentType from the specified SystemConfig

Parameters
agentProfileName | name of agent profile to sample
assignedParameters | parameters assigned by a catalog reference if appropriate
Returns
sampled AgentBlueprint if successful
void GenerateDynamicAgentBlueprint | ( | AgentBlueprintInterface & | agentBlueprint,
 |  | AgentBuildInformation | agentBuildInformation,
 |  | std::string & | driverProfileName
 | ) |  | const

Store sampled information in AgentBlueprint for dynamic AgentProfile.

Parameters
agentBlueprint | All results get stored in the agent blueprint
agentBuildInformation | AgentBuildInformation with information to store into the agentBlueprint
driverProfileName | name of sampled DriverProfile
void GenerateStaticAgentBlueprint | ( | AgentBlueprintInterface & | agentBlueprint,
 |  | std::string | systemConfigName,
 |  | int | systemId,
 |  | std::string | vehicleModelName
 | ) |  | const

Store sampled information in AgentBlueprint for static AgentProfile.

Parameters
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AgentBuildInformation Struct Reference

Static Public Member Functions | Private Member Functions | Friends | List of all members
AgentBuildInformation Struct Reference

The AgentBuildInformation struct contains all information that the AgentBlueprintProvider needs to fill out the AgentBlueprint for a dynamic AgentProfile. More...

Collaboration diagram for AgentBuildInformation:
[legend]

Static Public Member Functions

static DynamicAgentTypeGenerator make (SampledProfiles &sampledProfiles, DynamicParameters &dynamicParameters, std::shared_ptr< SystemConfigInterface > systemConfigBlueprint, ProfilesInterface *profiles, VehicleModelsInterface *vehicleModels)
Creates a new DynamicAgentTypeGenerator which can be used to build an instance of this struct. More...

Private Member Functions

AgentBuildInformation ()=default

Friends

class DynamicAgentTypeGenerator

Detailed Description

The AgentBuildInformation struct contains all information that the AgentBlueprintProvider needs to fill out the AgentBlueprint for a dynamic AgentProfile.

An instance of this struct is aquired by calling the static make function and then sequentially calling all building function on the returned DynamicAgentTypeGenerator

Constructor & Destructor Documentation

AgentBuildInformation ( )
privatedefault

Private constructor to be called by the DynamicAgentTypeGenerator

Member Function Documentation

static DynamicAgentTypeGenerator make | ( | SampledProfiles & | sampledProfiles,
 |  | DynamicParameters & | dynamicParameters,
 |  | std::shared_ptr< SystemConfigInterface > | systemConfigBlueprint,
 |  | ProfilesInterface * | profiles,
 |  | VehicleModelsInterface * | vehicleModels
 | ) |  |
static

Creates a new DynamicAgentTypeGenerator which can be used to build an instance of this struct.

Parameters
sampledProfiles | Profile names sampled by the DynamicProfilesSampler
dynamicParameters | Parameters samplied by the DynamicParametersSampler
systemConfigBlueprint | Imported SystemConfigBlueprint
profiles | Imported profiles from the ProfilesCatalog
vehicleModels | Imported vehicleModels from the VehiclesModelCatalog
Returns
new instance of DynamicAgentTypeGenerator
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AgentCompToCompCtrlSignal Class Reference

Public Member Functions | Private Attributes | List of all members
AgentCompToCompCtrlSignal Class Reference
Inheritance diagram for AgentCompToCompCtrlSignal:
[legend]
Collaboration diagram for AgentCompToCompCtrlSignal:
[legend]

Public Member Functions

AgentCompToCompCtrlSignal (const ComponentType componentType, const std::string &agentComponentName, const ComponentState currentState, const std::vector< ComponentWarningInformation > &warnings={})
Constructor.
virtual | operator std::string () const
ComponentType | GetComponentType () const
GetComponentType returns the type of the agent component sending the signal. More...
std::string | GetAgentComponentName () const
GetAgentComponentName returns the name of the agent component sending the signal. More...
ComponentState | GetCurrentState () const
GetCurrentState returns the current state of the agent component sending the signal. More...
std::vector< ComponentWarningInformation > | GetComponentWarnings () const
GetComponentWarning returns the warning from the agent component sending the signal, if one exists. More...

Private Attributes

const ComponentType | componentType
Type of the component.
const std::string | agentComponentName
Name of the component.
const ComponentState | currentState
Current component state.
const std::vector< ComponentWarningInformation > | warnings
Warning Information.

Member Function Documentation

virtual operator std::string ( ) const
inlinevirtual

Returns the content/payload of the signal as an std::string

Returns
Content/payload of the signal as an std::string
ComponentType GetComponentType ( ) const
inline

GetComponentType returns the type of the agent component sending the signal.

Returns
Type of the component
std::string GetAgentComponentName ( ) const
inline

GetAgentComponentName returns the name of the agent component sending the signal.

Returns
The name of the agent component sending the signal as a std::string
ComponentState GetCurrentState ( ) const
inline

GetCurrentState returns the current state of the agent component sending the signal.

Returns
The current state of the agent component sending the signal as a ComponentState
std::vector<ComponentWarningInformation> GetComponentWarnings ( ) const
inline

GetComponentWarning returns the warning from the agent component sending the signal, if one exists.

Returns
The warning information from the agent component sending the signal
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AgentNetwork Class Reference

Public Member Functions | Protected Member Functions | List of all members
AgentNetwork Class Reference

network of agents More...

Collaboration diagram for AgentNetwork:
[legend]

Public Member Functions

bool | AddAgent (int id, const AgentInterface *agent)
AddAgent Add agent to agent network: More...
void | Clear ()
Clear Clear map of agent network.
void | QueueAgentUpdate (std::function< void(double)> func, double val)
QueueAgentUpdate This function is used to store operations on the agents in a list. At the end of each time step all queued operations will be executed. More...
void | QueueAgentRemove (const AgentInterface *agent)
QueueAgentRemove. More...
void | SyncGlobalData ()
SyncGlobalData This function is called after each timestep and executes all update function and removes all agents in the remove list.
virtual const AgentInterface * | GetAgent (int id) const
GetAgent. More...
virtual const std::map< int, const AgentInterface * > & | GetAgents () const
GetAgents Retrieves all agents. More...
bool | AddAgent (int id, AgentInterface *agent)
AddAgent Add agent to agent network: More...
void | Clear ()
Clear Clear map of agent network.
void | QueueAgentUpdate (std::function< void()> func)
QueueAgentUpdate This function is used to store operations on the agents in a list. At the end of each time step all queued operations will be executed. More...
void | QueueAgentRemove (const AgentInterface *agent)
QueueAgentRemove. More...
void | RemoveAgent (const AgentInterface *agent)
void | PublishGlobalData (Publisher publish)
Publishes the general observations about current agents. More...
void | SyncGlobalData ()
SyncGlobalData This function is called after each timestep and executes all update function and removes all agents in the remove list.
AgentInterface * | GetAgent (int id) const
GetAgent. More...
virtual const std::map< int, AgentInterface * > & | GetAgents () const
GetAgents Retrieves all agents that currently exist. More...
virtual const std::list< const AgentInterface * > & | GetRemovedAgents () const
GetRemovedAgents Retrieves agents that were removed during the simulation run. More...
virtual const std::list< const AgentInterface * > | GetRemovedAgentsInPreviousTimestep ()
GetRemovedAgents Retrieves agents that were removed during the previous timestep and clears the list. More...

Protected Member Functions

void | Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)
void | Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)

Detailed Description

network of agents

This class stores all agents in a network. It is used to synchronize the update of all values of all agents.

Member Function Documentation

bool AddAgent | ( | int | id,
 |  | const AgentInterface * | agent
 | ) |  |

AddAgent Add agent to agent network:

Parameters
[in] | id | id of agent
[in] | agent | agent reference
Returns
true for success
void QueueAgentUpdate | ( | std::function< void(double)> | func,
 |  | double | val
 | ) |  |

QueueAgentUpdate This function is used to store operations on the agents in a list. At the end of each time step all queued operations will be executed.

Parameters
[in] | func | function which is to stored to be executed later
[in] | val | value for the function
void QueueAgentRemove ( const AgentInterface * agent )

QueueAgentRemove.

This function queues agents in a list that will be removed after a time step.

Parameters
agent agent which shall be removed
virtual const AgentInterface* GetAgent ( int id ) const
virtual

GetAgent.

Retrieves specific agent by id

Parameters
[in] id Agent id
Returns
Agent reference
virtual const std::map<int, const AgentInterface*>& GetAgents ( ) const
virtual

GetAgents Retrieves all agents.

Returns
Mapping of ids to agents
void Log | ( | CbkLogLevel | logLevel,
 |  | const char * | file,
 |  | int | line,
 |  | const std::string & | message
 | ) |  |
inlineprotected

Provides callback to LOG() macro

Parameters
[in] | logLevel | Importance of log
[in] | file | Name of file where log is called
[in] | line | Line within file where log is called
[in] | message | Message to log
bool AddAgent | ( | int | id,
 |  | AgentInterface * | agent
 | ) |  |

AddAgent Add agent to agent network:

Parameters
[in] | id | id of agent
[in] | agent | agent reference
Returns
true for success
void QueueAgentUpdate ( std::function< void()> func )

QueueAgentUpdate This function is used to store operations on the agents in a list. At the end of each time step all queued operations will be executed.

Parameters
[in] | func | function which is to stored to be executed later
[in] | val | value for the function
void QueueAgentRemove ( const AgentInterface * agent )

QueueAgentRemove.

This function queues agents in a list that will be removed during the next syncronization.

Parameters
agent agent which shall be removed
void RemoveAgent ( const AgentInterface * agent )

Removes an agent from the network

Parameters
agent agent which shall be removed
void PublishGlobalData ( Publisher publish )

Publishes the general observations about current agents.

Parameters
Publish call
AgentInterface* GetAgent ( int id ) const

GetAgent.

Retrieves specific agent by id

Parameters
[in] id Agent id
Returns
Agent reference
virtual const std::map<int, AgentInterface *>& GetAgents ( ) const
virtual

GetAgents Retrieves all agents that currently exist.

Returns
Mapping of ids to agents
virtual const std::list<const AgentInterface*>& GetRemovedAgents ( ) const
virtual

GetRemovedAgents Retrieves agents that were removed during the simulation run.

Returns
List of agent references
virtual const std::list<const AgentInterface*> GetRemovedAgentsInPreviousTimestep ( )
virtual

GetRemovedAgents Retrieves agents that were removed during the previous timestep and clears the list.

Returns
List of agent references
void Log | ( | CbkLogLevel | logLevel,
 |  | const char * | file,
 |  | int | line,
 |  | const std::string & | message
 | ) |  |
inlineprotected

Provides callback to LOG() macro

Parameters
[in] | logLevel | Importance of log
[in] | file | Name of file where log is called
[in] | line | Line within file where log is called
[in] | message | Message to log
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AgentSpawnItem Class Reference

List of all members
AgentSpawnItem Class Reference

Representation of an agent as defined in the run configuration. More...

Detailed Description

Representation of an agent as defined in the run configuration.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AgentUpdaterImplementation Class Reference

Public Member Functions | List of all members
AgentUpdaterImplementation Class Reference

The class which is responsible for updating the agent in each time step. More...

Inheritance diagram for AgentUpdaterImplementation:
[legend]
Collaboration diagram for AgentUpdaterImplementation:
[legend]

Public Member Functions

virtual void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
virtual void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
virtual void | Trigger (int time)
Process data within component. More...

Detailed Description

The class which is responsible for updating the agent in each time step.

Member Function Documentation

virtual void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
virtual void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update outputs.

Function is called by framework when this component has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
virtual void Trigger ( int time )
virtual

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component

Parameters
[in] time Current scheduling time
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Algorithm_FmuWrapper Class Reference

List of all members
Algorithm_FmuWrapper Class Reference
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AlgorithmAgentFollowingDriverModelImplementation Class Reference

Public Member Functions | Private Attributes | List of all members
AlgorithmAgentFollowingDriverModelImplementation Class Reference
Inheritance diagram for AlgorithmAgentFollowingDriverModelImplementation:
[legend]
Collaboration diagram for AlgorithmAgentFollowingDriverModelImplementation:
[legend]

Public Member Functions

AlgorithmAgentFollowingDriverModelImplementation (std::string componentName, bool isInit, int priority, int offsetTime, int responseTime, int cycleTime, StochasticsInterface *stochastics, WorldInterface *world, const ParameterInterface *parameters, PublisherInterface *const publisher, const CallbackInterface *callbacks, AgentInterface *agent)
Constructor. More...
void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
void | Trigger (int time)
Process data within component. More...

Private Attributes

ComponentState | componentState = ComponentState::Acting
component state for finely granulated evaluation of signal
const LateralDynamicConstants | lateralDynamicConstants
parameters for the lateral acceleration wish [m/s]
double | vWish = 120.0/3.6
desired speed
double | delta = 4.0
free acceleration exponent characterizing how the acceleration decreases with velocity (1: linear, infinity: constant)
double | tGapWish = 1.5
desired time gap between ego and front agent
double | minDistance = 2.0
minimum distance between ego and front (used at slow speeds) also called jam distance
double | maxAcceleration = 1.4
maximum acceleration in satisfactory way, not vehicle possible acceleration
double | decelerationWish = 2.0
desired deceleration
double | out_lateral_speed = 0
The lateral velocity of the current vehicle [m/s].
double | out_lateral_displacement = 0
The relative lateral position of the vehicle [m].
double | out_lateral_gain_displacement = 20.0
The gain for lateral displacement error controller [-].
double | out_lateral_damping = 0
The damping constant of the lateral oscillation of the vehicle [].
double | out_lateral_frequency = 0
The lateral oscillation frequency of the vehicle [1/s].
double | out_lateral_heading_error = 0
The heading angle error of the vehicle [rad].
double | out_lateral_gain_heading_error = 7.5
The gain for heading error controller [-].
double | out_curvature = 0
The curvature of the lane at vehicle's position [1/m].
double | out_laneWidth = 0
The width of the lane containing the vehicle [m].
double | out_longitudinal_acc = 0
The longitudinal acceleration of the vehicle [m/s^2].
int | out_indicatorState = static_cast<int>(IndicatorState::IndicatorState_Off)
The state of the turning indicator [-].
bool | out_hornSwitch = false
Activation of HornSwitch [-].
bool | out_headLight = false
Activation of Headlight [-].
bool | out_highBeamLight = false
Activation of Highbeam Light [-].
bool | out_flasher = false
Activation of Flasher [-].

Constructor & Destructor Documentation

AlgorithmAgentFollowingDriverModelImplementation | ( | std::string | componentName,
 |  | bool | isInit,
 |  | int | priority,
 |  | int | offsetTime,
 |  | int | responseTime,
 |  | int | cycleTime,
 |  | StochasticsInterface * | stochastics,
 |  | WorldInterface * | world,
 |  | const ParameterInterface * | parameters,
 |  | PublisherInterface *const | publisher,
 |  | const CallbackInterface * | callbacks,
 |  | AgentInterface * | agent
 | ) |  |

Constructor.

Parameters
[in] | componentId | Component ID
[in] | isInit | Component's init state
[in] | priority | Task priority level
[in] | offsetTime | Start time offset
[in] | responseTime | Update response time
[in] | cycleTime | Cycle time
[in] | stochastics | Stochastics instance
[in] | world | World interface
[in] | parameters | Paramaters
[in] | pubslisher | Publisher instance
[in] | callbacks | Callbacks
[in] | agent | Agent

Member Function Documentation

void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |

Update outputs.

Function is called by framework when this Component.has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
void Trigger ( int time )

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component

Parameters
[in] time Current scheduling time
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AlgorithmAutonomousEmergencyBrakingImplementation Class Reference

Public Member Functions | Private Member Functions | Private Attributes | List of all members
AlgorithmAutonomousEmergencyBrakingImplementation Class Reference
Inheritance diagram for AlgorithmAutonomousEmergencyBrakingImplementation:
[legend]
Collaboration diagram for AlgorithmAutonomousEmergencyBrakingImplementation:
[legend]

Public Member Functions

virtual void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
virtual void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
virtual void | Trigger (int time)
Process data within component. More...

Private Member Functions

void | ParseParameters (const ParameterInterface *parameters)
Reads the information of ttc, acceleration from the ParameterInterface and stores them in the stageParameters struct. More...
double | CalculateTTC ()
Calculates the minimim ttc (time to collision) of all objects the linked sensors have detected. More...
double | CalculateObjectTTC (const osi3::BaseMoving &baseMoving)
Calculates the ttc between a moving object and the own agent. More...
double | CalculateObjectTTC (const osi3::BaseStationary &baseStationary)
Calculates the ttc between a stationary object and the own agent. More...
bool | ShouldBeActivated (double ttc) const
ShouldBeActivated Determines if the Autonomous Emergency Braking system should be activated. More...
bool | ShouldBeDeactivated (double ttc) const
ShouldBeDeactivated Determines if the Autonomous Emergency Braking system should be deactivated. More...
void | UpdateAcceleration ()
Checks if current acceleration of the system needs to be updated. More...
void | SetAcceleration (double setValue)
Sets the current acceleration of the system.

Private Attributes

double | collisionDetectionLongitudinalBoundary {0.0}
!< Collection of sensor input ids
double | collisionDetectionLateralBoundary {0.0}
!< Additional length added to the vehicle boundary when checking for collision detection
std::vector< osi3::DetectedMovingObject > | detectedMovingObjects
!< Additional width added to the vehicle boundary when checking for collision detection
std::vector< osi3::DetectedStationaryObject > | detectedStationaryObjects
!< Collection of moving objects detected by connected sensors
ComponentState | componentState = ComponentState::Disabled
!< Collection of stationary objects detected by connected sensors
double | ttcBrake {0.0}
!< Current state of the AEB component
double | brakingAcceleration {0.0}
!< The minimum Time-To-Collision before the AEB component activates
double | activeAcceleration {0.0}
!< The acceleration provided by the AEB component when activated (should be negative)

Detailed Description

Member Function Documentation

virtual void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
virtual void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update outputs.

Function is called by framework when this Component.has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
virtual void Trigger ( int time )
virtual

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component.

Refer to module description for information about the module's task.

Parameters
[in] time Current scheduling time
void ParseParameters ( const ParameterInterface * parameters )
private

Reads the information of ttc, acceleration from the ParameterInterface and stores them in the stageParameters struct.

parameters ParameterInterface containing braking information

double CalculateTTC ( )
private

Calculates the minimim ttc (time to collision) of all objects the linked sensors have detected.

Returns
minimum ttc
double CalculateObjectTTC ( const osi3::BaseMoving & baseMoving )
private

Calculates the ttc between a moving object and the own agent.

Parameters
baseMoving osi BaseMoving of other object
Returns
ttc
double CalculateObjectTTC ( const osi3::BaseStationary & baseStationary )
private

Calculates the ttc between a stationary object and the own agent.

Parameters
baseStationary osi BaseStationary of other object
Returns
ttc
bool ShouldBeActivated ( double ttc ) const
private

ShouldBeActivated Determines if the Autonomous Emergency Braking system should be activated.

Parameters
[in] ttc the time to crash for which activation of the AEB is to be determined
Returns
true if AEB should be activated, false otherwise
bool ShouldBeDeactivated ( double ttc ) const
private

ShouldBeDeactivated Determines if the Autonomous Emergency Braking system should be deactivated.

Parameters
[in] ttc the time to crash for which deactivation of the AEB is to be determined
Returns
true if AEB should be deactivated, false otherwise
void UpdateAcceleration ( )
private

Checks if current acceleration of the system needs to be updated.

The acceleration is determined by the currently active stage.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AlgorithmFmuWrapperImplementation Class Reference

Private Member Functions | Private Attributes | List of all members
AlgorithmFmuWrapperImplementation Class Reference
Inheritance diagram for AlgorithmFmuWrapperImplementation:
[legend]
Collaboration diagram for AlgorithmFmuWrapperImplementation:
[legend]

Private Member Functions

void | SetupFilenames ()
Sets up filenames for FMU data output and logging.
void | SetupLog ()
Sets up FMU checker log output. More...
void | SetupOutput ()
Sets up FMU data log output. More...
void | SetupUnzip (const bool individualUnzip)
Sets up FMU unzipping paths and settings. More...
void | InitFmu ()
Initializes the FMU. More...
void | HandleFmiStatus (const jm_status_enu_t &fmiStatus, const std::string &logPrefix)
Calls a FMIL function and handles the return status. More...
FmuVariables | GetFmuVariables ()
Retrieve available variables from FMU.
VariableType | FmiTypeToCType (const fmi1_base_type_enu_t fmiType)
Converts the FMU variable type to a unique C++ type id. More...
VariableType | FmiTypeToCType (const fmi2_base_type_enu_t fmiType)
Converts the FMU variable type to a unique C++ type id. More...
void | MkDirOrThrowError (const boost::filesystem::path path)
Safely cretes a directory. More...

Private Attributes

struct fmu_check_data_t | cdata
check data to be passed around between the FMIL functions
int | startTime
Time of FMU start (simulation timebase)
const CallbackInterface * | callbacks
callback interface
std::string | folderUnzip
help for construction of unzip directory
std::string | FMU_name
name of FMU file
std::string | FMU_path
path of FMU file
std::string | FMU_fullName
name of FMU file including absolute path
std::string | logFileName
name of log file
std::string | outputFileName
name of output file
std::string | logFileFullName
name of log file including absolute path
std::string | outputFileFullName
name of output file including absolute path
std::string | agentIdString
agent identifier as string
FmuVariables | fmuVariables
Mapping from FMU variable name to it's FMI value reference and C++ type id. Provided to type-specific wrapper implementation on construction.
std::map< ValueReferenceAndType, FmuHandlerInterface::FmuValue > | fmuVariableValues
Mapping from FMI value reference and C++ type id to FmuWrapper value (union). Provided to type-specific wrapper implementation on construction.
bool isInitialized | false
Specifies, if the FMU has already be initialized.
FmuHandlerInterface * | fmuHandler = nullptr
Points to the instance of the FMU type-specific implementation.
std::string | fmuType
Type of the FMU.

Member Function Documentation

void SetupLog ( )
private

Sets up FMU checker log output.

Directory "Log" will be created beneath FMU path.

void SetupOutput ( )
private

Sets up FMU data log output.

Directory "Output" will be created beneath FMU path.

void SetupUnzip ( const bool individualUnzip )
private

Sets up FMU unzipping paths and settings.

Default is to have the fmu unzipped only once, but if the capability canBeInstantiatedOnlyOncePerProcess is set to true, then every agent needs an unzip folder on its own.

Parameters
[in] individualUnzip If false, unzip folder of existing FMU will be reused.
void InitFmu ( )
private

Initializes the FMU.

Calls the FMU checker which unzips and validates the FMU and parses the configuration of the FMU. The type of the FMU is detectd and stored for later use. After that an initializing simulation step is performed on the FMU.

Supported types of FMU are ACC and SWW

void HandleFmiStatus | ( | const jm_status_enu_t & | fmiStatus,
 |  | const std::string & | logPrefix
 | ) |  |
private

Calls a FMIL function and handles the return status.

Parameters
[in] | func | Function to call with cdata as argument
[in] | cdata | The FMIL cdata structure
[in] | logPrefix | Prefix to prepend to log messages
Note
Calls fmi1_end_handling with cdata as argument on FMI error.
VariableType FmiTypeToCType ( const fmi1_base_type_enu_t fmiType )
private

Converts the FMU variable type to a unique C++ type id.

Parameters
[in] fmiType FMILibrary specific type specifier
Returns
Hash code of the associated C++ type id
VariableType FmiTypeToCType ( const fmi2_base_type_enu_t fmiType )
private

Converts the FMU variable type to a unique C++ type id.

Parameters
[in] fmiType FMILibrary specific type specifier
Returns
Hash code of the associated C++ type id
void MkDirOrThrowError ( const boost::filesystem::path path )
private

Safely cretes a directory.

Create a directory with all missing directory along its path. Throws an error if the directory cannot be created for any reason.

Parameters
[in] path Path of directory to be created (relative or absolute)
Exceptions
std::runtime_error
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: AlgorithmLateralImplementation Class Reference

Public Member Functions | Protected Attributes | List of all members
AlgorithmLateralImplementation Class Reference

models the lateral controller of the driver More...

Inheritance diagram for AlgorithmLateralImplementation:
[legend]
Collaboration diagram for AlgorithmLateralImplementation:
[legend]

Public Member Functions

void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
void | Trigger (int time)
Process data within component. More...

Protected Attributes

double out_desiredSteeringWheelAngle {0}
The steering wheel angle wish of the driver in degree.

Detailed Description

models the lateral controller of the driver

This class models the lateral controller of the driver. It calculates a steering wheel angle wish of the driver that tries to diminish the lateral offset to the current or target lane in a lane change. This wish depends also on the intensity of a lane change.

Member Function Documentation

void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |

Update outputs.

Function is called by framework when this Component.has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
void Trigger ( int time )

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component

Parameters
[in] time Current scheduling time
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: BasicDataStoreImplementation Class Reference

Protected Attributes | List of all members
BasicDataStoreImplementation Class Reference

This class implements a basic version of a data store. More...

Inheritance diagram for BasicDataStoreImplementation:
[legend]
Collaboration diagram for BasicDataStoreImplementation:
[legend]

Protected Attributes

StaticStore | staticStore
Container for DataStore static values.
CyclicStore | cyclicStore
Container for DataStore cyclic values.
AcyclicStore | acyclicStore
Container for DataStore acyclic values.
StoreIndex< openpass::type::Timestamp > | timestampIndex
Index for timestamp based cyclics access.
StoreIndex< openpass::type::EntityId > | entityIdIndex
Index for entity id based cyclics access.
StoreIndex< openpass::type::Timestamp, openpass::type::EntityId > | timeAndEntityIdIndex
Index for (time, entity) based cyclics access.

Detailed Description

This class implements a basic version of a data store.

Data is stored in a simple mapping usign the timestamp and agent id as keys, values are stored as key/value pairs.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: BoolSignal Class Reference

Public Member Functions | Public Attributes | List of all members
BoolSignal Class Reference

Primitive signal class for boolean values. More...

Inheritance diagram for BoolSignal:
[legend]
Collaboration diagram for BoolSignal:
[legend]

Public Member Functions

virtual operator std::string () const
Converts signal to string.

Public Attributes

bool value
signal content

Detailed Description

Primitive signal class for boolean values.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: BorderPoint Struct Reference

List of all members
BorderPoint Struct Reference

This lane represents the outer boundary points of a lane at one s coordinate. More...

Collaboration diagram for BorderPoint:
[legend]

Detailed Description

This lane represents the outer boundary points of a lane at one s coordinate.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: BorderPoints Struct Reference

Public Member Functions | List of all members
BorderPoints Struct Reference

This struct represents the boundary points of all lanes (including lane 0) at one s coordinate (i.e. one joint) More...

Public Member Functions

double GetSquaredError (const BorderPoints &begin, const BorderPoints &end) const
Returns the highest squared lateral error of this joint to the line(s) defined by two other joints.

Detailed Description

This struct represents the boundary points of all lanes (including lane 0) at one s coordinate (i.e. one joint)

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: BoundingBoxCalculation Class Reference

Public Member Functions | Private Attributes | List of all members
BoundingBoxCalculation Class Reference

Public Member Functions

polygon_t | CalculateBoundingBox (double timeStepInSeconds, const osi3::BaseMoving &baseMoving)
Predicts the bounding box of a moving object in local coordinates. More...
polygon_t | CalculateBoundingBox (const osi3::BaseStationary &baseStationary)
Calculates the bounding box of a stationary object in local coordinates. More...
polygon_t | CalculateOwnBoundingBox (double timeStepInSeconds)
Predicts the bounding box of the own agent in local coordinates (coordinate system does not move along) More...

Private Attributes

double | collisionDetectionLongitudinalBoundary
!< The agent for which the boundingbox should be calculated
double | collisionDetectionLateralBoundary
!< Additional length added to the vehicle boundary when checking for collision detection

Detailed Description

Member Function Documentation

polygon_t CalculateBoundingBox | ( | double | timeStepInSeconds,
 |  | const osi3::BaseMoving & | baseMoving
 | ) |  |

Predicts the bounding box of a moving object in local coordinates.

Parameters
timeStepInSeconds | relative time since current timeStep
baseMoving | object to predict
Returns
predicted bounding box
polygon_t CalculateBoundingBox ( const osi3::BaseStationary & baseStationary )

Calculates the bounding box of a stationary object in local coordinates.

Parameters
baseMoving object to calculate
Returns
calculated bounding box
polygon_t CalculateOwnBoundingBox ( double timeStepInSeconds )

Predicts the bounding box of the own agent in local coordinates (coordinate system does not move along)

Parameters
timeStepInSeconds relative time since current timeStep
Returns
predicted bounding box
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: cmplx Struct Reference

List of all members
cmplx Struct Reference
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: cmplxl Struct Reference

List of all members
cmplxl Struct Reference
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CollisionAngles Struct Reference

Public Attributes | List of all members
CollisionAngles Struct Reference

Public Attributes

double | OYA = 0.0
opponent yaw angle
double | HCPAo = 0.0
original host collision point angle
double | OCPAo = 0.0
original opponent collision point angle
double | HCPA = 0.0
transformed host collision point angle
double | OCPA = 0.0
transformed opponent collision point angle

Detailed Description

For definitions see http://indexsmart.mirasmart.com/26esv/PDFfiles/26ESV-000177.pdf

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CommandLineArguments Struct Reference

List of all members
CommandLineArguments Struct Reference
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CommandLineOption Struct Reference

List of all members
CommandLineOption Struct Reference
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CommandLineParser Class Reference

List of all members
CommandLineParser Class Reference
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CompCtrlToAgentCompSignal Class Reference

Public Member Functions | Private Attributes | List of all members
CompCtrlToAgentCompSignal Class Reference

The CompCtrlToAgentCompSignal class facilitates communication with the agent component, defining the max reachable state of the component as well as the states of other components connected to the

ComponentController

More...

Inheritance diagram for CompCtrlToAgentCompSignal:
[legend]
Collaboration diagram for CompCtrlToAgentCompSignal:
[legend]

Public Member Functions

CompCtrlToAgentCompSignal (const ComponentState &maxReachableState, const std::map< std::string, std::pair< ComponentType, ComponentState >> &vehicleComponentStates)
Constructor.
virtual | operator std::string () const
ComponentState | GetMaxReachableState () const
GetMaxReachableState returns the max reachable state of the target component as defined by the ComponentController. More...
const std::map< std::string, std::pair< ComponentType, ComponentState > > & | GetVehicleComponentStates () const
GetVehicleComponentStates returns a map linking vehicle component names to types and states. More...

Private Attributes

const ComponentState | maxReachableState
Highest reachable state.
const std::map< std::string, std::pair< ComponentType, ComponentState > > | vehicleComponentStates
Current state of all components.

Detailed Description

The CompCtrlToAgentCompSignal class facilitates communication with the agent component, defining the max reachable state of the component as well as the states of other components connected to the

ComponentController

Member Function Documentation

virtual operator std::string ( ) const
inlinevirtual

Returns the content/payload of the signal as an std::string

Returns
Content/payload of the signal as an std::string
ComponentState GetMaxReachableState ( ) const
inline

GetMaxReachableState returns the max reachable state of the target component as defined by the ComponentController.

Returns
The max reachable state of the target component as defined by the ComponentController as a ComponentState
const std::map<std::string, std::pair<ComponentType, ComponentState> >& GetVehicleComponentStates ( ) const
inline

GetVehicleComponentStates returns a map linking vehicle component names to types and states.

Returns
A map of vehicle component names to pairs of types and states as std::map<std::string, std::pair<AdasType, ComponentState>>
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CompCtrlToDriverCompSignal Class Reference

Public Member Functions | Private Attributes | List of all members
CompCtrlToDriverCompSignal Class Reference

The CompCtrlToDriverCompSignal class facilitates communication with the driver component, allowing for warnings to be forwarded to the driver

alongside standard agent component information.

More...

Inheritance diagram for CompCtrlToDriverCompSignal:
[legend]
Collaboration diagram for CompCtrlToDriverCompSignal:
[legend]

Public Member Functions

CompCtrlToDriverCompSignal (const ComponentState &maxReachableState, const std::map< std::string, std::pair< ComponentType, ComponentState >> &vehicleComponentStates, const Warnings &warnings)
Constructor.
const Warnings & | GetWarnings () const
GetWarnings gets all warnings from the signal (if any exist), by component name. More...
- Public Member Functions inherited from CompCtrlToAgentCompSignal
CompCtrlToAgentCompSignal (const ComponentState &maxReachableState, const std::map< std::string, std::pair< ComponentType, ComponentState >> &vehicleComponentStates)
Constructor.
virtual | operator std::string () const
ComponentState | GetMaxReachableState () const
GetMaxReachableState returns the max reachable state of the target component as defined by the ComponentController. More...
const std::map< std::string, std::pair< ComponentType, ComponentState > > & | GetVehicleComponentStates () const
GetVehicleComponentStates returns a map linking vehicle component names to types and states. More...

Private Attributes

const Warnings warnings
Contains all warnings for the driver known by the ComponentController (if any exist) by component name.

Detailed Description

The CompCtrlToDriverCompSignal class facilitates communication with the driver component, allowing for warnings to be forwarded to the driver

alongside standard agent component information.

Member Function Documentation

const Warnings& GetWarnings ( ) const
inline

GetWarnings gets all warnings from the signal (if any exist), by component name.

Returns
all warnings for the driver known by the ComponentController (if any exist), by component name
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ComponentPort Class Reference

Public Member Functions | Private Attributes | List of all members
ComponentPort Class Reference

A Class to manage ports of a component. More...

Inheritance diagram for ComponentPort:
[legend]

Public Member Functions

ComponentPort (int id, std::map< int, ComponentPort * > *portMap)
virtual | ~ComponentPort ()=default
Destructor.
int | GetId ()
virtual bool | SetSignalValue (const std::shared_ptr< SignalInterface const > &data)
virtual bool | GetSignalValue (std::shared_ptr< SignalInterface const > &data)

Private Attributes

int id
id of component

Detailed Description

A Class to manage ports of a component.

Constructor & Destructor Documentation

ComponentPort | ( | int | id,
 |  | std::map< int, ComponentPort * > * | portMap
 | ) |  |
inline

Constructor

Parameters
[in] | id | Id of component
[in,out] | portMap | map of componentPort this componentPort shall be added

Member Function Documentation

int GetId ( )
inline

Retrieve the id of the component

Returns
id of component
virtual bool SetSignalValue ( const std::shared_ptr< SignalInterface const > & data )
inlinevirtual

Set the Signal

Parameters
[in] signal with data
Returns
virtual bool GetSignalValue ( std::shared_ptr< SignalInterface const > & data )
inlinevirtual

Retrieve the Signal

Parameters
[out] signal with data
Returns
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ComponentStateSignal Class Reference

Public Member Functions | List of all members
ComponentStateSignal Class Reference

Primitive signal class for componentState values. More...

Inheritance diagram for ComponentStateSignal:
[legend]
Collaboration diagram for ComponentStateSignal:
[legend]

Public Member Functions

virtual operator std::string () const
Converts signal to string.

Detailed Description

Primitive signal class for componentState values.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ConditionalEventDetector Class Reference

Private Member Functions | List of all members
ConditionalEventDetector Class Reference
Inheritance diagram for ConditionalEventDetector:
[legend]
Collaboration diagram for ConditionalEventDetector:
[legend]

Private Member Functions

void | TriggerEventInsertion (int time, const std::vector< const AgentInterface * > triggeringAgents)
TriggerEventInsertion inserts an event into the EventNetwork at the specified time. More...
bool | IsBelowMaximumNumberOfExecutions ()
IsBelowMaximumNumberOfExecutions determines if the EventDetector should still be allowed to execute. More...
std::vector< const AgentInterface * > | GetActors (const std::vector< const AgentInterface * > triggeringAgents={})
GetActors gets the actors to be targeted by the Events emitted by the EventDetector; this can either be those targeted as Actors in the openScenario file, or those specified as TriggeringEntities if TriggeringAgentsAsActors is set. More...
std::pair< bool, std::vector< const AgentInterface * > > | EvaluateConditions (const int time)
EvaluateConditionsAtTime evaluates all conditions for the specified time and returns triggering agents who meet all conditions. More...
auto | CheckCondition (const ConditionMetaInformation &cmi)
CheckCondition utilizes the overload pattern to build a variant visitor on the fly to appropriately evaluate whether a Condition is met. More...

Additional Inherited Members

- Public Member Functions inherited from EventDetectorCommonBase
virtual int | GetCycleTime () override
Returns the cycle time. More...
- Protected Member Functions inherited from EventDetectorCommonBase
void | Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)
Log Provides callback to LOG() macro. More...

Member Function Documentation

void TriggerEventInsertion | ( | int | time,
 |  | const std::vector< const AgentInterface * > | triggeringAgents
 | ) |  |
private

TriggerEventInsertion inserts an event into the EventNetwork at the specified time.

Parameters
[in] time The time at which to insert the event into the

EventNetwork.

bool IsBelowMaximumNumberOfExecutions ( )
private

IsBelowMaximumNumberOfExecutions determines if the EventDetector should still be allowed to execute.

Returns
true if the number of times the EventDetector is less than the

maximum number of executions specified for it; otherwise false

std::vector<const AgentInterface *> GetActors ( const std::vector< const AgentInterface * > triggeringAgents = {} )
private

GetActors gets the actors to be targeted by the Events emitted by the EventDetector; this can either be those targeted as Actors in the openScenario file, or those specified as TriggeringEntities if TriggeringAgentsAsActors is set.

Parameters
[in] triggeringAgents the collection of triggeringAgents as was specified in the TriggeringEntities section of the openScenario file
Returns
the collection of AgentInterfaces for the Actors to be targeted

by the Events emitted by the EventDetector

std::pair<bool, std::vector<const AgentInterface *> > EvaluateConditions ( const int time )
private

EvaluateConditionsAtTime evaluates all conditions for the specified time and returns triggering agents who meet all conditions.

Parameters
[in] time the time at which the conditions are being evaluated
Returns
<0> true if all conditions are met; false otherwise

<1> triggeringAgents who meet all conditions

auto CheckCondition ( const ConditionMetaInformation & cmi )
inlineprivate

CheckCondition utilizes the overload pattern to build a variant visitor on the fly to appropriately evaluate whether a Condition is met.

Parameters
[in] cmi meta-information related to evaluating a Condition variant

lambda function for evaluating a Condition variant

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ConditionCommonBase Class Reference

List of all members
ConditionCommonBase Class Reference
Inheritance diagram for ConditionCommonBase:
[legend]
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ConditionMetaInformation Struct Reference

List of all members
ConditionMetaInformation Struct Reference
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ConfigurationFiles Struct Reference

Public Attributes | List of all members
ConfigurationFiles Struct Reference

Public Attributes

const std::string | configurationDir
directory of the configuration files
const std::string | systemConfigBlueprintFile
absolute path of the systemConfigBlueprintFile
const std::string | slaveConfigFile
absolute path of the slaveConfigFile

Detailed Description

Container for configuration file related paths

See also
Directories
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Connection Class Reference

List of all members
Connection Class Reference
Inheritance diagram for Connection:
[legend]
Collaboration diagram for Connection:
[legend]
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CSVParser Class Reference

List of all members
CSVParser Class Reference
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CustomCommandFactory Class Reference

Static Public Member Functions | Static Private Member Functions | List of all members
CustomCommandFactory Class Referencefinal

Use this class as static auto registering factory for custom commands. More...

Static Public Member Functions

template<typename... Args>
static ManipulatorInterface * | Create (const std::string &command, Args...args)
Create registered class from command. More...
template<typename T >
static bool | Register (const std::string command)
Register a type T for a given command. More...

Static Private Member Functions

static std::map< std::string, CreateSignature > & repository ()
Gets the static repository of registered classes. More...

Detailed Description

Use this class as static auto registering factory for custom commands.

Note that registration happens automatically without additional construction code, when the register method is used in a static assignment. This means that registering will be done if the translation unit holds an according statement (!)

Example: SomeClass.h -> static inline bool registered = CustomCommandFactory::Register("myCommand"); SomeClass.cpp is part of the translation unit

Effect: SomeOtherFile.cpp -> CustomCommandFactory::Create("myCommand", ...); // Args must be delivered

Member Function Documentation

static ManipulatorInterface* Create | ( | const std::string & | command,
 |  | Args... | args
 | ) |  |
inlinestatic

Create registered class from command.

Parameters
command | The command, used during Register
args | Arguments of the underlying class
Returns
The created instance

Here is the call graph for this function:

static bool Register ( const std::string command )
inlinestatic

Register a type T for a given command.

Returns
True if command could been registered

Here is the call graph for this function:

static std::map<std::string, CreateSignature>& repository ( )
inlinestaticprivate

Gets the static repository of registered classes.

As the method register is also static, it's not sure, that repository would be initialized before (issue with static initialization order). The is solved by wrapping the static repository in a static method, as it is guaranteed, that static variables in static methods are initialized first.

Returns
The repository

Here is the caller graph for this function:

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CyclicResult Class Reference

Private Attributes | List of all members
CyclicResult Class Reference
Inheritance diagram for CyclicResult:
[legend]
Collaboration diagram for CyclicResult:
[legend]

Private Attributes

const CyclicStore & | store
Reference to the cyclic datastore associated with the result set.
const CyclicRowRefs | elements
The result set (referencing elements in a datastore)
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: DefaultComponents Struct Reference

List of all members
DefaultComponents Struct Reference

Defines the default components that all agents need. More...

Detailed Description

Defines the default components that all agents need.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: DoubleSignal Class Reference

Public Member Functions | Public Attributes | List of all members
DoubleSignal Class Reference

Primitive signal class for double values. More...

Inheritance diagram for DoubleSignal:
[legend]
Collaboration diagram for DoubleSignal:
[legend]

Public Member Functions

virtual operator std::string () const
Converts signal to string.

Public Attributes

double value
signal content

Detailed Description

Primitive signal class for double values.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: DynamicAgentTypeGenerator Class Reference

Public Member Functions | List of all members
DynamicAgentTypeGenerator Class Reference

The DynamicAgentTypeGenerator class is used to build the AgentBuildInformation struct in particular the AgentType. More...

Collaboration diagram for DynamicAgentTypeGenerator:
[legend]

Public Member Functions

operator AgentBuildInformation && ()
Returns the generated AgentBuildInformation;.
DynamicAgentTypeGenerator & GatherBasicComponents ()
Creates a new ComponentType for all basic components defined in DefaultComponents.basicComponents and stores them in the AgentType. Also collects there output channels. More...
DynamicAgentTypeGenerator & GatherDriverComponents ()
Creates a new ComponentType for all default driver components defined in DefaultComponents.basicComponents, the ParametersAgents and the driver module itself and stores them in the AgentType. Also collects there output channels. More...
DynamicAgentTypeGenerator & GatherVehicleComponents ()
Creates a new ComponentType for all default vehicle components defined in DefaultComponents.basicComponents and the sampled vehicle components module and stores them in the AgentType. Also collects there output channels. More...
DynamicAgentTypeGenerator & GatherSensors ()
Creates a new ComponentType for all sensor defined by the VehicleModel and the SensorFusion module if needed and stores them in the AgentType. Also collects there output channels. More...
DynamicAgentTypeGenerator & | SetVehicleModelParameters (const openScenario::Parameters &assignedParameters)
Sets the VehicleModelParameters in the AgentBuildInformation depending on the vehicle model name. More...
void | GatherComponent (const std::string componentName, std::shared_ptr< SimulationSlave::AgentType > agentType)
Gathers a component and adds it to the AgentType. More...
void | GatherComponentWithParameters (std::string componentName, std::shared_ptr< SimulationSlave::AgentType > agentType, const openpass::parameter::ParameterSetLevel1 &parameters)
Gathers a component with specified parameter set and adds it to the AgentType. More...
void | GatherComponentWithParameters (std::string componentName, std::shared_ptr< SimulationSlave::AgentType > agentType, const openpass::parameter::ParameterSetLevel1 &parameters, std::string componentNameInSystemConfigBlueprint, int channelOffset)
Gathers a component and adds it to the AgentType. More...
double | SampleSensorLatency (std::shared_ptr< ParameterInterface > curParameters)
Samples the latency of a sensor. More...

Detailed Description

The DynamicAgentTypeGenerator class is used to build the AgentBuildInformation struct in particular the AgentType.

This class is responsible for generating the AgentType for building an agent in the AgentFactory in the case of a dynamic AgentProfile. This AgentType contains the Driver, all Sensors and VehicleComponents that are definied by the sampled profiles as well as the defaultComponents, that are always needed. The DynamicAgentTypeGenerator also stores the information about the channels between these components in the AgentType.

Member Function Documentation

DynamicAgentTypeGenerator& GatherBasicComponents ( )

Creates a new ComponentType for all basic components defined in DefaultComponents.basicComponents and stores them in the AgentType. Also collects there output channels.

Returns
reference to itself
DynamicAgentTypeGenerator& GatherDriverComponents ( )

Creates a new ComponentType for all default driver components defined in DefaultComponents.basicComponents, the ParametersAgents and the driver module itself and stores them in the AgentType. Also collects there output channels.

Returns
reference to itself
DynamicAgentTypeGenerator& GatherVehicleComponents ( )

Creates a new ComponentType for all default vehicle components defined in DefaultComponents.basicComponents and the sampled vehicle components module and stores them in the AgentType. Also collects there output channels.

Returns
reference to itself
DynamicAgentTypeGenerator& GatherSensors ( )

Creates a new ComponentType for all sensor defined by the VehicleModel and the SensorFusion module if needed and stores them in the AgentType. Also collects there output channels.

Returns
reference to itself
DynamicAgentTypeGenerator& SetVehicleModelParameters ( const openScenario::Parameters & assignedParameters )

Sets the VehicleModelParameters in the AgentBuildInformation depending on the vehicle model name.

Returns
reference to itself
void GatherComponent | ( | const std::string | componentName,
 |  | std::shared_ptr< SimulationSlave::AgentType > | agentType
 | ) |  |

Gathers a component and adds it to the AgentType.

Retrieves the information of a component from the app config and adds the ComponentType to the AgentType. The parameter set is read from the app config specified by the parameter set name

Parameters
[in] | componentName | Name of the component
[out] | agentType | AgentType where the results get stored
void GatherComponentWithParameters | ( | std::string | componentName,
 |  | std::shared_ptr< SimulationSlave::AgentType > | agentType,
 |  | const openpass::parameter::ParameterSetLevel1 & | parameters
 | ) |  |

Gathers a component with specified parameter set and adds it to the AgentType.

Retrieves the information of a component from the app config and adds the ComponentType to the AgentType. The parameter set is explictly specified.

Parameters
[in] | componentName | Name of the component
[out] | agentType | AgentType where the results get stored
[in] | parameters | Parameters set.
void GatherComponentWithParameters | ( | std::string | componentName,
 |  | std::shared_ptr< SimulationSlave::AgentType > | agentType,
 |  | const openpass::parameter::ParameterSetLevel1 & | parameters,
 |  | std::string | componentNameInSystemConfigBlueprint,
 |  | int | channelOffset
 | ) |  |

Gathers a component and adds it to the AgentType.

Retrieves the information of a component from the app config and adds the ComponentType to the AgentType. The parameter set is explictly specified.

Parameters
[in] | componentName | Name of the component
[out] | agentType | AgentType where the results get stored
[in] | parameters | Parameters set.
[in] | componentNameInSystemConfigBlueprint | Name of the component in the app config, different if different from componentName (currently used for sensors)
[in] | channelIncrease | Increase in the ids of the output channels (currently used for sensors)
double SampleSensorLatency ( std::shared_ptr< ParameterInterface > curParameters )

Samples the latency of a sensor.

Samples the latency of a sensor based on the parameters provided.

Parameters
[in] curParameters Parameter interface containing the mean value, standard deviation, minimum and maximum
Returns
latency in s
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: DynamicParameters Struct Reference

List of all members
DynamicParameters Struct Reference
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: DynamicParameterSampler Class Reference

List of all members
DynamicParameterSampler Class Reference
Collaboration diagram for DynamicParameterSampler:
[legend]
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: DynamicProfileSampler Class Reference

Public Member Functions | List of all members
DynamicProfileSampler Class Reference

The DynamicProfileSampler class is responsible for sampling all profile names (except AgentProfile which is sampled by the AgentProfilesSampler) More...

Collaboration diagram for DynamicProfileSampler:
[legend]

Public Member Functions

DynamicProfileSampler & SampleDriverProfile ()
Samples the driver profile name based on the agent profile name. More...
DynamicProfileSampler & SampleVehicleProfile ()
Samples the vehicle profile name based on the agent profile name. More...
DynamicProfileSampler & SampleVehicleComponentProfiles ()
Samples all vehicle component profile names based on the vehicle profile name. Therefore SampleVehicleProfile has to be called before this method. More...
operator SampledProfiles && ()
Returns the generated SampledProfiles struct.

Detailed Description

The DynamicProfileSampler class is responsible for sampling all profile names (except AgentProfile which is sampled by the AgentProfilesSampler)

Member Function Documentation

DynamicProfileSampler& SampleDriverProfile ( )

Samples the driver profile name based on the agent profile name.

Returns
reference to itself
DynamicProfileSampler& SampleVehicleProfile ( )

Samples the vehicle profile name based on the agent profile name.

Returns
reference to itself
DynamicProfileSampler& SampleVehicleComponentProfiles ( )

Samples all vehicle component profile names based on the vehicle profile name. Therefore SampleVehicleProfile has to be called before this method.

Returns
reference to itself
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: DynamicsCollisionImplementation Class Reference

Public Member Functions | List of all members
DynamicsCollisionImplementation Class Reference
Inheritance diagram for DynamicsCollisionImplementation:
[legend]
Collaboration diagram for DynamicsCollisionImplementation:
[legend]

Public Member Functions

virtual void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
virtual void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
virtual void | Trigger (int time)
Process data within component. More...

Member Function Documentation

virtual void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
virtual void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update outputs.

Function is called by framework when this component has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
virtual void Trigger ( int time )
virtual

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component

Parameters
[in] time Current scheduling time
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: DynamicsSignal Class Reference

Public Member Functions | List of all members
DynamicsSignal Class Reference

Signal class. More...

Inheritance diagram for DynamicsSignal:
[legend]
Collaboration diagram for DynamicsSignal:
[legend]

Public Member Functions

virtual operator std::string () const

Detailed Description

Signal class.

Member Function Documentation

virtual operator std::string ( ) const
inlinevirtual

Returns the content/payload of the signal as an std::string

Returns
Content/payload of the signal as an std::string
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: EgoAgent Class Reference

List of all members
EgoAgent Class Reference
Inheritance diagram for EgoAgent:
[legend]
Collaboration diagram for EgoAgent:
[legend]
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: externalParameter< ValueType > Class Template Reference

Public Member Functions | Private Attributes | List of all members
externalParameter< ValueType > Class Template Reference
Collaboration diagram for externalParameter< ValueType >:
[legend]

Public Member Functions

externalParameter (int id, std::map< int, externalParameter< ValueType > * > *externalParameterMap)
virtual | ~externalParameter ()=default
Destructor.
int | GetId ()
ValueType | GetValue ()
void | SetValue (ValueType value)

Private Attributes

int | id
id of parameter
ValueType | value
value of parameter

Detailed Description

template<typename ValueType>
class externalParameter< ValueType >

A Template Class to manage external parameter of component

Constructor & Destructor Documentation

externalParameter | ( | int | id,
 |  | std::map< int, externalParameter< ValueType > * > * | externalParameterMap
 | ) |  |
inline

Constructor

Parameters
[in] | id | Id of externalParameter
[in,out] | portMap | map of externalParameter this externalParameter shall be added

Member Function Documentation

int GetId ( )
inline

Retrieve the id of the parameter

Returns
id
ValueType GetValue ( )
inline

Retrieve the value of the parameter

Returns
value
void SetValue ( ValueType value )
inline

Set the value of the parameter

Parameters
[in] value to be set
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: FakeLaneManager Struct Reference

List of all members
FakeLaneManager Struct Reference
Collaboration diagram for FakeLaneManager:
[legend]
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: fmi1_csv_input_t Struct Reference

Public Attributes | List of all members
fmi1_csv_input_t Struct Reference

Public Attributes

fmi1_import_t * | fmu
double | interpTime
size_t | discreteIndex
size_t | interpIndex1
size_t | interpIndex2
double | interpLambda
fmi1_real_t * | interpData
fmi1_real_t * | interpContinuousData
size_t | eventIndex1
size_t | eventIndex2

Detailed Description

Structure incapsulating information on input data

Member Data Documentation

fmi1_import_t* fmu

FMI1 main struct

double interpTime

interpolation data for doubles.

size_t discreteIndex

time instance where the coeff is calculated

size_t interpIndex1

current data element index for discrete inputs

size_t interpIndex2

first data element index for interpolation

double interpLambda

second data element index for interpolation

fmi1_real_t* interpData

interpolation coefficient

fmi1_real_t* interpContinuousData

interpolated inputs

size_t eventIndex1

interpolated continuous inputs

size_t eventIndex2

first data element index for interpolation

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: fmi2_csv_input_t Struct Reference

Public Attributes | List of all members
fmi2_csv_input_t Struct Reference

Public Attributes

fmi2_import_t * | fmu
double | interpTime
size_t | discreteIndex
size_t | interpIndex1
size_t | interpIndex2
double | interpLambda
fmi2_real_t * | interpData
size_t | eventIndex1
size_t | eventIndex2

Detailed Description

Structure incapsulating information on input data

Member Data Documentation

fmi2_import_t* fmu

FMI2 main struct

double interpTime

interpolation data for doubles.

size_t discreteIndex

time instance where the coeff is calculated

size_t interpIndex1

current data element index for discrete inputs

size_t interpIndex2

first data element index for interpolation

double interpLambda

second data element index for interpolation

fmi2_real_t* interpData

interpolation coefficient

size_t eventIndex1

interpolated inputs

size_t eventIndex2

first data element index for interpolation

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: fmu_check_data_t Struct Reference

Public Attributes | List of all members
fmu_check_data_t Struct Reference

Public Attributes

const char * | FMUPath
char * | tmpPath
char | unzipPathBuf [10000]
const char * | temp_dir
unsigned int | num_warnings
unsigned int | num_errors
unsigned int | num_fatal
unsigned int | num_fmu_messages
int | printed_instance_name_error_flg
jm_callbacks | callbacks
fmi_import_context_t * | context
const char * | modelIdentifierFMI1
double | stopTime
double | stepSize
int | stepSizeSetByUser
size_t | maxOutputPts
int | maxOutputPtsSetByUser
double | nextOutputTime
double | nextOutputStep
char | CSV_separator
int | write_output_files
Flag activates generation of Output files when 1. More...
const char * | output_file_name
FILE * | out_file
int | write_log_files
Flag activates generation of log files when 1.
const char * | log_file_name
FILE * | log_file
char * | inputFileName
int | do_simulate_flg
int | do_test_me
int | do_test_cs
int | require_me
int | require_cs
int | do_mangle_var_names
int | do_output_all_vars
int | print_all_event_vars
fmi_version_enu_t | version
fmi1_import_t * | fmu1
fmi1_fmu_kind_enu_t | fmu1_kind
fmi1_import_variable_list_t * | vl
fmi2_import_t * | fmu2
fmi2_fmu_kind_enu_t | fmu2_kind
fmi2_import_variable_list_t * | vl2
int | slave_initialized
Flag indicating slave was initialized.

Detailed Description

Checker data structure is used to pass information between different routines

Member Data Documentation

const char* FMUPath

FMU file

char* tmpPath

Temporary directory with unique name where FMU is unpacked

char unzipPathBuf[10000]

Same as tmpPath unless specified by an option

const char* temp_dir

Directory to be used for temporary files. Either user specified or system-wide

unsigned int num_warnings

Counter for the warnings

unsigned int num_errors

counter for the non-fatal errors

unsigned int num_fatal

counter for the non-fatal errors

unsigned int num_fmu_messages

counter for the non-info messages from FMU

int printed_instance_name_error_flg

A flag that makes instance name error appear only once

jm_callbacks callbacks

FMIL callbacks

fmi_import_context_t* context

FMIL context

const char* modelIdentifierFMI1

Model information

double stopTime

Simulation stop time

double stepSize

Step size for the simulation

int stepSizeSetByUser

Flag indicating if step size is user defined in command line

size_t maxOutputPts

Maximum number of steps to save to output

int maxOutputPtsSetByUser

Flag indicating if max number of steps is user defined in command line

double nextOutputTime

Next output time

double nextOutputStep

Next output step number

char CSV_separator

separator character to use

int write_output_files

Flag activates generation of Output files when 1.

this feature is currently off

const char* output_file_name

Name of the output file (NULL is stdout)

FILE* out_file

Output file stream

const char* log_file_name

Name of the log file (NULL is stderr)

FILE* log_file

Log file stream

char* inputFileName

input data file name

int do_simulate_flg

Should simulation be done (or only XML checking)

int do_test_me

Should we simulate ME if available?

int do_test_cs

Should we simulate CS if available?

int require_me

Should we require ME to be available?

int require_cs

Should we require CS to be available?

int do_mangle_var_names

should variable names be mangled to avoid quoting (-m switch)

int do_output_all_vars

should all variables be printed (-f switch)

int print_all_event_vars

should variables be printed before event handling (-d switch)

fmi_version_enu_t version

FMI standard version of the FMU

fmi1_import_t* fmu1

FMI1 main struct

fmi1_fmu_kind_enu_t fmu1_kind

Kind of the FMI

fmi1_import_variable_list_t* vl

model variables

fmi2_import_t* fmu2

FMI2 main struct

fmi2_fmu_kind_enu_t fmu2_kind

Kind of the FMI

fmi2_import_variable_list_t* vl2

model variables

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: FrameworkModules Struct Reference

List of all members
FrameworkModules Struct Reference
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: GeometryInformation Struct Reference

Public Attributes | List of all members
GeometryInformation Struct Reference

This struct contains infrastructure information of surrounding lanes that describe its geometric features. More...

Collaboration diagram for GeometryInformation:
[legend]

Public Attributes

double visibilityDistance {-999.0}
Current maximum visibility distance as specified by the world.
LaneInformationGeometry laneLeft
Data about the lane to left (in driving direction) of the mainLane.
LaneInformationGeometry laneEgo
Data about the lane the where the middle of the front of the agent is (i.e. mainLane)
LaneInformationGeometry laneRight
Data about the lane to right (in driving direction) of the mainLane.

Detailed Description

This struct contains infrastructure information of surrounding lanes that describe its geometric features.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: GlobalRoadPosition Struct Reference

List of all members
GlobalRoadPosition Struct Reference

Position of a point in the road network. More...

Collaboration diagram for GlobalRoadPosition:
[legend]

Detailed Description

Position of a point in the road network.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: InputPort< SignalType, ValueType > Class Template Reference

Public Member Functions | Private Attributes | List of all members
InputPort< SignalType, ValueType > Class Template Reference
Inheritance diagram for InputPort< SignalType, ValueType >:
[legend]
Collaboration diagram for InputPort< SignalType, ValueType >:
[legend]

Public Member Functions

InputPort (int id, std::map< int, ComponentPort * > *portMap)
virtual | ~InputPort ()=default
Destructor.
ValueType | GetValue ()
- Public Member Functions inherited from ComponentPort
ComponentPort (int id, std::map< int, ComponentPort * > *portMap)
virtual | ~ComponentPort ()=default
Destructor.
int | GetId ()
virtual bool | GetSignalValue (std::shared_ptr< SignalInterface const > &data)

Private Attributes

ValueType value
current value of input port

Detailed Description

template<typename SignalType, typename ValueType>
class InputPort< SignalType, ValueType >

A Template Class to manage input ports.

Constructor & Destructor Documentation

InputPort | ( | int | id,
 |  | std::map< int, ComponentPort * > * | portMap
 | ) |  |
inline

Constructor

Parameters
[in] | id | Id of input port
[in,out] | portMap | map of input port this input port shall be added

Member Function Documentation

ValueType GetValue ( )
inline

Retrieve the current value of the input port

Returns
value of input port
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: IntersectingConnection Struct Reference

List of all members
IntersectingConnection Struct Reference

Information regarding a connecting road intersecting another. More...

Detailed Description

Information regarding a connecting road intersecting another.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: IntSignal Class Reference

Public Member Functions | Public Attributes | List of all members
IntSignal Class Reference

Primitive signal class for integer values. More...

Inheritance diagram for IntSignal:
[legend]
Collaboration diagram for IntSignal:
[legend]

Public Member Functions

virtual operator std::string () const
Converts signal to string.

Public Attributes

int value
signal content

Detailed Description

Primitive signal class for integer values.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Joint Struct Reference

List of all members
Joint Struct Reference

This struct contains all information calculated by the JointBuilder for one joint. More...

Detailed Description

This struct contains all information calculated by the JointBuilder for one joint.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: JointsBuilder Class Reference

Public Member Functions | Private Attributes | List of all members
JointsBuilder Class Reference
Collaboration diagram for JointsBuilder:
[legend]

Public Member Functions

JointsBuilder (const SampledGeometry &sampledGeometry, const Joints &joints)
For testing only.
JointsBuilder & CalculatePoints ()
Calculates the left, center and right points of each lane.
JointsBuilder & CalculateHeadings ()
Calculates the headings by interpolating between the center points.
JointsBuilder & CalculateCurvatures ()
Calculates the curvatures from the heading changes.
Joints & GetJoints ()
Returns the calculated joints.

Private Attributes

Joints joints
input of the JointBuilder

Detailed Description

This class gets the sampled lane boundary points as input and calculates all the other information about the joints, that is needed for adding the joints to the WorldData. The functions have to be called in the order they appear in this header.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Junction Class Reference

List of all members
Junction Class Reference
Inheritance diagram for Junction:
[legend]
Collaboration diagram for Junction:
[legend]
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: JunctionConnection Struct Reference

List of all members
JunctionConnection Struct Reference
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: JunctionConnectorPriority Struct Reference

List of all members
JunctionConnectorPriority Struct Reference
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneGeometryPolygon Struct Reference

List of all members
LaneGeometryPolygon Struct Reference
Collaboration diagram for LaneGeometryPolygon:
[legend]
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneInformationGeometry Struct Reference

Public Attributes | List of all members
LaneInformationGeometry Struct Reference

This struct is used to transport data of a lane concerning its geometric features as seen by the driver. More...

Public Attributes

bool | exists {false}
Wether there is a lane on this position.
double | curvature {-999.0}
Curvature at current s position (default if not existing)
double | width {-999.0}
Width at current s position (default if not existing)
double | distanceToEndOfLane {-999.0}
Distance from current position to the end of the lane or infinity if the end is farther away than the visibility distance.

Detailed Description

This struct is used to transport data of a lane concerning its geometric features as seen by the driver.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneInformationTrafficRules Struct Reference

Public Attributes | List of all members
LaneInformationTrafficRules Struct Reference

This struct is used to trasport data of a lane concerning traffic rules as seen by the driver. More...

Public Attributes

std::vector< CommonTrafficSign::Entity > trafficSigns
Vector of all traffic signs valid for this lane inside the visibility distance.

Detailed Description

This struct is used to trasport data of a lane concerning traffic rules as seen by the driver.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LaneJoint Struct Reference

List of all members
LaneJoint Struct Reference

This struct contains all information calculated by the JointBuilder for one joint and one lane. More...

Collaboration diagram for LaneJoint:
[legend]

Detailed Description

This struct contains all information calculated by the JointBuilder for one joint and one lane.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LateralDynamicConstants Struct Reference

Public Attributes | List of all members
LateralDynamicConstants Struct Reference

Calulaction parameters for the lateral acceleration wish [m/s]. More...

Public Attributes

const double | lateralAcceleration = 1.5
Typical acceleration for a lane change [m/s].
const double | zeta = 1.0
Typical lateral damping for a lane change [m/s].
const double | gainHeadingError = 7.5
aggressiveness of the controller for heading errors

Detailed Description

Calulaction parameters for the lateral acceleration wish [m/s].

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LateralSignal Class Reference

Public Member Functions | List of all members
LateralSignal Class Reference
Inheritance diagram for LateralSignal:
[legend]
Collaboration diagram for LateralSignal:
[legend]

Public Member Functions

LateralSignal ()
Constructor.
LateralSignal (ComponentState componentState, double laneWidth, double lateralDeviation, double gainLateralDeviation, double headingError, double gainHeadingError, double kappaManoeuvre, double kappaRoad, std::vector< double > curvatureOfSegmentsToNearPoint, std::vector< double > curvatureOfSegmentsToFarPoint)
Constructor.
virtual operator std::string () const
LateralSignal (LateralSignal &other)
Constructor.
LateralSignal (ComponentState componentState, double laneWidth, double lateralDeviation, double gainLateralDeviation, double headingError, double gainHeadingError, double kappaManoeuvre)
Constructor.

Member Function Documentation

virtual operator std::string ( ) const
inlinevirtual

Returns the content/payload of the signal as an std::string

Returns
Content/payload of the signal as an std::string
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LimiterAccelerationVehicleComponentsImplementation Class Reference

Public Member Functions | List of all members
LimiterAccelerationVehicleComponentsImplementation Class Reference

This class implements the set limit. More...

Inheritance diagram for LimiterAccelerationVehicleComponentsImplementation:
[legend]
Collaboration diagram for LimiterAccelerationVehicleComponentsImplementation:
[legend]

Public Member Functions

virtual void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
virtual void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
virtual void | Trigger (int time)
Process data within component. More...

Detailed Description

This class implements the set limit.

Member Function Documentation

virtual void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
virtual void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |
virtual

Update outputs.

Function is called by framework when this component has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
virtual void Trigger ( int time )
virtual

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component

Parameters
[in] time Current scheduling time
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Log< T > Class Template Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | Static Private Attributes | List of all members
Log< T > Class Template Reference

Coordinates logging. More...

Public Member Functions

std::ostringstream & Get (const char *file, int line, LogLevel level=LogLevel::Warning)

Static Public Member Functions

static LogLevel & | ReportingLevel ()
static std::string | ToString (LogLevel level)

Protected Attributes

std::ostringstream os
output stream of current log session

Static Private Attributes

static QMutex logGuard
protects output stream from concurrent access

Detailed Description

template<typename T>
class Log< T >

Coordinates logging.

Member Function Documentation

std::ostringstream & Get | ( | const char * | file,
 |  | int | line,
 |  | LogLevel | level = LogLevel::Warning
 | ) |  |

Retrieves output stream.

Additional diagnostic information might be logged dependent on severity of log.

Parameters
[in] | file | File name where log is issued
[in] | line | Line number where log is issued
[in] | level | Severity of log.
Returns
Output stream for the log message
LogLevel & ReportingLevel ( )
static

Retrieves current severity limit.

Only log messages with a severity smaller or equal than this level will be printed.

Returns
Current severity limit
std::string ToString ( LogLevel level )
static

Converts severity value to a string for printing purposes.

Parameters
[in] level Severity level
Returns
Converted severity level
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LogOutputPolicy Class Reference

Static Public Member Functions | List of all members
LogOutputPolicy Class Reference

Handles access of file. More...

Static Public Member Functions

static void | SetFile (const std::string &fileName)
static bool | IsOpen ()
static void | Output (const std::string &message)

Detailed Description

Handles access of file.

Member Function Documentation

void SetFile ( const std::string & fileName )
inlinestatic

Initializes output file.

Parameters
[in] fileName Name of file where logs are stored
bool IsOpen ( )
inlinestatic

Verifies if output file has already been opened.

Returns
True if file is open
void Output ( const std::string & message )
inlinestatic

Logs message into file and standard output.

Parameters
[in] message Message to be logged.
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LongitudinalDistance Struct Reference

Public Attributes | List of all members
LongitudinalDistance Struct Reference

Longitudinal distance (i.e. along s) between two objects on the same road. More...

Public Attributes

std::optional< double > referencePoint
distance between boundaries

Detailed Description

Longitudinal distance (i.e. along s) between two objects on the same road.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: LongitudinalSignal Class Reference

Public Member Functions | List of all members
LongitudinalSignal Class Reference
Inheritance diagram for LongitudinalSignal:
[legend]
Collaboration diagram for LongitudinalSignal:
[legend]

Public Member Functions

virtual operator std::string () const

Member Function Documentation

virtual operator std::string ( ) const
inlinevirtual

Returns the content/payload of the signal as an std::string

Returns
Content/payload of the signal as an std::string
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: MultiStream< T > Class Template Reference

Classes | List of all members
MultiStream< T > Class Template Reference
Collaboration diagram for MultiStream< T >:
[legend]

Classes

struct Node

Detailed Description

template<typename T>
class MultiStream< T >

This class represent a directed tree of elements. It is used by various queries to search along consecutive elements within a range starting at some start point The elements supported by this class are: OWL::Lane* OWL::Road*

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: MultiStream< T >::Node Struct Reference

  • MultiStream
  • Node
List of all members
MultiStream< T >::Node Struct Reference
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ObjectInformation Struct Reference

Public Attributes | List of all members
ObjectInformation Struct Reference

This struct is used to transport data of an object as seen be the driver. More...

Public Attributes

int | id {-1}
Id of the object (default if not existing)
bool | exist {false}
false if there is no object in this position
bool | isStatic {false}
true if stationary object, false if agent
double | absoluteVelocity {-999.0}
Absolute velocity of the agent (default if object is not an agent)
double | acceleration {-999.0}
Acceleration of the agent (default if object is not an agent)
double | heading {-999.0}
Heading relative to the street (default if not existing)
double | length {-999.0}
Length of object (default if not existing)
double | width {-999.0}
Width of object (default if not existing)
double | height {-999.0}
Height of object (default if not existing)
double | relativeLongitudinalDistance {-999.0}
Relative distance along the road (i.e in direction s) between own agent and object (default if not existing)
double | relativeLateralDistance {-999.0}
Relative distance at right angle to the road (i.e. in direction t) between own agent and object (default if not existing)

Detailed Description

This struct is used to transport data of an object as seen be the driver.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ObjectPosition Struct Reference

Public Attributes | List of all members
ObjectPosition Struct Reference

Position of an object in the road network. More...

Public Attributes

std::map< const std::string, GlobalRoadPosition > | mainLocatePoint {}
position of the reference point mapped by roadId
std::map< std::string, RoadInterval > | touchedRoads {}
position of the mainLocatePoint (middle of agent front) mapped by roadId

Detailed Description

Position of an object in the road network.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ObjectView Struct Reference

List of all members
ObjectView Struct Reference
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ObservationCyclics Class Reference

Public Member Functions | List of all members
ObservationCyclics Class Reference

The ObservationCyclics stores the samples which are logged by various modules and written into the cyclics tag of the simulationOutput.xml. More...

Public Member Functions

void | Insert (int time, const std::string &key, const std::string &value)
std::string | GetHeader ()
Returns the string header that is written into the simulationOuput.xml.
std::string | GetSamplesLine (uint32_t timeStepNumber)
Returns a single line of samples for the given timestep for writing into the simulationOutput.
std::set< int > & | GetTimeSteps ()
Returns all timesteps for which samples exist.
void | Clear ()
Clears all samples for a new run.
void | Insert (int time, const std::string &key, const std::string &value)
std::string | GetHeader ()
Returns the string header that is written into the simulationOuput.xml.
std::string | GetAgentHeader ()
Returns the string header that is written into the Cyclics_*.csv including agentId.
std::string | GetSamplesLine (uint32_t timeStepNumber)
Returns a single line of samples for the given timestep for writing into the simulationOutput.
std::vector< std::string > | GetAgentSamplesLine (uint32_t timeStepNumber)
Returns for each agent a single line of samples for the given timestep for writing into the cyclics_*.csv.
std::set< int > & | GetTimeSteps ()
Returns all timesteps for which samples exist.
void | Clear ()
Clears all samples for a new run.

Detailed Description

The ObservationCyclics stores the samples which are logged by various modules and written into the cyclics tag of the simulationOutput.xml.

Member Function Documentation

void Insert | ( | int | time,
 |  | const std::string & | key,
 |  | const std::string & | value
 | ) |  |

Inserts a parameter into the samples. If the key does not exist yet, it inserts it into the list of keys and all previous timesteps are filled with an empty string. If the key exists, but some timesteps are missing for this key, then missing timesteps are filled with an empty string.

Parameters
[in] | time | Timestep in milliseconds.
[in] | key | Name of parameter as string.
[in] | value | Value of parameter as string.
void Insert | ( | int | time,
 |  | const std::string & | key,
 |  | const std::string & | value
 | ) |  |

Inserts a parameter into the samples. If the key does not exist yet, it inserts it into the list of keys and all previous timesteps are filled with an empty string. If the key exists, but some timesteps are missing for this key, then missing timesteps are filled with an empty string.

Parameters
[in] | time | Timestep in milliseconds.
[in] | key | Name of parameter as string.
[in] | value | Value of parameter as string.
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ObservationFileHandler Class Reference

Public Member Functions | Private Member Functions | Private Attributes | List of all members
ObservationFileHandler Class Reference

Provides the basic logging and observer functionality. More...

Collaboration diagram for ObservationFileHandler:
[legend]

Public Member Functions

void | SetOutputLocation (const std::string &outputDir, const std::string &outputFile)
Sets the directory where the output is written into. More...
void | WriteStartOfFile (const std::string &frameworkVersion)
Creates the output file as simulationOutput.tmp and writes the basic header information.
void | WriteRun (const RunResultInterface &runResult, RunStatistic runStatistik, ObservationCyclics &cyclics)
This function gets called after each run and writes all information about this run into the output file. More...
void | WriteEndOfFile ()
Closes the xml tags flushes the output file, closes it and renames it to simulationOutput.xlm.
void | SetOutputLocation (const std::string &outputDir, const std::string &outputFile)
Sets the directory where the output is written into. More...
void | WriteStartOfFile (const std::string &frameworkVersion)
Creates the output file as simulationOutput.tmp and writes the basic header information.
void | WriteRun (const RunResultInterface &runResult, RunStatistic runStatistik, ObservationCyclics &cyclics)
This function gets called after each run and writes all information about this run into the output file. More...
void | WriteEndOfFile ()
Closes the xml tags flushes the output file, closes it and renames it to simulationOutput.xlm.

Private Member Functions

bool | ContainsSensor (const openpass::sensors::Parameters &sensorParameters) const
Returns wether the agent has sensors or not. More...
void | AddSensor (const std::string &agentId, const std::string &sensorId)
Writes the sensor information into the simulation output. More...
void | AddVehicleAttributes (const std::string &agentId)
Writes the sensor information into the simulation output. More...
void | AddSensors (const std::string &agentId)
Writes all sensor information of an agent into the simulation output. More...
void | AddAgent (const std::string &agentId)
Writes the content of an agent into the simulation output. More...
void | AddAgents ()
Writes the content of all agent into the simulation output. More...
void | AddEvents ()
Writes all events into the simulation output. More...
void | AddHeader (ObservationCyclics &cyclics)
Writes the header into the simulation output during full logging. More...
void | AddSamples (ObservationCyclics &cyclics)
Writes the samples into the simulation output during full logging. More...
void | AddReference (QString filename)
Writes the filename for the cyclics file into the simulation output during full logging. More...
void | RemoveCsvCyclics (QString directory)
Removes old cyclic files from directory. More...
void | WriteCsvCyclics (QString runId, ObservationCyclics &cyclics)
Writes the cyclics of one run to a csv. More...
void | WriteEntities (const QString tag, const openpass::type::EntityIds &entities, bool mandatory=false)
Write entities to XML. More...
void | WriteParameter (const openpass::type::FlatParameter &parameters, bool mandatory=false)
Write (event) parameter to XML. More...
bool | ContainsSensor (const openpass::sensors::Parameters &sensorParameters) const
Returns wether the agent has sensors or not. More...
void | AddSensor (const std::string &agentId, const std::string &sensorId)
Writes the sensor information into the simulation output. More...
void | AddVehicleAttributes (const std::string &agentId)
Writes the sensor information into the simulation output. More...
void | AddSensors (const std::string &agentId)
Writes all sensor information of an agent into the simulation output. More...
void | AddAgent (const std::string &agentId)
Writes the content of an agent into the simulation output. More...
void | AddAgents ()
Writes the content of all agent into the simulation output. More...
void | AddEvents ()
Writes all events into the simulation output. More...
void | AddHeader (ObservationCyclics &cyclics)
Writes the header into the simulation output during full logging. More...
void | AddSamples (ObservationCyclics &cyclics)
Writes the samples into the simulation output during full logging. More...
void | AddReference (QString filename)
Writes the filename for the cyclics file into the simulation output during full logging. More...
void | RemoveCsvCyclics (QString directory)
Removes old cyclic files from directory. More...
void | WriteCsvCyclics (QString runId, ObservationCyclics &cyclics)
Writes the cyclics of one run to a csv. More...
void | WriteEntities (const QString tag, const openpass::type::EntityIds &entities, bool mandatory=false)
Write entities to XML. More...
void | WriteParameter (const openpass::type::FlatParameter &parameters, bool mandatory=false)
Write (event) parameter to XML. More...

Private Attributes

int runNumber
run number

Detailed Description

Provides the basic logging and observer functionality.

Provides the basic logging functionality. Writes the framework, events, agents and samples into the output. It has two logging modes either event based or as single output. This module also acts as an observer of agent modules.

Member Function Documentation

void SetOutputLocation | ( | const std::string & | outputDir,
 |  | const std::string & | outputFile
 | ) |  |
inline

Sets the directory where the output is written into.

Parameters
outputDir path of output directory
void WriteRun | ( | const RunResultInterface & | runResult,
 |  | RunStatistic | runStatistik,
 |  | ObservationCyclics & | cyclics
 | ) |  |

This function gets called after each run and writes all information about this run into the output file.

Parameters
runResult
runStatistik
cyclics
dataStore
bool ContainsSensor ( const openpass::sensors::Parameters & sensorParameters ) const
inlineprivate

Returns wether the agent has sensors or not.

Returns
true if agent has sensors, otherwise false.
void AddSensor | ( | const std::string & | agentId,
 |  | const std::string & | sensorId
 | ) |  |
private

Writes the sensor information into the simulation output.

Parameters
[in] | fStream | Shared pointer of the stream writer.
[in] | sensorParameter | Parameters of the sensor.
void AddVehicleAttributes ( const std::string & agentId )
private

Writes the sensor information into the simulation output.

Parameters
[in] | fStream | Shared pointer of the stream writer.
[in] | vehicleModelParameters | Parameters of the vehicle.
void AddSensors ( const std::string & agentId )
private

Writes all sensor information of an agent into the simulation output.

Parameters
[in] | fStream | Shared pointer of the stream writer.
[in] | agent | Pointer to the agent.
void AddAgent ( const std::string & agentId )
private

Writes the content of an agent into the simulation output.

Parameters
[in] | fStream | Shared pointer of the stream writer.
[in] | agent | Pointer to the agent.
void AddAgents ( )
private

Writes the content of all agent into the simulation output.

Parameters
[in] fStream Shared pointer of the stream writer.
void AddEvents ( )
private

Writes all events into the simulation output.

Parameters
[in] fStream Shared pointer of the stream writer.
void AddHeader ( ObservationCyclics & cyclics )
private

Writes the header into the simulation output during full logging.

Parameters
[in] fStream Shared pointer of the stream writer.
void AddSamples ( ObservationCyclics & cyclics )
private

Writes the samples into the simulation output during full logging.

Parameters
[in] fStream Shared pointer of the stream writer.
void AddReference ( QString filename )
private

Writes the filename for the cyclics file into the simulation output during full logging.

Parameters
[in] | fStream | Shared pointer of the stream writer.
[in] | filename | Name of the file, where cyclics are written to.
void RemoveCsvCyclics ( QString directory )
private

Removes old cyclic files from directory.

Parameters
[in] directory directory to delete teh cyclic files
void WriteCsvCyclics | ( | QString | runId,
 |  | ObservationCyclics & | cyclics
 | ) |  |
private

Writes the cyclics of one run to a csv.

Parameters
[in] | runId | Id of the current run
[in] | cyclics | Cyclics of the current run
void WriteEntities | ( | const QString | tag,
 |  | const openpass::type::EntityIds & | entities,
 |  | bool | mandatory = false
 | ) |  |
private

Write entities to XML.

Parameters
tag | tag name
entities | list of entities
mandatory | if set, an emtpy tag is added if entities is empty (default false)
void WriteParameter | ( | const openpass::type::FlatParameter & | parameters,
 |  | bool | mandatory = false
 | ) |  |
private

Write (event) parameter to XML.

Remarks
Might be used for generic parameters in the future - right now, only event parameters
Parameters
[in] | parameters | list of parameters
[in] | mandatory | if set, an emtpy tag is added if parameters are empty (default false)
void SetOutputLocation | ( | const std::string & | outputDir,
 |  | const std::string & | outputFile
 | ) |  |
inline

Sets the directory where the output is written into.

Parameters
outputDir path of output directory
void WriteRun | ( | const RunResultInterface & | runResult,
 |  | RunStatistic | runStatistik,
 |  | ObservationCyclics & | cyclics
 | ) |  |

This function gets called after each run and writes all information about this run into the output file.

Parameters
runResult
runStatistik
cyclics
dataStore
bool ContainsSensor ( const openpass::sensors::Parameters & sensorParameters ) const
inlineprivate

Returns wether the agent has sensors or not.

Returns
true if agent has sensors, otherwise false.
void AddSensor | ( | const std::string & | agentId,
 |  | const std::string & | sensorId
 | ) |  |
private

Writes the sensor information into the simulation output.

Parameters
[in] | fStream | Shared pointer of the stream writer.
[in] | sensorParameter | Parameters of the sensor.
void AddVehicleAttributes ( const std::string & agentId )
private

Writes the sensor information into the simulation output.

Parameters
[in] | fStream | Shared pointer of the stream writer.
[in] | vehicleModelParameters | Parameters of the vehicle.
void AddSensors ( const std::string & agentId )
private

Writes all sensor information of an agent into the simulation output.

Parameters
[in] | fStream | Shared pointer of the stream writer.
[in] | agent | Pointer to the agent.
void AddAgent ( const std::string & agentId )
private

Writes the content of an agent into the simulation output.

Parameters
[in] | fStream | Shared pointer of the stream writer.
[in] | agent | Pointer to the agent.
void AddAgents ( )
private

Writes the content of all agent into the simulation output.

Parameters
[in] fStream Shared pointer of the stream writer.
void AddEvents ( )
private

Writes all events into the simulation output.

Parameters
[in] fStream Shared pointer of the stream writer.
void AddHeader ( ObservationCyclics & cyclics )
private

Writes the header into the simulation output during full logging.

Parameters
[in] fStream Shared pointer of the stream writer.
void AddSamples ( ObservationCyclics & cyclics )
private

Writes the samples into the simulation output during full logging.

Parameters
[in] fStream Shared pointer of the stream writer.
void AddReference ( QString filename )
private

Writes the filename for the cyclics file into the simulation output during full logging.

Parameters
[in] | fStream | Shared pointer of the stream writer.
[in] | filename | Name of the file, where cyclics are written to.
void RemoveCsvCyclics ( QString directory )
private

Removes old cyclic files from directory.

Parameters
[in] directory directory to delete teh cyclic files
void WriteCsvCyclics | ( | QString | runId,
 |  | ObservationCyclics & | cyclics
 | ) |  |
private

Writes the cyclics of one run to a csv.

Parameters
[in] | runId | Id of the current run
[in] | cyclics | Cyclics of the current run
void WriteEntities | ( | const QString | tag,
 |  | const openpass::type::EntityIds & | entities,
 |  | bool | mandatory = false
 | ) |  |
private

Write entities to XML.

Parameters
tag | tag name
entities | list of entities
mandatory | if set, an emtpy tag is added if entities is empty (default false)
void WriteParameter | ( | const openpass::type::FlatParameter & | parameters,
 |  | bool | mandatory = false
 | ) |  |
private

Write (event) parameter to XML.

Remarks
Might be used for generic parameters in the future - right now, only event parameters
Parameters
[in] | parameters | list of parameters
[in] | mandatory | if set, an emtpy tag is added if parameters are empty (default false)
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ObservationInstance Struct Reference

Public Attributes | List of all members
ObservationInstance Struct Reference

Wrapper for building an ObservationInstance. More...

Public Attributes

std::string | libraryName
for internal use
openpass::parameter::ParameterSetLevel1 | parameters
Name of the library to load.

Detailed Description

Wrapper for building an ObservationInstance.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ObservationLogImplementation Class Reference

List of all members
ObservationLogImplementation Class Reference

This class adds the RunStatistic information to the simulation output. More...

Inheritance diagram for ObservationLogImplementation:
[legend]
Collaboration diagram for ObservationLogImplementation:
[legend]

Detailed Description

This class adds the RunStatistic information to the simulation output.

This class inherits the ObservationLogGeneric which creates the basic simulation output and adds the RunStatistic information to the output. This class also manages the stop reasons of the simulation.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Obstruction Class Reference

Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
Obstruction Class Reference

Describes the obstruction of an opposing object within the driving lanes. More...

Public Member Functions

Obstruction (double left, double right, double mainLaneLocator)
!< More...

Static Public Member Functions

static Obstruction | Invalid ()
static Obstruction | NoOpponent ()

Public Attributes

double | left {0.0}
!< More...
double | right {0.0}
!< More...
double | mainLaneLocator {0.0}
!< More...
bool | isOverlapping {false}
!< More...

Detailed Description

Describes the obstruction of an opposing object within the driving lanes.

Constructor & Destructor Documentation

Obstruction | ( | double | left,
 |  | double | right,
 |  | double | mainLaneLocator
 | ) |  |
inline

!<

True, if object obstructs

Member Function Documentation

static Obstruction Invalid ( )
inlinestatic
Returns
Invalid obstruction object
static Obstruction NoOpponent ( )
inlinestatic
Returns
Default for no opponent

Member Data Documentation

double left {0.0}

!<

True, if obstruction could be calculated

double right {0.0}

!<

How far do I need to drive to the left to pass the object

double mainLaneLocator {0.0}

!<

How far do I need to drive to the right to pass the object

bool isOverlapping {false}

!<

Lateral distance of the mainLaneLocator

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: OpenScenarioActionsImplementation Class Reference

List of all members
OpenScenarioActionsImplementation Class Reference

Relays triggered OpenScenario actions as signals to other components. More...

Inheritance diagram for OpenScenarioActionsImplementation:
[legend]
Collaboration diagram for OpenScenarioActionsImplementation:
[legend]

Detailed Description

Relays triggered OpenScenario actions as signals to other components.

When used in conjunction with autoregistering transformers (

See also
actionTransformRepository), the linkIdMapping has to be provided via the parameter interface.

That means that when a transformer for e.g. event X is autoregistered, a parameter for mapping X::Topic to a linkId needs to be defined.

Syntax: <parameter> <id>THE_TOPIC</id> <type>int</type> <unit>

THE_LINK_ID

</parameter>

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: OscActionsCalculation Class Reference

Public Member Functions | List of all members
OscActionsCalculation Class Reference

This class makes calculations for the OpenScenarioActions module. More...

Public Member Functions

openScenario::Trajectory CalculateSinusiodalLaneChange (double deltaS, double deltaT, double deltaTime, double timeStep, GlobalRoadPosition startPosition, double startTime) const

Detailed Description

This class makes calculations for the OpenScenarioActions module.

Member Function Documentation

openScenario::Trajectory CalculateSinusiodalLaneChange | ( | double | deltaS,
 |  | double | deltaT,
 |  | double | deltaTime,
 |  | double | timeStep,
 |  | GlobalRoadPosition | startPosition,
 |  | double | startTime
 | ) |  | const

Calculates a trajectory for a lane change with shape "sinusiodal" The result has constant speed in s

Parameters
deltaS | length of the trajectory in s
deltaT | length of the trajectory in t
deltaTime | time of the trajectory
timeStep | delta time between two trajectory points
startPosition | start point of the trajectory
startTime | time of the first trajectory point
Returns
sinusiodal lane change trajectory in world coordinates
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: OsmpFmuHandler Class Reference

Private Member Functions | Private Attributes | List of all members
OsmpFmuHandler Class Reference
Inheritance diagram for OsmpFmuHandler:
[legend]
Collaboration diagram for OsmpFmuHandler:
[legend]

Private Member Functions

void | SetSensorViewInput (const osi3::SensorView &data)
Sets the SensorView as input for the FMU.
void | GetSensorData ()
Reads the SensorData from the FMU.
void | WriteJson (const google::protobuf::Message &message, const QString &fileName)
Writes an OSI message into a JSON file.

Private Attributes

bool enforceDoubleBuffering {false}
check for double buffering of OSI messages allocated by FMU
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: OutputAttributes Struct Reference

List of all members
OutputAttributes Struct Reference
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: OutputPort< SignalType, ValueType > Class Template Reference

Public Member Functions | Private Attributes | List of all members
OutputPort< SignalType, ValueType > Class Template Reference
Inheritance diagram for OutputPort< SignalType, ValueType >:
[legend]
Collaboration diagram for OutputPort< SignalType, ValueType >:
[legend]

Public Member Functions

OutputPort (int id, std::map< int, ComponentPort * > *portMap)
virtual | ~OutputPort ()=default
Destructor.
void | SetValue (ValueType value)
- Public Member Functions inherited from ComponentPort
ComponentPort (int id, std::map< int, ComponentPort * > *portMap)
virtual | ~ComponentPort ()=default
Destructor.
int | GetId ()
virtual bool | SetSignalValue (const std::shared_ptr< SignalInterface const > &data)

Private Attributes

ValueType value
internal value

Detailed Description

template<typename SignalType, typename ValueType>
class OutputPort< SignalType, ValueType >

A Template Class to manage output ports.

Constructor & Destructor Documentation

OutputPort | ( | int | id,
 |  | std::map< int, ComponentPort * > * | portMap
 | ) |  |
inline

Constructor

Parameters
[in] | id | Id of output port
[in,out] | portMap | map of output port this output port shall be added

Member Function Documentation

void SetValue ( ValueType value )
inline

Set the value of the output port

Parameters
value value to be set
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: OutputTags Struct Reference

List of all members
OutputTags Struct Reference
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: overload< Ts > Struct Template Reference

overload< Ts > Struct Template Reference
Inheritance diagram for overload< Ts >:
[legend]
Collaboration diagram for overload< Ts >:
[legend]
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: OwnVehicleInformation Struct Reference

Public Attributes | List of all members
OwnVehicleInformation Struct Reference

Data about the lane to left (in driving direction) of the mainLane. More...

Public Attributes

double | absoluteVelocity {-999.0}
Absolute velocity of agent.
double | acceleration {-999.0}
Acceleration of agent.
double | lateralPosition {-999.0}
t-coordinate
double | heading {-999.0}
Heading relative to lane.
double | steeringWheelAngle {-999.0}
Angle of the steering wheel.
double | distanceToLaneBoundaryLeft {-999.0}
Distance between the left front point and the left boundary of the lane it is in.
double | distanceToLaneBoundaryRight {-999.0}
Distance between the right front point and the right boundary of the lane it is in.
bool | collision {false}
Wether this agent has collided with another object.

Detailed Description

Data about the lane to left (in driving direction) of the mainLane.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ParametersVehicleSignal Class Reference

Public Member Functions | List of all members
ParametersVehicleSignal Class Reference

Provides all vehicle parameters for the driver. More...

Inheritance diagram for ParametersVehicleSignal:
[legend]
Collaboration diagram for ParametersVehicleSignal:
[legend]

Public Member Functions

ParametersVehicleSignal (VehicleModelParameters vehicleParameters)
Constructor.
virtual operator std::string () const

Detailed Description

Provides all vehicle parameters for the driver.

Member Function Documentation

virtual operator std::string ( ) const
inlinevirtual

Returns the content/payload of the signal as an std::string

Returns
Content/payload of the signal as an std::string
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Polygon Class Reference

Public Member Functions | List of all members
Polygon Class Reference

polygon in 2d More...

Public Member Functions

bool | CalculateCentroid (Common::Vector2d &cog)
get centroid of the polygon Algorithm to calculate the center of the polygon. More...
double | GetNumberOfVertices ()
get number of vertices of the polygon More...
std::vector< Common::Vector2d > | GetVertices () const
get vertices of the polygon More...
void | SetVertices (const std::vector< Common::Vector2d > &value)
set vertices of the polygon More...
void | Translate (Common::Vector2d translationVector)
translate the polygon Translate the polygon along a given vector. More...

Detailed Description

polygon in 2d

This class represents a polygon in 2d. It consists of several vertices which are vectors in 2d. It provides several operations for working with the polygon.

Member Function Documentation

bool CalculateCentroid ( Common::Vector2d & cog )

get centroid of the polygon Algorithm to calculate the center of the polygon.

Notes:

  • the terms center of gravity and centroid are often used synonymous
  • algorithm works for clockwise and counter-clockwise order of the vertices

The algorithm is based on MATLAB-code provided by Harald Kolk (TU Graz). See also: https://en.wikipedia.org/wiki/Centroid

Parameters
[out] cog centroid of the polygon
Returns
true if calculation was successful
double GetNumberOfVertices ( )

get number of vertices of the polygon

Returns
number of vertices of the polygon
std::vector<Common::Vector2d> GetVertices ( ) const

get vertices of the polygon

Returns
vertices of polygon
void SetVertices ( const std::vector< Common::Vector2d > & value )

set vertices of the polygon

Parameters
vertices of the polygon
void Translate ( Common::Vector2d translationVector )

translate the polygon Translate the polygon along a given vector.

Parameters
translationVector vector for translation
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Position Struct Reference

List of all members
Position Struct Reference
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: PostCrashDynamic Class Reference

Public Member Functions | Private Attributes | List of all members
PostCrashDynamic Class Reference

Class to store post-crash dynamics data Used to store information about the dynamic after a collision. More...

Collaboration diagram for PostCrashDynamic:
[legend]

Public Member Functions

PostCrashDynamic (double velocity=0, double velocityChange=0, double velocityDirection=0, double yawVelocity=0, Common::Vector2d pulse=Common::Vector2d(), double pulseDirection=0, Common::Vector2d pulseLocal=Common::Vector2d(), Common::Vector2d pointOfContactLocal=Common::Vector2d(), double collisionVelocity=0, bool sliding=false)

Private Attributes

double | velocity = 0
post crash velocity, absolute [m/s]
double | velocityChange = 0
delta-V: collision induced velocity change [m/s]
double | velocityDirection = 0
post crash velocity direction [rad]
double | yawVelocity = 0
post crash yaw velocity [rad/s]
Common::Vector2d | pulse = Common::Vector2d(0, 0)
pulse vector [two-dimensional vector: kg*m/s,kg*m/s]
double | pulseDirection = 0
pulse direction [rad]
Common::Vector2d | pulseLocal = Common::Vector2d(0, 0)
crash pulse in local vehicle coordinate system
Common::Vector2d | pointOfContactLocal = Common::Vector2d(0, 0)
point of impact in local vehicle coordinate system
double | collisionVelocity = 0
collision velocity
bool | sliding = false
flag for collision type More...

Detailed Description

Class to store post-crash dynamics data Used to store information about the dynamic after a collision.

Constructor & Destructor Documentation

PostCrashDynamic | ( | double | velocity = 0,
 |  | double | velocityChange = 0,
 |  | double | velocityDirection = 0,
 |  | double | yawVelocity = 0,
 |  | Common::Vector2d | pulse = Common::Vector2d(),
 |  | double | pulseDirection = 0,
 |  | Common::Vector2d | pulseLocal = Common::Vector2d(),
 |  | Common::Vector2d | pointOfContactLocal = Common::Vector2d(),
 |  | double | collisionVelocity = 0,
 |  | bool | sliding = false
 | ) |  |
inline

Container Class to store all relevant data for a post crash dynamic

Parameters
velocity
velocityChange
velocityDirection
yawVelocity
pulse
pulseDirection
pulseLocal
pointOfContactLocal
collisionVelocity
sliding

Member Data Documentation

bool sliding = false
private

flag for collision type

true: sliding collision, false: no sliding collision

Note that the collision model is not valid for sliding collisions.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: PostCrashVelocity Struct Reference

Public Attributes | List of all members
PostCrashVelocity Struct Reference

Public Attributes

bool | isActive = false
activity flag
double | velocityAbsolute = 0.0
post crash velocity, absolute [m/s]
double | velocityDirection = 0.0
post crash velocity direction [rad]
double | yawVelocity = 0.0
post crash yaw velocity [rad/s]
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ProcessManager Class Reference

List of all members
ProcessManager Class Reference
Inheritance diagram for ProcessManager:
[legend]
Collaboration diagram for ProcessManager:
[legend]
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Profiles Class Reference

List of all members
Profiles Class Reference
Inheritance diagram for Profiles:
[legend]
Collaboration diagram for Profiles:
[legend]
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: ReachPositionCondition Class Reference

List of all members
ReachPositionCondition Class Reference
Inheritance diagram for ReachPositionCondition:
[legend]
Collaboration diagram for ReachPositionCondition:
[legend]
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Remainder Struct Reference

List of all members
Remainder Struct Reference

This struct describes how much space an agent has to next lane boundary on both sides. More...

Detailed Description

This struct describes how much space an agent has to next lane boundary on both sides.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Road Class Reference

Public Member Functions | List of all members
Road Class Reference

Class representing a road. More...

Inheritance diagram for Road:
[legend]
Collaboration diagram for Road:
[legend]

Public Member Functions

bool | AddGeometryLine (double s, double x, double y, double hdg, double length) override
bool | AddGeometryArc (double s, double x, double y, double hdg, double length, double curvature) override
bool | AddGeometrySpiral (double s, double x, double y, double hdg, double length, double curvStart, double curvEnd) override
bool | AddGeometryPoly3 (double s, double x, double y, double hdg, double length, double a, double b, double c, double d) override
bool | AddGeometryParamPoly3 (double s, double x, double y, double hdg, double length, ParamPoly3Parameters parameters) override
bool | AddElevation (double s, double a, double b, double c, double d) override
bool | AddLaneOffset (double s, double a, double b, double c, double d) override
bool | AddLink (RoadLinkType type, RoadLinkElementType elementType, const std::string &elementId, ContactPointType contactPoint, RoadLinkDirectionType direction, RoadLinkSideType side) override
RoadLaneSection * | AddRoadLaneSection (double start) override
void | AddRoadSignal (const RoadSignalSpecification &signal) override
const std::string | GetId () const override
const std::list< RoadElevation * > & | GetElevations () const override
const std::list< RoadLaneOffset * > & | GetLaneOffsets () const override
const std::list< RoadGeometryInterface * > & | GetGeometries () const override
const std::list< RoadLinkInterface * > & | GetRoadLinks () const override
const std::vector< RoadLaneSectionInterface * > & | GetLaneSections () const override
const std::vector< RoadSignalInterface * > & | GetRoadSignals () const override
const std::vector< RoadObjectInterface * > & | GetRoadObjects () const override
void | SetInDirection (bool inDirection) override
bool | GetInDirection () const override

Detailed Description

Class representing a road.

Member Function Documentation

bool AddGeometryLine | ( | double | s,
 |  | double | x,
 |  | double | y,
 |  | double | hdg,
 |  | double | length
 | ) |  |
override

Adds a line geometry to a road by creating a new RoadGeometryLine object and adding it to the stored list of geometries.

Parameters
[in] | s | start position s-coordinate
[in] | x | start position x inertial
[in] | y | start position y inertial
[in] | hdg | start orientation (inertial heading)
[in] | length | length of the element's reference line
Returns
false if an error has occurred, true otherwise
bool AddGeometryArc | ( | double | s,
 |  | double | x,
 |  | double | y,
 |  | double | hdg,
 |  | double | length,
 |  | double | curvature
 | ) |  |
override

Adds an arc geometry to a road by creating a new RoadGeometryArc object and adding it to the stored list of geometries.

Parameters
[in] | s | start position s-coordinate
[in] | x | start position x inertial
[in] | y | start position y inertial
[in] | hdg | start orientation (inertial heading)
[in] | length | length of the element's reference line
[in] | curvature | constant curvature throughout the element
Returns
false if an error has occurred, true otherwise
bool AddGeometrySpiral | ( | double | s,
 |  | double | x,
 |  | double | y,
 |  | double | hdg,
 |  | double | length,
 |  | double | curvStart,
 |  | double | curvEnd
 | ) |  |
override

Adds a spiral geometry to a road by creating a new RoadGeometrySpiral object and adding it to the stored list of geometries.

Parameters
[in] | s | start position s-coordinate
[in] | x | start position x inertial
[in] | y | start position y inertial
[in] | hdg | start orientation (inertial heading)
[in] | length | length of the element's reference line
[in] | curvStart | curvature at the start of the element
[in] | curvEnd | curvature at the end of the element
Returns
false if an error has occurred, true otherwise
bool AddGeometryPoly3 | ( | double | s,
 |  | double | x,
 |  | double | y,
 |  | double | hdg,
 |  | double | length,
 |  | double | a,
 |  | double | b,
 |  | double | c,
 |  | double | d
 | ) |  |
override

Adds a cubic polynomial geometry to a road by creating a new RoadGeometryPoly3 object and adding it to the stored list of geometries.

Parameters
[in] | s | start position s-coordinate
[in] | x | start position x inertial
[in] | y | start position y inertial
[in] | hdg | start orientation (inertial heading)
[in] | length | length of the element's reference line
[in] | a | constant factor of the polynomial
[in] | b | linear factor of the polynomial
[in] | c | quadratic factor of the polynomial
[in] | d | cubic factor of the polynomial
Returns
false if an error has occurred, true otherwise
bool AddGeometryParamPoly3 | ( | double | s,
 |  | double | x,
 |  | double | y,
 |  | double | hdg,
 |  | double | length,
 |  | ParamPoly3Parameters | parameters
 | ) |  |
override

Adds a parametric cubic polynomial geometry to a road by creating a new RoadGeometryparamPoly3 object and adding it to the stored list of geometries. Each coordinate is calculated in a local (u,v) coordinate system

Parameters
[in] | s | start position s-coordinate
[in] | x | start position x inertial
[in] | y | start position y inertial
[in] | hdg | start orientation (inertial heading)
[in] | length | length of the element's reference line
[in] | parameters | Factors of the two polynomials describing the road
Returns
false if an error has occurred, true otherwise
bool AddElevation | ( | double | s,
 |  | double | a,
 |  | double | b,
 |  | double | c,
 |  | double | d
 | ) |  |
override

Adds an elevation profile defined via a cubic polynomial to a road by creating a new RoadElevation object and adding it to the stored list of elevations.

Parameters
[in] | s | start position s-coordinate
[in] | a | constant factor of the polynomial
[in] | b | linear factor of the polynomial
[in] | c | quadratic factor of the polynomial
[in] | d | cubic factor of the polynomial
Returns
false if an error has occurred, true otherwise
bool AddLaneOffset | ( | double | s,
 |  | double | a,
 |  | double | b,
 |  | double | c,
 |  | double | d
 | ) |  |
override

Adds a lane offset defined via a cubic polynomial to a road by creating a new RoadLaneOffset object and adding it to the stored list of lane offsets.

Parameters
[in] | s | start position s-coordinate
[in] | a | constant factor of the polynomial
[in] | b | linear factor of the polynomial
[in] | c | quadratic factor of the polynomial
[in] | d | cubic factor of the polynomial
Returns
false if an error has occurred, true otherwise
bool AddLink | ( | RoadLinkType | type,
 |  | RoadLinkElementType | elementType,
 |  | const std::string & | elementId,
 |  | ContactPointType | contactPoint,
 |  | RoadLinkDirectionType | direction,
 |  | RoadLinkSideType | side
 | ) |  |
override

Adds a new link to a road by creating a new RoadLink object and adding it to the stored list of links.

Parameters
[in] | type | type of link
[in] | elementType | element type of the link
[in] | elementId | ID of the linked element
[in] | contactPoint | contact point type of link on the linked element
[in] | direction | orientation of the lanes to link; only relevant for a neighbor link type
[in] | side | at which side the neighboring road lies; only relevant for a neighbor link type
Returns
false if an error has occurred, true otherwise
RoadLaneSection* AddRoadLaneSection ( double start )
override

Adds a new lane section to a road by creating a new RoadLaneSection object and adding it to the stored list of lane sections.

Parameters
[in] start start position s-coordinate
Returns
created road lane section
void AddRoadSignal ( const RoadSignalSpecification & signal )
override

Adds a new signal a road by creating a new RoadSignal object and adding it to the stored list of road signals.

Returns
created road signal
const std::string GetId ( ) const
inlineoverride

Returns the ID of the road.

Returns
ID of the road
const std::list<RoadElevation *>& GetElevations ( ) const
inlineoverride

Returns the stored list of elevation profiles.

Returns
list of elevation profiles
const std::list<RoadLaneOffset *>& GetLaneOffsets ( ) const
inlineoverride

Returns the stored list of lane offsets.

Returns
list of lane offsets
const std::list<RoadGeometryInterface *>& GetGeometries ( ) const
inlineoverride

Returns the stored list of road geometries.

Returns
list of road geometries
const std::list<RoadLinkInterface *>& GetRoadLinks ( ) const
inlineoverride

Returns the stored list of road links.

Returns
list of road links
const std::vector<RoadLaneSectionInterface *>& GetLaneSections ( ) const
inlineoverride

Returns the stored list of lane sections.

Returns
list of lane sections
const std::vector<RoadSignalInterface *>& GetRoadSignals ( ) const
inlineoverride

Returns the stored list of signals

Returns
list of signals
const std::vector<RoadObjectInterface *>& GetRoadObjects ( ) const
inlineoverride

Returns the stored list of objects

Returns
list of objects
void SetInDirection ( bool inDirection )
inlineoverride

Sets the flag, if the road is in the reference direction or not.

Parameters
[in] inDirection Flag, if the road is in the reference direction or not
bool GetInDirection ( ) const
inlineoverride

Returns if the road is in the reference direction or not.

Returns
Flag, if the road is in the reference direction or not
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadGeometry Class Reference

Public Member Functions | Protected Member Functions | List of all members
RoadGeometry Class Referenceabstract
Inheritance diagram for RoadGeometry:
[legend]
Collaboration diagram for RoadGeometry:
[legend]

Public Member Functions

virtual Common::Vector2d | GetCoord (double sOffset, double tOffset) const override=0
virtual double | GetDir (double sOffset) const override=0
double | GetS () const override
double | GetHdg () const override
double | GetLength () const override

Protected Member Functions

Common::Vector2d | GetCoordLine (double sOffset, double tOffset) const
double | GetDirLine (double sOffset) const
Common::Vector2d | GetCoordArc (double sOffset, double tOffset, double curvature) const
double | GetDirArc (double sOffset, double curvature) const

Detailed Description

Abstract class representing the geometry of a road, i.e. the layout of the road's reference line in the in the x/y plane.

Member Function Documentation

virtual Common::Vector2d GetCoord | ( | double | sOffset,
 |  | double | tOffset
 | ) |  | const
 overridepure virtual

Calculates the x/y coordinates as vector.

Parameters
[in] | sOffset | s offset within geometry section
[in] | tOffset | offset to the left
Returns
coordinates with the x/y coordinates
virtual double GetDir ( double sOffset ) const
overridepure virtual

Calculates the heading.

Parameters
[in] sOffset s offset within geometry section
Returns
heading
double GetS ( ) const
inlineoverride

Retrieves the s offset within the OpenDrive road.

Returns
s offset
double GetHdg ( ) const
inlineoverride

Retrieves the initial heading of the geometry section

Returns
initial heading of geometry
double GetLength ( ) const
inlineoverride

Retrieves the length of the geometry section

Returns
length of geometry section
Common::Vector2d GetCoordLine | ( | double | sOffset,
 |  | double | tOffset
 | ) |  | const
 protected

Gets the coordinate at the s and t offest if the road is linear.

Parameters
[in] | sOffset | s offset within geometry section
[in] | tOffset | offset to the left
Returns
coordinates with the x/y coordinates
double GetDirLine ( double sOffset ) const
protected

Returns the direction of the line, i.e. the start orientation.

Parameters
[in] sOffset offset within geometry section; unused
Returns
direction
Common::Vector2d GetCoordArc | ( | double | sOffset,
 |  | double | tOffset,
 |  | double | curvature
 | ) |  | const
 protected

Gets the coordinate at the s and t offest if the road is an arc.

Parameters
[in] | sOffset | s offset within geometry section
[in] | tOffset | offset to the left
[in] | curvature | curvature of the arc
Returns
coordinates with the x/y coordinates
double GetDirArc | ( | double | sOffset,
 |  | double | curvature
 | ) |  | const
 protected

Returns the heading of an arc, i.e. the initial heading plus the fraction of the radius due to the curvature.

Parameters
[in] | sOffset | s offset within geometry section
[in] | curvature | curvature of the arc
Returns
heading of the arc
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadGeometryArc Class Reference

Public Member Functions | List of all members
RoadGeometryArc Class Reference

Class representing a road arc as a RoadGeometry. More...

Inheritance diagram for RoadGeometryArc:
[legend]
Collaboration diagram for RoadGeometryArc:
[legend]

Public Member Functions

double | GetCurvature () const
- Public Member Functions inherited from RoadGeometry
double | GetS () const override
double | GetHdg () const override
double | GetLength () const override

Additional Inherited Members

- Protected Member Functions inherited from RoadGeometry
Common::Vector2d | GetCoordLine (double sOffset, double tOffset) const
double | GetDirLine (double sOffset) const
Common::Vector2d | GetCoordArc (double sOffset, double tOffset, double curvature) const
double | GetDirArc (double sOffset, double curvature) const

Detailed Description

Class representing a road arc as a RoadGeometry.

Member Function Documentation

double GetCurvature ( ) const
inline

Returns the stored curvature.

Returns
curvature
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadGeometryLine Class Reference

List of all members
RoadGeometryLine Class Reference

Class representing a road line as a RoadGeometry. More...

Inheritance diagram for RoadGeometryLine:
[legend]
Collaboration diagram for RoadGeometryLine:
[legend]

Additional Inherited Members

- Public Member Functions inherited from RoadGeometry
double | GetS () const override
double | GetHdg () const override
double | GetLength () const override
- Protected Member Functions inherited from RoadGeometry
Common::Vector2d | GetCoordLine (double sOffset, double tOffset) const
double | GetDirLine (double sOffset) const
Common::Vector2d | GetCoordArc (double sOffset, double tOffset, double curvature) const
double | GetDirArc (double sOffset, double curvature) const

Detailed Description

Class representing a road line as a RoadGeometry.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadGeometryParamPoly3 Class Reference

Public Member Functions | List of all members
RoadGeometryParamPoly3 Class Reference

Class representing a road form defined via a parametric cubic polynomial as a RoadGeometry. More...

Inheritance diagram for RoadGeometryParamPoly3:
[legend]
Collaboration diagram for RoadGeometryParamPoly3:
[legend]

Public Member Functions

double | GetAU () const
double | GetBU () const
double | GetCU () const
double | GetD () const
double | GetAV () const
double | GetBV () const
double | GetCV () const
double | GetDV () const
- Public Member Functions inherited from RoadGeometry
double | GetS () const override
double | GetHdg () const override
double | GetLength () const override

Additional Inherited Members

- Protected Member Functions inherited from RoadGeometry
Common::Vector2d | GetCoordLine (double sOffset, double tOffset) const
double | GetDirLine (double sOffset) const
Common::Vector2d | GetCoordArc (double sOffset, double tOffset, double curvature) const
double | GetDirArc (double sOffset, double curvature) const

Detailed Description

Class representing a road form defined via a parametric cubic polynomial as a RoadGeometry.

Member Function Documentation

double GetAU ( ) const
inline

Returns the constant factor of the polynomial for the u coordinate.

Returns
constant factor of the polynomial
double GetBU ( ) const
inline

Returns the linear factor of the polynomial for the u coordinate.

Returns
linear factor of the polynomial
double GetCU ( ) const
inline

Returns the quadratic factor of the polynomial for the u coordinate.

Returns
quadratic factor of the polynomial
double GetD ( ) const
inline

Returns the cubic factor of the polynomial for the u coordinate.

Returns
cubic factor of the polynomial
double GetAV ( ) const
inline

Returns the constant factor of the polynomial for the v coordinate.

Returns
constant factor of the polynomial
double GetBV ( ) const
inline

Returns the linear factor of the polynomial for the v coordinate.

Returns
linear factor of the polynomial
double GetCV ( ) const
inline

Returns the quadratic factor of the polynomial for the v coordinate.

Returns
quadratic factor of the polynomial
double GetDV ( ) const
inline

Returns the cubic factor of the polynomial for the v coordinate.

Returns
cubic factor of the polynomial
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadGeometryPoly3 Class Reference

Public Member Functions | List of all members
RoadGeometryPoly3 Class Reference

Class representing a road form defined via a cubic polynomial as a RoadGeometry. More...

Inheritance diagram for RoadGeometryPoly3:
[legend]
Collaboration diagram for RoadGeometryPoly3:
[legend]

Public Member Functions

double | GetA () const
double | GetB () const
double | GetC () const
double | GetD () const
- Public Member Functions inherited from RoadGeometry
double | GetS () const override
double | GetHdg () const override
double | GetLength () const override

Additional Inherited Members

- Protected Member Functions inherited from RoadGeometry
Common::Vector2d | GetCoordLine (double sOffset, double tOffset) const
double | GetDirLine (double sOffset) const
Common::Vector2d | GetCoordArc (double sOffset, double tOffset, double curvature) const
double | GetDirArc (double sOffset, double curvature) const

Detailed Description

Class representing a road form defined via a cubic polynomial as a RoadGeometry.

Member Function Documentation

double GetA ( ) const
inline

Returns the constant factor of the polynomial.

Returns
constant factor of the polynomial
double GetB ( ) const
inline

Returns the linear factor of the polynomial.

Returns
linear factor of the polynomial
double GetC ( ) const
inline

Returns the quadratic factor of the polynomial.

Returns
quadratic factor of the polynomial
double GetD ( ) const
inline

Returns the cubic factor of the polynomial.

Returns
cubic factor of the polynomial
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadGeometrySpiral Class Reference

Public Member Functions | Private Member Functions | List of all members
RoadGeometrySpiral Class Reference

Class representing a spiral road (clothoid) as a RoadGeometry. More...

Inheritance diagram for RoadGeometrySpiral:
[legend]
Collaboration diagram for RoadGeometrySpiral:
[legend]

Public Member Functions

double | GetCurvStart () const
double | GetCurvEnd () const
- Public Member Functions inherited from RoadGeometry
double | GetS () const override
double | GetHdg () const override
double | GetLength () const override

Private Member Functions

Common::Vector2d | HalfCoord (double sOffset, double tOffset) const
Common::Vector2d | FullCoord (double sOffset, double tOffset) const
double | HalfCurvature (double sOffset) const
double | FullCurvature (double sOffset) const
double | HalfDir (double sOffset) const
double | FullDir (double sOffset) const

Additional Inherited Members

- Protected Member Functions inherited from RoadGeometry
Common::Vector2d | GetCoordLine (double sOffset, double tOffset) const
double | GetDirLine (double sOffset) const
Common::Vector2d | GetCoordArc (double sOffset, double tOffset, double curvature) const
double | GetDirArc (double sOffset, double curvature) const

Detailed Description

Class representing a spiral road (clothoid) as a RoadGeometry.

Member Function Documentation

double GetCurvStart ( ) const
inline

Returns the curvature at the start of the spiral.

Returns
curvature at the start of the spiral
double GetCurvEnd ( ) const
inline

Returns the curvature at the end of the spiral.

Returns
curvature at the end of the spiral
Common::Vector2d HalfCoord | ( | double | sOffset,
 |  | double | tOffset
 | ) |  | const
 private

Calculates the x/y coordinates as vector. Only valid if the start and end curvature of the spiral are either both positive or negative.

Parameters
[in] | sOffset | s offset within geometry section
[in] | tOffset | offset to the left
Returns
vector with the x/y coordinates
Common::Vector2d FullCoord | ( | double | sOffset,
 |  | double | tOffset
 | ) |  | const
 private

Calculates the x/y coordinates as vector. Returns an empty vector, if start and end curvature of the spiral have different signs.

Parameters
[in] | sOffset | s offset within geometry section
[in] | tOffset | offset to the left
Returns
vector with the x/y coordinates, empty vector, if start and end curvature of the spiral have different signs
double HalfCurvature ( double sOffset ) const
private

Calculates the curvature. Only valid if the start and end curvature of the spiral are either both positive or negative.

Parameters
[in] sOffset s offset within geometry section
Returns
curvature
double FullCurvature ( double sOffset ) const
private

Calculates the curvature. Returns 0.0, if start and end curvature of the spiral have different signs.

Parameters
[in] sOffset s offset within geometry section
Returns
curvature, 0.0, if start and end curvature of the spiral have different signs
double HalfDir ( double sOffset ) const
private

Calculates the direction. Only valid if the start and end curvature of the spiral are either both positive or negative.

Parameters
[in] sOffset s offset within geometry section
Returns
direction
double FullDir ( double sOffset ) const
private

Calculates the direction. Returns 0.0, if start and end curvature of the spiral have different signs.

Parameters
[in] sOffset s offset within geometry section
Returns
direction
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadInterval Struct Reference

List of all members
RoadInterval Struct Reference

Interval on a specific road. More...

Collaboration diagram for RoadInterval:
[legend]

Detailed Description

Interval on a specific road.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadLane Class Reference

Public Member Functions | List of all members
RoadLane Class Reference

Class representing a road lane. More...

Inheritance diagram for RoadLane:
[legend]
Collaboration diagram for RoadLane:
[legend]

Public Member Functions

bool | AddWidth (double sOffset, double a, double b, double c, double d) override
bool | AddBorder (double sOffset, double a, double b, double c, double d) override
bool | AddSuccessor (int id) override
bool | AddPredecessor (int id) override
int | GetId () const override
RoadLaneType | GetType () const override
const std::list< RoadLaneWidth * > & | GetWidths () const override
const std::list< RoadLaneWidth * > & | GetBorders () const override
const std::list< int > & | GetSuccessor () const override
const std::list< int > & | GetPredecessor () const override
void | SetInDirection (bool inDirection) override
bool | GetInDirection () const override
RoadLaneSectionInterface * | GetLaneSection () const override
bool | AddRoadMark (double sOffset, RoadLaneRoadDescriptionType type, RoadLaneRoadMarkType roadMark, RoadLaneRoadMarkColor color, RoadLaneRoadMarkLaneChange laneChange, RoadLaneRoadMarkWeight weight) override
const std::list< RoadLaneRoadMark * > & | GetRoadMarks () const override

Detailed Description

Class representing a road lane.

Member Function Documentation

bool AddWidth | ( | double | sOffset,
 |  | double | a,
 |  | double | b,
 |  | double | c,
 |  | double | d
 | ) |  |
override

Adds a new polynomial calculating the width of a lane to a road lane.

Parameters
[in] | sOffset | Offset relative to the preceding lane section
[in] | a | Constant factor from the polynomial
[in] | b | Linear factor from the polynomial
[in] | c | Quadratic factor from the polynomial
[in] | d | Cubic factor from the polynomial
Returns
False if an error occurred, true otherwise
bool AddBorder | ( | double | sOffset,
 |  | double | a,
 |  | double | b,
 |  | double | c,
 |  | double | d
 | ) |  |
override

Adds a new polynomial calculating the border of a lane to a road lane.

Parameters
[in] | sOffset | Offset relative to the preceding lane section
[in] | a | Constant factor from the polynomial
[in] | b | Linear factor from the polynomial
[in] | c | Quadratic factor from the polynomial
[in] | d | Cubic factor from the polynomial
Returns
False if an error occurred, true otherwise
bool AddSuccessor ( int id )
override

Adds the ID of a successor lane to a road lane.

Parameters
[in] id ID of a successor lane
Returns
False if an error occurred, true otherwise
bool AddPredecessor ( int id )
override

Adds the ID of a predecessor lane to a road lane.

Parameters
[in] id ID of a predecessor lane
Returns
False if an error occurred, true otherwise
int GetId ( ) const
inlineoverride

Returns the ID of the road lane.

Returns
ID of the road lane
RoadLaneType GetType ( ) const
inlineoverride

Returns the RoadLaneTypeType of the road lane.

Returns
RoadLaneTypeType of the road lane
const std::list<RoadLaneWidth *>& GetWidths ( ) const
inlineoverride

Returns the widths of the road lane.

Returns
RoadLaneTypeType of the road lane
const std::list<RoadLaneWidth *>& GetBorders ( ) const
inlineoverride

Returns the borders of the road lane.

Returns
RoadLaneTypeType of the road lane
const std::list<int>& GetSuccessor ( ) const
inlineoverride

Returns the successors of a road lane, can have at most one element.

Returns
Successors of the road lane
const std::list<int>& GetPredecessor ( ) const
inlineoverride

Returns the predecessors of a road lane, can have at most one element.

Returns
Predecessors of the road lane
void SetInDirection ( bool inDirection )
inlineoverride

Sets the flag, if the road lane is in the reference direction or not.

Parameters
[in] inDirection Flag, if the road lane is in the reference direction or not
bool GetInDirection ( ) const
inlineoverride

Returns if the road lane is in the reference direction or not.

Returns
Flag, if the road lane is in the reference direction or not
RoadLaneSectionInterface* GetLaneSection ( ) const
inlineoverride

Returns the RoadLaneSection to which the road lane belongs.

Returns
RoadLaneSection to which the road lane belongs
bool AddRoadMark | ( | double | sOffset,
 |  | RoadLaneRoadDescriptionType | type,
 |  | RoadLaneRoadMarkType | roadMark,
 |  | RoadLaneRoadMarkColor | color,
 |  | RoadLaneRoadMarkLaneChange | laneChange,
 |  | RoadLaneRoadMarkWeight | weight
 | ) |  |
override

Adds a road mark to the road

Parameters
[in] | sOffset | s offset from start of road
[in] | type | location type of road mark (left, center, right)
[in] | roadMark | Type of the road mark
[in] | color | Color of the road mark
[in] | laneChange | Allowed lane change directions
[in] | weight | Weight of the road mark (standard or bold)
Returns
False if an error occurred, true otherwise
const std::list<RoadLaneRoadMark *>& GetRoadMarks ( ) const
inlineoverride

Returns the road marks of the road

Returns
List of road marks
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadLaneSection Class Reference

Public Member Functions | List of all members
RoadLaneSection Class Reference

Class representing a road lane section that can contain several road lanes. More...

Inheritance diagram for RoadLaneSection:
[legend]
Collaboration diagram for RoadLaneSection:
[legend]

Public Member Functions

RoadLane * | AddRoadLane (int id, RoadLaneType type) override
const std::map< int, RoadLaneInterface * > & | GetLanes () const override
double | GetStart () const override
void | SetInDirection (bool inDirection) override
void | SetLaneIndexOffset (int laneIndexOffset) override
void | SetId (int Id) override
bool | GetInDirection () const override
int | GetLaneIndexOffset () const override
int | GetId () const override
RoadInterface * | GetRoad () const override

Detailed Description

Class representing a road lane section that can contain several road lanes.

Member Function Documentation

RoadLane* AddRoadLane | ( | int | id,
 |  | RoadLaneType | type
 | ) |  |
override

Adds and returns a road lane.

Parameters
[in] | id | ID of the lane
[in] | type | RoadLaneTypeType of the lane
Returns
False if an error occurred, true otherwise
const std::map<int, RoadLaneInterface *>& GetLanes ( ) const
inlineoverride

Returns the stored road lanes as a mapping from their respective IDs.

Returns
Stored road lanes as a mapping from their respective IDs
double GetStart ( ) const
inlineoverride

Returns the starting offset of the road lane section.

Returns
Starting offset of the road lane section
void SetInDirection ( bool inDirection )
inlineoverride

Sets the flag, if the lane section is in the reference direction or not.

Parameters
[in] inDirection Flag, if the road lane is in the reference direction or not
void SetLaneIndexOffset ( int laneIndexOffset )
inlineoverride

Sets the index offset for the road lanes in this section.

Parameters
[in] laneIndexOffset Index offset for the road lanes in this section
void SetId ( int Id )
inlineoverride

Sets the ID.

Parameters
[in] Id ID
bool GetInDirection ( ) const
inlineoverride

Returns if the lane section is in the reference direction or not.

Returns
Flag, if the lane section is in the reference direction or not
int GetLaneIndexOffset ( ) const
inlineoverride

Returns the index offset for the road lanes in this section.

Returns
Index offset for the road lanes in this section
int GetId ( ) const
inlineoverride

Returns the ID.

Returns
ID
RoadInterface* GetRoad ( ) const
inlineoverride

Returns the road from which this section is a part of.

Returns
Road from which this section is a part of
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadLink Class Reference

Public Member Functions | List of all members
RoadLink Class Reference

Class representing a link to a road. More...

Inheritance diagram for RoadLink:
[legend]
Collaboration diagram for RoadLink:
[legend]

Public Member Functions

RoadLinkType | GetType () const override
RoadLinkElementType | GetElementType () const override
const std::string & | GetElementId () const override
ContactPointType | GetContactPoint () const override
RoadLinkDirectionType | GetDirection () const override
RoadLinkSideType | GetSide () const override

Detailed Description

Class representing a link to a road.

Member Function Documentation

RoadLinkType GetType ( ) const
inlineoverride

Returns the RoadLinkType of the RoadLink.

Returns
RoadLinkType of the RoadLink
RoadLinkElementType GetElementType ( ) const
inlineoverride

Returns the RoadLinkElementType of the RoadLink.

Returns
RoadLinkElementType of the RoadLink
const std::string& GetElementId ( ) const
inlineoverride

Returns the ID of the RoadLink.

Returns
ID of the RoadLink
ContactPointType GetContactPoint ( ) const
inlineoverride

Returns the ContactPointType of the RoadLink.

Returns
ContactPointType of the RoadLink
RoadLinkDirectionType GetDirection ( ) const
inlineoverride

Returns the RoadLinkDirectionType of the RoadLink.

Returns
RoadLinkDirectionType of the RoadLink
RoadLinkSideType GetSide ( ) const
inlineoverride

Returns the RoadLinkSideType of the RoadLink.

Returns
RoadLinkSideType of the RoadLink
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadNetworkBuilder Class Reference

Public Member Functions | List of all members
RoadNetworkBuilder Class Reference

Public Member Functions

std::pair< RoadGraph, RoadGraphVertexMapping > Build ()

Member Function Documentation

std::pair<RoadGraph, RoadGraphVertexMapping> Build ( )

Converts the road netwerk of OpenDrive into a graph representation

Returns
graph of the road network and mapping from roads (with direction) to the vertices
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadNetworkElement Struct Reference

List of all members
RoadNetworkElement Struct Reference
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadObject Class Reference

Public Member Functions | List of all members
RoadObject Class Reference
Inheritance diagram for RoadObject:
[legend]
Collaboration diagram for RoadObject:
[legend]

Public Member Functions

std::string | GetId () const
Returns the unique identification string of the road object. More...
double | GetS () const
Returns the s coordinate of the road object. More...
double | GetT () const
Returns the t coordinate of the road object. More...
double | GetHdg () const
Returns the heading of the road object (relative to road direction) More...
bool | IsValidForLane (int laneId) const
Check, if road object is valid for provided lane id. More...
RoadObjectType | GetType () const
Returns the type of the road object. More...
double | GetLength () const
Returns the length of the road object. More...
double | GetWidth () const
Returns the width of the road object. More...

Member Function Documentation

std::string GetId ( ) const

Returns the unique identification string of the road object.

Returns
id
double GetS ( ) const

Returns the s coordinate of the road object.

Returns
s coordinate [m]
double GetT ( ) const

Returns the t coordinate of the road object.

Returns
t coordinate [m]
double GetHdg ( ) const

Returns the heading of the road object (relative to road direction)

Returns
heading [rad]
bool IsValidForLane ( int laneId ) const

Check, if road object is valid for provided lane id.

Parameters
[in] laneId lane id to test validity for
Returns
True if valid, false otherwise.
RoadObjectType GetType ( ) const

Returns the type of the road object.

Returns
type
double GetLength ( ) const

Returns the length of the road object.

Returns
length [m]
double GetWidth ( ) const

Returns the width of the road object.

Returns
width [m]
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadPosition Struct Reference

List of all members
RoadPosition Struct Reference

Position of a point on a specific lane. More...

Detailed Description

Position of a point on a specific lane.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RoadSignal Class Reference

Public Member Functions | List of all members
RoadSignal Class Reference

Class representing a road signal. More...

Inheritance diagram for RoadSignal:
[legend]
Collaboration diagram for RoadSignal:
[legend]

Public Member Functions

std::string | GetType () const override
Returns the type of the signal (e.g. code according to StVO) More...
std::string | GetSubType () const override
Returns the type of the signal (e.g. code according to StVO) More...
virtual std::string | GetId () const override
Returns the unique identification string of the signal. More...
double | GetValue () const override
Returns the value. More...
RoadSignalUnit | GetUnit () const override
Returns the unit. More...
std::string | GetText () const override
Returns the text on the signal. More...
double | GetS () const override
Returns the s coordinate of the signal. More...
double | GetT () const override
Returns the t coordinate of the signal. More...
RoadInterface * | GetRoad ()
bool | IsValidForLane (int laneId) const override
virtual double | GetHeight () const override
Returns the height of the signal. More...
virtual double | GetWidth () const override
Returns the width of the signal. More...
virtual double | GetLength () const
Returns the length of the signal. More...
virtual double | GetPitch () const
Returns the pitch of the signal. More...
virtual double | GetRoll () const
Returns the roll of the signal. More...
virtual double | GetYaw () const
Returns the yaw of the signal. More...
virtual bool | GetIsDynamic () const override
Returns true if the signal is dynamic. More...

Detailed Description

Class representing a road signal.

Member Function Documentation

std::string GetType ( ) const
override

Returns the type of the signal (e.g. code according to StVO)

Returns
type
std::string GetSubType ( ) const
override

Returns the type of the signal (e.g. code according to StVO)

Returns
type
virtual std::string GetId ( ) const
overridevirtual

Returns the unique identification string of the signal.

Returns
id
double GetValue ( ) const
override

Returns the value.

Returns
value
RoadSignalUnit GetUnit ( ) const
override

Returns the unit.

Returns
unit
std::string GetText ( ) const
override

Returns the text on the signal.

Returns
text
double GetS ( ) const
override

Returns the s coordinate of the signal.

Returns
s [m]
double GetT ( ) const
override

Returns the t coordinate of the signal.

Returns
s [m]
RoadInterface* GetRoad ( )
inline

Returns the road from which this section is a part of.

Returns
Road from which this section is a part of
bool IsValidForLane ( int laneId ) const
override

Returns if the signal is valid for a given lane

Parameters
[in] laneId lane Id of interest
Returns
true if signal is valid
virtual double GetHeight ( ) const
overridevirtual

Returns the height of the signal.

Returns
height [m]
virtual double GetWidth ( ) const
overridevirtual

Returns the width of the signal.

Returns
height [m]
virtual double GetLength ( ) const
virtual

Returns the length of the signal.

Returns
height [m]
virtual double GetPitch ( ) const
virtual

Returns the pitch of the signal.

Returns
height [m]
virtual double GetRoll ( ) const
virtual

Returns the roll of the signal.

Returns
height [m]
virtual double GetYaw ( ) const
virtual

Returns the yaw of the signal.

Returns
height [m]
virtual bool GetIsDynamic ( ) const
overridevirtual

Returns true if the signal is dynamic.

Returns
true if dynamic == "yes"
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RouteElement Struct Reference

List of all members
RouteElement Struct Reference

This represents one node on the road network graph of the world or in the routing graph of an agent. More...

Detailed Description

This represents one node on the road network graph of the world or in the routing graph of an agent.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RunStatistic Class Reference

List of all members
RunStatistic Class Reference
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: RunStatisticCalculation Class Reference

Static Public Member Functions | List of all members
RunStatisticCalculation Class Reference

The RunStatisticCalculation class provides helper functions for run statistic analysis. More...

Static Public Member Functions

static void | DetermineEgoCollision (RunStatistic &runStatistic, const RunResultInterface &runResult, WorldInterface *world)
Determines whether the ego had a collision and sets the related flag in the RunStatistic. More...
static void | DetermineEgoCollision (RunStatistic &runStatistic, const RunResultInterface &runResult, WorldInterface *world)
Determines whether the ego had a collision and sets the related flag in the RunStatistic. More...

Detailed Description

The RunStatisticCalculation class provides helper functions for run statistic analysis.

Member Function Documentation

static void DetermineEgoCollision | ( | RunStatistic & | runStatistic,
 |  | const RunResultInterface & | runResult,
 |  | WorldInterface * | world
 | ) |  |
static

Determines whether the ego had a collision and sets the related flag in the RunStatistic.

Parameters
[out] | runStatistic | Result is stored here
[in] | runResult | Structure to retrieve collisions from
[in] | world | Pointer to the world
static void DetermineEgoCollision | ( | RunStatistic & | runStatistic,
 |  | const RunResultInterface & | runResult,
 |  | WorldInterface * | world
 | ) |  |
static

Determines whether the ego had a collision and sets the related flag in the RunStatistic.

Parameters
[out] | runStatistic | Result is stored here
[in] | runResult | Structure to retrieve collisions from
[in] | world | Pointer to the world
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SampledGeometry Struct Reference

Public Member Functions | Public Attributes | List of all members
SampledGeometry Struct Reference

This struct is the result of the geometry sampling of one road section. More...

Public Member Functions

void Combine (SampledGeometry &other)
This is needed for calculating the curvature of the last joint. More...

Public Attributes

double endHeading
This is needed for calculating the curvature of the first joint.

Detailed Description

This struct is the result of the geometry sampling of one road section.

Member Function Documentation

void Combine ( SampledGeometry & other )

This is needed for calculating the curvature of the last joint.

Combine this SampledGeometry with another, that starts where this ends.

Parameters
other another SampledGeometry starting where this ends
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SampledProfiles Struct Reference

Static Public Member Functions | Friends | List of all members
SampledProfiles Struct Reference

The SampledProfiles struct constains the name of all profiles sampled by the DynamicProfileSampler. With this the DynamicAgentTypeGenerator can generate an AgentType. More...

Static Public Member Functions

static DynamicProfileSampler make (std::string agentProfileName, StochasticsInterface &stochastics, ProfilesInterface *profiles)
Creates a new DynamicProfileSampler which can be used to build an instance of this struct. More...

Friends

class DynamicProfileSampler

Detailed Description

The SampledProfiles struct constains the name of all profiles sampled by the DynamicProfileSampler. With this the DynamicAgentTypeGenerator can generate an AgentType.

An instance of this struct is aquired by calling the static make function and then sequentially calling all sample function on the returned DynamicProfileSampler.

Member Function Documentation

static DynamicProfileSampler make | ( | std::string | agentProfileName,
 |  | StochasticsInterface & | stochastics,
 |  | ProfilesInterface * | profiles
 | ) |  |
static

Creates a new DynamicProfileSampler which can be used to build an instance of this struct.

Parameters
agentProfileName | name of the AgentProfile samplied by the AgentProfileSampler
stochastics | Reference to the stochasticInterface
profiles | imported profiles from the ProfilesCatalog
Returns
new instance of DynamicProfileSampler
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SceneryConverter Class Reference

Public Member Functions | Protected Member Functions | Private Member Functions | List of all members
SceneryConverter Class Reference
Collaboration diagram for SceneryConverter:
[legend]

Public Member Functions

bool | ConvertRoads ()
void | ConvertObjects ()
Places all static traffic objects and all traffic signs in the world.

Protected Member Functions

void Log (CbkLogLevel logLevel, const char *file, int line, const std::string &message)

Private Member Functions

RoadLaneInterface * | GetOtherLane (RoadLaneSectionInterface *otherSection, int otherId)
RoadInterface * | GetConnectedRoad (RoadLinkInterface *roadLink)
void | MarkDirectionRoad (RoadInterface *road, bool inDirection)
bool | MarkDirections ()
bool | IndexElements ()
bool | ConnectLaneToLane (RoadLaneInterface *currentLane, ContactPointType currentContactPoint, RoadLaneInterface *otherLane)
bool | ConnectLaneToSection (RoadLaneInterface *currentLane, ContactPointType currentContactPoint, RoadLaneSectionInterface *otherLaneSection)
bool | ConnectLanes (RoadLaneSectionInterface *firstLaneSection, ContactPointType firstContactPoint, RoadLaneSectionInterface *secondLaneSection, ContactPointType secondContactPoint)
bool | ConnectRoadExternalWithElementTypeRoad (RoadInterface *road)
bool | ConnectExternalRoadSuccessor (const RoadInterface *currentRoad, const RoadInterface *otherRoad, RoadLaneSectionInterface *otherSection)
bool | ConnectExternalRoadPredecessor (const RoadInterface *currentRoad, const RoadInterface *otherRoad, RoadLaneSectionInterface *otherSection)
bool | ConnectRoadInternal (RoadInterface *road)
bool | ConnectJunction (const JunctionInterface *junction)
void | ConnectPathInJunction (const JunctionInterface *junction, const RoadInterface *incomingRoad, const RoadInterface *connectingRoad, const RoadInterface *outgoingRoad, ContactPointType incomingContactPoint, ContactPointType outgoingContactPoint, std::map< int, int > laneIdMapping)
bool | ConnectRoads ()
void | CreateTrafficSign (RoadSignalInterface *signal, Position position, const OWL::Interfaces::Lanes &lanes)
void | CreateRoadMarking (RoadSignalInterface *signal, Position position, const OWL::Interfaces::Lanes &lanes)

Detailed Description

Class for the convertion of a scenery, i.e. the roads in it; the road geometry is converted in class GeometryConverter.

Member Function Documentation

bool ConvertRoads ( )

Triggers the convertion process from OpenDrive to OSI in the following steps:

  • defines a unique direction within the road cluster (MarkDirections())
  • assigns IDs to OpenDrive lane sections
  • generates the mappings for lanes and lane sections from OpenDrive to OSI
  • then connects these sections
  • finally, triggers convertion of the road geometries
Returns
False if an error occurred, true otherwise
void Log | ( | CbkLogLevel | logLevel,
 |  | const char * | file,
 |  | int | line,
 |  | const std::string & | message
 | ) |  |
inlineprotected

Provides callback to LOG() macro

Parameters
[in] | logLevel | Importance of log
[in] | file | Name of file where log is called
[in] | line | Line within file where log is called
[in] | message | Message to log
RoadLaneInterface* GetOtherLane | ( | RoadLaneSectionInterface * | otherSection,
 |  | int | otherId
 | ) |  |
private

Returns the lane with the provided ID in the provided lane section.

Parameters
[in] | otherSection | OpenDrive lane section containing the lane
[in] | otherId | ID of the required lane
Returns
OpenDrive lane with the provided ID, if it exists in the provided lane section, nullptr otherwise
RoadInterface* GetConnectedRoad ( RoadLinkInterface * roadLink )
private

Returns the road from the scenery to which the provided link links to.

Preconditions:

  • Scenery has to be setup properly
Parameters
[in] roadLink OpenDrive road link to the desired road
Returns
Road which the provided link connects to, if it exists in the scenery, nullptr otherwise
void MarkDirectionRoad | ( | RoadInterface * | road,
 |  | bool | inDirection
 | ) |  |
private

Marks the direction of the provided road, on all of its lane sections and lanes within these lane sections to the provided value.

Parameters
[in] | road | OpenDrive road on which to set if it is in direction
[in] | inDirection | Specifies if road is in direction
bool MarkDirections ( )
private

Mark the directions of all roads in the scenery according to global direction definition.

Notes:

  • The first road of each cluster implictely defines the driving direction (OpenDrive lanes/roads which are connected with opposite directions will be converted to OSI lanes/sections which point into the same direction)
Returns
False if an error occurred, true otherwise
bool IndexElements ( )
private

Assigns unique IDs (beginning with 0) to all OpenDrive lane sections for all roads in the scenery.

Returns
True
bool ConnectLaneToLane | ( | RoadLaneInterface * | currentLane,
 |  | ContactPointType | currentContactPoint,
 |  | RoadLaneInterface * | otherLane
 | ) |  |
private

Connects the OSI representation of the two provided lanes.

Parameters
[in] | currentLane | First lane to connect
[in] | currentContactPoint | Contact point of the first lane
[in] | otherLane | Second lane to connect
[in] | otherContactPoint | Contact point of the second lane
Returns
False, if an error occurred, true otherwise
bool ConnectLaneToSection | ( | RoadLaneInterface * | currentLane,
 |  | ContactPointType | currentContactPoint,
 |  | RoadLaneSectionInterface * | otherLaneSection
 | ) |  |
private

Connects a lane to a lane section in OSI by connecting the predecessor and successor of the provided lane, which are in the provided lane section, to the provided line.

Parameters
[in] | currentLane | Lane to connect
[in] | currentContactPoint | Contact point of the lane
[in] | otherLaneSection | Lane section to connect
[in] | otherContactPoint | Contact point of the lane section
Returns
False, if an error occurred, true otherwise
bool ConnectLanes | ( | RoadLaneSectionInterface * | firstLaneSection,
 |  | ContactPointType | firstContactPoint,
 |  | RoadLaneSectionInterface * | secondLaneSection,
 |  | ContactPointType | secondContactPoint
 | ) |  |
private

Connects a lane section to a lane section in OSI by first connecting all lanes in the first section to the second section, then connecting all lanes in the second section to the first.

Notes:

  • OpenDrive center lanes are skipped (width=0 by convention)
Parameters
[in] | firstLaneSection | First lane section to connect
[in] | currentContactPoint | Contact point of the first lane section
[in] | secondLaneSection | Lane section to connect
[in] | secondContactPoint | Contact point of the second lane section
Returns
False, if an error occurred, true otherwise
bool ConnectRoadExternalWithElementTypeRoad ( RoadInterface * road )
private

Connects a road in the scenery to its predecessor and successor roads in OSI by connecting their respective lane sections. Only connects roads with roadlinktype Road

Parameters
[in] road Road which should be connected to its predecessors and successors
Returns
False, if an error occurred, true otherwise
bool ConnectExternalRoadSuccessor | ( | const RoadInterface * | currentRoad,
 |  | const RoadInterface * | otherRoad,
 |  | RoadLaneSectionInterface * | otherSection
 | ) |  |
private

Connects a road with another road by setting successor of road, section and lanes

Parameters
[in] | currentRoad | road which should be connected to its successor
[in] | otherRoad | successor of this currentRoad
[in] | otherSection | section on otherRoad to connect to
Returns
False, if an error occurred, true otherwise
bool ConnectExternalRoadPredecessor | ( | const RoadInterface * | currentRoad,
 |  | const RoadInterface * | otherRoad,
 |  | RoadLaneSectionInterface * | otherSection
 | ) |  |
private

Connects a road with another road by setting predecessor of road, section and lanes

Parameters
[in] | currentRoad | road which should be connected to its predecessor
[in] | otherRoad | predecessor of this currentRoad
[in] | otherSection | section on otherRoad to connect to
Returns
False, if an error occurred, true otherwise
bool ConnectRoadInternal ( RoadInterface * road )
private

Connects a road in the scenery internally in OSI by connecting all of its stored lane sections with their predecessors and successors.

Parameters
[in] road Road in which the lanes and lane sections should be connected
Returns
False, if an error occurred, true otherwise
bool ConnectJunction ( const JunctionInterface * junction )
private

Connects the incoming and connecting roads of the junction

Parameters
[in] junction Junction which should be connected
Returns
False, if an error occurred, true otherwise
void ConnectPathInJunction | ( | const JunctionInterface * | junction,
 |  | const RoadInterface * | incomingRoad,
 |  | const RoadInterface * | connectingRoad,
 |  | const RoadInterface * | outgoingRoad,
 |  | ContactPointType | incomingContactPoint,
 |  | ContactPointType | outgoingContactPoint,
 |  | std::map< int, int > | laneIdMapping
 | ) |  |
private

Connects a single path of a junction. It only sets the connections into the path, because the connections of the path itself are already set by ConnectRoadExternalWithElementTypeRoad

Parameters
[in] | incomingRoad | road going into the path
[in] | connectingRoad | connecting road == path
[in] | outgoingRoad | road going out of the path
[in] | incomingContactPoint | contactPoint on the path connected to the incomingRoad
[in] | outgoingContactPoint | contactPoint on the outgoing road connected to the path
[in] | laneIdMapping | mapping of the lane ids between the incoming road and the path
Returns
False, if an error occurred, true otherwise
bool ConnectRoads ( )
private

Connects OSI sections for all roads in the scenery internally and externally.

Returns
False, if an error occurred, true otherwise
void CreateTrafficSign | ( | RoadSignalInterface * | signal,
 |  | Position | position,
 |  | const OWL::Interfaces::Lanes & | lanes
 | ) |  |
private

Creates a traffic sign in OWL from an OpenDrive RoadSignal

Parameters
signal | OpenDrive specification of the sign
position | position of the sign in the world
lanes | lanes for which this sign is valid
void CreateRoadMarking | ( | RoadSignalInterface * | signal,
 |  | Position | position,
 |  | const OWL::Interfaces::Lanes & | lanes
 | ) |  |
private

Creates a road marking in OWL from an OpenDrive RoadSignal

Parameters
signal | OpenDrive specification of the road marking
position | position of the road marking in the world
lanes | lanes for which this road marking is valid
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SecondaryDriverTasksSignal Class Reference

Public Member Functions | List of all members
SecondaryDriverTasksSignal Class Reference
Inheritance diagram for SecondaryDriverTasksSignal:
[legend]
Collaboration diagram for SecondaryDriverTasksSignal:
[legend]

Public Member Functions

SecondaryDriverTasksSignal ()
Constructor.
SecondaryDriverTasksSignal (int indicatorState, bool hornSwitch, bool headLightSwitch, bool highBeamLightSwitch, bool flasher, ComponentState componentState)
Constructor.
SecondaryDriverTasksSignal (SecondaryDriverTasksSignal &other)
Constructor.
virtual operator std::string () const

Member Function Documentation

virtual operator std::string ( ) const
inlinevirtual

Returns the content/payload of the signal as an std::string

Returns
Content/payload of the signal as an std::string
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SensorDataSignal Class Reference

Public Member Functions | Public Attributes | List of all members
SensorDataSignal Class Reference
Inheritance diagram for SensorDataSignal:
[legend]
Collaboration diagram for SensorDataSignal:
[legend]

Public Member Functions

SensorDataSignal (osi3::SensorData sensorData)
Constructor.
virtual operator std::string () const

Public Attributes

osi3::SensorData sensorData
OSI SensorData payload of this signal.

Member Function Documentation

virtual operator std::string ( ) const
inlinevirtual

Returns the content/payload of the signal as an std::string

Returns
Content/payload of the signal as an std::string
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SensorDetectionResults Struct Reference

List of all members
SensorDetectionResults Struct Reference
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SensorDriverCalculations Class Reference

Public Member Functions | List of all members
SensorDriverCalculations Class Reference

Utility class for the sensor driver. More...

Public Member Functions

double GetLateralDistanceToObject (const std::string &roadId, const AgentInterface *otherObject)
Calculates the lateral distance (i.e. distance in t) between the own agent and another agent.

Detailed Description

Utility class for the sensor driver.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SensorDriverImplementation Class Reference

Public Member Functions | Public Attributes | Private Member Functions | Private Attributes | List of all members
SensorDriverImplementation Class Reference
Inheritance diagram for SensorDriverImplementation:
[legend]
Collaboration diagram for SensorDriverImplementation:
[legend]

Public Member Functions

SensorDriverImplementation (std::string componentName, bool isInit, int priority, int offsetTime, int responseTime, int cycleTime, StochasticsInterface *stochastics, WorldInterface *world, const ParameterInterface *parameters, PublisherInterface *const publisher, const CallbackInterface *callbacks, AgentInterface *agent)
Constructor. More...

Public Attributes

const std::string COMPONENTNAME = "SensorDriver"
Name of the component for debug output.

Private Member Functions

void | GetNewRoute ()
Calculates a new route for the agent and sets it in the EgoAgent.
void | UpdateGraphPosition ()
Updates the current position in the routing graph if neccessary.
virtual void | GetOwnVehicleInformation ()
Get sensor data concerning the own vehicle.
virtual void | GetTrafficRuleInformation ()
Get sensor data containing traffic rule information.
LaneInformationTrafficRules GetTrafficRuleLaneInformationEgo ()
Get traffic rule sensor data from the ego lane.
LaneInformationTrafficRules GetTrafficRuleLaneInformationLeft ()
Get traffic rule sensor data from the lane left of ego.
LaneInformationTrafficRules GetTrafficRuleLaneInformationRight ()
Get traffic rule sensor data from the lane right of ego.
virtual void | GetGeometryInformation ()
Get lane geometry sensor data.
LaneInformationGeometry GetGeometryLaneInformationEgo ()
Get lane geometry sensor data from the ego lane.
LaneInformationGeometry | GetGeometryLaneInformation (int relativeLaneId)
Get lane geometry sensor data from the lane left of ego.
const WorldObjectInterface * | GetObject (double visibilityDistance, int relativeLane, bool forwardSearch)
Returns the objects in the specified lane in front of (if forwardSearch) or behind (if not forwardSearch) the agent.
virtual void | GetSurroundingObjectsInformation ()
Get sensor data of surrounding objects.
virtual ObjectInformation | GetOtherObjectInformation (const WorldObjectInterface *surroundingObject)
Get information of one object.

Private Attributes

OwnVehicleInformation ownVehicleInformation
Struct for all sensor data concerning the own vehicle.
TrafficRuleInformation trafficRuleInformation
Struct for all sensor data concerning traffic rule information.
GeometryInformation geometryInformation
Struct for all sensor data concerning lane geometry information.
SurroundingObjects surroundingObjects
Struct for all sensor data concerning surrounding objects.

Detailed Description

Constructor & Destructor Documentation

SensorDriverImplementation | ( | std::string | componentName,
 |  | bool | isInit,
 |  | int | priority,
 |  | int | offsetTime,
 |  | int | responseTime,
 |  | int | cycleTime,
 |  | StochasticsInterface * | stochastics,
 |  | WorldInterface * | world,
 |  | const ParameterInterface * | parameters,
 |  | PublisherInterface *const | publisher,
 |  | const CallbackInterface * | callbacks,
 |  | AgentInterface * | agent
 | ) |  |

Constructor.

Parameters
[in] | componentName | Name of the component
[in] | isInit | Query whether the component was just initialized
[in] | priority | Priority of the component
[in] | offsetTime | Offset time of the component
[in] | responseTime | Response time of the component
[in] | cycleTime | Cycle time of this components trigger task [ms]
[in] | stochastics | Provides access to the stochastics functionality of the framework
[in] | world | Provides access to world representation
[in] | parameters | Interface provides access to the configuration parameters
[in] | pubisher | Instance provided by the framework
[in] | callbacks | Interface for callbacks to framework
[in] | agent | This interface provides access to agent parameters, properties, attributes and dynamic states
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SensorDriverSignal Class Reference

Public Member Functions | Private Attributes | List of all members
SensorDriverSignal Class Reference
Inheritance diagram for SensorDriverSignal:
[legend]
Collaboration diagram for SensorDriverSignal:
[legend]

Public Member Functions

SensorDriverSignal (OwnVehicleInformation ownVehicleInformation, TrafficRuleInformation trafficRuleInformation, GeometryInformation geometryInformation, SurroundingObjects surroundingObjects)
Constructor.
virtual | operator std::string () const
virtual OwnVehicleInformation | GetOwnVehicleInformation () const
Returns the information about the own vehicle.
virtual TrafficRuleInformation | GetTrafficRuleInformation () const
Returns the traffic rule information.
virtual GeometryInformation | GetGeometryInformation () const
Returns the lane geometry information.
virtual SurroundingObjects | GetSurroundingObjects () const
Returns the information about the surrouding objects.

Private Attributes

OwnVehicleInformation ownVehicleInformation
Struct for all sensor data concerning the own vehicle.
TrafficRuleInformation trafficRuleInformation
Struct for all sensor data concerning mesosopic information.
GeometryInformation geometryInformation
Struct for all sensor data concerning mesosopic information.
SurroundingObjects surroundingObjects
Struct for all sensor data concerning surrounding objects.

Member Function Documentation

virtual operator std::string ( ) const
inlinevirtual

Returns the content/payload of the signal as an std::string

Returns
Content/payload of the signal as an std::string
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SensorFusionHelperFunctions Class Reference

List of all members
SensorFusionHelperFunctions Class Reference
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SensorRecordStateImplementation Class Reference

Public Member Functions | List of all members
SensorRecordStateImplementation Class Reference

records the state of the agent. More...

Inheritance diagram for SensorRecordStateImplementation:
[legend]
Collaboration diagram for SensorRecordStateImplementation:
[legend]

Public Member Functions

void | UpdateInput (int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)
Update Inputs. More...
void | UpdateOutput (int localLinkId, std::shared_ptr< SignalInterface const > &data, int time)
Update outputs. More...
void | Trigger (int time)
Process data within component. More...

Detailed Description

records the state of the agent.

This component is used to record the state of agent in every single timestep.

Member Function Documentation

void UpdateInput | ( | int | localLinkId,
 |  | const std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |

Update Inputs.

Function is called by framework when another component delivers a signal over a channel to this component (scheduler calls update taks of other component).

Refer to module description for input channels and input ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentInput"
[in] | data | Referenced signal (copied by sending component)
[in] | time | Current scheduling time
void UpdateOutput | ( | int | localLinkId,
 |  | std::shared_ptr< SignalInterface const > & | data,
 |  | int | time
 | ) |  |

Update outputs.

Function is called by framework when this Component.has to deliver a signal over a channel to another component (scheduler calls update task of this component).

Refer to module description for output channels and output ids.

Parameters
[in] | localLinkId | Corresponds to "id" of "ComponentOutput"
[out] | data | Referenced signal (copied by this component)
[in] | time | Current scheduling time
void Trigger ( int time )

Process data within component.

Function is called by framework when the scheduler calls the trigger task of this component.

Refer to module description for information about the module's task.

Parameters
[in] time Current scheduling time
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SignalVector< DT > Class Template Reference

Public Member Functions | Public Attributes | List of all members
SignalVector< DT > Class Template Reference

Primitive signal class for vectors. More...

Inheritance diagram for SignalVector< DT >:
[legend]
Collaboration diagram for SignalVector< DT >:
[legend]

Public Member Functions

virtual operator std::string () const
Converts signal to string.

Public Attributes

std::vector< DT > value
signal content

Detailed Description

template<typename DT>
class SignalVector< DT >

Primitive signal class for vectors.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SimulationTimeCondition Class Reference

List of all members
SimulationTimeCondition Class Reference
Inheritance diagram for SimulationTimeCondition:
[legend]
Collaboration diagram for SimulationTimeCondition:
[legend]
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnPointDependencies Struct Reference

List of all members
SpawnPointDependencies Struct Reference
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnPointLibraryInfo Struct Reference

List of all members
SpawnPointLibraryInfo Struct Reference
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnPointPreRunCommon Class Reference

Public Member Functions | Private Member Functions | List of all members
SpawnPointPreRunCommon Class Reference

spawns agents for all scenarios More...

Inheritance diagram for SpawnPointPreRunCommon:
[legend]
Collaboration diagram for SpawnPointPreRunCommon:
[legend]

Public Member Functions

Agents Trigger (int time) override
Trigger creates the agents for the spawn points. More...

Private Member Functions

Agents | GenerateAgentsForRange (const LaneId &laneId, const RoadId &roadId, const Range &range)
Generates agents in specified lane based on specified range. More...
std::optional< SpawnInfo > | GetNextSpawnCarInfo (const RoadId &roadId, const LaneId &laneId, const Range &range, const double gapInSeconds, const double velocity, const double agentFrontLength, const double agentRearLength) const
Get SpawnInfo for the next agent that should be spawned. More...
bool | AreSpawningCoordinatesValid (const std::string &roadId, const int laneId, const double sPosition, const double offset, const VehicleModelParameters &vehicleModelParameters)
Checks validity of spawning coordinates. More...
bool | IsOffsetValidForLane (const std::string &roadId, const int laneId, const double distanceFromStart, const double offset, const double vehicleWidth)
Checks if offset for lane is valid. More...
bool | NewAgentIntersectsWithExistingAgent (const int laneId, const double sPosition, const double offset, const VehicleModelParameters &vehicleModelParameters) const
NewAgentIntersectsWithExistingAgent. More...
bool | CalculateSpawnParameter (AgentBlueprintInterface *agentBlueprint, const SpawnInfo &spawnInfo)
CalculateSpawnParameter. More...
void | LogError (const std::string &message)
Logs a message for error mode. More...

Detailed Description

spawns agents for all scenarios

This class implements the entire SpawnPointPreRunCommon logic. The spawnpoint calls the agentsampler to fill out all probability related parameters of the blueprint. The spawnpoint then adds the spawning depended parameters to the agentblueprint. The agentblueprint is then forwarded to the AgentFactory for instantiation.

Member Function Documentation

Agents Trigger ( int time )
override

Trigger creates the agents for the spawn points.

Returns
the created agents
Agents GenerateAgentsForRange | ( | const LaneId & | laneId,
 |  | const RoadId & | roadId,
 |  | const Range & | range
 | ) |  |
private

Generates agents in specified lane based on specified range.

Parameters
[in] | laneId | Id of the lane to spawn agents in.
[in] | roadId | Id of the road to spawn agents in.
[in] | range | Range in which to spawn agents.
Returns
std::optional<SpawnInfo> GetNextSpawnCarInfo | ( | const RoadId & | roadId,
 |  | const LaneId & | laneId,
 |  | const Range & | range,
 |  | const double | gapInSeconds,
 |  | const double | velocity,
 |  | const double | agentFrontLength,
 |  | const double | agentRearLength
 | ) |  | const
 private

Get SpawnInfo for the next agent that should be spawned.

Parameters
[in] | roadId | Id of the road to spawn agents in.
[in] | laneId | Id of the lane in which new agent should be spawned.
[in] | range | Range of the lane in which new agent should be spawned.
[in] | gapInSeconds | Gap between new agent and other agents in the lane.
[in] | velocity | Velocity of the new agent.
[in] | agentFrontLength
[in] | agentRearLength
Returns
SpawnInfo for new agent.
bool AreSpawningCoordinatesValid | ( | const std::string & | roadId,
 |  | const int | laneId,
 |  | const double | sPosition,
 |  | const double | offset,
 |  | const VehicleModelParameters & | vehicleModelParameters
 | ) |  |
private

Checks validity of spawning coordinates.

Parameters
[in] | roadId | Id of the road in which agent is to be spawned.
[in] | laneId | Id of the lane in which agent is to be spawned.
[in] | sPosition | Position on the road in which agent is to be spawned.
[in] | offset
[in] | vehicleModelParameters | Contains information about the vehicle model.
Returns
true if valid. false if not valid.
bool IsOffsetValidForLane | ( | const std::string & | roadId,
 |  | const int | laneId,
 |  | const double | distanceFromStart,
 |  | const double | offset,
 |  | const double | vehicleWidth
 | ) |  |
private

Checks if offset for lane is valid.

Parameters
[in] | roadId | Id of the road in which agent is to be spawned.
[in] | laneId | Id of the lane in which agent is to be spawned.
[in] | distanceFromStart | Distance from the start of the road.
[in] | offset
[in] | vehicleWidth | Width of the vehicle.
Returns
true if valid. false if not valid.
bool NewAgentIntersectsWithExistingAgent | ( | const int | laneId,
 |  | const double | sPosition,
 |  | const double | offset,
 |  | const VehicleModelParameters & | vehicleModelParameters
 | ) |  | const
 private

NewAgentIntersectsWithExistingAgent.

Parameters
[in] | laneId | Id of the lane in which agent is to be spawned.
[in] | sPosition | Position along the road where agent is to be spawned.
[in] | offset
[in] | vehicleModelParameters | Contains information about the vehicle model.
Returns
returns true if new agent intersects with existing agent. returns false if not.
bool CalculateSpawnParameter | ( | AgentBlueprintInterface * | agentBlueprint,
 |  | const SpawnInfo & | spawnInfo
 | ) |  |
private

CalculateSpawnParameter.

Parameters
[in] | agentBlueprint | AgentBlueprint for new agent.
[in] | laneId | Id of lane in which new agent should be spawned.
[in] | spawnInfo | SpawnInfo of new agent.
Returns
return true if successful
void LogError ( const std::string & message )
private

Logs a message for error mode.

Logs a message for error mode.

Parameters
[in] message Logged message.
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnPointRuntimeCommon Class Reference

Public Member Functions | Private Member Functions | List of all members
SpawnPointRuntimeCommon Class Reference
Inheritance diagram for SpawnPointRuntimeCommon:
[legend]
Collaboration diagram for SpawnPointRuntimeCommon:
[legend]

Public Member Functions

Agents Trigger (int time) override
Trigger creates the agents for the spawn points. More...

Private Member Functions

SpawnDetails | GenerateSpawnDetailsForLane (const SpawnPosition sceneryInformation, int time)
GenerateSpawnDetailsForLane Generates new spawn details for the specified lane. More...
void | LogError (const std::string &message)
LogError logs an error and throws. More...
void | CalculateSpawnParameter (AgentBlueprintInterface *agentBlueprint, const RoadId &roadId, const LaneId laneId, const SPosition sPosition, const double velocity) const
CalculateSpawnParameter. More...

Member Function Documentation

Agents Trigger ( int time )
override

Trigger creates the agents for the spawn points.

Returns
the created agents
SpawnDetails GenerateSpawnDetailsForLane | ( | const SpawnPosition | sceneryInformation,
 |  | int | time
 | ) |  |
private

GenerateSpawnDetailsForLane Generates new spawn details for the specified lane.

Parameters
laneId the laneId for which to get the spawn details
Returns
the spawn details for the lane
void LogError ( const std::string & message )
private

LogError logs an error and throws.

Parameters
message the message for the error to log
void CalculateSpawnParameter | ( | AgentBlueprintInterface * | agentBlueprint,
 |  | const RoadId & | roadId,
 |  | const LaneId | laneId,
 |  | const SPosition | sPosition,
 |  | const double | velocity
 | ) |  | const
 private

CalculateSpawnParameter.

Parameters
[in] | agentBlueprint | AgentBlueprint for new agent.
[in] | laneId | Id of lane in which new agent should be spawned.
[in] | spawnInfo | SpawnInfo of new agent.
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpawnPointScenario Class Reference

Public Member Functions | Private Member Functions | List of all members
SpawnPointScenario Class Reference

spawns agents for all scenarios More...

Inheritance diagram for SpawnPointScenario:
[legend]
Collaboration diagram for SpawnPointScenario:
[legend]

Public Member Functions

Agents Trigger (int time) override
Trigger creates the agents for the spawn points. More...

Private Member Functions

bool | ValidateOverlappingAgents (const STCoordinates &stCoordinates, const openScenario::LanePosition &lanePosition, const VehicleModelParameters &vehicleModelParameters)
Validates if there are already existing agents at a LanePosition. More...
bool | ValidateSTCoordinatesOnLane (const STCoordinates &stCoordinate, const openScenario::LanePosition &lanePosition, const double vehicleWidth)
Checks if the offset is valid for a specific lane. More...
STCoordinates | GetSTCoordinates (const openScenario::LanePosition &lanePosition, const VehicleModelParameters &vehicleModelParameters)
This method defines the S and T coordinate for a new agent, which is spawned based on a LanePosition. More...
SpawnParameter | CalculateSpawnParameter (const SpawnInfo &spawnInfo, const VehicleModelParameters &vehicleModelParameters)
Creates new SpawnParameter for the AgentBlueprint. More...
double | CalculateAttributeValue (const openScenario::StochasticAttribute &attribute)
Samples a value based on stochastics. More...
std::optional< Route > | GetRoute (const std::vector< RouteElement > &roads)
Converts the imported route from OpenScenario into a graph. More...
void | LogError (const std::string &message)
Logs a error message. More...

Detailed Description

spawns agents for all scenarios

This class implements a SpawnPointInterface which is used by the framework to fill out AgentBlueprints. The spawnpoint calls the agentsampler to fill out all probability related parameters of the blueprint. The spawnpoint then adds the spawning depended parameters to the agentblueprint. The agentblueprint is then returned to the framework.

Member Function Documentation

Agents Trigger ( int time )
override

Trigger creates the agents for the spawn points.

Returns
the created agents
bool ValidateOverlappingAgents | ( | const STCoordinates & | stCoordinates,
 |  | const openScenario::LanePosition & | lanePosition,
 |  | const VehicleModelParameters & | vehicleModelParameters
 | ) |  |
private

Validates if there are already existing agents at a LanePosition.

Parameters
[in] | stCoordinates | stCoordinates of position being validates
[in] | lanePosition | lanePosition containing road and lane id
[in] | vehicleModelParameters | vehicleModelParameters of the new agent
Returns
true, if new LanePosition does not overlap with existing agents
bool ValidateSTCoordinatesOnLane | ( | const STCoordinates & | stCoordinate,
 |  | const openScenario::LanePosition & | lanePosition,
 |  | const double | vehicleWidth
 | ) |  |
private

Checks if the offset is valid for a specific lane.

Checks if the vehicle is more than 50% inside the lane and is not placed on an invalid lane

Parameters
[in] | stCoordinates | stCoordinates of position being validates
[in] | lanePosition | lanePosition containing road and lane id
[in] | vehicleWidth | width of the new agent
Returns
true if valid. false if not valid.
STCoordinates GetSTCoordinates | ( | const openScenario::LanePosition & | lanePosition,
 |  | const VehicleModelParameters & | vehicleModelParameters
 | ) |  |
private

This method defines the S and T coordinate for a new agent, which is spawned based on a LanePosition.

If the LanePosition is based on stochastics the SpawnPoint will try to place up to 5 different samples. If no valid S and T coordinates can be found, an error is thrown.

Parameters
[in] | lanePosition | Id of the referenced openDrive road
[in] | vehicleModelParameters | Parameter of the vehicle
Returns
valid S and T coordinates of a new agent
SpawnParameter CalculateSpawnParameter | ( | const SpawnInfo & | spawnInfo,
 |  | const VehicleModelParameters & | vehicleModelParameters
 | ) |  |
private

Creates new SpawnParameter for the AgentBlueprint.

Parameters
[in] | spawnInfo | Containing spawn information of the scenario file
[in] | vehicleModelParameters | Parameter of the vehicle
Returns
Valid SpawnParameter
double CalculateAttributeValue ( const openScenario::StochasticAttribute & attribute )
private

Samples a value based on stochastics.

Parameters
[in] attribute
Returns
value
std::optional<Route> GetRoute ( const std::vector< RouteElement > & roads )
private

Converts the imported route from OpenScenario into a graph.

Parameters
[in] roads route from OpenScenario
Returns
graph of road network from agent's perspective with target node as given by OpenScenario, nullopt if no road in OpenScenario defined
void LogError ( const std::string & message )
private

Logs a error message.

Logs a error message.

Parameters
[in] message Logged message.
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SpeedActionSignal Class Reference

Public Member Functions | List of all members
SpeedActionSignal Class Reference

Signal class. More...

Inheritance diagram for SpeedActionSignal:
[legend]
Collaboration diagram for SpeedActionSignal:
[legend]

Public Member Functions

SpeedActionSignal ()
Constructor.
SpeedActionSignal (SpeedActionSignal &other)
Constructor.
SpeedActionSignal (ComponentState componentState, const double targetSpeed, const double acceleration)
Constructor.
virtual operator std::string () const

Detailed Description

Signal class.

Member Function Documentation

virtual operator std::string ( ) const
inlinevirtual

Returns the content/payload of the signal as an std::string

Returns
Content/payload of the signal as an std::string
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: STCoordinates Struct Reference

List of all members
STCoordinates Struct Reference
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SteeringController Class Reference

Public Member Functions | Protected Attributes | List of all members
SteeringController Class Reference
Collaboration diagram for SteeringController:
[legend]

Public Member Functions

double | CalculateSteeringAngle (int time)
Calculates the steering angle for a given timestep. More...
void | SetLateralInput (const LateralSignal &lateralSignal)
Sets the lateral input, which contains the desired lateral position. More...
void | SetVehicleParameter (const double &steeringRatio, const double &maximumSteeringWheelAngleAmplitude, const double &wheelbase)
Sets the vehicle parameters. This should ideally only be called once. More...
void | SetVelocityAndSteeringWheelAngle (const double &velocity, const double &steeringWheelAngle)
Sets the current velocity and the current steeringwheel angle of the vehicle. More...

Protected Attributes

double | in_velocity = 0.0
current velocity
double | in_steeringWheelAngle = 0.0
current angle of the steering wheel
double | in_steeringRatio = 10.7
The steering ratio of the vehicle.
double | in_steeringMax = 180.0
The maximum steering wheel angle of the car in both directions in degree.
double | in_wheelBase = 2.89
The wheelbase of the car in m.
double | tAverage {0.}
Time to Average regulation over.
const double | RadiantToDegree = 57.295779513082320876798154814105
Helper constant to convert radiant into degree.
int | timeLast {-100}
Previous scheduling time (for calculation of cycle time lenght).
double | meanCurvatureToNearPointSmoothLast {0.}
running average of mean curvature up to NearPoint
double | meanCurvatureToFarPointSmoothLast {0.}
running average of mean curvature from NearPoint up to FarPoint
double | curvatureRoadSmoothLast {0.}
running average of kappaRoad at referencepoint

Member Function Documentation

double CalculateSteeringAngle ( int time )

Calculates the steering angle for a given timestep.

Parameters
[in] time Current scheduling time

return steering angle

void SetLateralInput ( const LateralSignal & lateralSignal )
inline

Sets the lateral input, which contains the desired lateral position.

Parameters
[in] lateralSignal LateralSignal
void SetVehicleParameter | ( | const double & | steeringRatio,
 |  | const double & | maximumSteeringWheelAngleAmplitude,
 |  | const double & | wheelbase
 | ) |  |
inline

Sets the vehicle parameters. This should ideally only be called once.

Parameters
[in] | steeringRatio | steeringRatio
[in] | maximumSteeringWheelAngleAmplitude | maximumSteeringWheelAngleAmplitude
[in] | wheelbase | wheelbase
void SetVelocityAndSteeringWheelAngle | ( | const double & | velocity,
 |  | const double & | steeringWheelAngle
 | ) |  |
inline

Sets the current velocity and the current steeringwheel angle of the vehicle.

Parameters
[in] | velocity | Current velocity
[in] | steeringWheelAngle | Current steeringwheel angle
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SteeringSignal Class Reference

Public Member Functions | List of all members
SteeringSignal Class Reference

Signal class. More...

Inheritance diagram for SteeringSignal:
[legend]
Collaboration diagram for SteeringSignal:
[legend]

Public Member Functions

SteeringSignal (ComponentState componentState, double steeringWheelAngle)
Constructor.
virtual operator std::string () const

Detailed Description

Signal class.

Member Function Documentation

virtual operator std::string ( ) const
inlinevirtual

Returns the content/payload of the signal as an std::string

Returns
Content/payload of the signal as an std::string
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Stream< T > Class Template Reference

Public Member Functions | List of all members
Stream< T > Class Template Reference

Public Member Functions

Stream< T > | Reverse () const
Returns an element stream that has the same lanes in reverse order.
double | GetPositionByElementAndS (const T &element, double sCoordinate) const
std::pair< double, const T * > | GetElementAndSByPosition (double position) const
Returns the element and s coordinate corresponding to the given position on the stream.
bool | Contains (const T &element) const
Returns true if the specified element is contained in this element stream, false otherwise.

Detailed Description

template<typename T>
class Stream< T >

This class represent a consecutive sequence of elements. It is used by various queries to search along consecutive elements within a range starting at some start point The elements supported by this class are: OWL::Lane* OWL::Road*

Member Function Documentation

double GetPositionByElementAndS | ( | const T & | element,
 |  | double | sCoordinate
 | ) |  | const

Transform the sCoordinate on the given element to a position on the stream The element must be part of the stream

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: StreamInfo< T > Struct Template Reference

Public Member Functions | Public Attributes | List of all members
StreamInfo< T > Struct Template Reference

Public Member Functions

StreamInfo ()=default
Specifies whether the direction of the element is the same as the direction of the stream.
double | GetStreamPosition (double elementPosition) const
double | StartS () const
Returns the element stream position of the start of lane.
double | EndS () const
Returns the element stream position of the end of lane.

Public Attributes

double | sOffset
element represented by this object
bool | inStreamDirection
S Offset of the start point of the element from the beginning of the stream.

Detailed Description

template<typename T>
struct StreamInfo< T >

This class represents one element of a Stream. StreamInfo can contain elements of the following types: OWL::Lane OWL::Road

Member Function Documentation

double GetStreamPosition ( double elementPosition ) const
inline

Transform the s coordinate on the element to the s coordinate on the element stream

Parameters
elementPosition position relative to the start of the element
Returns
position relative to the start of the element stream

Here is the caller graph for this function:

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: SurroundingObjects Struct Reference

Public Attributes | List of all members
SurroundingObjects Struct Reference
Collaboration diagram for SurroundingObjects:
[legend]

Public Attributes

ObjectInformation objectFront
Next object in the same lane.
ObjectInformation objectRear
Closest object behind the agent in the same lane.
ObjectInformation objectFrontLeft
Next object in the lane to the left.
ObjectInformation objectRearLeft
Closest object behind the agent in the lane to the left.
ObjectInformation objectFrontRight
Next object in the lane to the right.
ObjectInformation objectRearRight
Closest object behind the agent in the lane to the right.

Detailed Description

This struct contains data of the objects surrounding the own agent as seen by the driver. For all cases mainLaneId is used as own lane

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Tire Class Reference

List of all members
Tire Class Reference

Static tire model based on TMEASY by Rill et al. More...

Detailed Description

Static tire model based on TMEASY by Rill et al.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TrafficHelperFunctions Class Reference

Static Public Member Functions | List of all members
TrafficHelperFunctions Class Reference

Containing general static functions to evaluate traffic situations. More...

Static Public Member Functions

static double | CalculateNetTimeGap (double vRear, double netDistance)
Calculates the net time gap between two (moving) objects. More...
template<typename T >
static T | ValueInBounds (const T &low, const T &value, const T &high)
Limits a value between a lower and an upper limit. More...
static bool | WillCrashDuringBrake (double sDelta, double vEgo, double aEgo, double vFront, double aFront)
Calculates if two agents will collide during braking. More...
static bool | WillCrash (double sDelta, double vEgo, double assumedBrakeAccelerationEgo, double vFront, double aFront, double assumedTtb)
Calculates if two agents will collide during braking. More...

Detailed Description

Containing general static functions to evaluate traffic situations.

Member Function Documentation

static double CalculateNetTimeGap | ( | double | vRear,
 |  | double | netDistance
 | ) |  |
inlinestatic

Calculates the net time gap between two (moving) objects.

Time gap is the time until two objects collide if the front object stands still and the velocity of the rear object remains unchanged.

Net in this context means that the carlengths are already substracted from the caller, i.e. netDistance = |sDist| - c where c REK-usually {carlengthEffective, carlength} More sophisticated would be c = dist(refPointRear, FrontEdgeRear) + dist(refPointFront, RearEdgeFront) + MinGap where MinGap = 0 for true TTC, >0 for estimated TTC with a safety gap

Default values of the function: -1 | netDistance < 0 0 | netDistance = 0 netDistance | vRear <= 1

Java: computeNetGap

Parameters
[in] | vRear | velocity of the rear object
[in] | netDistance | distance between the objects
Returns
time gap between the two objects
static T ValueInBounds | ( | const T & | low,
 |  | const T & | value,
 |  | const T & | high
 | ) |  |
inlinestatic

Limits a value between a lower and an upper limit.

Returns low | value < low value | low <= value < high high | value >= high

Parameters
[in] | low | lower limit
[in] | value | the value to be bounded
[in] | high | higher limit
Returns
bounded value
static bool WillCrashDuringBrake | ( | double | sDelta,
 |  | double | vEgo,
 |  | double | aEgo,
 |  | double | vFront,
 |  | double | aFront
 | ) |  |
inlinestatic

Calculates if two agents will collide during braking.

/details validates if cars crash during brake phase if velocity and acceleration of agents will be the same.

Parameters
[in] | sDelta | distance between both agents
[in] | vEgo | velocity ego
[in] | aEgo | acceleration ego
[in] | vFront | velocity front
[in] | aFront | acceleration front
Returns
true if collision would happen

Here is the caller graph for this function:

static bool WillCrash | ( | double | sDelta,
 |  | double | vEgo,
 |  | double | assumedBrakeAccelerationEgo,
 |  | double | vFront,
 |  | double | aFront,
 |  | double | assumedTtb
 | ) |  |
inlinestatic

Calculates if two agents will collide during braking.

validates if two cars crash within time to brake if velocity and acceleration of agents will be the same. Triggers WillCrashDuringBrake

Parameters
[in] | sDelta | distance between both agents
[in] | vEgo | velocity rear agent (ego)
[in] | aEgo | acceleration rear agent (ego)
[in] | vFront | velocity front
[in] | aFront | acceleratin front
[in] | assumedTtb | assumed time to brake
Returns
true if collision would happen

Here is the call graph for this function:

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TrafficObjectAdapter Class Reference

List of all members
TrafficObjectAdapter Class Reference
Inheritance diagram for TrafficObjectAdapter:
[legend]
Collaboration diagram for TrafficObjectAdapter:
[legend]
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TrafficRuleInformation Struct Reference

Public Attributes | List of all members
TrafficRuleInformation Struct Reference

This struct contains infrastructure information of surrounding lanes that are used to establish traffic rules. More...

Collaboration diagram for TrafficRuleInformation:
[legend]

Public Attributes

LaneInformationTrafficRules laneLeft
Data about the lane to left (in driving direction) of the mainLane.
LaneInformationTrafficRules laneEgo
Data about the lane the where the middle of the front of the agent is (i.e. mainLane)
LaneInformationTrafficRules laneRight
Data about the lane to right (in driving direction) of the mainLane.
std::vector< LaneMarking::Entity > | laneMarkingsLeft
List of lane markings on the left side of mainLane.
std::vector< LaneMarking::Entity > | laneMarkingsRight
List of lane markings on the right side of mainLane.
std::vector< LaneMarking::Entity > | laneMarkingsLeftOfLeftLane
List of lane markings on the left side of lane to the left.
std::vector< LaneMarking::Entity > | laneMarkingsRightOfRightLane
List of lane markings on the right side of lane to the right.

Detailed Description

This struct contains infrastructure information of surrounding lanes that are used to establish traffic rules.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TrajectorySignal Class Reference

Public Member Functions | List of all members
TrajectorySignal Class Reference

Signal class. More...

Inheritance diagram for TrajectorySignal:
[legend]
Collaboration diagram for TrajectorySignal:
[legend]

Public Member Functions

TrajectorySignal ()
Constructor.
TrajectorySignal (TrajectorySignal &other)
Constructor.
TrajectorySignal (ComponentState componentState, openScenario::Trajectory trajectory)
Constructor.
virtual operator std::string () const

Detailed Description

Signal class.

Member Function Documentation

virtual operator std::string ( ) const
inlinevirtual

Returns the content/payload of the signal as an std::string

Returns
Content/payload of the signal as an std::string
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TtcCalculations Class Reference

Classes | Static Public Member Functions | Static Private Member Functions | List of all members
TtcCalculations Class Reference

Containing functions to calculate time to collision of two objects. More...

Classes

struct TtcParameters
Structure to hold all necessary world object parameters for TTC calculation. More...

Static Public Member Functions

static double CalculateObjectTTC (const AgentInterface &agent, const WorldObjectInterface &detectedObject, double maxTtc, double collisionDetectionLongitudinalBoundary, double collisionDetectionLateralBoundary, double cycleTime)
Calculates the time to collision between two (moving) objects. More...

Static Private Member Functions

static TtcParameters | GetTTCObjectParameters (const WorldObjectInterface *object, double collisionDetectionLongitudinalBoundary, double collisionDetectionLateralBoundary)
Retrieves the parameters to calculate the TTC for a world object. More...
static polygon_t | CalculateBoundingBox (const TtcParameters parameters)
Calculates the bounding box of world objects in world coordinates. More...
static void | PropagateParametersForward (TtcParameters &parameters, const double timestep)
Propagates a world object forward by one timestep. More...

Detailed Description

Containing functions to calculate time to collision of two objects.

Member Function Documentation

static double CalculateObjectTTC | ( | const AgentInterface & | agent,
 |  | const WorldObjectInterface & | detectedObject,
 |  | double | maxTtc,
 |  | double | collisionDetectionLongitudinalBoundary,
 |  | double | collisionDetectionLateralBoundary,
 |  | double | cycleTime
 | ) |  |
inlinestatic

Calculates the time to collision between two (moving) objects.

Time to collision (TTC) is the time until two objects collide if their accelerations remain unchanged.

Parameters
[in] | vRear | velocity of the rear object
[in] | vFront | velocity of the front object
[in] | netDistance | distance between the objects
Returns
time to collsion between the two objects

Here is the call graph for this function:

static TtcParameters GetTTCObjectParameters | ( | const WorldObjectInterface * | object,
 |  | double | collisionDetectionLongitudinalBoundary,
 |  | double | collisionDetectionLateralBoundary
 | ) |  |
inlinestaticprivate

Retrieves the parameters to calculate the TTC for a world object.

Parameters
[in] | object | world object
[in] | collisionDetectionLongitudinalBoundary | longitudinal padding for collision detection
[in] | collisionDetectionLateralBoundary | lateral padding for collision detection
Returns
parameters needed for TTC calculation

Here is the caller graph for this function:

static polygon_t CalculateBoundingBox ( const TtcParameters parameters )
inlinestaticprivate

Calculates the bounding box of world objects in world coordinates.

Parameters
[in] parameters current state of the world objects reference point
Returns
bounding box in world coordinates
static void PropagateParametersForward | ( | TtcParameters & | parameters,
 |  | const double | timestep
 | ) |  |
inlinestaticprivate

Propagates a world object forward by one timestep.

Parameters
[in] | parameters | current state of the world objects reference point
[in] | timestep | time resolution of the TTC simulation
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: TtcCalculations::TtcParameters Struct Reference

  • TtcCalculations
  • TtcParameters
List of all members
TtcCalculations::TtcParameters Struct Reference

Structure to hold all necessary world object parameters for TTC calculation. More...

Detailed Description

Structure to hold all necessary world object parameters for TTC calculation.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: VehicleCompToCompCtrlSignal Class Reference

List of all members
VehicleCompToCompCtrlSignal Class Reference
Inheritance diagram for VehicleCompToCompCtrlSignal:
[legend]
Collaboration diagram for VehicleCompToCompCtrlSignal:
[legend]

Additional Inherited Members

- Public Member Functions inherited from AgentCompToCompCtrlSignal
AgentCompToCompCtrlSignal (const ComponentType componentType, const std::string &agentComponentName, const ComponentState currentState, const std::vector< ComponentWarningInformation > &warnings={})
Constructor.
virtual | operator std::string () const
ComponentType | GetComponentType () const
GetComponentType returns the type of the agent component sending the signal. More...
std::string | GetAgentComponentName () const
GetAgentComponentName returns the name of the agent component sending the signal. More...
ComponentState | GetCurrentState () const
GetCurrentState returns the current state of the agent component sending the signal. More...
std::vector< ComponentWarningInformation > | GetComponentWarnings () const
GetComponentWarning returns the warning from the agent component sending the signal, if one exists. More...
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: VehicleModelParameters Struct Reference

List of all members
VehicleModelParameters Struct Reference
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: VehicleSimpleTT Class Reference

List of all members
VehicleSimpleTT Class Reference

Simple STATIC two-track vehicle model. More...

Collaboration diagram for VehicleSimpleTT:
[legend]

Public Member Functions

Initialize
void | InitSetEngine (double weight, double P_engine, double T_brakeLimit)
Initialize tire characteristics.
void | InitSetGeometry (double x_wheelbase, double x_COG, double y_track, double y_COG)
Initialize car's physics.
void | InitSetTire (double vel, double mu_tire_max, double mu_tire_slide, double s_max, double r_tire, double frictionScaleRoll)
Initialize car's velocity.
Update state
void | UpdatePosition (double)
Refresh car's position.
void | SetVelocity (Common::Vector2d, const double)
Refresh car's velocity.
Make step
void | DriveTrain (double throttlePedal, double brakePedal, std::vector< double > brakeSuperpose)
Calculate local tire torques.
void | ForceLocal (double timeStep, double, std::vector< double > forceVertical)
Local forces and moments transferred onto road.
void | ForceGlobal ()
Global force and moment.
double | GetTireForce (int tireNumber)
double | GetForceTireVerticalStatic (int tireNumber)

Public Attributes

Output
Common::Vector2d forceTotalXY
Total force on vehicle's CoM.
double momentTotalZ
Total momentum on the vehicle around the z-axes.

Private Attributes

Constants
const double | coeffDrag = 0.34
Drag coefficient (Asbo from http://rc.opelgt.org/indexcw.php) [].
const double | areaFace = 1.94
Face area (Asbo from http://rc.opelgt.org/indexcw.php) [m^2].
const double | densityAir = 1.29
Air density [kg/m^3].
const double | accelVerticalEarth = -9.81
Earth's gravitation acceleration.
const double | anglePreSet = 0.0
Toe-in/-out.
const double | brakeBalance = 0.67
Brake balance.
const double | torqueEngineLimit = 10000.0
Max. engine moment.
Container
std::vector< Tire * > | tires

Parameters

double | forceTireVerticalStatic [NUMBER_OF_WHEELS]
double | inertiaTireX [NUMBER_OF_WHEELS]
Inertial moment of tires [kg*m^2].
double | powerEngineLimit
Maximal engine power [W].
double | torqueBrakeLimit
Brake force limit [N].
double | massTotal
Mass of the car [kg].
Common::Vector2d | positionTire [NUMBER_OF_WHEELS]
Tire positions in car CS [m].

Detailed Description

Simple STATIC two-track vehicle model.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: WorldAnalyzer Class Reference

Public Member Functions | List of all members
WorldAnalyzer Class Reference

This class provides utility functions for spawners to query information about the world. More...

Public Member Functions

std::optional< ValidLaneSpawningRanges > | GetValidLaneSpawningRanges (const RoadId &roadId, const LaneId laneId, const SPosition sStart, const SPosition sEnd) const
std::optional< double > | GetNextSpawnPosition (const RoadId &roadId, const LaneId laneId, const Range &bounds, const double agentFrontLength, const double agentRearLength, const double intendedVelocity, const double gapInSeconds, const Direction direction) const
double | CalculateSpawnVelocityToPreventCrashing (const RoadId &roadId, const LaneId laneId, const double intendedSpawnPosition, const double agentFrontLength, const double agentRearLength, const double intendedVelocity) const
bool | ValidMinimumSpawningDistanceToObjectInFront (const RoadId &roadId, const LaneId laneId, const SPosition sPosition, const VehicleModelParameters &vehicleModelParameters) const
Check wether the minimum distance the next object is satisfied.
bool | AreSpawningCoordinatesValid (const RoadId &roadId, const LaneId laneId, const SPosition sPosition, const double offset, const VehicleModelParameters &vehicleModelParameters) const
Check if it is allowed the spawn an agent at the given coordinate.
bool | SpawnWillCauseCrash (const RoadId &roadId, const LaneId laneId, const SPosition sPosition, const double agentFrontLength, const double agentRearLength, const double velocity, const Direction direction) const
Check wether spawning an agent with given parameters will result in a crash.
size_t | GetRightLaneCount (const RoadId &roadId, const LaneId &laneId, const double sPosition) const
void | ValidateRoadIdInDirection (const RoadId &roadId, const LaneId laneId) const

Detailed Description

This class provides utility functions for spawners to query information about the world.

Member Function Documentation

std::optional<ValidLaneSpawningRanges> GetValidLaneSpawningRanges | ( | const RoadId & | roadId,
 |  | const LaneId | laneId,
 |  | const SPosition | sStart,
 |  | const SPosition | sEnd
 | ) |  | const

Returns the ranges where the spawner can spawn common ranges. It excludes s positions where a scenario agent is standing as well as the range inbetween two scenario agents.

Parameters
roadId | Id of the road
laneId | Id of the lane
sStart | start of the search range
sEnd | end of the search range
Returns
valid spawning ranges
std::optional<double> GetNextSpawnPosition | ( | const RoadId & | roadId,
 |  | const LaneId | laneId,
 |  | const Range & | bounds,
 |  | const double | agentFrontLength,
 |  | const double | agentRearLength,
 |  | const double | intendedVelocity,
 |  | const double | gapInSeconds,
 |  | const Direction | direction
 | ) |  | const

Calculates the next s coordinate to spawn an agents on

Parameters
roadId | Id of the road
laneId | Id of the lane
bounds | s range to spawn in
agentFrontLength | distance from reference point to front of agent
agentRearLength | distance from reference point to rear of agent
intendedVelocity | spawning velocity
gapInSeconds | desired TGap between spawned agent and next agent
direction | wether to spawn from front to end of the road or from end to front
Returns
s position
double CalculateSpawnVelocityToPreventCrashing | ( | const RoadId & | roadId,
 |  | const LaneId | laneId,
 |  | const double | intendedSpawnPosition,
 |  | const double | agentFrontLength,
 |  | const double | agentRearLength,
 |  | const double | intendedVelocity
 | ) |  | const

Adjust spawning velocity so that the spawned agent won't immediately crash.

Parameters
roadId | Id of the road
laneId | Id of the lane
intendedSpawnPosition | s coordinate
agentFrontLength | distance from reference point to front of agent
agentRearLength | distance from reference point to rear of agent
intendedVelocity | spawning velocity
Returns
possibly adjusted velocity
size_t GetRightLaneCount | ( | const RoadId & | roadId,
 |  | const LaneId & | laneId,
 |  | const double | sPosition
 | ) |  | const

Returns the number of lanes to the right the given lane at the given s coordinate

Parameters
roadId | Id of the road
laneId | Id of the lane
sPosition | s coordinate
Returns
number of lanes to the right
void ValidateRoadIdInDirection | ( | const RoadId & | roadId,
 |  | const LaneId | laneId
 | ) |  | const

Checks if a roadId exists in direction of a laneId

Parameters
roadId | Id of the road
laneId | Id of the lane
Returns
true, if roadId exists in laneId direction
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: WorldDataQuery Class Reference

Public Member Functions | Private Member Functions | List of all members
WorldDataQuery Class Reference

Helper class for complex queries on the world data. More...

Collaboration diagram for WorldDataQuery:
[legend]

Public Member Functions

template<typename T >
bool | ObjectIsOfTypeAndWithinRange (const OWL::Interfaces::WorldObject *const worldObject, const double minS, const double maxS, const LaneStreamInfo &lane) const
template<typename T >
std::vector< const OWL::Interfaces::WorldObject * > | GetObjectsOfTypeInRange (const LaneStream &laneStream, const double startDistance, const double endDistance) const
template<typename T >
RouteQueryResult< std::vector< const OWL::Interfaces::WorldObject * > > | GetObjectsOfTypeInRange (const LaneMultiStream &laneStream, const double startDistance, const double endDistance) const
RouteQueryResult< double > | GetDistanceToEndOfLane (const LaneMultiStream &laneStream, double initialSearchPosition, double maxSearchLength, const std::vector< LaneType > &requestedLaneTypes) const
bool | IsSValidOnLane (std::string roadId, OWL::OdId laneId, double distance)
OWL::CLane & | GetLaneByOdId (std::string odRoadId, OWL::OdId odLaneId, double distance) const
OWL::CSection * | GetSectionByDistance (std::string odRoadId, double distance) const
OWL::CRoad * | GetRoadByOdId (std::string odRoadId) const
Returns the OWL road with the specified OpenDrive id.
const OWL::Interfaces::Junction * | GetJunctionByOdId (const std::string &odJunctionId) const
Returns the junction with the specified OpenDrive id.
const OWL::Interfaces::Junction * | GetJunctionOfConnector (const std::string &connectingRoadId) const
Returns the junction that the specified Connector is part of.
OWL::CLanes | GetLanesOfLaneTypeAtDistance (std::string roadId, double distance, std::list< LaneType > requestedLaneTypes) const
RouteQueryResult< std::vector< CommonTrafficSign::Entity > > | GetTrafficSignsInRange (LaneMultiStream laneStream, double startDistance, double searchRange) const
RouteQueryResult< std::vector< CommonTrafficSign::Entity > > | GetRoadMarkingsInRange (LaneMultiStream laneStream, double startDistance, double searchRange) const
RouteQueryResult< std::vector< LaneMarking::Entity > > | GetLaneMarkings (const LaneMultiStream &laneStream, double startDistance, double range, Side side) const
std::vector< IntersectingConnection > | GetIntersectingConnections (std::string connectingRoadId) const
std::vector< JunctionConnectorPriority > | GetPrioritiesOnJunction (std::string junctionId) const
std::vector< const OWL::Interfaces::WorldObject * > | GetMovingObjectsInRangeOfJunctionConnection (std::string connectingRoadId, double range) const
double | GetDistanceUntilObjectEntersConnector (const ObjectPosition position, std::string intersectingConnectorId, int intersectingLaneId, std::string ownConnectorId) const
double | GetDistanceUntilObjectLeavesConnector (const ObjectPosition position, std::string intersectingConnectorId, int intersectingLaneId, std::string ownConnectorId) const
std::shared_ptr< const LaneStream > | CreateLaneStream (const std::vector< RouteElement > &route, std::string startRoadId, OWL::OdId startLaneId, double startDistance) const
std::shared_ptr< const LaneMultiStream > | CreateLaneMultiStream (const RoadGraph &roadGraph, RoadGraphVertex start, OWL::OdId startLaneId, double startDistance) const
std::shared_ptr< const RoadStream > | CreateRoadStream (const std::vector< RouteElement > &route) const
Creates a RoadStream from the given route. More...
std::shared_ptr< const RoadMultiStream > | CreateRoadMultiStream (const RoadGraph &roadGraph, RoadGraphVertex start) const
RouteQueryResult< LongitudinalDistance > | GetDistanceBetweenObjects (const RoadMultiStream &roadStream, const ObjectPosition &objectPos, const std::optional< double > objectReferenceS, const ObjectPosition &targetObjectPos) const
GetDistanceBetweenObjects gets the distance between two ObjectPositions on a RoadStream. More...
RouteQueryResult< Obstruction > | GetObstruction (const LaneMultiStream &laneStream, double tCoordinate, const ObjectPosition &otherPosition, const std::vector< Common::Vector2d > &objectCorners, const Common::Vector2d &mainLaneLocator) const
Position | GetPositionByDistanceAndLane (const OWL::Interfaces::Lane &lane, double distanceOnLane, double offset) const
RouteQueryResult< RelativeWorldView::Junctions > | GetRelativeJunctions (const RoadMultiStream &roadStream, double startPosition, double range) const
RouteQueryResult< RelativeWorldView::Lanes > | GetRelativeLanes (const RoadMultiStream &roadStream, double startPosition, int startLaneId, double range) const

Private Member Functions

OWL::CLane * | GetOriginatingRouteLane (std::vector< RouteElement > route, std::string startRoadId, OWL::OdId startLaneId, double startDistance) const
std::vector< RouteElement > | GetRouteLeadingToConnector (std::string connectingRoadId) const
Returns the ids of the stream of roads leading the connecting road including the connecting road itself.
std::optional< Position > | CalculatePositionIfOnLane (double sCoordinate, double tCoordinate, const OWL::Interfaces::Lane &lane) const

Detailed Description

Helper class for complex queries on the world data.

Member Function Documentation

bool ObjectIsOfTypeAndWithinRange | ( | const OWL::Interfaces::WorldObject *const | worldObject,
 |  | const double | minS,
 |  | const double | maxS,
 |  | const LaneStreamInfo & | lane
 | ) |  | const
 inline

Checks if object is of type T and within the specified range when supplied an offset Returns true if so; false, otherwise

Parameters
worldObject | object to check
minS | minimum valid s position within the road
maxS | maximum valid s position within the road
lane | lane on which the object is

Here is the call graph for this function:

std::vector<const OWL::Interfaces::WorldObject*> GetObjectsOfTypeInRange | ( | const LaneStream & | laneStream,
 |  | const double | startDistance,
 |  | const double | endDistance
 | ) |  | const
 inline

Searches along a lane stream starting at startDistance and returns the all objects found until endDistance that are of type T. Returns an empty vector if there is no such object within the range T can be one of WorldObject, MovingObject or StationaryObject

RouteQueryResult<std::vector<const OWL::Interfaces::WorldObject*> > GetObjectsOfTypeInRange | ( | const LaneMultiStream & | laneStream,
 |  | const double | startDistance,
 |  | const double | endDistance
 | ) |  | const
 inline

Searches along a lane multi stream starting at startDistance and returns the all objects found until endDistance that are of type T. Returns an empty vector if there is no such object within the range The result is returned for every node. T can be one of WorldObject, MovingObject or StationaryObject

RouteQueryResult<double> GetDistanceToEndOfLane | ( | const LaneMultiStream & | laneStream,
 |  | double | initialSearchPosition,
 |  | double | maxSearchLength,
 |  | const std::vector< LaneType > & | requestedLaneTypes
 | ) |  | const

Iterates over a LaneMultStream until either the type of the next lane does not match one of the specified LaneTypes or maxSearchLength is reached. Returns the relative distance to the end of last matching lane. The result is returned for every node. Returns INFINITY if end of lane is outside maxSearchLength. Returns 0 if lane does not exist or LaneType does not match at initialSearchDistance

Parameters
laneStream | lane stream to search along
initialSearchPosition | start position in stream
maxSearchLength | maxmium look ahead distance
requestedLaneTypes | filter of LaneTypes
bool IsSValidOnLane | ( | std::string | roadId,
 |  | OWL::OdId | laneId,
 |  | double | distance
 | ) |  |

Checks if given s-coordinate is valid for specified laneId.

Parameters
roadId | OpenDrive id of road
laneId | OpenDrive Id of lane
distance | s-coordinate
OWL::CLane& GetLaneByOdId | ( | std::string | odRoadId,
 |  | OWL::OdId | odLaneId,
 |  | double | distance
 | ) |  | const

Returns lane at specified distance. Returns InvalidLane if there is no lane at given distance and OpenDriveId

Parameters
roadId | OpenDrive id of road
odLaneId | OpendDrive Id of Lane
distance | s-coordinate
OWL::CSection* GetSectionByDistance | ( | std::string | odRoadId,
 |  | double | distance
 | ) |  | const

Returns section at specified distance. Returns nullptr if there is no section at given distance

Parameters
odRaodId | ID of road in OpenDrive
distance | s-coordinate
OWL::CLanes GetLanesOfLaneTypeAtDistance | ( | std::string | roadId,
 |  | double | distance,
 |  | std::list< LaneType > | requestedLaneTypes
 | ) |  | const

Returns all lanes of given LaneType at specified distance.

Parameters
distance | s-coordinate
requestedLaneTypes | filter of laneTypes
RouteQueryResult<std::vector<CommonTrafficSign::Entity> > GetTrafficSignsInRange | ( | LaneMultiStream | laneStream,
 |  | double | startDistance,
 |  | double | searchRange
 | ) |  | const

Returns all TrafficSigns valid for the lanes in the LaneMultiStream within startDistance and startDistance + searchRange The result is returned for every node.

Parameters
laneStream | lane stream to search in
startDistance | start position in stream
searchRange | range of search (positive)
RouteQueryResult<std::vector<CommonTrafficSign::Entity> > GetRoadMarkingsInRange | ( | LaneMultiStream | laneStream,
 |  | double | startDistance,
 |  | double | searchRange
 | ) |  | const

Returns all RoadMarkings valid for the lanes in the LaneMultiStream within startDistance and startDistance + searchRange The result is returned for every node.

Parameters
laneStream | lane stream to search in
startDistance | start position in stream
searchRange | range of search (positive)
RouteQueryResult<std::vector<LaneMarking::Entity> > GetLaneMarkings | ( | const LaneMultiStream & | laneStream,
 |  | double | startDistance,
 |  | double | range,
 |  | Side | side
 | ) |  | const

Retrieves all lane markings within the given range on the given side of the lane inside the range The result is returned for every node.

Parameters
laneStream | lane stream to search in
startDistance | start position in stream
range | search range
side | side of the lane
std::vector<IntersectingConnection> GetIntersectingConnections ( std::string connectingRoadId ) const

Returns all intersections of the specified connector with other connectors in the junction

Parameters
connectingRoadId OpenDrive id of connector
Returns
intersections of connecting road with other roads
std::vector<JunctionConnectorPriority> GetPrioritiesOnJunction ( std::string junctionId ) const

Returns all priorities between the connectors of a junction

Parameters
junctionId OpenDrive id of the junction
std::vector<const OWL::Interfaces::WorldObject*> GetMovingObjectsInRangeOfJunctionConnection | ( | std::string | connectingRoadId,
 |  | double | range
 | ) |  | const

Returns all moving objects on the specified connector and the lanes leading to this connector inside a certain range

Parameters
connectingRoadId | OpenDrive id of the connector
range | Search range measured backwards from the end of the connector
Returns
moving objects in search range on connecting and incoming road
double GetDistanceUntilObjectEntersConnector | ( | const ObjectPosition | position,
 |  | std::string | intersectingConnectorId,
 |  | int | intersectingLaneId,
 |  | std::string | ownConnectorId
 | ) |  | const

Returns the distance from the front of the specified to the first intersection point of its road with the specified connector. If the object is not yet on the junction all possible route the object can take are considered and the minimum distance is returned

Parameters
object | object to calculate the distance for
connectingRoadId | OpenDrive id of connector intersecting with the route of the object
Returns
distance of object to first intersection with connecting road
double GetDistanceUntilObjectLeavesConnector | ( | const ObjectPosition | position,
 |  | std::string | intersectingConnectorId,
 |  | int | intersectingLaneId,
 |  | std::string | ownConnectorId
 | ) |  | const

Returns the distance from the rear of the specified to the last intersection point of its road with the specified connector. If the object is not yet on the junction all possible route the object can take are considered and the maximum distance is returned

Parameters
object | object to calculate the distance for
connectingRoadId | OpenDrive id of connector intersecting with the route of the object
Returns
distance of rear of object to last intersection with connecting road
std::shared_ptr<const LaneStream> CreateLaneStream | ( | const std::vector< RouteElement > & | route,
 |  | std::string | startRoadId,
 |  | OWL::OdId | startLaneId,
 |  | double | startDistance
 | ) |  | const

Creates the longest possible laneStream along the given route that contains the given startLane

Parameters
route | OpenDrive ids of the roads along which the laneStream should flow
startRoadId | OpenDrive id of the road of the startLane
startLaneId | OpenDrive id of the startLane
startDistance | s coordinate on the startLane
Returns
std::shared_ptr<const LaneMultiStream> CreateLaneMultiStream | ( | const RoadGraph & | roadGraph,
 |  | RoadGraphVertex | start,
 |  | OWL::OdId | startLaneId,
 |  | double | startDistance
 | ) |  | const

Creates a LaneMultiStream that contains the OWL lanes out of a roadGraph.

Parameters
roadGraph | road graph to convert, must be a tree
start | root of the tree
startLaneId | OpenDrive id of the lane at the root, where the lane stream should start
startDistance | s coordinate at the root, where the lane stream should start
Returns
LaneMultiStream starting with the specified lane and containing all consecutive lanes that are also contained in the given road graph
std::shared_ptr<const RoadStream> CreateRoadStream ( const std::vector< RouteElement > & route ) const

Creates a RoadStream from the given route.

Parameters
route Route containing the OpenDrive ids of the Roads along which the roadStream should flow
Returns
a RoadStream across the Roads specified in route
std::shared_ptr<const RoadMultiStream> CreateRoadMultiStream | ( | const RoadGraph & | roadGraph,
 |  | RoadGraphVertex | start
 | ) |  | const

Creates a RoadMultiStream that contains the OWL roads out of a roadGraph.

Parameters
roadGraph | road graph to convert, must be a tree
start | root of the tree
Returns
LaneMultiStream starting with the specified road and containing all consecutive roads that are also contained in the given road graph
RouteQueryResult<LongitudinalDistance> GetDistanceBetweenObjects | ( | const RoadMultiStream & | roadStream,
 |  | const ObjectPosition & | objectPos,
 |  | const std::optional< double > | objectReferenceS,
 |  | const ObjectPosition & | targetObjectPos
 | ) |  | const

GetDistanceBetweenObjects gets the distance between two ObjectPositions on a RoadStream.

Parameters
[in] | roadStream | RoadStream in which to get the distance between two ObjectPositions
[in] | objectPos | Object from whom the distance is calculated
[in] | objectReferenceS | Reference point offset of the target object
[in] | targetObject | Target object from whom the distance is calculated (if this object is behind, the distance is negative)
Returns
The distance between object and targetObject on roadStream
RouteQueryResult<Obstruction> GetObstruction | ( | const LaneMultiStream & | laneStream,
 |  | double | tCoordinate,
 |  | const ObjectPosition & | otherPosition,
 |  | const std::vector< Common::Vector2d > & | objectCorners,
 |  | const Common::Vector2d & | mainLaneLocator
 | ) |  | const

Calculates the obstruction with an object i.e. how far to left or the right the object is from my position For more information see the markdown documentation

Parameters
laneStream | own lane stream
tCoordinate | own t coordinate
otherPosition | position of the other object
objectCorners | corners of the other object
Returns
obstruction with other object
Position GetPositionByDistanceAndLane | ( | const OWL::Interfaces::Lane & | lane,
 |  | double | distanceOnLane,
 |  | double | offset
 | ) |  | const

Returns the world position that corresponds to a position on a lane

Parameters
lane | lane in the network
distanceOnLane | s coordinate on the lane
offset | t coordinate on the lane
RouteQueryResult<RelativeWorldView::Junctions> GetRelativeJunctions | ( | const RoadMultiStream & | roadStream,
 |  | double | startPosition,
 |  | double | range
 | ) |  | const

Returns the relative distances (start and end) and the connecting road id of all junctions on the road stream in range

Parameters
roadStream | road stream to search
startPosition | start search position on the road stream
range | range of search
Returns
information about all junctions in range
RouteQueryResult<RelativeWorldView::Lanes> GetRelativeLanes | ( | const RoadMultiStream & | roadStream,
 |  | double | startPosition,
 |  | int | startLaneId,
 |  | double | range
 | ) |  | const

Returns information about all lanes on the roadStream in range. These info are the relative distances (start and end), the laneId relative to the ego lane, the successors and predecessors if existing and the information wether the intended driving direction of the lane is the same as the direction of the roadStream. If the ego lane prematurely ends, then the further lane ids are relative to the middle of the road.

Parameters
roadStream | road stream to search
startPosition | start search position on the road stream
startLaneId | ego lane id
range | range of search
Returns
information about all lanes in range
OWL::CLane* GetOriginatingRouteLane | ( | std::vector< RouteElement > | route,
 |  | std::string | startRoadId,
 |  | OWL::OdId | startLaneId,
 |  | double | startDistance
 | ) |  | const
 private

Returns the most upstream lane on the specified route such that there is a continous stream of lanes regarding successor/predecessor relation up to the start lane

std::optional<Position> CalculatePositionIfOnLane | ( | double | sCoordinate,
 |  | double | tCoordinate,
 |  | const OWL::Interfaces::Lane & | lane
 | ) |  | const
 private

Returns the WorldPosition corresponding to the (s,t) position on the lane, if s is valid on the lane Otherwise the bool in the pair is false

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: WorldObjectAdapter Class Reference

List of all members
WorldObjectAdapter Class Referenceabstract
Inheritance diagram for WorldObjectAdapter:
[legend]
Collaboration diagram for WorldObjectAdapter:
[legend]
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: WorldParameter Class Reference

List of all members
WorldParameter Class Reference
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: WorldParameterOSI Struct Reference

List of all members
WorldParameterOSI Struct Reference
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Index

Class Index
A | B | C | D | E | F | G | I | J | L | M | N | O | P | R | S | T | U | V | W
A
DynamicAgentTypeGenerator Lazy (OWL) RoadMarking (OWL::Fakes) SpawnPointRuntimeCommon
DynamicParameters | LaneAcceleration (OWL::Primitive) | Road (OWL::Implementation) | SpawnDetails (SpawnPointRuntimeCommonDefinitions)
AccelerationSignal | DynamicParameterSampler | LaneGeometryElement (OWL::Primitive) | RoadMarking (OWL::Implementation) | SpawnPointRuntimeCommonParameters (SpawnPointRuntimeCommonDefinitions)
Action_BrakeLight_Basic_Implementation | DynamicProfileSampler | LaneGeometryJoint (OWL::Primitive) | Road (OWL::Interfaces) | SpawnPosition (SpawnPointRuntimeCommonDefinitions)
ActionLongitudinalDriverImplementation | Dynamics_Longitudinal_Basic_Implementation | LaneOrientation (OWL::Primitive) | RoadMarking (OWL::Interfaces) | SpawnPointScenario
ActionSecondaryDriverTasksImplementation | DynamicsCollisionImplementation | LaneOrientationRate (OWL::Primitive) | RoadAcceleration (OWL::Primitive) | SpeedActionManipulator
ActionTransformRepository | DynamicsPostCrashImplementation | LanePosition (OWL::Primitive) | RoadCoordinate (OWL::Primitive) | SpeedActionSignal
AcyclicResult | DynamicsRegularDrivingImplementation | LaneVelocity (OWL::Primitive) | RoadOrientationRate (OWL::Primitive) | STCoordinates
AgentAdapter | DynamicsRegularTwoTrackImplementation | Lane (RelativeWorldView) | RoadVelocity (OWL::Primitive) | SteeringController
AgentBlueprint | DynamicsSignal | LanesInterval (RelativeWorldView) | ReachPositionCondition | SteeringSignal
AgentBlueprintProvider | RuntimeInformation::Directories (openpass::common) | LaneIntersection (World::Localization) | Remainder | StochasticsImplementation
AgentBuildInformation | Directories (openpass::core) | LocalizationElement (World::Localization) | RemoveAgentsManipulator | Stream
AgentCompToCompCtrlSignal | Dimension (OWL::Primitive) | Localizer (World::Localization) | Road | StreamInfo
AgentNetwork | DataStore (SimulationSlave) | LocatedObject (World::Localization) | RoadGeometry | SurroundingObjects
AgentSpawnItem DataStoreBinding (SimulationSlave)
M
RoadGeometryArc
T
AgentUpdaterImplementation DataStoreLibrary (SimulationSlave) RoadGeometryLine
Algorithm_CruiseControlByDistance_Implementation
E
ManipulatorCommonBase RoadGeometryParamPoly3 VehicleModelsImporter::TypeHelper (Importer)
Algorithm_FmuWrapper MultiStream RoadGeometryPoly3 TrajectoryEvent (openpass::events)
AlgorithmAgentFollowingDriverModelImplementation | Entity (CommonTrafficSign) | ManipulatorTaskItem (openpass::scheduling) | RoadGeometrySpiral | TaskBuilder (openpass::scheduling)
AlgorithmAutonomousEmergencyBrakingImplementation | EgoAgent | ManipulatorInformation (openScenario) | RoadInterval | TaskBuilderInterface (openpass::scheduling)
AlgorithmFmuWrapperImplementation | EventDetectorCommonBase | MovingObject (OWL::Fakes) | RoadLane | TaskItem (openpass::scheduling)
AlgorithmLateralImplementation | EventDetectorImporter (Importer) | MovingObject (OWL::Implementation) | RoadLaneSection | Tasks (openpass::scheduling)
AlgorithmLongitudinalCalculations | Entity (LaneMarking) | MovingObject (OWL::Interfaces) | RoadLink | TimeKeeper (openpass::scheduling)
AlgorithmLongitudinalImplementation | ExponentialDistribution (openpass::parameter) | ModelParameters (SimulationCommon) | RoadNetworkBuilder | TriggerTaskItem (openpass::scheduling)
AdasComponentStateInformation (ComponentControl) | EventDetectorTaskItem (openpass::scheduling) | MasterConfig (SimulationMaster::Configuration) | RoadNetworkElement | TriggeringEntities (openpass::type)
AgentDataPublisher (openpass::publisher) | EntityAction (openScenario) | MasterConfigImporter (SimulationMaster::Configuration) | RoadObject | TimeHeadwayCondition (openScenario)
AgentParser (openpass::scheduling) | EventDetector (SimulationSlave) | Manipulator (SimulationSlave) | RoadPosition | TimeToCollisionCondition (openScenario)
AffectedEntities (openpass::type) | EventDetectorBinding (SimulationSlave) | ManipulatorBinding (SimulationSlave) | RoadSignal | Trajectory (openScenario)
AbsoluteTargetSpeed (openScenario) | EventDetectorLibrary (SimulationSlave) | ManipulatorLibrary (SimulationSlave) | RouteElement | TrajectoryPoint (openScenario)
ActorInformation (openScenario) | EventDetectorNetwork (SimulationSlave) | ManipulatorNetwork (SimulationSlave) | RunStatistic | Trajectory (openScenario::transformation)
AbsAcceleration (OWL::Primitive) | EventNetwork (SimulationSlave) | ModelBinding (SimulationSlave) | RunStatisticCalculation | TransformerBase (openScenario::transformation)
AbsCoordinate (OWL::Primitive)
F
ModelLibrary (SimulationSlave) RunInstantiator (SimulationSlave) TransitionDynamics (openScenario)
AbsOrientation (OWL::Primitive)
N
RunResult (SimulationSlave) TrafficSign (OWL::Fakes)
AbsOrientationRate (OWL::Primitive) | FixedComponentStateExpression (ComponentControl) | Result (World::Localization) | TrafficSign (OWL::Implementation)
AbsPosition (OWL::Primitive) FakeLaneManager MultiStream::Node
S
TrafficSign (OWL::Interfaces)
AbsVelocity (OWL::Primitive) | FrameworkModules | NoOperationManipulator | Tire
Agent (SimulationSlave) | FollowTrajectoryAction (openScenario) | NormalDistribution (openpass::parameter) | StateManager (ComponentControl) | TrafficHelperFunctions
AgentFactory (SimulationSlave) | FrameworkModuleContainer (SimulationSlave) | NamedType (openpass::type) | Scenario (Configuration) | TrafficObjectAdapter
AgentType (SimulationSlave)
G
NonExistentOsiRef (OWL) Scenery (Configuration) TrafficRuleInformation
AgentProfileLaneMaps (SpawnPointDefinitions)
O
SlaveConfig (Configuration) TrajectoryFollowerImplementation
B
GeometryInformation SystemConfig (Configuration) TrajectoryManipulator
GlobalRoadPosition | ObjectDetectorBase | ScenarioImporter (Importer) | TrajectorySignal
BasicDataStoreImplementation | GammaDistribution (openpass::parameter) | ObjectInformation | SceneryImporter (Importer) | TtcCalculations
BoolSignal
I
ObjectPosition SlaveConfigImporter (Importer) TtcCalculations::TtcParameters
BorderPoint ObjectView SystemConfigImporter (Importer)
U
BorderPoints InputPort Observation_State_Implementation SpeedActionEvent (openpass::events)
BoundingBoxCalculation | IntersectingConnection | Observation_Ttc_Implementation | Scheduler (openpass::scheduling) | UniformDistribution (openpass::parameter)
BasicEvent (openpass::events) | IntSignal | ObservationCyclics | SchedulerTasks (openpass::scheduling) | UpdateGlobalDrivingViewTaskItem (openpass::scheduling)
ByEntityCondition (openScenario) | InvalidLane (OWL::Implementation) | ObservationFileHandler | SpawningTaskItem (openpass::scheduling) | UpdateTaskItem (openpass::scheduling)
ByValueCondition (openScenario) InvalidRoad (OWL::Implementation) ObservationInstance SyncWorldTaskItem (openpass::scheduling)
V
C
InvalidSection (OWL::Implementation) ObservationLogImplementation ScenarioImporterHelper (openScenario)
IntersectionInfo (OWL) | Obstruction | SimulationTimeCondition (openScenario) | Vector2d (Common)
CollisionAngles
J
ObservationTaskItem (openpass::scheduling) SpeedAction (openScenario) Vector3d (Common)
CollisionDetectionPostCrash | Orientation (openScenario) | StochasticAttribute (openScenario) | VehicleComponentStateExpression (ComponentControl)
CollisionDetector | Joint | OpenScenarioActionsImplementation | SpeedAction (openScenario::transformation) | VehicleModels (Configuration)
CollisionManipulator | JointsBuilder | OscActionsCalculation | Section (OWL::Fakes) | VehicleModelsImporter (Importer)
CollisionManipulator::CrashInfo | Junction | OsmpFmuHandler | StationaryObject (OWL::Fakes) | RuntimeInformation::Versions (openpass::common)
CommandLineArguments | JunctionConnection | OutputAttributes | Section (OWL::Implementation) | Version (openpass::common)
CommandLineOption | JunctionConnectorPriority | OutputPort | StationaryObject (OWL::Implementation) | VisitParameterElement (openpass::parameter::internal)
CommandLineParser | Junction (OWL::Fakes) | OutputTags | Section (OWL::Interfaces) | VisibilityAction (openScenario)
CompCtrlToAgentCompSignal | Junction (OWL::Implementation) | OwnVehicleInformation | StationaryObject (OWL::Interfaces) | Vehicle (OWL::Implementation)
CompCtrlToDriverCompSignal | Junction (OWL::Interfaces) | ObservationParameters (SimulationCommon) | SampledGeometry | VehicleCompToCompCtrlSignal
ComponentStateEquality (ComponentControl) | LaneGeometryElement::Joints (OWL::Primitive) | ObservationBinding (SimulationSlave) | SampledProfiles | VehicleModelParameters
ComponentStateExpression (ComponentControl) | Junction (RelativeWorldView) | ObservationLibrary (SimulationSlave) | SceneryConverter | VehicleSimpleTT
ComponentStateInformation (ComponentControl)
L
ObservationModule (SimulationSlave) SecondaryDriverTasksSignal
W
Condition (ComponentControl) | ObservationNetwork (SimulationSlave) | Sensor_Distance_Implementation
ComponentControllerImplementation AgentAdapter::LaneObjParameters
P
SensorDataSignal WorldPosition (openScenario)
ComponentPort | Line (Common) | SensorDetectionResults | WorldData (OWL::Fakes)
ComponentStateChangeManipulator | LaneChangeManipulator | ProfilesImporter (Importer) | SensorDriverCalculations | WorldData (OWL::Interfaces)
ComponentStateSignal | LaneGeometryPolygon | Parameter (openpass::sensors) | SensorDriverImplementation | WorldObject (OWL::Interfaces)
ConditionalEventDetector | LaneInformationGeometry | Position (openpass::sensors) | SensorDriverSignal | WorldData (OWL)
ConditionCommonBase | LaneInformationTrafficRules | Profile (openpass::sensors) | SensorFusionHelperFunctions | WorldParameters (SimulationCommon)
ConditionMetaInformation | LaneJoint | ParameterizedAttribute (openScenario) | SensorFusionImplementation | World (SimulationSlave)
ConfigurationContainer (Configuration) | LateralDynamicConstants | LaneGeometryJoint::Points (OWL::Primitive) | SensorGeometric2D | WorldBinding (SimulationSlave)
ConfigurationFiles LateralSignal ParametersVehicleImplementation SensorRecordStateImplementation WorldLibrary (SimulationSlave)
Connection | LimiterAccelerationVehicleComponentsImplementation | ParametersVehicleSignal | SignalPrioritizerImplementation | WorldToRoadCoordinateConverter (World::Localization)
CSVParser Log Polygon SignalVector World_Basic_Implementation
CustomCommandFactory | LogOutputPolicy | Position | SpawnPointParameters (SimulationCommon) | WorldAnalyzer
CyclicResult | LongitudinalDistance | PostCrashDynamic | SlaveConfig (SimulationMaster::Configuration) | WorldDataQuery
ConversionStatus (Internal) | LongitudinalSignal | PostCrashVelocity | SpawnItemParameter (SimulationSlave) | WorldImplementation
CollisionEvent (openpass::events) LaneChangeEvent (openpass::events) ProcessManager SpawnPoint (SimulationSlave) WorldObjectAdapter
ComponentStateChangeEvent (openpass::events) | LogNormalDistribution (openpass::parameter) | Profiles | SpawnPointBinding (SimulationSlave) | WorldParameter
CoreDataPublisher (openpass::publisher) | LogEntry (openpass::publisher) | Parameters (SimulationCommon) | SpawnPointLibrary (SimulationSlave) | WorldParameterOSI
ConditionalEventDetectorInformation (openScenario) LogEntryBase (openpass::publisher) PreRunSpawnerParameters (SpawnPointPreRunCommonDefinitions) SpawnPointNetwork (SimulationSlave)
c
CustomCommandAction (openScenario) | LaneChangeAction (openScenario) | PointQuery (World::Localization) | Stochastics (SimulationSlave)
Callbacks (SimulationCommon) LaneChangeParameter (openScenario)
R
StochasticsBinding (SimulationSlave) cmplx
Channel (SimulationSlave) | LanePosition (openScenario) | StochasticsLibrary (SimulationSlave) | cmplxl
ChannelBuffer (SimulationSlave) LaneChange (openScenario::transformation) RuntimeInformation (openpass::common) SimulationTimeCondition
e
Component (SimulationSlave) | Lane (OWL::Fakes) | ReachPositionCondition (openScenario) | SpawnPoint_Start_Implementation
ComponentType (SimulationSlave) | LaneBoundary (OWL::Fakes) | RelativeLanePosition (openScenario) | SpawningAgentProfile (SpawnPointDefinitions) | externalParameter
D
Lane (OWL::Implementation) RelativeSpeedCondition (openScenario) SpawnPointDependencies
f
LaneBoundary (OWL::Implementation) | RelativeTargetSpeed (openScenario) | SpawnPointLibraryInfo
DefaultComponents | Lane (OWL::Interfaces) | RoadPosition (openScenario) | SpawnPointPreRunCommon | fmi1_csv_input_t
DoubleSignal | LaneBoundary (OWL::Interfaces) | Road (OWL::Fakes) | SpawnArea (SpawnPointPreRunCommonDefinitions) | fmi2_csv_input_t
A | B | C | D | E | F | G | I | J | L | M | N | O | P | R | S | T | U | V | W
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Hierarchy

Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 1234]
►C ActionInterface
C Action_BrakeLight_Basic_Implementation | Sets the brake light
C ActionLongitudinalDriverImplementation
C ActionSecondaryDriverTasksImplementation | Controls secondary driver tasks
C ActionTransformRepository | Use this class as mixed set for fixed and auto registering transformations
►C AcyclicResultInterface
C AcyclicResult
C AgentAdapter::LaneObjParameters
►C AgentBlueprintInterface
C AgentBlueprint | This class stores all information which is required to instantiate an agent
►C AgentBlueprintProviderInterface
C AgentBlueprintProvider
C AgentBuildInformation | The AgentBuildInformation struct contains all information that the AgentBlueprintProvider needs to fill out the AgentBlueprint for a dynamic AgentProfile
►C AgentFactoryInterface
C AgentFactory
►C AgentInterface
C AgentAdapter | The AgentAdapter class This class is a adapter for the communication between the framework and world
C AgentAdapter | The AgentAdapter class This class is a adapter for the communication between the framework and world
C AgentNetwork | Network of agents
C AgentSpawnItem | Representation of an agent as defined in the run configuration
►C AgentTypeInterface
C AgentType
C Algorithm_FmuWrapper
►C AlgorithmInterface
C Algorithm_CruiseControlByDistance_Implementation | Models the lateral controller of the driver
C AlgorithmAutonomousEmergencyBrakingImplementation
C AlgorithmLateralImplementation | Models the lateral controller of the driver
C AlgorithmLongitudinalImplementation
C SignalPrioritizerImplementation | This class manages the routing of signals to the sepcific components
C AlgorithmLongitudinalCalculations | This class does all the calculations in the Algorithm_Longitudinal module
C BorderPoint | This lane represents the outer boundary points of a lane at one s coordinate
C BorderPoints | This struct represents the boundary points of all lanes (including lane 0) at one s coordinate (i.e. one joint)
C BoundingBoxCalculation
►C CallbackInterface
C Callbacks | Callback implementation within framework
C cmplx
C cmplxl
C CollisionAngles
C CollisionDetectionPostCrash | Collision component that calculates post-crash dynamics
C CollisionManipulator::CrashInfo
C CommandLineArguments
C CommandLineOption
C CommandLineParser
C Line
C Vector2d
C Vector3d
C Entity
►C ComponentStateExpression | This class represents an expression that can be evaluated as ComponentState
C FixedComponentStateExpression | The FixedComponentStateExpression is a ComponentStateExpression that always evaluates to the same ComponentState
C VehicleComponentStateExpression | The VehicleComponentStateExpression is a ComponentStateExpression that evaluates to the current state of some fixed component
►C ComponentStateInformation | The ComponentStateConfiguration class handles the dependencies of a single component
C AdasComponentStateInformation
►C Condition | This class represents a Condition based on all the information the ComponentController has gathered
C ComponentStateEquality | This Condition is fullfilled if two ComponentStateExpressions are evaluated to the same value
C StateManager | Handles the dependencies of all components
►C ComponentInterface
C Component
►C ComponentPort | A Class to manage ports of a component
C InputPort< SignalType, ValueType >
C InputPort< DoubleSignal, double >
C OutputPort< SignalType, ValueType >
►C ComponentStateSignalInterface
C AccelerationSignal | Signal class
C BoolSignal | Primitive signal class for boolean values
C ComponentStateSignal | Primitive signal class for componentState values
C DoubleSignal | Primitive signal class for double values
C DynamicsSignal | Signal class
C IntSignal | Primitive signal class for integer values
C LateralSignal
C LongitudinalSignal
C SecondaryDriverTasksSignal
C SpeedActionSignal | Signal class
C SteeringSignal | Signal class
C TrajectorySignal | Signal class
►C ConditionCommonBase
C ReachPositionCondition
C SimulationTimeCondition
C ConditionMetaInformation
►C ConfigurationContainerInterface
C ConfigurationContainer | This class imports and stores all configurations
C ConfigurationFiles
►C ConnectionInterface
C Connection
C CSVParser
C CustomCommandFactory | Use this class as static auto registering factory for custom commands
►C CyclicResultInterface
C CyclicResult
►C DataStoreInterface
C BasicDataStoreImplementation | This class implements a basic version of a data store
C DataStore
C DefaultComponents | Defines the default components that all agents need
C DynamicAgentTypeGenerator | Used to build the AgentBuildInformation struct in particular the AgentType
C DynamicParameters
C DynamicParameterSampler
C DynamicProfileSampler | Responsible for sampling all profile names (except AgentProfile which is sampled by the AgentProfilesSampler)
►C DynamicsInterface
C Dynamics_Longitudinal_Basic_Implementation | Calculate the next velocity and position of the agent in the next timestep based on the acceleration in longitudinal direction
C DynamicsRegularDrivingImplementation
C DynamicsRegularTwoTrackImplementation
►C EgoAgentInterface
C EgoAgent
►C EventDetectorInterface
►C EventDetectorCommonBase | This is the parent class for all EventDetectors providing the basic functionality
C CollisionDetector | This class detectes wether a collision happen in the simulation
C ConditionalEventDetector
►C EventDetectorNetworkInterface
C EventDetectorNetwork
►C EventInterface
►C BasicEvent< EventCategory >
C CollisionEvent
C ComponentStateChangeEvent
C LaneChangeEvent
C SpeedActionEvent
C TrajectoryEvent
►C EventNetworkInterface
C EventNetwork | Implements the functionality of the interface
C externalParameter< ValueType >
C externalParameter< double >
C FakeLaneManager
C fmi1_csv_input_t
C fmi2_csv_input_t
C fmu_check_data_t
►C FmuHandlerInterface
C OsmpFmuHandler
►C FrameworkModuleContainerInterface
C FrameworkModuleContainer
C FrameworkModules
C GeometryInformation | This struct contains infrastructure information of surrounding lanes that describe its geometric features
C GlobalRoadPosition | Position of a point in the road network
C EventDetectorImporter
C ProfilesImporter
C ScenarioImporter
C SceneryImporter
C SlaveConfigImporter | This class povides the import functionality
C SystemConfigImporter | Class handles importing an agent system configuration
C VehicleModelsImporter | Provides methods for importing vehicle models from OpenSCENARIO catalog files
C VehicleModelsImporter::TypeHelper< T > | Helper for template type deduction with std::optional parameters
C ConversionStatus
C IntersectingConnection | Information regarding a connecting road intersecting another
C Joint | This struct contains all information calculated by the JointBuilder for one joint
C JointsBuilder
C JunctionConnection
C JunctionConnectorPriority
►C JunctionInterface
C Junction
C LaneGeometryPolygon
C LaneInformationGeometry | This struct is used to transport data of a lane concerning its geometric features as seen by the driver
C LaneInformationTrafficRules | This struct is used to trasport data of a lane concerning traffic rules as seen by the driver
C LaneJoint | This struct contains all information calculated by the JointBuilder for one joint and one lane
C Entity
C LateralDynamicConstants | Calulaction parameters for the lateral acceleration wish [m/s]
C Lazy< double >
C Log< T > | Coordinates logging
C LogOutputPolicy | Handles access of file
C LongitudinalDistance | Longitudinal distance (i.e. along s) between two objects on the same road
►C ManipulatorInterface
►C ManipulatorCommonBase | This is the parent class for all Manipulators providing the basic functionality
C CollisionManipulator | This class notifies all relevant modules about the collision
C ComponentStateChangeManipulator | This class toggles an assistance system
C LaneChangeManipulator | This class removes an agent
C NoOperationManipulator | This class is a manipulator, that doesn't trigger any action and solely returns the event. It existes to met the OpenSCENARIO conventions
C RemoveAgentsManipulator | This class removes an agent
C SpeedActionManipulator | This class emits the SpeedActionEvent
C TrajectoryManipulator | This manipulator sets a trajectory for an agent
►C ManipulatorNetworkInterface
C ManipulatorNetwork
C MultiStream< T >
C MultiStream< T >::Node
C ObjectInformation | This struct is used to transport data of an object as seen be the driver
C ObjectPosition | Position of an object in the road network
C ObjectView
C ObservationCyclics | The ObservationCyclics stores the samples which are logged by various modules and written into the cyclics tag of the simulationOutput.xml
C ObservationFileHandler | Provides the basic logging and observer functionality
C ObservationInstance | Wrapper for building an ObservationInstance
►C ObservationInterface
C Observation_State_Implementation | Logs the current X position of every agent at each time step
C Observation_Ttc_Implementation | Logs the time to collision (ttc) of all agents
C ObservationLogImplementation | This class adds the RunStatistic information to the simulation output
C ObservationLogImplementation | This class adds the RunStatistic information to the simulation output
►C ObservationNetworkInterface
C ObservationNetwork
C Obstruction | Describes the obstruction of an opposing object within the driving lanes
C RuntimeInformation
C RuntimeInformation::Directories
C RuntimeInformation::Versions
C Version
C Directories
C ExponentialDistribution
C GammaDistribution
C VisitParameterElement | Switches between flat parameters and parameter lists
C LogNormalDistribution
C NormalDistribution
C UniformDistribution
►C LogEntryBase | Base class for logging of acyclic events in the datastore
C LogEntry
C AgentParser | Convert agent to taskItems for Scheduling
C Scheduler | Execute all tasks for an simulation run
C SchedulerTasks | Managing timing of all given tasks
►C TaskBuilderInterface | Interface of taskBuilder
C TaskBuilder | Handles fix tasks of scheduler
►C TaskItem | Handles data to store scheduler tasks
C EventDetectorTaskItem | TaskItem for eventDetector task
C ManipulatorTaskItem | TaskItem for manipulator task
C ObservationTaskItem | TaskItem for observation task
C SpawningTaskItem | TaskItem for spawning task
C SyncWorldTaskItem | TaskItem for synchronize world task
C TriggerTaskItem | TaskItem for triggering task
C UpdateGlobalDrivingViewTaskItem | TaskItem for update global driving view task
C UpdateTaskItem | TaskItem for update task
C Tasks | Stores taskItems in multiset
C TimeKeeper | Allows core components to access the current schedule time without need for a direct reference
C Parameter
C Position
C Profile
C AffectedEntities | Contains the affected entities of an acyclic
C NamedType< T, Tag >
C TriggeringEntities | Contains the triggering entities of an acyclic
C AbsoluteTargetSpeed
C ActorInformation
►C ByEntityCondition
C ReachPositionCondition
C RelativeSpeedCondition
C TimeHeadwayCondition
C TimeToCollisionCondition
►C ByValueCondition
C SimulationTimeCondition
C ConditionalEventDetectorInformation | Event specific information collected from an openSCENARIO story
C CustomCommandAction
C EntityAction
C FollowTrajectoryAction
C LaneChangeAction
C LaneChangeParameter
C LanePosition
C ManipulatorInformation
C Orientation
C ParameterizedAttribute< T > | Attribute in a catalog that is not yet resolved
C RelativeLanePosition
C RelativeTargetSpeed
C RoadPosition
C ScenarioImporterHelper
C SpeedAction
C StochasticAttribute
C Trajectory
C TrajectoryPoint
C TransformerBase< T, Signal, TriggeringEvent > | CRTP Base class for Transformer
C TransitionDynamics
C VisibilityAction
C WorldPosition
C OscActionsCalculation | This class makes calculations for the OpenScenarioActions module
C OutputAttributes
C OutputTags
►C Junction | This class represents a junction in the world
C Junction
C Junction
►C Lane | This class represents a single lane inside a section
C Lane
►C Lane
C InvalidLane
►C LaneBoundary | This class represents the boundary between two lanes
C LaneBoundary
C LaneBoundary
►C Road | This class represents a road in the world
C Road
►C Road
C InvalidRoad
►C RoadMarking | This class represents a traffic sign that is painted on the road surface
C RoadMarking
C RoadMarking
►C Section | This class represents one section of a road
C Section
►C Section
C InvalidSection
►C TrafficSign | This class represents a static traffic sign
C TrafficSign
C TrafficSign
►C WorldData | This class contains the entire road network and all objects in the world
C WorldData
C WorldData
►C WorldObject
►C MovingObject
C MovingObject
►C MovingObject
C Vehicle
►C StationaryObject
C StationaryObject
C StationaryObject
C IntersectionInfo
C Lazy< T >
C AbsAcceleration
C AbsCoordinate
C AbsOrientation
C AbsOrientationRate
C AbsPosition
C AbsVelocity
C Dimension
C LaneAcceleration
C LaneGeometryElement
C LaneGeometryElement::Joints
C LaneGeometryJoint
C LaneGeometryJoint::Points | Tripple describing the sampled points of the lane
C LaneOrientation
C LaneOrientationRate
C LanePosition
C LaneVelocity
C RoadAcceleration
C RoadCoordinate
C RoadOrientationRate
C RoadVelocity
C OwnVehicleInformation | Data about the lane to left (in driving direction) of the mainLane
►C ParameterInterface
►C Parameters
C ModelParameters
C ObservationParameters
C SpawnPointParameters
C WorldParameters
C Polygon | Polygon in 2d
C Position
C PostCrashDynamic | Class to store post-crash dynamics data Used to store information about the dynamic after a collision
C PostCrashVelocity
►C ProfilesInterface
C Profiles
►C PublisherInterface
C AgentDataPublisher | ! Interface which has to be provided by observation modules
C CoreDataPublisher | ! Interface which has to be provided by observation modules
►C QObject
C ProcessManager
C Junction
C Lane
C LanesInterval
C Remainder | This struct describes how much space an agent has to next lane boundary on both sides
►C RoadGeometryInterface
►C RoadGeometry
C RoadGeometryArc | Class representing a road arc as a RoadGeometry
C RoadGeometryLine | Class representing a road line as a RoadGeometry
C RoadGeometryParamPoly3 | Class representing a road form defined via a parametric cubic polynomial as a RoadGeometry
C RoadGeometryPoly3 | Class representing a road form defined via a cubic polynomial as a RoadGeometry
C RoadGeometrySpiral | Class representing a spiral road (clothoid) as a RoadGeometry
►C RoadInterface
C Road | Class representing a road
C RoadInterval | Interval on a specific road
►C RoadLaneInterface
C RoadLane | Class representing a road lane
►C RoadLaneSectionInterface
C RoadLaneSection | Class representing a road lane section that can contain several road lanes
►C RoadLinkInterface
C RoadLink | Class representing a link to a road
C RoadNetworkBuilder
C RoadNetworkElement
►C RoadObjectInterface
C RoadObject
C RoadPosition | Position of a point on a specific lane
►C RoadSignalInterface
C RoadSignal | Class representing a road signal
C RouteElement | This represents one node on the road network graph of the world or in the routing graph of an agent
►C RunResultInterface
C RunResult | Stores run results for output data
C RunStatistic
C RunStatisticCalculation | Helper functions for run statistic analysis
C SampledGeometry | This struct is the result of the geometry sampling of one road section
C SampledProfiles | The SampledProfiles struct constains the name of all profiles sampled by the DynamicProfileSampler. With this the DynamicAgentTypeGenerator can generate an AgentType
►C ScenarioInterface
C Scenario
C SceneryConverter
►C SceneryInterface
C Scenery | Class representing a scenery as a list of roads
C SensorDetectionResults
C SensorDriverCalculations | Utility class for the sensor driver
C SensorFusionHelperFunctions
►C SensorInterface
C AlgorithmAgentFollowingDriverModelImplementation
►C ObjectDetectorBase | This class is the common base for all SensorObjectDetectors
C SensorGeometric2D | This file models a sensor which only detects agents in a 2D area (x/y) in front of the agent
C ParametersVehicleImplementation | Defines constants or creates stochastic values that are used in more than one module
C Sensor_Distance_Implementation | This module is a basic module to sense the current state of an agent
C SensorDriverImplementation
C SensorRecordStateImplementation | Records the state of the agent
►C SignalInterface
►C AgentCompToCompCtrlSignal
C VehicleCompToCompCtrlSignal
►C CompCtrlToAgentCompSignal Facilitates communication with the agent component, defining the max reachable state of the component as well as the states of other components connected to the

ComponentController

C CompCtrlToDriverCompSignal Facilitates communication with the driver component, allowing for warnings to be forwarded to the driver

alongside standard agent component information.

C ParametersVehicleSignal | Provides all vehicle parameters for the driver
C SensorDataSignal
C SensorDriverSignal
C SignalVector< DT > | Primitive signal class for vectors
C MasterConfig | Used as value storage of parsed configuration parameters
C MasterConfigImporter
C SlaveConfig
C Agent
C Channel
C ChannelBuffer
C ComponentType
C DataStoreBinding
C DataStoreLibrary
C EventDetector
C EventDetectorBinding
C EventDetectorLibrary
C Manipulator
C ManipulatorBinding
C ManipulatorLibrary
C ModelBinding
C ModelLibrary
C ObservationBinding
C ObservationLibrary
C ObservationModule
C RunInstantiator
C SpawnPoint
C SpawnPointBinding
C SpawnPointLibrary
C StochasticsBinding
C StochasticsLibrary
C WorldBinding
C WorldLibrary
►C SlaveConfigInterface
C SlaveConfig | Container class for the slave configuration
►C SpawnItemParameterInterface
C SpawnItemParameter
C AgentProfileLaneMaps
C SpawningAgentProfile
C SpawnPointDependencies
►C SpawnPointInterface
C SpawnPoint_Start_Implementation | Spawn agents at the beginning of road
C SpawnPointPreRunCommon | Spawns agents for all scenarios
C SpawnPointRuntimeCommon
C SpawnPointScenario | Spawns agents for all scenarios
C SpawnPointLibraryInfo
►C SpawnPointNetworkInterface
C SpawnPointNetwork
C PreRunSpawnerParameters
C SpawnArea
C SpawnDetails
C SpawnPointRuntimeCommonParameters
C SpawnPosition
C STCoordinates
►C exception
C NonExistentOsiRef
C SteeringController
►C StochasticsInterface
C Stochastics
C StochasticsImplementation | Implementation of StochasticsInterface
C Stream< T >
C StreamInfo< T >
C SurroundingObjects
►C SystemConfigInterface
C SystemConfig
C Tire | Static tire model based on TMEASY by Rill et al
C TrafficHelperFunctions | Containing general static functions to evaluate traffic situations
►C TrafficObjectInterface
C TrafficObjectAdapter
C TrafficRuleInformation | This struct contains infrastructure information of surrounding lanes that are used to establish traffic rules
►C TransformerBase< LaneChange, TrajectorySignal, openpass::events::LaneChangeEvent >
C LaneChange
►C TransformerBase< SpeedAction, SpeedActionSignal, openpass::events::SpeedActionEvent >
C SpeedAction
►C TransformerBase< Trajectory, TrajectorySignal, openpass::events::TrajectoryEvent >
C Trajectory
C TtcCalculations | Containing functions to calculate time to collision of two objects
C TtcCalculations::TtcParameters | Structure to hold all necessary world object parameters for TTC calculation
►C UnrestrictedEventModelInterface
C ComponentControllerImplementation
C OpenScenarioActionsImplementation | Relays triggered OpenScenario actions as signals to other components
►C UnrestrictedModelInterface
C AgentUpdaterImplementation | The class which is responsible for updating the agent in each time step
C AlgorithmFmuWrapperImplementation
C DynamicsCollisionImplementation
C DynamicsPostCrashImplementation
C LimiterAccelerationVehicleComponentsImplementation | This class implements the set limit
C SensorFusionImplementation | This class is the SensorFusion module
C TrajectoryFollowerImplementation | Makes an agent strictly follow a predefined path
C VehicleModelParameters
►C VehicleModelsInterface
C VehicleModels
C VehicleSimpleTT | Simple STATIC two-track vehicle model
C LaneIntersection< T > | This struct describes the intersection of an object with a lane
C LocalizationElement | This struct contains all the information about a LaneGeometryElement that is needed by the Localizer
C Localizer
C LocatedObject
C PointQuery
C Result
C WorldToRoadCoordinateConverter
C WorldAnalyzer | This class provides utility functions for spawners to query information about the world
C WorldDataQuery | Helper class for complex queries on the world data
►C WorldInterface
C World
C World_Basic_Implementation | Implementation of a WorldInterface
C WorldImplementation | Implementation of a WorldInterface
►C WorldObjectInterface
►C WorldObjectAdapter
C AgentAdapter | The AgentAdapter class This class is a adapter for the communication between the framework and world
C TrafficObjectAdapter
C WorldParameter
C WorldParameterOSI
►C Ts
C overload< Ts >
C overload< Ts >
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- _ -

  • _accelerationMax : Algorithm_CruiseControlByDistance_Implementation
  • _airDensity : Algorithm_CruiseControlByDistance_Implementation
  • _airDragCoefficent : Algorithm_CruiseControlByDistance_Implementation
  • _carHeight : Algorithm_CruiseControlByDistance_Implementation
  • _carRate : SpawnPoint_Start_Implementation
  • _carWeight : Algorithm_CruiseControlByDistance_Implementation
  • _carWidth : Algorithm_CruiseControlByDistance_Implementation
  • _cw : Algorithm_CruiseControlByDistance_Implementation
  • _iSpawnCar : SpawnPoint_Start_Implementation
  • _oneG : DynamicsRegularDrivingImplementation
  • _rho : DynamicsRegularDrivingImplementation
  • _standardCycleTime : SpawnPoint_Start_Implementation
  • _standardCycleTimeSecond : Algorithm_CruiseControlByDistance_Implementation
  • _twoPi : DynamicsRegularDrivingImplementation
  • _VLowerLimit : Dynamics_Longitudinal_Basic_Implementation
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • absoluteVelocity : ObjectInformation , OwnVehicleInformation
  • acceleration : ObjectInformation , OwnVehicleInformation
  • accelerationCar : DynamicsRegularTwoTrackImplementation
  • accelerationMin : Algorithm_CruiseControlByDistance_Implementation
  • AccelerationSignal() : AccelerationSignal
  • accelerationWish : AlgorithmLongitudinalImplementation
  • accelVerticalEarth : VehicleSimpleTT
  • AcquireOutputData() : Component
  • activeAcceleration : AlgorithmAutonomousEmergencyBrakingImplementation
  • acyclicStore : BasicDataStoreImplementation
  • Add() : Vector2d , Vector3d
  • AddAgent() : AgentNetwork , ObservationFileHandler
  • AddAgents() : ObservationFileHandler
  • AddBorder() : RoadLane
  • AddBoundaryPoint() : LaneBoundary
  • AddCenterLinePoint() : WorldData
  • AddCollision() : EventNetwork
  • AddCollisionId() : RunResult
  • AddComponent() : StateManager
  • AddConnectingRoad() : Junction
  • AddElevation() : Road
  • AddEvents() : ObservationFileHandler
  • AddGeometryArc() : Road
  • AddGeometryLine() : Road
  • AddGeometryParamPoly3() : Road
  • AddGeometryPoly3() : Road
  • AddGeometrySpiral() : Road
  • AddHeader() : ObservationFileHandler
  • AddInputLink() : Component
  • AddIntersectionInfo() : Junction
  • AddJunction() : Scenery , WorldData
  • AddJunctionConnection() : WorldData
  • AddJunctionPriority() : WorldData
  • AddLane() : Section , WorldData
  • AddLaneAssignment() : WorldObject
  • AddLaneBoundary() : WorldData
  • AddLaneGeometryJoint() : Lane
  • AddLaneGeometryPoint() : WorldData
  • AddLaneOffset() : Road
  • AddLanePredecessor() : WorldData
  • AddLaneSuccessor() : WorldData
  • AddLink() : Road
  • AddMovingObject() : Lane , WorldData
  • AddMovingObjectToSensorData() : SensorGeometric2D
  • AddNext() : Lane , Section
  • AddOutputLink() : Component
  • AddParsedObjectsToRoad() : SceneryImporter
  • AddPredecessor() : RoadLane
  • AddPrevious() : Lane , Section
  • AddPriority() : Junction
  • AddReference() : ObservationFileHandler
  • AddRoad() : Scenery , WorldData
  • AddRoadLane() : RoadLaneSection
  • AddRoadLaneSection() : Road
  • AddRoadMark() : RoadLane
  • AddRoadMarking() : Lane , WorldData
  • AddRoadSignal() : Road
  • AddSamples() : ObservationFileHandler
  • AddSection() : Road , WorldData
  • AddSensor() : AgentBlueprint , ObservationFileHandler
  • AddSensors() : ObservationFileHandler
  • AddStateCondition() : ComponentStateInformation
  • AddStationaryObject() : Lane , WorldData
  • AddStationaryObjectToSensorData() : SensorGeometric2D
  • AddSuccessor() : RoadLane
  • AddSupplementarySign() : TrafficSign
  • AddTask() : Tasks
  • AddTrafficSign() : Lane , WorldData
  • AddVehicleAttributes() : ObservationFileHandler
  • AddWidth() : RoadLane
  • AddWorldObject() : Lane
  • AgentBuildInformation() : AgentBuildInformation
  • agentComponentName : AgentCompToCompCtrlSignal
  • AgentCompToCompCtrlSignal() : AgentCompToCompCtrlSignal
  • agentIdString : AlgorithmFmuWrapperImplementation
  • AgentIsAffected() : TransformerBase< T, Signal, TriggeringEvent >
  • agentsMinTtc : Observation_Ttc_Implementation
  • agentsTtc : Observation_Ttc_Implementation
  • AlgorithmAgentFollowingDriverModelImplementation() : AlgorithmAgentFollowingDriverModelImplementation
  • AlgorithmLongitudinalCalculations() : AlgorithmLongitudinalCalculations
  • Angle() : Vector2d
  • anglePreSet : VehicleSimpleTT
  • angleTireFront : DynamicsRegularTwoTrackImplementation
  • ApplyGearLimit() : DynamicsRegularDrivingImplementation
  • ApplyLatency() : ObjectDetectorBase
  • ApplyMeasurementError() : ObjectDetectorBase
  • ApplyPedalPositionLimits() : DynamicsRegularDrivingImplementation
  • ApplyRepeat() : SceneryImporter
  • ApplySectorFilter() : WorldData
  • areaFace : VehicleSimpleTT
  • AreSpawningCoordinatesValid() : SpawnPointPreRunCommon , WorldAnalyzer
  • As() : WorldObject
  • AssignProperty() : VehicleModelsImporter
  • AssignRoadMarkingToLane() : WorldData
  • AssignTrafficSignToLane() : WorldData
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • brakeBalance : VehicleSimpleTT
  • brakePedal : DynamicsRegularTwoTrackImplementation
  • brakeSuperpose : DynamicsRegularTwoTrackImplementation
  • brakingAcceleration : AlgorithmAutonomousEmergencyBrakingImplementation
  • Build() : RoadNetworkBuilder
  • BuildEventDetectorTasks() : TaskBuilder
  • BuildManipulatorTasks() : TaskBuilder
  • BuildResult() : Localizer
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • CalcInitialBrightArea() : SensorGeometric2D
  • CalcObjectShadow() : SensorGeometric2D
  • CalcObjectVisibilityPercentage() : SensorGeometric2D
  • CalculateAllIntersectionPoints() : CollisionDetectionPostCrash
  • CalculateAttributeValue() : SpawnPointScenario
  • CalculateBoundingBox() : BoundingBoxCalculation , ObjectDetectorBase , TtcCalculations
  • CalculateCentroid() : Polygon
  • CalculateCollisionAngles() : CollisionDetectionPostCrash
  • CalculateCurvatures() : JointsBuilder
  • CalculateDistOnBorder() : CollisionDetector
  • CalculateGearAndEngineSpeed() : AlgorithmLongitudinalCalculations
  • CalculateGlobalSensorPosition() : ObjectDetectorBase
  • CalculateHeadings() : JointsBuilder
  • CalculateIntersectionPoints() : CollisionDetector
  • CalculateNetTimeGap() : TrafficHelperFunctions
  • CalculateNextTimestep() : TrajectoryFollowerImplementation
  • CalculateObjectTTC() : AlgorithmAutonomousEmergencyBrakingImplementation , TtcCalculations
  • CalculateOwnBoundingBox() : BoundingBoxCalculation
  • CalculatePedalPositionAndGear() : AlgorithmLongitudinalImplementation
  • CalculatePedalPositions() : AlgorithmLongitudinalCalculations
  • CalculatePlaneOfContact() : CollisionDetectionPostCrash
  • CalculatePointOfContact() : CollisionDetector
  • CalculatePoints() : JointsBuilder
  • CalculatePositionIfOnLane() : WorldDataQuery
  • CalculatePostCrashDynamic() : CollisionDetectionPostCrash
  • CalculateRelativeVector() : ObjectDetectorBase
  • CalculateSinusiodalLaneChange() : OscActionsCalculation
  • CalculateSpawnParameter() : SpawnPointPreRunCommon , SpawnPointRuntimeCommon , SpawnPointScenario
  • CalculateSpawnVelocityToPreventCrashing() : WorldAnalyzer
  • CalculateSteeringAngle() : SteeringController
  • CalculateTTC() : AlgorithmAutonomousEmergencyBrakingImplementation
  • CalculateWorldObjectGeometry() : CollisionDetector
  • CalcVisualObstruction() : SensorGeometric2D
  • callbacks : AlgorithmFmuWrapperImplementation , fmu_check_data_t
  • CategorizeEntities() : ScenarioImporter
  • cdata : AlgorithmFmuWrapperImplementation
  • channels : Observation_State_Implementation
  • CheckCondition() : ConditionalEventDetector
  • CheckModelParameters() : VehicleModelsImporter
  • CheckOrDefault() : MasterConfig
  • checkRoadSignalBoundaries() : SceneryImporter
  • Clear() : AgentNetwork , Scenery , ObservationCyclics , WorldData , EventDetectorNetwork , EventNetwork , ManipulatorNetwork
  • ClearLaneAssignments() : WorldObject
  • ClearMovingObjects() : Lane
  • ClearNonrecurringTasks() : SchedulerTasks
  • coeffDrag : VehicleSimpleTT
  • coeffRest : CollisionDetectionPostCrash
  • collAngles : CollisionDetectionPostCrash
  • collision : OwnVehicleInformation
  • collisionDetectionLateralBoundary : AlgorithmAutonomousEmergencyBrakingImplementation , BoundingBoxCalculation
  • collisionDetectionLongitudinalBoundary : AlgorithmAutonomousEmergencyBrakingImplementation , BoundingBoxCalculation
  • collisionPostCrash : CollisionManipulator
  • CollisionState : DynamicsPostCrashImplementation
  • collisionVelocity : PostCrashDynamic
  • Combine() : SampledGeometry
  • CompCtrlToAgentCompSignal() : CompCtrlToAgentCompSignal
  • CompCtrlToDriverCompSignal() : CompCtrlToDriverCompSignal
  • COMPONENTNAME : AlgorithmLongitudinalImplementation , DynamicsRegularDrivingImplementation , DynamicsRegularTwoTrackImplementation , SensorDriverImplementation
  • ComponentPort() : ComponentPort
  • componentState : AlgorithmAgentFollowingDriverModelImplementation , AlgorithmAutonomousEmergencyBrakingImplementation
  • componentType : AgentCompToCompCtrlSignal
  • Concat() : Directories
  • configurationDir : ConfigurationFiles , Directories
  • ConnectAgentLinks() : AgentFactory
  • ConnectExternalRoadPredecessor() : SceneryConverter
  • ConnectExternalRoadSuccessor() : SceneryConverter
  • ConnectJunction() : SceneryConverter
  • ConnectLanes() : WorldData , SceneryConverter
  • ConnectLaneToLane() : SceneryConverter
  • ConnectLaneToSection() : SceneryConverter
  • ConnectPathInJunction() : SceneryConverter
  • ConnectRoadExternalWithElementTypeRoad() : SceneryConverter
  • ConnectRoadInternal() : SceneryConverter
  • ConnectRoads() : SceneryConverter
  • ConsumeNonRecurringAgentTasks() : SchedulerTasks
  • Contains() : Stream< T >
  • ContainsEntity() : EventDetectorImporter , ScenarioImporter
  • ContainsSensor() : ObservationFileHandler
  • context : fmu_check_data_t
  • ConvertObjects() : SceneryConverter
  • ConvertRoads() : SceneryConverter
  • CopyToGroundTruth() : Lane , LaneBoundary , RoadMarking , TrafficSign , WorldObject
  • Covers() : Lane , Section
  • CoversInterval() : Section
  • Create() : CustomCommandFactory
  • CreateAgent() : AgentFactory
  • CreateBootstrapTasks() : TaskBuilder
  • CreateCollisionDetector() : EventDetectorLibrary
  • CreateComponent() : ModelLibrary
  • CreateDataStore() : DataStoreLibrary
  • CreateFinalizeTasks() : TaskBuilder
  • CreateFivePointDetectionField() : SensorGeometric2D
  • CreateFourPointDetectionField() : SensorGeometric2D
  • CreateLaneMultiStream() : WorldDataQuery
  • CreateLaneStream() : WorldDataQuery
  • CreateManipulator() : ManipulatorLibrary
  • CreateNewScheduledTimestamps() : SchedulerTasks
  • CreateObservationModule() : ObservationLibrary
  • CreateOutputBuffer() : Component
  • CreatePostCrashDynamics() : CollisionDetectionPostCrash
  • CreateRoadMarking() : SceneryConverter
  • CreateRoadMultiStream() : WorldDataQuery
  • CreateRoadStream() : WorldDataQuery
  • CreateSpawningTasks() : TaskBuilder
  • CreateSpawnPoint() : SpawnPointLibrary
  • CreateStochastics() : StochasticsLibrary
  • CreateSynchronizeTasks() : TaskBuilder
  • CreateTrafficSign() : SceneryConverter
  • CreateWorld() : WorldLibrary
  • Cross() : Vector2d
  • CSV_separator : fmu_check_data_t
  • currentState : AgentCompToCompCtrlSignal
  • currentVelocity : AlgorithmLongitudinalImplementation
  • curvature : LaneInformationGeometry , LaneGeometryJoint
  • curvatureRoadSmoothLast : SteeringController
  • cyclicStore : BasicDataStoreImplementation
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • decelerationWish : AlgorithmAgentFollowingDriverModelImplementation
  • defaultLibraryMapping : SlaveConfigImporter
  • defaultValue : ParameterizedAttribute< T >
  • DegreeToRadiant : DynamicsRegularDrivingImplementation
  • DeleteAgentTasks() : SchedulerTasks
  • DeleteTasks() : Tasks
  • delta : AlgorithmAgentFollowingDriverModelImplementation
  • densityAir : VehicleSimpleTT
  • DetectCollision() : CollisionDetector
  • DetectedCollisionWithAgent() : CollisionDetector
  • DetectedCollisionWithObject() : CollisionDetector
  • detectedMovingObjects : AlgorithmAutonomousEmergencyBrakingImplementation
  • detectedStationaryObjects : AlgorithmAutonomousEmergencyBrakingImplementation
  • DetectIntersectionOfTwoWorldObjects() : CollisionDetector
  • DetectObjects() : SensorGeometric2D
  • DetermineDefaultMaximumComponentStateByType() : AdasComponentStateInformation
  • DetermineEgoCollision() : RunStatisticCalculation
  • discreteIndex : fmi1_csv_input_t , fmi2_csv_input_t
  • distanceToEndOfLane : LaneInformationGeometry
  • distanceToLaneBoundaryLeft : OwnVehicleInformation
  • distanceToLaneBoundaryRight : OwnVehicleInformation
  • do_mangle_var_names : fmu_check_data_t
  • do_output_all_vars : fmu_check_data_t
  • do_simulate_flg : fmu_check_data_t
  • do_test_cs : fmu_check_data_t
  • do_test_me : fmu_check_data_t
  • Dot() : Vector2d
  • DriveTrain() : VehicleSimpleTT
  • dynamicsSignal : DynamicsPostCrashImplementation , DynamicsRegularDrivingImplementation , DynamicsRegularTwoTrackImplementation
  • dynamicsTarget : LaneChangeParameter
  • dynamicsType : LaneChangeParameter
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • elements : AcyclicResult , CyclicResult
  • endHeading : SampledGeometry
  • EndS() : StreamInfo< T >
  • endTimeInSeconds : Scenario
  • enforceDoubleBuffering : OsmpFmuHandler
  • entityIdIndex : BasicDataStoreImplementation
  • Error() : SignalPrioritizerImplementation
  • EvaluateConditions() : ConditionalEventDetector
  • eventIndex1 : fmi1_csv_input_t , fmi2_csv_input_t
  • eventIndex2 : fmi1_csv_input_t , fmi2_csv_input_t
  • ExecuteRun() : RunInstantiator
  • ExecuteTasks() : Scheduler
  • exist : ObjectInformation
  • exists : LaneInformationGeometry
  • Exists() : Lane
  • ExpandUpperBoundary() : SchedulerTasks
  • externalParameter() : externalParameter< ValueType >
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • false : AlgorithmFmuWrapperImplementation
  • findFrontAgentID() : Observation_Ttc_Implementation
  • FixedComponentStateExpression() : FixedComponentStateExpression
  • FlagComponentMaxReachableStateSetByEvent() : StateManager
  • FmiTypeToCType() : AlgorithmFmuWrapperImplementation
  • fmu : fmi1_csv_input_t , fmi2_csv_input_t
  • fmu1 : fmu_check_data_t
  • fmu1_kind : fmu_check_data_t
  • fmu2 : fmu_check_data_t
  • fmu2_kind : fmu_check_data_t
  • FMU_fullName : AlgorithmFmuWrapperImplementation
  • FMU_name : AlgorithmFmuWrapperImplementation
  • FMU_path : AlgorithmFmuWrapperImplementation
  • fmuHandler : AlgorithmFmuWrapperImplementation
  • FMUPath : fmu_check_data_t
  • fmuType : AlgorithmFmuWrapperImplementation
  • fmuVariables : AlgorithmFmuWrapperImplementation
  • fmuVariableValues : AlgorithmFmuWrapperImplementation
  • folderUnzip : AlgorithmFmuWrapperImplementation
  • ForceGlobal() : VehicleSimpleTT
  • ForceLocal() : VehicleSimpleTT
  • forceTotalXY : VehicleSimpleTT
  • forceWheelVertical : DynamicsRegularTwoTrackImplementation
  • FullCoord() : RoadGeometrySpiral
  • FullCurvature() : RoadGeometrySpiral
  • FullDir() : RoadGeometrySpiral
  • fullResultFilePath : Observation_Ttc_Implementation
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • gainHeadingError : LateralDynamicConstants
  • GatherBasicComponents() : DynamicAgentTypeGenerator
  • GatherComponent() : DynamicAgentTypeGenerator
  • GatherComponentWithParameters() : DynamicAgentTypeGenerator
  • GatherDriverComponents() : DynamicAgentTypeGenerator
  • GatherSensors() : DynamicAgentTypeGenerator
  • GatherVehicleComponents() : DynamicAgentTypeGenerator
  • GenerateAgentsForRange() : SpawnPointPreRunCommon
  • GenerateDynamicAgentBlueprint() : AgentBlueprintProvider
  • GenerateSensorViewConfiguration() : ObjectDetectorBase , SensorGeometric2D
  • GenerateSpawnDetailsForLane() : SpawnPointRuntimeCommon
  • GenerateStaticAgentBlueprint() : AgentBlueprintProvider
  • geometryInformation : SensorDriverImplementation , SensorDriverSignal
  • Get() : ComponentStateExpression , Log< T >
  • GetA() : RoadGeometryPoly3
  • GetAbsAccelerationDouble() : WorldObject
  • GetAbsoluteFilePath() : MasterConfigImporter
  • GetAbsolutePosition() : ObjectDetectorBase
  • GetAbsOrientation() : WorldObject
  • GetAbsVelocityDouble() : WorldObject
  • GetAccelerationFromAirResistance() : DynamicsRegularDrivingImplementation
  • GetAccelerationFromRollingResistance() : DynamicsRegularDrivingImplementation
  • GetAcceleratorPedalPosition() : AlgorithmLongitudinalCalculations
  • GetAccFromEngineMoment() : DynamicsRegularDrivingImplementation
  • GetAccFromEngineTorque() : AlgorithmLongitudinalCalculations
  • GetAccVehicle() : DynamicsRegularDrivingImplementation
  • GetActors() : ConditionalEventDetector
  • GetAdasType() : AdasComponentStateInformation
  • GetAgent() : AgentNetwork , Component
  • GetAgentCategory() : AgentBlueprint
  • GetAgentComponentName() : AgentCompToCompCtrlSignal
  • GetAgentCorners() : CollisionDetectionPostCrash
  • GetAgentFactory() : SpawnPoint
  • GetAgentHeader() : ObservationCyclics
  • GetAgentId() : WorldData
  • GetAgentProfileName() : AgentBlueprint
  • GetAgents() : AgentNetwork
  • GetAgentSamplesLine() : ObservationCyclics
  • GetAgentType() : AgentBlueprint
  • GetAgentVelocityVector() : CollisionDetectionPostCrash
  • GetAU() : RoadGeometryParamPoly3
  • GetAV() : RoadGeometryParamPoly3
  • GetB() : RoadGeometryPoly3
  • GetBootstrapTasks() : SchedulerTasks
  • GetBorders() : RoadLane
  • GetBrakePedalPosition() : AlgorithmLongitudinalCalculations
  • GetBU() : RoadGeometryParamPoly3
  • GetBV() : RoadGeometryParamPoly3
  • GetC() : RoadGeometryPoly3
  • GetCenterLaneBoundary() : Section
  • GetCollisionAngles() : CollisionDetectionPostCrash
  • GetCollisionPosition() : CollisionDetectionPostCrash
  • GetColor() : LaneBoundary
  • GetComponent() : StateManager
  • GetComponentLocalLinkIdByName() : StateManager
  • GetComponentName() : ComponentStateInformation
  • GetComponentType() : AgentCompToCompCtrlSignal , ComponentStateInformation
  • GetComponentWarnings() : AgentCompToCompCtrlSignal
  • GetConnectedRoad() : SceneryConverter
  • GetConnectingRoads() : Junction
  • GetContactPoint() : RoadLink
  • GetCoord() : RoadGeometry
  • GetCoordArc() : RoadGeometry
  • GetCoordLine() : RoadGeometry
  • GetCU() : RoadGeometryParamPoly3
  • GetCurrentState() : AgentCompToCompCtrlSignal , ComponentStateInformation
  • GetCurvature() : Lane , RoadGeometryArc
  • GetCurvEnd() : RoadGeometrySpiral
  • GetCurvStart() : RoadGeometrySpiral
  • GetCV() : RoadGeometryParamPoly3
  • GetCycleTime() : EventDetectorCommonBase , ManipulatorCommonBase , Component
  • GetD() : RoadGeometryParamPoly3 , RoadGeometryPoly3
  • GetDimension() : WorldObject
  • GetDir() : RoadGeometry
  • GetDirArc() : RoadGeometry
  • GetDirection() : Lane , RoadLink
  • GetDirLine() : RoadGeometry
  • GetDistance() : Lane , Road , Section
  • GetDistanceBetweenObjects() : WorldDataQuery
  • GetDistanceToEndOfLane() : WorldDataQuery
  • GetDistanceUntilObjectEntersConnector() : WorldDataQuery
  • GetDistanceUntilObjectLeavesConnector() : WorldDataQuery
  • GetDriverProfileName() : AgentBlueprint
  • GetDV() : RoadGeometryParamPoly3
  • GetElementAndSByPosition() : Stream< T >
  • GetElementId() : RoadLink
  • GetElementType() : RoadLink
  • GetElevations() : Road
  • GetEngineMoment() : DynamicsRegularDrivingImplementation
  • GetEngineMomentMax() : DynamicsRegularDrivingImplementation
  • GetEngineMomentMin() : DynamicsRegularDrivingImplementation
  • GetEngineSpeed() : AlgorithmLongitudinalCalculations
  • GetEngineSpeedByVelocity() : AlgorithmLongitudinalCalculations , DynamicsRegularDrivingImplementation
  • GetEngineTorqueAtGear() : AlgorithmLongitudinalCalculations
  • GetEngineTorqueMax() : AlgorithmLongitudinalCalculations
  • GetEngineTorqueMin() : AlgorithmLongitudinalCalculations
  • GetEntityByName() : ScenarioImporter
  • GetEventDetectors() : EventDetectorNetwork
  • GetEvents() : ManipulatorCommonBase , EventNetwork
  • GetFilteredGroundTruth() : WorldData
  • GetFinalizeTasks() : SchedulerTasks
  • GetFirstContact() : CollisionDetectionPostCrash
  • GetFmuVariables() : AlgorithmFmuWrapperImplementation
  • GetFrictionCoefficient() : DynamicsRegularDrivingImplementation
  • GetGear() : AlgorithmLongitudinalCalculations
  • GetGeometries() : Road
  • GetGeometryInformation() : SensorDriverImplementation , SensorDriverSignal
  • GetGeometryLaneInformation() : SensorDriverImplementation
  • GetGeometryLaneInformationEgo() : SensorDriverImplementation
  • GetHdg() : RoadGeometry , RoadObject
  • GetHeader() : ObservationCyclics
  • GetHeight() : RoadSignal
  • GetId() : ComponentPort , externalParameter< ValueType > , Junction , Lane , LaneBoundary , Road , RoadMarking , TrafficSign , WorldObject , Road , RoadLane , RoadLaneSection , RoadObject , RoadSignal , SpawnPoint
  • GetImplementation() : Component , EventDetector , Manipulator , SpawnPoint
  • GetInDirection() : Road , RoadLane , RoadLaneSection
  • GetInit() : Component
  • GetInputLinks() : Component
  • GetInterpolatedPointsAtDistance() : Lane
  • GetIntersectingConnections() : WorldDataQuery
  • GetIntersectionPoint() : CollisionDetectionPostCrash
  • GetIntersections() : Junction
  • GetInvalidLane() : WorldData
  • GetIsDynamic() : RoadSignal
  • GetJoints() : JointsBuilder
  • GetJunction() : Scenery
  • GetJunctionByOdId() : WorldDataQuery
  • GetJunctionOfConnector() : WorldDataQuery
  • GetJunctions() : Scenery , WorldData
  • GetLaneAssignments() : WorldObject
  • GetLaneBoundaries() : WorldData
  • GetLaneByOdId() : WorldDataQuery
  • GetLaneGeometryElements() : Lane
  • GetLaneIdMapping() : WorldData
  • GetLaneIndexOffset() : RoadLaneSection
  • GetLaneMarkings() : WorldDataQuery
  • GetLaneOffsets() : Road
  • GetLanes() : Section , WorldData , RoadLaneSection
  • GetLaneSection() : RoadLane
  • GetLaneSections() : Road
  • GetLanesOfLaneTypeAtDistance() : WorldDataQuery
  • GetLaneType() : Lane
  • GetLateralDistanceToObject() : SensorDriverCalculations
  • GetLeftLane() : Lane
  • GetLeftLaneBoundaries() : Lane
  • GetLength() : Lane , Road , Section , RoadGeometry , RoadObject , RoadSignal
  • GetLibrary() : EventDetector , Manipulator , SpawnPoint
  • GetLink() : WorldObject
  • GetLocatedPosition() : WorldObject
  • GetManipulators() : ManipulatorNetwork
  • GetMaxReachableState() : CompCtrlToAgentCompSignal , ComponentStateInformation
  • GetMaxReachableStateOfComponentAtLocalLinkId() : StateManager
  • GetMaxReachableStateSetByEvent() : ComponentStateInformation
  • GetMinMax2() : CollisionDetector
  • GetMinMax4() : CollisionDetector
  • GetMovingObjectsInRangeOfJunctionConnection() : WorldDataQuery
  • GetMovingObjectsInSector() : WorldData
  • GetName() : Component
  • GetNewRoute() : SensorDriverImplementation
  • GetNext() : Lane
  • GetNextSpawnCarInfo() : SpawnPointPreRunCommon
  • GetNextSpawnPosition() : WorldAnalyzer
  • GetNextTimestamp() : SchedulerTasks
  • GetNumberOfVertices() : Polygon
  • GetObject() : SensorDriverImplementation
  • GetObjectName() : AgentBlueprint
  • GetObjectsOfTypeInRange() : WorldDataQuery
  • GetObservations() : Component
  • GetObstruction() : WorldDataQuery
  • GetOffsetTime() : Component
  • GetOriginatingRouteLane() : WorldDataQuery
  • GetOtherLane() : SceneryConverter
  • GetOtherObjectInformation() : SensorDriverImplementation
  • GetOutputLinks() : Component
  • GetOwlId() : WorldData
  • GetOwnVehicleInformation() : SensorDriverImplementation , SensorDriverSignal
  • GetPedestrianCatalogPath() : Scenario
  • GetPitch() : RoadSignal
  • GetPositionByDistanceAndLane() : WorldDataQuery
  • GetPositionByElementAndS() : Stream< T >
  • GetPredecessor() : Road , RoadLane
  • GetPrevious() : Lane
  • GetPriorities() : Junction
  • GetPrioritiesOnJunction() : WorldDataQuery
  • GetPriority() : Component
  • GetProfiles() : ConfigurationContainer
  • GetRecurringAgentTasks() : SchedulerTasks
  • GetReferencePointPosition() : RoadMarking , TrafficSign , WorldObject
  • GetRelativeJunctions() : WorldDataQuery
  • GetRelativeLanes() : WorldDataQuery
  • GetRemovedAgents() : AgentNetwork
  • GetRemovedAgentsInPreviousTimestep() : AgentNetwork
  • GetResponseTime() : Component
  • GetRightLane() : Lane
  • GetRightLaneBoundaries() : Lane
  • GetRightLaneCount() : Lane , WorldAnalyzer
  • GetRoad() : Scenery , Lane , Section , RoadLaneSection , RoadSignal
  • GetRoadByOdId() : WorldDataQuery
  • GetRoadGraph() : WorldData
  • GetRoadGraphVertexMapping() : WorldData
  • GetRoadLinks() : Road
  • GetRoadMarkings() : Lane , WorldData
  • GetRoadMarkingsInRange() : WorldDataQuery
  • GetRoadMarkingsInSector() : WorldData
  • GetRoadMarks() : RoadLane
  • GetRoadObjects() : Road
  • GetRoads() : Scenery , WorldData
  • GetRoadSignals() : Road
  • GetRoll() : RoadSignal
  • GetRoute() : SpawnPointScenario
  • GetRouteLeadingToConnector() : WorldDataQuery
  • GetRuntimeInformation() : ConfigurationContainer
  • GetS() : RoadMarking , TrafficSign , RoadGeometry , RoadObject , RoadSignal
  • GetSamplesLine() : ObservationCyclics
  • GetScenario() : ConfigurationContainer
  • GetScenery() : ConfigurationContainer
  • GetSceneryPath() : Scenario
  • GetSection() : Lane
  • GetSectionByDistance() : WorldDataQuery
  • GetSections() : Road
  • GetSEnd() : LaneBoundary
  • getSensorData() : ObjectDetectorBase
  • GetSensorData() : OsmpFmuHandler
  • GetSensorParameters() : AgentBlueprint
  • GetSensorView() : WorldData
  • GetSide() : LaneBoundary , RoadLink
  • GetSignalValue() : ComponentPort
  • GetSignalWithHighestPriority() : SignalPrioritizerImplementation
  • GetSlaveConfig() : ConfigurationContainer
  • GetSOffset() : Section
  • GetSpawningTasks() : SchedulerTasks
  • GetSpawnParameter() : AgentBlueprint
  • GetSpecification() : RoadMarking , TrafficSign
  • GetSpeedGoalMin() : AgentBlueprint
  • GetSquaredError() : BorderPoints
  • GetSStart() : LaneBoundary
  • GetStart() : RoadLaneSection
  • GetStateConditions() : ComponentStateInformation
  • GetStationaryObjectsInSector() : WorldData
  • GetSTCoordinates() : SpawnPointScenario
  • GetStreamPosition() : StreamInfo< T >
  • GetSubType() : RoadSignal
  • GetSuccessor() : Road , RoadLane
  • GetSurroundingObjects() : SensorDriverSignal
  • GetSurroundingObjectsInformation() : SensorDriverImplementation
  • GetSystemConfigBlueprint() : ConfigurationContainer
  • GetSystemConfigs() : ConfigurationContainer
  • GetT() : RoadObject , RoadSignal
  • GetTasks() : SchedulerTasks
  • GetText() : RoadSignal
  • GetTimeSteps() : ObservationCyclics
  • GetTrafficRuleInformation() : SensorDriverImplementation , SensorDriverSignal
  • GetTrafficRuleLaneInformationEgo() : SensorDriverImplementation
  • GetTrafficRuleLaneInformationLeft() : SensorDriverImplementation
  • GetTrafficRuleLaneInformationRight() : SensorDriverImplementation
  • GetTrafficSignIdMapping() : WorldData
  • GetTrafficSigns() : Lane , WorldData
  • GetTrafficSignsInRange() : WorldDataQuery
  • GetTrafficSignsInSector() : WorldData
  • GetTrajectoryCatalogPath() : Scenario
  • GetTrajectoryElementFromCatalog() : ScenarioImporterHelper
  • GetTrigger() : EventNetwork
  • GetTTCObjectParameters() : TtcCalculations
  • GetType() : LaneBoundary , RoadLane , RoadLink , RoadObject , RoadSignal
  • GetUnit() : RoadSignal
  • GetValidLaneSpawningRanges() : WorldAnalyzer
  • GetValue() : externalParameter< ValueType > , InputPort< SignalType, ValueType > , RoadSignal
  • GetValueAndUnitInSI() : TrafficSign
  • GetVehicleCatalogPath() : Scenario
  • GetVehicleComponentNamesToTypeAndStateMap() : StateManager
  • GetVehicleComponentProfileNames() : AgentBlueprint
  • GetVehicleComponentStates() : CompCtrlToAgentCompSignal
  • GetVehicleModelName() : AgentBlueprint
  • GetVehicleModelParameters() : AgentBlueprint
  • GetVehicleModels() : ConfigurationContainer
  • GetVehicleProfileName() : AgentBlueprint
  • GetVertexTypes() : CollisionDetectionPostCrash
  • GetVertices() : Polygon
  • GetWarnings() : CompCtrlToDriverCompSignal
  • GetWidth() : Lane , LaneBoundary , RoadObject , RoadSignal
  • GetWidths() : RoadLane
  • GetWorldObjectGeometry() : CollisionDetector
  • GetWorldObjects() : Lane
  • GetYaw() : RoadSignal
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • HalfCoord() : RoadGeometrySpiral
  • HalfCurvature() : RoadGeometrySpiral
  • HalfDir() : RoadGeometrySpiral
  • HandleFmiStatus() : AlgorithmFmuWrapperImplementation
  • HasDetectionError() : ObjectDetectorBase
  • HCPA : CollisionAngles
  • HCPAo : CollisionAngles
  • heading : ObjectInformation , OwnVehicleInformation
  • height : ObjectInformation
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • id : ComponentPort , externalParameter< ValueType > , ObjectInformation
  • Import() : ProfilesImporter , SceneryImporter , SlaveConfigImporter , SystemConfigImporter , VehicleModelsImporter , MasterConfigImporter
  • ImportAction() : ScenarioImporter
  • ImportActors() : ScenarioImporter
  • ImportAgentProfiles() : ProfilesImporter
  • ImportAllConfigurations() : ConfigurationContainer
  • ImportAllSensorsOfVehicleProfile() : ProfilesImporter
  • ImportAllVehicleComponentsOfVehicleProfile() : ProfilesImporter
  • ImportAndValidateVersion() : ScenarioImporter
  • ImportByEntityElement() : EventDetectorImporter
  • ImportCatalog() : ScenarioImporter , VehicleModelsImporter
  • ImportCatalogs() : ScenarioImporter
  • ImportConditionByValueElement() : EventDetectorImporter
  • ImportConditionElement() : EventDetectorImporter
  • ImportEndConditionsFromStoryboard() : ScenarioImporter
  • ImportEntities() : ScenarioImporter
  • ImportEntity() : ScenarioImporter
  • ImportEntityAction() : ScenarioImporterHelper
  • ImportEntityCatalogReference() : ScenarioImporter
  • ImportEntityCondition() : EventDetectorImporter
  • ImportEnvironment() : SlaveConfigImporter
  • ImportEventDetector() : EventDetectorImporter
  • ImportExperiment() : SlaveConfigImporter
  • ImportGlobalAction() : ScenarioImporterHelper
  • ImportInitElement() : ScenarioImporter
  • ImportLanePosition() : ScenarioImporter , ScenarioImporterHelper
  • ImportLateralAction() : ScenarioImporterHelper
  • ImportLibraries() : SlaveConfigImporter
  • ImportLongitudinalAction() : ScenarioImporterHelper
  • ImportManeuverElement() : ScenarioImporter
  • ImportMembers() : ScenarioImporter
  • ImportModelBoundingBox() : VehicleModelsImporter
  • ImportOrientation() : ScenarioImporter , ScenarioImporterHelper
  • ImportPedestrianCatalog() : VehicleModelsImporter
  • ImportPedestrianModel() : VehicleModelsImporter
  • ImportPosition() : ScenarioImporterHelper
  • ImportPrivateAction() : ScenarioImporterHelper
  • ImportPrivateElement() : ScenarioImporter
  • ImportPrivateElements() : ScenarioImporter
  • ImportProfileGroups() : ProfilesImporter
  • ImportProperties() : VehicleModelsImporter
  • ImportRelativeLanePosition() : ScenarioImporterHelper
  • ImportRoadNetwork() : ScenarioImporter
  • ImportRoadPosition() : ScenarioImporterHelper
  • ImportRoutingAction() : ScenarioImporterHelper
  • ImportScenario() : SlaveConfigImporter
  • ImportSelectionElements() : ScenarioImporter
  • ImportSensorLinksOfComponent() : ProfilesImporter
  • ImportSensorParameters() : ProfilesImporter
  • ImportSpawners() : SlaveConfigImporter
  • ImportStochastics() : ScenarioImporterHelper
  • ImportStoryboard() : ScenarioImporter
  • ImportStoryElement() : ScenarioImporter
  • ImportSystemParameters() : SystemConfigImporter
  • ImportTeleportAction() : ScenarioImporterHelper
  • ImportUserDefinedAction() : ScenarioImporterHelper
  • ImportVehicleCatalog() : VehicleModelsImporter
  • ImportVehicleComponent() : ProfilesImporter
  • ImportVehicleModel() : VehicleModelsImporter
  • ImportVehicleModelAxle() : VehicleModelsImporter
  • ImportVehicleModelAxles() : VehicleModelsImporter
  • ImportVehicleModelGears() : VehicleModelsImporter
  • ImportVehicleModelPerformance() : VehicleModelsImporter
  • ImportVehicleProfile() : ProfilesImporter
  • ImportVehicleProfiles() : ProfilesImporter
  • ImportVisibilityAction() : ScenarioImporterHelper
  • ImportWorldPosition() : ScenarioImporter , ScenarioImporterHelper
  • in_accPedalPos : ActionLongitudinalDriverImplementation , DynamicsRegularDrivingImplementation
  • in_aCoasting : Action_BrakeLight_Basic_Implementation
  • in_aVehicle : Action_BrakeLight_Basic_Implementation , Dynamics_Longitudinal_Basic_Implementation
  • in_brakePedalPos : ActionLongitudinalDriverImplementation , DynamicsRegularDrivingImplementation
  • in_distance2NextAgent : Algorithm_CruiseControlByDistance_Implementation
  • in_flasherSwitch : ActionSecondaryDriverTasksImplementation
  • in_gear : ActionLongitudinalDriverImplementation , DynamicsRegularDrivingImplementation
  • in_headLightSwitch : ActionSecondaryDriverTasksImplementation
  • in_highBeamLightSwitch : ActionSecondaryDriverTasksImplementation
  • in_hornSwitch : ActionSecondaryDriverTasksImplementation
  • in_IndicatorState : ActionSecondaryDriverTasksImplementation
  • in_steeringMax : SteeringController
  • in_steeringRatio : SteeringController
  • in_steeringWheelAngle : DynamicsRegularDrivingImplementation , SteeringController
  • in_velocity : Algorithm_CruiseControlByDistance_Implementation , SteeringController
  • in_wheelBase : SteeringController
  • IndexElements() : SceneryConverter
  • inertiaTireX : VehicleSimpleTT
  • Init() : DynamicsRegularTwoTrackImplementation , DataStoreLibrary , EventDetectorLibrary , ManipulatorLibrary , ModelLibrary , ObservationLibrary , SpawnPointLibrary , StochasticsLibrary , WorldLibrary
  • InitEgoVehicle() : AgentAdapter
  • InitFmu() : AlgorithmFmuWrapperImplementation
  • Initialize() : EventNetwork
  • initializedAccelerationInput : AlgorithmLongitudinalImplementation
  • initializedSensorDriverData : AlgorithmLongitudinalImplementation
  • initializedVehicleModelParameters : AlgorithmLongitudinalImplementation
  • InitPreRun() : RunInstantiator
  • InitSetEngine() : VehicleSimpleTT
  • InitSetGeometry() : VehicleSimpleTT
  • InitSetTire() : VehicleSimpleTT
  • inputFileName : fmu_check_data_t
  • InputPort() : InputPort< SignalType, ValueType >
  • inputPorts : DynamicsRegularTwoTrackImplementation
  • Insert() : ObservationCyclics
  • InsertEvent() : EventNetwork
  • InsertTrigger() : EventNetwork
  • Instantiate() : DataStoreBinding , EventDetectorBinding , EventDetectorNetwork , ManipulatorBinding , ManipulatorNetwork , ModelBinding , ObservationBinding , SpawnPointBinding , StochasticsBinding , World , WorldBinding
  • inStreamDirection : StreamInfo< T >
  • interFriction : CollisionDetectionPostCrash
  • interpContinuousData : fmi1_csv_input_t
  • interpData : fmi1_csv_input_t , fmi2_csv_input_t
  • interpIndex1 : fmi1_csv_input_t , fmi2_csv_input_t
  • interpIndex2 : fmi1_csv_input_t , fmi2_csv_input_t
  • interpLambda : fmi1_csv_input_t , fmi2_csv_input_t
  • interpTime : fmi1_csv_input_t , fmi2_csv_input_t
  • Invalid() : Obstruction
  • Is() : WorldObject
  • isActive : DynamicsPostCrashImplementation , PostCrashVelocity
  • IsActive() : SignalPrioritizerImplementation
  • IsAgentAffectedByEvent() : ComponentControllerImplementation
  • IsBelowMaximumNumberOfExecutions() : ConditionalEventDetector
  • IsFullfilled() : Condition
  • isInstantiated() : World
  • IsInStreamDirection() : Road
  • IsOffsetValidForLane() : SpawnPointPreRunCommon
  • IsOpen() : LogOutputPolicy
  • isOverlapping : Obstruction
  • IsPrior() : SignalPrioritizerImplementation
  • IsRelative() : Directories
  • isStatic : ObjectInformation
  • IsSValidOnLane() : WorldDataQuery
  • IsValidForLane() : RoadMarking , TrafficSign , RoadObject , RoadSignal
  • IsWithin() : PointQuery
  • isWithinEngineLimits() : AlgorithmLongitudinalCalculations
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- j -

  • joints : JointsBuilder
  • JointsBuilder() : JointsBuilder
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • Lane() : Lane
  • laneEgo : GeometryInformation , TrafficRuleInformation
  • laneLeft : GeometryInformation , TrafficRuleInformation
  • laneMarkingsLeft : TrafficRuleInformation
  • laneMarkingsLeftOfLeftLane : TrafficRuleInformation
  • laneMarkingsRight : TrafficRuleInformation
  • laneMarkingsRightOfRightLane : TrafficRuleInformation
  • laneRight : GeometryInformation , TrafficRuleInformation
  • lateralAcceleration : LateralDynamicConstants
  • lateralDynamicConstants : AlgorithmAgentFollowingDriverModelImplementation
  • lateralPosition : OwnVehicleInformation
  • LateralSignal() : LateralSignal
  • left : Obstruction
  • Length() : Vector2d , Vector3d
  • length : ObjectInformation
  • libraryDir : Directories
  • libraryName : ObservationInstance
  • LocalLinkIdIsRegistered() : StateManager
  • Log() : AgentAdapter , AgentNetwork , CollisionDetectionPostCrash , StateManager , EventDetectorCommonBase , ManipulatorCommonBase , WorldData , SceneryConverter , Callbacks , StochasticsImplementation , World_Basic_Implementation , WorldImplementation
  • log_file : fmu_check_data_t
  • log_file_name : fmu_check_data_t
  • LogError() : SpawnPointPreRunCommon , SpawnPointRuntimeCommon , SpawnPointScenario
  • logFileFullName : AlgorithmFmuWrapperImplementation
  • logFileName : AlgorithmFmuWrapperImplementation
  • logGuard : Log< T >
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • mainLaneLocator : Obstruction
  • mainLocatePoint : ObjectPosition
  • make() : AgentBuildInformation , SampledProfiles
  • MarkDirectionRoad() : SceneryConverter
  • MarkDirections() : SceneryConverter
  • massTotal : VehicleSimpleTT
  • MasterPostHook() : Observation_State_Implementation , Observation_Ttc_Implementation
  • MasterPreHook() : Observation_State_Implementation , Observation_Ttc_Implementation
  • maxAcceleration : AlgorithmAgentFollowingDriverModelImplementation
  • maxOutputPts : fmu_check_data_t
  • maxOutputPtsSetByUser : fmu_check_data_t
  • maxReachableState : CompCtrlToAgentCompSignal
  • meanCurvatureToFarPointSmoothLast : SteeringController
  • meanCurvatureToNearPointSmoothLast : SteeringController
  • minDistance : AlgorithmAgentFollowingDriverModelImplementation
  • MkDirOrThrowError() : AlgorithmFmuWrapperImplementation
  • modelIdentifierFMI1 : fmu_check_data_t
  • momentTotalZ : VehicleSimpleTT
  • movingDirection : DynamicsPostCrashImplementation
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • NewAgentIntersectsWithExistingAgent() : SpawnPointPreRunCommon
  • nextOutputStep : fmu_check_data_t
  • nextOutputTime : fmu_check_data_t
  • NextStateRotation() : DynamicsRegularTwoTrackImplementation
  • NextStateSet() : DynamicsRegularTwoTrackImplementation
  • NextStateTranslation() : DynamicsRegularTwoTrackImplementation
  • NoOpponent() : Obstruction
  • Norm() : Vector2d , Vector3d
  • NormalizeAngle() : WorldData
  • Now() : TimeKeeper
  • num_errors : fmu_check_data_t
  • num_fatal : fmu_check_data_t
  • num_fmu_messages : fmu_check_data_t
  • num_warnings : fmu_check_data_t
  • numberOfCollisionPartners : DynamicsPostCrashImplementation
  • numberOfExecutions : ConditionalEventDetectorInformation
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • object : LaneChangeParameter
  • objectFront : SurroundingObjects
  • objectFrontLeft : SurroundingObjects
  • objectFrontRight : SurroundingObjects
  • ObjectIsOfTypeAndWithinRange() : WorldDataQuery
  • objectRear : SurroundingObjects
  • objectRearLeft : SurroundingObjects
  • objectRearRight : SurroundingObjects
  • Obstruction() : Obstruction
  • OCPA : CollisionAngles
  • OCPAo : CollisionAngles
  • OpeningAngleWithinFullCircle() : SensorGeometric2D
  • OpeningAngleWithinHalfCircle() : SensorGeometric2D
  • operator AgentBuildInformation &&() : DynamicAgentTypeGenerator
  • operator SampledProfiles &&() : DynamicProfileSampler
  • operator std::string() : AccelerationSignal , AgentCompToCompCtrlSignal , BoolSignal , CompCtrlToAgentCompSignal , ComponentStateSignal , DoubleSignal , DynamicsSignal , IntSignal , LateralSignal , LongitudinalSignal , ParametersVehicleSignal , SecondaryDriverTasksSignal , SensorDataSignal , SensorDriverSignal , SignalVector< DT > , SpeedActionSignal , SteeringSignal , TrajectorySignal
  • operator!=() : Vector2d
  • operator()() : VisitParameterElement
  • operator<< : Vector2d
  • operator==() : Vector2d
  • os : Log< T >
  • out_accPedalPos : AlgorithmLongitudinalImplementation
  • out_aCoasting : Algorithm_CruiseControlByDistance_Implementation
  • out_agentVelocity : Sensor_Distance_Implementation
  • out_brakePedalPos : AlgorithmLongitudinalImplementation
  • out_curvature : AlgorithmAgentFollowingDriverModelImplementation
  • out_desiredAcceleration : Algorithm_CruiseControlByDistance_Implementation
  • out_desiredSteeringWheelAngle : AlgorithmLateralImplementation
  • out_distanceToNextAgent : Sensor_Distance_Implementation
  • out_file : fmu_check_data_t
  • out_flasher : AlgorithmAgentFollowingDriverModelImplementation
  • out_gear : AlgorithmLongitudinalImplementation
  • out_headLight : AlgorithmAgentFollowingDriverModelImplementation
  • out_highBeamLight : AlgorithmAgentFollowingDriverModelImplementation
  • out_hornSwitch : AlgorithmAgentFollowingDriverModelImplementation
  • out_indicatorState : AlgorithmAgentFollowingDriverModelImplementation
  • out_laneWidth : AlgorithmAgentFollowingDriverModelImplementation
  • out_lateral_damping : AlgorithmAgentFollowingDriverModelImplementation
  • out_lateral_displacement : AlgorithmAgentFollowingDriverModelImplementation
  • out_lateral_frequency : AlgorithmAgentFollowingDriverModelImplementation
  • out_lateral_gain_displacement : AlgorithmAgentFollowingDriverModelImplementation
  • out_lateral_gain_heading_error : AlgorithmAgentFollowingDriverModelImplementation
  • out_lateral_heading_error : AlgorithmAgentFollowingDriverModelImplementation
  • out_lateral_speed : AlgorithmAgentFollowingDriverModelImplementation
  • out_longitudinal_acc : AlgorithmAgentFollowingDriverModelImplementation
  • Output() : LogOutputPolicy
  • output_file_name : fmu_check_data_t
  • outputDir : Directories
  • outputFileFullName : AlgorithmFmuWrapperImplementation
  • outputFileName : AlgorithmFmuWrapperImplementation
  • OutputPort() : OutputPort< SignalType, ValueType >
  • ownVehicleInformation : SensorDriverImplementation , SensorDriverSignal
  • OYA : CollisionAngles
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • Par_demandHighway : SpawnPoint_Start_Implementation
  • Par_desiredVelocity : Algorithm_CruiseControlByDistance_Implementation
  • Par_finalFileName : Observation_Ttc_Implementation
  • Par_NSpawnCars : SpawnPoint_Start_Implementation
  • Par_reactionTime : Algorithm_CruiseControlByDistance_Implementation
  • Par_resultFolderName : Observation_Ttc_Implementation
  • Par_tempFileName : Observation_Ttc_Implementation
  • Par_vMean : SpawnPoint_Start_Implementation
  • Par_vMin : SpawnPoint_Start_Implementation
  • Par_vSd : SpawnPoint_Start_Implementation
  • Par_WriteOutputForVisualisation : Observation_State_Implementation
  • ParameterizedAttribute() : ParameterizedAttribute< T >
  • parameters : ObservationInstance
  • ParametersVehicleSignal() : ParametersVehicleSignal
  • Parse() : AgentParser
  • ParseBasicParameter() : ObjectDetectorBase
  • ParseConditionAttributes() : ScenarioImporter
  • ParseElementValidity() : SceneryImporter
  • ParseElevationProfile() : SceneryImporter
  • ParseGeometries() : SceneryImporter
  • ParseJunctionConnectionLinks() : SceneryImporter
  • ParseJunctionConnections() : SceneryImporter
  • ParseJunctionPriorities() : SceneryImporter
  • ParseJunctions() : SceneryImporter
  • ParseLaneRoadMark() : SceneryImporter
  • ParseLanes() : SceneryImporter
  • ParseObject() : SceneryImporter
  • ParseObjectRepeat() : SceneryImporter
  • ParseObjects() : SceneryImporter
  • ParseOptionalInterval() : SceneryImporter
  • ParseParameters() : AlgorithmAutonomousEmergencyBrakingImplementation
  • ParseRepeat() : SceneryImporter
  • ParseRoadLanes() : SceneryImporter
  • ParseRoadLinks() : SceneryImporter
  • ParseRoads() : SceneryImporter
  • ParseRoadTypes() : SceneryImporter
  • ParseSenderPriorities() : SignalPrioritizerImplementation
  • ParseSignals() : SceneryImporter
  • ParseSignalUnit() : SceneryImporter
  • ParseSimulationTime() : ScenarioImporter
  • ParseSlaveConfig() : MasterConfigImporter
  • ParseSlaveConfigs() : MasterConfigImporter
  • pedestrianCatalogPath : Scenario
  • penetrationTime : CollisionDetectionPostCrash
  • PlausibleTestAcceleration() : Algorithm_CruiseControlByDistance_Implementation
  • pointOfContactLocal : PostCrashDynamic
  • positionCar : DynamicsRegularTwoTrackImplementation
  • positionTire : VehicleSimpleTT
  • PostCrashDynamic() : PostCrashDynamic
  • powerEngineLimit : VehicleSimpleTT
  • previousDistance : Algorithm_CruiseControlByDistance_Implementation
  • print_all_event_vars : fmu_check_data_t
  • printed_instance_name_error_flg : fmu_check_data_t
  • PropagateParametersForward() : TtcCalculations
  • PublishGlobalData() : AgentNetwork
  • PullNonRecurringTasks() : SchedulerTasks
  • pulse : PostCrashDynamic
  • pulseDirection : PostCrashDynamic
  • pulseLocal : PostCrashDynamic
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • QueueAgentRemove() : AgentNetwork
  • QueueAgentUpdate() : AgentNetwork
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • RadiantToDegree : SteeringController
  • ReadDocument() : MasterConfigImporter
  • ReadPreviousState() : DynamicsRegularTwoTrackImplementation
  • referencePoint : LongitudinalDistance
  • referenceScale : LocalizationElement
  • referenceVector : LocalizationElement
  • Register() : ActionTransformRepository , CustomCommandFactory
  • relativeLateralDistance : ObjectInformation
  • relativeLongitudinalDistance : ObjectInformation
  • ReleaseComponent() : ModelLibrary
  • ReleaseDataStore() : DataStoreLibrary
  • ReleaseEventDetector() : EventDetectorLibrary
  • ReleaseFromLibrary() : Component
  • ReleaseManipulator() : ManipulatorLibrary
  • ReleaseObservationModule() : ObservationLibrary
  • ReleaseOutputData() : Component
  • ReleaseStochastics() : StochasticsLibrary
  • ReleaseWorld() : WorldLibrary
  • RemoveAgent() : AgentNetwork
  • RemoveCsvCyclics() : ObservationFileHandler
  • RemoveMovingObjectById() : WorldData
  • ReportingLevel() : Log< T >
  • repository() : CustomCommandFactory
  • require_cs : fmu_check_data_t
  • require_me : fmu_check_data_t
  • Reset() : EventDetectorCommonBase , WorldData
  • ResetAll() : EventDetectorNetwork
  • Resolve() : Directories
  • Reverse() : Stream< T >
  • right : Obstruction
  • Rotate() : Vector2d
  • Run() : Scheduler
  • runID : Observation_Ttc_Implementation
  • runNumber : Observation_State_Implementation , ObservationFileHandler
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • SampleAgent() : AgentBlueprintProvider
  • SampleDriverProfile() : DynamicProfileSampler
  • SampleSensorLatency() : DynamicAgentTypeGenerator
  • SampleVehicleComponentProfiles() : DynamicProfileSampler
  • SampleVehicleProfile() : DynamicProfileSampler
  • Scale() : Vector2d , Vector3d
  • sceneryPath : Scenario
  • ScheduleAgentTasks() : Scheduler
  • ScheduleNewNonRecurringTasks() : SchedulerTasks
  • ScheduleNewRecurringTasks() : SchedulerTasks
  • ScheduleNewTasks() : SchedulerTasks
  • search_box : LocalizationElement
  • SecondaryDriverTasksSignal() : SecondaryDriverTasksSignal
  • sEnd : LaneBoundary
  • sensorData : SensorDataSignal
  • SensorDataSignal() : SensorDataSignal
  • SensorDriverImplementation() : SensorDriverImplementation
  • SensorDriverSignal() : SensorDriverSignal
  • SetAbsOrientation() : WorldObject
  • SetAcceleration() : AlgorithmAutonomousEmergencyBrakingImplementation
  • SetAgentCategory() : AgentBlueprint
  • SetAgentProfileName() : AgentBlueprint
  • SetCenterLaneBoundary() : Section , WorldData
  • SetCollisionAngles() : CollisionDetectionPostCrash
  • SetCurrentState() : ComponentStateInformation
  • SetDesiredState() : ComponentStateInformation
  • SetDimension() : WorldObject
  • SetDriverProfileName() : AgentBlueprint
  • SetFadingDynamics() : DynamicsPostCrashImplementation
  • SetFile() : LogOutputPolicy
  • SetId() : RoadLaneSection
  • SetImplementation() : Component
  • SetInDirection() : Road , RoadLane , RoadLaneSection
  • SetInputBuffer() : Component
  • SetLaneIndexOffset() : RoadLaneSection
  • SetLaneType() : Lane
  • SetLateralInput() : SteeringController
  • SetLeftLane() : Lane
  • SetLeftLaneBoundaries() : Lane
  • SetLocatedPosition() : WorldObject
  • SetMaxReachableState() : ComponentStateInformation
  • SetMaxReachableStateSetByEvent() : ComponentStateInformation
  • SetModelLibrary() : Component
  • SetObjectName() : AgentBlueprint
  • SetObservations() : Component
  • SetOutputLocation() : ObservationFileHandler
  • SetParameter() : SpawnPointBinding
  • SetPedestrianCatalogPath() : Scenario
  • SetPredecessor() : Road
  • SetReferencePointPosition() : WorldObject
  • SetRightLane() : Lane
  • SetRoad() : Section
  • SetRoadGraph() : WorldData
  • SetRoadPredecessor() : WorldData
  • SetRoadPredecessorJunction() : WorldData
  • SetRoadSuccessor() : WorldData
  • SetRoadSuccessorJunction() : WorldData
  • SetS() : RoadMarking , TrafficSign
  • SetSceneryPath() : Scenario
  • SetSectionPredecessor() : WorldData
  • SetSectionSuccessor() : WorldData
  • SetSensorViewInput() : OsmpFmuHandler
  • SetSignalValue() : ComponentPort
  • SetSpawnParameter() : AgentBlueprint
  • SetSpecification() : RoadMarking , TrafficSign
  • SetSpeedGoalMin() : AgentBlueprint
  • SetSuccessor() : Road
  • SetTrajectoryCatalogPath() : Scenario
  • SetupFilenames() : AlgorithmFmuWrapperImplementation
  • SetupLog() : AlgorithmFmuWrapperImplementation
  • SetupOutput() : AlgorithmFmuWrapperImplementation
  • SetupUnzip() : AlgorithmFmuWrapperImplementation
  • SetValidForLane() : RoadMarking , TrafficSign
  • SetValue() : externalParameter< ValueType > , OutputPort< SignalType, ValueType >
  • SetVehicleCatalogPath() : Scenario
  • SetVehicleComponentProfileNames() : AgentBlueprint
  • SetVehicleModelName() : AgentBlueprint
  • SetVehicleModelParameters() : AgentBlueprint , DynamicAgentTypeGenerator
  • SetVehicleParameter() : SteeringController
  • SetVehicleProfileName() : AgentBlueprint
  • SetVelocity() : VehicleSimpleTT
  • SetVelocityAndSteeringWheelAngle() : SteeringController
  • SetVertices() : Polygon
  • sHdg : LaneGeometryJoint
  • ShiftPolygonsAndCheckIntersection() : CollisionDetectionPostCrash
  • ShouldBeActivated() : AlgorithmAutonomousEmergencyBrakingImplementation
  • ShouldBeDeactivated() : AlgorithmAutonomousEmergencyBrakingImplementation
  • side : LaneBoundary
  • slave_initialized : fmu_check_data_t
  • slaveConfigFile : ConfigurationFiles
  • SlavePostHook() : Observation_State_Implementation , Observation_Ttc_Implementation
  • SlavePostRunHook() : Observation_State_Implementation , Observation_Ttc_Implementation
  • SlavePreHook() : Observation_Ttc_Implementation
  • SlavePreRunHook() : Observation_State_Implementation , Observation_Ttc_Implementation
  • SlaveResultFile() : Observation_State_Implementation , Observation_Ttc_Implementation
  • SlaveUpdateHook() : Observation_State_Implementation , Observation_Ttc_Implementation
  • sliding : PostCrashDynamic
  • sOffset : LaneGeometryJoint , StreamInfo< T >
  • sOffsets : IntersectionInfo
  • SpawnWillCauseCrash() : WorldAnalyzer
  • SpeedActionSignal() : SpeedActionSignal
  • sStart : LaneBoundary
  • StartS() : StreamInfo< T >
  • startTime : AlgorithmFmuWrapperImplementation
  • staticStore : BasicDataStoreImplementation
  • SteeringSignal() : SteeringSignal
  • steeringWheelAngle : OwnVehicleInformation
  • stepSize : fmu_check_data_t
  • stepSizeSetByUser : fmu_check_data_t
  • stopTime : fmu_check_data_t
  • store : AcyclicResult , CyclicResult
  • StreamInfo() : StreamInfo< T >
  • StripFile() : Directories
  • Sub() : Vector2d , Vector3d
  • supportedScenarioVersion : ScenarioImporter
  • surroundingObjects : SensorDriverImplementation , SensorDriverSignal
  • SyncGlobalData() : AgentNetwork
  • systemConfigBlueprintFile : ConfigurationFiles
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • tAverage : SteeringController
  • tAxisCenter : LocalizationElement
  • temp_dir : fmu_check_data_t
  • tGapWish : AlgorithmAgentFollowingDriverModelImplementation
  • throttlePedal : DynamicsRegularTwoTrackImplementation
  • time : TimeKeeper
  • timeAndEntityIdIndex : BasicDataStoreImplementation
  • timeChannel : Observation_State_Implementation
  • timeLast : SteeringController
  • timestampIndex : BasicDataStoreImplementation
  • timeStep : DynamicsRegularTwoTrackImplementation
  • timeVector : Observation_Ttc_Implementation
  • tmpPath : fmu_check_data_t
  • torqueBrakeLimit : VehicleSimpleTT
  • torqueEngineLimit : VehicleSimpleTT
  • ToString() : Log< T >
  • touchedRoads : ObjectPosition
  • trafficRuleInformation : SensorDriverImplementation , SensorDriverSignal
  • trafficSigns : LaneInformationTrafficRules
  • trajectoryCatalogPath : Scenario
  • TrajectorySignal() : TrajectorySignal
  • Transform() : ActionTransformRepository , TransformerBase< T, Signal, TriggeringEvent >
  • TransformPointToLocalCoordinates() : ObjectDetectorBase
  • TransformPolygonToGlobalCoordinates() : ObjectDetectorBase
  • Translate() : Vector2d , Vector3d , Polygon
  • Trigger() : Action_BrakeLight_Basic_Implementation , ActionLongitudinalDriverImplementation , ActionSecondaryDriverTasksImplementation , AgentUpdaterImplementation , Algorithm_CruiseControlByDistance_Implementation , AlgorithmAgentFollowingDriverModelImplementation , AlgorithmAutonomousEmergencyBrakingImplementation , AlgorithmLateralImplementation , CollisionDetector , CollisionManipulator , ComponentControllerImplementation , ComponentStateChangeManipulator , Dynamics_Longitudinal_Basic_Implementation , DynamicsCollisionImplementation , DynamicsPostCrashImplementation , DynamicsRegularDrivingImplementation , DynamicsRegularTwoTrackImplementation , EventDetectorCommonBase , LaneChangeManipulator , LimiterAccelerationVehicleComponentsImplementation , ManipulatorCommonBase , ObjectDetectorBase , RemoveAgentsManipulator , Sensor_Distance_Implementation , SensorFusionImplementation , SensorRecordStateImplementation , ModelLibrary , SpawnPointPreRunCommon , SpawnPointRuntimeCommon , SpawnPointScenario , SpeedActionManipulator , TrajectoryFollowerImplementation , TrajectoryManipulator
  • TriggerCycle() : Component
  • TriggerEventInsertion() : ConditionalEventDetector
  • TriggerPostCrashCheck() : DynamicsPostCrashImplementation
  • ttcBrake : AlgorithmAutonomousEmergencyBrakingImplementation
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • Unload() : DataStoreBinding , EventDetectorBinding , ManipulatorBinding , ModelBinding , ObservationBinding , SpawnPointBinding , StochasticsBinding , WorldBinding
  • unzipPathBuf : fmu_check_data_t
  • UpdateAcceleration() : AlgorithmAutonomousEmergencyBrakingImplementation
  • UpdateAgents() : Scheduler
  • UpdateCollision() : CollisionManipulator
  • UpdateComponentCurrentState() : StateManager
  • UpdateComponentDesiredState() : StateManager
  • UpdateComponentMaxReachableState() : StateManager
  • UpdateEgoVehicle() : AgentAdapter
  • UpdateGraphPosition() : SensorDriverImplementation
  • UpdateInput() : Action_BrakeLight_Basic_Implementation , ActionLongitudinalDriverImplementation , ActionSecondaryDriverTasksImplementation , AgentUpdaterImplementation , Algorithm_CruiseControlByDistance_Implementation , AlgorithmAgentFollowingDriverModelImplementation , AlgorithmAutonomousEmergencyBrakingImplementation , AlgorithmLateralImplementation , ComponentControllerImplementation , Dynamics_Longitudinal_Basic_Implementation , DynamicsCollisionImplementation , DynamicsPostCrashImplementation , DynamicsRegularDrivingImplementation , DynamicsRegularTwoTrackImplementation , LimiterAccelerationVehicleComponentsImplementation , ObjectDetectorBase , Sensor_Distance_Implementation , SensorFusionImplementation , SensorRecordStateImplementation , SignalPrioritizerImplementation , ModelLibrary , TrajectoryFollowerImplementation
  • UpdateInputData() : Component
  • UpdateMaxReachableStatesForRegisteredComponents() : StateManager
  • UpdateOutput() : Action_BrakeLight_Basic_Implementation , ActionLongitudinalDriverImplementation , ActionSecondaryDriverTasksImplementation , AgentUpdaterImplementation , Algorithm_CruiseControlByDistance_Implementation , AlgorithmAgentFollowingDriverModelImplementation , AlgorithmAutonomousEmergencyBrakingImplementation , AlgorithmLateralImplementation , ComponentControllerImplementation , Dynamics_Longitudinal_Basic_Implementation , DynamicsCollisionImplementation , DynamicsPostCrashImplementation , DynamicsRegularDrivingImplementation , DynamicsRegularTwoTrackImplementation , LimiterAccelerationVehicleComponentsImplementation , ObjectDetectorBase , Sensor_Distance_Implementation , SensorFusionImplementation , SensorRecordStateImplementation , SignalPrioritizerImplementation , ModelLibrary , TrajectoryFollowerImplementation
  • UpdatePosition() : VehicleSimpleTT
  • UpdateScheduledTimestamps() : SchedulerTasks
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • ValidateAxles() : VehicleModelsImporter
  • ValidateOverlappingAgents() : SpawnPointScenario
  • ValidateRoadIdInDirection() : WorldAnalyzer
  • ValidateSTCoordinatesOnLane() : SpawnPointScenario
  • ValidMinimumSpawningDistanceToObjectInFront() : WorldAnalyzer
  • value : BoolSignal , DoubleSignal , externalParameter< ValueType > , InputPort< SignalType, ValueType > , IntSignal , LaneChangeParameter , OutputPort< SignalType, ValueType > , SignalVector< DT >
  • ValueInBounds() : TrafficHelperFunctions
  • Vector2d() : Vector2d
  • Vector3d() : Vector3d
  • vehicle : DynamicsRegularTwoTrackImplementation
  • vehicleCatalogPath : Scenario
  • VehicleComponentStateExpression() : VehicleComponentStateExpression
  • vehicleComponentStates : CompCtrlToAgentCompSignal
  • vehicleModelParameters : AlgorithmLongitudinalImplementation , DynamicsRegularDrivingImplementation
  • velocity : DynamicsPostCrashImplementation , PostCrashDynamic
  • velocityAbsolute : PostCrashVelocity
  • velocityCar : DynamicsRegularTwoTrackImplementation
  • velocityChange : PostCrashDynamic
  • velocityDirection : PostCrashDynamic , PostCrashVelocity
  • version : fmu_check_data_t
  • visibilityDistance : GeometryInformation
  • vl : fmu_check_data_t
  • vl2 : fmu_check_data_t
  • VLowerLimit : DynamicsRegularDrivingImplementation
  • vWish : AlgorithmAgentFollowingDriverModelImplementation
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • warnings : AgentCompToCompCtrlSignal , CompCtrlToDriverCompSignal
  • width : LaneInformationGeometry , ObjectInformation , LaneBoundary
  • WillCrash() : TrafficHelperFunctions
  • WillCrashDuringBrake() : TrafficHelperFunctions
  • write_log_files : fmu_check_data_t
  • write_output_files : fmu_check_data_t
  • WriteCsvCyclics() : ObservationFileHandler
  • WriteEndOfFile() : ObservationFileHandler
  • WriteEntities() : ObservationFileHandler
  • WriteJson() : OsmpFmuHandler
  • WriteParameter() : ObservationFileHandler
  • WriteRun() : ObservationFileHandler
  • WriteStartOfFile() : ObservationFileHandler
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- y -

  • yawAcceleration : DynamicsRegularTwoTrackImplementation
  • yawAngle : DynamicsRegularTwoTrackImplementation
  • yawVelocity : DynamicsRegularTwoTrackImplementation , PostCrashDynamic , PostCrashVelocity
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- z -

  • zeta : LateralDynamicConstants
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~Component() : Component
  • ~ComponentPort() : ComponentPort
  • ~DataStoreLibrary() : DataStoreLibrary
  • ~EventDetector() : EventDetector
  • ~EventDetectorLibrary() : EventDetectorLibrary
  • ~externalParameter() : externalParameter< ValueType >
  • ~InputPort() : InputPort< SignalType, ValueType >
  • ~Manipulator() : Manipulator
  • ~ManipulatorLibrary() : ManipulatorLibrary
  • ~OutputPort() : OutputPort< SignalType, ValueType >
  • ~SpawnPoint() : SpawnPoint
  • ~SpawnPointLibrary() : SpawnPointLibrary
  • ~StochasticsLibrary() : StochasticsLibrary
  • ~WorldLibrary() : WorldLibrary
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- a -

  • AccelerationSignal() : AccelerationSignal
  • AcquireOutputData() : Component
  • Add() : Vector2d , Vector3d
  • AddAgent() : AgentNetwork , ObservationFileHandler
  • AddAgents() : ObservationFileHandler
  • AddBorder() : RoadLane
  • AddBoundaryPoint() : LaneBoundary
  • AddCenterLinePoint() : WorldData
  • AddCollision() : EventNetwork
  • AddCollisionId() : RunResult
  • AddComponent() : StateManager
  • AddConnectingRoad() : Junction
  • AddElevation() : Road
  • AddEvents() : ObservationFileHandler
  • AddGeometryArc() : Road
  • AddGeometryLine() : Road
  • AddGeometryParamPoly3() : Road
  • AddGeometryPoly3() : Road
  • AddGeometrySpiral() : Road
  • AddHeader() : ObservationFileHandler
  • AddInputLink() : Component
  • AddIntersectionInfo() : Junction
  • AddJunction() : Scenery , WorldData
  • AddJunctionConnection() : WorldData
  • AddJunctionPriority() : WorldData
  • AddLane() : Section , WorldData
  • AddLaneAssignment() : WorldObject
  • AddLaneBoundary() : WorldData
  • AddLaneGeometryJoint() : Lane
  • AddLaneGeometryPoint() : WorldData
  • AddLaneOffset() : Road
  • AddLanePredecessor() : WorldData
  • AddLaneSuccessor() : WorldData
  • AddLink() : Road
  • AddMovingObject() : Lane , WorldData
  • AddMovingObjectToSensorData() : SensorGeometric2D
  • AddNext() : Lane , Section
  • AddOutputLink() : Component
  • AddParsedObjectsToRoad() : SceneryImporter
  • AddPredecessor() : RoadLane
  • AddPrevious() : Lane , Section
  • AddPriority() : Junction
  • AddReference() : ObservationFileHandler
  • AddRoad() : Scenery , WorldData
  • AddRoadLane() : RoadLaneSection
  • AddRoadLaneSection() : Road
  • AddRoadMark() : RoadLane
  • AddRoadMarking() : Lane , WorldData
  • AddRoadSignal() : Road
  • AddSamples() : ObservationFileHandler
  • AddSection() : Road , WorldData
  • AddSensor() : AgentBlueprint , ObservationFileHandler
  • AddSensors() : ObservationFileHandler
  • AddStateCondition() : ComponentStateInformation
  • AddStationaryObject() : Lane , WorldData
  • AddStationaryObjectToSensorData() : SensorGeometric2D
  • AddSuccessor() : RoadLane
  • AddSupplementarySign() : TrafficSign
  • AddTask() : Tasks
  • AddTrafficSign() : Lane , WorldData
  • AddVehicleAttributes() : ObservationFileHandler
  • AddWidth() : RoadLane
  • AddWorldObject() : Lane
  • AgentBuildInformation() : AgentBuildInformation
  • AgentCompToCompCtrlSignal() : AgentCompToCompCtrlSignal
  • AgentIsAffected() : TransformerBase< T, Signal, TriggeringEvent >
  • AlgorithmAgentFollowingDriverModelImplementation() : AlgorithmAgentFollowingDriverModelImplementation
  • AlgorithmLongitudinalCalculations() : AlgorithmLongitudinalCalculations
  • Angle() : Vector2d
  • ApplyGearLimit() : DynamicsRegularDrivingImplementation
  • ApplyLatency() : ObjectDetectorBase
  • ApplyMeasurementError() : ObjectDetectorBase
  • ApplyPedalPositionLimits() : DynamicsRegularDrivingImplementation
  • ApplyRepeat() : SceneryImporter
  • ApplySectorFilter() : WorldData
  • AreSpawningCoordinatesValid() : SpawnPointPreRunCommon , WorldAnalyzer
  • As() : WorldObject
  • AssignProperty() : VehicleModelsImporter
  • AssignRoadMarkingToLane() : WorldData
  • AssignTrafficSignToLane() : WorldData
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- b -

  • Build() : RoadNetworkBuilder
  • BuildEventDetectorTasks() : TaskBuilder
  • BuildManipulatorTasks() : TaskBuilder
  • BuildResult() : Localizer
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- c -

  • CalcInitialBrightArea() : SensorGeometric2D
  • CalcObjectShadow() : SensorGeometric2D
  • CalcObjectVisibilityPercentage() : SensorGeometric2D
  • CalculateAllIntersectionPoints() : CollisionDetectionPostCrash
  • CalculateAttributeValue() : SpawnPointScenario
  • CalculateBoundingBox() : BoundingBoxCalculation , ObjectDetectorBase , TtcCalculations
  • CalculateCentroid() : Polygon
  • CalculateCollisionAngles() : CollisionDetectionPostCrash
  • CalculateCurvatures() : JointsBuilder
  • CalculateDistOnBorder() : CollisionDetector
  • CalculateGearAndEngineSpeed() : AlgorithmLongitudinalCalculations
  • CalculateGlobalSensorPosition() : ObjectDetectorBase
  • CalculateHeadings() : JointsBuilder
  • CalculateIntersectionPoints() : CollisionDetector
  • CalculateNetTimeGap() : TrafficHelperFunctions
  • CalculateNextTimestep() : TrajectoryFollowerImplementation
  • CalculateObjectTTC() : AlgorithmAutonomousEmergencyBrakingImplementation , TtcCalculations
  • CalculateOwnBoundingBox() : BoundingBoxCalculation
  • CalculatePedalPositionAndGear() : AlgorithmLongitudinalImplementation
  • CalculatePedalPositions() : AlgorithmLongitudinalCalculations
  • CalculatePlaneOfContact() : CollisionDetectionPostCrash
  • CalculatePointOfContact() : CollisionDetector
  • CalculatePoints() : JointsBuilder
  • CalculatePositionIfOnLane() : WorldDataQuery
  • CalculatePostCrashDynamic() : CollisionDetectionPostCrash
  • CalculateRelativeVector() : ObjectDetectorBase
  • CalculateSinusiodalLaneChange() : OscActionsCalculation
  • CalculateSpawnParameter() : SpawnPointPreRunCommon , SpawnPointRuntimeCommon , SpawnPointScenario
  • CalculateSpawnVelocityToPreventCrashing() : WorldAnalyzer
  • CalculateSteeringAngle() : SteeringController
  • CalculateTTC() : AlgorithmAutonomousEmergencyBrakingImplementation
  • CalculateWorldObjectGeometry() : CollisionDetector
  • CalcVisualObstruction() : SensorGeometric2D
  • CategorizeEntities() : ScenarioImporter
  • CheckCondition() : ConditionalEventDetector
  • CheckModelParameters() : VehicleModelsImporter
  • CheckOrDefault() : MasterConfig
  • checkRoadSignalBoundaries() : SceneryImporter
  • Clear() : AgentNetwork , Scenery , ObservationCyclics , WorldData , EventDetectorNetwork , EventNetwork , ManipulatorNetwork
  • ClearLaneAssignments() : WorldObject
  • ClearMovingObjects() : Lane
  • ClearNonrecurringTasks() : SchedulerTasks
  • Combine() : SampledGeometry
  • CompCtrlToAgentCompSignal() : CompCtrlToAgentCompSignal
  • CompCtrlToDriverCompSignal() : CompCtrlToDriverCompSignal
  • ComponentPort() : ComponentPort
  • Concat() : Directories
  • ConnectAgentLinks() : AgentFactory
  • ConnectExternalRoadPredecessor() : SceneryConverter
  • ConnectExternalRoadSuccessor() : SceneryConverter
  • ConnectJunction() : SceneryConverter
  • ConnectLanes() : WorldData , SceneryConverter
  • ConnectLaneToLane() : SceneryConverter
  • ConnectLaneToSection() : SceneryConverter
  • ConnectPathInJunction() : SceneryConverter
  • ConnectRoadExternalWithElementTypeRoad() : SceneryConverter
  • ConnectRoadInternal() : SceneryConverter
  • ConnectRoads() : SceneryConverter
  • ConsumeNonRecurringAgentTasks() : SchedulerTasks
  • Contains() : Stream< T >
  • ContainsEntity() : EventDetectorImporter , ScenarioImporter
  • ContainsSensor() : ObservationFileHandler
  • ConvertObjects() : SceneryConverter
  • ConvertRoads() : SceneryConverter
  • CopyToGroundTruth() : Lane , LaneBoundary , RoadMarking , TrafficSign , WorldObject
  • Covers() : Lane , Section
  • CoversInterval() : Section
  • Create() : CustomCommandFactory
  • CreateAgent() : AgentFactory
  • CreateBootstrapTasks() : TaskBuilder
  • CreateCollisionDetector() : EventDetectorLibrary
  • CreateComponent() : ModelLibrary
  • CreateDataStore() : DataStoreLibrary
  • CreateFinalizeTasks() : TaskBuilder
  • CreateFivePointDetectionField() : SensorGeometric2D
  • CreateFourPointDetectionField() : SensorGeometric2D
  • CreateLaneMultiStream() : WorldDataQuery
  • CreateLaneStream() : WorldDataQuery
  • CreateManipulator() : ManipulatorLibrary
  • CreateNewScheduledTimestamps() : SchedulerTasks
  • CreateObservationModule() : ObservationLibrary
  • CreateOutputBuffer() : Component
  • CreatePostCrashDynamics() : CollisionDetectionPostCrash
  • CreateRoadMarking() : SceneryConverter
  • CreateRoadMultiStream() : WorldDataQuery
  • CreateRoadStream() : WorldDataQuery
  • CreateSpawningTasks() : TaskBuilder
  • CreateSpawnPoint() : SpawnPointLibrary
  • CreateStochastics() : StochasticsLibrary
  • CreateSynchronizeTasks() : TaskBuilder
  • CreateTrafficSign() : SceneryConverter
  • CreateWorld() : WorldLibrary
  • Cross() : Vector2d
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- d -

  • DeleteAgentTasks() : SchedulerTasks
  • DeleteTasks() : Tasks
  • DetectCollision() : CollisionDetector
  • DetectedCollisionWithAgent() : CollisionDetector
  • DetectedCollisionWithObject() : CollisionDetector
  • DetectIntersectionOfTwoWorldObjects() : CollisionDetector
  • DetectObjects() : SensorGeometric2D
  • DetermineDefaultMaximumComponentStateByType() : AdasComponentStateInformation
  • DetermineEgoCollision() : RunStatisticCalculation
  • Dot() : Vector2d
  • DriveTrain() : VehicleSimpleTT
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- e -

  • EndS() : StreamInfo< T >
  • Error() : SignalPrioritizerImplementation
  • EvaluateConditions() : ConditionalEventDetector
  • ExecuteRun() : RunInstantiator
  • ExecuteTasks() : Scheduler
  • Exists() : Lane
  • ExpandUpperBoundary() : SchedulerTasks
  • externalParameter() : externalParameter< ValueType >
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- f -

  • findFrontAgentID() : Observation_Ttc_Implementation
  • FixedComponentStateExpression() : FixedComponentStateExpression
  • FlagComponentMaxReachableStateSetByEvent() : StateManager
  • FmiTypeToCType() : AlgorithmFmuWrapperImplementation
  • ForceGlobal() : VehicleSimpleTT
  • ForceLocal() : VehicleSimpleTT
  • FullCoord() : RoadGeometrySpiral
  • FullCurvature() : RoadGeometrySpiral
  • FullDir() : RoadGeometrySpiral
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- g -

  • GatherBasicComponents() : DynamicAgentTypeGenerator
  • GatherComponent() : DynamicAgentTypeGenerator
  • GatherComponentWithParameters() : DynamicAgentTypeGenerator
  • GatherDriverComponents() : DynamicAgentTypeGenerator
  • GatherSensors() : DynamicAgentTypeGenerator
  • GatherVehicleComponents() : DynamicAgentTypeGenerator
  • GenerateAgentsForRange() : SpawnPointPreRunCommon
  • GenerateDynamicAgentBlueprint() : AgentBlueprintProvider
  • GenerateSensorViewConfiguration() : ObjectDetectorBase , SensorGeometric2D
  • GenerateSpawnDetailsForLane() : SpawnPointRuntimeCommon
  • GenerateStaticAgentBlueprint() : AgentBlueprintProvider
  • Get() : ComponentStateExpression , Log< T >
  • GetA() : RoadGeometryPoly3
  • GetAbsAccelerationDouble() : WorldObject
  • GetAbsoluteFilePath() : MasterConfigImporter
  • GetAbsolutePosition() : ObjectDetectorBase
  • GetAbsOrientation() : WorldObject
  • GetAbsVelocityDouble() : WorldObject
  • GetAccelerationFromAirResistance() : DynamicsRegularDrivingImplementation
  • GetAccelerationFromRollingResistance() : DynamicsRegularDrivingImplementation
  • GetAcceleratorPedalPosition() : AlgorithmLongitudinalCalculations
  • GetAccFromEngineMoment() : DynamicsRegularDrivingImplementation
  • GetAccFromEngineTorque() : AlgorithmLongitudinalCalculations
  • GetAccVehicle() : DynamicsRegularDrivingImplementation
  • GetActors() : ConditionalEventDetector
  • GetAdasType() : AdasComponentStateInformation
  • GetAgent() : AgentNetwork , Component
  • GetAgentCategory() : AgentBlueprint
  • GetAgentComponentName() : AgentCompToCompCtrlSignal
  • GetAgentCorners() : CollisionDetectionPostCrash
  • GetAgentFactory() : SpawnPoint
  • GetAgentHeader() : ObservationCyclics
  • GetAgentId() : WorldData
  • GetAgentProfileName() : AgentBlueprint
  • GetAgents() : AgentNetwork
  • GetAgentSamplesLine() : ObservationCyclics
  • GetAgentType() : AgentBlueprint
  • GetAgentVelocityVector() : CollisionDetectionPostCrash
  • GetAU() : RoadGeometryParamPoly3
  • GetAV() : RoadGeometryParamPoly3
  • GetB() : RoadGeometryPoly3
  • GetBootstrapTasks() : SchedulerTasks
  • GetBorders() : RoadLane
  • GetBrakePedalPosition() : AlgorithmLongitudinalCalculations
  • GetBU() : RoadGeometryParamPoly3
  • GetBV() : RoadGeometryParamPoly3
  • GetC() : RoadGeometryPoly3
  • GetCenterLaneBoundary() : Section
  • GetCollisionAngles() : CollisionDetectionPostCrash
  • GetCollisionPosition() : CollisionDetectionPostCrash
  • GetColor() : LaneBoundary
  • GetComponent() : StateManager
  • GetComponentLocalLinkIdByName() : StateManager
  • GetComponentName() : ComponentStateInformation
  • GetComponentType() : AgentCompToCompCtrlSignal , ComponentStateInformation
  • GetComponentWarnings() : AgentCompToCompCtrlSignal
  • GetConnectedRoad() : SceneryConverter
  • GetConnectingRoads() : Junction
  • GetContactPoint() : RoadLink
  • GetCoord() : RoadGeometry
  • GetCoordArc() : RoadGeometry
  • GetCoordLine() : RoadGeometry
  • GetCU() : RoadGeometryParamPoly3
  • GetCurrentState() : AgentCompToCompCtrlSignal , ComponentStateInformation
  • GetCurvature() : Lane , RoadGeometryArc
  • GetCurvEnd() : RoadGeometrySpiral
  • GetCurvStart() : RoadGeometrySpiral
  • GetCV() : RoadGeometryParamPoly3
  • GetCycleTime() : EventDetectorCommonBase , ManipulatorCommonBase , Component
  • GetD() : RoadGeometryParamPoly3 , RoadGeometryPoly3
  • GetDimension() : WorldObject
  • GetDir() : RoadGeometry
  • GetDirArc() : RoadGeometry
  • GetDirection() : Lane , RoadLink
  • GetDirLine() : RoadGeometry
  • GetDistance() : Lane , Road , Section
  • GetDistanceBetweenObjects() : WorldDataQuery
  • GetDistanceToEndOfLane() : WorldDataQuery
  • GetDistanceUntilObjectEntersConnector() : WorldDataQuery
  • GetDistanceUntilObjectLeavesConnector() : WorldDataQuery
  • GetDriverProfileName() : AgentBlueprint
  • GetDV() : RoadGeometryParamPoly3
  • GetElementAndSByPosition() : Stream< T >
  • GetElementId() : RoadLink
  • GetElementType() : RoadLink
  • GetElevations() : Road
  • GetEngineMoment() : DynamicsRegularDrivingImplementation
  • GetEngineMomentMax() : DynamicsRegularDrivingImplementation
  • GetEngineMomentMin() : DynamicsRegularDrivingImplementation
  • GetEngineSpeed() : AlgorithmLongitudinalCalculations
  • GetEngineSpeedByVelocity() : AlgorithmLongitudinalCalculations , DynamicsRegularDrivingImplementation
  • GetEngineTorqueAtGear() : AlgorithmLongitudinalCalculations
  • GetEngineTorqueMax() : AlgorithmLongitudinalCalculations
  • GetEngineTorqueMin() : AlgorithmLongitudinalCalculations
  • GetEntityByName() : ScenarioImporter
  • GetEventDetectors() : EventDetectorNetwork
  • GetEvents() : ManipulatorCommonBase , EventNetwork
  • GetFilteredGroundTruth() : WorldData
  • GetFinalizeTasks() : SchedulerTasks
  • GetFirstContact() : CollisionDetectionPostCrash
  • GetFmuVariables() : AlgorithmFmuWrapperImplementation
  • GetFrictionCoefficient() : DynamicsRegularDrivingImplementation
  • GetGear() : AlgorithmLongitudinalCalculations
  • GetGeometries() : Road
  • GetGeometryInformation() : SensorDriverImplementation , SensorDriverSignal
  • GetGeometryLaneInformation() : SensorDriverImplementation
  • GetGeometryLaneInformationEgo() : SensorDriverImplementation
  • GetHdg() : RoadGeometry , RoadObject
  • GetHeader() : ObservationCyclics
  • GetHeight() : RoadSignal
  • GetId() : ComponentPort , externalParameter< ValueType > , Junction , Lane , LaneBoundary , Road , RoadMarking , TrafficSign , WorldObject , Road , RoadLane , RoadLaneSection , RoadObject , RoadSignal , SpawnPoint
  • GetImplementation() : Component , EventDetector , Manipulator , SpawnPoint
  • GetInDirection() : Road , RoadLane , RoadLaneSection
  • GetInit() : Component
  • GetInputLinks() : Component
  • GetInterpolatedPointsAtDistance() : Lane
  • GetIntersectingConnections() : WorldDataQuery
  • GetIntersectionPoint() : CollisionDetectionPostCrash
  • GetIntersections() : Junction
  • GetInvalidLane() : WorldData
  • GetIsDynamic() : RoadSignal
  • GetJoints() : JointsBuilder
  • GetJunction() : Scenery
  • GetJunctionByOdId() : WorldDataQuery
  • GetJunctionOfConnector() : WorldDataQuery
  • GetJunctions() : Scenery , WorldData
  • GetLaneAssignments() : WorldObject
  • GetLaneBoundaries() : WorldData
  • GetLaneByOdId() : WorldDataQuery
  • GetLaneGeometryElements() : Lane
  • GetLaneIdMapping() : WorldData
  • GetLaneIndexOffset() : RoadLaneSection
  • GetLaneMarkings() : WorldDataQuery
  • GetLaneOffsets() : Road
  • GetLanes() : Section , WorldData , RoadLaneSection
  • GetLaneSection() : RoadLane
  • GetLaneSections() : Road
  • GetLanesOfLaneTypeAtDistance() : WorldDataQuery
  • GetLaneType() : Lane
  • GetLateralDistanceToObject() : SensorDriverCalculations
  • GetLeftLane() : Lane
  • GetLeftLaneBoundaries() : Lane
  • GetLength() : Lane , Road , Section , RoadGeometry , RoadObject , RoadSignal
  • GetLibrary() : EventDetector , Manipulator , SpawnPoint
  • GetLink() : WorldObject
  • GetLocatedPosition() : WorldObject
  • GetManipulators() : ManipulatorNetwork
  • GetMaxReachableState() : CompCtrlToAgentCompSignal , ComponentStateInformation
  • GetMaxReachableStateOfComponentAtLocalLinkId() : StateManager
  • GetMaxReachableStateSetByEvent() : ComponentStateInformation
  • GetMinMax2() : CollisionDetector
  • GetMinMax4() : CollisionDetector
  • GetMovingObjectsInRangeOfJunctionConnection() : WorldDataQuery
  • GetMovingObjectsInSector() : WorldData
  • GetName() : Component
  • GetNewRoute() : SensorDriverImplementation
  • GetNext() : Lane
  • GetNextSpawnCarInfo() : SpawnPointPreRunCommon
  • GetNextSpawnPosition() : WorldAnalyzer
  • GetNextTimestamp() : SchedulerTasks
  • GetNumberOfVertices() : Polygon
  • GetObject() : SensorDriverImplementation
  • GetObjectName() : AgentBlueprint
  • GetObjectsOfTypeInRange() : WorldDataQuery
  • GetObservations() : Component
  • GetObstruction() : WorldDataQuery
  • GetOffsetTime() : Component
  • GetOriginatingRouteLane() : WorldDataQuery
  • GetOtherLane() : SceneryConverter
  • GetOtherObjectInformation() : SensorDriverImplementation
  • GetOutputLinks() : Component
  • GetOwlId() : WorldData
  • GetOwnVehicleInformation() : SensorDriverImplementation , SensorDriverSignal
  • GetPedestrianCatalogPath() : Scenario
  • GetPitch() : RoadSignal
  • GetPositionByDistanceAndLane() : WorldDataQuery
  • GetPositionByElementAndS() : Stream< T >
  • GetPredecessor() : Road , RoadLane
  • GetPrevious() : Lane
  • GetPriorities() : Junction
  • GetPrioritiesOnJunction() : WorldDataQuery
  • GetPriority() : Component
  • GetProfiles() : ConfigurationContainer
  • GetRecurringAgentTasks() : SchedulerTasks
  • GetReferencePointPosition() : RoadMarking , TrafficSign , WorldObject
  • GetRelativeJunctions() : WorldDataQuery
  • GetRelativeLanes() : WorldDataQuery
  • GetRemovedAgents() : AgentNetwork
  • GetRemovedAgentsInPreviousTimestep() : AgentNetwork
  • GetResponseTime() : Component
  • GetRightLane() : Lane
  • GetRightLaneBoundaries() : Lane
  • GetRightLaneCount() : Lane , WorldAnalyzer
  • GetRoad() : Scenery , Lane , Section , RoadLaneSection , RoadSignal
  • GetRoadByOdId() : WorldDataQuery
  • GetRoadGraph() : WorldData
  • GetRoadGraphVertexMapping() : WorldData
  • GetRoadLinks() : Road
  • GetRoadMarkings() : Lane , WorldData
  • GetRoadMarkingsInRange() : WorldDataQuery
  • GetRoadMarkingsInSector() : WorldData
  • GetRoadMarks() : RoadLane
  • GetRoadObjects() : Road
  • GetRoads() : Scenery , WorldData
  • GetRoadSignals() : Road
  • GetRoll() : RoadSignal
  • GetRoute() : SpawnPointScenario
  • GetRouteLeadingToConnector() : WorldDataQuery
  • GetRuntimeInformation() : ConfigurationContainer
  • GetS() : RoadMarking , TrafficSign , RoadGeometry , RoadObject , RoadSignal
  • GetSamplesLine() : ObservationCyclics
  • GetScenario() : ConfigurationContainer
  • GetScenery() : ConfigurationContainer
  • GetSceneryPath() : Scenario
  • GetSection() : Lane
  • GetSectionByDistance() : WorldDataQuery
  • GetSections() : Road
  • GetSEnd() : LaneBoundary
  • getSensorData() : ObjectDetectorBase
  • GetSensorData() : OsmpFmuHandler
  • GetSensorParameters() : AgentBlueprint
  • GetSensorView() : WorldData
  • GetSide() : LaneBoundary , RoadLink
  • GetSignalValue() : ComponentPort
  • GetSignalWithHighestPriority() : SignalPrioritizerImplementation
  • GetSlaveConfig() : ConfigurationContainer
  • GetSOffset() : Section
  • GetSpawningTasks() : SchedulerTasks
  • GetSpawnParameter() : AgentBlueprint
  • GetSpecification() : RoadMarking , TrafficSign
  • GetSpeedGoalMin() : AgentBlueprint
  • GetSquaredError() : BorderPoints
  • GetSStart() : LaneBoundary
  • GetStart() : RoadLaneSection
  • GetStateConditions() : ComponentStateInformation
  • GetStationaryObjectsInSector() : WorldData
  • GetSTCoordinates() : SpawnPointScenario
  • GetStreamPosition() : StreamInfo< T >
  • GetSubType() : RoadSignal
  • GetSuccessor() : Road , RoadLane
  • GetSurroundingObjects() : SensorDriverSignal
  • GetSurroundingObjectsInformation() : SensorDriverImplementation
  • GetSystemConfigBlueprint() : ConfigurationContainer
  • GetSystemConfigs() : ConfigurationContainer
  • GetT() : RoadObject , RoadSignal
  • GetTasks() : SchedulerTasks
  • GetText() : RoadSignal
  • GetTimeSteps() : ObservationCyclics
  • GetTrafficRuleInformation() : SensorDriverImplementation , SensorDriverSignal
  • GetTrafficRuleLaneInformationEgo() : SensorDriverImplementation
  • GetTrafficRuleLaneInformationLeft() : SensorDriverImplementation
  • GetTrafficRuleLaneInformationRight() : SensorDriverImplementation
  • GetTrafficSignIdMapping() : WorldData
  • GetTrafficSigns() : Lane , WorldData
  • GetTrafficSignsInRange() : WorldDataQuery
  • GetTrafficSignsInSector() : WorldData
  • GetTrajectoryCatalogPath() : Scenario
  • GetTrajectoryElementFromCatalog() : ScenarioImporterHelper
  • GetTrigger() : EventNetwork
  • GetTTCObjectParameters() : TtcCalculations
  • GetType() : LaneBoundary , RoadLane , RoadLink , RoadObject , RoadSignal
  • GetUnit() : RoadSignal
  • GetValidLaneSpawningRanges() : WorldAnalyzer
  • GetValue() : externalParameter< ValueType > , InputPort< SignalType, ValueType > , RoadSignal
  • GetValueAndUnitInSI() : TrafficSign
  • GetVehicleCatalogPath() : Scenario
  • GetVehicleComponentNamesToTypeAndStateMap() : StateManager
  • GetVehicleComponentProfileNames() : AgentBlueprint
  • GetVehicleComponentStates() : CompCtrlToAgentCompSignal
  • GetVehicleModelName() : AgentBlueprint
  • GetVehicleModelParameters() : AgentBlueprint
  • GetVehicleModels() : ConfigurationContainer
  • GetVehicleProfileName() : AgentBlueprint
  • GetVertexTypes() : CollisionDetectionPostCrash
  • GetVertices() : Polygon
  • GetWarnings() : CompCtrlToDriverCompSignal
  • GetWidth() : Lane , LaneBoundary , RoadObject , RoadSignal
  • GetWidths() : RoadLane
  • GetWorldObjectGeometry() : CollisionDetector
  • GetWorldObjects() : Lane
  • GetYaw() : RoadSignal
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- h -

  • HalfCoord() : RoadGeometrySpiral
  • HalfCurvature() : RoadGeometrySpiral
  • HalfDir() : RoadGeometrySpiral
  • HandleFmiStatus() : AlgorithmFmuWrapperImplementation
  • HasDetectionError() : ObjectDetectorBase
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- i -

  • Import() : ProfilesImporter , SceneryImporter , SlaveConfigImporter , SystemConfigImporter , VehicleModelsImporter , MasterConfigImporter
  • ImportAction() : ScenarioImporter
  • ImportActors() : ScenarioImporter
  • ImportAgentProfiles() : ProfilesImporter
  • ImportAllConfigurations() : ConfigurationContainer
  • ImportAllSensorsOfVehicleProfile() : ProfilesImporter
  • ImportAllVehicleComponentsOfVehicleProfile() : ProfilesImporter
  • ImportAndValidateVersion() : ScenarioImporter
  • ImportByEntityElement() : EventDetectorImporter
  • ImportCatalog() : ScenarioImporter , VehicleModelsImporter
  • ImportCatalogs() : ScenarioImporter
  • ImportConditionByValueElement() : EventDetectorImporter
  • ImportConditionElement() : EventDetectorImporter
  • ImportEndConditionsFromStoryboard() : ScenarioImporter
  • ImportEntities() : ScenarioImporter
  • ImportEntity() : ScenarioImporter
  • ImportEntityAction() : ScenarioImporterHelper
  • ImportEntityCatalogReference() : ScenarioImporter
  • ImportEntityCondition() : EventDetectorImporter
  • ImportEnvironment() : SlaveConfigImporter
  • ImportEventDetector() : EventDetectorImporter
  • ImportExperiment() : SlaveConfigImporter
  • ImportGlobalAction() : ScenarioImporterHelper
  • ImportInitElement() : ScenarioImporter
  • ImportLanePosition() : ScenarioImporter , ScenarioImporterHelper
  • ImportLateralAction() : ScenarioImporterHelper
  • ImportLibraries() : SlaveConfigImporter
  • ImportLongitudinalAction() : ScenarioImporterHelper
  • ImportManeuverElement() : ScenarioImporter
  • ImportMembers() : ScenarioImporter
  • ImportModelBoundingBox() : VehicleModelsImporter
  • ImportOrientation() : ScenarioImporter , ScenarioImporterHelper
  • ImportPedestrianCatalog() : VehicleModelsImporter
  • ImportPedestrianModel() : VehicleModelsImporter
  • ImportPosition() : ScenarioImporterHelper
  • ImportPrivateAction() : ScenarioImporterHelper
  • ImportPrivateElement() : ScenarioImporter
  • ImportPrivateElements() : ScenarioImporter
  • ImportProfileGroups() : ProfilesImporter
  • ImportProperties() : VehicleModelsImporter
  • ImportRelativeLanePosition() : ScenarioImporterHelper
  • ImportRoadNetwork() : ScenarioImporter
  • ImportRoadPosition() : ScenarioImporterHelper
  • ImportRoutingAction() : ScenarioImporterHelper
  • ImportScenario() : SlaveConfigImporter
  • ImportSelectionElements() : ScenarioImporter
  • ImportSensorLinksOfComponent() : ProfilesImporter
  • ImportSensorParameters() : ProfilesImporter
  • ImportSpawners() : SlaveConfigImporter
  • ImportStochastics() : ScenarioImporterHelper
  • ImportStoryboard() : ScenarioImporter
  • ImportStoryElement() : ScenarioImporter
  • ImportSystemParameters() : SystemConfigImporter
  • ImportTeleportAction() : ScenarioImporterHelper
  • ImportUserDefinedAction() : ScenarioImporterHelper
  • ImportVehicleCatalog() : VehicleModelsImporter
  • ImportVehicleComponent() : ProfilesImporter
  • ImportVehicleModel() : VehicleModelsImporter
  • ImportVehicleModelAxle() : VehicleModelsImporter
  • ImportVehicleModelAxles() : VehicleModelsImporter
  • ImportVehicleModelGears() : VehicleModelsImporter
  • ImportVehicleModelPerformance() : VehicleModelsImporter
  • ImportVehicleProfile() : ProfilesImporter
  • ImportVehicleProfiles() : ProfilesImporter
  • ImportVisibilityAction() : ScenarioImporterHelper
  • ImportWorldPosition() : ScenarioImporter , ScenarioImporterHelper
  • IndexElements() : SceneryConverter
  • Init() : DynamicsRegularTwoTrackImplementation , DataStoreLibrary , EventDetectorLibrary , ManipulatorLibrary , ModelLibrary , ObservationLibrary , SpawnPointLibrary , StochasticsLibrary , WorldLibrary
  • InitEgoVehicle() : AgentAdapter
  • InitFmu() : AlgorithmFmuWrapperImplementation
  • Initialize() : EventNetwork
  • InitPreRun() : RunInstantiator
  • InitSetEngine() : VehicleSimpleTT
  • InitSetGeometry() : VehicleSimpleTT
  • InitSetTire() : VehicleSimpleTT
  • InputPort() : InputPort< SignalType, ValueType >
  • Insert() : ObservationCyclics
  • InsertEvent() : EventNetwork
  • InsertTrigger() : EventNetwork
  • Instantiate() : DataStoreBinding , EventDetectorBinding , EventDetectorNetwork , ManipulatorBinding , ManipulatorNetwork , ModelBinding , ObservationBinding , SpawnPointBinding , StochasticsBinding , World , WorldBinding
  • Invalid() : Obstruction
  • Is() : WorldObject
  • IsActive() : SignalPrioritizerImplementation
  • IsAgentAffectedByEvent() : ComponentControllerImplementation
  • IsBelowMaximumNumberOfExecutions() : ConditionalEventDetector
  • IsFullfilled() : Condition
  • isInstantiated() : World
  • IsInStreamDirection() : Road
  • IsOffsetValidForLane() : SpawnPointPreRunCommon
  • IsOpen() : LogOutputPolicy
  • IsPrior() : SignalPrioritizerImplementation
  • IsRelative() : Directories
  • IsSValidOnLane() : WorldDataQuery
  • IsValidForLane() : RoadMarking , TrafficSign , RoadObject , RoadSignal
  • IsWithin() : PointQuery
  • isWithinEngineLimits() : AlgorithmLongitudinalCalculations
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- j -

  • JointsBuilder() : JointsBuilder
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- l -

  • Lane() : Lane
  • LateralSignal() : LateralSignal
  • Length() : Vector2d , Vector3d
  • LocalLinkIdIsRegistered() : StateManager
  • Log() : AgentAdapter , AgentNetwork , CollisionDetectionPostCrash , StateManager , EventDetectorCommonBase , ManipulatorCommonBase , WorldData , SceneryConverter , Callbacks , StochasticsImplementation , World_Basic_Implementation , WorldImplementation
  • LogError() : SpawnPointPreRunCommon , SpawnPointRuntimeCommon , SpawnPointScenario
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- m -

  • make() : AgentBuildInformation , SampledProfiles
  • MarkDirectionRoad() : SceneryConverter
  • MarkDirections() : SceneryConverter
  • MasterPostHook() : Observation_State_Implementation , Observation_Ttc_Implementation
  • MasterPreHook() : Observation_State_Implementation , Observation_Ttc_Implementation
  • MkDirOrThrowError() : AlgorithmFmuWrapperImplementation
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- n -

  • NewAgentIntersectsWithExistingAgent() : SpawnPointPreRunCommon
  • NextStateRotation() : DynamicsRegularTwoTrackImplementation
  • NextStateSet() : DynamicsRegularTwoTrackImplementation
  • NextStateTranslation() : DynamicsRegularTwoTrackImplementation
  • NoOpponent() : Obstruction
  • Norm() : Vector2d , Vector3d
  • NormalizeAngle() : WorldData
  • Now() : TimeKeeper
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- o -

  • ObjectIsOfTypeAndWithinRange() : WorldDataQuery
  • Obstruction() : Obstruction
  • OpeningAngleWithinFullCircle() : SensorGeometric2D
  • OpeningAngleWithinHalfCircle() : SensorGeometric2D
  • operator AgentBuildInformation &&() : DynamicAgentTypeGenerator
  • operator SampledProfiles &&() : DynamicProfileSampler
  • operator std::string() : AccelerationSignal , AgentCompToCompCtrlSignal , BoolSignal , CompCtrlToAgentCompSignal , ComponentStateSignal , DoubleSignal , DynamicsSignal , IntSignal , LateralSignal , LongitudinalSignal , ParametersVehicleSignal , SecondaryDriverTasksSignal , SensorDataSignal , SensorDriverSignal , SignalVector< DT > , SpeedActionSignal , SteeringSignal , TrajectorySignal
  • operator!=() : Vector2d
  • operator()() : VisitParameterElement
  • operator==() : Vector2d
  • Output() : LogOutputPolicy
  • OutputPort() : OutputPort< SignalType, ValueType >
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- p -

  • ParameterizedAttribute() : ParameterizedAttribute< T >
  • ParametersVehicleSignal() : ParametersVehicleSignal
  • Parse() : AgentParser
  • ParseBasicParameter() : ObjectDetectorBase
  • ParseConditionAttributes() : ScenarioImporter
  • ParseElementValidity() : SceneryImporter
  • ParseElevationProfile() : SceneryImporter
  • ParseGeometries() : SceneryImporter
  • ParseJunctionConnectionLinks() : SceneryImporter
  • ParseJunctionConnections() : SceneryImporter
  • ParseJunctionPriorities() : SceneryImporter
  • ParseJunctions() : SceneryImporter
  • ParseLaneRoadMark() : SceneryImporter
  • ParseLanes() : SceneryImporter
  • ParseObject() : SceneryImporter
  • ParseObjectRepeat() : SceneryImporter
  • ParseObjects() : SceneryImporter
  • ParseOptionalInterval() : SceneryImporter
  • ParseParameters() : AlgorithmAutonomousEmergencyBrakingImplementation
  • ParseRepeat() : SceneryImporter
  • ParseRoadLanes() : SceneryImporter
  • ParseRoadLinks() : SceneryImporter
  • ParseRoads() : SceneryImporter
  • ParseRoadTypes() : SceneryImporter
  • ParseSenderPriorities() : SignalPrioritizerImplementation
  • ParseSignals() : SceneryImporter
  • ParseSignalUnit() : SceneryImporter
  • ParseSimulationTime() : ScenarioImporter
  • ParseSlaveConfig() : MasterConfigImporter
  • ParseSlaveConfigs() : MasterConfigImporter
  • PlausibleTestAcceleration() : Algorithm_CruiseControlByDistance_Implementation
  • PostCrashDynamic() : PostCrashDynamic
  • PropagateParametersForward() : TtcCalculations
  • PublishGlobalData() : AgentNetwork
  • PullNonRecurringTasks() : SchedulerTasks
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- q -

  • QueueAgentRemove() : AgentNetwork
  • QueueAgentUpdate() : AgentNetwork
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- r -

  • ReadDocument() : MasterConfigImporter
  • ReadPreviousState() : DynamicsRegularTwoTrackImplementation
  • Register() : ActionTransformRepository , CustomCommandFactory
  • ReleaseComponent() : ModelLibrary
  • ReleaseDataStore() : DataStoreLibrary
  • ReleaseEventDetector() : EventDetectorLibrary
  • ReleaseFromLibrary() : Component
  • ReleaseManipulator() : ManipulatorLibrary
  • ReleaseObservationModule() : ObservationLibrary
  • ReleaseOutputData() : Component
  • ReleaseStochastics() : StochasticsLibrary
  • ReleaseWorld() : WorldLibrary
  • RemoveAgent() : AgentNetwork
  • RemoveCsvCyclics() : ObservationFileHandler
  • RemoveMovingObjectById() : WorldData
  • ReportingLevel() : Log< T >
  • repository() : CustomCommandFactory
  • Reset() : EventDetectorCommonBase , WorldData
  • ResetAll() : EventDetectorNetwork
  • Resolve() : Directories
  • Reverse() : Stream< T >
  • Rotate() : Vector2d
  • Run() : Scheduler
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- s -

  • SampleAgent() : AgentBlueprintProvider
  • SampleDriverProfile() : DynamicProfileSampler
  • SampleSensorLatency() : DynamicAgentTypeGenerator
  • SampleVehicleComponentProfiles() : DynamicProfileSampler
  • SampleVehicleProfile() : DynamicProfileSampler
  • Scale() : Vector2d , Vector3d
  • ScheduleAgentTasks() : Scheduler
  • ScheduleNewNonRecurringTasks() : SchedulerTasks
  • ScheduleNewRecurringTasks() : SchedulerTasks
  • ScheduleNewTasks() : SchedulerTasks
  • SecondaryDriverTasksSignal() : SecondaryDriverTasksSignal
  • SensorDataSignal() : SensorDataSignal
  • SensorDriverImplementation() : SensorDriverImplementation
  • SensorDriverSignal() : SensorDriverSignal
  • SetAbsOrientation() : WorldObject
  • SetAcceleration() : AlgorithmAutonomousEmergencyBrakingImplementation
  • SetAgentCategory() : AgentBlueprint
  • SetAgentProfileName() : AgentBlueprint
  • SetCenterLaneBoundary() : Section , WorldData
  • SetCollisionAngles() : CollisionDetectionPostCrash
  • SetCurrentState() : ComponentStateInformation
  • SetDesiredState() : ComponentStateInformation
  • SetDimension() : WorldObject
  • SetDriverProfileName() : AgentBlueprint
  • SetFadingDynamics() : DynamicsPostCrashImplementation
  • SetFile() : LogOutputPolicy
  • SetId() : RoadLaneSection
  • SetImplementation() : Component
  • SetInDirection() : Road , RoadLane , RoadLaneSection
  • SetInputBuffer() : Component
  • SetLaneIndexOffset() : RoadLaneSection
  • SetLaneType() : Lane
  • SetLateralInput() : SteeringController
  • SetLeftLane() : Lane
  • SetLeftLaneBoundaries() : Lane
  • SetLocatedPosition() : WorldObject
  • SetMaxReachableState() : ComponentStateInformation
  • SetMaxReachableStateSetByEvent() : ComponentStateInformation
  • SetModelLibrary() : Component
  • SetObjectName() : AgentBlueprint
  • SetObservations() : Component
  • SetOutputLocation() : ObservationFileHandler
  • SetParameter() : SpawnPointBinding
  • SetPedestrianCatalogPath() : Scenario
  • SetPredecessor() : Road
  • SetReferencePointPosition() : WorldObject
  • SetRightLane() : Lane
  • SetRoad() : Section
  • SetRoadGraph() : WorldData
  • SetRoadPredecessor() : WorldData
  • SetRoadPredecessorJunction() : WorldData
  • SetRoadSuccessor() : WorldData
  • SetRoadSuccessorJunction() : WorldData
  • SetS() : RoadMarking , TrafficSign
  • SetSceneryPath() : Scenario
  • SetSectionPredecessor() : WorldData
  • SetSectionSuccessor() : WorldData
  • SetSensorViewInput() : OsmpFmuHandler
  • SetSignalValue() : ComponentPort
  • SetSpawnParameter() : AgentBlueprint
  • SetSpecification() : RoadMarking , TrafficSign
  • SetSpeedGoalMin() : AgentBlueprint
  • SetSuccessor() : Road
  • SetTrajectoryCatalogPath() : Scenario
  • SetupFilenames() : AlgorithmFmuWrapperImplementation
  • SetupLog() : AlgorithmFmuWrapperImplementation
  • SetupOutput() : AlgorithmFmuWrapperImplementation
  • SetupUnzip() : AlgorithmFmuWrapperImplementation
  • SetValidForLane() : RoadMarking , TrafficSign
  • SetValue() : externalParameter< ValueType > , OutputPort< SignalType, ValueType >
  • SetVehicleCatalogPath() : Scenario
  • SetVehicleComponentProfileNames() : AgentBlueprint
  • SetVehicleModelName() : AgentBlueprint
  • SetVehicleModelParameters() : AgentBlueprint , DynamicAgentTypeGenerator
  • SetVehicleParameter() : SteeringController
  • SetVehicleProfileName() : AgentBlueprint
  • SetVelocity() : VehicleSimpleTT
  • SetVelocityAndSteeringWheelAngle() : SteeringController
  • SetVertices() : Polygon
  • ShiftPolygonsAndCheckIntersection() : CollisionDetectionPostCrash
  • ShouldBeActivated() : AlgorithmAutonomousEmergencyBrakingImplementation
  • ShouldBeDeactivated() : AlgorithmAutonomousEmergencyBrakingImplementation
  • SlavePostHook() : Observation_State_Implementation , Observation_Ttc_Implementation
  • SlavePostRunHook() : Observation_State_Implementation , Observation_Ttc_Implementation
  • SlavePreHook() : Observation_Ttc_Implementation
  • SlavePreRunHook() : Observation_State_Implementation , Observation_Ttc_Implementation
  • SlaveResultFile() : Observation_State_Implementation , Observation_Ttc_Implementation
  • SlaveUpdateHook() : Observation_State_Implementation , Observation_Ttc_Implementation
  • SpawnWillCauseCrash() : WorldAnalyzer
  • SpeedActionSignal() : SpeedActionSignal
  • StartS() : StreamInfo< T >
  • SteeringSignal() : SteeringSignal
  • StreamInfo() : StreamInfo< T >
  • StripFile() : Directories
  • Sub() : Vector2d , Vector3d
  • SyncGlobalData() : AgentNetwork
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- t -

  • ToString() : Log< T >
  • TrajectorySignal() : TrajectorySignal
  • Transform() : ActionTransformRepository , TransformerBase< T, Signal, TriggeringEvent >
  • TransformPointToLocalCoordinates() : ObjectDetectorBase
  • TransformPolygonToGlobalCoordinates() : ObjectDetectorBase
  • Translate() : Vector2d , Vector3d , Polygon
  • Trigger() : Action_BrakeLight_Basic_Implementation , ActionLongitudinalDriverImplementation , ActionSecondaryDriverTasksImplementation , AgentUpdaterImplementation , Algorithm_CruiseControlByDistance_Implementation , AlgorithmAgentFollowingDriverModelImplementation , AlgorithmAutonomousEmergencyBrakingImplementation , AlgorithmLateralImplementation , CollisionDetector , CollisionManipulator , ComponentControllerImplementation , ComponentStateChangeManipulator , Dynamics_Longitudinal_Basic_Implementation , DynamicsCollisionImplementation , DynamicsPostCrashImplementation , DynamicsRegularDrivingImplementation , DynamicsRegularTwoTrackImplementation , EventDetectorCommonBase , LaneChangeManipulator , LimiterAccelerationVehicleComponentsImplementation , ManipulatorCommonBase , ObjectDetectorBase , RemoveAgentsManipulator , Sensor_Distance_Implementation , SensorFusionImplementation , SensorRecordStateImplementation , ModelLibrary , SpawnPointPreRunCommon , SpawnPointRuntimeCommon , SpawnPointScenario , SpeedActionManipulator , TrajectoryFollowerImplementation , TrajectoryManipulator
  • TriggerCycle() : Component
  • TriggerEventInsertion() : ConditionalEventDetector
  • TriggerPostCrashCheck() : DynamicsPostCrashImplementation
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- u -

  • Unload() : DataStoreBinding , EventDetectorBinding , ManipulatorBinding , ModelBinding , ObservationBinding , SpawnPointBinding , StochasticsBinding , WorldBinding
  • UpdateAcceleration() : AlgorithmAutonomousEmergencyBrakingImplementation
  • UpdateAgents() : Scheduler
  • UpdateCollision() : CollisionManipulator
  • UpdateComponentCurrentState() : StateManager
  • UpdateComponentDesiredState() : StateManager
  • UpdateComponentMaxReachableState() : StateManager
  • UpdateEgoVehicle() : AgentAdapter
  • UpdateGraphPosition() : SensorDriverImplementation
  • UpdateInput() : Action_BrakeLight_Basic_Implementation , ActionLongitudinalDriverImplementation , ActionSecondaryDriverTasksImplementation , AgentUpdaterImplementation , Algorithm_CruiseControlByDistance_Implementation , AlgorithmAgentFollowingDriverModelImplementation , AlgorithmAutonomousEmergencyBrakingImplementation , AlgorithmLateralImplementation , ComponentControllerImplementation , Dynamics_Longitudinal_Basic_Implementation , DynamicsCollisionImplementation , DynamicsPostCrashImplementation , DynamicsRegularDrivingImplementation , DynamicsRegularTwoTrackImplementation , LimiterAccelerationVehicleComponentsImplementation , ObjectDetectorBase , Sensor_Distance_Implementation , SensorFusionImplementation , SensorRecordStateImplementation , SignalPrioritizerImplementation , ModelLibrary , TrajectoryFollowerImplementation
  • UpdateInputData() : Component
  • UpdateMaxReachableStatesForRegisteredComponents() : StateManager
  • UpdateOutput() : Action_BrakeLight_Basic_Implementation , ActionLongitudinalDriverImplementation , ActionSecondaryDriverTasksImplementation , AgentUpdaterImplementation , Algorithm_CruiseControlByDistance_Implementation , AlgorithmAgentFollowingDriverModelImplementation , AlgorithmAutonomousEmergencyBrakingImplementation , AlgorithmLateralImplementation , ComponentControllerImplementation , Dynamics_Longitudinal_Basic_Implementation , DynamicsCollisionImplementation , DynamicsPostCrashImplementation , DynamicsRegularDrivingImplementation , DynamicsRegularTwoTrackImplementation , LimiterAccelerationVehicleComponentsImplementation , ObjectDetectorBase , Sensor_Distance_Implementation , SensorFusionImplementation , SensorRecordStateImplementation , SignalPrioritizerImplementation , ModelLibrary , TrajectoryFollowerImplementation
  • UpdatePosition() : VehicleSimpleTT
  • UpdateScheduledTimestamps() : SchedulerTasks
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- v -

  • ValidateAxles() : VehicleModelsImporter
  • ValidateOverlappingAgents() : SpawnPointScenario
  • ValidateRoadIdInDirection() : WorldAnalyzer
  • ValidateSTCoordinatesOnLane() : SpawnPointScenario
  • ValidMinimumSpawningDistanceToObjectInFront() : WorldAnalyzer
  • ValueInBounds() : TrafficHelperFunctions
  • Vector2d() : Vector2d
  • Vector3d() : Vector3d
  • VehicleComponentStateExpression() : VehicleComponentStateExpression
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- w -

  • WillCrash() : TrafficHelperFunctions
  • WillCrashDuringBrake() : TrafficHelperFunctions
  • WriteCsvCyclics() : ObservationFileHandler
  • WriteEndOfFile() : ObservationFileHandler
  • WriteEntities() : ObservationFileHandler
  • WriteJson() : OsmpFmuHandler
  • WriteParameter() : ObservationFileHandler
  • WriteRun() : ObservationFileHandler
  • WriteStartOfFile() : ObservationFileHandler
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- ~ -

  • ~Component() : Component
  • ~ComponentPort() : ComponentPort
  • ~DataStoreLibrary() : DataStoreLibrary
  • ~EventDetector() : EventDetector
  • ~EventDetectorLibrary() : EventDetectorLibrary
  • ~externalParameter() : externalParameter< ValueType >
  • ~InputPort() : InputPort< SignalType, ValueType >
  • ~Manipulator() : Manipulator
  • ~ManipulatorLibrary() : ManipulatorLibrary
  • ~OutputPort() : OutputPort< SignalType, ValueType >
  • ~SpawnPoint() : SpawnPoint
  • ~SpawnPointLibrary() : SpawnPointLibrary
  • ~StochasticsLibrary() : StochasticsLibrary
  • ~WorldLibrary() : WorldLibrary
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- _ -

  • _accelerationMax : Algorithm_CruiseControlByDistance_Implementation
  • _airDensity : Algorithm_CruiseControlByDistance_Implementation
  • _airDragCoefficent : Algorithm_CruiseControlByDistance_Implementation
  • _carHeight : Algorithm_CruiseControlByDistance_Implementation
  • _carRate : SpawnPoint_Start_Implementation
  • _carWeight : Algorithm_CruiseControlByDistance_Implementation
  • _carWidth : Algorithm_CruiseControlByDistance_Implementation
  • _cw : Algorithm_CruiseControlByDistance_Implementation
  • _iSpawnCar : SpawnPoint_Start_Implementation
  • _oneG : DynamicsRegularDrivingImplementation
  • _rho : DynamicsRegularDrivingImplementation
  • _standardCycleTime : SpawnPoint_Start_Implementation
  • _standardCycleTimeSecond : Algorithm_CruiseControlByDistance_Implementation
  • _twoPi : DynamicsRegularDrivingImplementation
  • _VLowerLimit : Dynamics_Longitudinal_Basic_Implementation
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- a -

  • absoluteVelocity : ObjectInformation , OwnVehicleInformation
  • acceleration : ObjectInformation , OwnVehicleInformation
  • accelerationCar : DynamicsRegularTwoTrackImplementation
  • accelerationMin : Algorithm_CruiseControlByDistance_Implementation
  • accelerationWish : AlgorithmLongitudinalImplementation
  • accelVerticalEarth : VehicleSimpleTT
  • activeAcceleration : AlgorithmAutonomousEmergencyBrakingImplementation
  • acyclicStore : BasicDataStoreImplementation
  • agentComponentName : AgentCompToCompCtrlSignal
  • agentIdString : AlgorithmFmuWrapperImplementation
  • agentsMinTtc : Observation_Ttc_Implementation
  • agentsTtc : Observation_Ttc_Implementation
  • anglePreSet : VehicleSimpleTT
  • angleTireFront : DynamicsRegularTwoTrackImplementation
  • areaFace : VehicleSimpleTT
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- b -

  • brakeBalance : VehicleSimpleTT
  • brakePedal : DynamicsRegularTwoTrackImplementation
  • brakeSuperpose : DynamicsRegularTwoTrackImplementation
  • brakingAcceleration : AlgorithmAutonomousEmergencyBrakingImplementation
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- c -

  • callbacks : AlgorithmFmuWrapperImplementation , fmu_check_data_t
  • cdata : AlgorithmFmuWrapperImplementation
  • channels : Observation_State_Implementation
  • coeffDrag : VehicleSimpleTT
  • coeffRest : CollisionDetectionPostCrash
  • collAngles : CollisionDetectionPostCrash
  • collision : OwnVehicleInformation
  • collisionDetectionLateralBoundary : AlgorithmAutonomousEmergencyBrakingImplementation , BoundingBoxCalculation
  • collisionDetectionLongitudinalBoundary : AlgorithmAutonomousEmergencyBrakingImplementation , BoundingBoxCalculation
  • collisionPostCrash : CollisionManipulator
  • collisionVelocity : PostCrashDynamic
  • COMPONENTNAME : AlgorithmLongitudinalImplementation , DynamicsRegularDrivingImplementation , DynamicsRegularTwoTrackImplementation , SensorDriverImplementation
  • componentState : AlgorithmAgentFollowingDriverModelImplementation , AlgorithmAutonomousEmergencyBrakingImplementation
  • componentType : AgentCompToCompCtrlSignal
  • configurationDir : ConfigurationFiles , Directories
  • context : fmu_check_data_t
  • CSV_separator : fmu_check_data_t
  • currentState : AgentCompToCompCtrlSignal
  • currentVelocity : AlgorithmLongitudinalImplementation
  • curvature : LaneInformationGeometry , LaneGeometryJoint
  • curvatureRoadSmoothLast : SteeringController
  • cyclicStore : BasicDataStoreImplementation
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- d -

  • decelerationWish : AlgorithmAgentFollowingDriverModelImplementation
  • defaultLibraryMapping : SlaveConfigImporter
  • defaultValue : ParameterizedAttribute< T >
  • DegreeToRadiant : DynamicsRegularDrivingImplementation
  • delta : AlgorithmAgentFollowingDriverModelImplementation
  • densityAir : VehicleSimpleTT
  • detectedMovingObjects : AlgorithmAutonomousEmergencyBrakingImplementation
  • detectedStationaryObjects : AlgorithmAutonomousEmergencyBrakingImplementation
  • discreteIndex : fmi1_csv_input_t , fmi2_csv_input_t
  • distanceToEndOfLane : LaneInformationGeometry
  • distanceToLaneBoundaryLeft : OwnVehicleInformation
  • distanceToLaneBoundaryRight : OwnVehicleInformation
  • do_mangle_var_names : fmu_check_data_t
  • do_output_all_vars : fmu_check_data_t
  • do_simulate_flg : fmu_check_data_t
  • do_test_cs : fmu_check_data_t
  • do_test_me : fmu_check_data_t
  • dynamicsSignal : DynamicsPostCrashImplementation , DynamicsRegularDrivingImplementation , DynamicsRegularTwoTrackImplementation
  • dynamicsTarget : LaneChangeParameter
  • dynamicsType : LaneChangeParameter
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- e -

  • elements : AcyclicResult , CyclicResult
  • endHeading : SampledGeometry
  • endTimeInSeconds : Scenario
  • enforceDoubleBuffering : OsmpFmuHandler
  • entityIdIndex : BasicDataStoreImplementation
  • eventIndex1 : fmi1_csv_input_t , fmi2_csv_input_t
  • eventIndex2 : fmi1_csv_input_t , fmi2_csv_input_t
  • exist : ObjectInformation
  • exists : LaneInformationGeometry
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- f -

  • false : AlgorithmFmuWrapperImplementation
  • fmu : fmi1_csv_input_t , fmi2_csv_input_t
  • fmu1 : fmu_check_data_t
  • fmu1_kind : fmu_check_data_t
  • fmu2 : fmu_check_data_t
  • fmu2_kind : fmu_check_data_t
  • FMU_fullName : AlgorithmFmuWrapperImplementation
  • FMU_name : AlgorithmFmuWrapperImplementation
  • FMU_path : AlgorithmFmuWrapperImplementation
  • fmuHandler : AlgorithmFmuWrapperImplementation
  • FMUPath : fmu_check_data_t
  • fmuType : AlgorithmFmuWrapperImplementation
  • fmuVariables : AlgorithmFmuWrapperImplementation
  • fmuVariableValues : AlgorithmFmuWrapperImplementation
  • folderUnzip : AlgorithmFmuWrapperImplementation
  • forceTotalXY : VehicleSimpleTT
  • forceWheelVertical : DynamicsRegularTwoTrackImplementation
  • fullResultFilePath : Observation_Ttc_Implementation
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- g -

  • gainHeadingError : LateralDynamicConstants
  • geometryInformation : SensorDriverImplementation , SensorDriverSignal
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- h -

  • HCPA : CollisionAngles
  • HCPAo : CollisionAngles
  • heading : ObjectInformation , OwnVehicleInformation
  • height : ObjectInformation
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- i -

  • id : ComponentPort , externalParameter< ValueType > , ObjectInformation
  • in_accPedalPos : ActionLongitudinalDriverImplementation , DynamicsRegularDrivingImplementation
  • in_aCoasting : Action_BrakeLight_Basic_Implementation
  • in_aVehicle : Action_BrakeLight_Basic_Implementation , Dynamics_Longitudinal_Basic_Implementation
  • in_brakePedalPos : ActionLongitudinalDriverImplementation , DynamicsRegularDrivingImplementation
  • in_distance2NextAgent : Algorithm_CruiseControlByDistance_Implementation
  • in_flasherSwitch : ActionSecondaryDriverTasksImplementation
  • in_gear : ActionLongitudinalDriverImplementation , DynamicsRegularDrivingImplementation
  • in_headLightSwitch : ActionSecondaryDriverTasksImplementation
  • in_highBeamLightSwitch : ActionSecondaryDriverTasksImplementation
  • in_hornSwitch : ActionSecondaryDriverTasksImplementation
  • in_IndicatorState : ActionSecondaryDriverTasksImplementation
  • in_steeringMax : SteeringController
  • in_steeringRatio : SteeringController
  • in_steeringWheelAngle : DynamicsRegularDrivingImplementation , SteeringController
  • in_velocity : Algorithm_CruiseControlByDistance_Implementation , SteeringController
  • in_wheelBase : SteeringController
  • inertiaTireX : VehicleSimpleTT
  • initializedAccelerationInput : AlgorithmLongitudinalImplementation
  • initializedSensorDriverData : AlgorithmLongitudinalImplementation
  • initializedVehicleModelParameters : AlgorithmLongitudinalImplementation
  • inputFileName : fmu_check_data_t
  • inputPorts : DynamicsRegularTwoTrackImplementation
  • inStreamDirection : StreamInfo< T >
  • interFriction : CollisionDetectionPostCrash
  • interpContinuousData : fmi1_csv_input_t
  • interpData : fmi1_csv_input_t , fmi2_csv_input_t
  • interpIndex1 : fmi1_csv_input_t , fmi2_csv_input_t
  • interpIndex2 : fmi1_csv_input_t , fmi2_csv_input_t
  • interpLambda : fmi1_csv_input_t , fmi2_csv_input_t
  • interpTime : fmi1_csv_input_t , fmi2_csv_input_t
  • isActive : DynamicsPostCrashImplementation , PostCrashVelocity
  • isOverlapping : Obstruction
  • isStatic : ObjectInformation
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- j -

  • joints : JointsBuilder
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- l -

  • laneEgo : GeometryInformation , TrafficRuleInformation
  • laneLeft : GeometryInformation , TrafficRuleInformation
  • laneMarkingsLeft : TrafficRuleInformation
  • laneMarkingsLeftOfLeftLane : TrafficRuleInformation
  • laneMarkingsRight : TrafficRuleInformation
  • laneMarkingsRightOfRightLane : TrafficRuleInformation
  • laneRight : GeometryInformation , TrafficRuleInformation
  • lateralAcceleration : LateralDynamicConstants
  • lateralDynamicConstants : AlgorithmAgentFollowingDriverModelImplementation
  • lateralPosition : OwnVehicleInformation
  • left : Obstruction
  • length : ObjectInformation
  • libraryDir : Directories
  • libraryName : ObservationInstance
  • log_file : fmu_check_data_t
  • log_file_name : fmu_check_data_t
  • logFileFullName : AlgorithmFmuWrapperImplementation
  • logFileName : AlgorithmFmuWrapperImplementation
  • logGuard : Log< T >
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- m -

  • mainLaneLocator : Obstruction
  • mainLocatePoint : ObjectPosition
  • massTotal : VehicleSimpleTT
  • maxAcceleration : AlgorithmAgentFollowingDriverModelImplementation
  • maxOutputPts : fmu_check_data_t
  • maxOutputPtsSetByUser : fmu_check_data_t
  • maxReachableState : CompCtrlToAgentCompSignal
  • meanCurvatureToFarPointSmoothLast : SteeringController
  • meanCurvatureToNearPointSmoothLast : SteeringController
  • minDistance : AlgorithmAgentFollowingDriverModelImplementation
  • modelIdentifierFMI1 : fmu_check_data_t
  • momentTotalZ : VehicleSimpleTT
  • movingDirection : DynamicsPostCrashImplementation
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- n -

  • nextOutputStep : fmu_check_data_t
  • nextOutputTime : fmu_check_data_t
  • num_errors : fmu_check_data_t
  • num_fatal : fmu_check_data_t
  • num_fmu_messages : fmu_check_data_t
  • num_warnings : fmu_check_data_t
  • numberOfCollisionPartners : DynamicsPostCrashImplementation
  • numberOfExecutions : ConditionalEventDetectorInformation
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- o -

  • object : LaneChangeParameter
  • objectFront : SurroundingObjects
  • objectFrontLeft : SurroundingObjects
  • objectFrontRight : SurroundingObjects
  • objectRear : SurroundingObjects
  • objectRearLeft : SurroundingObjects
  • objectRearRight : SurroundingObjects
  • OCPA : CollisionAngles
  • OCPAo : CollisionAngles
  • os : Log< T >
  • out_accPedalPos : AlgorithmLongitudinalImplementation
  • out_aCoasting : Algorithm_CruiseControlByDistance_Implementation
  • out_agentVelocity : Sensor_Distance_Implementation
  • out_brakePedalPos : AlgorithmLongitudinalImplementation
  • out_curvature : AlgorithmAgentFollowingDriverModelImplementation
  • out_desiredAcceleration : Algorithm_CruiseControlByDistance_Implementation
  • out_desiredSteeringWheelAngle : AlgorithmLateralImplementation
  • out_distanceToNextAgent : Sensor_Distance_Implementation
  • out_file : fmu_check_data_t
  • out_flasher : AlgorithmAgentFollowingDriverModelImplementation
  • out_gear : AlgorithmLongitudinalImplementation
  • out_headLight : AlgorithmAgentFollowingDriverModelImplementation
  • out_highBeamLight : AlgorithmAgentFollowingDriverModelImplementation
  • out_hornSwitch : AlgorithmAgentFollowingDriverModelImplementation
  • out_indicatorState : AlgorithmAgentFollowingDriverModelImplementation
  • out_laneWidth : AlgorithmAgentFollowingDriverModelImplementation
  • out_lateral_damping : AlgorithmAgentFollowingDriverModelImplementation
  • out_lateral_displacement : AlgorithmAgentFollowingDriverModelImplementation
  • out_lateral_frequency : AlgorithmAgentFollowingDriverModelImplementation
  • out_lateral_gain_displacement : AlgorithmAgentFollowingDriverModelImplementation
  • out_lateral_gain_heading_error : AlgorithmAgentFollowingDriverModelImplementation
  • out_lateral_heading_error : AlgorithmAgentFollowingDriverModelImplementation
  • out_lateral_speed : AlgorithmAgentFollowingDriverModelImplementation
  • out_longitudinal_acc : AlgorithmAgentFollowingDriverModelImplementation
  • output_file_name : fmu_check_data_t
  • outputDir : Directories
  • outputFileFullName : AlgorithmFmuWrapperImplementation
  • outputFileName : AlgorithmFmuWrapperImplementation
  • ownVehicleInformation : SensorDriverImplementation , SensorDriverSignal
  • OYA : CollisionAngles
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- p -

  • Par_demandHighway : SpawnPoint_Start_Implementation
  • Par_desiredVelocity : Algorithm_CruiseControlByDistance_Implementation
  • Par_finalFileName : Observation_Ttc_Implementation
  • Par_NSpawnCars : SpawnPoint_Start_Implementation
  • Par_reactionTime : Algorithm_CruiseControlByDistance_Implementation
  • Par_resultFolderName : Observation_Ttc_Implementation
  • Par_tempFileName : Observation_Ttc_Implementation
  • Par_vMean : SpawnPoint_Start_Implementation
  • Par_vMin : SpawnPoint_Start_Implementation
  • Par_vSd : SpawnPoint_Start_Implementation
  • Par_WriteOutputForVisualisation : Observation_State_Implementation
  • parameters : ObservationInstance
  • pedestrianCatalogPath : Scenario
  • penetrationTime : CollisionDetectionPostCrash
  • pointOfContactLocal : PostCrashDynamic
  • positionCar : DynamicsRegularTwoTrackImplementation
  • positionTire : VehicleSimpleTT
  • powerEngineLimit : VehicleSimpleTT
  • previousDistance : Algorithm_CruiseControlByDistance_Implementation
  • print_all_event_vars : fmu_check_data_t
  • printed_instance_name_error_flg : fmu_check_data_t
  • pulse : PostCrashDynamic
  • pulseDirection : PostCrashDynamic
  • pulseLocal : PostCrashDynamic
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- r -

  • RadiantToDegree : SteeringController
  • referencePoint : LongitudinalDistance
  • referenceScale : LocalizationElement
  • referenceVector : LocalizationElement
  • relativeLateralDistance : ObjectInformation
  • relativeLongitudinalDistance : ObjectInformation
  • require_cs : fmu_check_data_t
  • require_me : fmu_check_data_t
  • right : Obstruction
  • runID : Observation_Ttc_Implementation
  • runNumber : Observation_State_Implementation , ObservationFileHandler
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- s -

  • sceneryPath : Scenario
  • search_box : LocalizationElement
  • sEnd : LaneBoundary
  • sensorData : SensorDataSignal
  • sHdg : LaneGeometryJoint
  • side : LaneBoundary
  • slave_initialized : fmu_check_data_t
  • slaveConfigFile : ConfigurationFiles
  • sliding : PostCrashDynamic
  • sOffset : LaneGeometryJoint , StreamInfo< T >
  • sOffsets : IntersectionInfo
  • sStart : LaneBoundary
  • startTime : AlgorithmFmuWrapperImplementation
  • staticStore : BasicDataStoreImplementation
  • steeringWheelAngle : OwnVehicleInformation
  • stepSize : fmu_check_data_t
  • stepSizeSetByUser : fmu_check_data_t
  • stopTime : fmu_check_data_t
  • store : AcyclicResult , CyclicResult
  • supportedScenarioVersion : ScenarioImporter
  • surroundingObjects : SensorDriverImplementation , SensorDriverSignal
  • systemConfigBlueprintFile : ConfigurationFiles
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- t -

  • tAverage : SteeringController
  • tAxisCenter : LocalizationElement
  • temp_dir : fmu_check_data_t
  • tGapWish : AlgorithmAgentFollowingDriverModelImplementation
  • throttlePedal : DynamicsRegularTwoTrackImplementation
  • time : TimeKeeper
  • timeAndEntityIdIndex : BasicDataStoreImplementation
  • timeChannel : Observation_State_Implementation
  • timeLast : SteeringController
  • timestampIndex : BasicDataStoreImplementation
  • timeStep : DynamicsRegularTwoTrackImplementation
  • timeVector : Observation_Ttc_Implementation
  • tmpPath : fmu_check_data_t
  • torqueBrakeLimit : VehicleSimpleTT
  • torqueEngineLimit : VehicleSimpleTT
  • touchedRoads : ObjectPosition
  • trafficRuleInformation : SensorDriverImplementation , SensorDriverSignal
  • trafficSigns : LaneInformationTrafficRules
  • trajectoryCatalogPath : Scenario
  • ttcBrake : AlgorithmAutonomousEmergencyBrakingImplementation
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- u -

  • unzipPathBuf : fmu_check_data_t
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- v -

  • value : BoolSignal , DoubleSignal , externalParameter< ValueType > , InputPort< SignalType, ValueType > , IntSignal , LaneChangeParameter , OutputPort< SignalType, ValueType > , SignalVector< DT >
  • vehicle : DynamicsRegularTwoTrackImplementation
  • vehicleCatalogPath : Scenario
  • vehicleComponentStates : CompCtrlToAgentCompSignal
  • vehicleModelParameters : AlgorithmLongitudinalImplementation , DynamicsRegularDrivingImplementation
  • velocity : DynamicsPostCrashImplementation , PostCrashDynamic
  • velocityAbsolute : PostCrashVelocity
  • velocityCar : DynamicsRegularTwoTrackImplementation
  • velocityChange : PostCrashDynamic
  • velocityDirection : PostCrashDynamic , PostCrashVelocity
  • version : fmu_check_data_t
  • visibilityDistance : GeometryInformation
  • vl : fmu_check_data_t
  • vl2 : fmu_check_data_t
  • VLowerLimit : DynamicsRegularDrivingImplementation
  • vWish : AlgorithmAgentFollowingDriverModelImplementation
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- w -

  • warnings : AgentCompToCompCtrlSignal , CompCtrlToDriverCompSignal
  • width : LaneInformationGeometry , ObjectInformation , LaneBoundary
  • write_log_files : fmu_check_data_t
  • write_output_files : fmu_check_data_t
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- y -

  • yawAcceleration : DynamicsRegularTwoTrackImplementation
  • yawAngle : DynamicsRegularTwoTrackImplementation
  • yawVelocity : DynamicsRegularTwoTrackImplementation , PostCrashDynamic , PostCrashVelocity
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z

- z -

  • zeta : LateralDynamicConstants
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Enumerations

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • CollisionState : DynamicsPostCrashImplementation
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Members - Related Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Functions
  • operator<< : Vector2d
Generated on Sun Sep 20 2020 11:49:50 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AccelerationSignal Member List

This is the complete list of members for AccelerationSignal, including all inherited members.

AccelerationSignal() | AccelerationSignal | inline
AccelerationSignal(AccelerationSignal &other) | AccelerationSignal | inline
AccelerationSignal(ComponentState componentState, double acceleration) | AccelerationSignal | inline
operator std::string() const | AccelerationSignal | inlinevirtual
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Action_BrakeLight_Basic_Implementation Member List

This is the complete list of members for Action_BrakeLight_Basic_Implementation, including all inherited members.

in_aCoasting | Action_BrakeLight_Basic_Implementation | private
in_aVehicle | Action_BrakeLight_Basic_Implementation | private
Trigger(int time) | Action_BrakeLight_Basic_Implementation | virtual
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | Action_BrakeLight_Basic_Implementation | virtual
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | Action_BrakeLight_Basic_Implementation | virtual
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ActionLongitudinalDriverImplementation Member List

This is the complete list of members for ActionLongitudinalDriverImplementation, including all inherited members.

in_accPedalPos | ActionLongitudinalDriverImplementation | private
in_brakePedalPos | ActionLongitudinalDriverImplementation | private
in_gear | ActionLongitudinalDriverImplementation | private
Trigger(int time) | ActionLongitudinalDriverImplementation | virtual
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | ActionLongitudinalDriverImplementation | virtual
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | ActionLongitudinalDriverImplementation | virtual
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ActionSecondaryDriverTasksImplementation Member List

This is the complete list of members for ActionSecondaryDriverTasksImplementation, including all inherited members.

in_flasherSwitch | ActionSecondaryDriverTasksImplementation | private
in_headLightSwitch | ActionSecondaryDriverTasksImplementation | private
in_highBeamLightSwitch | ActionSecondaryDriverTasksImplementation | private
in_hornSwitch | ActionSecondaryDriverTasksImplementation | private
in_IndicatorState | ActionSecondaryDriverTasksImplementation | private
Trigger(int time) | ActionSecondaryDriverTasksImplementation | virtual
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | ActionSecondaryDriverTasksImplementation | virtual
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | ActionSecondaryDriverTasksImplementation | virtual
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ActionTransformRepository Member List

This is the complete list of members for ActionTransformRepository, including all inherited members.

Register(TransformSignature transform) | ActionTransformRepository | inlinestatic
Transform(Args...args) | ActionTransformRepository | inlinestatic
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AcyclicResult Member List

This is the complete list of members for AcyclicResult, including all inherited members.

elements | AcyclicResult | private
store | AcyclicResult | private
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AgentAdapter Member List

This is the complete list of members for AgentAdapter, including all inherited members.

InitEgoVehicle() | AgentAdapter | private
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | AgentAdapter | inlineprotected
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) const | AgentAdapter | inlineprotected
UpdateEgoVehicle() | AgentAdapter | private
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AgentBlueprint Member List

This is the complete list of members for AgentBlueprint, including all inherited members.

AddSensor(openpass::sensors::Parameter parameters) override | AgentBlueprint | virtual
GetAgentCategory() const override | AgentBlueprint | virtual
GetAgentProfileName() const override | AgentBlueprint | virtual
GetAgentType() const override | AgentBlueprint | virtual
GetDriverProfileName() const override | AgentBlueprint | virtual
GetObjectName() const override | AgentBlueprint | virtual
GetSensorParameters() const override | AgentBlueprint | virtual
GetSpawnParameter() override | AgentBlueprint | virtual
GetSpawnParameter() const override | AgentBlueprint | virtual
GetSpeedGoalMin() const override | AgentBlueprint | virtual
GetVehicleComponentProfileNames() const override | AgentBlueprint | virtual
GetVehicleModelName() const override | AgentBlueprint | virtual
GetVehicleModelParameters() const override | AgentBlueprint | virtual
GetVehicleProfileName() const override | AgentBlueprint | virtual
SetAgentCategory(AgentCategory agentCategory) override | AgentBlueprint | virtual
SetAgentProfileName(std::string agentProfileName) override | AgentBlueprint | virtual
SetDriverProfileName(std::string driverProfileName) override | AgentBlueprint | virtual
SetObjectName(std::string objectName) override | AgentBlueprint | virtual
SetSpawnParameter(SpawnParameter spawnParameter) override | AgentBlueprint | virtual
SetSpeedGoalMin(double speedGoalMin) override | AgentBlueprint | virtual
SetVehicleComponentProfileNames(VehicleComponentProfileNames vehicleComponentProfileNames) override | AgentBlueprint | virtual
SetVehicleModelName(std::string vehicleModelName) override | AgentBlueprint | virtual
SetVehicleModelParameters(VehicleModelParameters vehicleModelParameters) override | AgentBlueprint | virtual
SetVehicleProfileName(std::string vehicleProfileName) override | AgentBlueprint | virtual
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AgentBlueprintProvider Member List

This is the complete list of members for AgentBlueprintProvider, including all inherited members.

GenerateDynamicAgentBlueprint(AgentBlueprintInterface &agentBlueprint, AgentBuildInformation agentBuildInformation, std::string &driverProfileName) const | AgentBlueprintProvider |
GenerateStaticAgentBlueprint(AgentBlueprintInterface &agentBlueprint, std::string systemConfigName, int systemId, std::string vehicleModelName) const | AgentBlueprintProvider |
SampleAgent(const std::string &agentProfileName, const openScenario::Parameters &assignedParameters) const override | AgentBlueprintProvider | virtual
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AgentCompToCompCtrlSignal Member List

This is the complete list of members for AgentCompToCompCtrlSignal, including all inherited members.

agentComponentName | AgentCompToCompCtrlSignal | private
AgentCompToCompCtrlSignal(const ComponentType componentType, const std::string &agentComponentName, const ComponentState currentState, const std::vector< ComponentWarningInformation > &warnings={}) | AgentCompToCompCtrlSignal | inline
componentType | AgentCompToCompCtrlSignal | private
currentState | AgentCompToCompCtrlSignal | private
GetAgentComponentName() const | AgentCompToCompCtrlSignal | inline
GetComponentType() const | AgentCompToCompCtrlSignal | inline
GetComponentWarnings() const | AgentCompToCompCtrlSignal | inline
GetCurrentState() const | AgentCompToCompCtrlSignal | inline
operator std::string() const | AgentCompToCompCtrlSignal | inlinevirtual
warnings | AgentCompToCompCtrlSignal | private
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AgentNetwork Member List

This is the complete list of members for AgentNetwork, including all inherited members.

AddAgent(int id, const AgentInterface *agent) | AgentNetwork |
AddAgent(int id, AgentInterface *agent) | AgentNetwork |
Clear() | AgentNetwork |
Clear() | AgentNetwork |
GetAgent(int id) const | AgentNetwork | virtual
GetAgent(int id) const | AgentNetwork |
GetAgents() const | AgentNetwork | virtual
GetAgents() const | AgentNetwork | virtual
GetRemovedAgents() const | AgentNetwork | virtual
GetRemovedAgentsInPreviousTimestep() | AgentNetwork | virtual
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | AgentNetwork | inlineprotected
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | AgentNetwork | inlineprotected
PublishGlobalData(Publisher publish) | AgentNetwork |
QueueAgentRemove(const AgentInterface *agent) | AgentNetwork |
QueueAgentRemove(const AgentInterface *agent) | AgentNetwork |
QueueAgentUpdate(std::function< void(double)> func, double val) | AgentNetwork |
QueueAgentUpdate(std::function< void()> func) | AgentNetwork |
RemoveAgent(const AgentInterface *agent) | AgentNetwork |
SyncGlobalData() | AgentNetwork |
SyncGlobalData() | AgentNetwork |
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AgentSpawnItem Member List

This is the complete list of members for AgentSpawnItem, including all inherited members.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AgentUpdaterImplementation Member List

This is the complete list of members for AgentUpdaterImplementation, including all inherited members.

Trigger(int time) | AgentUpdaterImplementation | virtual
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | AgentUpdaterImplementation | virtual
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | AgentUpdaterImplementation | virtual
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Algorithm_CruiseControlByDistance_Implementation Member List

This is the complete list of members for Algorithm_CruiseControlByDistance_Implementation, including all inherited members.

_accelerationMax | Algorithm_CruiseControlByDistance_Implementation | private
_airDensity | Algorithm_CruiseControlByDistance_Implementation | private
_airDragCoefficent | Algorithm_CruiseControlByDistance_Implementation | private
_carHeight | Algorithm_CruiseControlByDistance_Implementation | private
_carWeight | Algorithm_CruiseControlByDistance_Implementation | private
_carWidth | Algorithm_CruiseControlByDistance_Implementation | private
_cw | Algorithm_CruiseControlByDistance_Implementation | private
_standardCycleTimeSecond | Algorithm_CruiseControlByDistance_Implementation | private
accelerationMin | Algorithm_CruiseControlByDistance_Implementation | private
in_distance2NextAgent | Algorithm_CruiseControlByDistance_Implementation | private
in_velocity | Algorithm_CruiseControlByDistance_Implementation | private
out_aCoasting | Algorithm_CruiseControlByDistance_Implementation | private
out_desiredAcceleration | Algorithm_CruiseControlByDistance_Implementation | private
Par_desiredVelocity | Algorithm_CruiseControlByDistance_Implementation | private
Par_reactionTime | Algorithm_CruiseControlByDistance_Implementation | private
PlausibleTestAcceleration(double desiredAcceleration) | Algorithm_CruiseControlByDistance_Implementation | private
previousDistance | Algorithm_CruiseControlByDistance_Implementation | private
Trigger(int time) | Algorithm_CruiseControlByDistance_Implementation |
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | Algorithm_CruiseControlByDistance_Implementation |
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | Algorithm_CruiseControlByDistance_Implementation |
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Algorithm_FmuWrapper Member List

This is the complete list of members for Algorithm_FmuWrapper, including all inherited members.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AlgorithmAgentFollowingDriverModelImplementation Member List

This is the complete list of members for AlgorithmAgentFollowingDriverModelImplementation, including all inherited members.

AlgorithmAgentFollowingDriverModelImplementation(std::string componentName, bool isInit, int priority, int offsetTime, int responseTime, int cycleTime, StochasticsInterface *stochastics, WorldInterface *world, const ParameterInterface *parameters, PublisherInterface *const publisher, const CallbackInterface *callbacks, AgentInterface *agent) | AlgorithmAgentFollowingDriverModelImplementation |
componentState | AlgorithmAgentFollowingDriverModelImplementation | private
decelerationWish | AlgorithmAgentFollowingDriverModelImplementation | private
delta | AlgorithmAgentFollowingDriverModelImplementation | private
lateralDynamicConstants | AlgorithmAgentFollowingDriverModelImplementation | private
maxAcceleration | AlgorithmAgentFollowingDriverModelImplementation | private
minDistance | AlgorithmAgentFollowingDriverModelImplementation | private
out_curvature | AlgorithmAgentFollowingDriverModelImplementation | private
out_flasher | AlgorithmAgentFollowingDriverModelImplementation | private
out_headLight | AlgorithmAgentFollowingDriverModelImplementation | private
out_highBeamLight | AlgorithmAgentFollowingDriverModelImplementation | private
out_hornSwitch | AlgorithmAgentFollowingDriverModelImplementation | private
out_indicatorState | AlgorithmAgentFollowingDriverModelImplementation | private
out_laneWidth | AlgorithmAgentFollowingDriverModelImplementation | private
out_lateral_damping | AlgorithmAgentFollowingDriverModelImplementation | private
out_lateral_displacement | AlgorithmAgentFollowingDriverModelImplementation | private
out_lateral_frequency | AlgorithmAgentFollowingDriverModelImplementation | private
out_lateral_gain_displacement | AlgorithmAgentFollowingDriverModelImplementation | private
out_lateral_gain_heading_error | AlgorithmAgentFollowingDriverModelImplementation | private
out_lateral_heading_error | AlgorithmAgentFollowingDriverModelImplementation | private
out_lateral_speed | AlgorithmAgentFollowingDriverModelImplementation | private
out_longitudinal_acc | AlgorithmAgentFollowingDriverModelImplementation | private
tGapWish | AlgorithmAgentFollowingDriverModelImplementation | private
Trigger(int time) | AlgorithmAgentFollowingDriverModelImplementation |
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | AlgorithmAgentFollowingDriverModelImplementation |
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | AlgorithmAgentFollowingDriverModelImplementation |
vWish | AlgorithmAgentFollowingDriverModelImplementation | private
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AlgorithmAutonomousEmergencyBrakingImplementation Member List

This is the complete list of members for AlgorithmAutonomousEmergencyBrakingImplementation, including all inherited members.

activeAcceleration | AlgorithmAutonomousEmergencyBrakingImplementation | private
brakingAcceleration | AlgorithmAutonomousEmergencyBrakingImplementation | private
CalculateObjectTTC(const osi3::BaseMoving &baseMoving) | AlgorithmAutonomousEmergencyBrakingImplementation | private
CalculateObjectTTC(const osi3::BaseStationary &baseStationary) | AlgorithmAutonomousEmergencyBrakingImplementation | private
CalculateTTC() | AlgorithmAutonomousEmergencyBrakingImplementation | private
collisionDetectionLateralBoundary | AlgorithmAutonomousEmergencyBrakingImplementation | private
collisionDetectionLongitudinalBoundary | AlgorithmAutonomousEmergencyBrakingImplementation | private
componentState | AlgorithmAutonomousEmergencyBrakingImplementation | private
detectedMovingObjects | AlgorithmAutonomousEmergencyBrakingImplementation | private
detectedStationaryObjects | AlgorithmAutonomousEmergencyBrakingImplementation | private
ParseParameters(const ParameterInterface *parameters) | AlgorithmAutonomousEmergencyBrakingImplementation | private
SetAcceleration(double setValue) | AlgorithmAutonomousEmergencyBrakingImplementation | private
ShouldBeActivated(double ttc) const | AlgorithmAutonomousEmergencyBrakingImplementation | private
ShouldBeDeactivated(double ttc) const | AlgorithmAutonomousEmergencyBrakingImplementation | private
Trigger(int time) | AlgorithmAutonomousEmergencyBrakingImplementation | virtual
ttcBrake | AlgorithmAutonomousEmergencyBrakingImplementation | private
UpdateAcceleration() | AlgorithmAutonomousEmergencyBrakingImplementation | private
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | AlgorithmAutonomousEmergencyBrakingImplementation | virtual
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | AlgorithmAutonomousEmergencyBrakingImplementation | virtual
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AlgorithmFmuWrapperImplementation Member List

This is the complete list of members for AlgorithmFmuWrapperImplementation, including all inherited members.

agentIdString | AlgorithmFmuWrapperImplementation | private
callbacks | AlgorithmFmuWrapperImplementation | private
cdata | AlgorithmFmuWrapperImplementation | private
false | AlgorithmFmuWrapperImplementation | private
FmiTypeToCType(const fmi1_base_type_enu_t fmiType) | AlgorithmFmuWrapperImplementation | private
FmiTypeToCType(const fmi2_base_type_enu_t fmiType) | AlgorithmFmuWrapperImplementation | private
FMU_fullName | AlgorithmFmuWrapperImplementation | private
FMU_name | AlgorithmFmuWrapperImplementation | private
FMU_path | AlgorithmFmuWrapperImplementation | private
fmuHandler | AlgorithmFmuWrapperImplementation | private
fmuType | AlgorithmFmuWrapperImplementation | private
fmuVariables | AlgorithmFmuWrapperImplementation | private
fmuVariableValues | AlgorithmFmuWrapperImplementation | private
folderUnzip | AlgorithmFmuWrapperImplementation | private
GetFmuVariables() | AlgorithmFmuWrapperImplementation | private
HandleFmiStatus(const jm_status_enu_t &fmiStatus, const std::string &logPrefix) | AlgorithmFmuWrapperImplementation | private
InitFmu() | AlgorithmFmuWrapperImplementation | private
logFileFullName | AlgorithmFmuWrapperImplementation | private
logFileName | AlgorithmFmuWrapperImplementation | private
MkDirOrThrowError(const boost::filesystem::path path) | AlgorithmFmuWrapperImplementation | private
outputFileFullName | AlgorithmFmuWrapperImplementation | private
outputFileName | AlgorithmFmuWrapperImplementation | private
SetupFilenames() | AlgorithmFmuWrapperImplementation | private
SetupLog() | AlgorithmFmuWrapperImplementation | private
SetupOutput() | AlgorithmFmuWrapperImplementation | private
SetupUnzip(const bool individualUnzip) | AlgorithmFmuWrapperImplementation | private
startTime | AlgorithmFmuWrapperImplementation | private
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AlgorithmLateralImplementation Member List

This is the complete list of members for AlgorithmLateralImplementation, including all inherited members.

out_desiredSteeringWheelAngle | AlgorithmLateralImplementation | protected
Trigger(int time) | AlgorithmLateralImplementation |
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | AlgorithmLateralImplementation |
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | AlgorithmLateralImplementation |
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AlgorithmLongitudinalCalculations Member List

This is the complete list of members for AlgorithmLongitudinalCalculations, including all inherited members.

AlgorithmLongitudinalCalculations(double velocity, double accelerationWish, const VehicleModelParameters &vehicleModelParameters) | AlgorithmLongitudinalCalculations
CalculateGearAndEngineSpeed() | AlgorithmLongitudinalCalculations
CalculatePedalPositions() | AlgorithmLongitudinalCalculations
GetAcceleratorPedalPosition() const | AlgorithmLongitudinalCalculations
GetAccFromEngineTorque(double engineTorque, int chosenGear) | AlgorithmLongitudinalCalculations
GetBrakePedalPosition() const | AlgorithmLongitudinalCalculations
GetEngineSpeed() const | AlgorithmLongitudinalCalculations
GetEngineSpeedByVelocity(double velocity, int gear) | AlgorithmLongitudinalCalculations
GetEngineTorqueAtGear(int gear, double acceleration) | AlgorithmLongitudinalCalculations
GetEngineTorqueMax(double engineSpeed) | AlgorithmLongitudinalCalculations
GetEngineTorqueMin(double engineSpeed) | AlgorithmLongitudinalCalculations
GetGear() const | AlgorithmLongitudinalCalculations
isWithinEngineLimits(int gear, double engineSpeed, double acceleration) | AlgorithmLongitudinalCalculations
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AlgorithmLongitudinalImplementation Member List

This is the complete list of members for AlgorithmLongitudinalImplementation, including all inherited members.

accelerationWish | AlgorithmLongitudinalImplementation | private
CalculatePedalPositionAndGear() | AlgorithmLongitudinalImplementation | private
COMPONENTNAME | AlgorithmLongitudinalImplementation |
currentVelocity | AlgorithmLongitudinalImplementation | private
initializedAccelerationInput | AlgorithmLongitudinalImplementation | private
initializedSensorDriverData | AlgorithmLongitudinalImplementation | private
initializedVehicleModelParameters | AlgorithmLongitudinalImplementation | private
out_accPedalPos | AlgorithmLongitudinalImplementation | private
out_brakePedalPos | AlgorithmLongitudinalImplementation | private
out_gear | AlgorithmLongitudinalImplementation | private
vehicleModelParameters | AlgorithmLongitudinalImplementation | private
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

BasicDataStoreImplementation Member List

This is the complete list of members for BasicDataStoreImplementation, including all inherited members.

acyclicStore | BasicDataStoreImplementation | protected
cyclicStore | BasicDataStoreImplementation | protected
entityIdIndex | BasicDataStoreImplementation | protected
staticStore | BasicDataStoreImplementation | protected
timeAndEntityIdIndex | BasicDataStoreImplementation | protected
timestampIndex | BasicDataStoreImplementation | protected
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

BoolSignal Member List

This is the complete list of members for BoolSignal, including all inherited members.

operator std::string() const | BoolSignal | inlinevirtual
value | BoolSignal |
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

BoundingBoxCalculation Member List

This is the complete list of members for BoundingBoxCalculation, including all inherited members.

CalculateBoundingBox(double timeStepInSeconds, const osi3::BaseMoving &baseMoving) | BoundingBoxCalculation |
CalculateBoundingBox(const osi3::BaseStationary &baseStationary) | BoundingBoxCalculation |
CalculateOwnBoundingBox(double timeStepInSeconds) | BoundingBoxCalculation |
collisionDetectionLateralBoundary | BoundingBoxCalculation | private
collisionDetectionLongitudinalBoundary | BoundingBoxCalculation | private
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

CSVParser Member List

This is the complete list of members for CSVParser, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

CollisionDetectionPostCrash Member List

This is the complete list of members for CollisionDetectionPostCrash, including all inherited members.

CalculateAllIntersectionPoints(std::vector< Common::Vector2d > corners1, std::vector< Common::Vector2d > corners2) | CollisionDetectionPostCrash | private
CalculateCollisionAngles(const AgentInterface *agent1, const AgentInterface *agent2, int timeFirstContact) | CollisionDetectionPostCrash | private
CalculatePlaneOfContact(Polygon intersection, std::vector< int > vertexTypes, Common::Vector2d &pointOfImpact, double &phi) | CollisionDetectionPostCrash | private
CalculatePostCrashDynamic(Common::Vector2d cog1, const AgentInterface *agent1, Common::Vector2d cog2, const AgentInterface *agent2, Common::Vector2d poi, double phi, PostCrashDynamic *postCrashDynamic1, PostCrashDynamic *postCrashDynamic2) | CollisionDetectionPostCrash | private
coeffRest | CollisionDetectionPostCrash | private
collAngles | CollisionDetectionPostCrash | private
CreatePostCrashDynamics(const AgentInterface *agent1, const AgentInterface *agent2, PostCrashDynamic *postCrashDynamic1, PostCrashDynamic *postCrashDynamic2, int &timeOfFirstContact) | CollisionDetectionPostCrash |
GetAgentCorners(const AgentInterface *agent) | CollisionDetectionPostCrash | private
GetAgentVelocityVector(const AgentInterface *agent) | CollisionDetectionPostCrash | private
GetCollisionAngles() | CollisionDetectionPostCrash |
GetCollisionPosition(const AgentInterface *agent1, const AgentInterface *agent2, Common::Vector2d &cog1, Common::Vector2d &cog2, Common::Vector2d &pointOfImpact, double &phi, int timeFirstContact) | CollisionDetectionPostCrash | private
GetFirstContact(const AgentInterface *agent1, const AgentInterface *agent2, int &timeFirstContact) | CollisionDetectionPostCrash | private
GetIntersectionPoint(Common::Vector2d n1, Common::Vector2d n2, double d1, double d2, Common::Vector2d &intersectionPoint) | CollisionDetectionPostCrash | private
GetVertexTypes(std::vector< Common::Vector2d > vertices1, std::vector< Common::Vector2d > vertices2, std::vector< Common::Vector2d > verticesIntersection) | CollisionDetectionPostCrash | private
interFriction | CollisionDetectionPostCrash | private
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | CollisionDetectionPostCrash | inlineprotected
penetrationTime | CollisionDetectionPostCrash | private
SetCollisionAngles(double OYA, double HCPAo, double OCPAo, double HCPA, double OCPA) | CollisionDetectionPostCrash |
ShiftPolygonsAndCheckIntersection(Polygon polygon1, Polygon polygon2, Common::Vector2d shiftVector1, Common::Vector2d shiftVector2) | CollisionDetectionPostCrash | private
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

CollisionDetector Member List

This is the complete list of members for CollisionDetector, including all inherited members.

CalculateDistOnBorder(const WorldObjectInterface *worldObject, int corner, double cornerDistance, double &result) | CollisionDetector |
CalculateIntersectionPoints(const WorldObjectInterface *agent, const WorldObjectInterface *other, bool &intersected, Common::Vector2d &intersectionPoint, double &otherDistanceFromCorner, int &otherFromCorner, double &agentDistanceFromInitial, Common::Vector2d &agentReferencePoint, Common::Vector2d &otherReferencePoint, size_t &agentPenetratingCorner) | CollisionDetector |
CalculatePointOfContact(AgentInterface *agent, const WorldObjectInterface *other, double &resultAgentDistOnBorder, double &resultOtherDistOnBorder, Common::Vector2d &resultAgentReferencePoint, Common::Vector2d &resultOtherReferencePoint) | CollisionDetector |
CalculateWorldObjectGeometry(const WorldObjectInterface *worldObject, const Common::Vector2d &position, std::array< Common::Vector2d, 4 > &resultCorners, std::array< Common::Vector2d, 2 > &resultNormals) | CollisionDetector |
DetectCollision(const WorldObjectInterface *other, AgentInterface *agent, std::array< Common::Vector2d, NumberCorners > agentCorners, std::array< Common::Vector2d, NumberNormals > agentNormals) | CollisionDetector |
DetectedCollisionWithAgent(int time, AgentInterface *agent, AgentInterface *other) | CollisionDetector | private
DetectedCollisionWithObject(int time, AgentInterface *agent, const WorldObjectInterface *other) | CollisionDetector | private
DetectIntersectionOfTwoWorldObjects(const WorldObjectInterface *agent, std::array< Common::Vector2d, NumberNormals > agentNormals, std::array< Common::Vector2d, NumberCorners > agentCorners, const WorldObjectInterface *other, std::array< Common::Vector2d, NumberNormals > otherNormals, std::array< Common::Vector2d, NumberCorners > otherCorners) | CollisionDetector | private
GetCycleTime() override | EventDetectorCommonBase | virtual
GetMinMax2(std::array< double, 2 > &input, double &maxValue, double &minValue) | CollisionDetector |
GetMinMax4(std::array< double, 4 > &input, double &maxValue, double &minValue) | CollisionDetector |
GetWorldObjectGeometry(const WorldObjectInterface *worldObject, std::array< Common::Vector2d, 4 > &resultCorners, std::array< Common::Vector2d, 2 > &resultNormals) | CollisionDetector |
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | EventDetectorCommonBase | protected
Reset() override | EventDetectorCommonBase | virtual
Trigger(int time) | CollisionDetector | virtual
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

CollisionManipulator Member List

This is the complete list of members for CollisionManipulator, including all inherited members.

collisionPostCrash | CollisionManipulator | private
GetCycleTime() | ManipulatorCommonBase | virtual
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | ManipulatorCommonBase | protected
Trigger(int time) override | CollisionManipulator | virtual
UpdateCollision(AgentInterface *agent, AgentInterface *opponent) | CollisionManipulator | private
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

CommandLineParser Member List

This is the complete list of members for CommandLineParser, including all inherited members.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Common
  • Vector2d
Vector2d Member List

This is the complete list of members for Vector2d, including all inherited members.

Add(const Vector2d &in) noexcept | Vector2d | inline
Angle() const noexcept | Vector2d | inline
Cross(const Vector2d &in) const noexcept | Vector2d | inline
Dot(const Vector2d &in) const noexcept | Vector2d | inline
Length() const noexcept | Vector2d | inline
Norm() | Vector2d | inline
operator!=(const Vector2d &in) const noexcept | Vector2d | inline
operator<<(std::ostream &os, const Vector2d &vector) | Vector2d | friend
operator==(const Vector2d &in) const noexcept | Vector2d | inline
Rotate(double angle) noexcept | Vector2d | inline
Scale(double scale) noexcept | Vector2d | inline
Sub(const Vector2d &in) noexcept | Vector2d | inline
Translate(double x, double y) noexcept | Vector2d | inline
Translate(Vector2d translationVector) noexcept | Vector2d | inline
Vector2d(double x=0, double y=0) noexcept | Vector2d | inline
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Common
  • Vector3d
Vector3d Member List

This is the complete list of members for Vector3d, including all inherited members.

Add(const Vector3d &in) | Vector3d
Length() const | Vector3d
Norm() | Vector3d
Scale(double scale) | Vector3d
Sub(const Vector3d &in) | Vector3d
Translate(double x, double y, double z) | Vector3d
Vector3d(double x=0, double y=0, double z=0) | Vector3d
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

CompCtrlToAgentCompSignal Member List

This is the complete list of members for CompCtrlToAgentCompSignal, including all inherited members.

CompCtrlToAgentCompSignal(const ComponentState &maxReachableState, const std::map< std::string, std::pair< ComponentType, ComponentState >> &vehicleComponentStates) | CompCtrlToAgentCompSignal | inline
GetMaxReachableState() const | CompCtrlToAgentCompSignal | inline
GetVehicleComponentStates() const | CompCtrlToAgentCompSignal | inline
maxReachableState | CompCtrlToAgentCompSignal | private
operator std::string() const | CompCtrlToAgentCompSignal | inlinevirtual
vehicleComponentStates | CompCtrlToAgentCompSignal | private
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

CompCtrlToDriverCompSignal Member List

This is the complete list of members for CompCtrlToDriverCompSignal, including all inherited members.

CompCtrlToAgentCompSignal(const ComponentState &maxReachableState, const std::map< std::string, std::pair< ComponentType, ComponentState >> &vehicleComponentStates) | CompCtrlToAgentCompSignal | inline
CompCtrlToDriverCompSignal(const ComponentState &maxReachableState, const std::map< std::string, std::pair< ComponentType, ComponentState >> &vehicleComponentStates, const Warnings &warnings) | CompCtrlToDriverCompSignal | inline
GetMaxReachableState() const | CompCtrlToAgentCompSignal | inline
GetVehicleComponentStates() const | CompCtrlToAgentCompSignal | inline
GetWarnings() const | CompCtrlToDriverCompSignal | inline
operator std::string() const | CompCtrlToAgentCompSignal | inlinevirtual
warnings | CompCtrlToDriverCompSignal | private
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • ComponentControl
  • AdasComponentStateInformation
AdasComponentStateInformation Member List

This is the complete list of members for AdasComponentStateInformation, including all inherited members.

AddStateCondition(std::shared_ptr< Condition > condition, const ComponentState state) | ComponentStateInformation
DetermineDefaultMaximumComponentStateByType() const | AdasComponentStateInformation
GetAdasType() const | AdasComponentStateInformation
GetComponentName() const | ComponentStateInformation
GetComponentType() const | ComponentStateInformation
GetCurrentState() const | ComponentStateInformation
GetMaxReachableState() const | ComponentStateInformation
GetMaxReachableStateSetByEvent() const | ComponentStateInformation
GetStateConditions() const | ComponentStateInformation
SetCurrentState(const ComponentState currentState) | ComponentStateInformation
SetDesiredState(const ComponentState desiredState) | ComponentStateInformation
SetMaxReachableState(const ComponentState maxReachableState) | ComponentStateInformation
SetMaxReachableStateSetByEvent(const bool maxReachableStateSetByEvent) | ComponentStateInformation
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • ComponentControl
  • ComponentStateEquality
ComponentStateEquality Member List

This is the complete list of members for ComponentStateEquality, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • ComponentControl
  • ComponentStateExpression
ComponentStateExpression Member List

This is the complete list of members for ComponentStateExpression, including all inherited members.

Get(const StateMapping &componentNameToComponentTypeAndStateMap) const =0 ComponentStateExpression pure virtual
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • ComponentControl
  • ComponentStateInformation
ComponentStateInformation Member List

This is the complete list of members for ComponentStateInformation, including all inherited members.

AddStateCondition(std::shared_ptr< Condition > condition, const ComponentState state) | ComponentStateInformation
GetComponentName() const | ComponentStateInformation
GetComponentType() const | ComponentStateInformation
GetCurrentState() const | ComponentStateInformation
GetMaxReachableState() const | ComponentStateInformation
GetMaxReachableStateSetByEvent() const | ComponentStateInformation
GetStateConditions() const | ComponentStateInformation
SetCurrentState(const ComponentState currentState) | ComponentStateInformation
SetDesiredState(const ComponentState desiredState) | ComponentStateInformation
SetMaxReachableState(const ComponentState maxReachableState) | ComponentStateInformation
SetMaxReachableStateSetByEvent(const bool maxReachableStateSetByEvent) | ComponentStateInformation
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • ComponentControl
  • Condition
Condition Member List

This is the complete list of members for Condition, including all inherited members.

IsFullfilled(const StateMapping &componentNameToComponentTypeAndStatesMap) const =0 Condition pure virtual
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • ComponentControl
  • FixedComponentStateExpression
FixedComponentStateExpression Member List

This is the complete list of members for FixedComponentStateExpression, including all inherited members.

FixedComponentStateExpression(ComponentState value) FixedComponentStateExpression inline
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • ComponentControl
  • StateManager
StateManager Member List

This is the complete list of members for StateManager, including all inherited members.

AddComponent(const int localLinkId, std::shared_ptr< ComponentStateInformation > componentStateInformation) | StateManager |
FlagComponentMaxReachableStateSetByEvent(const int localLinkId) | StateManager |
GetComponent(const int localLinkId) const | StateManager |
GetComponentLocalLinkIdByName(const std::string &componentName) const | StateManager |
GetMaxReachableStateOfComponentAtLocalLinkId(const int localLinkId) const | StateManager |
GetVehicleComponentNamesToTypeAndStateMap() | StateManager |
LocalLinkIdIsRegistered(const int localLinkId) const | StateManager |
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) const | StateManager | inlineprivate
UpdateComponentCurrentState(const int localLinkId, const ComponentState currentState) | StateManager |
UpdateComponentDesiredState(const int localLinkId, ComponentState desiredState) | StateManager |
UpdateComponentMaxReachableState(const int localLinkId, ComponentState maxReachableState) | StateManager |
UpdateMaxReachableStatesForRegisteredComponents(std::vector< openpass::events::ComponentStateChangeEvent const * > &componentStateChanges) | StateManager |
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • ComponentControl
  • VehicleComponentStateExpression
VehicleComponentStateExpression Member List

This is the complete list of members for VehicleComponentStateExpression, including all inherited members.

VehicleComponentStateExpression(const std::string &component) VehicleComponentStateExpression inline
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ComponentControllerImplementation Member List

This is the complete list of members for ComponentControllerImplementation, including all inherited members.

IsAgentAffectedByEvent(EventInterface const *event) | ComponentControllerImplementation | private
Trigger(int time) | ComponentControllerImplementation | virtual
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | ComponentControllerImplementation | virtual
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | ComponentControllerImplementation | virtual
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ComponentPort Member List

This is the complete list of members for ComponentPort, including all inherited members.

ComponentPort(int id, std::map< int, ComponentPort * > *portMap) | ComponentPort | inline
GetId() | ComponentPort | inline
GetSignalValue(std::shared_ptr< SignalInterface const > &data) | ComponentPort | inlinevirtual
id | ComponentPort | private
SetSignalValue(const std::shared_ptr< SignalInterface const > &data) | ComponentPort | inlinevirtual
~ComponentPort()=default | ComponentPort | virtual
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ComponentStateChangeManipulator Member List

This is the complete list of members for ComponentStateChangeManipulator, including all inherited members.

GetCycleTime() | ManipulatorCommonBase | virtual
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | ManipulatorCommonBase | protected
Trigger(int time) override | ComponentStateChangeManipulator | virtual
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ComponentStateSignal Member List

This is the complete list of members for ComponentStateSignal, including all inherited members.

operator std::string() const ComponentStateSignal inlinevirtual
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ConditionCommonBase Member List

This is the complete list of members for ConditionCommonBase, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ConditionalEventDetector Member List

This is the complete list of members for ConditionalEventDetector, including all inherited members.

CheckCondition(const ConditionMetaInformation &cmi) | ConditionalEventDetector | inlineprivate
EvaluateConditions(const int time) | ConditionalEventDetector | private
GetActors(const std::vector< const AgentInterface * > triggeringAgents={}) | ConditionalEventDetector | private
GetCycleTime() override | EventDetectorCommonBase | virtual
IsBelowMaximumNumberOfExecutions() | ConditionalEventDetector | private
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | EventDetectorCommonBase | protected
TriggerEventInsertion(int time, const std::vector< const AgentInterface * > triggeringAgents) | ConditionalEventDetector | private
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Configuration
  • ConfigurationContainer
ConfigurationContainer Member List

This is the complete list of members for ConfigurationContainer, including all inherited members.

GetProfiles() override | ConfigurationContainer
GetRuntimeInformation() const override | ConfigurationContainer
GetScenario() override | ConfigurationContainer
GetScenery() override | ConfigurationContainer
GetSlaveConfig() override | ConfigurationContainer
GetSystemConfigBlueprint() override | ConfigurationContainer
GetSystemConfigs() override | ConfigurationContainer
GetVehicleModels() override | ConfigurationContainer
ImportAllConfigurations() override | ConfigurationContainer
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Configuration
  • Scenario
Scenario Member List

This is the complete list of members for Scenario, including all inherited members.

endTimeInSeconds | Scenario | private
GetPedestrianCatalogPath() override | Scenario |
GetSceneryPath() override | Scenario |
GetTrajectoryCatalogPath() override | Scenario |
GetVehicleCatalogPath() override | Scenario |
pedestrianCatalogPath | Scenario | private
sceneryPath | Scenario | private
SetPedestrianCatalogPath(const std::string &catalogPath) override | Scenario |
SetSceneryPath(const std::string &sceneryPath) override | Scenario |
SetTrajectoryCatalogPath(const std::string &catalogPath) override | Scenario |
SetVehicleCatalogPath(const std::string &catalogPath) override | Scenario |
trajectoryCatalogPath | Scenario | private
vehicleCatalogPath | Scenario | private
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Configuration
  • Scenery
Scenery Member List

This is the complete list of members for Scenery, including all inherited members.

AddJunction(const std::string &id) | Scenery |
AddRoad(const std::string &id) | Scenery |
Clear() | Scenery |
GetJunction(const std::string &id) const | Scenery | inline
GetJunctions() const | Scenery | inline
GetRoad(const std::string &id) const | Scenery | inline
GetRoads() const | Scenery | inline
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Configuration
  • SlaveConfig
SlaveConfig Member List

This is the complete list of members for SlaveConfig, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Configuration
  • SystemConfig
SystemConfig Member List

This is the complete list of members for SystemConfig, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Configuration
  • VehicleModels
VehicleModels Member List

This is the complete list of members for VehicleModels, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Connection Member List

This is the complete list of members for Connection, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

CustomCommandFactory Member List

This is the complete list of members for CustomCommandFactory, including all inherited members.

Create(const std::string &command, Args...args) | CustomCommandFactory | inlinestatic
Register(const std::string command) | CustomCommandFactory | inlinestatic
repository() | CustomCommandFactory | inlineprivatestatic
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

CyclicResult Member List

This is the complete list of members for CyclicResult, including all inherited members.

elements | CyclicResult | private
store | CyclicResult | private
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

DoubleSignal Member List

This is the complete list of members for DoubleSignal, including all inherited members.

operator std::string() const | DoubleSignal | inlinevirtual
value | DoubleSignal |
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

DynamicAgentTypeGenerator Member List

This is the complete list of members for DynamicAgentTypeGenerator, including all inherited members.

GatherBasicComponents() | DynamicAgentTypeGenerator |
GatherComponent(const std::string componentName, std::shared_ptr< SimulationSlave::AgentType > agentType) | DynamicAgentTypeGenerator |
GatherComponentWithParameters(std::string componentName, std::shared_ptr< SimulationSlave::AgentType > agentType, const openpass::parameter::ParameterSetLevel1 &parameters) | DynamicAgentTypeGenerator |
GatherComponentWithParameters(std::string componentName, std::shared_ptr< SimulationSlave::AgentType > agentType, const openpass::parameter::ParameterSetLevel1 &parameters, std::string componentNameInSystemConfigBlueprint, int channelOffset) | DynamicAgentTypeGenerator |
GatherDriverComponents() | DynamicAgentTypeGenerator |
GatherSensors() | DynamicAgentTypeGenerator |
GatherVehicleComponents() | DynamicAgentTypeGenerator |
operator AgentBuildInformation &&() | DynamicAgentTypeGenerator | inline
SampleSensorLatency(std::shared_ptr< ParameterInterface > curParameters) | DynamicAgentTypeGenerator |
SetVehicleModelParameters(const openScenario::Parameters &assignedParameters) | DynamicAgentTypeGenerator |
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

DynamicParameterSampler Member List

This is the complete list of members for DynamicParameterSampler, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

DynamicProfileSampler Member List

This is the complete list of members for DynamicProfileSampler, including all inherited members.

operator SampledProfiles &&() | DynamicProfileSampler | inline
SampleDriverProfile() | DynamicProfileSampler |
SampleVehicleComponentProfiles() | DynamicProfileSampler |
SampleVehicleProfile() | DynamicProfileSampler |
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Dynamics_Longitudinal_Basic_Implementation Member List

This is the complete list of members for Dynamics_Longitudinal_Basic_Implementation, including all inherited members.

_VLowerLimit | Dynamics_Longitudinal_Basic_Implementation | private
in_aVehicle | Dynamics_Longitudinal_Basic_Implementation | private
Trigger(int time) | Dynamics_Longitudinal_Basic_Implementation | virtual
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | Dynamics_Longitudinal_Basic_Implementation | virtual
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | Dynamics_Longitudinal_Basic_Implementation | virtual
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

DynamicsCollisionImplementation Member List

This is the complete list of members for DynamicsCollisionImplementation, including all inherited members.

Trigger(int time) | DynamicsCollisionImplementation | virtual
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | DynamicsCollisionImplementation | virtual
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | DynamicsCollisionImplementation | virtual
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

DynamicsPostCrashImplementation Member List

This is the complete list of members for DynamicsPostCrashImplementation, including all inherited members.

CollisionState enum name | DynamicsPostCrashImplementation | private
dynamicsSignal | DynamicsPostCrashImplementation | private
isActive | DynamicsPostCrashImplementation | private
movingDirection | DynamicsPostCrashImplementation | private
numberOfCollisionPartners | DynamicsPostCrashImplementation | private
SetFadingDynamics() | DynamicsPostCrashImplementation | private
Trigger(int time) | DynamicsPostCrashImplementation | virtual
TriggerPostCrashCheck(int time) | DynamicsPostCrashImplementation | private
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | DynamicsPostCrashImplementation | virtual
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | DynamicsPostCrashImplementation | virtual
velocity | DynamicsPostCrashImplementation | private
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

DynamicsRegularDrivingImplementation Member List

This is the complete list of members for DynamicsRegularDrivingImplementation, including all inherited members.

_oneG | DynamicsRegularDrivingImplementation | private
_rho | DynamicsRegularDrivingImplementation | private
_twoPi | DynamicsRegularDrivingImplementation | private
ApplyGearLimit() | DynamicsRegularDrivingImplementation | private
ApplyPedalPositionLimits() | DynamicsRegularDrivingImplementation | private
COMPONENTNAME | DynamicsRegularDrivingImplementation |
DegreeToRadiant | DynamicsRegularDrivingImplementation | private
dynamicsSignal | DynamicsRegularDrivingImplementation | private
GetAccelerationFromAirResistance(double velocity) | DynamicsRegularDrivingImplementation | private
GetAccelerationFromRollingResistance() | DynamicsRegularDrivingImplementation | private
GetAccFromEngineMoment(double xVel, double engineMoment, int chosenGear, int cycleTime) | DynamicsRegularDrivingImplementation | private
GetAccVehicle(double accPedalPos, double brakePedalPos, int gear, int time) | DynamicsRegularDrivingImplementation | private
GetEngineMoment(double gasPedalPos, int lastGear) | DynamicsRegularDrivingImplementation | private
GetEngineMomentMax(double engineSpeed) | DynamicsRegularDrivingImplementation | private
GetEngineMomentMin(double engineSpeed) | DynamicsRegularDrivingImplementation | private
GetEngineSpeedByVelocity(double xVel, int gear) | DynamicsRegularDrivingImplementation | private
GetFrictionCoefficient() | DynamicsRegularDrivingImplementation | private
in_accPedalPos | DynamicsRegularDrivingImplementation | private
in_brakePedalPos | DynamicsRegularDrivingImplementation | private
in_gear | DynamicsRegularDrivingImplementation | private
in_steeringWheelAngle | DynamicsRegularDrivingImplementation | private
Trigger(int time) | DynamicsRegularDrivingImplementation | virtual
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | DynamicsRegularDrivingImplementation | virtual
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | DynamicsRegularDrivingImplementation | virtual
vehicleModelParameters | DynamicsRegularDrivingImplementation | private
VLowerLimit | DynamicsRegularDrivingImplementation | private
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

DynamicsRegularTwoTrackImplementation Member List

This is the complete list of members for DynamicsRegularTwoTrackImplementation, including all inherited members.

accelerationCar | DynamicsRegularTwoTrackImplementation | private
angleTireFront | DynamicsRegularTwoTrackImplementation | private
brakePedal | DynamicsRegularTwoTrackImplementation | private
brakeSuperpose | DynamicsRegularTwoTrackImplementation | private
COMPONENTNAME | DynamicsRegularTwoTrackImplementation |
dynamicsSignal | DynamicsRegularTwoTrackImplementation | private
forceWheelVertical | DynamicsRegularTwoTrackImplementation | private
Init() | DynamicsRegularTwoTrackImplementation | private
inputPorts | DynamicsRegularTwoTrackImplementation | private
NextStateRotation() | DynamicsRegularTwoTrackImplementation | private
NextStateSet() | DynamicsRegularTwoTrackImplementation | private
NextStateTranslation() | DynamicsRegularTwoTrackImplementation | private
positionCar | DynamicsRegularTwoTrackImplementation | private
ReadPreviousState() | DynamicsRegularTwoTrackImplementation | private
throttlePedal | DynamicsRegularTwoTrackImplementation | private
timeStep | DynamicsRegularTwoTrackImplementation | private
Trigger(int time) | DynamicsRegularTwoTrackImplementation | virtual
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | DynamicsRegularTwoTrackImplementation | virtual
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | DynamicsRegularTwoTrackImplementation | virtual
vehicle | DynamicsRegularTwoTrackImplementation | private
velocityCar | DynamicsRegularTwoTrackImplementation | private
yawAcceleration | DynamicsRegularTwoTrackImplementation | private
yawAngle | DynamicsRegularTwoTrackImplementation | private
yawVelocity | DynamicsRegularTwoTrackImplementation | private
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

DynamicsSignal Member List

This is the complete list of members for DynamicsSignal, including all inherited members.

operator std::string() const DynamicsSignal inlinevirtual
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

EgoAgent Member List

This is the complete list of members for EgoAgent, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

EventDetectorCommonBase Member List

This is the complete list of members for EventDetectorCommonBase, including all inherited members.

GetCycleTime() override | EventDetectorCommonBase | virtual
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | EventDetectorCommonBase | protected
Reset() override | EventDetectorCommonBase | virtual
Trigger(int time) override=0 | EventDetectorCommonBase | pure virtual
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Importer
  • EventDetectorImporter
EventDetectorImporter Member List

This is the complete list of members for EventDetectorImporter, including all inherited members.

ContainsEntity(const std::vector< ScenarioEntity > &entities, const std::string &entityName) | EventDetectorImporter | privatestatic
ImportByEntityElement(QDomElement byEntityElement, const std::vector< ScenarioEntity > &entities, openScenario::Parameters &parameters) | EventDetectorImporter | privatestatic
ImportConditionByValueElement(QDomElement &byValueElement, openScenario::Parameters &parameters) | EventDetectorImporter | privatestatic
ImportConditionElement(QDomElement &conditionElement, const std::vector< ScenarioEntity > &entities, openScenario::Parameters &parameters) | EventDetectorImporter | privatestatic
ImportEntityCondition(QDomElement byEntityCondition, std::vector< std::string > triggeringEntities) | EventDetectorImporter | privatestatic
ImportEventDetector(QDomElement &eventElement, const std::string &eventName, const int numberOfExecutions, const openScenario::ActorInformation &actorInformation, const std::vector< ScenarioEntity > &entities, openScenario::Parameters &parameters) | EventDetectorImporter | static
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Importer
  • ProfilesImporter
ProfilesImporter Member List

This is the complete list of members for ProfilesImporter, including all inherited members.

Import(const std::string &filename, Profiles &profiles) | ProfilesImporter | static
ImportAgentProfiles(QDomElement agentProfilesElement, std::unordered_map< std::string, AgentProfile > &agentProfiles) | ProfilesImporter | static
ImportAllSensorsOfVehicleProfile(QDomElement vehicleProfileElement, VehicleProfile &vehicleProfile) | ProfilesImporter | static
ImportAllVehicleComponentsOfVehicleProfile(QDomElement vehicleProfileElement, VehicleProfile &vehicleProfile) | ProfilesImporter | static
ImportProfileGroups(ProfileGroups &profileGroups, QDomElement &profilesElement) | ProfilesImporter | static
ImportSensorLinksOfComponent(QDomElement sensorLinksElement, std::list< SensorLink > &sensorLinks) | ProfilesImporter | static
ImportSensorParameters(QDomElement sensorElement, openpass::sensors::Parameter &sensorParameter) | ProfilesImporter | static
ImportVehicleComponent(QDomElement vehicleComponentElement, VehicleComponent &vehicleComponent) | ProfilesImporter | static
ImportVehicleProfile(QDomElement vehicleProfileElement) | ProfilesImporter | static
ImportVehicleProfiles(QDomElement vehicleProfilesElement, std::unordered_map< std::string, VehicleProfile > &vehicleProfiles) | ProfilesImporter | static
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Importer
  • ScenarioImporter
ScenarioImporter Member List

This is the complete list of members for ScenarioImporter, including all inherited members.

CategorizeEntities(const std::vector< ScenarioEntity > &entities, const std::map< std::string, std::list< std::string > > &groups, ScenarioInterface *scenario) | ScenarioImporter | privatestatic
ContainsEntity(const std::vector< ScenarioEntity > &entities, const std::string &entityName) | ScenarioImporter | privatestatic
GetEntityByName(std::vector< ScenarioEntity > &entities, const std::string &entityName) | ScenarioImporter | privatestatic
ImportAction(QDomElement eventElement, openScenario::Parameters &parameters, const std::string catalogPath) | ScenarioImporter | privatestatic
ImportActors(QDomElement &actorsElement, const std::vector< ScenarioEntity > &entities, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportAndValidateVersion(openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportCatalog(const std::string &catalogName, QDomElement &catalogsElement, openScenario::Parameters &parameters) | ScenarioImporter | static
ImportCatalogs(QDomElement &documentRoot, ScenarioInterface *scenario, const std::string &filePath, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportEndConditionsFromStoryboard(const QDomElement &storyboardElement, ScenarioInterface *scenario, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportEntities(QDomElement &documentRoot, std::vector< ScenarioEntity > &entities, std::map< std::string, std::list< std::string > > &groups, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportEntity(QDomElement &entityElement, ScenarioEntity &entity, openScenario::Parameters &parameters) | ScenarioImporter | static
ImportEntityCatalogReference(QDomElement &catalogReferenceElement, ScenarioEntity &entity, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportInitElement(QDomElement &initElement, std::vector< ScenarioEntity > &entities, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportLanePosition(QDomElement positionElement, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportManeuverElement(QDomElement &maneuverElement, const std::vector< ScenarioEntity > &entities, ScenarioInterface *scenario, const openScenario::ActorInformation &actorInformation, const std::vector< std::string > &nameStack, const int numberOfExecutions, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportMembers(const QDomElement &membersElement, std::list< std::string > &members, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportOrientation(QDomElement &orientationElement, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportPrivateElement(QDomElement &privateElement, std::vector< ScenarioEntity > &entities, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportPrivateElements(QDomElement &actionsElement, std::vector< ScenarioEntity > &entities, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportRoadNetwork(QDomElement &roadNetworkElement, std::string &sceneryPath, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportSelectionElements(QDomElement &entitiesElement, std::map< std::string, std::list< std::string >> &groups, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportStoryboard(QDomElement &documentRoot, std::vector< ScenarioEntity > &entities, ScenarioInterface *scenario, openScenario::Parameters &parameters) | ScenarioImporter | static
ImportStoryElement(QDomElement &storyElement, const std::vector< ScenarioEntity > &entities, ScenarioInterface *scenario, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ImportWorldPosition(QDomElement positionElement, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ParseConditionAttributes(const QDomElement &conditionElement, std::string &name, double &delay, std::string &edge, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
ParseSimulationTime(const QDomElement &byValueElement, double &value, std::string &rule, openScenario::Parameters &parameters) | ScenarioImporter | privatestatic
supportedScenarioVersion | ScenarioImporter | privatestatic
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Importer
  • SceneryImporter
SceneryImporter Member List

This is the complete list of members for SceneryImporter, including all inherited members.

AddParsedObjectsToRoad(std::list< RoadObjectSpecification > parsedObjects, RoadInterface *road) | SceneryImporter | static
ApplyRepeat(ObjectRepeat objectRepeat, RoadObjectSpecification object, std::list< RoadObjectSpecification > &objectRepitions) | SceneryImporter | static
checkRoadSignalBoundaries(RoadSignalSpecification signal) | SceneryImporter | privatestatic
Import(const std::string &filename, Scenery *scenery) | SceneryImporter | static
ParseElementValidity(const QDomElement &rootElement, RoadElementValidity &validity) | SceneryImporter | static
ParseElevationProfile(QDomElement &roadElement, RoadInterface *road) | SceneryImporter | privatestatic
ParseGeometries(QDomElement &roadElement, RoadInterface *road) | SceneryImporter | privatestatic
ParseJunctionConnectionLinks(QDomElement &connectionElement, ConnectionInterface *connection) | SceneryImporter | static
ParseJunctionConnections(QDomElement &junctionElement, JunctionInterface *junction) | SceneryImporter | static
ParseJunctionPriorities(QDomElement &junctionElement, JunctionInterface *junction) | SceneryImporter | static
ParseJunctions(QDomElement &documentRoot, Scenery *scenery) | SceneryImporter | static
ParseLaneRoadMark(std::string leftCenterRight, QDomElement &roadLaneElement, RoadLaneInterface *roadLane) | SceneryImporter | privatestatic
ParseLanes(QDomElement &rootElement, RoadLaneSectionInterface *laneSection) | SceneryImporter | privatestatic
ParseObject(QDomElement &objectElement, RoadInterface *road) | SceneryImporter | static
ParseObjectRepeat(QDomElement &objectElement, const RoadObjectSpecification &object) | SceneryImporter | static
ParseObjects(QDomElement &roadElement, RoadInterface *road) | SceneryImporter | static
ParseOptionalInterval(QDomElement &repeatElement, std::string startAttribute, std::string endAttribute, OptionalInterval &interval) | SceneryImporter | static
ParseRepeat(QDomElement &repeatElement, RoadObjectSpecification object, std::list< RoadObjectSpecification > &objectRepitions) | SceneryImporter | static
ParseRoadLanes(QDomElement &roadElement, RoadInterface *road) | SceneryImporter | privatestatic
ParseRoadLinks(QDomElement &roadElement, RoadInterface *road) | SceneryImporter | privatestatic
ParseRoads(QDomElement &documentRoot, Scenery *scenery) | SceneryImporter | static
ParseRoadTypes(QDomElement &roadElement, RoadInterface *road) | SceneryImporter | static
ParseSignals(QDomElement &roadElement, RoadInterface *road) | SceneryImporter | static
ParseSignalUnit(std::string element, RoadSignalUnit &signalUnit) | SceneryImporter | privatestatic
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Importer
  • SlaveConfigImporter
SlaveConfigImporter Member List

This is the complete list of members for SlaveConfigImporter, including all inherited members.

defaultLibraryMapping | SlaveConfigImporter | inlineprivatestatic
Import(const std::string &configurationDir, const std::string &slaveConfigFile, Configuration::SlaveConfig &slaveConfig) | SlaveConfigImporter | static
ImportEnvironment(QDomElement environmentElement, EnvironmentConfig &environmentConfig) | SlaveConfigImporter | static
ImportExperiment(QDomElement experimentElement, ExperimentConfig &experimentConfig) | SlaveConfigImporter | static
ImportLibraries(QDomElement rootElement) | SlaveConfigImporter | static
ImportScenario(QDomElement scenarioElement, const std::string configurationDir, ScenarioConfig &scenarioConfig) | SlaveConfigImporter | static
ImportSpawners(const QDomElement &spawnersElement, SpawnPointLibraryInfoCollection &spawnPointsInfo) | SlaveConfigImporter | static
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Importer
  • SystemConfigImporter
SystemConfigImporter Member List

This is the complete list of members for SystemConfigImporter, including all inherited members.

Import(const std::string &filename, std::shared_ptr< SystemConfig > systemConfig) | SystemConfigImporter | static
ImportSystemParameters(QDomElement &parametersElement) | SystemConfigImporter | static
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Importer
  • VehicleModelsImporter
VehicleModelsImporter Member List

This is the complete list of members for VehicleModelsImporter, including all inherited members.

AssignProperty(const std::string &propertyName, openScenario::ParameterizedAttribute< T > &attribute, const Properties &properties, std::optional< typename TypeHelper< T >::type > defaultValue=std::nullopt) | VehicleModelsImporter | inlineprivatestatic
CheckModelParameters(const ParametrizedVehicleModelParameters &model) | VehicleModelsImporter | privatestatic
Import(const std::string &vehicleModelsPath, const std::string &pedestrianModelsPath, Configuration::VehicleModels &vehicleModels) | VehicleModelsImporter | static
ImportCatalog(const std::string &catalogPath, QDomElement &catalogElement) | VehicleModelsImporter | privatestatic
ImportModelBoundingBox(QDomElement &modelElement, ParametrizedVehicleModelParameters &modelParameters, openScenario::Parameters &parameters) | VehicleModelsImporter | privatestatic
ImportPedestrianCatalog(QDomElement &catalogElement, Configuration::VehicleModels &vehicleModels) | VehicleModelsImporter | privatestatic
ImportPedestrianModel(QDomElement &pedestrianElement, VehicleModelMap &vehicleModelsMap) | VehicleModelsImporter | static
ImportProperties(QDomElement &root) | VehicleModelsImporter | privatestatic
ImportVehicleCatalog(QDomElement &catalogElement, Configuration::VehicleModels &vehicleModels) | VehicleModelsImporter | privatestatic
ImportVehicleModel(QDomElement &modelElement, VehicleModelMap &vehicleModelsMap) | VehicleModelsImporter | static
ImportVehicleModelAxle(QDomElement &axleElement, VehicleAxle &axleParameters, openScenario::Parameters &parameters) | VehicleModelsImporter | privatestatic
ImportVehicleModelAxles(QDomElement &vehicleElement, ParametrizedVehicleModelParameters &modelParameters, openScenario::Parameters &parameters) | VehicleModelsImporter | privatestatic
ImportVehicleModelGears(ParametrizedVehicleModelParameters &modelParameters, const Properties &properties) | VehicleModelsImporter | privatestatic
ImportVehicleModelPerformance(QDomElement &vehicleElement, ParametrizedVehicleModelParameters &modelParameters, openScenario::Parameters &parameters) | VehicleModelsImporter | privatestatic
ValidateAxles(const VehicleAxle &frontAxle, const VehicleAxle &rearAxle) | VehicleModelsImporter | privatestatic
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

InputPort< SignalType, ValueType > Member List

This is the complete list of members for InputPort< SignalType, ValueType >, including all inherited members.

ComponentPort(int id, std::map< int, ComponentPort * > *portMap) | ComponentPort | inline
GetId() | ComponentPort | inline
GetSignalValue(std::shared_ptr< SignalInterface const > &data) | ComponentPort | inlinevirtual
GetValue() | InputPort< SignalType, ValueType > | inline
InputPort(int id, std::map< int, ComponentPort * > *portMap) | InputPort< SignalType, ValueType > | inline
value | InputPort< SignalType, ValueType > | private
~ComponentPort()=default | ComponentPort | virtual
~InputPort()=default | InputPort< SignalType, ValueType > | virtual
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

IntSignal Member List

This is the complete list of members for IntSignal, including all inherited members.

operator std::string() const | IntSignal | inlinevirtual
value | IntSignal |
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

JointsBuilder Member List

This is the complete list of members for JointsBuilder, including all inherited members.

CalculateCurvatures() | JointsBuilder |
CalculateHeadings() | JointsBuilder |
CalculatePoints() | JointsBuilder |
GetJoints() | JointsBuilder |
joints | JointsBuilder | private
JointsBuilder(const SampledGeometry &sampledGeometry, const Joints &joints) | JointsBuilder | inline
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Junction Member List

This is the complete list of members for Junction, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

LaneChangeManipulator Member List

This is the complete list of members for LaneChangeManipulator, including all inherited members.

GetCycleTime() | ManipulatorCommonBase | virtual
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | ManipulatorCommonBase | protected
Trigger(int time) override | LaneChangeManipulator | virtual
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

LateralSignal Member List

This is the complete list of members for LateralSignal, including all inherited members.

LateralSignal() | LateralSignal | inline
LateralSignal(ComponentState componentState, double laneWidth, double lateralDeviation, double gainLateralDeviation, double headingError, double gainHeadingError, double kappaManoeuvre, double kappaRoad, std::vector< double > curvatureOfSegmentsToNearPoint, std::vector< double > curvatureOfSegmentsToFarPoint) | LateralSignal | inline
LateralSignal(LateralSignal &other) | LateralSignal | inline
LateralSignal(ComponentState componentState, double laneWidth, double lateralDeviation, double gainLateralDeviation, double headingError, double gainHeadingError, double kappaManoeuvre) | LateralSignal | inline
operator std::string() const | LateralSignal | inlinevirtual
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

LimiterAccelerationVehicleComponentsImplementation Member List

This is the complete list of members for LimiterAccelerationVehicleComponentsImplementation, including all inherited members.

Trigger(int time) | LimiterAccelerationVehicleComponentsImplementation | virtual
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | LimiterAccelerationVehicleComponentsImplementation | virtual
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | LimiterAccelerationVehicleComponentsImplementation | virtual
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Log< T > Member List

This is the complete list of members for Log< T >, including all inherited members.

Get(const char *file, int line, LogLevel level=LogLevel::Warning) | Log< T > |
logGuard | Log< T > | privatestatic
os | Log< T > | protected
ReportingLevel() | Log< T > | static
ToString(LogLevel level) | Log< T > | static
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

LogOutputPolicy Member List

This is the complete list of members for LogOutputPolicy, including all inherited members.

IsOpen() | LogOutputPolicy | inlinestatic
Output(const std::string &message) | LogOutputPolicy | inlinestatic
SetFile(const std::string &fileName) | LogOutputPolicy | inlinestatic
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

LongitudinalSignal Member List

This is the complete list of members for LongitudinalSignal, including all inherited members.

operator std::string() const LongitudinalSignal inlinevirtual
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ManipulatorCommonBase Member List

This is the complete list of members for ManipulatorCommonBase, including all inherited members.

GetCycleTime() | ManipulatorCommonBase | virtual
GetEvents()=0 | ManipulatorCommonBase | protectedpure virtual
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | ManipulatorCommonBase | protected
Trigger(int time)=0 | ManipulatorCommonBase | pure virtual
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

MultiStream< T > Member List

This is the complete list of members for MultiStream< T >, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

NoOperationManipulator Member List

This is the complete list of members for NoOperationManipulator, including all inherited members.

GetCycleTime() | ManipulatorCommonBase | virtual
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | ManipulatorCommonBase | protected
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Fakes
  • Junction
Junction Member List

This is the complete list of members for Junction, including all inherited members.

AddConnectingRoad(const Interfaces::Road *connectingRoad)=0 | Junction | pure virtual
AddIntersectionInfo(const std::string &roadId, const IntersectionInfo &intersectionInfo)=0 | Junction | pure virtual
AddPriority(const std::string &high, const std::string &low)=0 | Junction | pure virtual
GetConnectingRoads() const =0 | Junction | pure virtual
GetId() const =0 | Junction | pure virtual
GetIntersections() const =0 | Junction | pure virtual
GetPriorities() const =0 | Junction | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Fakes
  • Lane
Lane Member List

This is the complete list of members for Lane, including all inherited members.

AddLaneGeometryJoint(const Common::Vector2d &pointLeft, const Common::Vector2d &pointCenter, const Common::Vector2d &pointRight, double sOffset, double curvature, double heading)=0 | Lane | pure virtual
AddMovingObject(OWL::Interfaces::MovingObject &movingObject)=0 | Lane | pure virtual
AddNext(const Lane *lane)=0 | Lane | pure virtual
AddPrevious(const Lane *lane)=0 | Lane | pure virtual
AddRoadMarking(Interfaces::RoadMarking &roadMarking)=0 | Lane | pure virtual
AddStationaryObject(OWL::Interfaces::StationaryObject &stationaryObject)=0 | Lane | pure virtual
AddTrafficSign(Interfaces::TrafficSign &trafficSign)=0 | Lane | pure virtual
AddWorldObject(Interfaces::WorldObject &worldObject)=0 | Lane | pure virtual
ClearMovingObjects()=0 | Lane | pure virtual
CopyToGroundTruth(osi3::GroundTruth &target) const =0 | Lane | pure virtual
Covers(double distance) const =0 | Lane | pure virtual
Exists() const =0 | Lane | pure virtual
GetCurvature(double distance) const =0 | Lane | pure virtual
GetDirection(double distance) const =0 | Lane | pure virtual
GetDistance(MeasurementPoint measurementPoint) const =0 | Lane | pure virtual
GetId() const =0 | Lane | pure virtual
GetInterpolatedPointsAtDistance(double distance) const =0 | Lane | pure virtual
GetLaneGeometryElements() const =0 | Lane | pure virtual
GetLaneType() const =0 | Lane | pure virtual
GetLeftLane() const =0 | Lane | pure virtual
GetLeftLaneBoundaries() const =0 | Lane | pure virtual
GetLength() const =0 | Lane | pure virtual
GetNext() const =0 | Lane | pure virtual
GetPrevious() const =0 | Lane | pure virtual
GetRightLane() const =0 | Lane | pure virtual
GetRightLaneBoundaries() const =0 | Lane | pure virtual
GetRightLaneCount() const =0 | Lane | pure virtual
GetRoad() const =0 | Lane | pure virtual
GetRoadMarkings() const =0 | Lane | pure virtual
GetSection() const =0 | Lane | pure virtual
GetTrafficSigns() const =0 | Lane | pure virtual
GetWidth(double distance) const =0 | Lane | pure virtual
GetWorldObjects() const =0 | Lane | pure virtual
SetLaneType(LaneType specifiedType)=0 | Lane | pure virtual
SetLeftLane(const Interfaces::Lane &lane)=0 | Lane | pure virtual
SetLeftLaneBoundaries(const std::vector< OWL::Id > laneBoundaries)=0 | Lane | pure virtual
SetRightLane(const Interfaces::Lane &lane)=0 | Lane | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Fakes
  • LaneBoundary
LaneBoundary Member List

This is the complete list of members for LaneBoundary, including all inherited members.

AddBoundaryPoint(const Common::Vector2d &point, double heading)=0 | LaneBoundary | pure virtual
CopyToGroundTruth(osi3::GroundTruth &target) const =0 | LaneBoundary | pure virtual
GetColor() const =0 | LaneBoundary | pure virtual
GetId() const =0 | LaneBoundary | pure virtual
GetSEnd() const =0 | LaneBoundary | pure virtual
GetSide() const =0 | LaneBoundary | pure virtual
GetSStart() const =0 | LaneBoundary | pure virtual
GetType() const =0 | LaneBoundary | pure virtual
GetWidth() const =0 | LaneBoundary | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Fakes
  • MovingObject
MovingObject Member List

This is the complete list of members for MovingObject, including all inherited members.

As() const | WorldObject | inline
As() | WorldObject | inline
CopyToGroundTruth(osi3::GroundTruth &target) const =0 | WorldObject | pure virtual
GetAbsAccelerationDouble() const =0 | WorldObject | pure virtual
GetAbsOrientation() const =0 | WorldObject | pure virtual
GetAbsVelocityDouble() const =0 | WorldObject | pure virtual
GetDimension() const =0 | WorldObject | pure virtual
GetId() const =0 | WorldObject | pure virtual
GetLink() | WorldObject | inline
GetLink() const | WorldObject | inline
GetReferencePointPosition() const =0 | WorldObject | pure virtual
Is() const | WorldObject | inline
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Fakes
  • Road
Road Member List

This is the complete list of members for Road, including all inherited members.

AddSection(Interfaces::Section &section)=0 | Road | pure virtual
GetDistance(MeasurementPoint mp) const =0 | Road | pure virtual
GetId() const =0 | Road | pure virtual
GetLength() const =0 | Road | pure virtual
GetPredecessor() const =0 | Road | pure virtual
GetSections() const =0 | Road | pure virtual
GetSuccessor() const =0 | Road | pure virtual
IsInStreamDirection() const =0 | Road | pure virtual
SetPredecessor(const std::string &predecessor)=0 | Road | pure virtual
SetSuccessor(const std::string &successor)=0 | Road | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Fakes
  • RoadMarking
RoadMarking Member List

This is the complete list of members for RoadMarking, including all inherited members.

CopyToGroundTruth(osi3::GroundTruth &target) const =0 | RoadMarking | pure virtual
GetId() const =0 | RoadMarking | pure virtual
GetReferencePointPosition() const =0 | RoadMarking | pure virtual
GetS() const =0 | RoadMarking | pure virtual
GetSpecification(const double relativeDistance) const =0 | RoadMarking | pure virtual
IsValidForLane(OWL::Id laneId) const =0 | RoadMarking | pure virtual
SetS(double sPos)=0 | RoadMarking | pure virtual
SetSpecification(RoadSignalInterface *signal, Position position)=0 | RoadMarking | pure virtual
SetValidForLane(OWL::Id laneId)=0 | RoadMarking | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Fakes
  • Section
Section Member List

This is the complete list of members for Section, including all inherited members.

AddLane(const Interfaces::Lane &lane)=0 | Section | pure virtual
AddNext(const Interfaces::Section &section)=0 | Section | pure virtual
AddPrevious(const Interfaces::Section &section)=0 | Section | pure virtual
Covers(double distance) const =0 | Section | pure virtual
CoversInterval(double startDistance, double endDistance) const =0 | Section | pure virtual
GetCenterLaneBoundary() const =0 | Section | pure virtual
GetDistance(MeasurementPoint measurementPoint) const =0 | Section | pure virtual
GetLanes() const =0 | Section | pure virtual
GetLength() const =0 | Section | pure virtual
GetRoad() const =0 | Section | pure virtual
GetSOffset() const =0 | Section | pure virtual
SetCenterLaneBoundary(std::vector< Id > laneBoundaryId)=0 | Section | pure virtual
SetRoad(Interfaces::Road *road)=0 | Section | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Fakes
  • StationaryObject
StationaryObject Member List

This is the complete list of members for StationaryObject, including all inherited members.

AddLaneAssignment(const Interfaces::Lane &lane)=0 | WorldObject | pure virtual
As() const | WorldObject | inline
As() | WorldObject | inline
ClearLaneAssignments()=0 | WorldObject | pure virtual
CopyToGroundTruth(osi3::GroundTruth &target) const =0 | WorldObject | pure virtual
GetAbsAccelerationDouble() const =0 | WorldObject | pure virtual
GetAbsOrientation() const =0 | WorldObject | pure virtual
GetAbsVelocityDouble() const =0 | WorldObject | pure virtual
GetDimension() const =0 | WorldObject | pure virtual
GetId() const =0 | WorldObject | pure virtual
GetLaneAssignments() const =0 | WorldObject | pure virtual
GetLink() | WorldObject | inline
GetLink() const | WorldObject | inline
GetReferencePointPosition() const =0 | WorldObject | pure virtual
Is() const | WorldObject | inline
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Fakes
  • TrafficSign
TrafficSign Member List

This is the complete list of members for TrafficSign, including all inherited members.

AddSupplementarySign(RoadSignalInterface *odSignal, Position position)=0 | TrafficSign | pure virtual
CopyToGroundTruth(osi3::GroundTruth &target) const =0 | TrafficSign | pure virtual
GetId() const =0 | TrafficSign | pure virtual
GetReferencePointPosition() const =0 | TrafficSign | pure virtual
GetS() const =0 | TrafficSign | pure virtual
GetSpecification(const double relativeDistance) const =0 | TrafficSign | pure virtual
GetValueAndUnitInSI(const double osiValue, const osi3::TrafficSignValue_Unit osiUnit) const =0 | TrafficSign | pure virtual
IsValidForLane(OWL::Id laneId) const =0 | TrafficSign | pure virtual
SetS(double sPos)=0 | TrafficSign | pure virtual
SetSpecification(RoadSignalInterface *signal, Position position)=0 | TrafficSign | pure virtual
SetValidForLane(OWL::Id laneId)=0 | TrafficSign | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Fakes
  • WorldData
WorldData Member List

This is the complete list of members for WorldData, including all inherited members.

AddCenterLinePoint(const RoadLaneSectionInterface &odSection, const Common::Vector2d &pointCenter, const double sOffset, double heading)=0 | WorldData | pure virtual
AddJunction(const JunctionInterface *odJunction)=0 | WorldData | pure virtual
AddJunctionConnection(const JunctionInterface *odJunction, const RoadInterface &odRoad)=0 | WorldData | pure virtual
AddJunctionPriority(const JunctionInterface *odJunction, const std::string &high, const std::string &low)=0 | WorldData | pure virtual
AddLane(RoadLaneSectionInterface &odSection, const RoadLaneInterface &odLane, const std::vector< Id > laneBoundaries)=0 | WorldData | pure virtual
AddLaneBoundary(const RoadLaneRoadMark &odLaneRoadMark, double sectionStart, LaneMarkingSide side)=0 | WorldData | pure virtual
AddLaneGeometryPoint(const RoadLaneInterface &odLane, const Common::Vector2d &pointLeft, const Common::Vector2d &pointCenter, const Common::Vector2d &pointRight, const double sOffset, const double curvature, const double heading)=0 | WorldData | pure virtual
AddLanePredecessor(RoadLaneInterface &odLane, RoadLaneInterface &predecessorOdLane)=0 | WorldData | pure virtual
AddLaneSuccessor(RoadLaneInterface &odLane, RoadLaneInterface &successorOdLane)=0 | WorldData | pure virtual
AddMovingObject(void *linkedObject)=0 | WorldData | pure virtual
AddRoad(const RoadInterface &odRoad)=0 | WorldData | pure virtual
AddRoadMarking()=0 | WorldData | pure virtual
AddSection(const RoadInterface &odRoad, const RoadLaneSectionInterface &odSection)=0 | WorldData | pure virtual
AddStationaryObject(void *linkedObject)=0 | WorldData | pure virtual
AddTrafficSign(const std::string odId)=0 | WorldData | pure virtual
AssignRoadMarkingToLane(OWL::Id laneId, Interfaces::RoadMarking &roadMarking)=0 | WorldData | pure virtual
AssignTrafficSignToLane(OWL::Id laneId, Interfaces::TrafficSign &trafficSign)=0 | WorldData | pure virtual
Clear()=0 | WorldData | pure virtual
ConnectLanes(RoadLaneSectionInterface &firstOdSection, RoadLaneSectionInterface &secondOdSection, const std::map< int, int > &lanePairs, bool isPrev)=0 | WorldData | pure virtual
GetAgentId(const OWL::Id owlId) const =0 | WorldData | pure virtual
GetJunctions() const =0 | WorldData | pure virtual
GetLaneBoundaries() const =0 | WorldData | pure virtual
GetLaneIdMapping() const =0 | WorldData | pure virtual
GetLanes() const =0 | WorldData | pure virtual
GetOwlId(int agentId)=0 | WorldData | pure virtual
GetRoadGraph() const =0 | WorldData | pure virtual
GetRoadGraphVertexMapping() const =0 | WorldData | pure virtual
GetRoadMarkings() const =0 | WorldData | pure virtual
GetRoads() const =0 | WorldData | pure virtual
GetSensorView(osi3::SensorViewConfiguration &conf, int agentId)=0 | WorldData | pure virtual
GetTrafficSignIdMapping() const =0 | WorldData | pure virtual
GetTrafficSigns() const =0 | WorldData | pure virtual
RemoveMovingObjectById(Id id)=0 | WorldData | pure virtual
Reset()=0 | WorldData | pure virtual
SetCenterLaneBoundary(const RoadLaneSectionInterface &odSection, std::vector< Id > laneBoundaryIds)=0 | WorldData | pure virtual
SetRoadGraph(const RoadGraph &&roadGraph, const RoadGraphVertexMapping &&vertexMapping)=0 | WorldData | pure virtual
SetRoadPredecessor(const RoadInterface &road, const RoadInterface &predecessorRoad)=0 | WorldData | pure virtual
SetRoadPredecessorJunction(const RoadInterface &road, const JunctionInterface *predecessorJunction)=0 | WorldData | pure virtual
SetRoadSuccessor(const RoadInterface &road, const RoadInterface &successorRoad)=0 | WorldData | pure virtual
SetRoadSuccessorJunction(const RoadInterface &road, const JunctionInterface *successorJunction)=0 | WorldData | pure virtual
SetSectionPredecessor(const RoadLaneSectionInterface &section, const RoadLaneSectionInterface &predecessorSection)=0 | WorldData | pure virtual
SetSectionSuccessor(const RoadLaneSectionInterface &section, const RoadLaneSectionInterface &successorSection)=0 | WorldData | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Implementation
  • InvalidLane
InvalidLane Member List

This is the complete list of members for InvalidLane, including all inherited members.

Lane(osi3::Lane *osiLane, const Interfaces::Section *section) Lane
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Implementation
  • InvalidRoad
InvalidRoad Member List

This is the complete list of members for InvalidRoad, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Implementation
  • InvalidSection
InvalidSection Member List

This is the complete list of members for InvalidSection, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Implementation
  • Junction
Junction Member List

This is the complete list of members for Junction, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Implementation
  • Lane
Lane Member List

This is the complete list of members for Lane, including all inherited members.

Lane(osi3::Lane *osiLane, const Interfaces::Section *section) Lane
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Implementation
  • LaneBoundary
LaneBoundary Member List

This is the complete list of members for LaneBoundary, including all inherited members.

sEnd | LaneBoundary | private
side | LaneBoundary | private
sStart | LaneBoundary | private
width | LaneBoundary | private
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Implementation
  • MovingObject
MovingObject Member List

This is the complete list of members for MovingObject, including all inherited members.

As() const | WorldObject | inline
As() | WorldObject | inline
GetLink() | WorldObject | inline
GetLink() const | WorldObject | inline
Is() const | WorldObject | inline
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Implementation
  • Road
Road Member List

This is the complete list of members for Road, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Implementation
  • RoadMarking
RoadMarking Member List

This is the complete list of members for RoadMarking, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Implementation
  • Section
Section Member List

This is the complete list of members for Section, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Implementation
  • StationaryObject
StationaryObject Member List

This is the complete list of members for StationaryObject, including all inherited members.

As() const | WorldObject | inline
As() | WorldObject | inline
GetLink() | WorldObject | inline
GetLink() const | WorldObject | inline
Is() const | WorldObject | inline
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Implementation
  • TrafficSign
TrafficSign Member List

This is the complete list of members for TrafficSign, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Implementation
  • Vehicle
Vehicle Member List

This is the complete list of members for Vehicle, including all inherited members.

As() const | WorldObject | inline
As() | WorldObject | inline
GetLink() | WorldObject | inline
GetLink() const | WorldObject | inline
Is() const | WorldObject | inline
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Interfaces
  • Junction
Junction Member List

This is the complete list of members for Junction, including all inherited members.

AddConnectingRoad(const Interfaces::Road *connectingRoad)=0 | Junction | pure virtual
AddIntersectionInfo(const std::string &roadId, const IntersectionInfo &intersectionInfo)=0 | Junction | pure virtual
AddPriority(const std::string &high, const std::string &low)=0 | Junction | pure virtual
GetConnectingRoads() const =0 | Junction | pure virtual
GetId() const =0 | Junction | pure virtual
GetIntersections() const =0 | Junction | pure virtual
GetPriorities() const =0 | Junction | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Interfaces
  • Lane
Lane Member List

This is the complete list of members for Lane, including all inherited members.

AddLaneGeometryJoint(const Common::Vector2d &pointLeft, const Common::Vector2d &pointCenter, const Common::Vector2d &pointRight, double sOffset, double curvature, double heading)=0 | Lane | pure virtual
AddMovingObject(OWL::Interfaces::MovingObject &movingObject)=0 | Lane | pure virtual
AddNext(const Lane *lane)=0 | Lane | pure virtual
AddPrevious(const Lane *lane)=0 | Lane | pure virtual
AddRoadMarking(Interfaces::RoadMarking &roadMarking)=0 | Lane | pure virtual
AddStationaryObject(OWL::Interfaces::StationaryObject &stationaryObject)=0 | Lane | pure virtual
AddTrafficSign(Interfaces::TrafficSign &trafficSign)=0 | Lane | pure virtual
AddWorldObject(Interfaces::WorldObject &worldObject)=0 | Lane | pure virtual
ClearMovingObjects()=0 | Lane | pure virtual
CopyToGroundTruth(osi3::GroundTruth &target) const =0 | Lane | pure virtual
Covers(double distance) const =0 | Lane | pure virtual
Exists() const =0 | Lane | pure virtual
GetCurvature(double distance) const =0 | Lane | pure virtual
GetDirection(double distance) const =0 | Lane | pure virtual
GetDistance(MeasurementPoint measurementPoint) const =0 | Lane | pure virtual
GetId() const =0 | Lane | pure virtual
GetInterpolatedPointsAtDistance(double distance) const =0 | Lane | pure virtual
GetLaneGeometryElements() const =0 | Lane | pure virtual
GetLaneType() const =0 | Lane | pure virtual
GetLeftLane() const =0 | Lane | pure virtual
GetLeftLaneBoundaries() const =0 | Lane | pure virtual
GetLength() const =0 | Lane | pure virtual
GetNext() const =0 | Lane | pure virtual
GetPrevious() const =0 | Lane | pure virtual
GetRightLane() const =0 | Lane | pure virtual
GetRightLaneBoundaries() const =0 | Lane | pure virtual
GetRightLaneCount() const =0 | Lane | pure virtual
GetRoad() const =0 | Lane | pure virtual
GetRoadMarkings() const =0 | Lane | pure virtual
GetSection() const =0 | Lane | pure virtual
GetTrafficSigns() const =0 | Lane | pure virtual
GetWidth(double distance) const =0 | Lane | pure virtual
GetWorldObjects() const =0 | Lane | pure virtual
SetLaneType(LaneType specifiedType)=0 | Lane | pure virtual
SetLeftLane(const Interfaces::Lane &lane)=0 | Lane | pure virtual
SetLeftLaneBoundaries(const std::vector< OWL::Id > laneBoundaries)=0 | Lane | pure virtual
SetRightLane(const Interfaces::Lane &lane)=0 | Lane | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Interfaces
  • LaneBoundary
LaneBoundary Member List

This is the complete list of members for LaneBoundary, including all inherited members.

AddBoundaryPoint(const Common::Vector2d &point, double heading)=0 | LaneBoundary | pure virtual
CopyToGroundTruth(osi3::GroundTruth &target) const =0 | LaneBoundary | pure virtual
GetColor() const =0 | LaneBoundary | pure virtual
GetId() const =0 | LaneBoundary | pure virtual
GetSEnd() const =0 | LaneBoundary | pure virtual
GetSide() const =0 | LaneBoundary | pure virtual
GetSStart() const =0 | LaneBoundary | pure virtual
GetType() const =0 | LaneBoundary | pure virtual
GetWidth() const =0 | LaneBoundary | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Interfaces
  • MovingObject
MovingObject Member List

This is the complete list of members for MovingObject, including all inherited members.

As() const | WorldObject | inline
As() | WorldObject | inline
CopyToGroundTruth(osi3::GroundTruth &target) const =0 | WorldObject | pure virtual
GetAbsAccelerationDouble() const =0 | WorldObject | pure virtual
GetAbsOrientation() const =0 | WorldObject | pure virtual
GetAbsVelocityDouble() const =0 | WorldObject | pure virtual
GetDimension() const =0 | WorldObject | pure virtual
GetId() const =0 | WorldObject | pure virtual
GetLink() | WorldObject | inline
GetLink() const | WorldObject | inline
GetReferencePointPosition() const =0 | WorldObject | pure virtual
Is() const | WorldObject | inline
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Interfaces
  • Road
Road Member List

This is the complete list of members for Road, including all inherited members.

AddSection(Interfaces::Section &section)=0 | Road | pure virtual
GetDistance(MeasurementPoint mp) const =0 | Road | pure virtual
GetId() const =0 | Road | pure virtual
GetLength() const =0 | Road | pure virtual
GetPredecessor() const =0 | Road | pure virtual
GetSections() const =0 | Road | pure virtual
GetSuccessor() const =0 | Road | pure virtual
IsInStreamDirection() const =0 | Road | pure virtual
SetPredecessor(const std::string &predecessor)=0 | Road | pure virtual
SetSuccessor(const std::string &successor)=0 | Road | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Interfaces
  • RoadMarking
RoadMarking Member List

This is the complete list of members for RoadMarking, including all inherited members.

CopyToGroundTruth(osi3::GroundTruth &target) const =0 | RoadMarking | pure virtual
GetId() const =0 | RoadMarking | pure virtual
GetReferencePointPosition() const =0 | RoadMarking | pure virtual
GetS() const =0 | RoadMarking | pure virtual
GetSpecification(const double relativeDistance) const =0 | RoadMarking | pure virtual
IsValidForLane(OWL::Id laneId) const =0 | RoadMarking | pure virtual
SetS(double sPos)=0 | RoadMarking | pure virtual
SetSpecification(RoadSignalInterface *signal, Position position)=0 | RoadMarking | pure virtual
SetValidForLane(OWL::Id laneId)=0 | RoadMarking | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Interfaces
  • Section
Section Member List

This is the complete list of members for Section, including all inherited members.

AddLane(const Interfaces::Lane &lane)=0 | Section | pure virtual
AddNext(const Interfaces::Section &section)=0 | Section | pure virtual
AddPrevious(const Interfaces::Section &section)=0 | Section | pure virtual
Covers(double distance) const =0 | Section | pure virtual
CoversInterval(double startDistance, double endDistance) const =0 | Section | pure virtual
GetCenterLaneBoundary() const =0 | Section | pure virtual
GetDistance(MeasurementPoint measurementPoint) const =0 | Section | pure virtual
GetLanes() const =0 | Section | pure virtual
GetLength() const =0 | Section | pure virtual
GetRoad() const =0 | Section | pure virtual
GetSOffset() const =0 | Section | pure virtual
SetCenterLaneBoundary(std::vector< Id > laneBoundaryId)=0 | Section | pure virtual
SetRoad(Interfaces::Road *road)=0 | Section | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Interfaces
  • StationaryObject
StationaryObject Member List

This is the complete list of members for StationaryObject, including all inherited members.

AddLaneAssignment(const Interfaces::Lane &lane)=0 | WorldObject | pure virtual
As() const | WorldObject | inline
As() | WorldObject | inline
ClearLaneAssignments()=0 | WorldObject | pure virtual
CopyToGroundTruth(osi3::GroundTruth &target) const =0 | WorldObject | pure virtual
GetAbsAccelerationDouble() const =0 | WorldObject | pure virtual
GetAbsOrientation() const =0 | WorldObject | pure virtual
GetAbsVelocityDouble() const =0 | WorldObject | pure virtual
GetDimension() const =0 | WorldObject | pure virtual
GetId() const =0 | WorldObject | pure virtual
GetLaneAssignments() const =0 | WorldObject | pure virtual
GetLink() | WorldObject | inline
GetLink() const | WorldObject | inline
GetReferencePointPosition() const =0 | WorldObject | pure virtual
Is() const | WorldObject | inline
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Interfaces
  • TrafficSign
TrafficSign Member List

This is the complete list of members for TrafficSign, including all inherited members.

AddSupplementarySign(RoadSignalInterface *odSignal, Position position)=0 | TrafficSign | pure virtual
CopyToGroundTruth(osi3::GroundTruth &target) const =0 | TrafficSign | pure virtual
GetId() const =0 | TrafficSign | pure virtual
GetReferencePointPosition() const =0 | TrafficSign | pure virtual
GetS() const =0 | TrafficSign | pure virtual
GetSpecification(const double relativeDistance) const =0 | TrafficSign | pure virtual
GetValueAndUnitInSI(const double osiValue, const osi3::TrafficSignValue_Unit osiUnit) const =0 | TrafficSign | pure virtual
IsValidForLane(OWL::Id laneId) const =0 | TrafficSign | pure virtual
SetS(double sPos)=0 | TrafficSign | pure virtual
SetSpecification(RoadSignalInterface *signal, Position position)=0 | TrafficSign | pure virtual
SetValidForLane(OWL::Id laneId)=0 | TrafficSign | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Interfaces
  • WorldData
WorldData Member List

This is the complete list of members for WorldData, including all inherited members.

AddCenterLinePoint(const RoadLaneSectionInterface &odSection, const Common::Vector2d &pointCenter, const double sOffset, double heading)=0 | WorldData | pure virtual
AddJunction(const JunctionInterface *odJunction)=0 | WorldData | pure virtual
AddJunctionConnection(const JunctionInterface *odJunction, const RoadInterface &odRoad)=0 | WorldData | pure virtual
AddJunctionPriority(const JunctionInterface *odJunction, const std::string &high, const std::string &low)=0 | WorldData | pure virtual
AddLane(RoadLaneSectionInterface &odSection, const RoadLaneInterface &odLane, const std::vector< Id > laneBoundaries)=0 | WorldData | pure virtual
AddLaneBoundary(const RoadLaneRoadMark &odLaneRoadMark, double sectionStart, LaneMarkingSide side)=0 | WorldData | pure virtual
AddLaneGeometryPoint(const RoadLaneInterface &odLane, const Common::Vector2d &pointLeft, const Common::Vector2d &pointCenter, const Common::Vector2d &pointRight, const double sOffset, const double curvature, const double heading)=0 | WorldData | pure virtual
AddLanePredecessor(RoadLaneInterface &odLane, RoadLaneInterface &predecessorOdLane)=0 | WorldData | pure virtual
AddLaneSuccessor(RoadLaneInterface &odLane, RoadLaneInterface &successorOdLane)=0 | WorldData | pure virtual
AddMovingObject(void *linkedObject)=0 | WorldData | pure virtual
AddRoad(const RoadInterface &odRoad)=0 | WorldData | pure virtual
AddRoadMarking()=0 | WorldData | pure virtual
AddSection(const RoadInterface &odRoad, const RoadLaneSectionInterface &odSection)=0 | WorldData | pure virtual
AddStationaryObject(void *linkedObject)=0 | WorldData | pure virtual
AddTrafficSign(const std::string odId)=0 | WorldData | pure virtual
AssignRoadMarkingToLane(OWL::Id laneId, Interfaces::RoadMarking &roadMarking)=0 | WorldData | pure virtual
AssignTrafficSignToLane(OWL::Id laneId, Interfaces::TrafficSign &trafficSign)=0 | WorldData | pure virtual
Clear()=0 | WorldData | pure virtual
ConnectLanes(RoadLaneSectionInterface &firstOdSection, RoadLaneSectionInterface &secondOdSection, const std::map< int, int > &lanePairs, bool isPrev)=0 | WorldData | pure virtual
GetAgentId(const OWL::Id owlId) const =0 | WorldData | pure virtual
GetInvalidLane() const =0 | WorldData | pure virtual
GetJunctions() const =0 | WorldData | pure virtual
GetLaneBoundaries() const =0 | WorldData | pure virtual
GetLaneIdMapping() const =0 | WorldData | pure virtual
GetLanes() const =0 | WorldData | pure virtual
GetOwlId(int agentId)=0 | WorldData | pure virtual
GetRoadGraph() const =0 | WorldData | pure virtual
GetRoadGraphVertexMapping() const =0 | WorldData | pure virtual
GetRoadMarkings() const =0 | WorldData | pure virtual
GetRoads() const =0 | WorldData | pure virtual
GetSensorView(osi3::SensorViewConfiguration &conf, int agentId)=0 | WorldData | pure virtual
GetTrafficSignIdMapping() const =0 | WorldData | pure virtual
GetTrafficSigns() const =0 | WorldData | pure virtual
RemoveMovingObjectById(Id id)=0 | WorldData | pure virtual
Reset()=0 | WorldData | pure virtual
SetCenterLaneBoundary(const RoadLaneSectionInterface &odSection, std::vector< Id > laneBoundaryIds)=0 | WorldData | pure virtual
SetRoadGraph(const RoadGraph &&roadGraph, const RoadGraphVertexMapping &&vertexMapping)=0 | WorldData | pure virtual
SetRoadPredecessor(const RoadInterface &road, const RoadInterface &predecessorRoad)=0 | WorldData | pure virtual
SetRoadPredecessorJunction(const RoadInterface &road, const JunctionInterface *predecessorJunction)=0 | WorldData | pure virtual
SetRoadSuccessor(const RoadInterface &road, const RoadInterface &successorRoad)=0 | WorldData | pure virtual
SetRoadSuccessorJunction(const RoadInterface &road, const JunctionInterface *successorJunction)=0 | WorldData | pure virtual
SetSectionPredecessor(const RoadLaneSectionInterface &section, const RoadLaneSectionInterface &predecessorSection)=0 | WorldData | pure virtual
SetSectionSuccessor(const RoadLaneSectionInterface &section, const RoadLaneSectionInterface &successorSection)=0 | WorldData | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Interfaces
  • WorldObject
WorldObject Member List

This is the complete list of members for WorldObject, including all inherited members.

AddLaneAssignment(const Interfaces::Lane &lane)=0 | WorldObject | pure virtual
As() const | WorldObject | inline
As() | WorldObject | inline
ClearLaneAssignments()=0 | WorldObject | pure virtual
CopyToGroundTruth(osi3::GroundTruth &target) const =0 | WorldObject | pure virtual
GetAbsAccelerationDouble() const =0 | WorldObject | pure virtual
GetAbsOrientation() const =0 | WorldObject | pure virtual
GetAbsVelocityDouble() const =0 | WorldObject | pure virtual
GetDimension() const =0 | WorldObject | pure virtual
GetId() const =0 | WorldObject | pure virtual
GetLaneAssignments() const =0 | WorldObject | pure virtual
GetLink() | WorldObject | inline
GetLink() const | WorldObject | inline
GetLocatedPosition() const =0 | WorldObject | pure virtual
GetReferencePointPosition() const =0 | WorldObject | pure virtual
Is() const | WorldObject | inline
SetAbsOrientation(const Primitive::AbsOrientation &newOrientation)=0 | WorldObject | pure virtual
SetDimension(const Primitive::Dimension &newDimension)=0 | WorldObject | pure virtual
SetLocatedPosition(const ObjectPosition &position)=0 | WorldObject | pure virtual
SetReferencePointPosition(const Primitive::AbsPosition &newPosition)=0 | WorldObject | pure virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • NonExistentOsiRef
NonExistentOsiRef Member List

This is the complete list of members for NonExistentOsiRef, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • WorldData
WorldData Member List

This is the complete list of members for WorldData, including all inherited members.

ApplySectorFilter(const std::vector< T * > &objects, const Primitive::AbsPosition &origin, double radius, double leftBoundaryAngle, double rightBoundaryAngle) | WorldData | inline
GetFilteredGroundTruth(const osi3::SensorViewConfiguration &conf, const Interfaces::MovingObject &reference) | WorldData |
GetMovingObjectsInSector(const Primitive::AbsPosition &origin, double radius, double absYawMin, double absYawMax) | WorldData |
GetRoadMarkingsInSector(const Primitive::AbsPosition &origin, double radius, double absYawMin, double absYawMax) | WorldData |
GetStationaryObjectsInSector(const Primitive::AbsPosition &origin, double radius, double absYawMin, double absYawMax) | WorldData |
GetTrafficSignsInSector(const Primitive::AbsPosition &origin, double radius, double absYawMin, double absYawMax) | WorldData |
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | WorldData | inlineprotected
NormalizeAngle(double angle) | WorldData |
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ObjectDetectorBase Member List

This is the complete list of members for ObjectDetectorBase, including all inherited members.

ApplyLatency(int time, osi3::SensorData currentSensorData) | ObjectDetectorBase | protected
ApplyMeasurementError(double value) | ObjectDetectorBase | protected
CalculateBoundingBox(const osi3::Dimension3d dimension, const osi3::Vector3d position, const osi3::Orientation3d orientation) | ObjectDetectorBase | protectedstatic
CalculateGlobalSensorPosition(point_t vehiclePosition, double yaw) const | ObjectDetectorBase | protected
CalculateRelativeVector(const point_t absolute, const point_t own, double yaw) | ObjectDetectorBase | protectedvirtual
GenerateSensorViewConfiguration() | ObjectDetectorBase | protectedvirtual
GetAbsolutePosition() | ObjectDetectorBase | protected
getSensorData() | ObjectDetectorBase | inline
HasDetectionError() | ObjectDetectorBase | protected
ParseBasicParameter() | ObjectDetectorBase | private
TransformPointToLocalCoordinates(point_t point, point_t sensorPositionGlobal, double yaw) | ObjectDetectorBase | protectedvirtual
TransformPolygonToGlobalCoordinates(polygon_t polygon, point_t sensorPositionGlobal, double yaw) const | ObjectDetectorBase | protected
Trigger(int time)=0 | ObjectDetectorBase | pure virtual
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time)=0 | ObjectDetectorBase | pure virtual
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | ObjectDetectorBase |
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Observation_State_Implementation Member List

This is the complete list of members for Observation_State_Implementation, including all inherited members.

channels | Observation_State_Implementation | private
MasterPostHook(const std::string &filename) | Observation_State_Implementation | inlinevirtual
MasterPreHook() | Observation_State_Implementation | inlinevirtual
Par_WriteOutputForVisualisation | Observation_State_Implementation | private
runNumber | Observation_State_Implementation | private
SlavePostHook() | Observation_State_Implementation | virtual
SlavePostRunHook(const RunResultInterface &runResult) | Observation_State_Implementation | virtual
SlavePreRunHook() | Observation_State_Implementation | virtual
SlaveResultFile() | Observation_State_Implementation | inlinevirtual
SlaveUpdateHook(int time, RunResultInterface &runResult) | Observation_State_Implementation | virtual
timeChannel | Observation_State_Implementation | private
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Observation_Ttc_Implementation Member List

This is the complete list of members for Observation_Ttc_Implementation, including all inherited members.

agentsMinTtc | Observation_Ttc_Implementation | private
agentsTtc | Observation_Ttc_Implementation | private
findFrontAgentID(int ownID) | Observation_Ttc_Implementation |
fullResultFilePath | Observation_Ttc_Implementation | private
MasterPostHook(const std::string &filename) | Observation_Ttc_Implementation | inlinevirtual
MasterPreHook() | Observation_Ttc_Implementation | inlinevirtual
Par_finalFileName | Observation_Ttc_Implementation | private
Par_resultFolderName | Observation_Ttc_Implementation | private
Par_tempFileName | Observation_Ttc_Implementation | private
runID | Observation_Ttc_Implementation | private
SlavePostHook() | Observation_Ttc_Implementation | virtual
SlavePostRunHook(const RunResultInterface &runResult) | Observation_Ttc_Implementation | virtual
SlavePreHook(const std::string &path) | Observation_Ttc_Implementation | virtual
SlavePreRunHook() | Observation_Ttc_Implementation | virtual
SlaveResultFile() | Observation_Ttc_Implementation | inlinevirtual
SlaveUpdateHook(int time, RunResultInterface &runResult) | Observation_Ttc_Implementation | virtual
timeVector | Observation_Ttc_Implementation | private
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ObservationCyclics Member List

This is the complete list of members for ObservationCyclics, including all inherited members.

Clear() | ObservationCyclics |
Clear() | ObservationCyclics |
GetAgentHeader() | ObservationCyclics |
GetAgentSamplesLine(uint32_t timeStepNumber) | ObservationCyclics |
GetHeader() | ObservationCyclics |
GetHeader() | ObservationCyclics |
GetSamplesLine(uint32_t timeStepNumber) | ObservationCyclics |
GetSamplesLine(uint32_t timeStepNumber) | ObservationCyclics |
GetTimeSteps() | ObservationCyclics | inline
GetTimeSteps() | ObservationCyclics | inline
Insert(int time, const std::string &key, const std::string &value) | ObservationCyclics |
Insert(int time, const std::string &key, const std::string &value) | ObservationCyclics |
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ObservationFileHandler Member List

This is the complete list of members for ObservationFileHandler, including all inherited members.

AddAgent(const std::string &agentId) | ObservationFileHandler | private
AddAgent(const std::string &agentId) | ObservationFileHandler | private
AddAgents() | ObservationFileHandler | private
AddAgents() | ObservationFileHandler | private
AddEvents() | ObservationFileHandler | private
AddEvents() | ObservationFileHandler | private
AddHeader(ObservationCyclics &cyclics) | ObservationFileHandler | private
AddHeader(ObservationCyclics &cyclics) | ObservationFileHandler | private
AddReference(QString filename) | ObservationFileHandler | private
AddReference(QString filename) | ObservationFileHandler | private
AddSamples(ObservationCyclics &cyclics) | ObservationFileHandler | private
AddSamples(ObservationCyclics &cyclics) | ObservationFileHandler | private
AddSensor(const std::string &agentId, const std::string &sensorId) | ObservationFileHandler | private
AddSensor(const std::string &agentId, const std::string &sensorId) | ObservationFileHandler | private
AddSensors(const std::string &agentId) | ObservationFileHandler | private
AddSensors(const std::string &agentId) | ObservationFileHandler | private
AddVehicleAttributes(const std::string &agentId) | ObservationFileHandler | private
AddVehicleAttributes(const std::string &agentId) | ObservationFileHandler | private
ContainsSensor(const openpass::sensors::Parameters &sensorParameters) const | ObservationFileHandler | inlineprivate
ContainsSensor(const openpass::sensors::Parameters &sensorParameters) const | ObservationFileHandler | inlineprivate
RemoveCsvCyclics(QString directory) | ObservationFileHandler | private
RemoveCsvCyclics(QString directory) | ObservationFileHandler | private
runNumber | ObservationFileHandler | private
SetOutputLocation(const std::string &outputDir, const std::string &outputFile) | ObservationFileHandler | inline
SetOutputLocation(const std::string &outputDir, const std::string &outputFile) | ObservationFileHandler | inline
WriteCsvCyclics(QString runId, ObservationCyclics &cyclics) | ObservationFileHandler | private
WriteCsvCyclics(QString runId, ObservationCyclics &cyclics) | ObservationFileHandler | private
WriteEndOfFile() | ObservationFileHandler |
WriteEndOfFile() | ObservationFileHandler |
WriteEntities(const QString tag, const openpass::type::EntityIds &entities, bool mandatory=false) | ObservationFileHandler | private
WriteEntities(const QString tag, const openpass::type::EntityIds &entities, bool mandatory=false) | ObservationFileHandler | private
WriteParameter(const openpass::type::FlatParameter &parameters, bool mandatory=false) | ObservationFileHandler | private
WriteParameter(const openpass::type::FlatParameter &parameters, bool mandatory=false) | ObservationFileHandler | private
WriteRun(const RunResultInterface &runResult, RunStatistic runStatistik, ObservationCyclics &cyclics) | ObservationFileHandler |
WriteRun(const RunResultInterface &runResult, RunStatistic runStatistik, ObservationCyclics &cyclics) | ObservationFileHandler |
WriteStartOfFile(const std::string &frameworkVersion) | ObservationFileHandler |
WriteStartOfFile(const std::string &frameworkVersion) | ObservationFileHandler |
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ObservationLogImplementation Member List

This is the complete list of members for ObservationLogImplementation, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Obstruction Member List

This is the complete list of members for Obstruction, including all inherited members.

Invalid() | Obstruction | inlinestatic
isOverlapping | Obstruction |
left | Obstruction |
mainLaneLocator | Obstruction |
NoOpponent() | Obstruction | inlinestatic
Obstruction(double left, double right, double mainLaneLocator) | Obstruction | inline
right | Obstruction |
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

OpenScenarioActionsImplementation Member List

This is the complete list of members for OpenScenarioActionsImplementation, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

OscActionsCalculation Member List

This is the complete list of members for OscActionsCalculation, including all inherited members.

CalculateSinusiodalLaneChange(double deltaS, double deltaT, double deltaTime, double timeStep, GlobalRoadPosition startPosition, double startTime) const OscActionsCalculation
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

OsmpFmuHandler Member List

This is the complete list of members for OsmpFmuHandler, including all inherited members.

enforceDoubleBuffering | OsmpFmuHandler | private
GetSensorData() | OsmpFmuHandler | private
SetSensorViewInput(const osi3::SensorView &data) | OsmpFmuHandler | private
WriteJson(const google::protobuf::Message &message, const QString &fileName) | OsmpFmuHandler | private
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

OutputPort< SignalType, ValueType > Member List

This is the complete list of members for OutputPort< SignalType, ValueType >, including all inherited members.

ComponentPort(int id, std::map< int, ComponentPort * > *portMap) | ComponentPort | inline
GetId() | ComponentPort | inline
OutputPort(int id, std::map< int, ComponentPort * > *portMap) | OutputPort< SignalType, ValueType > | inline
SetSignalValue(const std::shared_ptr< SignalInterface const > &data) | ComponentPort | inlinevirtual
SetValue(ValueType value) | OutputPort< SignalType, ValueType > | inline
value | OutputPort< SignalType, ValueType > | private
~ComponentPort()=default | ComponentPort | virtual
~OutputPort()=default | OutputPort< SignalType, ValueType > | virtual
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ParametersVehicleImplementation Member List

This is the complete list of members for ParametersVehicleImplementation, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ParametersVehicleSignal Member List

This is the complete list of members for ParametersVehicleSignal, including all inherited members.

operator std::string() const | ParametersVehicleSignal | inlinevirtual
ParametersVehicleSignal(VehicleModelParameters vehicleParameters) | ParametersVehicleSignal | inline
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Polygon Member List

This is the complete list of members for Polygon, including all inherited members.

CalculateCentroid(Common::Vector2d &cog) | Polygon
GetNumberOfVertices() | Polygon
GetVertices() const | Polygon
SetVertices(const std::vector< Common::Vector2d > &value) | Polygon
Translate(Common::Vector2d translationVector) | Polygon
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

PostCrashDynamic Member List

This is the complete list of members for PostCrashDynamic, including all inherited members.

collisionVelocity | PostCrashDynamic | private
pointOfContactLocal | PostCrashDynamic | private
PostCrashDynamic(double velocity=0, double velocityChange=0, double velocityDirection=0, double yawVelocity=0, Common::Vector2d pulse=Common::Vector2d(), double pulseDirection=0, Common::Vector2d pulseLocal=Common::Vector2d(), Common::Vector2d pointOfContactLocal=Common::Vector2d(), double collisionVelocity=0, bool sliding=false) | PostCrashDynamic | inline
pulse | PostCrashDynamic | private
pulseDirection | PostCrashDynamic | private
pulseLocal | PostCrashDynamic | private
sliding | PostCrashDynamic | private
velocity | PostCrashDynamic | private
velocityChange | PostCrashDynamic | private
velocityDirection | PostCrashDynamic | private
yawVelocity | PostCrashDynamic | private
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ProcessManager Member List

This is the complete list of members for ProcessManager, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Profiles Member List

This is the complete list of members for Profiles, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ReachPositionCondition Member List

This is the complete list of members for ReachPositionCondition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RemoveAgentsManipulator Member List

This is the complete list of members for RemoveAgentsManipulator, including all inherited members.

GetCycleTime() | ManipulatorCommonBase | virtual
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | ManipulatorCommonBase | protected
Trigger(int time) override | RemoveAgentsManipulator | virtual
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Road Member List

This is the complete list of members for Road, including all inherited members.

AddElevation(double s, double a, double b, double c, double d) override | Road |
AddGeometryArc(double s, double x, double y, double hdg, double length, double curvature) override | Road |
AddGeometryLine(double s, double x, double y, double hdg, double length) override | Road |
AddGeometryParamPoly3(double s, double x, double y, double hdg, double length, ParamPoly3Parameters parameters) override | Road |
AddGeometryPoly3(double s, double x, double y, double hdg, double length, double a, double b, double c, double d) override | Road |
AddGeometrySpiral(double s, double x, double y, double hdg, double length, double curvStart, double curvEnd) override | Road |
AddLaneOffset(double s, double a, double b, double c, double d) override | Road |
AddLink(RoadLinkType type, RoadLinkElementType elementType, const std::string &elementId, ContactPointType contactPoint, RoadLinkDirectionType direction, RoadLinkSideType side) override | Road |
AddRoadLaneSection(double start) override | Road |
AddRoadSignal(const RoadSignalSpecification &signal) override | Road |
GetElevations() const override | Road | inline
GetGeometries() const override | Road | inline
GetId() const override | Road | inline
GetInDirection() const override | Road | inline
GetLaneOffsets() const override | Road | inline
GetLaneSections() const override | Road | inline
GetRoadLinks() const override | Road | inline
GetRoadObjects() const override | Road | inline
GetRoadSignals() const override | Road | inline
SetInDirection(bool inDirection) override | Road | inline
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RoadGeometry Member List

This is the complete list of members for RoadGeometry, including all inherited members.

GetCoord(double sOffset, double tOffset) const override=0 | RoadGeometry | pure virtual
GetCoordArc(double sOffset, double tOffset, double curvature) const | RoadGeometry | protected
GetCoordLine(double sOffset, double tOffset) const | RoadGeometry | protected
GetDir(double sOffset) const override=0 | RoadGeometry | pure virtual
GetDirArc(double sOffset, double curvature) const | RoadGeometry | protected
GetDirLine(double sOffset) const | RoadGeometry | protected
GetHdg() const override | RoadGeometry | inline
GetLength() const override | RoadGeometry | inline
GetS() const override | RoadGeometry | inline
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RoadGeometryArc Member List

This is the complete list of members for RoadGeometryArc, including all inherited members.

GetCoordArc(double sOffset, double tOffset, double curvature) const | RoadGeometry | protected
GetCoordLine(double sOffset, double tOffset) const | RoadGeometry | protected
GetCurvature() const | RoadGeometryArc | inline
GetDirArc(double sOffset, double curvature) const | RoadGeometry | protected
GetDirLine(double sOffset) const | RoadGeometry | protected
GetHdg() const override | RoadGeometry | inline
GetLength() const override | RoadGeometry | inline
GetS() const override | RoadGeometry | inline
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RoadGeometryLine Member List

This is the complete list of members for RoadGeometryLine, including all inherited members.

GetCoordArc(double sOffset, double tOffset, double curvature) const | RoadGeometry | protected
GetCoordLine(double sOffset, double tOffset) const | RoadGeometry | protected
GetDirArc(double sOffset, double curvature) const | RoadGeometry | protected
GetDirLine(double sOffset) const | RoadGeometry | protected
GetHdg() const override | RoadGeometry | inline
GetLength() const override | RoadGeometry | inline
GetS() const override | RoadGeometry | inline
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RoadGeometryParamPoly3 Member List

This is the complete list of members for RoadGeometryParamPoly3, including all inherited members.

GetAU() const | RoadGeometryParamPoly3 | inline
GetAV() const | RoadGeometryParamPoly3 | inline
GetBU() const | RoadGeometryParamPoly3 | inline
GetBV() const | RoadGeometryParamPoly3 | inline
GetCoordArc(double sOffset, double tOffset, double curvature) const | RoadGeometry | protected
GetCoordLine(double sOffset, double tOffset) const | RoadGeometry | protected
GetCU() const | RoadGeometryParamPoly3 | inline
GetCV() const | RoadGeometryParamPoly3 | inline
GetD() const | RoadGeometryParamPoly3 | inline
GetDirArc(double sOffset, double curvature) const | RoadGeometry | protected
GetDirLine(double sOffset) const | RoadGeometry | protected
GetDV() const | RoadGeometryParamPoly3 | inline
GetHdg() const override | RoadGeometry | inline
GetLength() const override | RoadGeometry | inline
GetS() const override | RoadGeometry | inline
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RoadGeometryPoly3 Member List

This is the complete list of members for RoadGeometryPoly3, including all inherited members.

GetA() const | RoadGeometryPoly3 | inline
GetB() const | RoadGeometryPoly3 | inline
GetC() const | RoadGeometryPoly3 | inline
GetCoordArc(double sOffset, double tOffset, double curvature) const | RoadGeometry | protected
GetCoordLine(double sOffset, double tOffset) const | RoadGeometry | protected
GetD() const | RoadGeometryPoly3 | inline
GetDirArc(double sOffset, double curvature) const | RoadGeometry | protected
GetDirLine(double sOffset) const | RoadGeometry | protected
GetHdg() const override | RoadGeometry | inline
GetLength() const override | RoadGeometry | inline
GetS() const override | RoadGeometry | inline
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RoadGeometrySpiral Member List

This is the complete list of members for RoadGeometrySpiral, including all inherited members.

FullCoord(double sOffset, double tOffset) const | RoadGeometrySpiral | private
FullCurvature(double sOffset) const | RoadGeometrySpiral | private
FullDir(double sOffset) const | RoadGeometrySpiral | private
GetCoordArc(double sOffset, double tOffset, double curvature) const | RoadGeometry | protected
GetCoordLine(double sOffset, double tOffset) const | RoadGeometry | protected
GetCurvEnd() const | RoadGeometrySpiral | inline
GetCurvStart() const | RoadGeometrySpiral | inline
GetDirArc(double sOffset, double curvature) const | RoadGeometry | protected
GetDirLine(double sOffset) const | RoadGeometry | protected
GetHdg() const override | RoadGeometry | inline
GetLength() const override | RoadGeometry | inline
GetS() const override | RoadGeometry | inline
HalfCoord(double sOffset, double tOffset) const | RoadGeometrySpiral | private
HalfCurvature(double sOffset) const | RoadGeometrySpiral | private
HalfDir(double sOffset) const | RoadGeometrySpiral | private
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RoadLane Member List

This is the complete list of members for RoadLane, including all inherited members.

AddBorder(double sOffset, double a, double b, double c, double d) override | RoadLane |
AddPredecessor(int id) override | RoadLane |
AddRoadMark(double sOffset, RoadLaneRoadDescriptionType type, RoadLaneRoadMarkType roadMark, RoadLaneRoadMarkColor color, RoadLaneRoadMarkLaneChange laneChange, RoadLaneRoadMarkWeight weight) override | RoadLane |
AddSuccessor(int id) override | RoadLane |
AddWidth(double sOffset, double a, double b, double c, double d) override | RoadLane |
GetBorders() const override | RoadLane | inline
GetId() const override | RoadLane | inline
GetInDirection() const override | RoadLane | inline
GetLaneSection() const override | RoadLane | inline
GetPredecessor() const override | RoadLane | inline
GetRoadMarks() const override | RoadLane | inline
GetSuccessor() const override | RoadLane | inline
GetType() const override | RoadLane | inline
GetWidths() const override | RoadLane | inline
SetInDirection(bool inDirection) override | RoadLane | inline
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RoadLaneSection Member List

This is the complete list of members for RoadLaneSection, including all inherited members.

AddRoadLane(int id, RoadLaneType type) override | RoadLaneSection |
GetId() const override | RoadLaneSection | inline
GetInDirection() const override | RoadLaneSection | inline
GetLaneIndexOffset() const override | RoadLaneSection | inline
GetLanes() const override | RoadLaneSection | inline
GetRoad() const override | RoadLaneSection | inline
GetStart() const override | RoadLaneSection | inline
SetId(int Id) override | RoadLaneSection | inline
SetInDirection(bool inDirection) override | RoadLaneSection | inline
SetLaneIndexOffset(int laneIndexOffset) override | RoadLaneSection | inline
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RoadLink Member List

This is the complete list of members for RoadLink, including all inherited members.

GetContactPoint() const override | RoadLink | inline
GetDirection() const override | RoadLink | inline
GetElementId() const override | RoadLink | inline
GetElementType() const override | RoadLink | inline
GetSide() const override | RoadLink | inline
GetType() const override | RoadLink | inline
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RoadNetworkBuilder Member List

This is the complete list of members for RoadNetworkBuilder, including all inherited members.

Build() RoadNetworkBuilder
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RoadObject Member List

This is the complete list of members for RoadObject, including all inherited members.

GetHdg() const | RoadObject
GetId() const | RoadObject
GetLength() const | RoadObject
GetS() const | RoadObject
GetT() const | RoadObject
GetType() const | RoadObject
GetWidth() const | RoadObject
IsValidForLane(int laneId) const | RoadObject
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RoadSignal Member List

This is the complete list of members for RoadSignal, including all inherited members.

GetHeight() const override | RoadSignal | virtual
GetId() const override | RoadSignal | virtual
GetIsDynamic() const override | RoadSignal | virtual
GetLength() const | RoadSignal | virtual
GetPitch() const | RoadSignal | virtual
GetRoad() | RoadSignal | inline
GetRoll() const | RoadSignal | virtual
GetS() const override | RoadSignal |
GetSubType() const override | RoadSignal |
GetT() const override | RoadSignal |
GetText() const override | RoadSignal |
GetType() const override | RoadSignal |
GetUnit() const override | RoadSignal |
GetValue() const override | RoadSignal |
GetWidth() const override | RoadSignal | virtual
GetYaw() const | RoadSignal | virtual
IsValidForLane(int laneId) const override | RoadSignal |
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RunStatistic Member List

This is the complete list of members for RunStatistic, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RunStatisticCalculation Member List

This is the complete list of members for RunStatisticCalculation, including all inherited members.

DetermineEgoCollision(RunStatistic &runStatistic, const RunResultInterface &runResult, WorldInterface *world) | RunStatisticCalculation | static
DetermineEgoCollision(RunStatistic &runStatistic, const RunResultInterface &runResult, WorldInterface *world) | RunStatisticCalculation | static
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SceneryConverter Member List

This is the complete list of members for SceneryConverter, including all inherited members.

ConnectExternalRoadPredecessor(const RoadInterface *currentRoad, const RoadInterface *otherRoad, RoadLaneSectionInterface *otherSection) | SceneryConverter | private
ConnectExternalRoadSuccessor(const RoadInterface *currentRoad, const RoadInterface *otherRoad, RoadLaneSectionInterface *otherSection) | SceneryConverter | private
ConnectJunction(const JunctionInterface *junction) | SceneryConverter | private
ConnectLanes(RoadLaneSectionInterface *firstLaneSection, ContactPointType firstContactPoint, RoadLaneSectionInterface *secondLaneSection, ContactPointType secondContactPoint) | SceneryConverter | private
ConnectLaneToLane(RoadLaneInterface *currentLane, ContactPointType currentContactPoint, RoadLaneInterface *otherLane) | SceneryConverter | private
ConnectLaneToSection(RoadLaneInterface *currentLane, ContactPointType currentContactPoint, RoadLaneSectionInterface *otherLaneSection) | SceneryConverter | private
ConnectPathInJunction(const JunctionInterface *junction, const RoadInterface *incomingRoad, const RoadInterface *connectingRoad, const RoadInterface *outgoingRoad, ContactPointType incomingContactPoint, ContactPointType outgoingContactPoint, std::map< int, int > laneIdMapping) | SceneryConverter | private
ConnectRoadExternalWithElementTypeRoad(RoadInterface *road) | SceneryConverter | private
ConnectRoadInternal(RoadInterface *road) | SceneryConverter | private
ConnectRoads() | SceneryConverter | private
ConvertObjects() | SceneryConverter |
ConvertRoads() | SceneryConverter |
CreateRoadMarking(RoadSignalInterface *signal, Position position, const OWL::Interfaces::Lanes &lanes) | SceneryConverter | private
CreateTrafficSign(RoadSignalInterface *signal, Position position, const OWL::Interfaces::Lanes &lanes) | SceneryConverter | private
GetConnectedRoad(RoadLinkInterface *roadLink) | SceneryConverter | private
GetOtherLane(RoadLaneSectionInterface *otherSection, int otherId) | SceneryConverter | private
IndexElements() | SceneryConverter | private
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | SceneryConverter | inlineprotected
MarkDirectionRoad(RoadInterface *road, bool inDirection) | SceneryConverter | private
MarkDirections() | SceneryConverter | private
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SecondaryDriverTasksSignal Member List

This is the complete list of members for SecondaryDriverTasksSignal, including all inherited members.

operator std::string() const | SecondaryDriverTasksSignal | inlinevirtual
SecondaryDriverTasksSignal() | SecondaryDriverTasksSignal | inline
SecondaryDriverTasksSignal(int indicatorState, bool hornSwitch, bool headLightSwitch, bool highBeamLightSwitch, bool flasher, ComponentState componentState) | SecondaryDriverTasksSignal | inline
SecondaryDriverTasksSignal(SecondaryDriverTasksSignal &other) | SecondaryDriverTasksSignal | inline
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Sensor_Distance_Implementation Member List

This is the complete list of members for Sensor_Distance_Implementation, including all inherited members.

out_agentVelocity | Sensor_Distance_Implementation | private
out_distanceToNextAgent | Sensor_Distance_Implementation | private
Trigger(int time) | Sensor_Distance_Implementation | virtual
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | Sensor_Distance_Implementation | virtual
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | Sensor_Distance_Implementation | virtual
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SensorDataSignal Member List

This is the complete list of members for SensorDataSignal, including all inherited members.

operator std::string() const | SensorDataSignal | inlinevirtual
sensorData | SensorDataSignal |
SensorDataSignal(osi3::SensorData sensorData) | SensorDataSignal | inline
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SensorDriverCalculations Member List

This is the complete list of members for SensorDriverCalculations, including all inherited members.

GetLateralDistanceToObject(const std::string &roadId, const AgentInterface *otherObject) SensorDriverCalculations
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SensorDriverImplementation Member List

This is the complete list of members for SensorDriverImplementation, including all inherited members.

COMPONENTNAME | SensorDriverImplementation |
geometryInformation | SensorDriverImplementation | private
GetGeometryInformation() | SensorDriverImplementation | privatevirtual
GetGeometryLaneInformation(int relativeLaneId) | SensorDriverImplementation | private
GetGeometryLaneInformationEgo() | SensorDriverImplementation | private
GetNewRoute() | SensorDriverImplementation | private
GetObject(double visibilityDistance, int relativeLane, bool forwardSearch) | SensorDriverImplementation | private
GetOtherObjectInformation(const WorldObjectInterface *surroundingObject) | SensorDriverImplementation | privatevirtual
GetOwnVehicleInformation() | SensorDriverImplementation | privatevirtual
GetSurroundingObjectsInformation() | SensorDriverImplementation | privatevirtual
GetTrafficRuleInformation() | SensorDriverImplementation | privatevirtual
GetTrafficRuleLaneInformationEgo() | SensorDriverImplementation | private
GetTrafficRuleLaneInformationLeft() | SensorDriverImplementation | private
GetTrafficRuleLaneInformationRight() | SensorDriverImplementation | private
ownVehicleInformation | SensorDriverImplementation | private
SensorDriverImplementation(std::string componentName, bool isInit, int priority, int offsetTime, int responseTime, int cycleTime, StochasticsInterface *stochastics, WorldInterface *world, const ParameterInterface *parameters, PublisherInterface *const publisher, const CallbackInterface *callbacks, AgentInterface *agent) | SensorDriverImplementation |
surroundingObjects | SensorDriverImplementation | private
trafficRuleInformation | SensorDriverImplementation | private
UpdateGraphPosition() | SensorDriverImplementation | private
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SensorDriverSignal Member List

This is the complete list of members for SensorDriverSignal, including all inherited members.

geometryInformation | SensorDriverSignal | private
GetGeometryInformation() const | SensorDriverSignal | inlinevirtual
GetOwnVehicleInformation() const | SensorDriverSignal | inlinevirtual
GetSurroundingObjects() const | SensorDriverSignal | inlinevirtual
GetTrafficRuleInformation() const | SensorDriverSignal | inlinevirtual
operator std::string() const | SensorDriverSignal | inlinevirtual
ownVehicleInformation | SensorDriverSignal | private
SensorDriverSignal(OwnVehicleInformation ownVehicleInformation, TrafficRuleInformation trafficRuleInformation, GeometryInformation geometryInformation, SurroundingObjects surroundingObjects) | SensorDriverSignal | inline
surroundingObjects | SensorDriverSignal | private
trafficRuleInformation | SensorDriverSignal | private
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SensorFusionHelperFunctions Member List

This is the complete list of members for SensorFusionHelperFunctions, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SensorFusionImplementation Member List

This is the complete list of members for SensorFusionImplementation, including all inherited members.

Trigger(int time) | SensorFusionImplementation | virtual
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | SensorFusionImplementation | virtual
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | SensorFusionImplementation |
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SensorGeometric2D Member List

This is the complete list of members for SensorGeometric2D, including all inherited members.

AddMovingObjectToSensorData(osi3::MovingObject object, point_t ownVelocity, point_t ownAcceleration, point_t ownPosition, double yaw, double yawRate) | SensorGeometric2D | private
AddStationaryObjectToSensorData(osi3::StationaryObject object, point_t ownPosition, double yaw) | SensorGeometric2D | private
ApplyLatency(int time, osi3::SensorData currentSensorData) | ObjectDetectorBase | protected
ApplyMeasurementError(double value) | ObjectDetectorBase | protected
CalcInitialBrightArea(point_t sensorPosition) | SensorGeometric2D | private
CalcObjectShadow(const polygon_t &boundingBox, point_t sensorPosition) | SensorGeometric2D | privatestatic
CalcObjectVisibilityPercentage(const polygon_t &boundingBox, const multi_polygon_t &brightArea) | SensorGeometric2D | privatestatic
CalculateBoundingBox(const osi3::Dimension3d dimension, const osi3::Vector3d position, const osi3::Orientation3d orientation) | ObjectDetectorBase | protectedstatic
CalculateGlobalSensorPosition(point_t vehiclePosition, double yaw) const | ObjectDetectorBase | protected
CalculateRelativeVector(const point_t absolute, const point_t own, double yaw) | ObjectDetectorBase | protectedvirtual
CalcVisualObstruction(const std::vector< const T * > &objects, const multi_polygon_t &brightArea) | SensorGeometric2D | private
CreateFivePointDetectionField() const | SensorGeometric2D | private
CreateFourPointDetectionField() const | SensorGeometric2D | private
DetectObjects() | SensorGeometric2D |
GenerateSensorViewConfiguration() override | SensorGeometric2D | protectedvirtual
GetAbsolutePosition() | ObjectDetectorBase | protected
getSensorData() | ObjectDetectorBase | inline
HasDetectionError() | ObjectDetectorBase | protected
OpeningAngleWithinFullCircle() const | SensorGeometric2D | private
OpeningAngleWithinHalfCircle() const | SensorGeometric2D | private
TransformPointToLocalCoordinates(point_t point, point_t sensorPositionGlobal, double yaw) | ObjectDetectorBase | protectedvirtual
TransformPolygonToGlobalCoordinates(polygon_t polygon, point_t sensorPositionGlobal, double yaw) const | ObjectDetectorBase | protected
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | ObjectDetectorBase |
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SensorRecordStateImplementation Member List

This is the complete list of members for SensorRecordStateImplementation, including all inherited members.

Trigger(int time) | SensorRecordStateImplementation
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | SensorRecordStateImplementation
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | SensorRecordStateImplementation
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SignalPrioritizerImplementation Member List

This is the complete list of members for SignalPrioritizerImplementation, including all inherited members.

Error(std::string message) const | SignalPrioritizerImplementation | private
GetSignalWithHighestPriority() const | SignalPrioritizerImplementation | private
IsActive(const std::shared_ptr< const ComponentStateSignalInterface > &signal) const | SignalPrioritizerImplementation | private
IsPrior(int firstSignal, int secondSignal) const | SignalPrioritizerImplementation | private
ParseSenderPriorities(const std::map< std::string, int > &priorities) | SignalPrioritizerImplementation | private
UpdateInput(int localLinkId, const Signal &signal, int time) override | SignalPrioritizerImplementation |
UpdateOutput(int localLinkId, Signal &signal, int time) override | SignalPrioritizerImplementation |
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SignalVector< DT > Member List

This is the complete list of members for SignalVector< DT >, including all inherited members.

operator std::string() const | SignalVector< DT > | inlinevirtual
value | SignalVector< DT > |
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationCommon
  • Callbacks
Callbacks Member List

This is the complete list of members for Callbacks, including all inherited members.

Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) const Callbacks virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationCommon
  • ModelParameters
ModelParameters Member List

This is the complete list of members for ModelParameters, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationCommon
  • ObservationParameters
ObservationParameters Member List

This is the complete list of members for ObservationParameters, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationCommon
  • Parameters
Parameters Member List

This is the complete list of members for Parameters, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationCommon
  • SpawnPointParameters
SpawnPointParameters Member List

This is the complete list of members for SpawnPointParameters, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationCommon
  • WorldParameters
WorldParameters Member List

This is the complete list of members for WorldParameters, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationMaster
  • Configuration
  • MasterConfigImporter
MasterConfigImporter Member List

This is the complete list of members for MasterConfigImporter, including all inherited members.

GetAbsoluteFilePath(const QString &filename) | MasterConfigImporter | privatestatic
Import(const QString &filename) | MasterConfigImporter | static
ParseSlaveConfig(const QDomElement &element) | MasterConfigImporter | privatestatic
ParseSlaveConfigs(const QDomElement &element) | MasterConfigImporter | privatestatic
ReadDocument(QFile &xmlFile, const std::string &file) | MasterConfigImporter | privatestatic
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationMaster
  • Configuration
  • SlaveConfig
SlaveConfig Member List

This is the complete list of members for SlaveConfig, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • Agent
Agent Member List

This is the complete list of members for Agent, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • AgentFactory
AgentFactory Member List

This is the complete list of members for AgentFactory, including all inherited members.

ConnectAgentLinks(Agent *agent) | AgentFactory | private
CreateAgent(int id, AgentBlueprintInterface *agentBlueprint) | AgentFactory | private
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • AgentType
AgentType Member List

This is the complete list of members for AgentType, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • Channel
Channel Member List

This is the complete list of members for Channel, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • ChannelBuffer
ChannelBuffer Member List

This is the complete list of members for ChannelBuffer, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • Component
Component Member List

This is the complete list of members for Component, including all inherited members.

AcquireOutputData(int linkId, int time) override | Component |
AddInputLink(Channel *input, int linkId) override | Component |
AddOutputLink(Channel *output, int linkId) override | Component |
CreateOutputBuffer(int linkId) override | Component |
GetAgent() const override | Component |
GetCycleTime() const override | Component |
GetImplementation() const override | Component |
GetInit() const override | Component |
GetInputLinks() override | Component |
GetName() const override | Component |
GetObservations() const override | Component |
GetOffsetTime() const override | Component |
GetOutputLinks() override | Component |
GetPriority() const override | Component |
GetResponseTime() const override | Component |
ReleaseFromLibrary() override | Component |
ReleaseOutputData(int linkId) override | Component |
SetImplementation(ModelInterface *implementation) override | Component |
SetInputBuffer(int linkId, ChannelBuffer *buffer) override | Component |
SetModelLibrary(ModelLibrary *modelLibrary) override | Component |
SetObservations(const std::map< int, ObservationModule * > &observations) override | Component | virtual
TriggerCycle(int time) override | Component |
UpdateInputData(int linkId, int time) override | Component |
~Component() override | Component | virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • ComponentType
ComponentType Member List

This is the complete list of members for ComponentType, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • DataStore
DataStore Member List

This is the complete list of members for DataStore, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • DataStoreBinding
DataStoreBinding Member List

This is the complete list of members for DataStoreBinding, including all inherited members.

Instantiate() | DataStoreBinding
Unload() | DataStoreBinding
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • DataStoreLibrary
DataStoreLibrary Member List

This is the complete list of members for DataStoreLibrary, including all inherited members.

CreateDataStore(const openpass::common::RuntimeInformation &runtimeInformation) | DataStoreLibrary |
Init() | DataStoreLibrary |
ReleaseDataStore() | DataStoreLibrary |
~DataStoreLibrary() | DataStoreLibrary | virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • EventDetector
EventDetector Member List

This is the complete list of members for EventDetector, including all inherited members.

GetImplementation() const | EventDetector | inline
GetLibrary() | EventDetector | inline
~EventDetector() | EventDetector | inlinevirtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • EventDetectorBinding
EventDetectorBinding Member List

This is the complete list of members for EventDetectorBinding, including all inherited members.

Instantiate(const std::string libraryPath, ScenarioInterface *scenario, EventNetworkInterface *eventNetwork, WorldInterface *world, StochasticsInterface *stochastics) | EventDetectorBinding
Unload() | EventDetectorBinding
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • EventDetectorLibrary
EventDetectorLibrary Member List

This is the complete list of members for EventDetectorLibrary, including all inherited members.

CreateCollisionDetector(EventNetworkInterface *eventNetwork, WorldInterface *world, StochasticsInterface *stochastics) | EventDetectorLibrary |
Init() | EventDetectorLibrary |
ReleaseEventDetector(EventDetector *eventDetector) | EventDetectorLibrary |
~EventDetectorLibrary() | EventDetectorLibrary | virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • EventDetectorNetwork
EventDetectorNetwork Member List

This is the complete list of members for EventDetectorNetwork, including all inherited members.

Clear() | EventDetectorNetwork
GetEventDetectors() | EventDetectorNetwork
Instantiate(const std::string libraryPath, ScenarioInterface *scenario, EventNetworkInterface *eventNetwork, StochasticsInterface *stochastics) | EventDetectorNetwork
ResetAll() | EventDetectorNetwork
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • EventNetwork
EventNetwork Member List

This is the complete list of members for EventNetwork, including all inherited members.

AddCollision(const int agentId) override | EventNetwork | virtual
Clear() override | EventNetwork | virtual
GetEvents(const EventDefinitions::EventCategory eventCategory) override | EventNetwork | virtual
GetTrigger(const std::string &topic) const override | EventNetwork |
Initialize(RunResultInterface *runResult) override | EventNetwork | virtual
InsertEvent(SharedEvent event) override | EventNetwork | virtual
InsertTrigger(const std::string &topic, std::unique_ptr< EventInterface > event) override | EventNetwork |
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • FrameworkModuleContainer
FrameworkModuleContainer Member List

This is the complete list of members for FrameworkModuleContainer, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • Manipulator
Manipulator Member List

This is the complete list of members for Manipulator, including all inherited members.

GetImplementation() const | Manipulator | inline
GetLibrary() | Manipulator | inline
~Manipulator() | Manipulator | inlinevirtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • ManipulatorBinding
ManipulatorBinding Member List

This is the complete list of members for ManipulatorBinding, including all inherited members.

Instantiate(const std::string libraryPath, ScenarioInterface *scenario, EventNetworkInterface *eventNetwork, WorldInterface *world, PublisherInterface *publisher) | ManipulatorBinding
Unload() | ManipulatorBinding
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • ManipulatorLibrary
ManipulatorLibrary Member List

This is the complete list of members for ManipulatorLibrary, including all inherited members.

CreateManipulator(const openScenario::ManipulatorInformation manipulatorInformation, EventNetworkInterface *eventNetwork, WorldInterface *world) | ManipulatorLibrary |
Init() | ManipulatorLibrary |
ReleaseManipulator(Manipulator *manipulator) | ManipulatorLibrary |
~ManipulatorLibrary() | ManipulatorLibrary | virtual
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • ManipulatorNetwork
ManipulatorNetwork Member List

This is the complete list of members for ManipulatorNetwork, including all inherited members.

Clear() | ManipulatorNetwork
GetManipulators() | ManipulatorNetwork
Instantiate(const std::string libraryPath, ScenarioInterface *scenario, EventNetworkInterface *eventNetwork) | ManipulatorNetwork
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • ModelBinding
ModelBinding Member List

This is the complete list of members for ModelBinding, including all inherited members.

Instantiate(std::shared_ptr< ComponentType > componentType, std::string componentName, StochasticsInterface *stochastics, WorldInterface *world, ObservationNetworkInterface *observationNetwork, Agent *agent, EventNetworkInterface *eventNetwork, PublisherInterface *publisher) | ModelBinding
Unload() | ModelBinding
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • ModelLibrary
ModelLibrary Member List

This is the complete list of members for ModelLibrary, including all inherited members.

CreateComponent(std::shared_ptr< ComponentType > componentType, std::string componentName, const openpass::common::RuntimeInformation &runtimeInformation, StochasticsInterface *stochastics, WorldInterface *world, ObservationNetworkInterface *observationNetwork, Agent *agent, EventNetworkInterface *eventNetwork, PublisherInterface *publisher) | ModelLibrary |
Init() | ModelLibrary |
ReleaseComponent(ComponentInterface *component) | ModelLibrary |
Trigger(ModelInterface *implementation, int time) | ModelLibrary | inline
UpdateInput(ModelInterface *implementation, int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) | ModelLibrary | inline
UpdateOutput(ModelInterface *implementation, int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) | ModelLibrary | inline
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • ObservationBinding
ObservationBinding Member List

This is the complete list of members for ObservationBinding, including all inherited members.

Instantiate(const std::string &libraryPath, const openpass::parameter::ParameterSetLevel1 &parameter, StochasticsInterface *stochastics, WorldInterface *world, SimulationSlave::EventNetworkInterface *eventNetwork, DataStoreReadInterface *dataStore) | ObservationBinding
Unload() | ObservationBinding
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • ObservationLibrary
ObservationLibrary Member List

This is the complete list of members for ObservationLibrary, including all inherited members.

CreateObservationModule(const openpass::common::RuntimeInformation &runtimeInformation, const openpass::parameter::ParameterSetLevel1 &parameters, StochasticsInterface *stochastics, WorldInterface *world, EventNetworkInterface *eventNetwork, DataStoreReadInterface *const dataStore) | ObservationLibrary
Init() | ObservationLibrary
ReleaseObservationModule(ObservationModule *observationModule) | ObservationLibrary
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • ObservationModule
ObservationModule Member List

This is the complete list of members for ObservationModule, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • ObservationNetwork
ObservationNetwork Member List

This is the complete list of members for ObservationNetwork, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • RunInstantiator
RunInstantiator Member List

This is the complete list of members for RunInstantiator, including all inherited members.

ExecuteRun() | RunInstantiator |
InitPreRun(ScenarioInterface &scenario, SceneryInterface &scenery) | RunInstantiator | private
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • RunResult
RunResult Member List

This is the complete list of members for RunResult, including all inherited members.

AddCollisionId(const int agentId) RunResult
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • SpawnItemParameter
SpawnItemParameter Member List

This is the complete list of members for SpawnItemParameter, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • SpawnPoint
SpawnPoint Member List

This is the complete list of members for SpawnPoint, including all inherited members.

GetAgentFactory() | SpawnPoint | inline
GetId() const | SpawnPoint | inline
GetImplementation() | SpawnPoint | inline
GetLibrary() | SpawnPoint | inline
~SpawnPoint()=default | SpawnPoint | virtual
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • SpawnPointBinding
SpawnPointBinding Member List

This is the complete list of members for SpawnPointBinding, including all inherited members.

Instantiate(const std::string &libraryPath, const SpawnPointDependencies &dependencies) | SpawnPointBinding |
SetParameter(std::unique_ptr< ParameterInterface > parameter) | SpawnPointBinding | inline
Unload() | SpawnPointBinding |
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • SpawnPointLibrary
SpawnPointLibrary Member List

This is the complete list of members for SpawnPointLibrary, including all inherited members.

CreateSpawnPoint(const SpawnPointDependencies &dependencies) | SpawnPointLibrary |
Init() | SpawnPointLibrary |
~SpawnPointLibrary() | SpawnPointLibrary | virtual
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • SpawnPointNetwork
SpawnPointNetwork Member List

This is the complete list of members for SpawnPointNetwork, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • Stochastics
Stochastics Member List

This is the complete list of members for Stochastics, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • StochasticsBinding
StochasticsBinding Member List

This is the complete list of members for StochasticsBinding, including all inherited members.

Instantiate(std::string libraryPath) | StochasticsBinding
Unload() | StochasticsBinding
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • StochasticsLibrary
StochasticsLibrary Member List

This is the complete list of members for StochasticsLibrary, including all inherited members.

CreateStochastics() | StochasticsLibrary |
Init() | StochasticsLibrary |
ReleaseStochastics() | StochasticsLibrary |
~StochasticsLibrary() | StochasticsLibrary | virtual
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • World
World Member List

This is the complete list of members for World, including all inherited members.

Instantiate() | World | inline
isInstantiated() override | World | inline
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • WorldBinding
WorldBinding Member List

This is the complete list of members for WorldBinding, including all inherited members.

Instantiate() | WorldBinding
Unload() | WorldBinding
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationSlave
  • WorldLibrary
WorldLibrary Member List

This is the complete list of members for WorldLibrary, including all inherited members.

CreateWorld() | WorldLibrary |
Init() | WorldLibrary |
ReleaseWorld() | WorldLibrary |
~WorldLibrary() | WorldLibrary | virtual
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SimulationTimeCondition Member List

This is the complete list of members for SimulationTimeCondition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SpawnPoint_Start_Implementation Member List

This is the complete list of members for SpawnPoint_Start_Implementation, including all inherited members.

_carRate | SpawnPoint_Start_Implementation | private
_iSpawnCar | SpawnPoint_Start_Implementation | private
_standardCycleTime | SpawnPoint_Start_Implementation | private
Par_demandHighway | SpawnPoint_Start_Implementation | private
Par_NSpawnCars | SpawnPoint_Start_Implementation | private
Par_vMean | SpawnPoint_Start_Implementation | private
Par_vMin | SpawnPoint_Start_Implementation | private
Par_vSd | SpawnPoint_Start_Implementation | private
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SpawnPointPreRunCommon Member List

This is the complete list of members for SpawnPointPreRunCommon, including all inherited members.

AreSpawningCoordinatesValid(const std::string &roadId, const int laneId, const double sPosition, const double offset, const VehicleModelParameters &vehicleModelParameters) | SpawnPointPreRunCommon | private
CalculateSpawnParameter(AgentBlueprintInterface *agentBlueprint, const SpawnInfo &spawnInfo) | SpawnPointPreRunCommon | private
GenerateAgentsForRange(const LaneId &laneId, const RoadId &roadId, const Range &range) | SpawnPointPreRunCommon | private
GetNextSpawnCarInfo(const RoadId &roadId, const LaneId &laneId, const Range &range, const double gapInSeconds, const double velocity, const double agentFrontLength, const double agentRearLength) const | SpawnPointPreRunCommon | private
IsOffsetValidForLane(const std::string &roadId, const int laneId, const double distanceFromStart, const double offset, const double vehicleWidth) | SpawnPointPreRunCommon | private
LogError(const std::string &message) | SpawnPointPreRunCommon | private
NewAgentIntersectsWithExistingAgent(const int laneId, const double sPosition, const double offset, const VehicleModelParameters &vehicleModelParameters) const | SpawnPointPreRunCommon | private
Trigger(int time) override | SpawnPointPreRunCommon |
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SpawnPointRuntimeCommon Member List

This is the complete list of members for SpawnPointRuntimeCommon, including all inherited members.

CalculateSpawnParameter(AgentBlueprintInterface *agentBlueprint, const RoadId &roadId, const LaneId laneId, const SPosition sPosition, const double velocity) const | SpawnPointRuntimeCommon | private
GenerateSpawnDetailsForLane(const SpawnPosition sceneryInformation, int time) | SpawnPointRuntimeCommon | private
LogError(const std::string &message) | SpawnPointRuntimeCommon | private
Trigger(int time) override | SpawnPointRuntimeCommon |
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SpawnPointScenario Member List

This is the complete list of members for SpawnPointScenario, including all inherited members.

CalculateAttributeValue(const openScenario::StochasticAttribute &attribute) | SpawnPointScenario | private
CalculateSpawnParameter(const SpawnInfo &spawnInfo, const VehicleModelParameters &vehicleModelParameters) | SpawnPointScenario | private
GetRoute(const std::vector< RouteElement > &roads) | SpawnPointScenario | private
GetSTCoordinates(const openScenario::LanePosition &lanePosition, const VehicleModelParameters &vehicleModelParameters) | SpawnPointScenario | private
LogError(const std::string &message) | SpawnPointScenario | private
Trigger(int time) override | SpawnPointScenario |
ValidateOverlappingAgents(const STCoordinates &stCoordinates, const openScenario::LanePosition &lanePosition, const VehicleModelParameters &vehicleModelParameters) | SpawnPointScenario | private
ValidateSTCoordinatesOnLane(const STCoordinates &stCoordinate, const openScenario::LanePosition &lanePosition, const double vehicleWidth) | SpawnPointScenario | private
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SpeedActionManipulator Member List

This is the complete list of members for SpeedActionManipulator, including all inherited members.

GetCycleTime() | ManipulatorCommonBase | virtual
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | ManipulatorCommonBase | protected
Trigger(int time) | SpeedActionManipulator | virtual
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SpeedActionSignal Member List

This is the complete list of members for SpeedActionSignal, including all inherited members.

operator std::string() const | SpeedActionSignal | inlinevirtual
SpeedActionSignal() | SpeedActionSignal | inline
SpeedActionSignal(SpeedActionSignal &other) | SpeedActionSignal | inline
SpeedActionSignal(ComponentState componentState, const double targetSpeed, const double acceleration) | SpeedActionSignal | inline
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SteeringController Member List

This is the complete list of members for SteeringController, including all inherited members.

CalculateSteeringAngle(int time) | SteeringController |
curvatureRoadSmoothLast | SteeringController | protected
in_steeringMax | SteeringController | protected
in_steeringRatio | SteeringController | protected
in_steeringWheelAngle | SteeringController | protected
in_velocity | SteeringController | protected
in_wheelBase | SteeringController | protected
meanCurvatureToFarPointSmoothLast | SteeringController | protected
meanCurvatureToNearPointSmoothLast | SteeringController | protected
RadiantToDegree | SteeringController | protected
SetLateralInput(const LateralSignal &lateralSignal) | SteeringController | inline
SetVehicleParameter(const double &steeringRatio, const double &maximumSteeringWheelAngleAmplitude, const double &wheelbase) | SteeringController | inline
SetVelocityAndSteeringWheelAngle(const double &velocity, const double &steeringWheelAngle) | SteeringController | inline
tAverage | SteeringController | protected
timeLast | SteeringController | protected
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SteeringSignal Member List

This is the complete list of members for SteeringSignal, including all inherited members.

operator std::string() const | SteeringSignal | inlinevirtual
SteeringSignal(ComponentState componentState, double steeringWheelAngle) | SteeringSignal | inline
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

StochasticsImplementation Member List

This is the complete list of members for StochasticsImplementation, including all inherited members.

Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) StochasticsImplementation inlineprotected
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Stream< T > Member List

This is the complete list of members for Stream< T >, including all inherited members.

Contains(const T &element) const | Stream< T >
GetElementAndSByPosition(double position) const | Stream< T >
GetPositionByElementAndS(const T &element, double sCoordinate) const | Stream< T >
Reverse() const | Stream< T >
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Tire Member List

This is the complete list of members for Tire, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

TrafficHelperFunctions Member List

This is the complete list of members for TrafficHelperFunctions, including all inherited members.

CalculateNetTimeGap(double vRear, double netDistance) | TrafficHelperFunctions | inlinestatic
ValueInBounds(const T &low, const T &value, const T &high) | TrafficHelperFunctions | inlinestatic
WillCrash(double sDelta, double vEgo, double assumedBrakeAccelerationEgo, double vFront, double aFront, double assumedTtb) | TrafficHelperFunctions | inlinestatic
WillCrashDuringBrake(double sDelta, double vEgo, double aEgo, double vFront, double aFront) | TrafficHelperFunctions | inlinestatic
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

TrafficObjectAdapter Member List

This is the complete list of members for TrafficObjectAdapter, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

TrajectoryFollowerImplementation Member List

This is the complete list of members for TrajectoryFollowerImplementation, including all inherited members.

CalculateNextTimestep() | TrajectoryFollowerImplementation
Trigger(int time) override | TrajectoryFollowerImplementation
UpdateInput(int localLinkId, const std::shared_ptr< SignalInterface const > &data, int time) override | TrajectoryFollowerImplementation
UpdateOutput(int localLinkId, std::shared_ptr< SignalInterface const > &data, int time) override | TrajectoryFollowerImplementation
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

TrajectoryManipulator Member List

This is the complete list of members for TrajectoryManipulator, including all inherited members.

GetCycleTime() | ManipulatorCommonBase | virtual
Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) | ManipulatorCommonBase | protected
Trigger(int time) override | TrajectoryManipulator | virtual
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

TrajectorySignal Member List

This is the complete list of members for TrajectorySignal, including all inherited members.

operator std::string() const | TrajectorySignal | inlinevirtual
TrajectorySignal() | TrajectorySignal | inline
TrajectorySignal(TrajectorySignal &other) | TrajectorySignal | inline
TrajectorySignal(ComponentState componentState, openScenario::Trajectory trajectory) | TrajectorySignal | inline
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

TtcCalculations Member List

This is the complete list of members for TtcCalculations, including all inherited members.

CalculateBoundingBox(const TtcParameters parameters) | TtcCalculations | inlineprivatestatic
CalculateObjectTTC(const AgentInterface &agent, const WorldObjectInterface &detectedObject, double maxTtc, double collisionDetectionLongitudinalBoundary, double collisionDetectionLateralBoundary, double cycleTime) | TtcCalculations | inlinestatic
GetTTCObjectParameters(const WorldObjectInterface *object, double collisionDetectionLongitudinalBoundary, double collisionDetectionLateralBoundary) | TtcCalculations | inlineprivatestatic
PropagateParametersForward(TtcParameters &parameters, const double timestep) | TtcCalculations | inlineprivatestatic
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

VehicleCompToCompCtrlSignal Member List

This is the complete list of members for VehicleCompToCompCtrlSignal, including all inherited members.

AgentCompToCompCtrlSignal(const ComponentType componentType, const std::string &agentComponentName, const ComponentState currentState, const std::vector< ComponentWarningInformation > &warnings={}) | AgentCompToCompCtrlSignal | inline
GetAgentComponentName() const | AgentCompToCompCtrlSignal | inline
GetComponentType() const | AgentCompToCompCtrlSignal | inline
GetComponentWarnings() const | AgentCompToCompCtrlSignal | inline
GetCurrentState() const | AgentCompToCompCtrlSignal | inline
operator std::string() const | AgentCompToCompCtrlSignal | inlinevirtual
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

VehicleSimpleTT Member List

This is the complete list of members for VehicleSimpleTT, including all inherited members.

accelVerticalEarth | VehicleSimpleTT | private
anglePreSet | VehicleSimpleTT | private
areaFace | VehicleSimpleTT | private
brakeBalance | VehicleSimpleTT | private
coeffDrag | VehicleSimpleTT | private
densityAir | VehicleSimpleTT | private
DriveTrain(double throttlePedal, double brakePedal, std::vector< double > brakeSuperpose) | VehicleSimpleTT |
ForceGlobal() | VehicleSimpleTT |
ForceLocal(double timeStep, double, std::vector< double > forceVertical) | VehicleSimpleTT |
forceTotalXY | VehicleSimpleTT |
inertiaTireX | VehicleSimpleTT | private
InitSetEngine(double weight, double P_engine, double T_brakeLimit) | VehicleSimpleTT |
InitSetGeometry(double x_wheelbase, double x_COG, double y_track, double y_COG) | VehicleSimpleTT |
InitSetTire(double vel, double mu_tire_max, double mu_tire_slide, double s_max, double r_tire, double frictionScaleRoll) | VehicleSimpleTT |
massTotal | VehicleSimpleTT | private
momentTotalZ | VehicleSimpleTT |
positionTire | VehicleSimpleTT | private
powerEngineLimit | VehicleSimpleTT | private
SetVelocity(Common::Vector2d, const double) | VehicleSimpleTT |
torqueBrakeLimit | VehicleSimpleTT | private
torqueEngineLimit | VehicleSimpleTT | private
UpdatePosition(double) | VehicleSimpleTT |
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • World
  • Localization
  • Localizer
Localizer Member List

This is the complete list of members for Localizer, including all inherited members.

BuildResult(const LocatedObject &locatedObject) const Localizer private
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • World
  • Localization
  • PointQuery
PointQuery Member List

This is the complete list of members for PointQuery, including all inherited members.

IsWithin(const OWL::Primitive::LaneGeometryElement &element, const Common::Vector2d &point) PointQuery static
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • World
  • Localization
  • Result
Result Member List

This is the complete list of members for Result, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • World
  • Localization
  • WorldToRoadCoordinateConverter
WorldToRoadCoordinateConverter Member List

This is the complete list of members for WorldToRoadCoordinateConverter, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

World_Basic_Implementation Member List

This is the complete list of members for World_Basic_Implementation, including all inherited members.

Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) World_Basic_Implementation inlineprotected
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

WorldAnalyzer Member List

This is the complete list of members for WorldAnalyzer, including all inherited members.

AreSpawningCoordinatesValid(const RoadId &roadId, const LaneId laneId, const SPosition sPosition, const double offset, const VehicleModelParameters &vehicleModelParameters) const | WorldAnalyzer
CalculateSpawnVelocityToPreventCrashing(const RoadId &roadId, const LaneId laneId, const double intendedSpawnPosition, const double agentFrontLength, const double agentRearLength, const double intendedVelocity) const | WorldAnalyzer
GetNextSpawnPosition(const RoadId &roadId, const LaneId laneId, const Range &bounds, const double agentFrontLength, const double agentRearLength, const double intendedVelocity, const double gapInSeconds, const Direction direction) const | WorldAnalyzer
GetRightLaneCount(const RoadId &roadId, const LaneId &laneId, const double sPosition) const | WorldAnalyzer
GetValidLaneSpawningRanges(const RoadId &roadId, const LaneId laneId, const SPosition sStart, const SPosition sEnd) const | WorldAnalyzer
SpawnWillCauseCrash(const RoadId &roadId, const LaneId laneId, const SPosition sPosition, const double agentFrontLength, const double agentRearLength, const double velocity, const Direction direction) const | WorldAnalyzer
ValidateRoadIdInDirection(const RoadId &roadId, const LaneId laneId) const | WorldAnalyzer
ValidMinimumSpawningDistanceToObjectInFront(const RoadId &roadId, const LaneId laneId, const SPosition sPosition, const VehicleModelParameters &vehicleModelParameters) const | WorldAnalyzer
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

WorldDataQuery Member List

This is the complete list of members for WorldDataQuery, including all inherited members.

CalculatePositionIfOnLane(double sCoordinate, double tCoordinate, const OWL::Interfaces::Lane &lane) const | WorldDataQuery | private
CreateLaneMultiStream(const RoadGraph &roadGraph, RoadGraphVertex start, OWL::OdId startLaneId, double startDistance) const | WorldDataQuery |
CreateLaneStream(const std::vector< RouteElement > &route, std::string startRoadId, OWL::OdId startLaneId, double startDistance) const | WorldDataQuery |
CreateRoadMultiStream(const RoadGraph &roadGraph, RoadGraphVertex start) const | WorldDataQuery |
CreateRoadStream(const std::vector< RouteElement > &route) const | WorldDataQuery |
GetDistanceBetweenObjects(const RoadMultiStream &roadStream, const ObjectPosition &objectPos, const std::optional< double > objectReferenceS, const ObjectPosition &targetObjectPos) const | WorldDataQuery |
GetDistanceToEndOfLane(const LaneMultiStream &laneStream, double initialSearchPosition, double maxSearchLength, const std::vector< LaneType > &requestedLaneTypes) const | WorldDataQuery |
GetDistanceUntilObjectEntersConnector(const ObjectPosition position, std::string intersectingConnectorId, int intersectingLaneId, std::string ownConnectorId) const | WorldDataQuery |
GetDistanceUntilObjectLeavesConnector(const ObjectPosition position, std::string intersectingConnectorId, int intersectingLaneId, std::string ownConnectorId) const | WorldDataQuery |
GetIntersectingConnections(std::string connectingRoadId) const | WorldDataQuery |
GetJunctionByOdId(const std::string &odJunctionId) const | WorldDataQuery |
GetJunctionOfConnector(const std::string &connectingRoadId) const | WorldDataQuery |
GetLaneByOdId(std::string odRoadId, OWL::OdId odLaneId, double distance) const | WorldDataQuery |
GetLaneMarkings(const LaneMultiStream &laneStream, double startDistance, double range, Side side) const | WorldDataQuery |
GetLanesOfLaneTypeAtDistance(std::string roadId, double distance, std::list< LaneType > requestedLaneTypes) const | WorldDataQuery |
GetMovingObjectsInRangeOfJunctionConnection(std::string connectingRoadId, double range) const | WorldDataQuery |
GetObjectsOfTypeInRange(const LaneStream &laneStream, const double startDistance, const double endDistance) const | WorldDataQuery | inline
GetObjectsOfTypeInRange(const LaneMultiStream &laneStream, const double startDistance, const double endDistance) const | WorldDataQuery | inline
GetObstruction(const LaneMultiStream &laneStream, double tCoordinate, const ObjectPosition &otherPosition, const std::vector< Common::Vector2d > &objectCorners, const Common::Vector2d &mainLaneLocator) const | WorldDataQuery |
GetOriginatingRouteLane(std::vector< RouteElement > route, std::string startRoadId, OWL::OdId startLaneId, double startDistance) const | WorldDataQuery | private
GetPositionByDistanceAndLane(const OWL::Interfaces::Lane &lane, double distanceOnLane, double offset) const | WorldDataQuery |
GetPrioritiesOnJunction(std::string junctionId) const | WorldDataQuery |
GetRelativeJunctions(const RoadMultiStream &roadStream, double startPosition, double range) const | WorldDataQuery |
GetRelativeLanes(const RoadMultiStream &roadStream, double startPosition, int startLaneId, double range) const | WorldDataQuery |
GetRoadByOdId(std::string odRoadId) const | WorldDataQuery |
GetRoadMarkingsInRange(LaneMultiStream laneStream, double startDistance, double searchRange) const | WorldDataQuery |
GetRouteLeadingToConnector(std::string connectingRoadId) const | WorldDataQuery | private
GetSectionByDistance(std::string odRoadId, double distance) const | WorldDataQuery |
GetTrafficSignsInRange(LaneMultiStream laneStream, double startDistance, double searchRange) const | WorldDataQuery |
IsSValidOnLane(std::string roadId, OWL::OdId laneId, double distance) | WorldDataQuery |
ObjectIsOfTypeAndWithinRange(const OWL::Interfaces::WorldObject *const worldObject, const double minS, const double maxS, const LaneStreamInfo &lane) const | WorldDataQuery | inline
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

WorldImplementation Member List

This is the complete list of members for WorldImplementation, including all inherited members.

Log(CbkLogLevel logLevel, const char *file, int line, const std::string &message) WorldImplementation inlineprotected
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

WorldObjectAdapter Member List

This is the complete list of members for WorldObjectAdapter, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

WorldParameter Member List

This is the complete list of members for WorldParameter, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

externalParameter< ValueType > Member List

This is the complete list of members for externalParameter< ValueType >, including all inherited members.

externalParameter(int id, std::map< int, externalParameter< ValueType > * > *externalParameterMap) | externalParameter< ValueType > | inline
GetId() | externalParameter< ValueType > | inline
GetValue() | externalParameter< ValueType > | inline
id | externalParameter< ValueType > | private
SetValue(ValueType value) | externalParameter< ValueType > | inline
value | externalParameter< ValueType > | private
~externalParameter()=default | externalParameter< ValueType > | virtual
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • ByEntityCondition
ByEntityCondition Member List

This is the complete list of members for ByEntityCondition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • ByValueCondition
ByValueCondition Member List

This is the complete list of members for ByValueCondition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • ReachPositionCondition
ReachPositionCondition Member List

This is the complete list of members for ReachPositionCondition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • RelativeSpeedCondition
RelativeSpeedCondition Member List

This is the complete list of members for RelativeSpeedCondition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • ScenarioImporterHelper
ScenarioImporterHelper Member List

This is the complete list of members for ScenarioImporterHelper, including all inherited members.

GetTrajectoryElementFromCatalog(const std::string &catalogName, const std::string &catalogPath, const std::string &entryName, openScenario::Parameters &parameters) | ScenarioImporterHelper | privatestatic
ImportEntityAction(QDomElement entityActionElement, Parameters &parameters) | ScenarioImporterHelper | privatestatic
ImportGlobalAction(QDomElement globalActionElement, Parameters &parameters) | ScenarioImporterHelper | static
ImportLanePosition(QDomElement positionElement, Parameters &parameters) | ScenarioImporterHelper | privatestatic
ImportLateralAction(QDomElement lateralActionElement, Parameters &parameters) | ScenarioImporterHelper | privatestatic
ImportLongitudinalAction(QDomElement longitudinalActionElement, Parameters &parameters) | ScenarioImporterHelper | privatestatic
ImportOrientation(QDomElement &orientationElement, Parameters &parameters) | ScenarioImporterHelper | privatestatic
ImportPosition(QDomElement root, Parameters &parameters) | ScenarioImporterHelper | static
ImportPrivateAction(QDomElement privateActionElement, Parameters &parameters, const std::string catalogPath="") | ScenarioImporterHelper | static
ImportRelativeLanePosition(QDomElement positionElement, Parameters &parameters) | ScenarioImporterHelper | privatestatic
ImportRoadPosition(QDomElement positionElement, Parameters &parameters) | ScenarioImporterHelper | privatestatic
ImportRoutingAction(QDomElement routingActionElement, Parameters &parameters, const std::string catalogPath) | ScenarioImporterHelper | privatestatic
ImportStochastics(QDomElement &stochasticsElement, Parameters &parameters) | ScenarioImporterHelper | privatestatic
ImportTeleportAction(QDomElement teleportActionElement, Parameters &parameters) | ScenarioImporterHelper | privatestatic
ImportUserDefinedAction(QDomElement userDefinedActionElement) | ScenarioImporterHelper | static
ImportVisibilityAction(QDomElement visibilityActionElement, Parameters &parameters) | ScenarioImporterHelper | privatestatic
ImportWorldPosition(QDomElement positionElement, Parameters &parameters) | ScenarioImporterHelper | privatestatic
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • SimulationTimeCondition
SimulationTimeCondition Member List

This is the complete list of members for SimulationTimeCondition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • TimeHeadwayCondition
TimeHeadwayCondition Member List

This is the complete list of members for TimeHeadwayCondition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • TimeToCollisionCondition
TimeToCollisionCondition Member List

This is the complete list of members for TimeToCollisionCondition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • transformation
  • TransformerBase
TransformerBase< T, Signal, TriggeringEvent > Member List

This is the complete list of members for TransformerBase< T, Signal, TriggeringEvent >, including all inherited members.

AgentIsAffected(const int agentId, EventInterface const *event) | TransformerBase< T, Signal, TriggeringEvent > | inlineprivatestatic
Transform(const SimulationSlave::EventNetworkInterface *eventNetwork, WorldInterface *world, AgentInterface *agent, int cycleTime) | TransformerBase< T, Signal, TriggeringEvent > | inlinestatic
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • core
  • Directories
Directories Member List

This is the complete list of members for Directories, including all inherited members.

Concat(const std::string &path, const std::string &file) | Directories | static
Concat(const std::string &path, const std::vector< std::string > &filenames) | Directories | static
configurationDir | Directories |
IsRelative(const std::string &path) | Directories | static
libraryDir | Directories |
outputDir | Directories |
Resolve(const std::string &applicationPath, const std::string &path) | Directories | privatestatic
StripFile(const std::string &path) | Directories | static
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • events
  • BasicEvent
BasicEvent< EventCategory > Member List

This is the complete list of members for BasicEvent< EventCategory >, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • events
  • CollisionEvent
CollisionEvent Member List

This is the complete list of members for CollisionEvent, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • events
  • ComponentStateChangeEvent
ComponentStateChangeEvent Member List

This is the complete list of members for ComponentStateChangeEvent, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • events
  • LaneChangeEvent
LaneChangeEvent Member List

This is the complete list of members for LaneChangeEvent, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • events
  • SpeedActionEvent
SpeedActionEvent Member List

This is the complete list of members for SpeedActionEvent, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • events
  • TrajectoryEvent
TrajectoryEvent Member List

This is the complete list of members for TrajectoryEvent, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • parameter
  • ExponentialDistribution
ExponentialDistribution Member List

This is the complete list of members for ExponentialDistribution, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • parameter
  • GammaDistribution
GammaDistribution Member List

This is the complete list of members for GammaDistribution, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • parameter
  • LogNormalDistribution
LogNormalDistribution Member List

This is the complete list of members for LogNormalDistribution, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • parameter
  • NormalDistribution
NormalDistribution Member List

This is the complete list of members for NormalDistribution, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • parameter
  • UniformDistribution
UniformDistribution Member List

This is the complete list of members for UniformDistribution, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • publisher
  • AgentDataPublisher
AgentDataPublisher Member List

This is the complete list of members for AgentDataPublisher, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • publisher
  • CoreDataPublisher
CoreDataPublisher Member List

This is the complete list of members for CoreDataPublisher, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • publisher
  • LogEntry
LogEntry Member List

This is the complete list of members for LogEntry, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • publisher
  • LogEntryBase
LogEntryBase Member List

This is the complete list of members for LogEntryBase, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • AgentParser
AgentParser Member List

This is the complete list of members for AgentParser, including all inherited members.

Parse(const SimulationSlave::Agent &agent) AgentParser
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • EventDetectorTaskItem
EventDetectorTaskItem Member List

This is the complete list of members for EventDetectorTaskItem, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • ManipulatorTaskItem
ManipulatorTaskItem Member List

This is the complete list of members for ManipulatorTaskItem, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • ObservationTaskItem
ObservationTaskItem Member List

This is the complete list of members for ObservationTaskItem, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • Scheduler
Scheduler Member List

This is the complete list of members for Scheduler, including all inherited members.

ExecuteTasks(T tasks) | Scheduler | private
Run(int startTime, int endTime, SimulationSlave::RunResult &runResult, SimulationSlave::EventNetworkInterface &eventNetwork) | Scheduler |
ScheduleAgentTasks(SchedulerTasks &taskList, const SimulationSlave::Agent &agent) | Scheduler |
UpdateAgents(SchedulerTasks &taskList, WorldInterface &world) | Scheduler | private
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • SchedulerTasks
SchedulerTasks Member List

This is the complete list of members for SchedulerTasks, including all inherited members.

ClearNonrecurringTasks() | SchedulerTasks | private
ConsumeNonRecurringAgentTasks(int timestamp) | SchedulerTasks |
CreateNewScheduledTimestamps() | SchedulerTasks | private
DeleteAgentTasks(std::list< int > &agents) | SchedulerTasks |
DeleteAgentTasks(int agentId) | SchedulerTasks |
ExpandUpperBoundary(int timestamp) | SchedulerTasks | private
GetBootstrapTasks() | SchedulerTasks |
GetFinalizeTasks() | SchedulerTasks |
GetNextTimestamp(int timestamp) | SchedulerTasks |
GetRecurringAgentTasks(int timestamp) | SchedulerTasks |
GetSpawningTasks(int timestamp) | SchedulerTasks |
GetTasks(int timestamp) | SchedulerTasks |
GetTasks(int timestamp, std::multiset< TaskItem > &tasks, std::list< TaskItem > &currentTasks) | SchedulerTasks | private
PullNonRecurringTasks(int timestamp, std::list< TaskItem > &currentTasks) | SchedulerTasks |
ScheduleNewNonRecurringTasks(std::list< TaskItem > newTasks) | SchedulerTasks |
ScheduleNewRecurringTasks(std::list< TaskItem > newTasks) | SchedulerTasks |
ScheduleNewTasks(Tasks &tasks, std::list< TaskItem > newTasks) | SchedulerTasks | private
UpdateScheduledTimestamps(int cycleTime, int delay) | SchedulerTasks | private
UpdateScheduledTimestamps(std::multiset< TaskItem > &tasks) | SchedulerTasks | private
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • SpawningTaskItem
SpawningTaskItem Member List

This is the complete list of members for SpawningTaskItem, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • SyncWorldTaskItem
SyncWorldTaskItem Member List

This is the complete list of members for SyncWorldTaskItem, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • TaskBuilder
TaskBuilder Member List

This is the complete list of members for TaskBuilder, including all inherited members.

BuildEventDetectorTasks() | TaskBuilder | private
BuildManipulatorTasks() | TaskBuilder | private
CreateBootstrapTasks() override | TaskBuilder | virtual
CreateFinalizeTasks() override | TaskBuilder | virtual
CreateSpawningTasks() override | TaskBuilder | virtual
CreateSynchronizeTasks() override | TaskBuilder | virtual
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • TaskBuilderInterface
TaskBuilderInterface Member List

This is the complete list of members for TaskBuilderInterface, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • TaskItem
TaskItem Member List

This is the complete list of members for TaskItem, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • Tasks
Tasks Member List

This is the complete list of members for Tasks, including all inherited members.

AddTask(const TaskItem &newTask) | Tasks
DeleteTasks(int agentId) | Tasks
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • TimeKeeper
TimeKeeper Member List

This is the complete list of members for TimeKeeper, including all inherited members.

Now() noexcept | TimeKeeper | inlinestatic
Now() noexcept | TimeKeeper | inlinestatic
time | TimeKeeper | inlineprotectedstatic
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • TriggerTaskItem
TriggerTaskItem Member List

This is the complete list of members for TriggerTaskItem, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • UpdateGlobalDrivingViewTaskItem
UpdateGlobalDrivingViewTaskItem Member List

This is the complete list of members for UpdateGlobalDrivingViewTaskItem, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • scheduling
  • UpdateTaskItem
UpdateTaskItem Member List

This is the complete list of members for UpdateTaskItem, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Action_LongitudinalDriver/src Directory Reference

  • src
  • components
  • Action_LongitudinalDriver
  • src
src Directory Reference
Directory dependency graph for src:

Files

file longitudinalDriver.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/Spawners/SpawnPoint_Start Directory Reference

  • src
  • core
  • slave
  • modules
  • Spawners
  • SpawnPoint_Start
SpawnPoint_Start Directory Reference
Directory dependency graph for SpawnPoint_Start:

Files

file | spawnpoint_start.h
Interface-file for class Spawnpoint_Start.
file | spawnpoint_start_global.h
This file contains DLL export declarations.
file | spawnpoint_start_implementation.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/EventDetector/Conditions Directory Reference

  • src
  • core
  • slave
  • modules
  • EventDetector
  • Conditions
Conditions Directory Reference
Directory dependency graph for Conditions:

Files

file | ConditionCommonBase.h
file | ReachPositionCondition.h
file | SimulationTimeCondition.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/master/importer Directory Reference

  • src
  • core
  • master
  • importer
importer Directory Reference
Directory dependency graph for importer:

Files

file masterConfigImporter.h
This file contains the importer of the master configuration.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/BasicDataStore Directory Reference

  • src
  • core
  • slave
  • modules
  • BasicDataStore
BasicDataStore Directory Reference
Directory dependency graph for BasicDataStore:

Files

file | basicDataStore.h
This file provides the exported methods.
file | basicDataStoreGlobal.h
This file contains DLL export declarations.
file | basicDataStoreImplementation.h
Stores data sent by publishers and provides acces to this data for observers.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/bindings Directory Reference

  • src
  • core
  • slave
  • bindings
bindings Directory Reference
Directory dependency graph for bindings:

Files

file | dataStore.h
This file provides the interface to a data store implementation.
file | dataStoreBinding.h
This file contains the interface to the dataStore library.
file | dataStoreLibrary.h
This file contains the internal representation of the library of a dataStoreInterface.
file | eventDetectorBinding.h
This file contains the interface to the event detector libraries.
file | eventDetectorLibrary.h
This file contains the internal representation of the library of a event detector.
file | manipulatorBinding.h
This file contains the interface to the event detector libraries.
file | manipulatorLibrary.h
This file contains the internal representation of the library of a manipulator.
file | modelBinding.h
This file contains the interface to the model libraries.
file | modelLibrary.h
This file contains the internal representation of the library of a model.
file | observationBinding.h
This file contains the interface to the observation module libraries.
file | observationLibrary.h
This file contains the internal representation of the library of an observation module.
file | spawnPointBinding.h
This file contains the interface to the spawn point libraries.
file | spawnPointLibrary.h
This file contains the internal representation of the library of a spawn point.
file | stochastics.h
file | stochasticsBinding.h
This file contains the interface to the stochastics library.
file | stochasticsLibrary.h
This file contains the internal representation of the library of a stochasticsInterface.
file | world.h
file | worldBinding.h
This file contains the interface to the world library.
file | worldLibrary.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/Observation_LogAgent Directory Reference

  • src
  • core
  • slave
  • modules
  • Observation_LogAgent
Observation_LogAgent Directory Reference
Directory dependency graph for Observation_LogAgent:

Files

file | observation_log.h
file | observation_LogGlobal.h
file | observation_logImplementation.h
file | observationCyclics.h
file | observationFileHandler.h
file | observationLogConstants.h
file | runStatistic.h
file | runStatisticCalculation.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Algorithm_AEB/src Directory Reference

  • src
  • components
  • Algorithm_AEB
  • src
src Directory Reference
Directory dependency graph for src:

Files

file | autonomousEmergencyBraking.h
file | boundingBoxCalculation.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Sensor_RecordState/src Directory Reference

  • src
  • components
  • Sensor_RecordState
  • src
src Directory Reference
Directory dependency graph for src:

Files

file sensor_recordStateImpl.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Dynamics_CollisionPostCrash/src Directory Reference

  • src
  • components
  • Dynamics_CollisionPostCrash
  • src
src Directory Reference
Directory dependency graph for src:

Files

file collisionPostCrash.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components Directory Reference

  • src
  • components
components Directory Reference
Directory dependency graph for components:

Directories

directory | Action_BrakeLight_Basic
directory | Action_LongitudinalDriver
directory | Action_SecondaryDriverTasks
directory | AgentUpdater
directory | Algorithm_AEB
directory | Algorithm_CruiseControlByDistance
directory | Algorithm_FmuWrapper
directory | Algorithm_Lateral
directory | Algorithm_Longitudinal
directory | AlgorithmAFDM
directory | ComponentController
directory | Dynamics_Collision
directory | Dynamics_CollisionPostCrash
directory | Dynamics_Longitudinal_Basic
directory | Dynamics_RegularDriving
directory | Dynamics_RegularTwoTrack
directory | Dynamics_TF
directory | LimiterAccVehComp
directory | OpenScenarioActions
directory | Parameters_Vehicle
directory | Sensor_Distance
directory | Sensor_Driver
directory | Sensor_OSI
directory | Sensor_RecordState
directory | SensorFusion_OSI
directory | SignalPrioritizer
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/SensorFusion_OSI/src Directory Reference

  • src
  • components
  • SensorFusion_OSI
  • src
src Directory Reference
Directory dependency graph for src:

Files

file | sensorFusionImpl.h
file | sensorFusionQuery.h
This file provides methods to retrieve structured basic information from sensorData provided by SensorFusionImplementation::Output().
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Algorithm_Longitudinal/src Directory Reference

  • src
  • components
  • Algorithm_Longitudinal
  • src
src Directory Reference
Directory dependency graph for src:

Files

file | algo_longImpl.h
file | longCalcs.h
This file contains the calculations.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/Manipulator/srcCollisionPostCrash Directory Reference

  • src
  • core
  • slave
  • modules
  • Manipulator
  • srcCollisionPostCrash
srcCollisionPostCrash Directory Reference
Directory dependency graph for srcCollisionPostCrash:

Files

file | collisionDetection_Impact_implementation.h
file | polygon.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Sensor_RecordState Directory Reference

  • src
  • components
  • Sensor_RecordState
Sensor_RecordState Directory Reference
Directory dependency graph for Sensor_RecordState:

Directories

directory src

Files

file sensor_recordState.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/framework/scheduler Directory Reference

  • src
  • core
  • slave
  • framework
  • scheduler
scheduler Directory Reference
Directory dependency graph for scheduler:

Files

file | agentParser.h
The Parser generates all component tasks for an given agent.
file | runResult.h
This file represents the result of a simulation run.
file | scheduler.h
file | schedulerTasks.h
This file contains the generic schedule managing component.
file | taskBuilder.h
This file contains the logic of unchangeable tasks.
file | tasks.h
This file contains TaskItem and Tasks.
file | timeKeeper.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/Spawners/PreRunCommon Directory Reference

  • src
  • core
  • slave
  • modules
  • Spawners
  • PreRunCommon
PreRunCommon Directory Reference
Directory dependency graph for PreRunCommon:

Files

file | SpawnPointPreRunCommon.h
file | SpawnPointPreRunCommonDefinitions.h
file | SpawnPointPreRunCommonExport.h
file | SpawnPointPreRunCommonGlobal.h
file | SpawnPointPreRunCommonParameterExtractor.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Dynamics_RegularDriving/src Directory Reference

  • src
  • components
  • Dynamics_RegularDriving
  • src
src Directory Reference
Directory dependency graph for src:

Files

file regularDriving.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/common/cephes Directory Reference

  • src
  • core
  • common
  • cephes
cephes Directory Reference
Directory dependency graph for cephes:

Files

file mconf.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Parameters_Vehicle Directory Reference

  • src
  • components
  • Parameters_Vehicle
Parameters_Vehicle Directory Reference
Directory dependency graph for Parameters_Vehicle:

Directories

directory src

Files

file parameters_vehicle.h
This file provides the exported methods.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/Observation_Log Directory Reference

  • src
  • core
  • slave
  • modules
  • Observation_Log
Observation_Log Directory Reference
Directory dependency graph for Observation_Log:

Files

file | observation_log.h
file | observation_LogGlobal.h
file | observation_logImplementation.h
file | observationCyclics.h
file | observationFileHandler.h
file | observationLogConstants.h
file | runStatistic.h
file | runStatisticCalculation.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/World_OSI/OWL/fakes Directory Reference

  • src
  • core
  • slave
  • modules
  • World_OSI
  • OWL
  • fakes
fakes Directory Reference
Directory dependency graph for fakes:

Files

file | fakeLane.h
file | fakeLaneBoundary.h
file | fakeLaneManager.h
file | fakeMovingObject.h
file | fakeOWLJunction.h
file | fakeRoad.h
file | fakeRoadMarking.h
file | fakeSection.h
file | fakeTrafficSign.h
file | fakeWorldData.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modelElements Directory Reference

  • src
  • core
  • slave
  • modelElements
modelElements Directory Reference
Directory dependency graph for modelElements:

Files

file | agent.h
This file contains the internal representation of an agent instance during a simulation run.
file | agentBlueprint.h
This file stores all information which is necessary to instantiate an agent.
file | agentType.h
This file contains the internal representation of an agent type as given by the configuration.
file | channel.h
This file contains the internal representation of a channel instance during a simulation run.
file | channelBuffer.h
This file contains a buffer which stores the data of a channel.
file | component.h
This file contains the internal representation of a model component during a simulation run.
file | componentType.h
This file contains the internal representation of the type of a model component as given by the configuration.
file | eventDetector.h
This file contains the internal representation of the a event detector.
file | eventDetectorNetwork.h
file | manipulator.h
This file contains the internal representation of the manipulator.
file | manipulatorNetwork.h
file | spawnItemParameter.h
This file contains the internal representation of parameter set of a newly created agent spawn item.
file | spawnPoint.h
This file contains the internal representation of the a spawn point.
file | spawnPointNetwork.h
This file implements a container of the spawn points during a simulation run.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Sensor_OSI Directory Reference

  • src
  • components
  • Sensor_OSI
Sensor_OSI Directory Reference
Directory dependency graph for Sensor_OSI:

Directories

directory src

Files

file sensorOSI.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Algorithm_FmuWrapper/src Directory Reference

  • src
  • components
  • Algorithm_FmuWrapper
  • src
src Directory Reference
Directory dependency graph for src:

Directories

directory FmiImporter

Files

file | fmuWrapper.h
file | OsmpFmuHandler.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Sensor_Driver/src/Signals Directory Reference

  • src
  • components
  • Sensor_Driver
  • src
  • Signals
Signals Directory Reference
Directory dependency graph for Signals:

Files

file | sensor_driverDefinitions.h
This file contains several classes for sensor driver purposes.
file | sensorDriverSignal.h
This file contains all functions for class SensorDriverSignal.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/common Directory Reference

  • src
  • core
  • common
common Directory Reference
Directory dependency graph for common:

Directories

directory | cephes
directory | cephesMIT

Files

file | callbacks.h
This file contains the implementation of the model callbacks to interact with the framework.
file | coreDataPublisher.h
file | log.h
This file contains the implementation of the debug logging.
file | parameters.h
This file contains the interface of the internal representation of configuration parameters.
file | timeKeeper.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Action_SecondaryDriverTasks/src Directory Reference

  • src
  • components
  • Action_SecondaryDriverTasks
  • src
src Directory Reference
Directory dependency graph for src:

Files

file secondaryDriverTasks.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Sensor_OSI/src Directory Reference

  • src
  • components
  • Sensor_OSI
  • src
src Directory Reference
Directory dependency graph for src:

Files

file | objectDetectorBase.h
file | sensorGeometric2D.h
This file models a sensor which only detects agents in a 2D area (x/y) in front of the agent.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/World_OSI/OWL Directory Reference

  • src
  • core
  • slave
  • modules
  • World_OSI
  • OWL
OWL Directory Reference
Directory dependency graph for OWL:

Directories

directory fakes

Files

file | DataTypes.h
This file provides the basic datatypes of the osi world layer (OWL)
file | LaneGeometryElement.h
file | LaneGeometryJoint.h
file | OpenDriveTypeMapper.h
This file provides conversions from OpenDRIVE constants to OSI constants.
file | Primitives.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/Spawners/RuntimeCommon Directory Reference

  • src
  • core
  • slave
  • modules
  • Spawners
  • RuntimeCommon
RuntimeCommon Directory Reference
Directory dependency graph for RuntimeCommon:

Files

file | SpawnPointRuntimeCommon.h
file | SpawnPointRuntimeCommonDefinitions.h
file | SpawnPointRuntimeCommonExport.h
file | SpawnPointRuntimeCommonGlobal.h
file | SpawnPointRuntimeCommonParameterExtractor.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/World_OSI/RoutePlanning Directory Reference

  • src
  • core
  • slave
  • modules
  • World_OSI
  • RoutePlanning
RoutePlanning Directory Reference
Directory dependency graph for RoutePlanning:

Files

file RouteCalculation.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Algorithm_FmuWrapper/src/FmiImporter Directory Reference

  • src
  • components
  • Algorithm_FmuWrapper
  • src
  • FmiImporter
FmiImporter Directory Reference
Directory dependency graph for FmiImporter:

Directories

directory include
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Action_LongitudinalDriver Directory Reference

  • src
  • components
  • Action_LongitudinalDriver
Action_LongitudinalDriver Directory Reference
Directory dependency graph for Action_LongitudinalDriver:

Directories

directory src

Files

file action_longitudinalDriver.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/AlgorithmAFDM/src Directory Reference

  • src
  • components
  • AlgorithmAFDM
  • src
src Directory Reference
Directory dependency graph for src:

Files

file followingDriverModel.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/SensorFusion_OSI Directory Reference

  • src
  • components
  • SensorFusion_OSI
SensorFusion_OSI Directory Reference
Directory dependency graph for SensorFusion_OSI:

Directories

directory src

Files

file sensorFusion.h
This file provides the exported methods.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Algorithm_AEB Directory Reference

  • src
  • components
  • Algorithm_AEB
Algorithm_AEB Directory Reference
Directory dependency graph for Algorithm_AEB:

Directories

directory src

Files

file algorithm_autonomousEmergencyBraking.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Dynamics_TF Directory Reference

  • src
  • components
  • Dynamics_TF
Dynamics_TF Directory Reference
Directory dependency graph for Dynamics_TF:

Directories

directory src

Files

file dynamics_tf.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Algorithm_Lateral/src Directory Reference

  • src
  • components
  • Algorithm_Lateral
  • src
src Directory Reference
Directory dependency graph for src:

Files

file | lateralImpl.h
file | steeringController.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Sensor_Driver Directory Reference

  • src
  • components
  • Sensor_Driver
Sensor_Driver Directory Reference
Directory dependency graph for Sensor_Driver:

Directories

directory src

Files

file sensor_driver.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/AgentUpdater Directory Reference

  • src
  • components
  • AgentUpdater
AgentUpdater Directory Reference
Directory dependency graph for AgentUpdater:

Directories

directory src

Files

file agentUpdater.h
This file provides the exported methods.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/AgentUpdater/src Directory Reference

  • src
  • components
  • AgentUpdater
  • src
src Directory Reference
Directory dependency graph for src:

Files

file agentUpdaterImpl.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/LimiterAccVehComp/src Directory Reference

  • src
  • components
  • LimiterAccVehComp
  • src
src Directory Reference
Directory dependency graph for src:

Files

file limiterAccVehCompImpl.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Dynamics_TF/src Directory Reference

  • src
  • components
  • Dynamics_TF
  • src
src Directory Reference
Directory dependency graph for src:

Files

file tfImplementation.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/LimiterAccVehComp Directory Reference

  • src
  • components
  • LimiterAccVehComp
LimiterAccVehComp Directory Reference
Directory dependency graph for LimiterAccVehComp:

Directories

directory src

Files

file limiterAccVehComp.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Parameters_Vehicle/src Directory Reference

  • src
  • components
  • Parameters_Vehicle
  • src
src Directory Reference
Directory dependency graph for src:

Files

file parameters_vehicleImpl.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/Spawners Directory Reference

  • src
  • core
  • slave
  • modules
  • Spawners
Spawners Directory Reference
Directory dependency graph for Spawners:

Directories

directory | common
directory | PreRunCommon
directory | RuntimeCommon
directory | Scenario
directory | SpawnPoint_Start
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Dynamics_RegularTwoTrack Directory Reference

  • src
  • components
  • Dynamics_RegularTwoTrack
Dynamics_RegularTwoTrack Directory Reference
Directory dependency graph for Dynamics_RegularTwoTrack:

Directories

directory src

Files

file dynamics_regularTwoTrack.h
This file provides the exported methods.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/importer/road Directory Reference

  • src
  • core
  • slave
  • importer
  • road
road Directory Reference
Directory dependency graph for road:

Files

file | roadObject.h
file | roadSignal.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/ComponentController Directory Reference

  • src
  • components
  • ComponentController
ComponentController Directory Reference
Directory dependency graph for ComponentController:

Directories

directory src

Files

file componentController.h
This file provides the exported methods.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Dynamics_RegularDriving Directory Reference

  • src
  • components
  • Dynamics_RegularDriving
Dynamics_RegularDriving Directory Reference
Directory dependency graph for Dynamics_RegularDriving:

Directories

directory src

Files

file dynamics_regularDriving.h
This file provides the exported methods.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/common/cephesMIT Directory Reference

  • src
  • core
  • common
  • cephesMIT
cephesMIT Directory Reference
Directory dependency graph for cephesMIT:

Files

file mconf.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src Directory Reference

  • src
src Directory Reference
Directory dependency graph for src:

Directories

directory | common
directory | components
directory | core
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/EventDetector Directory Reference

  • src
  • core
  • slave
  • modules
  • EventDetector
EventDetector Directory Reference
Directory dependency graph for EventDetector:

Directories

directory Conditions

Files

file | CollisionDetector.h
Detects wether agents collided.
file | ConditionalEventDetector.h
file | EventDetectorCommonBase.h
file | EventDetectorExport.h
This file provides the exported methods.
file | EventDetectorGlobal.h
This file contains DLL export declarations.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/OpenScenarioActions/src Directory Reference

  • src
  • components
  • OpenScenarioActions
  • src
src Directory Reference
Directory dependency graph for src:

Files

file | actionTransformRepository.h
file | openScenarioActionsImpl.h
file | oscActionsCalculation.h
file | transformerBase.h
file | transformLaneChange.h
file | transformSpeedAction.h
file | transformTrajectory.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/framework Directory Reference

  • src
  • core
  • slave
  • framework
framework Directory Reference
Directory dependency graph for framework:

Directories

directory scheduler

Files

file | agentBlueprintProvider.h
This file contains the AgentBlueprintProvider, which creates agentBlueprints according to either a given SceneryConfiguration or based on a sampled agent.
file | agentDataPublisher.h
file | agentFactory.h
This file contains the singleton which creates agent instances.
file | commandLineParser.h
file | configurationContainer.h
This file stores all configurations.
file | directories.h
file | dynamicAgentTypeGenerator.h
file | dynamicParametersSampler.h
file | dynamicProfileSampler.h
file | eventNetwork.h
The EventNetwork manages events and can trigger functions in different framework modules.
file | frameworkModuleContainer.h
This file stores all core framework modules.
file | observationModule.h
This file contains the internal representation of an observation module.
file | observationNetwork.h
This file implements the container of all observation modules.
file | parameterbuilder.h
file | runInstantiator.h
This file contains the component which triggers the simulation runs.
file | sampler.h
This file contains the Sampler, which samples parameters and probabilities.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Sensor_Driver/src Directory Reference

  • src
  • components
  • Sensor_Driver
  • src
src Directory Reference
Directory dependency graph for src:

Directories

directory Signals

Files

file | sensor_driverCalculations.h
file | sensor_driverImpl.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Dynamics_Collision/src Directory Reference

  • src
  • components
  • Dynamics_Collision
  • src
src Directory Reference
Directory dependency graph for src:

Files

file collisionImpl.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Action_SecondaryDriverTasks Directory Reference

  • src
  • components
  • Action_SecondaryDriverTasks
Action_SecondaryDriverTasks Directory Reference
Directory dependency graph for Action_SecondaryDriverTasks:

Directories

directory src

Files

file action_secondaryDriverTasks.h
This file provides the exported methods.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Algorithm_CruiseControlByDistance Directory Reference

  • src
  • components
  • Algorithm_CruiseControlByDistance
Algorithm_CruiseControlByDistance Directory Reference
Directory dependency graph for Algorithm_CruiseControlByDistance:

Files

file | algorithm_cruisecontrolbydistance.h
Interface-file for class Algorithm_CruiseControlByDistance.
file | algorithm_cruisecontrolbydistance_global.h
This file contains DLL export declarations.
file | algorithm_cruisecontrolbydistance_implementation.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/importer Directory Reference

  • src
  • core
  • slave
  • importer
importer Directory Reference
Directory dependency graph for importer:

Directories

directory road

Files

file | configurationFiles.h
file | connection.h
file | csvParser.h
file | eventDetectorImporter.h
file | frameworkModules.h
file | importerLoggingHelper.h
file | junction.h
file | oscImporterCommon.h
file | parameterImporter.h
file | profiles.h
file | profilesImporter.h
file | road.h
This file contains the internal representation of a road in a scenery.
file | scenario.h
This file contains all information for the choosen scenario.
file | scenarioImporter.h
This file contains the importer of the scenario.
file | scenarioImporterHelper.h
This file contains the helper class of the scenario importer.
file | scenery.h
This file contains the representation of the static objects of the scenery.
file | sceneryImporter.h
This file contains the importer of the scenery configuration.
file | slaveConfig.h
file | slaveConfigImporter.h
This file contains the importer of the slave configuration.
file | systemConfig.h
file | systemConfigImporter.h
file | vehicleModels.h
file | vehicleModelsImporter.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Dynamics_Collision Directory Reference

  • src
  • components
  • Dynamics_Collision
Dynamics_Collision Directory Reference
Directory dependency graph for Dynamics_Collision:

Directories

directory src

Files

file dynamics_collision.h
This file provides the exported methods.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core Directory Reference

  • src
  • core
core Directory Reference
Directory dependency graph for core:

Directories

directory | common
directory | master
directory | slave
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/master Directory Reference

  • src
  • core
  • master
master Directory Reference
Directory dependency graph for master:

Directories

directory | framework
directory | importer

Files

file openPassMaster.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Dynamics_Longitudinal_Basic Directory Reference

  • src
  • components
  • Dynamics_Longitudinal_Basic
Dynamics_Longitudinal_Basic Directory Reference
Directory dependency graph for Dynamics_Longitudinal_Basic:

Files

file | dynamics_longitudinal_basic.h
Interface-file for class Dynamics_Longitudinal_Basic.
file | dynamics_longitudinal_basic_global.h
contains DLL export declarations
file | dynamics_longitudinal_basic_implementation.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/World_Basic Directory Reference

  • src
  • core
  • slave
  • modules
  • World_Basic
World_Basic Directory Reference
Directory dependency graph for World_Basic:

Files

file | agentAdapter.h
file | agentNetwork.h
file | world_basic.h
Interface-file for class World.
file | world_basic_global.h
This file contains DLL export declarations.
file | world_basic_implementation.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/common/events Directory Reference

  • src
  • common
  • events
events Directory Reference
Directory dependency graph for events:

Files

file | basicEvent.h
This file contains all basic functionality of events.
file | collisionEvent.h
This file contains all functions for collision based events.
file | componentStateChangeEvent.h
file | laneChangeEvent.h
file | speedActionEvent.h
file | trajectoryEvent.h
This file contains all functions for agent based events.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/Stochastics Directory Reference

  • src
  • core
  • slave
  • modules
  • Stochastics
Stochastics Directory Reference
Directory dependency graph for Stochastics:

Files

file | stochastics.h
file | stochastics_global.h
file | stochastics_implementation.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/Observation_Ttc Directory Reference

  • src
  • core
  • slave
  • modules
  • Observation_Ttc
Observation_Ttc Directory Reference
Directory dependency graph for Observation_Ttc:

Files

file | observation_ttc.h
Interface-file for class Observation_Ttc.
file | observation_ttc_global.h
This file contains DLL export declarations.
file | observation_ttc_implementation.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Algorithm_FmuWrapper/src/FmiImporter/include Directory Reference

  • src
  • components
  • Algorithm_FmuWrapper
  • src
  • FmiImporter
  • include
include Directory Reference
Directory dependency graph for include:

Files

file | fmi1_input_reader.h
file | fmi2_input_reader.h
file | fmuChecker.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/World_OSI Directory Reference

  • src
  • core
  • slave
  • modules
  • World_OSI
World_OSI Directory Reference
Directory dependency graph for World_OSI:

Directories

directory | OWL
directory | RoutePlanning

Files

file | AgentAdapter.h
file | AgentNetwork.h
file | egoAgent.h
file | GeometryConverter.h
This file contains the converter of the scenery geometry.
file | JointsBuilder.h
file | Localization.h
file | LocalizationElement.h
file | PointQuery.h
file | RamerDouglasPeucker.h
file | SceneryConverter.h
This file contains the converter of the scenery configuration.
file | TrafficObjectAdapter.h
file | World.h
file | WorldData.h
This file provides access to underlying data structures for scenery and dynamic objects.
file | WorldDataException.h
This file provides exceptions for the OWL.
file | WorldDataQuery.h
file | WorldGlobal.h
This file contains DLL export declarations.
file | WorldImplementation.h
file | WorldObjectAdapter.h
file | WorldToRoadCoordinateConverter.h
Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/SignalPrioritizer Directory Reference

  • src
  • components
  • SignalPrioritizer
SignalPrioritizer Directory Reference
Directory dependency graph for SignalPrioritizer:

Directories

directory src

Files

file signalPrioritizer.h
This file provides the exported methods.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Action_BrakeLight_Basic Directory Reference

  • src
  • components
  • Action_BrakeLight_Basic
Action_BrakeLight_Basic Directory Reference
Directory dependency graph for Action_BrakeLight_Basic:

Files

file | action_brakelight_basic.h
Interface-file for class Action_BrakeLight.
file | action_brakelight_basic_global.h
contains DLL export declarations
file | action_brakelight_basic_implementation.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Sensor_Distance Directory Reference

  • src
  • components
  • Sensor_Distance
Sensor_Distance Directory Reference
Directory dependency graph for Sensor_Distance:

Files

file | sensor_distance.h
Interface-file for class Sensor_Distance.
file | sensor_distance_global.h
This file contains DLL export declarations.
file | sensor_distance_implementation.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/Manipulator Directory Reference

  • src
  • core
  • slave
  • modules
  • Manipulator
Manipulator Directory Reference
Directory dependency graph for Manipulator:

Directories

directory srcCollisionPostCrash

Files

file | CollisionManipulator.h
This file notifies all necessary modules about the collision.
file | ComponentStateChangeManipulator.h
This manipulator toggles the max state of a component.
file | CustomCommandFactory.h
file | LaneChangeManipulator.h
This file removes the agent.
file | ManipulatorCommonBase.h
file | ManipulatorExport.h
This file provides the exported methods.
file | ManipulatorGlobal.h
file | NoOperationManipulator.h
file | RemoveAgentsManipulator.h
This file removes the agent.
file | SpeedActionManipulator.h
This manipulator adjusts the acceleration of an actor based on different variables.
file | TrajectoryManipulator.h
This manipulator sets a trajectory for an agent.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Dynamics_RegularTwoTrack/src Directory Reference

  • src
  • components
  • Dynamics_RegularTwoTrack
  • src
src Directory Reference
Directory dependency graph for src:

Files

file | dynamics_regularTwoTrackImpl.h
file | dynamics_twotrack_tire.h
file | dynamics_twotrack_vehicle.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/AlgorithmAFDM Directory Reference

  • src
  • components
  • AlgorithmAFDM
AlgorithmAFDM Directory Reference
Directory dependency graph for AlgorithmAFDM:

Directories

directory src

Files

file AlgorithmAFDM.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Algorithm_FmuWrapper Directory Reference

  • src
  • components
  • Algorithm_FmuWrapper
Algorithm_FmuWrapper Directory Reference
Directory dependency graph for Algorithm_FmuWrapper:

Directories

directory src

Files

file AlgorithmFmuWrapper.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/master/framework Directory Reference

  • src
  • core
  • master
  • framework
framework Directory Reference
Directory dependency graph for framework:

Files

file | masterConfig.h
This file contains the representation of the master configuration.
file | processManager.h
file | slaveConfig.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules Directory Reference

  • src
  • core
  • slave
  • modules
modules Directory Reference
Directory dependency graph for modules:

Directories

directory | BasicDataStore
directory | EventDetector
directory | Manipulator
directory | Observation_Log
directory | Observation_LogAgent
directory | Observation_State
directory | Observation_Ttc
directory | Spawners
directory | Stochastics
directory | World_Basic
directory | World_OSI
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Dynamics_CollisionPostCrash Directory Reference

  • src
  • components
  • Dynamics_CollisionPostCrash
Dynamics_CollisionPostCrash Directory Reference
Directory dependency graph for Dynamics_CollisionPostCrash:

Directories

directory src

Files

file dynamics_collisionPostCrash.h
This file provides the exported methods.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/SignalPrioritizer/src Directory Reference

  • src
  • components
  • SignalPrioritizer
  • src
src Directory Reference
Directory dependency graph for src:

Files

file signalPrioritizerImpl.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave Directory Reference

  • src
  • core
  • slave
slave Directory Reference
Directory dependency graph for slave:

Directories

directory | bindings
directory | framework
directory | importer
directory | modelElements
directory | modules

Files

file OpenPassSlave.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Algorithm_Lateral Directory Reference

  • src
  • components
  • Algorithm_Lateral
Algorithm_Lateral Directory Reference
Directory dependency graph for Algorithm_Lateral:

Directories

directory src

Files

file algorithm_lateral.h
This file provides the exported methods.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/ComponentController/src Directory Reference

  • src
  • components
  • ComponentController
  • src
src Directory Reference
Directory dependency graph for src:

Files

file | componentControllerCommon.h
file | componentControllerImpl.h
file | componentStateInformation.h
This file contains all functions for class ComponentStateInformation.
file | condition.h
file | stateManager.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/Spawners/Scenario Directory Reference

  • src
  • core
  • slave
  • modules
  • Spawners
  • Scenario
Scenario Directory Reference
Directory dependency graph for Scenario:

Files

file | SpawnPointScenario.h
file | SpawnPointScenarioExport.h
file | SpawnPointScenarioGlobal.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/Observation_State Directory Reference

  • src
  • core
  • slave
  • modules
  • Observation_State
Observation_State Directory Reference
Directory dependency graph for Observation_State:

Files

file | observation_state.h
Interface-file for class Observation_State.
file | observation_state_global.h
This file contains DLL export declarations.
file | observation_state_implementation.h
file | observationtypes.h
This file defines all types of data which can be observed.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/Algorithm_Longitudinal Directory Reference

  • src
  • components
  • Algorithm_Longitudinal
Algorithm_Longitudinal Directory Reference
Directory dependency graph for Algorithm_Longitudinal:

Directories

directory src

Files

file algorithm_longitudinal.h
This file provides the exported methods.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/components/OpenScenarioActions Directory Reference

  • src
  • components
  • OpenScenarioActions
OpenScenarioActions Directory Reference
Directory dependency graph for OpenScenarioActions:

Directories

directory src

Files

file openScenarioActions.h
This file provides the exported methods.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/common Directory Reference

  • src
  • common
common Directory Reference
Directory dependency graph for common:

Directories

directory events

Files

file | accelerationSignal.h
This file contains all functions for class AccelerationSignal.
file | agentCompToCompCtrlSignal.h
This file contains all functions for class AgentCompToCompCtrlSignal.
file | boostGeometryCommon.h
file | commonHelper.h
file | commonTools.h
file | compatibility.h
file | compCtrlToAgentCompSignal.h
This file contains all functions for class CompCtrlToAgentCompSignal.
file | componentPorts.h
file | dynamicsSignal.h
This file contains all functions for class DynamicsSignal.
file | eventDetectorDefinitions.h
file | eventTypes.h
file | globalDefinitions.h
This file contains several classes for global purposes.
file | lateralSignal.h
This file contains all functions for class LateralSignal.
file | logEntryBase.h
file | longitudinalSignal.h
file | namedType.h
file | observationLibraryDefinitions.h
file | openPassTypes.h
file | openPassUtils.h
file | openScenarioDefinitions.h
file | opExport.h
file | opMath.h
file | parameter.h
file | parametersVehicleSignal.h
file | postCrashDynamic.h
file | primitiveSignals.h
This file contains an interface to predefined primitive signals for usage by component models.
file | runtimeInformation.h
file | secondaryDriverTasksSignal.h
This file contains all functions for class SecondaryDriverTasksSignal.
file | sensorDataSignal.h
This file contains all functions for class SensorDataSignal.
file | sensorDefinitions.h
file | spawnPointLibraryDefinitions.h
file | speedActionSignal.h
This file contains all functions for class SpeedActionSignal.
file | steeringSignal.h
This file contains all functions for class SteeringSignal.
file | stochasticDefinitions.h
file | trajectorySignal.h
This file contains all functions for class TrajectorySignal.
file | vector2d.h
file | vector3d.h
file | vectorSignals.h
This file contains signals.
file | version.h
file | worldDefinitions.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: C:/Arbeit/050_PASS/eclipse/itk/sim/src/core/slave/modules/Spawners/common Directory Reference

  • src
  • core
  • slave
  • modules
  • Spawners
  • common
common Directory Reference
Directory dependency graph for common:

Files

file | SpawnPointDefinitions.h
file | WorldAnalyzer.h
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

1 /*! Invisible class because of truncation */
2 class Invisible { };
3
4 /*! Truncated class, inheritance relation is hidden */
5 class Truncated : public Invisible { };
6
7 /* Class not documented with doxygen comments */
8 class Undocumented { };
9
10 /*! Class that is inherited using public inheritance */
11 class PublicBase : public Truncated { };
12
13 /*! A template class */
14 template<class T> class Templ { };
15
16 /*! Class that is inherited using protected inheritance */
17 class ProtectedBase { };
18
19 /*! Class that is inherited using private inheritance */
20 class PrivateBase { };
21
22 /*! Class that is used by the Inherited class */
23 class Used { };
24
25 /*! Super class that inherits a number of other classes */
26 class Inherited : public PublicBase,
27 protected ProtectedBase,
28 private PrivateBase,
29 public Undocumented,
30 public Templ<int>
31 {
32 private:
33 Used *m_usedClass;
34 };

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Class Hierarchy

Class Hierarchy

Go to the textual class hierarchy

Generated on Sun Sep 20 2020 11:49:49 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: CommonHelper Namespace Reference

  • Namespace Members
Functions
CommonHelper Namespace Reference

defines common helper functions like conversion from and to enums. More...

Functions

static constexpr bool | DoubleEquality (double value1, double value2, double epsilon=EPSILON)
Treat values smaller than epsilon as zero for geometric calculations.
static double | SetAngleToValidRange (double angel)
Returns the same angle but within the range [-PI, PI].
static std::vector< double > | InterpolateLinear (const double start, const double end, const int totalPoints)
Calculate linear interpolated points with constant spacing. More...
static double | CalcAngleBetweenPoints (const Common::Vector2d &firstPoint, const Common::Vector2d &secondPoint)
static Common::Vector2d | TransformPointToSourcePointCoord (const Common::Vector2d *point, const Common::Vector2d *sourcePoint, double direction)
static double | roundDoubleWithDecimals (double value, int decimals)
Round doubles. More...
static double | CalculateMomentInertiaYaw (double mass, double length, double width)
static std::vector< std::string > | TokenizeString (const std::string &str, const char delimiter= ',')
Tokenizes string by delimiter. More...

Detailed Description

defines common helper functions like conversion from and to enums.

Function Documentation

static std::vector<double> CommonHelper::InterpolateLinear | ( | const double | start,
 |  | const double | end,
 |  | const int | totalPoints
 | ) |  |
static

Calculate linear interpolated points with constant spacing.

Parameters
[in] | start | Start of interval
[in] | end | End of interval
[in] | totalPoints | Total number of points returned (includes start and end point)
Returns
Vector of interpolated points.
static double CommonHelper::CalcAngleBetweenPoints | ( | const Common::Vector2d & | firstPoint,
 |  | const Common::Vector2d & | secondPoint
 | ) |  |
static

Calculate the absolute angle between two pcm points.

Parameters
[in] | firstPoint | firstPoint
[in] | secondPoint | secondPoint
Returns
distance between two pcm points
static Common::Vector2d CommonHelper::TransformPointToSourcePointCoord | ( | const Common::Vector2d * | point,
 |  | const Common::Vector2d * | sourcePoint,
 |  | double | direction
 | ) |  |
static

Transform a pcm point to a vector in the coordination system of a source point in a direction.

Parameters
[in] point point
Returns
vector

Here is the call graph for this function:

static double CommonHelper::roundDoubleWithDecimals | ( | double | value,
 |  | int | decimals
 | ) |  |
static

Round doubles.

Rounds doubles to a given amount of decimals.

Parameters
[in] | value | Value which is rounded
[in] | decimals | Amount of decimals.
Returns
Rounded value.
static double CommonHelper::CalculateMomentInertiaYaw | ( | double | mass,
 |  | double | length,
 |  | double | width
 | ) |  |
static

Estimate the inertial momentum for rotation around the vehicle's z-axis, assuming a cuboid of homogeneous mass density. ( see .e.g. https://en.wikipedia.org/wiki/List_of_moments_of_inertia )

Parameters
[in] | mass | Mass of the vehicle [kg]
[in] | length | Length of the vehicle [m]
[in] | width | Width of the vehicle [m]
Returns
momentInertiaYaw [kg*m^2]
static std::vector<std::string> CommonHelper::TokenizeString | ( | const std::string & | str,
 |  | const char | delimiter = ','
 | ) |  |
static

Tokenizes string by delimiter.

Parameters
[in] | str | String to be tokenized
[in] | delimiter | Delimiter by which string gets tokenized
Returns
Vector of trimmed tokens
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: GeometryConverter Namespace Reference

  • Namespace Members
Functions | Variables
GeometryConverter Namespace Reference

Functions

void | Convert (const SceneryInterface &scenery, OWL::Interfaces::WorldData &worldData)
Converts OpenDrive road network to OSI objects. More...
void | CalculateRoads (const SceneryInterface &scenery, OWL::Interfaces::WorldData &worldData)
void | CalculateSection (OWL::Interfaces::WorldData &worldData, double roadSectionStart, double roadSectionEnd, const RoadInterface *road, const RoadLaneSectionInterface *roadSection)
SampledGeometry | CalculateSectionBetweenRoadMarkChanges (double roadSectionStart, double roadSectionEnd, const RoadInterface *road, const RoadLaneSectionInterface *roadSection)
SampledGeometry | CalculateGeometry (double roadSectionStart, double roadSectionEnd, const RoadInterface *road, const RoadLaneSectionInterface *roadSection, const RoadGeometryInterface *roadGeometry)
double | CalculateGeometryOffsetStart (double roadSectionStart, double roadGeometryStart)
double | CalculateGeometryOffsetEnd (double roadSectionEnd, double roadGeometryStart, double roadGeometryEnd, double roadGeometryLength)
std::vector< BorderPoints > | CalculateJoints (double geometryOffsetStart, double geometryOffsetEnd, const RoadLaneSectionInterface *roadSection, const RoadInterface *road, const RoadGeometryInterface *roadGeometry, double roadGeometryStart, double roadSectionStart)
BorderPoints | CalculateBorderPoints (const RoadLaneSectionInterface *roadSection, const RoadInterface *road, const RoadGeometryInterface *roadGeometry, double geometryOffset, double roadOffset, double roadSectionStart)
void | AddPointsToWorld (OWL::Interfaces::WorldData &worldData, const Joints &joints)
double | CalculateCoordZ (RoadInterface *road, double offset)
double | CalculateSlope (RoadInterface *road, double offset)
double | CalculateLaneWidth (const RoadLaneInterface *roadLane, double sectionOffset)
double | CalculateLaneBorder (const RoadLaneInterface *roadLane, double sectionOffset)
double | CalculateSlopeAtRoadPosition (const RoadElevation *elevation, double position)
double | CalculateWidthAtSectionPosition (const RoadLaneWidth *width, double position)
const RoadElevation * | GetRelevantRoadElevation (double sectionOffset, RoadInterface *road)
const RoadLaneWidth * | GetRelevantRoadLaneWidth (double sectionOffset, const std::list< RoadLaneWidth * > widthsOrBorders)
bool | IsEqual (const double valueA, const double valueB)
void | CalculateIntersections (OWL::Interfaces::WorldData &worldData)
CalculateIntersections calculates any intersections on the scenery's junctions.
RoadPolygons | BuildRoadPolygons (const OWL::Road *const road)
BuildRoadPolygons builds all polygons for the road and pairs them with the road's id. More...
void | CalculateJunctionIntersectionsFromRoadPolygons (const JunctionPolygons &junctionPolygons, OWL::Junction *const junction)
CalculateJunctionIntersectionsFromRoadPolygons calculates intersections for a junction from polygons created from that junction's roads. More...
std::optional< OWL::IntersectionInfo > | CalculateIntersectionInfoForRoadPolygons (const RoadPolygons &polygons, const RoadPolygons &polygonsToCompare, const OWL::Junction *const junction)
CalculateIntersectionInfoForRoadPolygons calculates intersection information between two sets of RoadPolygons. More...
IntersectingConnectionRank | GetRelativeRank (const std::string &roadId, const std::string &intersectingRoadId, const OWL::Junction *const junction)
GetRelativeRank Gets the relative rank of an intersecting road with respect to a road. More...

Variables

std::function< LaneGeometryPolygon(const OWL::Primitive::LaneGeometryElement *const)> CreateBuildPolygonFromLaneGeometryFunction (const std::string &roadId, const OWL::Id laneId)
CreateBuildPolygonFromLaneGeometryFunction creates a function that builds LaneGeometryPolygons from a LaneGeometryElement for a specific roadId and laneId. More...

Detailed Description

Functions for the convertion of the road geometries in a section. First, the roads, lane sections and lanes have to be converted using SceneryConverter, which then provides the mappings from OpenDrive to OSI of those elements.

Function Documentation

void GeometryConverter::Convert | ( | const SceneryInterface & | scenery,
 |  | OWL::Interfaces::WorldData & | worldData
 | ) |  |

Converts OpenDrive road network to OSI objects.

This function reads from the imported OpenDrive scenery and adds all roads, sections, lanes and junctions to the WorldData by calling the respective functions of the WorldData.

Parameters
scenery | Scenery with the OpenDrive roads
worldData | worldData that is built by this function
void GeometryConverter::CalculateRoads | ( | const SceneryInterface & | scenery,
 |  | OWL::Interfaces::WorldData & | worldData
 | ) |  |

Converts the Roads section in OpenDrive to OSI

Parameters
scenery | Scenery with the OpenDrive roads
worldData | worldData that is built by this function
void GeometryConverter::CalculateSection | ( | OWL::Interfaces::WorldData & | worldData,
 |  | double | roadSectionStart,
 |  | double | roadSectionEnd,
 |  | const RoadInterface * | road,
 |  | const RoadLaneSectionInterface * | roadSection
 | ) |  |

Converts a single section of an OpenDrive road to OSI

Parameters
worldData | worldData that is built by this function
roadSectionStart | start s coordinate of the section
roadSectionEnd | end s coordinate of the section
road | road the section is part of
roadSection | section to convert
SampledGeometry GeometryConverter::CalculateSectionBetweenRoadMarkChanges | ( | double | roadSectionStart,
 |  | double | roadSectionEnd,
 |  | const RoadInterface * | road,
 |  | const RoadLaneSectionInterface * | roadSection
 | ) |  |

Samples the lane boundary points of the lanes of one section between two consecutive changes in the RoadMarks of the lanes with a defined maximum lateral error

Parameters
roadSectionStart | start s coordinate of the section / first RoadMark change
roadSectionEnd | end s coordinate of the section / second RoadMark change
road | road the section is part of
roadSection | section to convert
Returns
sampled boundary points
SampledGeometry GeometryConverter::CalculateGeometry | ( | double | roadSectionStart,
 |  | double | roadSectionEnd,
 |  | const RoadInterface * | road,
 |  | const RoadLaneSectionInterface * | roadSection,
 |  | const RoadGeometryInterface * | roadGeometry
 | ) |  |

Samples the lane boundary points of one geometry for one section with a defined maximum lateral error

Parameters
roadSectionStart | start s coordinate of the section / first RoadMark change
roadSectionEnd | end s coordinate of the section / second RoadMark change
road | road the section is part of
roadSection | section to convert
roadGeometry | geometry to sample
Returns
sampled boundary points
double GeometryConverter::CalculateGeometryOffsetStart | ( | double | roadSectionStart,
 |  | double | roadGeometryStart
 | ) |  |

Calculates the start s offset of a geometry inside a section

Parameters
roadSectionStart | start s coordinate of the section
roadGeometryStart | start s coordinate of the geometry
Returns
start s offset of the geometry in the section
double GeometryConverter::CalculateGeometryOffsetEnd | ( | double | roadSectionEnd,
 |  | double | roadGeometryStart,
 |  | double | roadGeometryEnd,
 |  | double | roadGeometryLength
 | ) |  |

Calculates the end s offset of a geometry inside a section

Parameters
roadSectionEnd | end s coordinate of the section
roadGeometryStart | start s coordinate of the geometry
roadGeometryEnd | end s coordinate of the section
roadGeometryLength | length of the geometry
Returns
end s offset of the geometry in the section
std::vector<BorderPoints> GeometryConverter::CalculateJoints | ( | double | geometryOffsetStart,
 |  | double | geometryOffsetEnd,
 |  | const RoadLaneSectionInterface * | roadSection,
 |  | const RoadInterface * | road,
 |  | const RoadGeometryInterface * | roadGeometry,
 |  | double | roadGeometryStart,
 |  | double | roadSectionStart
 | ) |  |

Calculates the lane boundary points with a high sampling rate

Parameters
geometryOffsetStart | start s offset of the geometry in the section
geometryOffsetEnd | end s offset of the geometry in the section
roadSection | section to convert
road | road the section is part of
roadGeometry | geometry to sample
roadGeometryStart | start s coordinate of the geometry
roadSectionStart | start s coordinate of the section
Returns
sampled lane boundary points
BorderPoints GeometryConverter::CalculateBorderPoints | ( | const RoadLaneSectionInterface * | roadSection,
 |  | const RoadInterface * | road,
 |  | const RoadGeometryInterface * | roadGeometry,
 |  | double | geometryOffset,
 |  | double | roadOffset,
 |  | double | roadSectionStart
 | ) |  |

Calculates the lane boundary points of a single joint (i.e. at one s coordinate)

Parameters
roadSection | section to convert
road | road the section is part of
roadGeometry | geometry to sample
geometryOffset | s offset on the geometry
roadOffset | s coordinate on the road
roadSectionStart | start s coordinate of the section
Returns
sampled lane boundary points
void GeometryConverter::AddPointsToWorld | ( | OWL::Interfaces::WorldData & | worldData,
 |  | const Joints & | joints
 | ) |  |

Adds the sampled joints to the world

Parameters
worldData | worldData that is built by this function
joints | sampled joints
double GeometryConverter::CalculateCoordZ | ( | RoadInterface * | road,
 |  | double | offset
 | ) |  |

Calculates height coordinate according to OpenDrive elevation profiles.

Parameters
[in] | road | OpenDrive road data structure
[in] | offset | Absolute offset on reference line within road
Returns
height coordinate
double GeometryConverter::CalculateSlope | ( | RoadInterface * | road,
 |  | double | offset
 | ) |  |

Calculates slope according to OpenDrive elevation profiles.

Parameters
[in] | road | OpenDrive road data structure
[in] | offset | Absolute offset on reference line within road
Returns
slope
double GeometryConverter::CalculateLaneWidth | ( | const RoadLaneInterface * | roadLane,
 |  | double | sectionOffset
 | ) |  |

Calculates the width of the provided lane.

Parameters
[in] | roadLane | OpenDrive road lane (for width information)
[in] | sectionOffset | Offset within the OpenDrive section
Returns
Lane width, 0.0 if no width was specified
double GeometryConverter::CalculateLaneBorder | ( | const RoadLaneInterface * | roadLane,
 |  | double | sectionOffset
 | ) |  |

Calculates the border of the provided lane.

Parameters
[in] | roadLane | OpenDrive road lane (for width information)
[in] | sectionOffset | Offset within the OpenDrive section
Returns
Lane border, 0.0 if no width was specified
double GeometryConverter::CalculateSlopeAtRoadPosition | ( | const RoadElevation * | elevation,
 |  | double | position
 | ) |  |

Calculates the slope of a lane at a given position

Parameters
[in] | elevation | elevation input data (has to match given position)
[in] | position | position w.r.t. start of section
Returns
width at given position
double GeometryConverter::CalculateWidthAtSectionPosition | ( | const RoadLaneWidth * | width,
 |  | double | position
 | ) |  |

Calculates the width of a lane at a given position

Parameters
[in] | width | width input data (has to match given position)
[in] | position | position w.r.t. start of section
Returns
width at given position
const RoadElevation* GeometryConverter::GetRelevantRoadElevation | ( | double | sectionOffset,
 |  | RoadInterface * | road
 | ) |  |

Get the RoadElevation which is relevant for the given position

Parameters
[in] | sectionOffset | position w.r.t. start of section
[in] | roadLane | the RoadLaneInterface input data
Returns
relevant RoadElevation
const RoadLaneWidth* GeometryConverter::GetRelevantRoadLaneWidth | ( | double | sectionOffset,
 |  | const std::list< RoadLaneWidth * > | widthsOrBorders
 | ) |  |

Get the RoadLaneWidth which is relevant for the given position

Parameters
[in] | sectionOffset | position w.r.t. start of section
[in] | widthsOrBorders | container with all potential RoadLaneWidth pointers
Returns
relevant RoadLaneWidth
bool GeometryConverter::IsEqual | ( | const double | valueA,
 |  | const double | valueB
 | ) |  |

Tests if the provided values' difference is smaller than EPS

Parameters
[in] | valueA | input value A
[in] | valueB | input value B
Returns
true, if valueA and valueB are (approximately) the same, false otherwise
RoadPolygons GeometryConverter::BuildRoadPolygons ( const OWL::Road *const road )

BuildRoadPolygons builds all polygons for the road and pairs them with the road's id.

Parameters
[in] road the road for which polygons will be built
Returns
the pair of the road id to the collection of polygons for the road
void GeometryConverter::CalculateJunctionIntersectionsFromRoadPolygons | ( | const JunctionPolygons & | junctionPolygons,
 |  | OWL::Junction *const | junction
 | ) |  |

CalculateJunctionIntersectionsFromRoadPolygons calculates intersections for a junction from polygons created from that junction's roads.

Parameters
[in] | junctionPolygons | the map of road ids to LaneGeometryPolygons for the junction
[out] | junction | the junction to which intersection information should be added, given that any interesections are found
std::optional<OWL::IntersectionInfo> GeometryConverter::CalculateIntersectionInfoForRoadPolygons | ( | const RoadPolygons & | polygons,
 |  | const RoadPolygons & | polygonsToCompare,
 |  | const OWL::Junction *const | junction
 | ) |  |

CalculateIntersectionInfoForRoadPolygons calculates intersection information between two sets of RoadPolygons.

Parameters
[in] | polygons | the base road's set of polygons
[in] | polygonsToCompare | the potentially-intersecting road's set of polygons
[in] | junction | the junction for which the intersection info is calculated
Returns
the IntersectionInfo between the two sets of RoadPolygons, if an intersection exists between them
IntersectingConnectionRank GeometryConverter::GetRelativeRank | ( | const std::string & | roadId,
 |  | const std::string & | intersectingRoadId,
 |  | const OWL::Junction *const | junction
 | ) |  |

GetRelativeRank Gets the relative rank of an intersecting road with respect to a road.

Parameters
[in] | roadId | the roadId of the road whose relative rank to get
[in] | intersectingRoadId | the roadId of the intersecting road
[in] | junction | the junction in which the roads intersect
Returns
the relative rank of the intersecting road

Variable Documentation

std::function<LaneGeometryPolygon (const OWL::Primitive::LaneGeometryElement* const)> CreateBuildPolygonFromLaneGeometryFunction(const std::string &roadId, const OWL::Id laneId)

CreateBuildPolygonFromLaneGeometryFunction creates a function that builds LaneGeometryPolygons from a LaneGeometryElement for a specific roadId and laneId.

Parameters
[in] | roadId | the roadId for which the created function will build LaneGeometryPolygons
[in] | laneId | the laneId for which the created function will build LaneGeometryPolygons
Returns
a function that creates LaneGeometryPolygons from LaneGeometryElements for the lane at laneId on the road at roadId
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Sampler Namespace Reference

  • Namespace Members
Sampler Namespace Reference

Sampler samples probabilities and SpawnPoint and World parameters. More...

Detailed Description

Sampler samples probabilities and SpawnPoint and World parameters.

This class contains all stochastics functions of the SpawnPoint and the world It samples parameters according to probabilities specified in the configurations

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • AgentAdapter
  • LaneObjParameters
AgentAdapter::LaneObjParameters Member List

This is the complete list of members for AgentAdapter::LaneObjParameters, including all inherited members.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

AgentBuildInformation Member List

This is the complete list of members for AgentBuildInformation, including all inherited members.

AgentBuildInformation()=default | AgentBuildInformation | private
make(SampledProfiles &sampledProfiles, DynamicParameters &dynamicParameters, std::shared_ptr< SystemConfigInterface > systemConfigBlueprint, ProfilesInterface *profiles, VehicleModelsInterface *vehicleModels) | AgentBuildInformation | static
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

BorderPoint Member List

This is the complete list of members for BorderPoint, including all inherited members.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

BorderPoints Member List

This is the complete list of members for BorderPoints, including all inherited members.

GetSquaredError(const BorderPoints &begin, const BorderPoints &end) const BorderPoints
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

CollisionAngles Member List

This is the complete list of members for CollisionAngles, including all inherited members.

HCPA | CollisionAngles
HCPAo | CollisionAngles
OCPA | CollisionAngles
OCPAo | CollisionAngles
OYA | CollisionAngles
Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • CollisionManipulator
  • CrashInfo
CollisionManipulator::CrashInfo Member List

This is the complete list of members for CollisionManipulator::CrashInfo, including all inherited members.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

CommandLineArguments Member List

This is the complete list of members for CommandLineArguments, including all inherited members.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

CommandLineOption Member List

This is the complete list of members for CommandLineOption, including all inherited members.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Common
  • Line
Line Member List

This is the complete list of members for Line, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • CommonTrafficSign
  • Entity
Entity Member List

This is the complete list of members for Entity, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ConditionMetaInformation Member List

This is the complete list of members for ConditionMetaInformation, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ConfigurationFiles Member List

This is the complete list of members for ConfigurationFiles, including all inherited members.

configurationDir | ConfigurationFiles
slaveConfigFile | ConfigurationFiles
systemConfigBlueprintFile | ConfigurationFiles
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

DefaultComponents Member List

This is the complete list of members for DefaultComponents, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

DynamicParameters Member List

This is the complete list of members for DynamicParameters, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

FakeLaneManager Member List

This is the complete list of members for FakeLaneManager, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

FrameworkModules Member List

This is the complete list of members for FrameworkModules, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

GeometryInformation Member List

This is the complete list of members for GeometryInformation, including all inherited members.

laneEgo | GeometryInformation
laneLeft | GeometryInformation
laneRight | GeometryInformation
visibilityDistance | GeometryInformation
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

GlobalRoadPosition Member List

This is the complete list of members for GlobalRoadPosition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Importer
  • VehicleModelsImporter
  • TypeHelper
VehicleModelsImporter::TypeHelper< T > Member List

This is the complete list of members for VehicleModelsImporter::TypeHelper< T >, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • Internal
  • ConversionStatus
ConversionStatus Member List

This is the complete list of members for ConversionStatus, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

IntersectingConnection Member List

This is the complete list of members for IntersectingConnection, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Joint Member List

This is the complete list of members for Joint, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

JunctionConnection Member List

This is the complete list of members for JunctionConnection, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

JunctionConnectorPriority Member List

This is the complete list of members for JunctionConnectorPriority, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

LaneGeometryPolygon Member List

This is the complete list of members for LaneGeometryPolygon, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

LaneInformationGeometry Member List

This is the complete list of members for LaneInformationGeometry, including all inherited members.

curvature | LaneInformationGeometry
distanceToEndOfLane | LaneInformationGeometry
exists | LaneInformationGeometry
width | LaneInformationGeometry
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

LaneInformationTrafficRules Member List

This is the complete list of members for LaneInformationTrafficRules, including all inherited members.

trafficSigns LaneInformationTrafficRules
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

LaneJoint Member List

This is the complete list of members for LaneJoint, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • LaneMarking
  • Entity
Entity Member List

This is the complete list of members for Entity, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

LateralDynamicConstants Member List

This is the complete list of members for LateralDynamicConstants, including all inherited members.

gainHeadingError | LateralDynamicConstants
lateralAcceleration | LateralDynamicConstants
zeta | LateralDynamicConstants
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

LongitudinalDistance Member List

This is the complete list of members for LongitudinalDistance, including all inherited members.

referencePoint LongitudinalDistance
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • MultiStream
  • Node
MultiStream< T >::Node Member List

This is the complete list of members for MultiStream< T >::Node, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • IntersectionInfo
IntersectionInfo Member List

This is the complete list of members for IntersectionInfo, including all inherited members.

sOffsets IntersectionInfo
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Lazy
Lazy< T > Member List

This is the complete list of members for Lazy< T >, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • AbsAcceleration
AbsAcceleration Member List

This is the complete list of members for AbsAcceleration, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • AbsCoordinate
AbsCoordinate Member List

This is the complete list of members for AbsCoordinate, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • AbsOrientation
AbsOrientation Member List

This is the complete list of members for AbsOrientation, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • AbsOrientationRate
AbsOrientationRate Member List

This is the complete list of members for AbsOrientationRate, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • AbsPosition
AbsPosition Member List

This is the complete list of members for AbsPosition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • AbsVelocity
AbsVelocity Member List

This is the complete list of members for AbsVelocity, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • Dimension
Dimension Member List

This is the complete list of members for Dimension, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • LaneAcceleration
LaneAcceleration Member List

This is the complete list of members for LaneAcceleration, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • LaneGeometryElement
LaneGeometryElement Member List

This is the complete list of members for LaneGeometryElement, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • LaneGeometryElement
  • Joints
LaneGeometryElement::Joints Member List

This is the complete list of members for LaneGeometryElement::Joints, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • LaneGeometryJoint
LaneGeometryJoint Member List

This is the complete list of members for LaneGeometryJoint, including all inherited members.

curvature | LaneGeometryJoint
sHdg | LaneGeometryJoint
sOffset | LaneGeometryJoint
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • LaneGeometryJoint
  • Points
LaneGeometryJoint::Points Member List

This is the complete list of members for LaneGeometryJoint::Points, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • LaneOrientation
LaneOrientation Member List

This is the complete list of members for LaneOrientation, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • LaneOrientationRate
LaneOrientationRate Member List

This is the complete list of members for LaneOrientationRate, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • LanePosition
LanePosition Member List

This is the complete list of members for LanePosition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • LaneVelocity
LaneVelocity Member List

This is the complete list of members for LaneVelocity, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • RoadAcceleration
RoadAcceleration Member List

This is the complete list of members for RoadAcceleration, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • RoadCoordinate
RoadCoordinate Member List

This is the complete list of members for RoadCoordinate, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • RoadOrientationRate
RoadOrientationRate Member List

This is the complete list of members for RoadOrientationRate, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • OWL
  • Primitive
  • RoadVelocity
RoadVelocity Member List

This is the complete list of members for RoadVelocity, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ObjectInformation Member List

This is the complete list of members for ObjectInformation, including all inherited members.

absoluteVelocity | ObjectInformation
acceleration | ObjectInformation
exist | ObjectInformation
heading | ObjectInformation
height | ObjectInformation
id | ObjectInformation
isStatic | ObjectInformation
length | ObjectInformation
relativeLateralDistance | ObjectInformation
relativeLongitudinalDistance | ObjectInformation
width | ObjectInformation
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ObjectPosition Member List

This is the complete list of members for ObjectPosition, including all inherited members.

mainLocatePoint | ObjectPosition
touchedRoads | ObjectPosition
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ObjectView Member List

This is the complete list of members for ObjectView, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

ObservationInstance Member List

This is the complete list of members for ObservationInstance, including all inherited members.

libraryName | ObservationInstance
parameters | ObservationInstance
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

OutputAttributes Member List

This is the complete list of members for OutputAttributes, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

OutputTags Member List

This is the complete list of members for OutputTags, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

OwnVehicleInformation Member List

This is the complete list of members for OwnVehicleInformation, including all inherited members.

absoluteVelocity | OwnVehicleInformation
acceleration | OwnVehicleInformation
collision | OwnVehicleInformation
distanceToLaneBoundaryLeft | OwnVehicleInformation
distanceToLaneBoundaryRight | OwnVehicleInformation
heading | OwnVehicleInformation
lateralPosition | OwnVehicleInformation
steeringWheelAngle | OwnVehicleInformation
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Position Member List

This is the complete list of members for Position, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

PostCrashVelocity Member List

This is the complete list of members for PostCrashVelocity, including all inherited members.

isActive | PostCrashVelocity
velocityAbsolute | PostCrashVelocity
velocityDirection | PostCrashVelocity
yawVelocity | PostCrashVelocity
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • RelativeWorldView
  • Junction
Junction Member List

This is the complete list of members for Junction, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • RelativeWorldView
  • Lane
Lane Member List

This is the complete list of members for Lane, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • RelativeWorldView
  • LanesInterval
LanesInterval Member List

This is the complete list of members for LanesInterval, including all inherited members.

Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

Remainder Member List

This is the complete list of members for Remainder, including all inherited members.

Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RoadInterval Member List

This is the complete list of members for RoadInterval, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RoadNetworkElement Member List

This is the complete list of members for RoadNetworkElement, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RoadPosition Member List

This is the complete list of members for RoadPosition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

RouteElement Member List

This is the complete list of members for RouteElement, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

STCoordinates Member List

This is the complete list of members for STCoordinates, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SampledGeometry Member List

This is the complete list of members for SampledGeometry, including all inherited members.

Combine(SampledGeometry &other) | SampledGeometry
endHeading | SampledGeometry
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SampledProfiles Member List

This is the complete list of members for SampledProfiles, including all inherited members.

make(std::string agentProfileName, StochasticsInterface &stochastics, ProfilesInterface *profiles) SampledProfiles static
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SensorDetectionResults Member List

This is the complete list of members for SensorDetectionResults, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SimulationMaster
  • Configuration
  • MasterConfig
MasterConfig Member List

This is the complete list of members for MasterConfig, including all inherited members.

CheckOrDefault(int logLevel) MasterConfig inlineprivatestatic
Generated on Sun Sep 20 2020 11:49:47 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SpawnPointDefinitions
  • AgentProfileLaneMaps
AgentProfileLaneMaps Member List

This is the complete list of members for AgentProfileLaneMaps, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SpawnPointDefinitions
  • SpawningAgentProfile
SpawningAgentProfile Member List

This is the complete list of members for SpawningAgentProfile, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SpawnPointDependencies Member List

This is the complete list of members for SpawnPointDependencies, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SpawnPointLibraryInfo Member List

This is the complete list of members for SpawnPointLibraryInfo, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SpawnPointPreRunCommonDefinitions
  • PreRunSpawnerParameters
PreRunSpawnerParameters Member List

This is the complete list of members for PreRunSpawnerParameters, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SpawnPointPreRunCommonDefinitions
  • SpawnArea
SpawnArea Member List

This is the complete list of members for SpawnArea, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SpawnPointRuntimeCommonDefinitions
  • SpawnDetails
SpawnDetails Member List

This is the complete list of members for SpawnDetails, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SpawnPointRuntimeCommonDefinitions
  • SpawnPointRuntimeCommonParameters
SpawnPointRuntimeCommonParameters Member List

This is the complete list of members for SpawnPointRuntimeCommonParameters, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • SpawnPointRuntimeCommonDefinitions
  • SpawnPosition
SpawnPosition Member List

This is the complete list of members for SpawnPosition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

StreamInfo< T > Member List

This is the complete list of members for StreamInfo< T >, including all inherited members.

EndS() const | StreamInfo< T > | inline
GetStreamPosition(double elementPosition) const | StreamInfo< T > | inline
inStreamDirection | StreamInfo< T > |
sOffset | StreamInfo< T > |
StartS() const | StreamInfo< T > | inline
StreamInfo()=default | StreamInfo< T > |
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

SurroundingObjects Member List

This is the complete list of members for SurroundingObjects, including all inherited members.

objectFront | SurroundingObjects
objectFrontLeft | SurroundingObjects
objectFrontRight | SurroundingObjects
objectRear | SurroundingObjects
objectRearLeft | SurroundingObjects
objectRearRight | SurroundingObjects
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

TrafficRuleInformation Member List

This is the complete list of members for TrafficRuleInformation, including all inherited members.

laneEgo | TrafficRuleInformation
laneLeft | TrafficRuleInformation
laneMarkingsLeft | TrafficRuleInformation
laneMarkingsLeftOfLeftLane | TrafficRuleInformation
laneMarkingsRight | TrafficRuleInformation
laneMarkingsRightOfRightLane | TrafficRuleInformation
laneRight | TrafficRuleInformation
Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • TtcCalculations
  • TtcParameters
TtcCalculations::TtcParameters Member List

This is the complete list of members for TtcCalculations::TtcParameters, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

VehicleModelParameters Member List

This is the complete list of members for VehicleModelParameters, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • World
  • Localization
  • LaneIntersection
LaneIntersection< T > Member List

This is the complete list of members for LaneIntersection< T >, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • World
  • Localization
  • LocalizationElement
LocalizationElement Member List

This is the complete list of members for LocalizationElement, including all inherited members.

referenceScale | LocalizationElement
referenceVector | LocalizationElement
search_box | LocalizationElement
tAxisCenter | LocalizationElement
Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • World
  • Localization
  • LocatedObject
LocatedObject Member List

This is the complete list of members for LocatedObject, including all inherited members.

Generated on Sun Sep 20 2020 11:49:48 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

WorldParameterOSI Member List

This is the complete list of members for WorldParameterOSI, including all inherited members.

Generated on Sun Sep 20 2020 11:49:45 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

cmplx Member List

This is the complete list of members for cmplx, including all inherited members.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

cmplxl Member List

This is the complete list of members for cmplxl, including all inherited members.

Generated on Sun Sep 20 2020 11:49:43 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

fmi1_csv_input_t Member List

This is the complete list of members for fmi1_csv_input_t, including all inherited members.

discreteIndex | fmi1_csv_input_t
eventIndex1 | fmi1_csv_input_t
eventIndex2 | fmi1_csv_input_t
fmu | fmi1_csv_input_t
interpContinuousData | fmi1_csv_input_t
interpData | fmi1_csv_input_t
interpIndex1 | fmi1_csv_input_t
interpIndex2 | fmi1_csv_input_t
interpLambda | fmi1_csv_input_t
interpTime | fmi1_csv_input_t
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

fmi2_csv_input_t Member List

This is the complete list of members for fmi2_csv_input_t, including all inherited members.

discreteIndex | fmi2_csv_input_t
eventIndex1 | fmi2_csv_input_t
eventIndex2 | fmi2_csv_input_t
fmu | fmi2_csv_input_t
interpData | fmi2_csv_input_t
interpIndex1 | fmi2_csv_input_t
interpIndex2 | fmi2_csv_input_t
interpLambda | fmi2_csv_input_t
interpTime | fmi2_csv_input_t
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

fmu_check_data_t Member List

This is the complete list of members for fmu_check_data_t, including all inherited members.

callbacks | fmu_check_data_t
context | fmu_check_data_t
CSV_separator | fmu_check_data_t
do_mangle_var_names | fmu_check_data_t
do_output_all_vars | fmu_check_data_t
do_simulate_flg | fmu_check_data_t
do_test_cs | fmu_check_data_t
do_test_me | fmu_check_data_t
fmu1 | fmu_check_data_t
fmu1_kind | fmu_check_data_t
fmu2 | fmu_check_data_t
fmu2_kind | fmu_check_data_t
FMUPath | fmu_check_data_t
inputFileName | fmu_check_data_t
log_file | fmu_check_data_t
log_file_name | fmu_check_data_t
maxOutputPts | fmu_check_data_t
maxOutputPtsSetByUser | fmu_check_data_t
modelIdentifierFMI1 | fmu_check_data_t
nextOutputStep | fmu_check_data_t
nextOutputTime | fmu_check_data_t
num_errors | fmu_check_data_t
num_fatal | fmu_check_data_t
num_fmu_messages | fmu_check_data_t
num_warnings | fmu_check_data_t
out_file | fmu_check_data_t
output_file_name | fmu_check_data_t
print_all_event_vars | fmu_check_data_t
printed_instance_name_error_flg | fmu_check_data_t
require_cs | fmu_check_data_t
require_me | fmu_check_data_t
slave_initialized | fmu_check_data_t
stepSize | fmu_check_data_t
stepSizeSetByUser | fmu_check_data_t
stopTime | fmu_check_data_t
temp_dir | fmu_check_data_t
tmpPath | fmu_check_data_t
unzipPathBuf | fmu_check_data_t
version | fmu_check_data_t
vl | fmu_check_data_t
vl2 | fmu_check_data_t
write_log_files | fmu_check_data_t
write_output_files | fmu_check_data_t
Generated on Sun Sep 20 2020 11:49:44 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • AbsoluteTargetSpeed
AbsoluteTargetSpeed Member List

This is the complete list of members for AbsoluteTargetSpeed, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • ActorInformation
ActorInformation Member List

This is the complete list of members for ActorInformation, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • ConditionalEventDetectorInformation
ConditionalEventDetectorInformation Member List

This is the complete list of members for ConditionalEventDetectorInformation, including all inherited members.

numberOfExecutions ConditionalEventDetectorInformation
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • CustomCommandAction
CustomCommandAction Member List

This is the complete list of members for CustomCommandAction, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • EntityAction
EntityAction Member List

This is the complete list of members for EntityAction, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • FollowTrajectoryAction
FollowTrajectoryAction Member List

This is the complete list of members for FollowTrajectoryAction, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • LaneChangeAction
LaneChangeAction Member List

This is the complete list of members for LaneChangeAction, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • LaneChangeParameter
LaneChangeParameter Member List

This is the complete list of members for LaneChangeParameter, including all inherited members.

dynamicsTarget | LaneChangeParameter
dynamicsType | LaneChangeParameter
object | LaneChangeParameter
value | LaneChangeParameter
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • LanePosition
LanePosition Member List

This is the complete list of members for LanePosition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • ManipulatorInformation
ManipulatorInformation Member List

This is the complete list of members for ManipulatorInformation, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • Orientation
Orientation Member List

This is the complete list of members for Orientation, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • ParameterizedAttribute
ParameterizedAttribute< T > Member List

This is the complete list of members for ParameterizedAttribute< T >, including all inherited members.

defaultValue | ParameterizedAttribute< T >
ParameterizedAttribute()=default | ParameterizedAttribute< T >
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • RelativeLanePosition
RelativeLanePosition Member List

This is the complete list of members for RelativeLanePosition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • RelativeTargetSpeed
RelativeTargetSpeed Member List

This is the complete list of members for RelativeTargetSpeed, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • RoadPosition
RoadPosition Member List

This is the complete list of members for RoadPosition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • SpeedAction
SpeedAction Member List

This is the complete list of members for SpeedAction, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • StochasticAttribute
StochasticAttribute Member List

This is the complete list of members for StochasticAttribute, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • Trajectory
Trajectory Member List

This is the complete list of members for Trajectory, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • TrajectoryPoint
TrajectoryPoint Member List

This is the complete list of members for TrajectoryPoint, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • TransitionDynamics
TransitionDynamics Member List

This is the complete list of members for TransitionDynamics, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • VisibilityAction
VisibilityAction Member List

This is the complete list of members for VisibilityAction, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • WorldPosition
WorldPosition Member List

This is the complete list of members for WorldPosition, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • transformation
  • LaneChange
LaneChange Member List

This is the complete list of members for LaneChange, including all inherited members.

Transform(const SimulationSlave::EventNetworkInterface *eventNetwork, WorldInterface *world, AgentInterface *agent, int cycleTime) TransformerBase< LaneChange, TrajectorySignal, openpass::events::LaneChangeEvent > inlinestatic
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • transformation
  • SpeedAction
SpeedAction Member List

This is the complete list of members for SpeedAction, including all inherited members.

Transform(const SimulationSlave::EventNetworkInterface *eventNetwork, WorldInterface *world, AgentInterface *agent, int cycleTime) TransformerBase< SpeedAction, SpeedActionSignal, openpass::events::SpeedActionEvent > inlinestatic
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openScenario
  • transformation
  • Trajectory
Trajectory Member List

This is the complete list of members for Trajectory, including all inherited members.

Transform(const SimulationSlave::EventNetworkInterface *eventNetwork, WorldInterface *world, AgentInterface *agent, int cycleTime) TransformerBase< Trajectory, TrajectorySignal, openpass::events::TrajectoryEvent > inlinestatic
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • common
  • RuntimeInformation
RuntimeInformation Member List

This is the complete list of members for RuntimeInformation, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • common
  • RuntimeInformation
  • Directories
RuntimeInformation::Directories Member List

This is the complete list of members for RuntimeInformation::Directories, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • common
  • RuntimeInformation
  • Versions
RuntimeInformation::Versions Member List

This is the complete list of members for RuntimeInformation::Versions, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • common
  • Version
Version Member List

This is the complete list of members for Version, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • parameter
  • internal
  • VisitParameterElement
VisitParameterElement Member List

This is the complete list of members for VisitParameterElement, including all inherited members.

operator()(const ParameterValue &value) | VisitParameterElement | inline
operator()(const ParameterListLevel2 &list) | VisitParameterElement | inline
Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • sensors
  • Parameter
Parameter Member List

This is the complete list of members for Parameter, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • sensors
  • Position
Position Member List

This is the complete list of members for Position, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • sensors
  • Profile
Profile Member List

This is the complete list of members for Profile, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • type
  • AffectedEntities
AffectedEntities Member List

This is the complete list of members for AffectedEntities, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • type
  • NamedType
NamedType< T, Tag > Member List

This is the complete list of members for NamedType< T, Tag >, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1


openPASS - Developer Documentation: Member List

  • openpass
  • type
  • TriggeringEntities
TriggeringEntities Member List

This is the complete list of members for TriggeringEntities, including all inherited members.

Generated on Sun Sep 20 2020 11:49:46 for openPASS - Developer Documentation by doxygen 1.8.9.1